Prise en main : créer une réunion Notez système avec InfoPath et SharePoint

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

En apportant des modifications mineures à un exemple de modèle de formulaire dans Microsoft Office InfoPath 2007 et en créant une bibliothèque de documents sur un site Windows SharePoint Services 3.0, vous pouvez implémenter un système pour prendre des notes de réunion de manière cohérente, les envoyer à chacun des participants, puis les stocker dans une bibliothèque de documents SharePoint Services. Cet article explique comment créer ce système.

Dans cet article

Présentation

Avant de commencer

Créer le système de notes de réunion

Mettre à jour le modèle de formulaire

Vue d’ensemble

InfoPath intègre un exemple de modèle de formulaire spécialement conçu pour collecter des données de réunion communes, telles que les ordres du jour, les participants, les points de discussion et les points d’action. L’exemple de modèle de formulaire est configuré de sorte que vous puissiez envoyer à chaque participant une copie électronique d’un formulaire basé sur le modèle.

L’exemple de modèle de formulaire est configuré pour aider le preneur de notes à collecter les données enregistrées au cours d’une réunion. Les contrôles sont organisés en sections logiques pour aider le preneur de notes à collecter les données appropriées et lui éviter de collecter celles qui peuvent être générées automatiquement. En outre, comme les contrôles sont disposés de manière cohérente, le preneur de notes n’a plus qu’à renseigner les champs vides lors de la réunion. Ainsi, il n’est plus obligé de mémoriser les types de données à collecter.

Bien qu’il soit possible de modifier le modèle de formulaire pour collecter des données supplémentaires, il est conseillé d’utiliser le modèle de formulaire existant en lui apportant une modification qui vous permettra d’enregistrer les formulaires remplis dans une bibliothèque de documents SharePoint. Vous pourrez ensuite tester l’efficacité de votre système et utiliser les résultats obtenus pour modifier le modèle de formulaire en fonction des attentes de votre groupe.

Vous pouvez utiliser cet exemple de modèle de formulaire dans votre système en commençant par le publier dans une nouvelle bibliothèque de documents sur un site SharePoint. Vous allez créer une bibliothèque de documents dans le cadre du processus de publication. Lorsque vous aurez publié le modèle de formulaire et créé la bibliothèque de documents, vous modifierez le modèle de formulaire afin d’enregistrer un formulaire rempli dans la nouvelle bibliothèque de documents et d’envoyer une copie du formulaire aux participants.

Pour utiliser ce système, le preneur de notes accède à la bibliothèque de documents et crée un formulaire basé sur ce modèle. Au cours d’une réunion, il entre les données dans les contrôles appropriés du formulaire. À la fin de la réunion, il envoie le formulaire à la bibliothèque de documents. Une copie est alors transmise à tous les participants. Ceux qui n’ont pas participé à la réunion peuvent lire les notes en accédant à la bibliothèque de documents et en ouvrant le formulaire dans InfoPath.

L’exemple de modèle de formulaire contient les sections suivantes :

Modèle de formulaire de l’ordre du jour constitué de quatre sections

1. titre section contient des contrôles pour le nom, objet, emplacement et dates de réunion et les heures. Le contrôle de Date affiche automatiquement la date de que création de l'écran. Par défaut, le contrôle de zone de texte Heure de fin affiche automatiquement une heure qui est une heure le temps entré dans le contrôle de zone de texte de L'heure de début au plus tard.

2. participants extensible section contient des contrôles pour les noms et adresses de messagerie de chaque participant à la réunion. Lorsque la personne qui la passe note envoie le formulaire complété, chaque participant répertorié dans cette section reçoit une copie du formulaire rempli.

3. élément de discussion section extensible contient des contrôles de chaque présentateur (un participant qui mène une discussion) et des notes sur chaque élément de discussion. Le contrôle de zone de liste déroulante présentateur affiche les noms de la section participants.

4. élément action section extensible contient des contrôles pour le nom, l'attribution et échéance date pour chaque élément action. Le contrôle de zone de liste déroulante affectation affiche les noms de la section participants.

Si vous utilisez InfoPath pour la première fois, lisez les articles suivants pour comprendre les concepts importants et car ils définissent mieux les termes que vous allez rencontrer à chaque étape. Ces liens figurent également dans les sections appropriées de cet article pour vous aider à exécuter une tâche donnée.

Haut de la page

Avant de commencer

Vous avez besoin de l'URL Uniform Resource Locator () et, au minimum des autorisations pour la collection de sites du site SharePoint que vous utiliserez pour ce système de création. Si vous pouvez créer une bibliothèque de documents dans votre collection de sites, vous avez les autorisations requises. Les personnes qui ont besoin de voir les notes de réunion, vous avez besoin lira autorisations pour votre collection de sites. Si vous devez disposer des autorisations pour créer une bibliothèque de documents ou définir des autorisations de lecture pour votre collection de sites pour vos utilisateurs de formulaire, contactez l'administrateur de votre collection de sites.

Vous devrez également disposer d’au moins une adresse de messagerie à laquelle envoyer une copie du formulaire rempli, ainsi que d’un client de messagerie électronique, tel que Microsoft Office Outlook 2007, capable de recevoir des messages pour que vous puissiez tester le modèle de formulaire.

Dans cet article, nous supposons que vous utilisez une configuration SharePoint Services par défaut.

Haut de la page

Créer le système de notes de réunion

Pour créer ce système, procédez comme suit :

  1. Ouvrez et enregistrez l’exemple de modèle de formulaire.

  2. Publiez-le afin de créer une bibliothèque de documents pour les notes de réunion.

  3. Modifiez-le pour enregistrer les formulaires remplis dans la nouvelle bibliothèque de documents, puis envoyez une copie à chaque participant.

  4. Publiez le modèle de formulaire modifié.

  5. Testez ce dernier ainsi que la nouvelle bibliothèque de documents en créant puis en envoyant les formulaires de test basés sur ce modèle de formulaire.

Ouvrir et enregistrer le modèle de formulaire

  1. Dans le menu Fichier, cliquez sur Créer un modèle de formulaire.

  2. Sous Ouvrir un modèle de formulaire, cliquez sur Personnaliser un exemple.

  3. Sous Personnaliser un exemple, double-cliquez sur Exemple - Ordre du jour.

  4. Dans le menu fichier, cliquez sur Enregistrer.

  5. Si InfoPath affiche un message concernant la publication du modèle de formulaire, cliquez sur OK.

  6. Dans la boîte de dialogue Enregistrer sous, spécifiez l’emplacement où vous voulez enregistrer le modèle de formulaire.

  7. Dans la zone nom de fichier, tapez un nom pour le modèle de formulaire.

  8. Dans la liste Type de fichier, cliquez sur Modèle de formulaire InfoPath, puis sur Enregistrer.

Publier le modèle de formulaire

Vous allez créer une bibliothèque de documents dans le cadre du processus de publication.

Pour plus d'informations sur la publication d'un modèle de formulaire, voir l'article Introduction à la publication d'un modèle de formulaire.

  1. Dans le menu Fichier, cliquez sur Publier.

  2. Sur la première page de l’Assistant Publication, cliquez sur Vers un serveur SharePoint avec ou sans InfoPath Forms Services, puis cliquez sur Suivant.

  3. Sur la page suivante de l’Assistant, dans la zone Indiquez l’emplacement de votre site SharePoint ou InfoPath Forms Services, entrez l’URL de votre collection de sites sur le site SharePoint, puis cliquez sur Suivant. Par exemple, pour utiliser une collection de sites avec l’URL http://www.adventureworks.com/EmployésUniquement, tapez http://www.adventureworks.com/EmployésUniquement dans la zone.

  4. Sur la page suivante, cliquez sur Bibliothèque de documents, puis sur Suivant.

  5. Sur la page suivante, cliquez sur Créer une nouvelle bibliothèque de documents, puis cliquez sur Suivant.

  6. Sur la page suivante, tapez un nom et une description pour la nouvelle bibliothèque de documents, puis cliquez sur Suivant.

  7. Acceptez les colonnes suggérées, puis cliquez sur Suivant.

  8. Sur la dernière page de l’Assistant, vérifiez que les informations s’affichent correctement, puis cliquez sur Publier.

  9. Cliquez sur Fermer.

    Vous recevrez une confirmation à la dernière page de l’Assistant si la publication de votre modèle de formulaire a réussi.

Notez l’URL de la nouvelle bibliothèque de documents dont vous aurez besoin ultérieurement. L’URL de la nouvelle bibliothèque de documents sera celle de la collection de sites, suivie d’une barre oblique (/), puis du nom de la bibliothèque de documents. Par exemple, si vous avez créé une bibliothèque de documents intitulée NotesRéunion dans la collection de sites avec l’URL http://www.adventureworks.com/EmployésUniquement, l’URL de la nouvelle bibliothèque de documents sera http://www.adventureworks.com/EmployésUniquement/NotesRéunion.

Modifier le modèle de formulaire

Cette section indique comment effectuer les opérations suivantes :

  • Ajouter une nouvelle connexion de données d’envoi qui enregistre le formulaire rempli dans la nouvelle bibliothèque de documents.

    Pour en savoir que plus sur Envoyer les connexions de données, voir Présentation des connexions de données.

  • Modifier les options de la connexion de données pour pouvoir enregistrer le formulaire rempli dans la bibliothèque de documents et en envoyer une copie à chaque participant.

  • Configurer le modèle de formulaire pour qu’il ferme le formulaire envoyé.

Pour en savoir plus sur l’envoi d’un formulaire basé sur un modèle de formulaire, voir l’article Introduction à l’envoi de données de formulaire.

Ajouter une nouvelle connexion de données d’envoi

Dans cette section, vous allez créer une connexion de données d’envoi à la nouvelle bibliothèque de documents et configurer la connexion de données pour enregistrer le formulaire sous un nom unique. Le nom du formulaire sera constitué du titre de la réunion et de la date de création du formulaire.

Commencer à créer la connexion de données
  1. Dans le menu Outils, cliquez sur Connexions de données.

  2. Dans la boîte de dialogue Connexions de données, cliquez sur Ajouter.

  3. Dans l'Assistant Connexion de données, cliquez sur Créer une nouvelle connexion, puis sur Envoyer les données et enfin, sur Suivant.

  4. Dans la page suivante de l'Assistant, cliquez dans une bibliothèque de documents sur un site SharePoint et puis cliquez sur suivant. Sélection d’une destination pour les données envoyées dans l’Assistant Connexion de données

  5. Sur la page suivante de l’Assistant, dans la zone Bibliothèque de documents, tapez l’URL de la bibliothèque de documents créée précédemment. Par exemple, pour utiliser une bibliothèque de documents avec l’URL http://www.adventureworks.com/EmployésUniquement/NotesRéunion, tapez http://www.adventureworks.com/EmployésUniquement/NotesRéunion dans la zone Bibliothèque de documents.

    Dans la section suivante, vous allez définir un nom de formulaire unique à partir de cette page de l’Assistant. Ne cliquez pas encore sur Suivant.

Définir un nom de formulaire unique

Le modèle de formulaire enregistre le formulaire dans une bibliothèque de documents sous un nom par défaut. Si vous utilisez ce nom, la nouvelle bibliothèque de documents stockera uniquement un formulaire rempli. Dans cette section, vous allez configurer la connexion de données pour enregistrer les formulaires basés sur ce modèle de formulaire sous un nom constitué du titre et de la date de la réunion. Pour ce faire, vous devez créer une formule qui utilise une fonction XPath.

Pour en savoir plus sur les formules et des fonctions, voir Ajouter une formule à un contrôle.

  1. Cliquez sur Insérer une formule Bouton Formule .

  2. Dans la boîte de dialogue Insérer une formule, cliquez sur Insérer une fonction.

  3. Dans la liste Catégories de la boîte de dialogue Insérer une fonction, cliquez sur Texte.

  4. Dans la liste Fonctions, cliquez sur concat, puis cliquez sur OK.

  5. Dans la zone formule, double-cliquez sur la première instance de double-cliquer pour insérer le champ.

    Double clic pour insérer le premier champ à utiliser dans le nom du formulaire

  6. Dans la boîte de dialogue Sélectionner un champ ou un groupe, ouvrez réunion, cliquez sur TitreRéunion, puis cliquez sur OK.

    Sélection du champ TitreRéunion dans la boîte de dialogue Sélectionner un champ ou un groupe

  7. Dans la zone Formule, cliquez sur la deuxième instance de double-cliquer pour insérer un champ pour la sélectionner (ne double-cliquez pas).

    Double clic pour insérer un tiret dans le nom du formulaire

  8. Tapez un guillemet double ("), un tiret (-) et un autre guillemet double.

    Insertion d’un tiret dans le nom du formulaire

  9. Double-cliquez sur la troisième instance de double-cliquer pour insérer un champ.

    Double clic pour insérer un autre champ à utiliser dans le nom du formulaire

  10. Dans la boîte de dialogue Sélectionner un champ ou un groupe, ouvrez réunion, cliquez sur DateRéunion, puis cliquez sur OK.

    Sélection du champ DateRéunion dans la boîte de dialogue Sélectionner un champ ou un groupe

    La boîte de dialogue Insérer une formule doit ressembler à ce qui suit :

    Formule finale dans la boîte de dialogue Insérer une formule qui crée le nom du formulaire

  11. Pour vérifier la formule pour la syntaxe correcte, dans la boîte de dialogue Insérer une formule, cliquez sur Vérifier la formule.

  12. Si la formule ne contient aucune erreur, cliquez sur OK pour fermer la boîte de dialogue.

Terminer la configuration de la connexion de données
  1. Dans l’Assistant, cliquez sur Suivant.

  2. Dans la page suivante de l'Assistant, dans la zone Entrez un nom pour cette connexion de données, tapez un nom descriptif pour ce soumettre la connexion de données.

  3. Vérifiez l'exactitude des informations de la zone Résumé, puis cliquez sur Terminer.

  4. Cliquez sur Fermer.

  5. Dans le menu fichier, cliquez sur Enregistrer.

Modifier les options d’envoi pour utiliser les deux connexions de données d’envoi

  1. Dans le menu Outils, cliquez sur Options d'envoi.

  2. Dans la boîte de dialogue Options d'envoi, activez la case à cocher Autoriser les utilisateurs à envoyer ce formulaire.

  3. Cliquez sur Effectuer une action personnalisée à l'aide des règles, puis cliquez sur Règles.

  4. Dans la boîte de dialogue Règles pour l'envoi de formulaires, cliquez sur Ajouter.

  5. Cliquez sur Ajouter une action.

  6. Dans la zone Action, cliquez sur Envoyer via une connexion de données.

  7. Dans la liste Connexion de données, cliquez sur la connexion de données à la bibliothèque de documents que vous avez créée précédemment, puis cliquez sur OK.

  8. Cliquez sur Ajouter une action.

  9. Dans la zone Action, cliquez sur Envoyer via une connexion de données.

  10. Dans la liste Connexion de données, cliquez sur Envoi principal, puis sur OK.

    Vous allez utiliser la connexion de données Envoi principal pour envoyer une copie du formulaire à chaque participant.

  11. Dans la zone Nom de la boîte de dialogue Règle, tapez Règles d’envoi pour identifier la règle que vous venez de créer.

  12. Cliquez sur OK à deux reprises.

Configurer le modèle de formulaire pour fermer le formulaire envoyé

  1. Dans la boîte de dialogue Options d’envoi, cliquez sur Avancées.

  2. Dans la liste Après envoi, cliquez sur Fermer le formulaire.

  3. Cliquez sur OK.

  4. Dans le menu fichier, cliquez sur Enregistrer.

Publier le modèle de formulaire

Une fois le modèle de formulaire modifié, publiez-le dans la bibliothèque de documents pour déployer les modifications.

  1. Dans le menu Fichier, cliquez sur Publier.

  2. Sur la première page de l’Assistant Publication, cliquez sur Vers un serveur SharePoint avec ou sans InfoPath Forms Services, puis cliquez sur Suivant.

  3. Sur la page suivante de l’Assistant, dans la zone Indiquez l’emplacement de votre site SharePoint ou InfoPath Forms Services, indiquez l’emplacement de votre bibliothèque de documents dans la collection de sites de votre site SharePoint, puis cliquez sur Suivant.

  4. Sur la page suivante, cliquez sur Bibliothèque de documents, puis sur Suivant.

  5. Sur la page suivante, cliquez sur Mettre à jour le modèle de formulaire dans une bibliothèque de documents existante.

  6. Dans la liste Bibliothèque de documents à mettre à jour, cliquez sur votre bibliothèque de documents, puis sur Suivant.

  7. Cliquez sur Suivant.

  8. Sur la page suivante, vérifiez que les informations s’affichent correctement, puis cliquez sur Publier.

    Vous recevrez une confirmation à la dernière page de l’Assistant si la publication de votre modèle de formulaire a réussi.

Tester le modèle de formulaire et le site

  1. Sur la dernière page de l’Assistant Publication, cliquez sur Ouvrir cette bibliothèque de documents, puis sur Fermer.

  2. Dans la bibliothèque de documents, cliquez sur Nouveau.

  3. Remplissez le formulaire comme si vous preniez des notes à une réunion. Entrez une heure dans le contrôle de zone de texte Heure de début, puis appuyez sur la touche Tab pour passer au contrôle suivant. InfoPath remplit automatiquement le contrôle de zone de texte Heure de fin.

  4. Entrez l’adresse de messagerie d’un participant dans la zone Adresse de messagerie de la section Participant. Pour ajouter des participants et leurs adresses de messagerie, cliquez sur Ajouter participant.

  5. Dans la barre d’outils InfoPath, cliquez sur Envoyer.

  6. Vérifiez que les adresses de messagerie appropriées s’affichent dans la boîte de dialogue.

  7. Cliquez sur Envoyer, puis sur OK pour fermer la boîte de dialogue.

Vos notes de réunion devraient figurer dans la bibliothèque de documents, ainsi que dans le nouveau message électronique envoyé à votre attention.

Maintenant que vous avez testé le système en créant et en envoyant quelques formulaires basés sur ce modèle de formulaire, vous pouvez commencer à utiliser le système pour stocker et distribuer vos notes de réunion.

Haut de la page

Mettre à jour le modèle de formulaire

Lorsque d’autres utilisateurs auront testé votre nouveau système en créant et en enregistrant des notes de réunion, vous pourrez modifier la conception du modèle de formulaire en fonction de leurs commentaires. Pour modifier le modèle de formulaire, procédez comme suit :

  1. Dans la bibliothèque de documents, ouvrez le modèle de formulaire, modifiez-le à votre convenance, puis enregistrez les modifications.

  2. Validez vos modifications dans la bibliothèque de documents en publiant le modèle de formulaire.

Ouvrir le modèle de formulaire à partir de la bibliothèque de documents

  1. Ouvrez la bibliothèque de documents.

  2. Cliquez sur Paramètres, puis sur les paramètres Bibliothèque de formulaires.

  3. Sous Paramètres généraux, cliquez sur paramètres avancés.

  4. Sous la zone URL du modèle de la section Modèle de document, cliquez sur Modifier le modèle.

  5. Si InfoPath affiche un message concernant la publication du modèle de formulaire, cliquez sur Oui.

Enregistrez le modèle de formulaire que vous venez de modifier avant de le publier.

Publier le modèle de formulaire

Une fois le modèle de formulaire modifié, publiez-le dans la bibliothèque de documents.

  1. Dans le menu Fichier, cliquez sur Publier.

  2. Sur la première page de l’Assistant Publication, cliquez sur Vers un serveur SharePoint avec ou sans InfoPath Forms Services, puis cliquez sur Suivant.

  3. Sur la page suivante de l’Assistant, dans la zone Indiquez l’emplacement de votre site SharePoint ou InfoPath Forms Services, indiquez l’emplacement de votre bibliothèque de documents dans la collection de sites de votre site SharePoint, puis cliquez sur Suivant.

  4. Sur la page suivante, cliquez sur Bibliothèque de documents, puis sur Suivant.

  5. Sur la page suivante, cliquez sur Mettre à jour le modèle de formulaire dans une bibliothèque de documents existante.

  6. Dans la liste Bibliothèque de documents à mettre à jour, cliquez sur votre bibliothèque de documents, puis sur Suivant.

  7. Cliquez sur Suivant.

  8. Sur la page suivante, vérifiez que les informations s’affichent correctement, puis cliquez sur Publier.

  9. Cliquez sur Fermer.

    Vous recevrez une confirmation à la dernière page de l’Assistant si la publication de votre modèle de formulaire a réussi.

Haut de la page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×