Présentation des tables

Important    Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Les tables sont des objets essentiels dans une base de données, car ils conservent toutes les informations ou données. Par exemple, une base de données d’une entreprise peut contenir une table Contacts qui stocke les noms des fournisseurs, leurs adresses de messagerie et numéros de téléphone. Cet article propose une vue d’ensemble des tables Access. Avant de créer des tables, vous devez étudier vos besoins et déterminer toutes les tables dont vous pourriez avoir besoin. Pour une introduction à la planification et à la conception d’une base de données, voir Concepts de base sur la conception d’une base de données.

Contenu de cet article

Vue d’ensemble

Ajouter une table à une base de données de bureau

Tables dans Access web apps

Enregistrer une table

Présentation

Une base de données relationnelle comme Access comporte généralement plusieurs tables liées. Dans une base de données bien conçue, chaque table stocke les données d’un sujet spécifique, tel que les employés ou les produits. Une table contient des enregistrements (lignes) et des champs (colonnes). Les champs ont des types de données différents, tels que du texte, des nombres, des dates et des liens hypertexte.

Table Clients dans Access montrant la disposition d’enregistrements et de champs

  1. Un enregistrement : contient des données spécifiques, telles que des informations sur un employé en particulier ou d'un produit.

  2. Un champ : contient des données sur l'un des aspects de l'objet table, telles que le prénom ou adresse de messagerie.

  3. Une valeur de champ : chaque enregistrement possède une valeur de champ. Par exemple, Contoso, Ltd. ou someone@example.com.

Propriétés de table et de champ

Les caractéristiques et le comportement des tables et des champs sont définis et contrôlés par les propriétés. Les propriétés d’une table sont définies dans la feuille de propriétés de la table. Par exemple, vous pouvez configurer la propriété Affichage par défaut d’une table pour spécifier le mode d’affichage par défaut de la table. Une propriété de champ définit un aspect du comportement du champ. Vous pouvez également définir les propriétés de champ en mode Création à l’aide du volet Propriétés du champ. Chaque champ comporte un type de données qui définit le type d’information stockée dans le champ. Par exemple, plusieurs lignes de texte ou de devises sont des types de données.

Relations entre les tables

Bien que chaque table d’une base de données stocke des données concernant un sujet spécifique, les tables d’une base de données relationnelle comme Access stockent des données concernant des sujets associés. Par exemple, une base de données peut contenir :

  • une table de clients qui répertorie les clients de votre société et leurs adresses ;

  • une table de produits qui répertorie les produits vendus, avec les prix et les photos de chaque article ;

  • une table de commandes qui permet d’effectuer le suivi des commandes des clients.

Pour connecter les données stockées dans différentes tables, vous devez créer des relations. Une relation est une connexion logique entre deux tables ayant un champ commun.

Clés

Les champs qui font partie d’une relation de table portent le nom de « clé ». Une clé se compose généralement d’un seul champ, mais cela n’est pas toujours le cas. Il existe deux types de clés :

  • Clé primaire : une table ne peut posséder qu’une seule clé primaire. Une clé primaire consiste en un ou plusieurs champs qui identifient de manière unique chaque enregistrement stocké dans la table. Access fournit un numéro d’identification unique, appelé ID, qui sert de clé primaire. Pour plus d’informations, voir ajout ou modification de la clé primaire d’une table.

  • Clé étrangère : une table peut avoir une ou plusieurs clés étrangères. Une clé étrangère contient des valeurs qui correspondent à des valeurs dans la clé primaire d’une autre table. Par exemple, vous pouvez avoir une table Commandes dans laquelle chaque commande a un ID de client correspondant à un enregistrement dans la table Clients. Le champ d’ID de client est une clé étrangère de la table Commandes.

La correspondance des valeurs entre les champs clés forme la base d’une relation de table. On utilise une relation de table pour combiner des données de tables liées. Par exemple, supposez que vous avez une table Clients et une table Commandes. Dans votre table Clients, chaque enregistrement est identifié par le champ de clé primaire, ID.

Pour associer chaque commande à un client, vous ajoutez un champ de clé étrangère à la table Commandes qui correspond au champ ID de la table Clients, puis vous créez une relation entre les deux clés. Lorsque vous ajoutez un enregistrement à la table Commandes, vous utilisez une valeur d’ID de client issue de la table Clients. Lorsque vous souhaitez afficher des informations concernant la commande d’un client, vous utilisez la relation pour identifier les données de la table Clients qui correspondent aux différents enregistrements de la table Commandes.

Relation de table Access affichée dans la fenêtre Relations
  1. Une clé primaire est identifiée par l'icône en regard du nom du champ de clé.

  2. Une clé étrangère, notez l'absence de l'icône de clé.

Avantages offerts par l’utilisation de relations

Le fait de conserver les données séparées dans des tables liées offre les avantages suivants :

  • Cohérence    Chaque élément de données n’étant enregistré qu’une seule fois, dans une seule table, il existe moins de risque d’ambiguïté ou d’incohérence. Par exemple, vous stockez le nom d’un client une seule fois, dans une table qui concerne les clients, plutôt qu’à plusieurs reprises (avec le risque d’incohérence qui en découle) dans une table qui contient des données relatives aux commandes.

  • Efficacité    L’enregistrement des données dans un seul emplacement permet d’utiliser moins d’espace disque. En outre, les tables plus compactes offrent en général un traitement des données plus rapide que les tables volumineuses. Pour finir, si vous n’utilisez pas des tables distinctes pour des sujets distincts, vous introduirez des valeurs Null (absence de données) et une redondance dans vos tables, ce qui peut nuire aux performances et utiliser de l’espace inutilement.

  • Facilité de compréhension    La structure d’une base de données est plus simple à comprendre si les sujets sont séparés correctement dans des tables.

Haut de la page

Ajouter une table à une base de données du bureau de l'accès

Créez une table si vous avez une nouvelle source de données qui ne convient à aucune de vos tables existantes. Plusieurs options vous permettent d’ajouter une table à votre base de données Access, par exemple en créant une nouvelle base de données, en insérant une table dans une base de données existante, ou en important ou établissant un lien à une table d’une autre source de données (telle qu’un classeur Microsoft Excel, un document Microsoft Word, un fichier texte, un service web ou une autre base de données). Lorsque vous créez une base de données vide, une nouvelle table vide est insérée automatiquement. Vous pouvez ensuite entrer des données dans cette table pour commencer à définir vos champs.

Pour plus d’informations sur l’ajout d’un champ à une base de données de bureau, voir l’article Ajouter un champ à une table.

Créer une table dans une nouvelle base de données de bureau

  1. Sous Fichier, cliquez sur Nouveau > Base de données du Bureau vide.

  2. Dans la zone Nom de fichier, tapez un nom de fichier pour la nouvelle base de données.

  3. Pour enregistrer la base de données à un autre emplacement, cliquez sur l’icône de dossier.

  4. Cliquez sur Créer.

La nouvelle base de données s’ouvre avec une nouvelle table appelée Table1. Renommez la table en fonction du type de données qu’elle stocke.

Créer une table dans une base de données existante

  1. Cliquez sur Fichier >Ouvrir, et cliquez sur la base de données si elle est répertoriée sous Récent. Dans le cas contraire, sélectionnez l’une des options de navigation pour localiser la base de données.

  2. Sous Créer, cliquez sur Table.

Une nouvelle table est ajoutée et s’ouvre en mode Feuille de données.

Haut de la page

Données externes

Vous pouvez établir un lien à diverses sources de données externes, telles que d’autres bases de données, des fichiers texte et des classeurs Excel. Lorsque vous établissez un lien à des données externes, Access peut utiliser le lien comme s’il s’agissait d’une table. En fonction de la source de données externe et de la façon dont vous créez le lien, vous pouvez modifier les données dans la table liée et créer des relations qui impliquent la table liée. En revanche, vous ne pouvez pas modifier la structure des données externes au moyen d’un lien.

Importer ou créer un lien pour créer une table

Vous pouvez créer une table en important des données stockées ailleurs ou en établissant un lien à ces données. Vous pouvez importer ou lier les données d’une feuille de calcul Excel, d’une liste Windows SharePoint Services, d’un fichier XML, d’une autre base de données Access, d’un dossier Microsoft Outlook et de bien d’autres éléments.

Lorsque vous importez des données, vous créez une copie de ces données dans une nouvelle table de la base de données active. Les modifications apportées ultérieurement aux données sources n’auront aucun effet sur les données importées et les modifications apportées aux données importées n’affectent pas les données sources. Après vous être connecté à une source de données et avoir importé ses données, vous pouvez utiliser les données importées sans vous connecter à la source. Vous pouvez modifier la structure d’une table importée.

Lorsque vous établissez un lien à des données, vous créez une table liée dans la base de données active qui représente un lien actif aux informations existantes stockées autre part. Lorsque vous modifiez des données dans une table liée, vous les modifiez dans la source. Chaque fois que des données changent dans la source, ce changement est affiché dans la table liée. Vous devez être en mesure de vous connecter à la source de données chaque fois que vous utilisez une table liée.

Remarque   Vous ne pouvez pas modifier les données d’une feuille de calcul Excel au moyen d’une table liée. Une solution de contournement consiste à importer les données sources dans une base de données Access, puis à établir un lien à la base de données à partir d’Excel. Pour plus d’informations sur la liaison à Access à partir d’Excel, effectuez une recherche dans l’aide d’Excel.

Créer une table en important des données externes ou en établissant un lien à ces données

  1. Sous l’onglet Données externes, dans le groupe Importer et lier, cliquez sur l’une des sources de données disponibles.

  2. Suivez les instructions fournies par les boîtes de dialogue qui s’affichent à chaque étape.

    Access crée la nouvelle table et l’affiche dans le volet de navigation.

Conseil   Vous pouvez également importer ou attacher une liste SharePoint. Pour plus d’informations, voir Importer ou attacher une liste SharePoint.

Haut de la page

Utiliser un site SharePoint pour créer une table

Vous pouvez créer une table dans votre base de données qui importe ou établit un lien à une liste SharePoint. Vous pouvez également créer une liste SharePoint au moyen d’un modèle prédéfini.

  1. Sous Créer, cliquez sur Listes SharePoint, puis effectuez une des opérations suivantes :

  2. Créer une liste SharePoint basée sur un modèle

    1. Cliquez sur Contacts, Tâches, Problèmes ou Événements.

    2. Dans la boîte de dialogue Créer une nouvelle liste, tapez l’URL du site SharePoint sur lequel vous souhaitez créer la liste.

    3. Entrez un nom pour la nouvelle liste et sa description dans les zones de spécifier un nom pour la nouvelle liste et la Description.

    4. Pour ouvrir la table liée après sa création, activez la case à cocher Ouvrir la liste une fois l’opération terminée (activée par défaut).

  3. Créer une nouvelle liste personnalisée

    1. Cliquez sur personnalisé. Dans la boîte de dialogue Créer une nouvelle liste, tapez l'URL du site SharePoint où vous souhaitez créer la liste.

    2. Entrez un nom et une description pour la nouvelle liste dans les zones Spécifiezle nom de la nouvelle liste et Description.

    3. Pour ouvrir la table liée après sa création, activez la case à cocher Ouvrir la liste une fois l’opération terminée (activée par défaut).

  4. Importer des données dans une liste existante

    1. Cliquez sur Liste SharePoint existante.

    2. Dans la boîte de dialogue Données externes, tapez l’URL du site SharePoint qui contient les données à importer.

    3. Cliquez sur Importer les données sources dans une nouvelle table de la base de données active, puis sur Suivant.

    4. Activez la case à cocher en regard de chaque liste SharePoint que vous souhaitez importer.

  5. Établir un lien à une liste existante

    1. Cliquez sur Liste SharePoint existante.

    2. Dans la boîte de dialogue Données externes - Site SharePoint, tapez l’URL du site SharePoint qui contient la liste vers laquelle vous souhaitez établir un lien.

    3. Cliquez sur Lier à la source de données en créant une table attachée, puis sur Suivant.

    4. Activez la case à cocher en regard de chaque liste SharePoint vers laquelle vous souhaitez établir un lien.

Haut de la page

Utiliser un service web pour créer une table

Vous pouvez créer une table dans votre base de données qui établit une connexion à des données sur un site web qui fournit une interface de service web.

Remarque   Les tables de service web sont en lecture seule.

  1. Sous l’onglet Données externes, dans le groupe Importer et lier, cliquez sur Plus, puis sur Services de données.

  2. Si la connexion à utiliser a déjà été installée, passez à l’étape 5. Sinon, continuez à l’étape suivante.

  3. Cliquez sur Installer une nouvelle connexion.

  4. Sélectionnez le fichier de connexion à utiliser, puis cliquez sur OK.

  5. Dans la boîte de dialogue Créer une liaison aux données de service web, développez la connexion à utiliser.

  6. Sélectionnez la table à lier. Access affiche les champs sur le côté droit de la boîte de dialogue.

  7. Si vous le souhaitez, tapez un nom pour la table liée dans la zone Spécifiez le nom de la liaison. Access utilisera ce nom pour la table liée dans le volet de navigation.

  8. Cliquez sur OK. Access crée la table liée.

Haut de la page

Définir les propriétés de table dans une base de données de bureau

Vous pouvez définir des propriétés qui s’appliquent à une table entière ou à des enregistrements entiers.

  1. Sélectionnez la table dont vous souhaitez définir les propriétés.

  2. Sous l’onglet Accueil, dans le groupe Affichages, cliquez sur Affichage, puis sur Mode Création.

  3. Sous l’onglet Créer, dans le groupe Afficher/Masquer, cliquez sur Feuille de propriétés.

    Groupe Afficher/Masquer sous l’onglet Création dans Access.

  4. Sur la feuille de propriétés, cliquez sur l’onglet Général.

  5. Cliquez sur la zone située à gauche de la propriété à définir, puis entrez un paramètre pour la propriété. Pour voir une liste des propriétés de la table, cliquez sur Propriétés de table disponibles.

  6. Appuyez sur Ctrl+S pour enregistrer vos modifications.

    Utilisez cette propriété de table

    Pour

    Afficher les vues sur un site SharePoint

    Spécifier si les affichages basés sur la table peuvent être affichés sur un site SharePoint.

    Remarque   Les effets de ce paramètre dépendent du paramètre de la propriété de base de données Afficher les vues sur un site SharePoint.

    Pour plus d’informations, voir la section Voir aussi.

    Sous-feuille données étendue

    Développer toutes les sous-feuilles de données lorsque vous ouvrez la table.

    Hauteur sous-feuille données

    Effectuez l’une des actions suivantes :

    • Si vous souhaitez que la fenêtre de sous-feuille de données soit étendue de façon à afficher toutes les lignes, affectez la valeur 0" à cette propriété.

    • Si vous souhaitez contrôler la hauteur de la sous-feuille de données, entrez la hauteur souhaitée en pouces.

    Orientation

    Définir l’orientation de l’affichage en fonction du sens de votre écriture, de gauche à droite ou de droite à gauche.

    Description

    Fournir une description de la table. Cette description sera affichée dans les info-bulles pour la table.

    Affichage par défaut

    Définir Feuille de données, Tableau croisé dynamique ou Graphique croisé dynamique comme affichage par défaut lorsque vous ouvrez la table.

    Valide si

    Entrer une expression qui doit être vraie lorsque vous ajoutez ou modifiez un enregistrement.

    Message si erreur

    Entrer un message qui s’affiche lorsqu’un enregistrement n’est pas conforme à l’expression dans la propriété Valide si.

    Filtre

    Définir des critères pour afficher uniquement certaines lignes en mode Feuille de données.

    Tri par

    Sélectionner un ou plusieurs champs pour spécifier l’ordre de tri par défaut des lignes en mode Feuille de données.

    Nom sous-feuille données

    Spécifier si une sous-feuille doit s’afficher en mode Feuille de données et, si oui, la table ou la requête qui doit fournir les lignes dans la sous-feuille.

    Champs fils

    Répertorier les champs dans la table ou la requête qui sont utilisés pour la sous-feuille de données et qui correspondent à la propriété Champs pères spécifiée pour la table.

    Champs pères

    Répertorier les champs dans la table qui correspondent à la propriété Champs fils spécifiée pour la table.

    Filtrer au chargement

    Appliquer automatiquement les critères de filtre dans la propriété Filtrer (en spécifiant la valeur Oui) lorsque la table est ouverte en mode Feuille de données.

    Trier au chargement

    Appliquer automatiquement les critères de tri dans la propriété Tri par (en spécifiant la valeur Oui) lorsque la table est ouverte en mode Feuille de données.

    Conseil   Pour disposer de davantage d’espace pour la saisie ou la modification d’un paramètre dans la zone de propriété, appuyez sur Maj+F2 pour afficher la zone Zoom. Si vous affectez la propriété Valide si à une expression et que vous souhaitez obtenir de l’aide, cliquez sur Bouton Générateur en regard de la zone de propriété Valide si pour afficher le Générateur d’expression.

Haut de la page

Ajouter un champ à une table dans une base de données du bureau de l'accès

Vous stockez chaque donnée dont vous souhaitez assurer le suivi dans un champ. Par exemple, dans une table de contacts, vous créez des champs pour le Nom de famille, le Prénom, le Numéro de téléphone et l’Adresse. Dans une table de produits, vous créez des champs pour le Nom du produit, l’ID de produit et le Prix.

Avant de créer des champs, essayez de séparer les données sous leur plus petite forme. Il est beaucoup plus simple de combiner ultérieurement des données que de les séparer. Par exemple, au lieu d’un champ Nom, créez des champs Nom de famille et Prénom. Par la suite, il sera très facile de rechercher ou trier par Prénom, Nom de famille ou les deux. Si vous prévoyez d’exécuter un état, un tri, une recherche ou un calcul sur un élément de données, placez cet élément dans son propre champ. Pour plus d’informations sur la création d’une base de données et la création de champs, voir les liens dans la section Voir aussi.

Après avoir créé un champ, vous pouvez également définir des propriétés de champ afin de contrôler son apparence et son comportement.

Vous pouvez créer un champ dans Access en entrant des données dans une nouvelle colonne en mode Feuille de données. Lorsque vous créez un champ de cette manière, Access affecte automatiquement un type de données au champ, en fonction de la valeur que vous entrez. Si aucun autre type de données n’est impliqué par votre saisie, Access sélectionne Texte comme type de données, mais vous pouvez modifier le type de données.

Ajouter un champ en entrant des données

Lorsque vous créez une table ou ouvrez une table existante en mode Feuille de données, vous pouvez ajouter un champ à la table en tapant des données dans la colonne Ajouter un nouveau champ de la feuille de données.

Feuille de données dans Access avec la colonne Ajouter un nouveau champ

1. Entrer des données dans la colonne vierge Ajouter un nouveau champ.

Pour ajouter un nouveau champ :

  1. Créez ou ouvrez une table en mode Feuille de données.

  2. Dans la colonne Ajouter un nouveau champ, entrez le nom du champ à créer. Utilisez un nom descriptif afin de faciliter son identification.

  3. Entrez des données dans le nouveau champ.

Haut de la page

Définir les propriétés d’un champ

Après avoir créé un champ, vous pouvez définir des propriétés de champ afin de contrôler son apparence et son comportement.

En définissant des propriétés de champ, vous pouvez par exemple :

  • contrôler l’apparence des données dans un champ ;

  • aider à prévenir la saisie de données incorrectes dans un champ ;

  • spécifier des valeurs par défaut pour un champ ;

  • aider à accélérer les opérations de recherche et de tri sur un champ.

Vous pouvez définir une partie des propriétés de champ disponibles pendant que vous travaillez en mode Feuille de données. En revanche, pour avoir accès à la liste complète des propriétés de champ et définir toutes les propriétés de champ, vous devez utiliser le mode Création.

Définir des propriétés de champ en mode Feuille de données

Vous pouvez renommer un champ, modifier son type de données, modifier sa propriété Format et modifier certaines de ses autres propriétés pendant que vous travaillez en mode Feuille de données.

  • Pour ouvrir une table en mode Feuille de données :    dans le volet de navigation, cliquez avec le bouton droit sur la table, puis cliquez sur Mode Feuille de données dans le menu contextuel.

  • Pour renommer un champ :    Lorsque vous ajoutez un champ en entrant des données dans le mode feuille de données, Access affecte automatiquement un nom générique pour le champ. Access attribue le nom Champ1 pour le premier nouveau champ, Champ2 pour le deuxième champ et ainsi de suite. Par défaut, un nom de champ est utilisé comme étiquette partout où le champ est affiché, par exemple un en-tête de colonne sur une feuille de données. Renommer des champs afin qu'ils aient des noms plus descriptifs, vous aide à les rendre plus faciles à utiliser lorsque vous permet d'afficher ou de modifiez des enregistrements.

  • Cliquez avec le bouton droit sur l’en-tête du champ à renommer (par exemple, Champ1).

  • Dans le menu contextuel, cliquez sur Renommer la colonne.

  • Entrez le nouveau nom dans l’en-tête du champ.

Les noms de champs peuvent compter au maximum 64 caractères (lettres ou nombres), y compris les espaces.

Modifier le type de données d’un champ

Lorsque vous créez un champ en entrant des données en mode Feuille de données, Access examine ces données afin de déterminer le type de données approprié pour le champ. Par exemple, si vous entrez 1/1/2006, Access reconnaît qu’il s’agit d’une date et il affecte le type de données Date/heure au champ. Si Access n’est pas en mesure de déterminer le type de données de manière sûre, le type de données Texte est utilisé par défaut.

Le type de données du champ détermine les autres propriétés de champ que vous pouvez définir. Par exemple, vous pouvez définir la propriété Ajouter uniquement seulement pour un champ dont le type de données est Lien hypertexte ou Mémo.

Il peut arriver que vous souhaitiez modifier manuellement le type de données d’un champ. Par exemple, supposez que vous avez des numéros de salles qui ressemblent à des dates, tels que 10/2001. Si vous entrez 10/2001 dans un nouveau champ en mode Feuille de données, la fonctionnalité de détection automatique de type de données sélectionne le type de données Date/heure pour le champ. Les numéros de salles étant des étiquettes, et non des dates, ils doivent utiliser le type de données Texte. Pour modifier le type de données d’un champ, appliquez la procédure suivante :

  1. Cliquez sur l’onglet Feuille de données.

  2. Dans la liste Type de données, dans le groupe Type de données et mise en forme, sélectionnez le type de données souhaité.

    Image du ruban Access, groupe Type de données et mise en forme

Modifier le format d’un champ

En plus de déterminer le type de données d’un nouveau champ, Access peut définir la propriété Format en fonction de ce que vous avez tapé. Par exemple, si vous entrez 10:50 a.m., Access affecte le type de données Date/heure et affecte à la propriété Format la valeur Heure, réduit. Pour modifier manuellement la propriété Format d’un champ, procédez comme suit :

  1. Dans le ruban, cliquez sur l’onglet Feuille de données.

  2. Dans la liste Format, dans le groupe Type de données et mise en forme, entrez le format souhaité.

    Remarque   La liste Format peut ne pas être disponible pour certains champs (par exemple les champs Texte) ; tout dépend du type de données du champ.

Définir d’autres propriétés de champ

  1. En mode Feuille de données, cliquez sur le champ dont vous souhaitez définir la propriété.

  2. Sous l’onglet Feuille de données, dans le groupe Type de données et mise en forme, sélectionnez les propriétés souhaitées.

    Image du ruban Access, groupe Type de données et mise en forme

Haut de la page

Définir les propriétés d’un champ

Vous pouvez définir une propriété de champ en ouvrant la table en mode Création.

  • Pour ouvrir une table en mode Création   : dans le volet de Navigation, cliquez sur la table et dans le menu contextuel, cliquez sur Mode Création.

  • Pour modifier un type de données   : recherchez le nom du champ pour lequel vous souhaitez définir le type de données et cliquez sur le champ de Type de données, puis choisissez un type de données à partir de la liste.

  • Pour définir d'autres propriétés de champ   : dans la grille de création de table, sélectionnez le champ pour lequel vous souhaitez définir les propriétés. Dans le volet de Propriétés du champ, entrez les paramètres que vous souhaitez pour chaque propriété. Enregistrez vos modifications, appuyez sur la touche CTRL+S.to.

    Remarque   Les propriétés que vous pouvez définir dépendent du type de données du champ. définir.

Haut de la page

Tables dans Access web apps

Le client d'accès offre des concepteurs pour créer et modifier des tables qui seront stockées sur SQL Server. Informations nécessaires à Access pour créer et tenir à jour une table et les propriétés de mise en forme et des informations de recherche sont stockés dans une table système (Access.ColumnProperties) dans la base de données de l'utilisateur. Pour plus d'informations, consultez Création d'une application Access.

Haut de la page

Enregistrer une table

Une fois que vous créez ou modifiez une table, dans une base de données de bureau, vous devez enregistrer sa conception. Lorsque vous enregistrez une table pour la première fois, donnez-lui un nom qui décrit les données qu'il contient. Vous pouvez utiliser jusqu'à 64 caractères alphanumériques, espaces compris. Par exemple, vous pouvez nommer une table clients, stock de pièces ou produits.

Access vous donne une grande souplesse lorsqu'il s'agit d'affectation de noms des tables dans des applications web ; Toutefois, il y a certaines restrictions en tenir compte. Les crochets ([]), espace, entraînant le signe égal (=) ou un caractère non imprimable comme un chariot à gauche du nom d'une table peut être jusqu'à 64 caractères de longs, peuvent inclure toute combinaison de lettres, des chiffres, des espaces et des caractères spéciaux à l'exception d'un point (.), point d'exclamation (!), retourner. Le nom ne doit pas contenir les caractères suivants:' / \: ; * ? "' < > | # < onglet > {} % ~ &.

Conseil   Vous devez statuer sur une convention d'affectation de noms pour les objets dans votre base de données et utilisez de façon cohérente.

  1. Cliquez sur Enregistrer dans la barre d'outils Accès rapide ou appuyez sur CTRL + S.

  2. Si vous enregistrez la table pour la première fois, tapez un nom pour la table, puis cliquez sur OK.

Haut de la page

Remarque   Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

S’applique à : Access 2013, Access 2016 Developer, Access 2016 Preview, Access 2010



Ces informations vous ont-elles été utiles ?

Oui Non

Comment pouvons-nous nous améliorer ?

255 caractères restants

Afin de protéger votre vie privée, n’indiquez aucune information de contact dans vos commentaires. Lisez notre déclaration de confidentialité.

Nous vous remercions pour vos commentaires.

Ressources de support

Changer la langue