Présentation des états

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Lorsque vous utilisez une base de données, vous utiliserez rapports pour afficher, mettre en forme et synthétiser les données. Par exemple, vous pouvez créer un rapport de type de liste pour afficher les numéros de téléphone pour tous vos contacts, ou un rapport de synthèse à totaliser les ventes de votre société dans différentes régions et les périodes.

Cet article fournit une vue d'ensemble des rapports dans Microsoft Access 2010 et présente les fonctionnalités de rapport nouveaux ou modifiés. Cet article explique également comment créer un rapport, comment trier, grouper et synthétiser les données et comment imprimer un état.

Vous trouverez qu'il est beaucoup plus facile de créer des rapports pertinents si votre base de données a une structure de table bien conçue et les relations. Pour une introduction à la planification et la conception d'une base de données, voir l'article Concepts de base de création de base de données.

Contenu de cet article

Présentation

Quelles sont les nouveautés

Créer un rapport

Appliquer un regroupement, un tri ou ajouter des totaux

Mettez en surbrillance les valeurs à l'aide de la mise en forme conditionnelle

Obtenir un aspect professionnel avec des thèmes

Ajouter des images

Afficher l’aperçu d’un état et l’imprimer

Présentation

Un rapport est un objet de base de données que vous utilisez pour afficher et synthétiser les données. Rapports permettent de distribuer ou archiver des instantanés de vos données, soit en étant imprimée, convertis en fichiers PDF ou XPS ou exportées vers d'autres formats de fichier.

État sur les employés en mode Aperçu avant impression

Les rapports peuvent fournir des détails sur les enregistrements individuels, résumés au sein de nombreux enregistrements ou les deux. Vous pouvez également utiliser des états Access pour créer des étiquettes de publipostage ou d'autres fins.

Il est possible de créer des rapports « indépendants » qui ne pas affichent les données, mais aux fins de cet article, nous allons supposer qu'un rapport est lié à une source de données telle qu'une table ou requête.

Rapports de client et rapports Web

Access 2010 offre une nouvelle fonctionnalité qui vous permet de créer un « base de données Web » en publiant une base de données Access sur un serveur SharePoint qui est en cours d'exécution Access Services. Lorsque vous créez une base de données Web, accéder aux rapports sont rendus dans le navigateur à l'aide de SQL Server Reporting Services. Cette conversion place certaines limitations sur les fonctionnalités que vous pouvez utiliser dans les rapports que vous souhaitez afficher dans le navigateur. Toutefois, si vous ne craignez pas le rendu du rapport dans le navigateur, vous pouvez utiliser l'ensemble des fonctionnalités fournies par le Concepteur de rapports Access.

Sections d’un état

Dans Access, la conception d'un rapport est divisée en sections. Dans une base de données client, vous pouvez afficher votre rapport en mode Création pour afficher ces sections. Dans mise en page mode, les sections ne sont pas comme évidentes, mais ils sont toujours disponibles et pouvant être sélectionnés à l'aide de la liste déroulante dans le groupe sélection sous l'onglet Format. Pour créer des États utiles, vous devez comprendre le fonctionne de chaque section. Par exemple, la section dans laquelle vous choisissez de placer un contrôle calculé détermine comment Access calcule les résultats. La liste suivante est un résumé des types de section et leur utilisation :

  • En-tête d'état    Cette section est imprimée une seule fois, au début du rapport. Utiliser l'en-tête d'état pour plus d'informations qui apparaissent normalement dans une page de garde, comme un logo, un titre ou une date. Lorsque vous placez un contrôle calculé qui utilise la fonction d'agrégation Somme dans l'en-tête d'état, la somme calculée concerne l'intégralité du rapport. L'en-tête d'état est imprimé avant l'en-tête de page.

  • En-tête de page    Cette section est imprimée en haut de chaque page. Par exemple, utilisez un en-tête de page pour répéter le titre du rapport sur chaque page.

  • En-tête de groupe    Cette section est imprimée au début de chaque nouveau groupe d'enregistrements. Utilisez l'en-tête de groupe pour imprimer le nom du groupe. Par exemple, dans un état groupé par produit, utilisez l'en-tête de groupe pour imprimer le nom du produit. Lorsque vous placez un contrôle calculé qui utilise la fonction d'agrégation Somme dans l'en-tête de groupe, la somme est pour le groupe actuel. Vous pouvez avoir plusieurs sections d'en-tête de groupe dans un rapport, selon le nombre de niveaux de regroupement que vous avez ajouté. Pour plus d'informations sur la création des en-têtes de groupe et des pieds de page, voir la section Ajouter le regroupement, le tri ou des totaux.

  • Détail    Cette section est imprimée une seule fois pour chaque ligne de la source d'enregistrement. Il s'agit de l'endroit où vous placez les contrôles qui constituent le corps principal du rapport.

  • Pied de groupe    Cette section est imprimée à la fin de chaque groupe d'enregistrements. Utilisez un pied de groupe pour imprimer les informations de synthèse pour un groupe. Vous pouvez avoir plusieurs sections de pied de page de groupe dans un rapport, selon le nombre de niveaux de regroupement que vous avez ajouté.

  • Pied de page    Cette section est imprimée à la fin de chaque page. Utilisez un pied de page pour les numéros de page d'impression ou des informations spécifiques pour chaque page.

  • Pied d'état    Cette section est imprimée une seule fois, à la fin du rapport. Utiliser le pied d'état pour imprimer rapport totaux ou d'autres informations de synthèse pour l'intégralité du rapport.

Remarque : En mode Création, le pied d'état s'affiche sous le pied de page. Toutefois, dans tous les autres affichages (affichage en mode, par exemple, ou lorsque l'état est imprimé ou Aperçu avant impression), le pied d'état apparaît au-dessus de pied de page, juste après le dernier groupe pied de page ou de détail ligne sur la dernière page.

Haut du document

Quelles sont les nouveautés

Création d'un état dans Access 2010 est un processus très similaire à la création d'un rapport dans Access 2007. Toutefois, dans Access 2010, il existe plusieurs nouvelles fonctionnalités relatives aux rapports :

  • Partagé des bibliothèques d'images    Dans Access 2010, vous pouvez désormais joindre une image à une base de données et ensuite utiliser l'image à plusieurs objets. Mise à jour de l'image unique met à jour à l'endroit où il est utilisé sur la base de données entière.

  • Thèmes Office    Dans Access 2010, vous pouvez désormais utiliser les thèmes Office Microsoft standard pour appliquer des professionnels jeux de polices et les couleurs à l'ensemble de vos formulaires et états Access à la fois.

  • Mise en forme conditionnelle plus importants    Access 2010 inclut plus de puissants outils pour mettre en surbrillance des données dans un état. Vous pouvez ajouter jusqu'à 50 règles de mise en forme conditionnelle pour chaque contrôle ou un groupe de contrôles, et dans les rapports de client, vous pouvez ajouter des barres de données pour comparer les données dans d'autres enregistrements.

  • Dispositions plus flexibles    Dans Access 2010, la méthode de conception par défaut pour les rapports consiste à placer des contrôles dans les mises en page. Ces grilles vous aident à alignez et redimensionner des contrôles facilement et sont requises pour les rapports que vous souhaitez afficher dans un navigateur. Bien que les dispositions ne sont pas nouveautées dans Access 2010, il existe certaines modifications qui les façons dans lequel vous permet de les déplacer, aligner et redimensionner des contrôles. Pour plus d'informations, voir la vidéo d' Introduction aux mises en page de formulaire et état.

Haut du document

Créer un rapport

Étape 1 : choisir une source d’enregistrement

La source d’enregistrement d’un état peut être une table, une requête nommée ou une requête incorporée. Elle doit contenir toutes les lignes et les colonnes de données que vous souhaitez afficher dans l’état.

  • Si les données que vous souhaitez sont contenues dans une table ou requête existante, sélectionnez la table ou la requête dans le volet de Navigation, puis puis continuer à étape 2: choisir un outil d'état.

  • Si la source d’enregistrement n’existe pas encore, effectuez l’une des opérations suivantes :

Pour plus d'informations sur la création des tables ou requêtes, voir les articles Introduction aux tables ou Présentation des requêtes.

Pour plus d'informations sur la création et la sélection de sources d'enregistrement, voir l'article définir la source d'enregistrement d'un rapport.

Étape 2 : choisir un outil d’état

Les outils d'état sont situées sous l'onglet créer du ruban, dans le groupe de rapports. Le tableau suivant décrit brièvement que signifie chaque outil :

Rapports Web compatibles

Les rapports créés à l'aide de ces outils sont compatibles avec la publier sur fonctionnalité Access Services et seront affiche dans un navigateur. Notez que les objets compatibles Web sont indiqués par le globe sur l'icône de l'objet.

Image du bouton

Outil

Description

Image du bouton

Rapport

Permet de créer un état simple sous forme de tableau contenant tous les champs de la source d’enregistrement que vous avez sélectionnée dans le volet de navigation.

Image du bouton

État vide

Ouvre un état vierge en mode page et affiche le volet Liste de champs. Access crée une requête de source d'enregistrement en faisant glisser les champs à partir de la liste des champs au rapport.

Pour plus d'informations sur la publier sur fonctionnalité Access Services, voir l'article créer une base de données Access à partager sur le Web.

Rapports client

Les rapports créés à l'aide de ces outils ne sont pas compatibles avec la publier sur fonctionnalité Access Services. Ajout de rapports client à une base de données Web n'empêche pas la base de données de publication, mais les rapports client ne sera pas disponibles dans le navigateur. Toutefois, vous pouvez utiliser un rapport client lors de la base de données est ouverte dans Access.

Image du bouton

Outil

Description

Image du bouton

Rapport

Permet de créer un état simple sous forme de tableau contenant tous les champs de la source d’enregistrement que vous avez sélectionnée dans le volet de navigation.

Image du bouton

Création d’état

Permet d’ouvrir un état vierge en mode Création auquel vous pouvez ajouter les champs et contrôles désirés.

Image du bouton

État vide

Permet d’ouvrir un état vierge en mode Page et d’afficher le volet Office Liste de champs. Lorsque vous faites glisser des champs de la Liste de champs vers l’état, Access crée un requête incorporée et la stocke dans la propriété Record Source de l’état.

Image du bouton

Assistant État

Permet d’afficher un Assistant comportant plusieurs étapes dans lequel vous pouvez spécifier des champs, les niveaux de regroupement/tri et des options de disposition. L’Assistant crée un état en fonction de vos sélections.

Image du bouton

Étiquettes

Permet d’afficher un Assistant dans lequel vous pouvez sélectionner des tailles d’étiquette standard ou personnalisées. Vous avez également la possibilité de sélectionner les champs à afficher et le mode de tri de ces derniers. L’Assistant crée un état en fonction de vos sélections.


Étape 3 : créer l’état

  1. Cliquez sur le bouton de l'outil que vous voulez utiliser. Si un Assistant s'affiche, suivez les étapes dans l'Assistant, puis cliquez sur Terminer dans la dernière page.

    Access affiche l'état en mode page.

  2. Mettre en forme le rapport jusqu'à ce qu'il se présente comme vous le souhaitez :

    • Redimensionnez les champs et les étiquettes en les sélectionnant et en faisant glisser les bords jusqu’à la taille désirée.

    • Déplacez un champ en le sélectionnant (avec son étiquette, le cas échéant), puis en le faisant glisser jusqu’au nouvel emplacement.

    • Cliquez avec le bouton droit sur un champ, puis utilisez les commandes du menu contextuel pour fusionner ou fractionner des cellules, supprimer ou sélectionner des champs et effectuer d’autres tâches de mise en forme.

      Vous pouvez en outre avoir recours aux fonctionnalités décrites dans les sections ci-après pour rendre l’état plus lisible et attrayant.

Haut du document

Appliquer un regroupement, un tri ou ajouter des totaux

Le moyen le plus rapide pour ajouter le regroupement, un tri ou totaux à un rapport est avec le bouton droit le champ auquel vous voulez appliquer le groupe, de tri et total, puis cliquez sur la commande souhaitée dans le menu contextuel.

Lorsque l’état est ouvert en mode Page ou Création, vous pouvez également appliquer un regroupement, un tri ou ajouter des totaux à l’aide du volet Regrouper, trier et total :

  1. Si le volet Regrouper, trier et total n’est pas encore ouvert, sous l’onglet Création, dans le groupe Regroupement et totaux, cliquez sur Regrouper et trier.

  2. Cliquez sur Ajouter un groupe ou Ajouter un tri, puis sélectionnez le champ pour lequel vous souhaitez un regroupement ou un tri.

  3. Cliquez sur Autres sur une ligne de tri ou de regroupement pour définir des options supplémentaires et ajouter des totaux.

Pour plus d'informations sur le regroupement, le tri et des totaux, voir l'article créer un état groupé ou de synthèse.

Haut du document

Mettez en surbrillance les valeurs à l'aide de la mise en forme conditionnelle

Access 2010 inclut plus de puissants outils pour mettre en surbrillance des données dans un état. Vous pouvez ajouter jusqu'à 50 règles de mise en forme conditionnelle pour chaque contrôle ou un groupe de contrôles, et dans les rapports de client, vous pouvez ajouter des barres de données pour comparer les données dans d'autres enregistrements.

Pour ajouter une mise en forme conditionnelle :

  1. Ouvrez l'état en mode page par clic droit sur l'état dans le volet de Navigation, puis en cliquant sur Mode page.

  2. Sélectionnez tous les contrôles auquel vous voulez appliquer la mise en forme conditionnelle. Pour sélectionner plusieurs contrôles, maintenez la touche MAJ ou CTRL enfoncée et cliquez sur les contrôles de que votre choix.

  3. Sous l'onglet Format, dans le groupe Mise en forme du contrôle, cliquez sur Mise en forme conditionnelle.

    Access ouvre la boîte de dialogue Gestionnaire des règles de mise en forme conditionnelle.

  4. Dans la boîte de dialogue Gestionnaire des règles de mise en forme conditionnelle, cliquez sur Nouvelle règle.

  5. Dans la boîte de dialogue Nouvelle règle de mise en forme, sélectionnez une valeur sous Sélectionnez un type de règle :

    • Pour créer une règle qui est évaluée pour chaque enregistrement, sélectionnez Vérifier les valeurs de l’enregistrement actif ou utiliser une expression.

    • Pour créer une règle qui permet de comparer les enregistrements entre eux à l’aide de barres de données, cliquez sur Comparaison aux autres enregistrements.

Remarque : L'option comparaison aux autres enregistrements n'est pas disponible dans les bases de données Web.


  1. Sous Modifier la description de la règle, spécifiez la règle qui détermine à quel moment la mise en forme doit être appliquée, ainsi que la mise en forme souhaitée lorsque les critères de la règle sont satisfaits.

  2. Cliquez sur OK pour revenir à la boîte de dialogue Gestionnaire de règles de mise en forme conditionnelle.

  3. Pour créer une autre règle pour ce contrôle ou cet ensemble de contrôles, répétez les étapes de cette procédure à partir de l’étape 4. Sinon, cliquez sur OK pour fermer la boîte de dialogue.

Pour plus d'informations sur l'ajout de la mise en forme conditionnelle à un rapport, voir vidéo utiliser des rapports de mise en forme conditionnelle.

Haut du document

Obtenir un aspect professionnel avec des thèmes

Vous pouvez maintenant appliquer les thèmes Office 2010 à une base de données Access, pour vous aider à créer un style cohérent sur tous vos documents Office.

Important : Si vous choisissez un thème Office, la police ou la couleur, elle s'applique à tous les formulaires et rapports dans votre base de données (pas uniquement à celui que vous utilisez).

  1. Ouvrir un rapport en mode page en cliquant dans le volet de Navigation, puis cliquez sur mise en page VUE.

  2. Sous l'onglet Création, dans le groupe thèmes, sélectionnez le thème, la couleur ou la police de votre choix :

    Image du ruban Word

    • Utiliser la galerie de thèmes pour définir simultanément les couleurs et polices à un modèle prédéfini.

    • Utilisez les galeries Couleurs ou Polices pour définir les couleurs ou les polices indépendamment.


Pour plus d'informations sur l'utilisation des thèmes Office, voir la vidéo rendre vos formulaires et états Access plus cohérentes et attrayant avec les thèmes Office.

Haut du document

Ajouter des images

Traditionnellement dans Access, les images ont été liés aux contrôles d'image individuelles des formulaires ou états. Pour modifier une image fréquemment utilisées qui a été utilisée dans plusieurs formulaires et rapports, chaque contrôle d'image devait être modifiés manuellement. Dans Access 2010, cependant, vous pouvez désormais joindre une fois une image à une base de données et ensuite utiliser l'image à plusieurs objets. Mise à jour de l'image unique met à jour à l'endroit où il est utilisé sur la base de données entière. C'est très utile pour des éléments tels que logos d'entreprise ou des images d'arrière-plan sont utilisées dans une base de données.

Ajouter une image

  1. Dans le volet de Navigation, avec le bouton droit de l'état auquel vous souhaitez ajouter l'image, puis cliquez sur Mode page.

  2. Cliquez sur le rapport dans lequel vous souhaitez ajouter l'image.

  3. Sous l'onglet Création, dans le groupe contrôles, cliquez sur Insérer une Image.

  4. Effectuez l’une des opérations suivantes :

    • Utiliser une image existante    Si l'image que vous voulez est déjà dans la galerie, cliquez dessus pour l'ajouter à l'état.

    • Télécharger une nouvelle image    En bas de la galerie, cliquez sur Parcourir. Dans la boîte de dialogue Insérer une image, naviguez jusqu'à l'image que vous voulez utiliser, puis cliquez sur Ouvrir.

      Access ajoute l'image sélectionnée dans le rapport.

Ajouter une image d’arrière-plan

Remarque : Images d'arrière-plan ne peut pas être ajoutées aux rapports Web compatible.

  1. Dans le volet de Navigation, avec le bouton droit de l'état auquel vous souhaitez ajouter l'image d'arrière-plan, puis cliquez sur Mode page.

  2. Sous l’onglet Format, dans le groupe Arrière-plan, cliquez sur Image d’arrière-plan.

  3. Effectuez l’une des opérations suivantes :

    • Utiliser une image existante    Si l'image que vous voulez est déjà dans la galerie, cliquez dessus pour l'ajouter à l'état.

    • Télécharger une nouvelle image    En bas de la galerie, cliquez sur Parcourir. Dans la boîte de dialogue Insérer une image, naviguez jusqu'à l'image que vous voulez utiliser, puis cliquez sur Ouvrir.

      Access ajoute l'image sélectionnée dans le rapport.

Haut du document

Afficher l’aperçu d’un état et l’imprimer

Afficher l’aperçu d’un état

  1. Ouvrez l'état que vous souhaitez afficher un aperçu, ou simplement le sélectionner dans le volet de Navigation.

  2. Sous l'onglet fichier, cliquez sur Imprimer, puis cliquez sur Aperçu avant impression.

    Access ouvre l'état en mode Aperçu avant impression. Vous pouvez utiliser les commandes sous l'onglet Aperçu avant impression pour effectuer une des opérations suivantes :

    • Imprimer le rapport ;

    • Ajuster la taille de la page ou la mise en page.

    • Effectuer un zoom avant ou arrière ou afficher plusieurs pages à la fois ;

    • Actualiser les données sur le rapport ;

    • Exporter l’état dans un autre format de fichier

  3. Pour revenir à l'espace de travail de base de données, sous l'onglet Aperçu avant impression, dans le groupe Fermer l'aperçu, cliquez sur Fermer l'aperçu avant impression.

Imprimer un rapport

Outre l'impression à partir de l'aperçu avant impression, vous pouvez également imprimer un rapport sans les visualiser :

  1. Ouvrez l'état que vous souhaitez afficher un aperçu, ou simplement le sélectionner dans le volet de Navigation.

  2. Sous l’onglet Fichier, cliquez sur Imprimer.

    • Pour envoyer le rapport directement à l'imprimante par défaut sans définir les options d'impression, cliquez sur Impression rapide.

    • Pour ouvrir une boîte de dialogue dans laquelle vous pouvez sélectionner une imprimante, indiquer le nombre de copies et définir d’autres paramètres, cliquez sur Imprimer.

Haut du document

Essayez Office 2010

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Ces informations vous ont-elles été utiles ?

Comment pouvons-nous nous améliorer ?

Comment pouvons-nous nous améliorer ?

Afin de protéger votre vie privée, n’indiquez aucune information de contact dans vos commentaires. Lisez notre déclaration de confidentialité.

Nous vous remercions pour vos commentaires.