Présenter vos données dans un diagramme de Gantt

Présenter vos données dans un diagramme de Gantt

Vous avez besoin d’afficher le statut pour une planification de projet simple au moyen d’un diagramme de Gantt ? Bien qu’Excel n’offre pas de type de diagramme de Gantt prédéfini, vous pouvez en simuler un en personnalisant un graphique à barres empilées pour indiquer les dates de début et de fin des tâches, comme suit :

Remarque : Un diagramme de Gantt Excel utilise généralement les jours comme unité de temps le long de l’axe horizontal.

Exemple de diagramme de Gantt simulé
Exemple de diagramme de Gantt simulé dans Excel 2016 et 2013
Simulation de diagramme de Gantt dans Excel
Exemple de diagramme de Gantt simulé dans Excel 2010 et 2007

La procédure suivante vous aidera à créer un diagramme de Gantt. Pour ce graphique, nous avons utilisé les données de l’exemple de feuille de calcul ci-dessous. Vous pouvez également utiliser vos propres données, tant que vous utilisez les mêmes en-têtes de colonne et la même structure de feuille de calcul.

Conseil : Si votre projet présente une planification plus complexe et que vous voulez capturer les dépendances, vous voudrez peut-être créer le diagramme de Gantt dans Microsoft Project à la place.

Pour créer un diagramme de Gantt similaire à celui de notre exemple qui indique l’avancement des tâches en jours, procédez comme suit :

  1. Créez les données suivantes dans une feuille de calcul Excel.

    exemples de données de table pour le diagramme de Gantt

    Si vos données se trouvent dans une plage de cellules continue, sélectionnez une cellule quelconque de cette plage pour inclure toutes les données de cette plage.

    Si vos données ne se trouvent pas dans une plage continue, sélectionnez les cellules tout en maintenant la touche Ctrl enfoncée.

    Conseil : Si vous ne voulez pas inclure des lignes ou des colonnes spécifiques de données, vous pouvez les masquer dans la feuille de calcul. En savoir plus sur la sélection de données pour votre graphique

  2. Cliquez sur Insérer > Insérer un histogramme ou un graphique à barres > Barres empilées.

    Graphique à barres empilées dans Excel 2016

  3. Maintenant, nous allons mettre en forme le graphique à barres empilées pour qu’il ressemble à un diagramme de Gantt. Dans le graphique, cliquez avec le bouton droit sur la première série de données (la partie Démarrer de la barre en bleu) et cliquez sur Remplir > Aucun remplissage.

    graphique à barres empilées 2D

  4. Si vous n’avez pas besoin de la légende ou du titre du graphique, cliquez dessus et appuyez sur Suppr.

  5. Inversons l’ordre des tâches de façon à ce qu’elles commencent par la Tâche1. Cliquez avec le bouton droit sur l’axe vertical (Tâches) et cliquez sur Format de l’axe > zone Abscisses en ordre inverse.

  1. Dans votre message électronique, cliquez sur l’onglet Insérer, puis, dans le groupe Illustrations, cliquez sur Graphique.

  2. Dans la boîte de dialogue Insérer un graphique, cliquez sur Graphique > Barres empilées, puis sur OK.

    Excel s’ouvre dans une fenêtre fractionnée et affiche des exemples de données sur une feuille de calcul.

  3. Vous pouvez remplacer les données d’exemple par vos propres données. Pour ce faire, cliquez simplement à l’intérieur de la fenêtre et commencez à modifier les données d’exemple.

    Exemple de données d’un graphique
  4. Vous pouvez également remplacer les exemples d’étiquettes des axes dans la colonne A et le nom de l’élément de légende dans la ligne 1.

    Remarque : Après avoir mis à jour la feuille de calcul, le graphique dans Outlook sera mis à jour automatiquement avec les nouvelles données.

  5. Vous pouvez également enregistrer la feuille de calcul.

La procédure suivante vous aidera à créer un diagramme de Gantt. Pour ce graphique, nous avons utilisé les données de l’exemple de feuille de calcul ci-dessous. Vous pouvez également utiliser vos propres données, tant que vous utilisez les mêmes en-têtes de colonne et la même structure de feuille de calcul.

Conseil : Si votre projet présente une planification plus complexe et que vous voulez capturer les dépendances, vous voudrez peut-être créer le diagramme de Gantt dans Microsoft Project à la place.

Pour créer un diagramme de Gantt similaire à celui de notre exemple qui indique l’avancement des tâches en jours, procédez comme suit :

  1. Créez les données suivantes dans une feuille de calcul Excel.

    exemples de données de table pour le diagramme de Gantt

    Si vos données se trouvent dans une plage de cellules continue, sélectionnez une cellule quelconque de cette plage pour inclure toutes les données de cette plage.

    Si vos données ne se trouvent pas dans une plage continue, sélectionnez les cellules tout en maintenant la touche Ctrl enfoncée.

    Conseil : Si vous ne voulez pas inclure des lignes ou des colonnes spécifiques de données, vous pouvez les masquer dans la feuille de calcul. En savoir plus sur la sélection de données pour votre graphique

  2. Cliquez sur Insérer > Insérer un graphique à barres > Barres empilées.

    la sélection du graphique dans le ruban

  3. Maintenant, nous allons mettre en forme le graphique à barres empilées pour qu’il ressemble à un diagramme de Gantt. Dans le graphique, cliquez avec le bouton droit sur la première série de données (la partie Démarrer de la barre en bleu) et cliquez sur Remplir > Aucun remplissage.

    graphique à barres empilées 2D

  4. Si vous n’avez pas besoin de la légende ou du titre du graphique, cliquez dessus et appuyez sur Suppr.

  5. Inversons l’ordre des tâches de façon à ce qu’elles commencent par la Tâche1. Cliquez avec le bouton droit sur l’axe vertical (Tâches) et cliquez sur Format de l’axe > zone Abscisses en ordre inverse.

  1. Dans votre message électronique, cliquez sur l’onglet Insérer, puis, dans le groupe Illustrations, cliquez sur Graphique.

  2. Dans la boîte de dialogue Insérer un graphique, cliquez sur Graphique > Barres empilées, puis sur OK.

    Excel s’ouvre dans une fenêtre fractionnée et affiche des exemples de données sur une feuille de calcul.

  3. Vous pouvez remplacer les données d’exemple par vos propres données. Pour ce faire, cliquez simplement à l’intérieur de la fenêtre et commencez à modifier les données d’exemple.

    Exemple de données d’un graphique
  4. Vous pouvez également remplacer les exemples d’étiquettes des axes dans la colonne A et le nom de l’élément de légende dans la ligne 1.

    Remarque : Après avoir mis à jour la feuille de calcul, le graphique dans Outlook sera mis à jour automatiquement avec les nouvelles données.

  5. Vous pouvez également enregistrer la feuille de calcul.

La procédure suivante vous aidera à créer un diagramme de Gantt. Pour ce graphique, nous avons utilisé les données de l’exemple de feuille de calcul ci-dessous. Vous pouvez également utiliser vos propres données, tant que vous utilisez les mêmes en-têtes de colonne et la même structure de feuille de calcul.

  1. Créez les données suivantes dans une feuille de calcul Excel.

    exemples de données de table pour le diagramme de Gantt

    Si vos données se trouvent dans une plage de cellules continue, sélectionnez une cellule quelconque de cette plage pour inclure toutes les données de cette plage.

    Si vos données ne se trouvent pas dans une plage continue, sélectionnez les cellules tout en maintenant la touche Ctrl enfoncée.

  2. Dans l’onglet Insertion, dans le groupe Graphiques, cliquez sur Barres.

  3. Sous Barres 2D, cliquez sur Barres empilées.

  4. Cliquez sur la zone de graphique du graphique.

    Cela permet d’afficher les Outils de graphique et les onglets Création, Disposition et Mise en forme.

  5. Dans l’onglet Création, dans le groupe Styles du graphique, cliquez sur le style de graphique à utiliser.

    Styles du graphique dans le ruban Excel

  6. Dans l’onglet Format, dans le groupe Sélection actuelle, dans la liste déroulante Éléments de graphique, sélectionnez l’option Série « Jours écoulés depuis le début ».

    Liste déroulante Éléments de graphique
  7. Dans l’onglet Mise en forme, dans le groupe Sélection active, cliquez sur Mise en forme de la sélection.

    Image du ruban Excel

  8. Cliquez sur Remplissage > Aucun remplissage > Fermer.

  9. Dans le graphique, cliquez sur la légende, puis appuyez sur Suppr.

  10. Dans l’onglet Format, dans le groupe Sélection actuelle, dans la liste déroulante Éléments de graphique, sélectionnez l’option Axe vertical (abscisses).

  11. Dans l’onglet Mise en forme, dans le groupe Sélection active, cliquez sur Mise en forme de la sélection.

  12. Dans la boîte de dialogue Format de l’axe, sous Options d’axe, activez la case à cocher Abscisses en ordre inverse, puis cliquez sur Fermer.

    Boîte de dialogue Format de l’axe
  13. Si vous souhaitez utiliser des couleurs de thème différentes du thème par défaut qui est appliqué à votre classeur, procédez comme suit :

    1. Dans l’onglet Mise en page, dans le groupe Thèmes, cliquez sur Thèmes.

      Image du ruban Excel

    2. Sous Prédéfini, cliquez sur le thème à utiliser.

  1. Dans votre message électronique, cliquez sur l’onglet Insérer, puis, dans le groupe Illustrations, cliquez sur Graphique.

  2. Dans la boîte de dialogue Insérer un graphique, cliquez sur Graphique > Barres empilées, puis sur OK.

    Excel s’ouvre dans une fenêtre fractionnée et affiche des exemples de données sur une feuille de calcul.

  3. Vous pouvez remplacer les données d’exemple par vos propres données. Pour ce faire, cliquez simplement à l’intérieur de la fenêtre et commencez à modifier les données d’exemple.

    Exemple de données d’un graphique
  4. Vous pouvez également remplacer les exemples d’étiquettes des axes dans la colonne A et le nom de l’élément de légende dans la ligne 1.

    Remarque : Après avoir mis à jour la feuille de calcul, le graphique dans Outlook sera mis à jour automatiquement avec les nouvelles données.

  5. Vous pouvez également enregistrer la feuille de calcul.

Le saviez-vous ?

Si vous n’avez pas d’abonnement Office 365 ou la dernière version d’Office, vous pouvez essayer ce produit dès aujourd’hui :

Essayez Office 365 ou la dernière version d’Excel

Voir aussi

Créer un graphique de bout en bout

Enregistrer un graphique personnalisé en tant que modèle

Ces informations vous ont-elles été utiles ?

Très bien ! Vous avez d’autres commentaires ?

Comment pouvons-nous l’améliorer ?

Nous vous remercions pour vos commentaires.

×