Présenter des données (groupe) sous forme de plan dans une feuille de calcul

Si vous disposez d’une liste de données que vous souhaitez regrouper et synthétiser, vous pouvez créer un plan comportant jusqu’à huit niveaux, un pour chaque groupe. Chaque niveau interne, représenté par un numéro plus élevé dans les symboles du plan affiche les données de détails du niveau externe précédent, représenté par un numéro moins élevé. Un plan vous permet d’afficher rapidement les lignes ou les colonnes de synthèse ou de révéler les détails de chaque groupe. Vous pouvez créer un plan de lignes (comme dans l’exemple ci-après), un plan de colonnes ou un plan de lignes et de colonnes.

Liste avec plan
Plan de lignes de données de ventes regroupées par régions géographiques et mois et dans lequel plusieurs lignes de synthèse et de détail sont affichées.

1.  Pour afficher les lignes d’un niveau, cliquez sur les symboles du plan un deux trois appropriés.

2.  Le niveau 1 contient le total des ventes pour toutes les lignes de détails.

3.  Le niveau 2 contient le total des ventes par mois et par région.

4.  Le niveau 3 contient les lignes de détail (en l’occurrence, les lignes de détails 11 à 13).

5.  Pour développer ou réduire les données dans le plan, cliquez sur les symboles de plan plus et moins .

Que voulez-vous faire ?

Créer un plan de lignes

Créer un plan de colonnes

Afficher ou masquer des données affichées en mode plan

Personnaliser un plan avec des styles

Copier des données affichées en mode plan

Masquer ou supprimer un plan

Créer un rapport de synthèse avec un graphique

Créer un plan de lignes

  1. Chaque colonne de données à afficher en mode Plan doit comporter une étiquette dans la première ligne et contenir des informations similaires et aucune ligne ou colonne de la plage de cellules ne doit être vide.

  2. Assurez-vous que les lignes de détail ont également une ligne de synthèse (un sous-total). Effectuez l’une des actions suivantes :

    Insérer des lignes de synthèse à l’aide de la commande Sous-total    

    • Utilisez la commande Sous-total qui insère la fonction SOUS.TOTAL immédiatement en dessous ou au-dessus de chaque groupe de lignes de détails et qui crée automatiquement le plan. Pour plus d’informations sur l’utilisation de la fonction Sous-total, voir SOUS.TOTAL, fonction.

      Insérer des lignes de synthèse    

    • Insérez vos propres lignes de synthèse avec des formules immédiatement en dessous ou au-dessus de chaque groupe de lignes de détails. Par exemple, sous (ou au-dessus) de la ligne des données de vente pour mars et avril, utilisez la fonction SOMME pour calculer le sous-total des ventes pour ces mois. Le tableau ci-après vous montre cet exemple.

  3. Spécifiez si les lignes de synthèse sont situées sous ou au-dessus des lignes de détail. Sous l’onglet Données, dans le groupe Plan, cliquez sur le lanceur de boîte de dialogue Plan.
    Dans le groupe Plan, cliquez sur le lanceur de la boîte de dialogue

  4. Si vos lignes de synthèse se trouvent au-dessus de vos lignes de détail, désactivez la case à cocher Lignes de synthèse sous les lignes de détail. Dans le cas contraire, conservez cette case à cocher activée.

  5. Affichez vos données en mode plan. Effectuez l’une des actions suivantes :

    Créer automatiquement un plan des données

    1. Si nécessaire, sélectionnez une cellule dans la plage pour laquelle vous voulez créer un plan.

    2. Sous l’onglet Données, dans le groupe Plan, cliquez sur la flèche sous Grouper, puis cliquez sur Plan automatique.

      Cliquez sur la flèche sous Groupe, puis cliquez sur Plan automatique

    Créer manuellement un plan des données

    Important : Lorsque vous groupez manuellement des niveaux du plan, veillez à ce que toutes les données soient affichées pour éviter de grouper incorrectement les lignes.

    1. Affichez le groupe externe en mode plan.

      Comment présenter le groupe externe en mode plan

      1. Sélectionnez toutes les lignes de synthèse subordonnées et les lignes de détail qui leur sont associées.

        Dans l’exemple ci-dessous, la ligne 6 contient les sous-totaux des lignes 2 à 5, la ligne 10 contient le sous-total des lignes 7 à 9 et la ligne 11 contient le total général. Pour grouper toutes les données de détails de la ligne 11, sélectionnez les lignes 2 à 10.

         

        A

        B

        C

        1

        Région

        Mois

        Ventes

        2

        Est

        Mars

        9 647 €

        3

        Est

        Mars

        4 101 €

        4

        Est

        Mars

        7 115 €

        5

        Est

        Mars

        2 957 €

        6

        Est

        Total mars

        23 820 €

        7

        Est

        Avril

        4 257 €

        8

        Est

        Avril

        1 829 €

        9

        Est

        Avril

        6 550 €

        10

        Est

        Total avril

        12 636 €

        11

        Total Est

        36 456 €

        Important : N’incluez pas la ligne de synthèse (ligne 11) dans la sélection.

      2. Sous l’onglet Données, dans le groupe Plan, cliquez sur Grouper, sur Lignes, puis sur OK.

        Cliquez sur Lignes, puis sur OK.

        Les symboles du plan s’affichent à côté du groupe à l’écran.

    2. (Facultatif) Présentez en mode plan un groupe imbriqué interne (lignes de détail pour une section donnée de vos données).

      Comment présenter les groupes imbriqués internes en mode plan (groupes de lignes de détail)

      1. Pour chaque groupe imbriqué interne, sélectionnez les lignes de détails adjacentes à la ligne qui contient la ligne de synthèse.

        Dans l’exemple ci-dessous, pour grouper les lignes 2 à 5 (suivies de la ligne de synthèse 6), sélectionnez les lignes 2 à 5. Pour grouper les lignes 7 à 9 (suivies de la ligne de synthèse 10), sélectionnez les lignes 7 à 9.

         

        A

        B

        C

        1

        Région

        Mois

        Ventes

        2

        Est

        Mars

        9 647 €

        3

        Est

        Mars

        4 101 €

        4

        Est

        Mars

        7 115 €

        5

        Est

        Mars

        2 957 €

        6

        Est

        Total mars

        23 820 €

        7

        Est

        Avril

        4 257 €

        8

        Est

        Avril

        1 829 €

        9

        Est

        Avril

        6 550 €

        10

        Est

        Total avril

        12 636 €

        11

        Total Est

        36 456 €

        Important : N’incluez pas la ligne de synthèse dans la sélection.

      2. Sous l’onglet Données, dans le groupe Plan, cliquez sur Grouper.

        Cliquez sur Groupe sous l’onglet Données

        Les symboles du plan s’affichent à côté du groupe à l’écran.

      3. Continuez à sélectionner et à grouper les lignes internes jusqu’à ce que vous ayez créé tous les niveaux souhaités dans le plan.

      4. Si vous souhaitez dissocier des lignes, sélectionnez-les, puis, dans le groupe Plan de l’onglet Données, cliquez sur Dissocier.

        Vous pouvez également dissocier des sections du plan sans supprimer le plan entier. Maintenez la touche MAJ enfoncée et cliquez sur la case case plus ou sur la case case moins du groupe, puis, dans le groupe Plan de l’onglet Données, cliquez sur Dissocier.

        Important : Si vous dissociez des sections du plan alors que les données de détail sont masquées, les lignes de détail peuvent rester masquées. Pour afficher les données, faites glisser le pointeur sur les numéros des lignes visibles adjacentes aux lignes masquées. Dans le groupe Cellules de l’onglet Accueil, cliquez sur la flèche en dessous de Format, pointez sur Masquer et afficher, puis cliquez sur Afficher les lignes.

Haut de la page

Créer un plan de colonnes

  1. Chaque ligne de données à afficher en mode Plan doit comporter une étiquette dans la première colonne et contenir des informations similaires et aucune ligne ou colonne de la plage de cellules ne doit être vide.

  2. Insérez vos propres colonnes de synthèse avec les formules immédiatement à droite ou à gauche de chaque groupe de colonnes de détails. Le tableau indiqué à l’étape 4 ci-dessous montre cet exemple.

    Remarque :  Pour afficher les données par colonne en mode plan, les colonnes de synthèse doivent contenir des formules qui font référence aux cellules de chaque colonne de détails pour le groupe.

  3. Spécifiez si l’emplacement de la colonne de synthèse est à droite ou à gauche des colonnes de détails. Sous l’onglet Données, dans le groupe Plan cliquez sur le lanceur de boîte de dialogue Plan.

    Comment spécifier un emplacement de colonne de synthèse

    1. Sous l’onglet Données, dans le groupe Plan cliquez sur le lanceur de boîte de dialogue Plan.

      Dans le groupe Plan, cliquez sur le lanceur de la boîte de dialogue

    2. Pour spécifier une colonne de synthèse à gauche de la colonne de détails, désactivez la case à cocher Colonnes de synthèse à droite des colonnes de détail. Pour spécifier une colonne de synthèse à droite de la colonne de détails, activez la case à cocher Colonnes de synthèse à droite des colonnes de détails.

    3. Cliquez sur OK.

  4. Pour afficher les données en mode Plan, effectuez l’une des actions suivantes :

    Créer automatiquement un plan des données

    1. Si nécessaire, sélectionnez une cellule dans la plage.

    2. Sous l’onglet Données, dans le groupe Plan, cliquez sur la flèche sous Grouper, puis cliquez sur Plan automatique.

    Créer manuellement un plan des données

    Important :  Lorsque vous groupez manuellement des niveaux du plan, veillez à ce que toutes les données soient affichées pour éviter de grouper incorrectement les colonnes.

    1. Affichez le groupe externe en mode plan.

      Comment présenter le groupe externe en mode plan (toutes les colonnes sauf le total général)

      1. Sélectionnez toutes les colonnes de synthèse subordonnées ainsi que les données de détail qui leur sont associées.

        Dans l’exemple ci-dessous, la colonne E contient les sous-totaux des colonnes B à D, la colonne I contient les sous-totaux des colonnes F à H, et la colonne J contient les totaux généraux. Pour grouper toutes les données de détail de la colonne J, sélectionnez les colonnes B à I.

         

        A

        B

        C

        D

        E

        F

        G

        H

        I

        J

        1

        Région

        Janv

        Fév

        Mar

        T1

        Avr

        Mai

        Juin

        T2

        H1

        2

        Est

        371

        504

        880

        1 755

        186

        653

        229

        1 068

        2 823

        3

        Ouest

        192

        185

        143

        520

        773

        419

        365

        1 557

        2 077

        4

        Nord

        447

        469

        429

        1 345

        579

        180

        367

        1 126

        2 471

        5

        Sud

        281

        511

        410

        1 202

        124

        750

        200

        1 074

        2 276

        Important : N’incluez pas la colonne de synthèse J (grands totaux) dans la sélection.

      2. Sous l’onglet Données, dans le groupe Plan, cliquez sur Grouper.

        Cliquez sur Groupe sous l’onglet Données

        Les symboles du plan s’affichent à côté du groupe à l’écran.

    2. Vous pouvez éventuellement afficher un groupe imbriqué interne en mode plan (groupes individuels de colonnes de détail).

      Comment présenter le groupe imbriqué interne en mode plan (groupes de colonnes de détail)

      1. Pour chaque groupe imbriqué interne, sélectionnez les colonnes de détail adjacentes à la colonne qui contient la colonne de synthèse.

        Dans l’exemple ci-dessous, pour grouper les colonnes B à D (suivies de la colonne de synthèse E), sélectionnez les colonnes B à D. Pour grouper les colonnes F à H (suivies de la colonne de synthèse), sélectionnez les colonnes F à H.

         

        A

        B

        C

        D

        E

        F

        G

        H

        I

        J

        1

        Région

        Janv

        Fév

        Mar

        T1

        Avr

        Mai

        Juin

        T2

        H1

        2

        Est

        371

        504

        880

        1 755

        186

        653

        229

        1 068

        2 823

        3

        Ouest

        192

        185

        143

        520

        773

        419

        365

        1 557

        2 077

        4

        Nord

        447

        469

        429

        1 345

        579

        180

        367

        1 126

        2 471

        5

        Sud

        281

        511

        410

        1 202

        124

        750

        200

        1 074

        2 276

        Important : N’incluez pas la colonne de synthèse pour ce groupe dans la sélection.

      2. Sous l’onglet Données, dans le groupe Plan, cliquez sur Grouper.

        Cliquez sur Groupe sous l’onglet Données

        Les symboles du plan s’affichent à côté du groupe à l’écran.

  5. Continuez à sélectionner et à grouper les colonnes internes jusqu’à ce que vous ayez créé tous les niveaux que vous souhaitez dans le plan.

  6. Si vous souhaitez dissocier des colonnes, sélectionnez-les, puis, dans le groupe Plan de l’onglet Données, cliquez sur Dissocier.

Sous l’onglet Données, cliquez sur Dissocier

Vous pouvez également dissocier des sections du plan sans supprimer le plan entier. Maintenez la touche Maj enfoncée et cliquez sur la case case plus ou sur la case case moins du groupe, puis, dans le groupe Plan de l’onglet Données, cliquez sur Dissocier.

Si vous dissociez des sections du plan alors que les données de détails sont masquées, les colonnes de détails peuvent rester masquées. Pour afficher les données, faites glisser le pointeur sur les lettres des colonnes visibles adjacentes aux colonnes masquées. Dans le groupe Cellules de l’onglet Accueil, cliquez sur Format, pointez sur Masquer et afficher, puis cliquez sur Masquer les colonnes.

Haut de la page

Afficher ou masquer des données affichées en mode plan

  1. Si vous ne voyez pas les symboles du plan un deux trois , plus et moins , cliquez sur le Bouton Microsoft Office Image du bouton Office , puis sur Options Excel (Excel 2007) OU sur l’onglet Fichier (autres versions) ; cliquez ensuite sur Options, sur la catégorie Options avancées et, sous la section Afficher les options pour cette feuille de calcul, sélectionnez la feuille de calcul, puis cochez la case Afficher les symboles du plan si un plan est appliqué.

  2. Cliquez sur OK.

  3. Effectuez au moins l’une des opérations suivantes :

    Afficher ou masquer les données de détail pour un groupe    

    • Pour afficher les données de détail à l’intérieur d’un groupe, cliquez sur la case plus de ce groupe.

    • Pour masquer les données de détail pour un groupe, cliquez sur la case moins de ce groupe.

      Développer ou réduire la totalité d’un plan à un niveau particulier    

    • Dans les symboles du plan un deux trois , cliquez sur le numéro du niveau souhaité. Les données de détail des niveaux inférieurs sont alors masquées.

      Par exemple, si un plan comporte quatre niveaux, vous pouvez masquer le quatrième niveau tout en affichant les autres niveaux, en cliquant sur trois .

      Afficher ou masquer toutes les données de détail en mode plan    

    • Pour afficher toutes les données de détail, cliquez sur le niveau le plus bas dans les symboles du plan un deux trois . Si, par exemple, il existe trois niveaux, cliquez sur trois .

    • Pour masquer toutes les données de détail, cliquez sur un .

Haut de la page

Personnaliser un plan avec des styles

Pour les lignes du plan, Microsoft Excel utilise des styles, tels que NiveauLigne_1 et NiveauLigne_2. Pour les colonnes du plan, Excel utilise des styles tels que NiveauColonne_1 et NiveauColonne_2. Ces styles utilisent les mises en forme gras, italique et autres pour différencier les lignes ou les colonnes de synthèse au sein des données. En changeant la façon dont chacun de ces styles est défini, vous pouvez appliquer différentes mises en forme de texte et de cellule afin de personnaliser l’apparence de votre plan. Vous pouvez appliquer un style à un plan au moment de sa création ou ultérieurement.

Effectuez au moins l’une des opérations suivantes :

Appliquer automatiquement un style à une ligne ou une colonne de synthèse    

  1. Sous l’onglet Données, dans le groupe Plan cliquez sur le lanceur de boîte de dialogue Plan.

    Dans le groupe Plan, cliquez sur le lanceur de la boîte de dialogue

  2. Activez la case à cocher Styles automatiques.

Appliquer un style à une ligne ou une colonne existante    

  1. Sélectionnez les cellules auxquelles vous souhaitez appliquer des styles en mode plan.

  2. Sous l’onglet Données, dans le groupe Plan cliquez sur le lanceur de boîte de dialogue Plan.

    Dans le groupe Plan, cliquez sur le lanceur de la boîte de dialogue

  3. Activez la case à cocher Styles automatiques.

  4. Cliquez sur Appliquer les styles.

Vous pouvez également utiliser les mises en forme automatiques pour mettre en forme les données du plan.

Haut de la page

Copier des données affichées en mode plan

  1. Si vous ne voyez pas les symboles du plan un deux trois , plus et moins , cliquez sur le Bouton Microsoft Office Image du bouton Office , puis sur Options Excel (Excel 2007) OU sur l’onglet Fichier (autres versions) ; cliquez ensuite sur Options, sur la catégorie Options avancées et, sous la section Afficher les options pour cette feuille de calcul, sélectionnez la feuille de calcul, puis cochez la case Afficher les symboles du plan si un plan est appliqué.

  2. Utilisez les symboles du plan un deux trois , moins et plus pour masquer les données de détail à ne pas copier.

    Pour plus d’informations, voir Afficher ou masquer des données affichées en mode plan.

  3. Sélectionnez la plage de lignes de synthèse.

  4. Dans l’onglet Accueil, dans le groupe Édition, cliquez sur Rechercher et sélectionner, puis sur Atteindre.

    Cliquez sur Rechercher et sélectionner, puis sur Atteindre

  5. Cliquez sur Sélectionner les cellules.

  6. Cliquez sur Cellules visibles seulement.

  7. Cliquez sur OK, puis copiez les données.

Haut de la page

Masquer ou supprimer un plan

Remarque : Aucune donnée n’est supprimée lorsque vous masquez ou supprimez un plan.

Masquer un plan

  • (Excel 2007) Cliquez sur le Bouton Microsoft Office Image du bouton Office , puis sur Options Excel OU sur l’onglet Fichier (autres versions) ; cliquez ensuite sur Options, sur la catégorie Options avancées et, sous la section Afficher les options pour cette feuille de calcul, sélectionnez la feuille de calcul contenant le plan à masquer et décochez la case Afficher les symboles du plan si un plan est appliqué.

Supprimer un plan

  1. Cliquez sur la feuille de calcul.

  2. Sous l’onglet Données, dans le groupe Plan, cliquez sur Dissocier, puis sur Effacer le plan.

    Cliquez sur Dissocier, puis sur Effacer le plan

    Important : Si vous supprimez un plan alors que les données de détail sont masquées, les lignes ou les colonnes de détail peuvent rester masquées. Pour afficher les données, faites glisser le pointeur sur les numéros des lignes ou les lettres des colonnes visibles et adjacentes aux lignes et aux colonnes masquées. Dans le groupe Cellules de l’onglet Accueil, cliquez sur Format, pointez sur Masquer et afficher, puis sur Afficher les lignes ou sur Afficher les colonnes.

Haut de la page

Créer un rapport de synthèse avec un graphique

Supposons que vous vouliez créer un rapport de synthèse de vos données qui n’affiche que les totaux accompagnés d’un graphique. En général, la procédure est la suivante :

  1. Créez un rapport de synthèse.

    1. Affichez vos données en mode plan.

      Pour plus d’informations, voir Créer un plan de lignes ou Créer un plan de colonnes.

    2. Masquez les détails en cliquant sur les symboles du plan un deux trois , plus et moins pour n’afficher que les totaux comme le montre l’exemple suivant d’un plan de lignes :

      Liste sous forme de plan affichant uniquement les lignes de totaux

    3. Pour plus d’informations, voir Afficher ou masquer des données affichées en mode plan.

  2. Représentez graphiquement le rapport de synthèse.

    1. Sélectionnez les données de synthèse que vous voulez représenter graphiquement.

      Par exemple, pour ne représenter graphiquement que les totaux pour Beaune et Davolio, mais pas les totaux généraux, sélectionnez les cellules A1 à C11 comme le montre l’exemple ci-dessus.

    2. Créez le graphique. Par exemple, sous l’onglet Insertion, dans le groupe Graphiques, cliquez sur Graphiques recommandés, ou choisissez un autre type de graphique.

      Par exemple, si vous créez le graphique à l’aide de l’Assistant Graphique, il ressemblera à l’exemple suivant.

      Graphique créé à partir des données de sous-totaux

      Si vous affichez ou masquez des détails dans la liste de données sous forme de plan, le graphique est également mis à jour pour afficher ou masquer les données en conséquence.

Haut de la page

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×