Préparer, publier et tenir à jour votre site Web Publisher

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Remarque : COMPOSITIONS Web sont uniquement disponibles dans Publisher 2007 et les versions antérieures. Pour plus d’informations sur la mise à jour des publications Web existantes dans Publisher 2010, voir fonctionnalités Web.

Une fois que vous planifiez et créez une composition Web dans Microsoft Office Publisher 2007, vous pouvez le publier sur le web, un serveur réseau ou un dossier partagé sur votre ordinateur. Quelle que soit la destination, Publisher crée des fichiers HTML filtrés à partir de la composition Web. Vous pouvez ouvrir et lire ces fichiers HTML dans n’importe quel navigateur Web, tels que Windows Internet Explorer.

Composition Web avec barre de navigation, texte et graphismes

Contenu de cet article

Cet article décrit les procédures permettant de créer et publier votre composition Web en tant que fichiers HTML et de mise à jour de votre site Web en modifiant la composition Web et il republier.

Préparer votre site Web

Publier votre site Web

Mettre à jour votre site Web

Préparer votre site Web

Votre site Web est une extension de vous, votre entreprise, et la personnalisation de votre entreprise. Avant de créer votre site Web, le planifier. Pour obtenir de l’aide ainsi, voir l’article planifier votre site Web.

Qu’est le mieux ?

Pour préparer votre site et les informations qu’il fournira, tenez compte quel outil de création est adapté à vos besoins. Office Publisher 2007 est un excellent outil à utiliser lorsque vous souhaitez rapidement créer, publier et gérer des sites Web simples, statiques qui correspondent à la marque de votre entreprise et nécessitant des révisions du texte et de graphismes. Office Publisher 2007 n’est pas l’outil approprié dans les cas suivants :

  • Si votre site Web doit interactivité ou contenu piloté par base de données, afin que les visiteurs peuvent répondre d’un site Web ouvrir une session (blog) ou des éléments dans un panier d’achat

  • Si votre site Web requiert la validation des données, par exemple pour la vérification de crédit numéros de carte

  • Si vous souhaitez modifier ultérieurement le code HTML brut dans un éditeur HTML après avoir créé votre site Web dans Office Publisher 2007, qui combine le code HTML, XML et VML pour produire des sites Web

Créer votre site Web

Vous pouvez créer une nouvelle composition Web dans Office Publisher 2007. Si vous souhaitez travailler sur un site Web existant pour lequel vous n’avez aucune composition Web, vous pouvez copier et coller du contenu à partir des pages Web publiées dans une nouvelle composition Web, qui recrée le site Web dans une composition Web, ou vous pouvez utiliser un outil d’édition HTML.

  1. Dans le menu Fichier, cliquez sur Nouveau.

  2. Dans la liste des Types de composition, cliquez sur Sites Web.

  3. Effectuez l’une des opérations suivantes :

    • Pour créer un site Web personnalisé basé sur vos objectifs de site, vérifiez Utiliser l’Assistant Web simple, dans le volet Options, est sélectionnée, puis cliquez sur la conception de votre choix.

    • Pour créer un site Web à partir de zéro, sous Sites Web, cliquez sur Taille vierges, puis cliquez sur la taille souhaitée.

  4. Cliquez sur Créer.

  5. Si vous décidez d’utiliser l' Assistant Web simple, sélectionnez les options de votre choix dans la boîte de dialogue Générateur rapide de Site Web, puis cliquez sur OK.

  6. Ajouter du contenu à votre composition, puis apportez les modifications souhaitées.

    Conseil : Évitez de placer des objets sur les pages maîtres dans votre composition Web. Objets sont placés sur les pages maîtres Office Publisher 2007 ne s’affichent pas correctement lorsqu’elles sont affichées dans certains navigateurs Web.

Vérifier votre composition Web

Avant de publier votre site Web, vérifiez que le site fonctionne comme prévu et que vous avez traité toutes les éventuels problèmes qui peuvent survenir.

Vous pouvez rechercher les problèmes à l’aide du vérificateur de mise en et afficher un aperçu de votre site.

Utiliser le vérificateur de mise en pour rechercher et corriger les problèmes

Le vérificateur de mise en est un outil puissant pour la recherche d’éventuels problèmes. La plupart des vérifications sont appliquent aux problèmes de mise en forme de base. Il existe cependant certaines vérifications spécialement pour les problèmes qui peuvent affecter les compositions Web. Pour exécuter le vérificateur, procédez comme suit :

  1. Dans le menu Outils, cliquez sur Vérificateur de mise en page.

  2. Dans le volet Office Vérificateur de mise en, activez les cases à cocher exécuter les tests généraux et exécuter les tests de site web.

    Remarque : Assurez-vous que la case à cocher exécuter les tests d’impression n’est pas sélectionnée.

  3. Dans le volet Office Vérificateur de mise en page, sous Sélectionner un élément à corriger, cliquez sur la flèche en regard de l'élément à corriger, puis effectuez l'une des opérations suivantes :

    • Cliquez sur correction automatique pour corriger automatiquement le problème affectant l’élément.

      La correction automatique varie selon le problème. Dans la plupart des cas, aucune correction automatique n’est disponible.

    • Cliquez sur Atteindre cet élément pour accéder à la page où se trouve l’élément problème sélectionné.

      Vous pouvez ensuite résoudre le problème en effectuant les modifications nécessaires.

    • Cliquez sur Expliquer pour ouvrir une rubrique d'aide qui décrit le problème et propose des méthodes de correction.

    • Cliquez sur ne plus exécuter cette vérification pour désactiver la vérification.

      Cliquez sur cette option affecte toutes les instances du problème.

Afficher un aperçu de votre site Web

  • Dans le menu Fichier, cliquez sur Aperçu de la page Web.

Votre site Web aperçu apparaît dans votre navigateur par défaut. Vérifier l’aperçu pour les éléments suivants :

  • Le site s’ouvre et toutes les pages sont accessibles.

  • Tous les liens hypertexte fonctionnent comme prévu.

  • Contrôles de navigation fonctionnent comme prévu.

  • Aucun élément ne disparaissent.

  • N’importe quel sonores fonctionnent comme prévu.

Rechercher un service d’hébergement Web

Avant de pouvoir publier votre site Web sur le web, vous devez vous abonner à un service qui est fourni par un fournisseur de services Internet (ISP) d’hébergement Web. Ce service vous fournira accès à Internet, espace de stockage sur un serveur web et une URL Uniform Resource Locator () afin que les personnes peuvent accéder à votre site Web. Avant de publier votre site Web, contactez votre fournisseur de services Internet ou administrateur système pour obtenir les informations dont vous avez besoin et l’URL du site Web ou l’adresse du site FTP dans lequel vous pouvez enregistrer des fichiers.

Plusieurs fournisseurs de services Internet sont probablement disponibles dans votre région. Vous assurer que le fournisseur de services Internet auquel vous êtes abonné propose le type de prise en charge de votre choix. Si vous avez peu d’expérience dans la publication sur le web, vous souhaiterez peut-être un fournisseur de services Internet qui peut vous aider aux problèmes éventuels.

Haut de la Page

Composition Web avec barre de navigation, texte et graphismes

Une fois que vous vérifiez et afficher un aperçu de votre composition Web et s’abonner à un service d’hébergement Web, vous êtes prêt à publier votre site Web.

Vous pouvez publier un site Web à un serveur web, un serveur réseau, un serveur de protocole FTP (File Transfer) ou un dossier sur votre ordinateur.

Votre site de publication à un emplacement sur votre ordinateur peut avoir plusieurs fonctions :

  • Vous pouvez utiliser les fichiers publiés pour tester votre site Web avant d’effectuer les fichiers disponibles sur le web.

  • Vous pouvez utiliser un utilitaire FTP pour publier les fichiers sur le web en les téléchargeant à partir de l’emplacement du fichier sur votre ordinateur.

  • Vous conservez une copie locale des fichiers HTML, ainsi que la composition Web.

Votre fournisseur de services Internet peut fournir des informations qui vous aidera à choisir la méthode de publication qui vous convient le mieux.

Si vous publiez sur le web ou sur votre ordinateur, Office Publisher 2007 assemble tous les fichiers associés qu’il crée dans un seul dossier. Les fichiers que Office Publisher 2007 crée inclure les autres pages HTML qui composent votre site, GIF et JPEG graphiques que vous utilisez dans vos pages et les fichiers des sons incorporés.

Vous pouvez configurer Office Publisher 2007 pour organiser ces fichiers dans le dossier dans lequel vous publiez votre site Web de deux manières. Par défaut, Office Publisher 2007 crée une page d’accueil et un sous-dossier contenant tous les fichiers de prise en charge sont nécessaires pour votre site Web. Ou vous pouvez organiser la page d’accueil avec tous les fichiers de prise en charge pour votre site Web dans un seul dossier.

Comment contrôler l’endroit où Office Publisher 2007 organise le site Web il publie des fichiers ?

Dans le menu Outils, cliquez sur Options et cliquez sur l’onglet Web, puis effectuez l’une des opérations suivantes :

  • Pour séparer la page d’accueil parmi les fichiers de prise en charge, activez la case à cocher regrouper les fichiers de prise en charge dans un dossier.

  • Pour grouper la page d’accueil et tous les fichiers de prise en charge dans le même dossier, désactivez la case à cocher regrouper les fichiers de prise en charge dans un dossier.

Lorsque vous publiez une composition sur le web, Office Publisher 2007 crée des fichiers HTML filtrés, qui se propagent plus rapidement que les fichiers HTML non filtrés sur le web. Étant donné que le code HTML filtré fichiers ce Office Publisher 2007 crée ne contenir aucun balises spécifiques à Microsoft Office, vous ne pouvez pas ouvrir les fichiers HTML dans Office Publisher 2007 et à les modifier. Vous devez apporter des modifications à votre site Web dans la composition Web et republier ensuite le site sur le web.

Publier un site Web à un emplacement sur Internet ou un réseau

Avant de suivre cette procédure, contactez votre fournisseur de services Internet ou administrateur système pour obtenir les informations dont vous avez besoin pour publier et l’URL du site Web où vous pouvez enregistrer des fichiers.

  1. Dans le menu Fichier, cliquez sur Publier sur le Web.

  2. Dans la boîte de dialogue publier sur le Web, dans la zone nom de fichier, tapez l’URL du serveur web ou réseau dans lequel vous voulez enregistrer votre site Web. Par exemple, tapez http://www.northwindtraders.com.

  3. Cliquez sur Enregistrer.

  4. Si vous y êtes invité, entrez votre nom d'utilisateur et votre mot de passe, puis cliquez sur OK.

    Le répertoire associé à votre URL apparaîtra dans la boîte de dialogue publier sur le Web.

  5. Double-cliquez sur le dossier dans lequel vous voulez enregistrer votre site Web.

  6. Dans la zone Nom de fichier, sélectionnez index comme nom par défaut pour votre page d’accueil, puis cliquez sur Enregistrer.

    Index.htm est la sélection par défaut. Sélection d’index en tant que le nom de votre page d’accueil facilite l’accès et empêche les utilisateurs d’afficher une liste des fichiers qui composent votre site Web.

  7. À l'invite, cliquez sur OK.

Publier un site Web à l’aide de FTP

Avant de suivre cette procédure, contactez votre fournisseur de services Internet ou votre administrateur système pour obtenir les informations dont vous avez besoin pour publier sur un site FTP. Vous devez également créer un site FTP dans Des emplacements FTP.

Avant de pouvoir ajouter un site FTP à la liste des emplacements FTP, vous devez avoir accès à Internet ou à un intranet.

  1. Dans le menu Fichier, cliquez sur Publier sur le Web.

  2. Dans la boîte de dialogue publier sur le Web, cliquez sur Outils, puis cliquez sur connecter un lecteur réseau.

  3. Dans la boîte de dialogue connecter un lecteur réseau, procédez comme suit :

    • Dans la liste des lecteurs, cliquez sur une lettre de lecteur. Vous pouvez choisir n’importe quelle lettre disponible.

    • Pour vous connecter chaque fois que vous ouvrez une session sur votre ordinateur, activez la case à cocher se reconnecter à se connecter.

    • Cliquez sur se connecter à un site Web que vous pouvez utiliser pour stocker vos documents et des images.

  4. Dans l’Assistant Ajouter un emplacement réseau, cliquez sur suivant, cliquez sur Choisir un emplacement réseau personnalisé, puis sur suivant.

  5. Dans la zone adresse Internet ou réseau, tapez l’adresse du site FTP (par exemple, type ftp://ftp.microsoft.com), puis cliquez sur suivant.

    Remarque : Si vous ne pouvez pas vous connecter à un lecteur réseau ou un dossier, l’ordinateur peut être désactivé ou avez ne peut-être pas les autorisations appropriées. Si vous ne pouvez pas vous connecter, contactez votre administrateur réseau ou votre fournisseur de services Internet.

  6. Si vous ne souhaitez pas session anonyme, désactivez la case à cocher session anonyme, tapez un nom d’utilisateur dans la zone nom d’utilisateur, puis sur suivant.

  7. Tapez un nom pour cet emplacement réseau, puis cliquez sur suivant.

  8. Cliquez sur Terminer.

  9. Dans le menu Fichier, cliquez sur Publier sur le Web.

  10. Dans la liste Enregistrer dans, cliquez sur Adresses FTP.

  11. Dans la liste des sites FTP, double-cliquez sur le site que vous voulez et puis double-cliquez sur le dossier où vous souhaitez publier votre site Web.

    Remarque : Si votre fournisseur de services Internet, vous devez utiliser un programme spécifique pour télécharger votre site Web, ou si vous publiez votre site Web sur un réseau intranet, vous devrez peut-être enregistrer une version de votre site Web dans un format de fichier spécifique HTML et suivre une autre procédure pour publier votre site Web. Demandez à votre fournisseur de services Internet ou votre administrateur système pour savoir comment enregistrer et publier votre site Web.

Publier un site Web dans un dossier sur votre ordinateur

  1. Dans le menu Fichier, cliquez sur Publier sur le Web.

  2. Dans la barre d’adresses, cliquez sur le lecteur ou le dossier dans lequel vous voulez publier votre site Web, tels que votre dossier Documents.

    Si vous voulez ajouter votre site Web dans un nouveau dossier, cliquez sur Nouveau dossier dans la barre d’outils pour créer un dossier, tapez un nom pour le nouveau dossier, puis appuyez sur ENTRÉE.

  3. Dans la zone Nom de fichier, sélectionnez index comme nom par défaut pour votre page d’accueil, puis cliquez sur Enregistrer.

    Index.htm est la sélection par défaut. Sélection d’index en tant que le nom de votre page d’accueil facilite l’accès et empêche les utilisateurs d’afficher une liste des fichiers qui composent votre site Web.

Mettre à jour votre site Web

Une fois que vous publiez votre site Web, vous pouvez mettre à jour nécessaire pour refléter les nouvelles informations. Toutefois, vous ne pouvez pas ouvrir les fichiers HTML filtrés dans Publisher. Vous devez ouvrir la composition Web d’origine, apportez les modifications souhaitées et puis republier votre site sur le web.

Remarque : Vous devriez pas mettre à jour les fichiers HTML filtrés à l’aide d’un éditeur de texte, tel que Microsoft Notepad ou Microsoft WordPad. Même s’il est possible de le faire, générés par l’éditeur HTML est très complexe, et vous sera sans doute difficile à modifier manuellement. Pour obtenir de meilleurs résultats, toujours à jour votre site Web Publisher à l’aide de la composition Web, puis le republier sur le web.

Publier uniquement ce qui a changé

Dans Office Publisher 2007, vous pouvez publier des mises à jour à un site Web publié précédemment rapidement à l’aide d’incrémentielles publier sur le web, qui publie uniquement les pages que vous avez mis à jour. Si vous envisagez de mettre à jour votre site Web souvent, ou si votre site Web est grande et complexe, incrémentielles publier sur le web peut accélérer la tâche de mise à jour de votre site Web.

Si vous apportez des modifications à votre site Web directement sur un serveur web en dehors de Office Publisher 2007, cependant, activation incrémentielles publier sur le web peut-être vous empêcher de publier des mises à jour ultérieures à votre site Web à l’aide de la commande publier sur le Web. Si vous prévoyez de gérer vos fichiers de site Web directement sur le serveur web (par exemple via un programme distinct FTP ), vous devez désactiver incrémentielles publier sur le web.

Remarque : Changement publier sur le web est activé par défaut dans Publisher.

Activer incrémentiel publier sur le web ou désactiver

  1. Dans le menu Outils, cliquez sur Options, puis cliquez sur l’onglet Web.

  2. Sous Enregistrer, effectuez l’une des opérations suivantes :

    • Pour désactiver les incrémentielles publier sur le web, désactivez la case à cocher Activer incrémentiel publier sur le Web.

    • Activer les incrémentielles publier sur le web, activez la case à cocher Activer incrémentiel publier sur le Web.

Publier les modifications apportées à votre site Web

Mises à jour de publication à un site Web est légèrement différente de publier un site Web pour la première fois. Une fois que vous publiez un site Web à un emplacement sur le web ou sur un réseau, un raccourci vers le serveur web ou un serveur réseau s’affiche dans le dossier Favoris réseau.

  1. Dans le menu Fichier, cliquez sur Publier sur le Web.

  2. Dans la boîte de dialogue publier sur le Web, dans le volet de navigation, cliquez sur Ce PC.

  3. Dans la liste des fichiers, double-cliquez sur le raccourci vers le dossier sur le serveur web ou un serveur réseau où vous avez publié votre site Web.

  4. Double-cliquez sur le dossier dans lequel vous voulez enregistrer le fichier.

  5. Dans la zone nom de fichier, tapez le nom du fichier que vous mettez à jour, puis cliquez sur Enregistrer.

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×