NON (NON, fonction)

Lorsque vous voulez vous assurer qu’une valeur n’est pas égale à une autre, utilisez la fonction PAS, l’une des fonctions logiques.

Exemple

Exemples d’utilisation de la fonction NON pour inverser des arguments  PAR EXEMPLE =NON(1+1=2)

La fonction NON inverse la valeur de son argument.

La fonction NON est couramment utilisée pour étendre l’utilité d’autres fonctions qui effectuent des tests logiques. Par exemple, la fonction SI effectue un test logique, puis renvoie une valeur si le résultat du test est VRAI, et une autre valeur si le résultat du test est FAUX. En utilisant la fonction NON en tant qu’argument test_logique de la fonction SI, vous pouvez tester un grand nombre de conditions différentes au lien d’une seule.

Syntaxe

NON(valeur_logique)

La syntaxe de la fonction NON comporte les arguments suivants :

  • valeur_logique    Obligatoire. Représente une valeur ou expression qui peut prendre la valeur VRAI ou FAUX.

Remarques

Si valeur_logique a la valeur FAUX, NON renvoie VRAI, et si valeur_logique a la valeur VRAI, NON renvoie FAUX.

Exemples

Voici quelques exemples généraux d’utilisation de la fonction NON isolément ou conjointement avec les fonctions SI, ET et OU.

Exemples d’utilisation de la fonction NON avec les fonctions SI, ET et OU

Formule

Description

=NON(A2>100)

A2 est NON supérieur à 100

=SI(ET(NON(A2>1);NON(A2<100));A2;"La valeur est hors limites")

50 étant supérieur à 1 (VRAI), ET 50 inférieur à 100 (VRAI), NON inverse les deux arguments en FAUX. La fonction ET exigeant que les deux arguments soient VRAI, elle retourne le résultat s’il est FAUX.

=SI(OU(NON(A3<0);NON(A3>50));A3;"La valeur est hors limites")

100 n’étant pas inférieur à 0 (FAUX) et étant supérieur à 50 (VRAI), NON inverse les arguments en VRAI/FAUX. La fonction OU exigeant uniquement qu’un argument soit VRAI, elle retourne le résultat s’il est VRAI.

Calcul de commission de ventes

Voici un scénario assez courant dans le cadre duquel il s’agit de calculer si un représentant commercial a droit à une prime en utilisant la fonction NON avec SI et ET.

Exemple de calcul de prime de ventes avec les fonctions ET, SI et NON.  La formule dans la cellule E14 est =SI(ET(NON(B14<$B$7),NON(C14<$B$5)),B14*$B$8,0)
  • =SI(ET(NON(B14<$B$7);NON(C14<$B$5)),B14*$B$8;0)- SI Total Sales est NON inférieur à Sales Goal, ET Accounts est NON inférieure à Account Goal, multiplier Total Sales par Commission %, sinon retourner 0.

Vous avez besoin d’une aide supplémentaire ?

Vous pouvez toujours consulter un expert de la communauté technique Excel, obtenir une assistance dans la communauté Answers ou suggérer une nouvelle fonctionnalité ou une amélioration sur le forum Excel User Voice.

Rubriques connexes

Vidéo : fonctions SI avancées
Découvrez comment utiliser des fonctions imbriquées dans une formule
Fonction SI
Fonction ET
Fonction OU
Vue d’ensemble des formules dans Excel
Comment éviter les formules incorrectes
Corriger les erreurs courantes dans les formules à l’aide de la vérification des erreurs
Raccourcis clavier dans Excel 2016 pour Windows
Raccourcis clavier dans Excel 2016 pour Mac
Fonctions logiques (référence)
Fonctions Excel (par ordre alphabétique)
Fonctions Excel (par catégorie)

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×