Modifier, supprimer ou insérer des enregistrements dans un affichage de données

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Lorsque vous avez créé un affichage de données dont la source se trouve dans une liste ou une bibliothèque SharePoint, une base de données SQL ou un fichier XML, vous ajoutez facilement des liens pour modifier, supprimer ou insérer des enregistrements dans la source des données à l'aide du navigateur.

Par exemple, la sociétéNorthwind Traders, entreprise de distribution de produits alimentaires d'épicerie fine, utilise un fichier XML pour effectuer son suivi d'inventaire. Lorsque le stock est faible, un employé appelle le fournisseur de ce produit et passe une commande. Vous suggérez d'ajouter des liens pour modifier l'affichage des données, de façon que l'employé qui passe la commande puisse immédiatement mettre à jour l'enregistrement du produit. Vous pouvez également insérer et supprimer des liens vers l'affichage de données afin que les employés puissent ajouter ou supprimer des produits. Ainsi, Northwind Traders dispose toujours des informations les plus récentes sur son stock actuel.

Cet article vous explique comment ajouter, modifier, supprimer et insérer des liens vers une vue de données existante. Pour créer les données et la vue de données qui sont utilisées dans cet exemple, ou pour en savoir plus sur les vues de données, voir l’article créer une vue de données.

Dans cet article

Avant de commencer

Ajouter des liens pour modifier, supprimer ou insérer des enregistrements dans une vue de données

Modifier, supprimer ou insérer un enregistrement via le navigateur

Personnaliser les modèles de modification ou d’insertion

Avant de commencer

Microsoft Office SharePoint Designer 2007 comporte deux fonctionnalités indépendantes qui permettent aux utilisateurs de modifier les données d'un affichage de données à l'aide du navigateur :

  • Ajouter des liens à un affichage de données existant     Vous pouvez ajouter des liens vers un affichage de données existant de façon que les utilisateurs puissent modifier, supprimer ou insérer des enregistrements dans la source des données. Les utilisateurs cliquent sur le lien modifier d'un enregistrement afin que cet élément passe en mode édition. Si vous ajoutez des liens vers un affichage de données inséré en tant que formulaire, ces liens remplacent les boutons du formulaire. De plus, si vous ajoutez des liens vers un affichage de données inséré en tant que formulaire, cette vue des données n'affiche plus les champs du formulaire par défaut ; par défaut, il affiche uniquement les données dans une vue.

  • Insérer une vue de données en tant que formulaire     Lorsque vous créez une vue de données, vous pouvez choisir Insérer en tant qu’un seul élément ou à plusieurs éléments un formulaire. Le formulaire est toujours en mode édition et affiche un ou plusieurs enregistrements. Les utilisateurs peuvent modifier les enregistrements existants via le navigateur, mais ils ne peuvent pas insérer ou supprimer des enregistrements. Vous souhaiterez peut-être choisir un formulaire à plusieurs éléments si les utilisateurs sont susceptibles d’à modifier rapidement les données dans plusieurs enregistrements en même temps. Pour plus d’informations, voir l’article Insérer une vue de données en tant que formulaire.

Formats des données

Cet exemple utilise un fichier XML comme source de données. Du fait qu'un fichier XML est un pur fichier texte, il n'est pas possible de spécifier les types des valeurs que chaque champ doit contenir. Par exemple, rien ne vous empêche de taper et d'enregistrer du texte qui doivent contenir des chiffres/nombres (ex. UnitsOnOrder).

Cependant, si votre source de données est une base de données ou une liste ou une bibliothèque SharePoint, vous pouvez, lorsque vous créez la base de données, la liste ou la bibliothèque, de spécifier les types des valeurs que chaque champ peut contenir. Dans ce cas, si vous utilisez le formulaire pour taper du texte dans un champ qui nécessite des nombres, et si vous cliquez ensuite sur Enregistrer, vous recevez un message d'erreur qui indique que le contrôle de la source de données n'a pas pu exécuter la commande de mise à jour. Cela est dû au fait que vous tapez une valeur que le champ de la source de données ne peut accepter. Si vous recevez ce type de message, cliquez sur le bouton Précédent du navigateur. Cliquez ensuite sur Annuler dans le formulaire pour abandonner vos modifications ou tapez une valeur acceptable par la source de données.

Lorsque vous concevez le formulaire, vous voudrez peut-être inclure une note dans chaque en-tête de colonne pour indiquer le type de données exigé par ce champ.

Haut de la Page

Ajouter des liens pour modifier, supprimer ou insérer des enregistrements dans un affichage de données

Il est possible d'ajouter ces liens dans n'importe quel affichage de données, qu'il ait été inséré en tant que vue ou formulaire. Cependant, si vous ajoutez des liens vers un affichage de données inséré en tant que formulaire, ces liens remplacent les boutons du formulaire. De plus, si vous ajoutez des liens vers un affichage de données inséré en tant que formulaire, cette vue des données n'affiche plus les champs du formulaire ; il affiche uniquement les données dans une vue. Il n'est pas possible d'avoir un affichage de données qui propose à la fois les boutons et les liens en utilisant ces fonctionnalités.

  1. Ouvrez la page qui contient la vue de données à laquelle vous souhaitez ajouter une des liens.

    Pour suivre cet exemple, utilisez la vue de données que vous avez créé dans créer une vue de données.

    Fichier Products.xml tel qu'il apparaît dans une vue de données

  2. Cliquez sur la vue de données, cliquez sur la flèche Image du bouton dans le coin supérieur droit pour afficher la liste de Tâches vue de données, puis cliquez sur Propriétés vue de données. Cliquez sur la flèche à nouveau pour masquer la liste.

    Conseil : Vous pouvez également cliquer sur Affichage des données, puis sur Afficher les tâches du contrôle commun dans le menu contextuel.

  3. Dans la boîte de dialogue Propriétés de la vue de données, cliquez sur l'onglet Modification.

  4. Dans l'onglet Image, sous Options des liens, effectuez une ou plusieurs opérations suivantes :

    • Pour ajouter un lien afin de modifier un enregistrement, cochez la case Afficher les liens de modification des éléments .

    • Pour ajouter un lien afin de supprimer un enregistrement, cochez la case Afficher les liens de suppression des éléments.

    • Pour ajouter un lien afin d'insérer un nouvel enregistrement, cochez la case Afficher les liens d'insertion des éléments.

      Dans cet exemple, cochez les cases Afficher les liens de modification des éléments, Afficher les liens de suppression des éléments et Afficher les liens d'insertion d'un élément.

      Onglet Edition de la boîte de dialogue Propriétés de la vue de données

      Remarque : L'exemple précédent est propre aux fichiers XML. Lorsque vous travaillez avec des bases de données SQL, l'onglet Edition de la boîte de dialogue Propriétés de la vue de données propose également l'option Options de synchronisation automatique des commandes. Lorsque cette option est sélectionnée, les commandes de mise à jour, de suppression et d'insertion de la source de données SQL sont synchronisées avec les contrôles correspondants dans l'affichage des données.

  5. Cliquez sur OK.

    Chaque enregistrement de l'affichage des données est alors précédé d'un lien Edition et d'un lien Supprimer. Dans le coin inférieur gauche de l'affichage des données figure un lien Insérer.

    Affichage de données à plusieurs éléments avec des liens d'insertion, de modification et de suppression

  6. Dans le menu Fichier, cliquez sur Enregistrer sous.

  7. Dans la boîte de dialogue Enregistrer sous, tapez un nom dans le champ Nom de fichier, puis cliquez sur Enregistrer.

Haut de la Page

Modifier, supprimer ou insérer un enregistrement à l'aide du navigateur

Lorsque vous avez enregistré la page qui contient le formulaire, vous pouvez afficher son aperçu dans le navigateur et modifier les données du formulaire.

Aperçu de l'affichage des données dans le navigateur

  • Dans Office SharePoint Designer 2007, dans le menu Fichier, cliquez sur Aperçu dans le navigateur, puis sur le type et la taille du navigateur que vous voulez utiliser.

    Raccourci clavier cliquez sur la page que vous souhaitez afficher un aperçu dans la liste des dossiers et appuyez sur F12.

    L'affichage des données qui contient les liens apparaît dans le navigateur.

    Affichage des données avec les liens tel qu'il apparaît dans le navigateur

Modifier un enregistrement

  1. Cliquez sur le lien Edition de l'enregistrement que vous voulez modifier.

    Pour suivre l’exemple, cliquez sur le lien ModifierChai. Une vue de données qui contient un formulaire de données pour la Chai enregistrement s’affiche.

    Enregistrement unique dans une vue de données en mode Edition

    Remarques : 

    • Lorsque vous travaillez avec des listes et des bibliothèques SharePoint, les contrôles de modification ne sont pas des zones de texte, mais des contrôles de champs de formulaires SharePoint.

    • Lorsque vous travaillez avec des fichiers en lecture seule (ex. ID dans une liste SharePoint ou une base de données SQL), le champ est uniquement affiché : il n'est pas modifiable.

    Vous pouvez désormais modifier les informations qui s’affiche dans le enregistrement Chai.

  2. Modifiez les données de cet enregistrement, puis cliquez sur Enregistrer pour conserver vos modifications, ou cliquez sur annuler pour les ignorer et revenir à l'affichage des données.

    Pour suivre l’exemple, dans la zone de la colonne UnitsOnOrder , tapez 40, puis cliquez sur Enregistrer à gauche de la enregistrement Chai.

    La vue des données s'affiche avec l'enregistrement mis à jour.

    Enregistrement avec la valeur UnitsOnOrder

Supprimer un enregistrement

  • Cliquez sur le lien Supprimer à gauche de l'enregistrement que vous voulez supprimer.

    Important : Lorsque vous supprimez un enregistrement à l'aide du navigateur, aucune invite ne vous demande de confirmer la suppression. Il n'existe aucun moyen de récupérer un enregistrement supprimé.

    Pour suivre l’exemple, cliquez sur Supprimer le lien vers la gauche du Chang dans la liste ProductName . Une vue de données qui contient uniquement quatre enregistrements s’affiche.

    Seuls 4 enregistrements apparaissent dans la vue des données

Insérer un enregistrement

  1. Cliquez sur le lien Insérer dans le coin inférieur gauche de la vue des données.

    Un enregistrement avec des champs de formulaire vides s'affiche.

    Enregistrement avec des champs de formulaire vides qui s'affichent lorsque vous cliquez sur le lien d'insertion

    Vous ne pouvez pas insérer un nouvel enregistrement.

  2. Tapez les données de cet enregistrement, puis cliquez sur enregistrer pour conserver vos modifications, ou cliquez sur annuler pour les ignorer et revenir à l'affichage des données.

    Pour suivre l’exemple, dans la zone dans la colonne ProductName , tapez Boysenberry réparties de Mamie. Dans la zone dans la colonne unités en stock , tapez 120. Dans la zone de la colonne UnitsOnOrder , tapez 0. Dans la zone de la colonne ReorderLevel , tapez 25. Cliquez sur Enregistrer. Une vue de données avec le nouvel enregistrement s’affiche.

    Le nouvel enregistrement inséré s'affiche dans la vue des données

Haut de la Page

Personnaliser les modèles de modification ou d'insertion

L'utilisation d'une vue des données pour l'insertion ou la modification d'enregistrements fonctionne légèrement différemment de, par exemple, l'utilisation de formulaires de listes (ex. NewForm.aspx ou EditForm.aspx) pour ajouter ou modifier des éléments dans une liste SharePoint. Une liste ou une bibliothèque affiche une page différente pour les utilisateurs lorsqu'ils veulent ajouter ou modifier des éléments : une vue des données s'affiche dans un mode différent. Toutefois, chaque mode comporte un modèle totalement personnalisable. Par exemple, si vous personnalisez le modèle de modification, les utilisateurs voient ces personnalisations uniquement lorsqu'ils cliquent sur le lien de modification pour placer la vue des données en mode édition.

Vous voudrez peut-être personnaliser chaque modèle de mode lorsque, par exemple, vous voulez proposer aux utilisateurs des instructions particulières lors de l'insertion ou de la modification d'enregistrements. Vous pouvez facilement insérer une nouvelle ligne sous les en-têtes des colonnes, puis utiliser cette ligne pour taper du texte indiquant le type de données à taper dans chaque colonne, ainsi que le format de ces données (texte, nombre, etc.).

  1. Cliquez sur la vue de données, puis cliquez sur la flèche Image du bouton dans le coin supérieur droit pour afficher la liste de Tâches vue de données.

    Conseil : Vous pouvez également cliquer sur Affichage des données, puis sur Afficher les tâches du contrôle commun dans le menu contextuel.

  2. Dans la liste Aperçu de la vue de données, cliquez sur Modifier le modèle ou sur Insérer un modèle.

    Le modèle de ce mode s'affiche dans la vue des données. Vous modifier la police, la mise en forme ou la disposition du formulaire pour personnaliser la structure et l'aspect du modèle.

  3. Pour enregistrer vos modifications, dans le menu Fichier, cliquez sur Enregistrer.

  4. Pour obtenir un aperçu du modèle dans le navigateur, dans le menu Fichier menu, cliquez sur Aperçu dans le navigateur, puis cliquez sur le type de navigateur et la taille que vous voulez utiliser.

    Raccourci clavier cliquez sur la page que vous souhaitez afficher un aperçu dans la liste des dossiers et appuyez sur F12.

Lorsque vous ouvrez la vue des données dans le navigateur et cliquez sur Edition ou Insérer, le modèle personnalisé que vous avez créé s'affiche.

Haut de la Page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×