Mise en route d'Access 2007

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

La mise en route de Microsoft Office Access 2007 peut s'effectuer de plusieurs façons. Les procédures diffèrent selon que vous utilisez Access pour la première fois, que vous déplacez des données d'un autre programme de base de données ou tableur vers Access ou que vous procédez à la mise à niveau d'une version antérieure d'Access. Cet article traite de diverses questions qui peuvent se poser dans ces trois situations.

Que voulez-vous faire ?

Commencer à utiliser Access pour la première fois

Importer des données d’une feuille de calcul ou un autre programme

Utiliser une version antérieure de base de données dans plusieurs versions d’Access

Utiliser Access pour la première fois

Office Access 2007 offre de nombreuses améliorations : jamais la création d'une base de données n'aura été aussi facile. Les utilisateurs ayant déjà créé des bases de données dans Access sauront apprécier ces nouvelles fonctionnalités améliorées et le gain de temps qu'elles procurent.

Au démarrage d'Office Access 2007, le premier écran à s'afficher est la page Prise en main de Microsoft Office Access, à moins d'avoir démarré Access en double-cliquant sur un fichier de base de données Access spécifique, auquel cas c'est la base de données qui s'ouvre. La page Prise en main de Microsoft Office Access est le point de départ à partir duquel vous allez pouvoir créer une base de données, ouvrir une base de données existante ou consulter le contenu proposé dans Microsoft Office Online.

Créer une base de données en utilisant un modèle

Télécharger un modèle à partir de Microsoft Office Online

Créer une base de données à partir de zéro

Créer une base de données vide

Ajouter un tableau

Coller des données à partir d’une autre source dans une table Access

Importer des données à partir d’une autre source

Ouvrir une base de données Access existante

Access 2010 offre de puissants outils qui facilitent la suivre, état et partagez vos données.

Créer une base de données à l’aide d’un modèle

Access fournit de nombreux modèles accélérant la création de vos bases de données. Un modèle est une base de données prête à l’emploi contenant la totalité des tables, des requêtes, des formulaires et des états requis pour effectuer une certaine tâche. Par exemple, vous pouvez avoir recours à des modèles pour assurer le suivi des problèmes, pour gérer vos contacts ou pour enregistrer vos notes de frais. Certains modèles contiennent plusieurs exemples d’enregistrements dans un but illustratif. Vous pouvez utiliser ces modèles de base de données tels quels ou les personnaliser en fonction de vos besoins.

  1. Démarrez Access s'il n'est déjà pas en cours d'exécution.

    Si une base de données est déjà ouverte, procédez comme suit pour afficher la page Prise en main de Microsoft Office Access :

    • Cliquez sur le Bouton Microsoft Office Image du bouton Office , puis cliquez sur Fermer de base de données. Image du bouton

      Page Prise en main de Microsoft Office Access

  2. Plusieurs modèles s’affichent sous Modèles en ligne dans la page Prise en main de Microsoft Office Access, et plus devient pas disponibles si vous sélectionnez une des catégories sous Catégories de modèles sur le côté gauche de la Fenêtre Access. Toujours plus pouvant être téléchargés à partir du site Web de Microsoft Office (voir la section suivante, télécharger un modèle à partir de Microsoft Office Online, pour plus d’informations).

  3. Cliquez sur le modèle voulu.

  4. Dans le volet situé à droite de la fenêtre Access, un nom de fichier affiché dans la zone Nom de fichier est suggéré pour la base de données. Vous pouvez modifier ce nom et préciser un autre dossier. Vous pouvez aussi créer votre base de données et la lier à un site Windows SharePoint Services 3.0.

  5. Cliquez sur le bouton Créer (ou sur le bouton Télécharger pour ouvrir un modèle Office Online).

    Access crée et ouvre la base de données. Un formulaire s'affiche, dans lequel vous pouvez entrer vos données.

    Si le modèle contient des données exemples, vous pouvez supprimer chaque enregistrement comme suit :

    • Cliquez sur l'en-tête de ligne pour l'enregistrement que vous souhaitez supprimer. (L'en-tête de ligne est la zone ou la barre située à gauche de l'enregistrement.)

    • Sous l’onglet accueil, dans le groupe enregistrements, cliquez sur Supprimer. Image du bouton

  6. Pour commencer à entrer des données, cliquez d'abord sur la première cellule vide du formulaire et commencez à taper. Après avoir entré quelques enregistrements, vous pouvez utiliser le volet de navigation pour vérifier si vous souhaitez utiliser d'autres formulaires ou états.

Télécharger un modèle sur le site Microsoft Office Online

Si vous ne trouvez aucun modèle répondant à vos besoins dans la page Prise en main de Microsoft Office Access, sachez que le site Web Microsoft Office Online propose un large éventail de modèles.

  1. Démarrez Access s'il n'est déjà pas en cours d'exécution.

    Si une base de données est déjà ouverte, procédez comme suit pour afficher la page Prise en main de Microsoft Office Access :

    • Cliquez sur le Bouton Microsoft Office Image du bouton Office , puis cliquez sur Fermer de base de données. Image du bouton

  2. Dans la partie inférieure de la page Prise en main de Microsoft Office Access, sous Informations supplémentaires sur Office Online, cliquez sur Modèles.

    Le site Web Microsoft Office Online s'affiche dans une nouvelle fenêtre de navigateur.

  3. Utilisez les outils de recherche du site Web Microsoft Office Online pour rechercher et télécharger le modèle souhaité.

  4. Après le téléchargement d'un modèle, la nouvelle base de données est stockée dans l'un des dossiers suivants :

    • Windows Vista    c:\Users\user name\Documents

    • Microsoft Windows Server 2003 ou Microsoft Windows XP    c:\Documents et Settings\nom plus Documents

      La prochaine fois que vous souhaiterez accéder à la base de données, utilisez Access ou l'Explorateur Windows pour l'ouvrir à partir de ce dossier.

Haut de la section

Créer une base de données entièrement nouvelle

Si aucun modèle ne vous satisfait ou si vous souhaitez importer des données provenant d'un autre programme vers Access, vous préférerez peut-être créer une toute nouvelle base de données. Pour la plupart des applications, vous devez pour cela effectuer l'une des opérations suivantes ou les deux :

  • créer de nouvelles tables, puis entrer, coller ou importer des données dans ces tables ;

  • importer des données provenant d'autres sources, ce qui a pour résultat de créer de nouvelles tables.

Pour en savoir plus sur la planification et la conception d'une base de données ou sur la création de relations, de formulaires, d'états ou de requêtes, suivez les liens de la section Voir aussi dans cet article.

Créer une base de données vide

  1. Démarrez Access.

  2. Dans la page Prise en main de Microsoft Office Access, cliquez sur Base de données vide.

    Bouter Base de données vide

  3. Dans le volet Base de données vide, tapez un nom de fichier dans la zone Nom de fichier. Si vous ne précisez pas l'extension du nom de fichier, Access l'ajoute automatiquement. L'emplacement par défaut du fichier est l'un des dossiers suivants :

    • Windows Vista    c:\Users\user name\Documents

    • Microsoft Windows Server 2003 ou Microsoft Windows XP    c:\Documents et Settings\nom plus Documents

      Pour modifier l’emplacement du fichier, cliquez sur Parcourir Image du bouton en regard de la zone Nom de fichier, naviguez jusqu’au et sélectionner le nouvel emplacement, puis cliquez sur OK.

  4. Cliquez sur Créer.

    Access crée la base de données, puis ouvre une table vide (intitulée Table1) en mode Feuille de données.

  5. Access place le curseur dans la première cellule vide de la colonne Ajouter un nouveau champ.

    Table vide créée dans une nouvelle base de données

    Pour ajouter des données, commencez à taper, ou vous pouvez coller des données à partir d’une autre source, comme décrit dans la section Coller des données à partir d’une autre source dans une table Access, plus loin dans cet article.

    Remarques : 

    • L'entrée de données en mode Feuille de données est fort semblable à l'entrée de données dans une feuille de calcul Excel. La principale contrainte est qu'il est obligatoire d'entrer les données dans des lignes et des colonnes contiguës, en commençant par l'angle supérieur gauche de la feuille de données. N'essayez pas de mettre en forme vos données en insérant des lignes ou des colonnes vides, comme vous le feriez dans une feuille de calcul Excel. En effet, cette opération se soldera par une perte d'espace dans la table. La table ne contient que les données. Toute la présentation visuelle de ces dernières sera appliquée dans les formulaires et les états créés ultérieurement.

    • La structure de la table est créée lors de l'entrée des données. Un nouveau champ est défini à chaque ajout d'une colonne. Access définit le type de données du champ en fonction du type de données que vous entrez. Par exemple, si la table contient une colonne dans laquelle vous n'avez renseigné que des dates, Access attribue le type de données Date/Heure à ce champ. Par la suite, si vous essayez d'entrer une valeur qui n'est pas une date (comme un nom ou un numéro de téléphone) dans ce champ, Access affiche un message vous informant que cette valeur ne correspond pas au type de données de cette colonne. Dans la mesure du possible, pensez à concevoir une table où chaque colonne contient un type de données unique, que ce soit du texte, des dates, des nombres ou toute autre valeur. C'est ainsi que vous faciliterez la génération de requêtes, de formulaires et d'états qui sélectionnent uniquement les données souhaitées.

    • Pour plus d’informations sur l’utilisation des feuilles de données, voir l’article Ouvrir une feuille de données vide.

Si vous n’êtes pas d’informations sur la saisie de données pour le moment, cliquez sur Fermer image du bouton .

Ajouter une table

Vous pouvez ajouter une nouvelle table à une base de données existante en utilisant les outils du groupe Tables sous l’onglet Créer.

Ruban d'images Access

Cliquez sur Table pour créer une table vide en mode Feuille de données. Vous pouvez recourir au mode Feuille de données pour entamer immédiatement l'entrée des données et pour permettre à Access de créer la structure de table au fur et à mesure. Vous pouvez aussi utiliser le mode Création pour créer la structure de table dans un premier temps, puis basculer de nouveau en mode Feuille de données et entrer vos données. Quel que soit le mode utilisé en premier lieu, vous pouvez basculer de l'un à l'autre grâce aux boutons de modes d'affichage situés dans la barre d'état de la fenêtre Access.

Insérer une table, en commençant en mode Feuille de données    En mode Feuille de données, vous pouvez entrer des données immédiatement et laisser Access générer une structure de table en arrière-plan. Les noms sont attribués aux champs par incréments numériques (Champ1, Champ2, etc.) et Access définit leur type de données en fonction du type de données que vous y entrez.

  1. Sous l’onglet créer, dans le groupe tableaux, cliquez sur tableau. Image du bouton

  2. Access crée la table puis place le curseur dans la première cellule vide de la colonne Ajouter un nouveau champ.

    Remarque : Si vous ne voyez pas de colonne intitulée Ajouter un nouveau champ, sans doute êtes-vous en mode Création et non en mode Feuille de données. Pour basculer en mode Feuille de données, double-cliquez sur la table dans le volet de navigation. Vous êtes invité à entrer un nom pour la nouvelle table, puis le mode Feuille de données est activé automatiquement.

  3. Sous l’onglet feuille de données, dans le groupe champs et colonnes, cliquez sur Nouveau champ. Image du bouton

    Access affiche le volet Modèles de champ, qui contient une liste des champs couramment utilisés. Si vous faites glisser un de ces champs dans la feuille de données, Access ajoute le champ avec ce nom et définit ses propriétés comme il se doit. Vous pouvez modifier ces propriétés ultérieurement. Vous devez faire glisser ce champ dans la zone de la feuille de données contenant des données. Une barre d'insertion verticale s'affiche, vous indiquant l'emplacement du champ.

  4. Pour ajouter des données, commencez à les taper dans la première cellule vide ; vous pouvez également les coller à partir d'une autre source, comme décrit plus loin dans cet article.

    • Pour renommer une colonne (un champ), double-cliquez sur l'en-tête de colonne, puis tapez le nouveau nom. Il est important de choisir un nom descriptif pour chaque champ (en d'autres termes, un nom expliquant son contenu), afin d'identifier facilement les champs dans le volet liste de champs.

    • Pour déplacer une colonne, sélectionnez-la en cliquant sur son en-tête avant de la faire glisser à l'emplacement souhaité. Vous pouvez également sélectionner plusieurs colonnes contiguës et toutes les faire glisser vers une nouvelle destination.

Insérer une table, en commençant en mode Création    En mode Création, vous devez d'abord créer la structure de la nouvelle table. Vous pouvez ensuite basculer en mode Feuille de données pour entrer des données, ou bien vous pouvez entrer des données à l'aide d'une autre méthode telle que le collage ou l'ajout.

  1. Sous l’onglet créer, dans le groupe tableaux, cliquez sur Création de Table. Image du bouton

  2. Pour chaque champ de votre table, tapez un nom dans la colonne Nom du champ puis sélectionnez un type de données dans la liste Type de données.

    Remarque : Si vous ne voyez pas les colonnes Nom du champ et Type de données, sans doute êtes-vous en mode Feuille de données et non en mode Création. Pour basculer en mode Création, cliquez sur le bouton Mode Création dans la barre d'état de la fenêtre Access. Vous êtes invité à entrer un nom pour la nouvelle table, puis le mode Création est activé automatiquement.

  3. Vous pouvez entrer une description pour chaque champ dans la colonne Description. Cette description s'affiche dans la barre d'état lorsque le point d'insertion se trouve dans ce champ et lorsqu'il est utilisé comme texte de la barre d'état pour tous les contrôles que vous créez en faisant glisser le champ du volet liste de champs vers un formulaire ou un état, ainsi que pour tous les contrôles créés pour ce champ par le biais de l'Assistant Formulaire ou État.

  4. Après avoir ajouté tous les champs, enregistrez la table.

    • Cliquez sur le Bouton Microsoft Office Image du bouton Office puis cliquez sur Enregistrer ou appuyez sur CTRL + S.

  5. Vous pouvez commencer à entrer des données dans la table à tout moment en basculant en mode Feuille de données, en cliquant sur la première cellule vide puis en tapant les données. Vous pouvez par ailleurs coller des données à partir d'une autre source, comme décrit dans la section suivante.

Après avoir entré des données, si vous souhaitez ajouter un ou plusieurs champs dans votre table, vous pouvez soit taper des valeurs dans la colonne Ajouter un nouveau champ en mode Feuille de données, soit ajouter des champs à l'aide des commandes du groupe Champs et colonnes dans l'onglet Feuille de données.

Pour plus d’informations sur la création de tableaux, y compris l’utilisation de modèles de table, voir l’article créer des tables dans une base de données.

Haut de la section

Coller des données d'une autre source dans une table Access

Si les données qui vous intéressent sont stockées dans un autre programme, par exemple dans Office Excel 2007, vous pouvez les copier puis les coller dans une table Access. En règle générale, les résultats sont optimisés si les données sont déjà séparées en colonnes, comme c'est le cas dans une feuille de calcul Excel. Si les données se trouvent dans un programme de traitement de texte, il est préférable de les séparer à l'aide de tabulations ou de les convertir en tableau dans le programme de traitement de texte, avant de les copier. Si vous devez modifier ou manipuler les données (par exemple, séparer des noms complets en prénoms et noms de famille), faites-le avant de les copier , en particulier si vous ne connaissez pas très bien les fonctionnalités d'Access.

Lorsque vous collez des données dans une table vide, le type de données de chaque champ est automatiquement défini en fonction du type des données collées. Par exemple, si un champ collé ne contient que des dates, Access lui applique le type de données Date/Heure. Si le champ collé ne contient que les mots « oui » et « non », Access lui applique alors le type de données Oui/Non.

Pour attribuer le nom des champs, Access se base sur le contenu de la première ligne de données collées. Si le type de cette ligne est similaire aux lignes suivantes, Access détermine que la première ligne fait partie des données et attribue aux champs des noms génériques (F1, F2, etc.). Si la première ligne de données collées n'est pas similaire aux lignes suivantes, Access détermine qu'elle est constituée de noms de champs. Les champs sont alors nommés en conséquence et la première ligne n'est pas incluse dans les données.

Si Access attribue des noms de champ génériques, renommez les champs dès que possible pour éviter toute confusion. Suivez la procédure ci-dessous :

  1. Enregistrez la table.

    • Cliquez sur le Bouton Microsoft Office Image du bouton Office puis cliquez sur Enregistrer ou appuyez sur CTRL + S.

  2. En mode Feuille de données, double-cliquez sur l'en-tête de chaque colonne, puis tapez un nom de champ valide. Cette opération peut s'apparenter au remplacement de données, mais n'oubliez pas que la ligne d'en-têtes de colonne ne contient pas de données, mais bien des noms de champs.

  3. Enregistrez à nouveau la table.

Remarque : Pour renommer un champ, vous pouvez également activer le mode Création et modifier le nom du champ. Pour passer en mode Création, cliquez avec le bouton droit sur la table dans le volet de navigation, puis cliquez sur Mode Création. Pour réactiver le mode Feuille de données, double-cliquez sur la table dans le volet de navigation.

Haut de la section

Importer des données provenant d'une autre source

Il se peut que vous ayez collecté des données dans un autre programme et que vous souhaitiez les importer dans Access. Autre éventualité : vous pouvez collaborer avec des personnes qui stockent leurs données dans d'autres programmes et vouloir manipuler leurs informations dans Access. Quel que soit le cas de figure, Access facilite l'importation de données à partir d'autres programmes. Vous pouvez importer des données provenant d'une feuille de calcul Excel, d'une table appartenant à une autre base de données Access, d'une liste SharePoint ou de tout un éventail d'autres sources. Le processus varie légèrement en fonction de la source choisie, mais les instructions ci-dessous faciliteront la mise en route :

  1. Sous l'onglet Données externes, dans le groupe Importer, cliquez sur la commande correspondant au type de fichier à importer.

    Ruban d'images Access

    Par exemple, si vous importez des données d'une feuille de calcul Excel, cliquez sur Excel. Si le type de programme correct n'est pas affiché, cliquez sur Plus.

    Remarque : Si le type de format adéquat n'apparaît pas dans le groupe Importer, il vous faudra peut-être démarrer le programme dans lequel les données ont été créées, puis utiliser ce programme pour enregistrer les données dans un format de fichier courant (fichier texte délimité, par exemple) avant de les importer dans Access.

  2. Dans la boîte de dialogue Données externes, cliquez sur le bouton Parcourir pour accéder au fichier de données source ou tapez le chemin d'accès complet de ce fichier dans la zone Nom du fichier.

  3. Cliquez sur l'option souhaitée dans la zone Spécifiez le mode et l'emplacement de stockage des données dans la base de données active. Vous pouvez créer une table en utilisant les données importées, ajouter les données à une table existante ou créer une table attachée qui conserve un lien avec la source de données.

  4. Cliquez sur OK.

    Access démarre l'Assistant Importation.

  5. Suivez les instructions de l'Assistant Importation. La procédure exacte dépend de l'option d'importation ou de liaison choisie.

  6. Dans la dernière page de l'Assistant, cliquez sur Terminer.

    Vous devez indiquer si vous souhaitez enregistrer le détail de l'importation à peine terminée.

    • Si vous pensez renouveler cette importation, cliquez sur Enregistrer les étapes d'importation puis entrez les détails.

      Vous pouvez ensuite facilement reproduire l’opération d’importation en cliquant successivement sur Importations enregistrées dans le groupe Importer de l’onglet Données externes, sur la spécification d’importation, puis sur Exécuter.

    • Si vous ne souhaitez pas enregistrer les détails de cette opération, cliquez sur Fermer.

Access importe les données dans une nouvelle table, qu’il affiche ensuite sous Tables dans le volet de navigation.

Pour en savoir plus la procédure d’importation des données dans Access, suivez les liens dans la section Voir aussi de cet article.

Haut de la section

Ouvrir une base de données Access

  1. Cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur Ouvrir.

  2. Cliquez sur un raccourci dans la boîte de dialogue Ouvrir ou, dans la zone Regarder dans, cliquez sur le lecteur ou sur le dossier contenant la base de données souhaitée.

  3. Dans la liste de dossiers, double-cliquez sur les dossiers l’un après l’autre jusqu’à parvenir au dossier contenant la base de données.

  4. Lorsque vous avez trouvé la base de données, effectuez l’une des opérations suivantes :

    • Pour ouvrir la base de données en mode d’ouverture par défaut, double-cliquez dessus.

    • Pour ouvrir la base de données pour un accès partagé dans un environnement multi-utilisateur, afin que vous et autres utilisateurs peuvent lire et écrire dans la base de données en même temps, cliquez sur Ouvrir.

    • Pour ouvrir la base de données en lecture seule afin de pouvoir la consulter mais pas de la modifier, cliquez sur la flèche en regard du bouton Ouvrir, puis sur Ouvrir en lecture seule.

    • Pour ouvrir la base de données en mode exclusif, empêchant ainsi toute autre personne de l’ouvrir au même moment que vous, cliquez sur la flèche en regard du bouton Ouvrir et puis sur Ouvrir en exclusif.

    • Pour ouvrir la base de données en mode lecture seule, cliquez sur la flèche à côté du bouton Ouvrir, puis sur Ouvrir en mode lecture seule exclusif. D’autres utilisateurs peuvent ouvrir la base de données, mais en lecture seule uniquement.

Si vous ne trouvez pas la base de données que vous voulez ouvrir   

  1. Dans la boîte de dialogue Ouvrir, cliquez sur le raccourci Poste de travail ou, dans la zone Regarder dans, cliquez sur Poste de travail.

  2. Dans la liste de lecteurs, cliquez avec le bouton droit sur le lecteur qui contient en principe la base de données, puis cliquez sur Rechercher.

  3. Entrez vos critères de recherche puis appuyez sur la touche ENTRÉE pour rechercher la base de données.

  4. Si vous trouvez la base de données, ouvrez-la en double-cliquant dessus dans la boîte de dialogue Résultats de la recherche.

  5. Étant donné que la recherche a été lancée dans la boîte de dialogue Ouvrir, cliquez sur le bouton Annuler de cette boîte de dialogue pour que la base de données s'ouvre.

Remarque : Vous pouvez ouvrir directement un fichier de données dans un format de fichier externe (tel que dBASE, Paradox, Microsoft Exchange ou Microsoft Excel). Vous pouvez également ouvrir directement n'importe quelle source de données ODBC, comme Microsoft SQL Server ou Microsoft FoxPro. Access crée automatiquement une base de données Access dans le même dossier que le fichier de données, puis ajoute des liens vers chaque table de la base de données externe.

Conseils

  • Pour ouvrir une des dernières bases de données que vous avez récemment ouvertes, cliquez sur le nom du fichier dans la liste Ouvrir une base de données récente dans la page Prise en main de Microsoft Office Access. Access ouvre la base de données, appliquer les mêmes paramètres que la base de données avait la dernière fois que vous l’avez ouvert. Si la liste des derniers fichiers utilisés n’est pas affichée, cliquez sur le Bouton Microsoft Office Image du bouton Office , puis cliquez sur Options Access. La boîte de dialogue Options Access s’affiche. Cliquez sur la catégorie Options avancées puis, sous la section affichage, activez la case à cocher derniers fichiers utilisés (Vous pouvez également spécifier le nombre de fichiers récemment utilisés que vous voulez avoir affiché dans la liste, avec un maximum de neuf).

  • Si vous ouvrez une base de données en cliquant sur le Bouton Microsoft Office Image du bouton Office et à l’aide de la commande Ouvrir, vous pouvez afficher une liste des raccourcis vers les bases de données que vous avez récemment ouverts en cliquant sur Mes Documents récents dans la Ouvrir boîte de dialogue.

Haut de la section

Haut de la Page

Importer des données depuis un tableur ou un autre programme

Si vous êtes habitué avec d’autres programmes de base de données ou une feuille de calcul, vous savez probablement les notions de base du fonctionnement de ces applications et les bases de données sont utilisées pour. Accès diffère de nombreuses autres applications de base de données en vous permettant de créer des bases de données relationnelles. Access fournit également de nombreuses options pour travailler avec d’autres programmes de base de données, telles que SQL Server.

Dans cette section

Importer une feuille de calcul Excel dans Access

Importer une feuille de calcul Excel sous forme de tableau dans une nouvelle base de données Office Access 2007

Utiliser l’Assistant Analyseur de Table pour organiser vos données

Utiliser des données provenant d’autres programmes

Importer une feuille de calcul Excel dans Access

Nombreux sont ceux qui se mettent à explorer Access après avoir généré une liste dans Excel. Si Excel se prête idéalement à la création initiale d’une liste, plus cette dernière s’étoffe et plus son organisation et sa mise à jour deviennent délicates. Généralement, le transfert de cette liste vers Access constitue l’étape logique suivante.

Une table de base de données est une structure semblable à une feuille de calcul, dans la mesure où données sont stockées dans des lignes et colonnes. Par conséquent, il est facile d’importer une feuille de calcul dans une table de base de données. La différence entre le stockage de vos données dans une feuille de calcul et le stockage dans une base de données principale se trouve dans la manière dont les données sont organisées. Importez simplement votre feuille de calcul entière en tant qu’une nouvelle table dans une base de données ne résout pas les problèmes liés à l’organisation et mise à jour de vos données, notamment si votre feuille de calcul contient les données redondantes. Pour résoudre les problèmes, vous devez fractionner les données de feuille de calcul des tables distinctes, chacun d’eux contenant des données associées. Pour plus d’informations sur la réorganisation des données dans vos tables, voir l’article Concepts de base de création de base de données.

Accès aux fonctionnalités de l’Assistant Analyseur de Table, qui peuvent vous aider à effectuer cette procédure. Après avoir importé vos données dans un tableau, l’Assistant vous aide à fractionner la table en tables distinctes, chacun d'entre eux contient des données qui ne sont pas dupliquées dans une autre table. L’Assistant crée également les relations entre les tables nécessaires.

Importer une feuille de calcul Excel sous la forme d'une table dans une nouvelle base de données Office Access 2007

  1. Cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur Nouveau.

  2. Tapez un nom pour la nouvelle base de données dans la zone Nom du fichier puis cliquez sur le bouton Créer.

  3. Fermez la table Table1.

    Lorsque vous êtes invité à enregistrer les modifications apportées à la conception de Table1, cliquez sur Non.

  4. Sous l’onglet Données externes, dans le groupe Importer, cliquez sur Excel. Image du bouton

  5. Dans la boîte de dialogue Données externes, cliquez sur Parcourir.

  6. Utilisez la boîte de dialogue Ouvrir pour accéder au fichier.

  7. Sélectionnez le fichier puis cliquez sur Ouvrir.

  8. Dans la boîte de dialogue Données externes, vérifiez que l’option Importer les données sources dans une nouvelle table de la base de données active est sélectionnée.

  9. Cliquez sur OK.

    L’Assistant Importation de feuille de calcul démarre ; répondez aux questions qui vous sont posées sur les données.

  10. Suivez les instructions en cliquant sur le bouton Suivant ou Précédent pour parcourir les pages. Sur la dernière page de l’Assistant, cliquez sur le bouton Terminer.

    Remarque : Vous devez indiquer si vous souhaitez enregistrer le détail de l’importation à peine terminée. Si vous pensez renouveler cette importation, cliquez sur Oui puis entrez les détails. Vous pouvez alors facilement reproduire l’importation en cliquant sur Importations enregistrées dans le groupe Importer de l’onglet Données externes. Si vous ne souhaitez pas enregistrer les détails de cette opération, cliquez sur le bouton Fermer.

Access importe les données dans une nouvelle table, qu’il affiche ensuite sous Toutes les tables dans le volet de navigation.

Utiliser l'Assistant Analyseur de table pour organiser des données

Après l'importation de données dans une table Access, vous pouvez recourir à l'Assistant Analyseur de table pour identifier rapidement les données en double. Cet Assistant simplifie l'organisation des données dupliquées en tables séparées, de façon à optimiser leur stockage. Access sauvegarde une copie de la table initiale, puis crée de nouvelles tables sur lesquelles s'appuiera votre application de base de données.

  1. Ouvrez la base de données Access contenant la table que vous souhaitez analyser.

  2. Sous l’onglet Outils de base de données, dans le groupe Analyser, cliquez sur Analyse table.

    L’Assistant Analyseur de table démarre.

    Si le concept de normalisation vous est étranger, lisez les deux pages d'introduction de l'Assistant qui y sont consacrées : ce court didacticiel comprend des boutons sur lesquels vous pouvez cliquer pour afficher des exemples. Si les pages d'introduction ne s'affichent pas, activez la case à cocher Afficher les pages d'introduction et cliquez deux fois sur le bouton Précédent pour revenir à l'introduction. Si, après avoir lu l'introduction, vous ne souhaitez plus voir apparaître ces pages, vous pouvez désactiver cette case à cocher.

  3. Sur la page commençant par la phrase Quelle table contient des champs dont les valeurs sont répétées dans plusieurs enregistrements, sélectionnez la table que vous souhaitez analyser puis cliquez sur Suivant.

  4. L'Assistant peut organiser les champs dans les tables automatiquement, ou vous pouvez effectuer ces choix vous-même. Si vous suivez les suggestions de l'Assistant, vous pouvez toujours modifier la disposition des tables à la page suivante.

    Remarque : Les choix effectués par l’Assistant lorsqu’il organise les champs dans les tables ne sont pas toujours appropriés, en particulier si le volume de données est faible. Vérifiez donc minutieusement les résultats obtenus avec l’Assistant. Néanmoins, il est possible que ce dernier recommande une meilleure organisation que la vôtre, c’est pourquoi il est judicieux de l’exécuter au moins une fois. Si ces suggestions ne vous conviennent pas, vous pouvez toujours réorganiser les champs manuellement et cliquer sur le bouton Précédent pour revoir la disposition des champs vous-même.

  5. Cliquez sur le bouton Suivant. Cette page permet de spécifier les tables et les champs qu’elles contiennent. Si vous aviez opté pour l’organisation déterminée par l’Assistant, vous devriez voir plusieurs tables connectées par des lignes de jointure. Sinon, Access crée une seule table contenant tous les champs. Quoi qu’il en soit, vous pouvez apporter les modifications souhaitées sur cette page.

    • Vous pouvez faire glisser des champs d’une table vers une zone vide de la page pour créer une nouvelle table les contenant. Vous êtes invité à entrer un nom de table.

    • Vous pouvez faire glisser les champs d’une table à une autre si vous pensez que cela peut optimiser leur stockage.

    • Un champ ID ou Numéro unique généré est octroyé à la plupart des tables. Pour en savoir plus sur les champs d’identification, cliquez sur Conseils dans le coin supérieur droit de l’Assistant.

    • Pour annuler une modification, cliquez sur le bouton Annuler.

    • Pour renommer une table, double-cliquez sur sa barre de titre, tapez le nouveau nom puis cliquez sur OK.

  6. Après avoir organisé les champs comme vous le souhaitez, cliquez sur Suivant.

  7. Si l’Assistant identifie des enregistrements aux valeurs très similaires, il les considère comme d’éventuelles erreurs typographiques et affiche un écran où vous pouvez confirmer la conduite à tenir face à ces enregistrements. Faites défiler la liste pour trouver les enregistrements avec des valeurs dans la colonne Correction puis cliquez sur l’élément approprié dans la liste déroulante. Sélectionnez (Laisser tel quel) pour que l’Assistant ne modifie pas la valeur. Une fois terminé, cliquez sur Suivant.

  8. L’Assistant vous demande si vous souhaitez créer une requête qui ressemble à la table initiale. Si vous avez déjà généré des formulaires et des états fondés sur la table initiale, la création d’une telle requête est une idée judicieuse. Si vous sélectionnez Oui, créer la requête, l’Assistant renomme la table initiale en ajoutant le suffixe « _ANCIEN » au nom de la table. Il octroie alors un nom à la nouvelle requête en reprenant celui de la table initiale. Les formulaires et les états reposant sur cette table utilisent à présent la requête pour leurs données et fonctionnent comme auparavant.

  9. Cliquez sur Terminer.

    L’Assistant crée les nouvelles tables, comme indiqué, avant de les ouvrir. Fermez-les lorsque vous en avez fini avec l’inspection des résultats.

Haut de la section

Utiliser des données provenant d'autres programmes

Office Access 2007 offre des fonctionnalités permettant d'utiliser des données stockées dans d'autres programmes.

  • Créer une nouvelle base de données Access liée aux données dans un autre format de fichier    Vous pouvez utiliser Access pour ouvrir un fichier dans un autre format de fichier, comme un fichier texte ou dBASE ou une feuille de calcul. Access crée automatiquement une base de données Access et lie le fichier à votre place.

    1. Démarrez Access.

    2. Cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur Ouvrir.

    3. Dans la boîte de dialogue Ouvrir, cliquez sur le type de fichier que vous souhaitez ouvrir dans la liste. Si vous ne savez pas quel type choisir, cliquez sur Tous les fichiers (*.*).

    4. Le cas échéant, accédez au dossier contenant le fichier à ouvrir. Le fichier localisé, double-cliquez dessus pour l’ouvrir.

    5. Suivez les instructions de l’Assistant. Dans la dernière page de l’Assistant, cliquez sur Terminer.

  • Importer ou lier des données à une base de données Access existante    Vous pouvez importer des données provenant d'autres sources et programmes vers des tables Access, afin que ces données soient comprises dans ce fichier Access. Une autre option consiste à créer dans Access une liaison vers ces données, qui de cette façon demeureront dans leur fichier initial (en dehors du fichier Access).

    Importer ou lier des données

    1. Dans l'onglet Données externes, dans le groupe Importer, cliquez sur le format utilisé pour stocker les données.

      Vous pouvez importer ou lier des données aux formats suivants :

      • Microsoft Office Access

      • Microsoft Office Excel

      • Microsoft Windows SharePoint Services

      • Fichiers texte

      • Fichiers XML

      • Bases de données ODBC

      • Documents HTML

      • Microsoft Office Outlook

      • dBase

      • Paradox

      • Lotus 1-2-3

        La boîte de dialogue Données externes s'affiche.

    2. Suivez les instructions affichées dans la boîte de dialogue.

      Access importe les données dans votre base de données ou lie les données à votre base de données. Pour la plupart des formats de fichier, vous devez spécifier l’emplacement des données puis indiquer la façon dont celles-ci seront stockées dans la base de données.

Haut de la section

Haut de la Page

Utiliser une base de données de version antérieure dans plusieurs versions d'Access

Si votre base de données ou projet Access a été créé dans Access 2000 ou ultérieur, vous pouvez l'utiliser dans la version d'Access qui a servi à sa création ou dans une version ultérieure, même si la sécurité du fichier est activée. Par exemple, les fichiers Access 2000 sont utilisables d'Access 2000 jusqu'à Office Access 2007 et les fichiers Access 2002-2003 d'Access 2002-2003 jusqu'à Office Access 2007.

Dans certaines situations, vous souhaitez conserver vos données dans une version antérieure d'Access, mais des utilisateurs disposant d'une version ultérieure d'Access souhaitent se lier à ces données tout en bénéficiant de certaines fonctionnalités de la version ultérieure. La solution consiste à créer une nouvelle base de données "frontale" dans la version ultérieure (contenant formulaires, états, requêtes, macros, mais aucune table) et de la lier aux tables du fichier de la version précédente. Utilisez l'une des procédures suivantes, selon que votre base de données est contenue dans le seul fichier ou déjà fractionnée en une application frontale/principale.

Utiliser une base de données Access seul fichier dans plusieurs versions d’Access

Utiliser une application frontal-dans plusieurs versions d’Access

Utiliser une base de données Access à un seul fichier dans plusieurs versions d'Access

Si toutes les tables, formulaires et autres objets de votre base de données Access sont contenus dans le seul fichier .mdb et si vous voulez utiliser la base de données dans plusieurs versions d'Access, vous pouvez créer une nouvelle base de données frontale dans une version ultérieure et la lier au fichier d'origine. Les utilisateurs qui possèdent de la version antérieure d'Access peuvent toujours utiliser la base de données d'origine. Les utilisateurs qui possèdent la version plus récente peuvent utiliser la nouvelle base de données frontale pour se lier aux mêmes données.

  1. Utilisez la procédure suivante pour convertir la base de données dans l'un des trois formats Access récents : Access 2000, Access 2002-2003 ou Access 2007. Cette commande conserve la base de données d'origine dans son format originel et crée une copie au format que vous spécifiez.

    • Fermez le fichier Access. S'il s'agit d'une base de données Access multi-utilisateur située sur un serveur ou dans un dossier partagé, assurez-vous qu'elle n'est pas ouverte par un autre utilisateur.

    • Démarrez Access 2007.

    • Cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur Ouvrir.

    • Parcourez l'arborescence jusqu'à accéder au fichier à convertir et double-cliquez dessus pour l'ouvrir.

      Si la boîte de dialogue Amélioration de la base de données s'affiche vous demandant si vous souhaitez améliorer la base de données, cliquez sur Non.

    • Si un formulaire s’ouvre au démarrage de la base de données, fermez-le.

    • Cliquez sur le Bouton Microsoft Office Image du bouton Office , pointez sur Enregistrer sous et puis, sous Enregistrer la base de données dans un autre format, cliquez sur le format de fichier vers lequel vous voulez convertir.

    • Dans la boîte de dialogue Enregistrer sous, tapez le nom de la nouvelle base de données.

      Remarque : À moins d'enregistrer la nouvelle base de données dans un autre emplacement, son nom doit être différent de la base de données d'origine. Quoi qu'il en soit, il est généralement préférable d'utiliser un autre nom afin de distinguer plus facilement les bases de données frontale et principale. Sachez cependant que, lorsque vous convertissez une base de données au format Access 2007, l'extension du nom du fichier .mdb est remplacée par .accdb, ce qui signifie que le nom du fichier peut rester le même.

    • Cliquez sur Enregistrer.

  2. Fractionnez la base de données convertie en une application frontale/principale en utilisant la procédure suivante :

    • Sous l’onglet Outils de base de données, dans le groupe Déplacer les données, cliquez sur Base de données Access. Image du bouton

    • Dans la boîte de dialogue Assistant Fractionnement de base de données, cliquez sur Fractionner la base de données.

    • Tapez le nom de la base de données principale, puis cliquez sur Fractionner.

  3. Supprimez la base de données principale que l'Assistant Fractionnement de base de données a créée tout en veillant à ne pas supprimer la base de données d'origine.

  4. Lier la nouvelle base de données frontale aux tables de la base de données d’origine : sous l’onglet Outils de base de données, dans le groupe Outils de base de données, cliquez sur Gestionnaire d’attaches. image du bouton

  5. Cliquez sur Sélectionner tout puis activez la case à cocher Toujours demander un nouvel emplacement.

  6. Cliquez sur OK, accédez à la base de données de version antérieure et double-cliquez dessus.

    Si l'opération se passe bien, Access affiche un message indiquant que toutes les tables attachées sélectionnées ont été actualisées correctement.

    Vous pouvez à présent optimiser la nouvelle base de données frontale afin qu'elle prenne en charge de nouvelles fonctionnalités pour les utilisateurs qui ont effectué une mise à niveau vers Access 2000, Access 2002-2003 ou Access 2007. Les utilisateurs dotés d'une version antérieure du programme peuvent continuer à utiliser la base de données d'origine.

    Le cas échéant, vous pouvez également convertir la base de données nouvelle frontale en une autre version. Si la base de données d'origine était au format Access 2000, vous pouvez par exemple créer une base de données frontale Access 2002-2003 pour les utilisateurs disposant de cette version et une base de données frontale Access 2007 pour les utilisateurs possédant cette version. Ces deux versions frontales se lient aux données du fichier Access 2000.

Haut de la section

Utiliser une application frontale/principale dans plusieurs versions d'Access

Si votre base de données Access est déjà une application frontale/principale, il vous suffit de convertir l'application frontale au format de fichier Access 2000, Access 2002-2003 ou Access 2007. Aucune modification n'est requise pour la base de données principale.

La procédure suivante montre comment utiliser la commande Enregistrer la base de données sous pour convertir la base de données frontale dans l'un des trois formats Access récents : Access 2000, Access 2002-2003 ou Access 2007. Cette commande conserve la base de données d'origine dans son format originel et crée une copie au format que vous spécifiez.

  1. Fermez la base de données frontale. S'il s'agit d'une base de données Access multi-utilisateur située sur un serveur ou dans un dossier partagé, assurez-vous qu'elle n'est pas ouverte par un autre utilisateur.

  2. Démarrez Access 2007.

  3. Cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur Ouvrir.

  4. Parcourez l’arborescence jusqu’à accéder à la base de données frontale, puis double-cliquez sur celle-ci pour l’ouvrir.

    Si la boîte de dialogue Amélioration de la base de données s’affiche vous demandant si vous souhaitez améliorer la base de données, cliquez sur Non.

  5. Si un formulaire s’affiche à l’ouverture de la base de données, fermez-le.

  6. Cliquez sur le Bouton Microsoft Office Image du bouton Office , pointez sur Enregistrer sous et puis, sous Enregistrer la base de données dans un autre format, cliquez sur le format de fichier vers lequel vous voulez convertir.

  7. Dans la boîte de dialogue Enregistrer sous, tapez le nom de la nouvelle base de données.

  8. Cliquez sur Enregistrer.

Vous pouvez à présent optimiser la nouvelle base de données frontale afin qu'elle prenne en charge de nouvelles fonctionnalités pour les utilisateurs qui ont effectué une mise à niveau vers Access 2000, Access 2002-2003 ou Access 2007.

Haut de la section

Haut de la Page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×