Mesurer les performances et l'utilisation d'un site à l'aide de rapports

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Si vous êtes responsable de la gestion d'un site, vous vous posez probablement certaines questions sur le site, comme :

  • Combien de personnes visitent mon site ?

  • Quelle a été l'évolution du trafic du site au fil du temps ?

  • Quels sont les principaux utilisateurs de mon site ?

  • D'où vient le trafic de mon site ?

  • Quelles sont les pages les plus visitées et les ressources les plus utilisées de mon site ?

  • Comment savoir où se trouvent les documents et les autres ressources dans le processus de flux de travail ?

Parallèlement, en qualité de gestionnaire d'un site Web, il y a des questions auxquelles vous voulez régulièrement des réponses, notamment :

  • Y a-t-il des ressources de mon site que je peux supprimer car elles sont obsolètes ou ne sont plus utilisées ?

  • Comment détecter les problèmes sur mon site (par exemple, fichiers indésirables, pages chargées et liens hypertexte rompus) avant qu'ils soient remarqués et signalés par des utilisateurs ?

Ces questions peuvent paraître insurmontables, mais avec Microsoft Office SharePoint Designer 2007 et un site Windows SharePoint Services 3.0 ou Microsoft Office SharePoint Server 2007, vous pouvez facilement y répondre grâce aux rapports Office SharePoint Designer 2007. Cet article explique comment mesurer l'utilisation et les performances d'un site à l'aide de rapports.

Important : Les données des rapports générés par Office SharePoint Designer 2007 sont enregistrées sur le serveur qui héberge le site. Les administrateurs serveur peuvent accorder ou refuser l'accès à ces rapports. Si les rapports que vous demandez ne contiennent pas de données, contactez votre administrateur serveur pour obtenir de l'aide. Pour exécuter des rapports d'utilisation, vous devez disposer de l'autorisation Afficher les données d'utilisation et l'administrateur serveur doit activer la collection de données d'utilisation sur le serveur. Par défaut, la collection de données d'utilisation est désactivée sur le serveur.

Que voulez-vous faire ?

Afficher le rapport Résumé du Site

Afficher les rapports sur les fichiers

Afficher des rapports sur le contenu partagé

Afficher des rapports sur les problèmes

Afficher le rapport de synthèse de l’utilisation

Afficher les rapports d’utilisation détaillés

Vos résultats de données de l’utilisation du graphique

Trier un rapport

Filtrer un rapport

Copier un rapport

Enregistrer un rapport

Afficher le rapport Résumé du site

Le rapport Résumé du site offre un aperçu global du site, ainsi que des liens vers des rapports plus détaillés. Vous pouvez, par exemple, générer un rapport Résumé du site similaire à celui illustré ci-dessous.

Rapport Résumé du site

Pour générer un rapport Résumé du site pour votre site, procédez comme suit :

  1. Ouvrez le site pour lequel vous souhaitez exécuter le rapport dans Office SharePoint Designer 2007.

  2. Dans le menu Site, pointez sur Rapports, puis cliquez sur Résumé du site.

    Le rapport est généré.

Remarque : Vous pouvez cliquer sur les liens hypertexte de la colonne Nom pour accéder à des rapports plus détaillés. Par exemple, cliquez sur Liens hypertexte rompus pour accéder directement au rapport Liens hypertexte rompus.

Haut de la Page

Afficher des rapports sur des fichiers

Vous pouvez générer des rapports qui affichent tous les fichiers, les fichiers récemment ajoutés, les fichiers récemment modifiés ou les anciens fichiers. Par exemple, si vous voulez mettre en évidence le nouveau contenu dans la page d'accueil de votre site ou dans un bulletin de promotion de votre site, vous pouvez utiliser le rapport Fichiers récemment ajoutés pour identifier rapidement votre nouveau contenu. Sinon, vous pouvez utiliser le rapport Fichiers anciens pour identifier le contenu suffisamment ancien pour nécessiter une révision en vue de sa mise à jour, voire de sa suppression.

Pour exécuter des rapports sur des fichiers, spécifiez d'abord vos définitions de fichiers récents et anciens et spécifiez également le nombre de mois à afficher dans les rapports par mois :

  1. Ouvrez le site Web pour lequel vous voulez exécuter le rapport dans Office SharePoint Designer 2007.

  2. Dans le menu Outils, cliquez sur Options des applications.

  3. Cliquez sur l'onglet Affichage de rapports.

    Boîte de dialogue Options des applications affichant l'onglet Affichage de rapports

  4. Dans la zone Les fichiers « récents » ont été créés depuis moins de, entrez le nombre de jours identifiant une page récente.

  5. Dans la zone Les fichiers « anciens » ont été créés depuis plus de, entrez le nombre de jours identifiant une page ancienne.

  6. Dans la zone Nombre de mois affichés, entrez le nombre de mois à afficher dans les rapports par mois.

  7. Cliquez sur OK.

    Vous êtes maintenant prêt à exécuter les rapports.

  8. Dans le menu Site, pointez sur Rapports, sur Fichiers, puis cliquez sur le rapport à exécuter :

    • Tous les fichiers     Affiche une liste de tous les fichiers du site.

    • Fichiers récemment ajoutés     Affiche une liste des fichiers qui ont été ajoutés au site dans le nombre de jours spécifié à l'étape 4.

    • Fichiers récemment modifiés     Affiche une liste des fichiers qui ont été modifiés sur le site dans le nombre de jours spécifié à l'étape 4.

    • Fichiers anciens     Affiche une liste de fichiers considérés comme « anciens » en fonction du nombre de jours spécifié à l'étape 5.

    • État de l'extraction     Affiche une liste des fichiers du site ainsi que l'état d'extraction actuel de chaque fichier. (Ce rapport comporte les colonnes de données Extrait par, Version et verrouillé le.)

      Dans l'affichage de rapports, pour les rapports sur des fichiers, vous pouvez cliquer sur des options de la liste pour modifier rapidement les paramètres des fichiers anciens ou récents.

      Affichage de rapports illustrant le menu de filtre d'âge de fichier

Haut de la Page

Afficher des rapports sur du contenu partagé

Le contenu partagé peut comprendre des pages maîtres, des pages personnalisées et mais aussi d'autres pages incluses dans la définition du site, ainsi que des liens de feuille de style. Grâce à Office SharePoint Designer 2007, vous pouvez facilement localiser le contenu partagé. Par exemple, si vous voulez modifier un logo sur toutes les pages de votre site Web et que vous utilisez des pages maîtres pour contrôler la mise en page, vous pouvez utiliser le rapport Pages maîtres pour rechercher toutes les pages maîtres dans lesquelles vous devez modifier le logo. Vous pouvez également utiliser le rapport Liens de feuille de style pour rechercher toutes les feuilles de style à mettre à jour pour refléter une modification de police ou de mise en forme à appliquer dans tout le site.

  1. Ouvrez le site Web pour lequel vous voulez exécuter le rapport dans Office SharePoint Designer 2007.

  2. Dans le menu Site, pointez sur Rapports, sur Contenu partagé, puis cliquez sur le rapport à exécuter :

    • Modèles Web dynamiques     Affiche une liste de toutes les pages du site. La colonne Modèle Web dynamique indique si chaque page est attachée à un modèle Web dynamique (et le cas échéant, auquel).

    • Pages maîtres     Affiche une liste de toutes les pages du site. La colonne Page maître indique si chaque page est attachée à une page maître (et le cas échéant, à laquelle).

    • Pages personnalisées     Affiche une liste de toutes les pages du site. La colonne Personnalisé indique si une page basée sur la définition du site a été personnalisée.

    • Liens de feuille de style     Affiche une liste de toutes les pages du site. La colonne Liens de feuille de style indique si chaque page est attachée à une feuille de style.

      Remarque : Les liens de feuille de style affichés sont statiques (balises <lien>). Ce rapport ne comprend pas les liens de feuille de style dynamiques générés par des contrôles Microsoft ASP.NET (comme <SharePoint:CssLink>).

Haut de la Page

Afficher des rapports sur des problèmes

Les rapports Office SharePoint Designer 2007 sur des problèmes peuvent vous aider à anticiper des problèmes potentiels et à les résoudre avant que les utilisateurs soient affectés. Vous pouvez, par exemple, utiliser ces rapports pour identifier les pages chargées, pour localiser les liens hypertexte rompus et pour rechercher d'éventuels fichiers à supprimer du fait qu'ils ne sont pas liés aux autres. Pour exécuter des rapports Problèmes, définissez d'abord vos préférences afin de déterminer les pages chargées.

  1. Ouvrez le site Web pour lequel vous voulez exécuter le rapport dans Office SharePoint Designer 2007.

  2. Dans le menu Outils, cliquez sur Options des applications.

  3. Cliquez sur l'onglet Affichage de rapports.

    Boîte de dialogue Options des applications affichant l'onglet Affichage de rapports

  4. Dans la zone Les pages « chargées » nécessitent au moins, entrez le nombre de secondes définissant la durée nécessaire pour télécharger une page page chargée.

  5. Dans la zone Vitesse de connexion estimée à, entrez le nombre de kilobits par seconde (Kbps) de la vitesse de connexion de l'utilisateur moyen.

  6. Cliquez sur OK.

    Vous êtes maintenant prêt à exécuter les rapports.

  7. Cliquez sur Site, pointez sur Rapports, sur Problèmes, puis cliquez sur le rapport à exécuter :

    • Fichiers non liés     Affiche une liste de tous les fichiers du site vers lesquels aucun lien ne renvoie. Cette liste peut vous aider à rechercher les fichiers inutilisés qui doivent être supprimés du site. Notez que ce rapport ne tient pas compte des liens générés par les contrôles ASP.NET tels que le composant WebPart Table des matières dans les sites Office SharePoint Server 2007.

    • Pages chargées     Affiche une liste des pages du site identifiées comme lentes à charger d'après la définition spécifiée à l'étape 3 et la vitesse de connexion moyenne spécifiée à l'étape 4. Notez que ce rapport reflète le temps nécessaire pour charger les marques de révision de la page, mais ne prend pas en compte le contenu dynamique généré par des contrôles ASP.NET.

    • Liens hypertexte     Affiche une lise de tous les liens hypertexte du site. Après avoir exécuté ce rapport, une boîte de dialogue vous demande si vous souhaitez vérifier les liens hypertexte du site. Cliquez sur Oui si vous voulez qu'Office SharePoint Designer 2007 vérifie chaque lien hypertexte pour vous. Le cas échéant, vous obtenez une liste des différents liens hypertexte identifiés comme OK ou Rompu. Pour modifier un lien rompu, cliquez sur le lien dans le rapport, puis cliquez sur Modifier le lien hypertexte dans la barre d'outils qui s'affiche dans le coin supérieur droit de la fenêtre de document dans l'affichage de rapports.

      Remarque :  Boîte de dialogue Modifier le lien hypertexte

    • Erreurs de composant     Affiche une liste des composants, par exemple des boutons interactifs ou le compteur d'accès (anciennement et plus communément appelés bots ou webbots), qui génèrent actuellement des erreurs. Vous pouvez afficher une liste des composants Web en cliquant sur Composant Web dans le menu Insertion.

Haut de la Page

Afficher le rapport Informations sur l'utilisation

Les rapport sur l'utilisation des sites permettent de répondre à certaines des questions les plus urgentes que les propriétaires de site se posent quant à leur site, notamment : combien de personnes utilisent mon site, quelles sont les ressources les plus utilisées, qui utilise le plus le site et d'où les visiteurs accèdent-ils au site. Le rapport Informations sur l'utilisation comprend une synthèse du nombre total de visites, des pages visitées, des octets téléchargés et bien plus encore.

Rapport Informations sur l'utilisation

Pour exécuter le rapport Informations sur l'utilisation, procédez comme suit :

  1. Ouvrez le site Web pour lequel vous voulez exécuter le rapport dans Office SharePoint Designer 2007.

  2. Dans le menu Site, pointez sur Rapports, sur Utilisation, puis sur Informations sur l'utilisation.

    Le rapport est généré. Vous pouvez cliquer sur un des éléments avec lien hypertexte dans la colonne Nom pour afficher des rapports détaillés.

Haut de la Page

Afficher des rapports d'utilisation détaillés

Vous pouvez exécuter des rapports d'utilisation détaillés pour savoir notamment comment les utilisateurs accèdent à votre site. Par exemple, bien que le rapport Informations sur l'utilisation généré à la section précédente affiche le nombre total de page visitées, le rapport Nombre de visites par mois détaille le nombre de visite de chaque page du site. Pour exécuter des rapports d'utilisation détaillés, procédez comme suit :

  1. Ouvrez le site Web pour lequel vous voulez exécuter le rapport dans Office SharePoint Designer 2007.

  2. Dans le menu Site, pointez sur Rapports, sur Utilisation, puis cliquez sur le rapport à exécuter :

    • Résumé mensuel     Résume le nombre de visites, d'accès, le total des accès et la taille de téléchargement sur votre site par mois.

    • Résumé hebdomadaire     Résume le nombre de visites, d'accès, le total des accès et la taille de téléchargement sur votre site par semaine.

    • Résumé quotidien     Résume le nombre de visites, d'accès, le total des accès et la taille de téléchargement sur votre site par jour.

    • Nombre de visites par mois     Résume le nombre d'accès ainsi que le nombre total d'accès par mois pour chaque page de votre site Web.

    • Nombre de visites par semaine     Résume le nombre d'accès ainsi que le nombre total d'accès par semaine pour chaque page de votre site Web.

    • Nombre de visites par jour     Résume le nombre d'accès ainsi que le nombre total d'accès par jour pour chaque page de votre site Web.

    • Visiteurs     Résume le nombre de visiteurs ainsi que leur pourcentage du total pour un mois donné.

    • Systèmes d'exploitation     Résume le nombre de systèmes d'exploitation des visiteurs et leur pourcentage du total pour un mois donné.

    • Navigateurs     Résume le nombre de navigateurs de visiteurs et leur pourcentage du total pour un mois donné.

    • Domaines de référence     Résume le nombre de visites provenant d'un domaine spécifique, ainsi que leur pourcentage du total pour un mois donné.

    • URLs de référence     Résume le nombre de visites provenant d'une URL spécifique, ainsi que leur pourcentage du total pour un mois donné.

    • Chaînes recherchées     Énumère les chaînes recherchées tapées dans la zone de recherche du site, ainsi que leur pourcentage du total pour un mois donné.

Haut de la Page

Représenter les résultats des données d'utilisation sous forme graphique

Vous pouvez facilement créer un graphique représentant les données d'utilisation sous forme graphique afin d'identifier facilement les tendances et les schémas d'utilisation.

  1. Dans le menu Site, pointez sur Rapports, sur Utilisation, puis cliquez sur le rapport à exécuter.

  2. Dans la barre d'outils qui s'affiche dans le coin supérieur droit de la fenêtre de document, dans la liste Graphique, cliquez sur le type de graphique à créer, par exemple Histogramme.

    Barre d'outils de l'affichage de rapports illustrant la liste Graphique

    Le rapport s'ouvre dans une nouvelle fenêtre.

    Graphique de données d'utilisation

    Remarque : Par défaut, des données graphiques sont générées avec les rapports graphiques. Si vous ne trouvez pas de données graphiques lorsque vous tentez d'exécuter le rapport, dans le menu Outils, cliquez sur Options des applications, cliquez sur l'onglet Affichage de rapports, et assurez-vous que la case à cocher Inclure le graphique une fois le rapport d'utilisation enregistré est activée.

Haut de la Page

Trier un rapport

Dans l'affichage de rapports, vous pouvez trier un rapport en cliquant sur les titres de colonne.

Haut de la Page

Filtrer un rapport

Vous pouvez limiter les résultats des rapports pour afficher uniquement les informations qui vous intéressent. Vous pouvez filtrer sur une seule colonne ou sur plusieurs colonnes pour créer un filtre progressif.

  1. Dans le menu Site, pointez sur Rapports, puis cliquez sur le rapport à exécuter.

  2. Cliquez sur la flèche en regard du titre de la colonne sur laquelle vous voulez filtrer, puis cliquez sur les données à filtrer.

    Par exemple, lorsque vous filtrez par type de fichier, vous pouvez cliquer sur la flèche en regard du titre de colonne Type, puis sur bmp pour afficher uniquement les fichiers bitmap dans le rapport.

    Colonne Type illustrant le menu Filtrer

  3. Pour filtrer sur plusieurs colonnes, répétez l'étape 2 pour chaque colonne.

  4. Pour créer un filtre personnalisé sur une colonne, cliquez sur la flèche en regard du titre de colonne, puis sur (Personnalisé). Entrez vos critères de recherche, puis cliquez sur OK.

    Vous pouvez, par exemple, utiliser un filtre automatique personnalisé pour identifier tous les fichiers d'image .bmp et .gif de votre site.

    Boîte de dialogue Filtre automatique personnalisé

  5. Pour supprimer un filtre d'une colonne, cliquez sur la flèche en regard du titre de la colonne en question, puis cliquez sur (Toutes).

Remarque : Les paramètres de filtre actuellement appliqués sont enregistrés lorsque vous fermez le site. Si vous ne parvenez pas à trouver de fichiers dans un rapport que vous venez d'exécuter, il se peut qu'ils soient masqués par les filtres appliqués lors d'une session précédente.

Pour supprimer tous les filtres d'un rapport, cliquez avec le bouton droit sur un titre de colonne, puis cliquez sur Supprimer les filtres dans le menu contextuel.

Haut de la Page

Copier un rapport

Après avoir exécuté un rapport, vous pouvez copier et coller les résultats dans un message électronique ou dans un autre document (par exemple, une feuille de calcul Microsoft Office Excel). Tous les rapports peuvent être copiés à l'exception du rapport Résumé du site.

  1. Cliquez avec le bouton droit sur un titre de colonne dans le rapport que vous avez exécuté, puis cliquez sur Copier le rapport dans le menu contextuel.

    Menu de la colonne Nom avec la commande Copier le rapport sélectionnée

  2. Collez les données dans le document ou le message.

Haut de la Page

Enregistrer un rapport

Vous pouvez enregistrer des rapports si vous utiliser Microsoft Office Excel 2007 pour afficher et analyser les résulatst ou pour créer des graphiques personnalisés.

  1. Dans le menu Site, pointez sur Rapports, puis cliquez sur le rapport à exécuter.

  2. Dans le menu Fichier, cliquez sur Enregistrer ou appuyez sur les touches CTRL+S.

  3. Dans la zone Nom du fichier, tapez un nom pour le rapport, puis cliquez sur Enregistrer. Le rapport est enregistré en tant que fichier .htm dans le site.

    Rapport ouvert dans Excel

  4. Pour ouvrir le rapport, double-cliquez dessus.

    Le rapport s'ouvre dans Office Excel 2007.

Haut de la Page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×