Maquette des éléments de l'interface Windows XP

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Utilisez le modèle Interface utilisateur Windows XP pour créer des maquettes d'interfaces utilisateur à l'aide de formes conçues selon les directives Microsoft Windows XP. Ces formes comprennent les éléments généralement utilisés dans les interfaces, notamment un formulaire vide comme base d'une fenêtre d'application, des pages d'Assistant, des formes de barre d'outils et de menus, ainsi que des formes de contrôle.

Vous pouvez utiliser ces formes pour tous les éléments à partir d’une maquette d’une fenêtre d’application complexe ou de la boîte de dialogue apporter à une boîte de message simple ou un bouton unique.

Que voulez-vous faire ?

Créer une simple boîte de dialogue

Créer une boîte de dialogue avec onglets

Créer une fenêtre d'application

Construire des menus et des barres d'outils

Créer une simple boîte de dialogue

  1. À partir de Fenêtres et boîtes de dialogue, faites glisser une forme Formulaire vide sur la page de dessin.

  2. Lorsque la forme est sélectionnée, attribuez un titre à la boîte de dialogue.

  3. Faites glisser une forme Bouton de fenêtre à l'extrémité droite de la barre de titre et sélectionnez le type de bouton. De gauche à droite, on trouve généralement un bouton Aide et un bouton Fermer.

  4. Dans le coin inférieur droit de la forme Formulaire vide, ajoutez des boutons de commande, comme OK, Annuler et Appliquer.

    how

    1. À partir de Contrôles communs, faites glisser des formes Bouton de commande vers le coin inférieur droit de la forme Formulaire vide.

    2. Sélectionnez chaque bouton et tapez le nom du contrôle.

  5. Faites glisser les contrôles de votre choix dans la forme Formulaire vide. Cliquez avec le bouton droit sur les formes pour choisir les options appropriées.

    Pour obtenir de l'aide sur une forme de contrôle spécifique, cliquez avec le bouton droit sur la forme et cliquez sur ? (Aide).

    Si vous utilisez l'outil Texte pour créer votre propre texte dans la forme Formulaire vide, mettez le texte en forme en Tahoma 8pt.

  6. Assemblez les commandes en groupes logiques.

  7. Faites glisser les formes Zone de groupe et Séparateur de groupe sur la forme Formulaire vide pour séparer visuellement les groupes.

    Utilisez des Repères pour aligner les contrôles.

    La boîte de dialogue Imprimer, sous le menu Fichier, constitue un bon exemple car elle comporte de nombreux éléments d'utilisation courante.

Haut de la page

Créer une boîte de dialogue avec onglets

  1. À partir de Fenêtres et boîtes de dialogue, faites glisser une forme Formulaire vide sur la page de dessin.

  2. Lorsque la forme est sélectionnée, attribuez un titre à la boîte de dialogue.

  3. Faites glisser une forme Bouton de fenêtre à l'extrémité droite de la barre de titre et sélectionnez le type de bouton. De gauche à droite, on trouve généralement un bouton Aide et un bouton Fermer.

  4. Dans le coin inférieur droit de la forme Formulaire vide, ajoutez des boutons de commande, comme OK, Annuler et Appliquer.

    how

    1. À partir de Contrôles communs, faites glisser des formes Bouton de commande vers le coin inférieur droit de la forme Formulaire vide.

    2. Sélectionnez chaque bouton et tapez le nom du contrôle.

  5. Faites glisser une forme Contrôle Onglet (corps) sur la forme Formulaire vide et dimensionnez-la de manière à ce qu'elle s'ajuste dans le formulaire tout en laissant l'espace nécessaire aux onglets.

  6. Faites glisser une forme Contrôle Onglet (onglets) et collez-la dans le coin supérieur de la forme Contrôle Onglet (corps).

  7. Lorsque la forme Contrôle Onglet (onglets) est sélectionnée, attribuez un nom à l'onglet.

  8. Répétez les étapes 6 et 7 pour chaque onglet, en collant les onglets les uns aux autres, ainsi qu'à la forme Contrôle Onglet (corps).

  9. Cliquez avec le bouton droit sur l'onglet que vous souhaitez afficher à l'avant-plan, puis cliquez sur Onglet de premier plan et définissez les autres sur Onglet d'arrière-plan.

  10. Faites glisser les contrôles de votre choix sur la forme Formulaire vide. Cliquez avec le bouton droit sur les formes pour choisir les options appropriées.

    Pour obtenir de l'aide sur une forme de contrôle spécifique, cliquez avec le bouton droit sur la forme et cliquez sur ? (Aide).

    Si vous utilisez l'outil Texte pour créer votre propre texte dans la forme Formulaire vide, mettez le texte en forme en Tahoma 8pt.

  11. Assemblez les commandes en groupes logiques.

  12. Faites glisser les formes Zone de groupe et Séparateur de groupe sur la forme Formulaire vide pour séparer visuellement les groupes.

    Utilisez des Repères pour aligner les contrôles.

    La boîte de dialogue Mise en page, sous le menu Fichier, constitue un bon exemple car elle comporte de nombreux éléments d'utilisation courante.

Haut de la page

Créer une fenêtre d'application

  1. À partir de Fenêtres et boîtes de dialogue, faites glisser une forme Formulaire vide sur la page de dessin.

  2. Lorsque la forme est sélectionnée, tapez un titre pour la fenêtre d'application.

  3. Pour ajouter une icône à gauche du texte dans la barre de titre, cliquez avec le bouton droit sur la forme Formulaire vide et activez la case à cocher Espace pour une icône.

  4. Faites glisser une forme Boutons de fenêtre à l'extrémité droite de la barre de titre et sélectionnez le type de bouton. On trouve généralement trois types de boutons : le bouton Réduire, le bouton Agrandir ou Restaurer, et le bouton Fermer (de gauche à droite).

  5. À partir de Barres d'outils et menus, faites glisser une forme Barre de menus sur la forme Formulaire vide, collez-la sous la barre de titre et ajoutez ensuite les éléments de menu de votre choix.

    how

    1. Faites glisser une forme Élément de menu supérieur sur la page et collez-la sur le côté gauche de la barre de menus.

      Vous pouvez placer une icône à gauche du premier élément de menu.

    2. Lorsque la forme est sélectionnée, attribuez-lui un nom. Si l'élément de menu comporte un raccourci clavier, soulignez la lettre appropriée.

    3. Répétez les étapes 1 et 2 autant de fois que nécessaire.

      Pour obtenir de l'aide sur une forme, cliquez dessus avec le bouton droit, puis sélectionnez ? (Aide).

      Pour masquer les points de connexion Image de point de connexion (X bleu) , dans le menu Affichage, cliquez sur Points de connexion.

      Les éléments d'une colonne doivent tous avoir la largeur de l'élément le plus large.

    Pour afficher les points de préhension sur le bord gauche de la barre de menus, cliquez avec le bouton droit sur la forme et désactivez la case à cocher Verrouiller la barre de menus.

  6. À partir de Barres d'outils et menus, faites glisser une forme Barre d'outils sur la forme Formulaire vide, collez-la sous la barre de menu, puis ajoutez des boutons de barre d'outils.

    how

    1. Faites glisser l'une des formes Boutons de barre d'outils sur la page et collez-la sur le bord gauche de la forme Barre d'outils.

    2. Dans la boîte de dialogue Données de forme, choisissez le type de bouton de votre choix. Si, plus tard, vous souhaitez en changer, cliquez avec le bouton droit sur la forme et cliquez sur Définir le type de bouton pour rouvrir la boîte de dialogue Données de forme.

    3. Faites glisser autant de formes Boutons de barre d'outils et Séparateur de boutons que nécessaire et collez-les les unes aux autres.

      Pour obtenir de l'aide sur une forme, cliquez avec le bouton droit, puis cliquez sur ? (Aide).

      Pour masquer les points de connexion Image de point de connexion (X bleu) , dans le menu Affichage, cliquez sur Points de connexion.

    Pour afficher les points de préhension sur le bord gauche de la barre d'outils, cliquez avec le bouton droit sur la forme et désactivez la case à cocher Verrouiller la barre d'outils.

  7. À partir de Contrôles communs, faites glisser, au besoin, les barres de défilement horizontal et vertical vers les bords droit et inférieur de la forme Formulaire vide.

  8. Cliquez avec le bouton droit sur les barres de défilement et sélectionnez Définir la taille de la barre pour indiquer le niveau de défilement de la fenêtre.

    Pour indiquer que seule une petite portion du document est visible, définissez une petite taille de barre. Pour indiquer que la majeure partie du document est visible, définissez une grande taille de barre.

  9. Faites glisser une forme Barre d'état jusqu'au bord inférieur de la fenêtre d'application et mettez-la en forme.

    how

    1. Faites glisser une forme Séparation de la barre d'état sur la page et collez-la sur la poignée de contrôle de la forme Barre d'état Poignée de contrôle .

      Les poignées de contrôle fournissent un emplacement pour coller une forme Séparation de la barre d'état sur une forme Barre d'état ou sur une autre forme Séparation de la barre d'état.

      Si aucune forme Séparation de la barre d'état n'apparaît après l'avoir collée sur une forme Barre d'état, sélectionnez la forme Barre d'état, dans le menu Forme, pointez sur Ordre, puis cliquez sur Reculer d'un plan.

    2. Faites glisser une forme Redimensionnement de fenêtre jusqu'au bord droit de la barre d'état pour indiquer que la fenêtre est actuellement redimensionnable.

Haut de la page

Créer des menus et des barres d'outils

Vous pouvez utiliser les formes Windows XP pour créer des menus de base, des menus déroulants et des barres d'outils.

Créer un menu

  1. À partir de Barres d'outils et menus, faites glisser une forme Barre de menus sur la page de dessin. Pour afficher les points de préhension sur le bord gauche de la barre de menus, cliquez avec le bouton droit sur la forme et désactivez la case à cocher Verrouiller la barre de menus.

  2. Faites glisser une forme Élément de menu supérieur, puis collez-la sur le côté gauche de la barre de menus.

    Conseil : Vous pouvez, si vous le souhaitez, insérer une icône à gauche du premier élément de menu.

  3. Lorsque la forme est sélectionnée, attribuez-lui un nom. Si l'élément de menu comporte un raccourci clavier, soulignez la lettre appropriée.

  4. Répétez les étapes 2 et 3 autant de fois que nécessaire.

    Pour obtenir de l'aide sur une forme, cliquez avec le bouton droit, puis cliquez sur ? (Aide).

    Pour masquer les points de connexion Image de point de connexion (X bleu) , dans le menu Affichage, cliquez sur Points de connexion.

    Les éléments d'une colonne doivent tous avoir la largeur de l'élément le plus large.

Créer un menu déroulant

  1. Faites glisser une forme Élément de menu supérieur sur la page de dessin.

  2. Lorsque la forme est sélectionnée, attribuez-lui un nom. Si l'élément de menu comporte un raccourci clavier, soulignez la lettre appropriée.

  3. Faites glisser une forme Élément de menu déroulant, collez-la au bas de l'Élément de menu supérieur et attribuez-lui un nom.

  4. Répétez l'étape 3 pour tous les éléments de menu déroulant de la colonne.

  5. Redimensionnez tous les Éléments de menu déroulant en fonction la largeur de l'élément le plus large.

  6. Cliquez avec le bouton droit sur chaque forme Élément de menu déroulant, cliquez sur Propriétés d'élément de menu et sélectionnez les options appropriées.

    Pour obtenir de l'aide sur une forme, cliquez avec le bouton droit, puis cliquez sur ? (Aide).

    Pour masquer les points de connexion Image de point de connexion (X bleu) , dans le menu Affichage, cliquez sur Points de connexion.

Créer une barre d'outils

  1. À partir de Barres d'outils et menus, faites glisser la forme Barre d'outils sur la page de dessin. Pour afficher les points de préhension sur le bord gauche de la barre d'outils, cliquez avec le bouton droit sur la forme et désactivez la case à cocher Verrouiller la barre d'outils.

  2. Faites glisser une forme Bouton de barre d'outils et collez-la sur le bord gauche de la forme Barre d'outils.

  3. Dans la boîte de dialogue Données de forme, choisissez le type de bouton de votre choix. Si, plus tard, vous souhaitez en changer, cliquez avec le bouton droit sur la forme et cliquez sur Définir le type de bouton pour rouvrir la boîte de dialogue Données de forme.

  4. Faites glisser autant de formes Boutons de barre d'outils et Séparateur de boutons que nécessaire et collez-les les unes aux autres.

    Pour obtenir de l'aide sur une forme, cliquez avec le bouton droit, puis cliquez sur ? (Aide).

    Pour masquer les points de connexion Image de point de connexion (X bleu) , dans le menu Affichage, cliquez sur Points de connexion.

Haut de la page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×