Méthodes pour additionner des valeurs dans une feuille de calcul

Compter ou additionner ?

L’addition de valeurs fait partie intégrante de l’analyse des données, que vous calculiez le sous-total de ventes régionales ou le total cumulé de tickets hebdomadaires. Excel offre différentes techniques que vous pouvez utiliser pour additionner des données.

Pour vous aider à faire le meilleur choix, cet article présente un résumé des méthodes disponibles, propose des informations de support pour vous aider à identifier rapidement la technique à utiliser et inclut des liens vers des articles détaillés.

Vous ne devez pas confondre l’addition du contenu de cellules et le décompte d’un nombre de cellules. Pour plus d’informations sur le décompte du nombre de cellules, de colonnes ou de lignes de données, voir Fonction NB.SI.

Contenu de cet article

Addition et soustraction simples

Addition des données par regroupement et création d’un tableau croisé dynamique

Additionner des valeurs sur la base d’une ou plusieurs conditions

Addition de valeurs de carré et de tableau

Cas particuliers (résultat cumulé, valeurs uniques)

Insertion de valeurs issues d’autres feuilles de calcul ou classeurs dans une formule

Addition et soustraction de valeurs de date et d’heure

Affichage de calculs sur la barre d’état d’Excel

Addition et soustraction simples

Vous pouvez ajouter ou soustraire des nombres à l’aide d’une formule simple, en cliquant sur un bouton ou en utilisant une fonction de feuille de calcul.

Additionner les valeurs dans une cellule à l’aide d’une formule simple

Si vous avez simplement besoin d’un résultat rapide, vous pouvez utiliser Excel comme mini calculatrice. Pour ce faire, utilisez le signe plus (+) comme opérateur arithmétique.

Formule

Description

Résultat

=5+10

Utilise l’opérateur + (signe plus) pour additionner plusieurs valeurs.

15

=A2+B2

Additionne les valeurs de plusieurs cellules. Dans le cas présent, supposons que A2 = 5 et B2 = 10.

15

=A2+B2+20

Additionne les valeurs de deux cellules à un nombre que vous entrez directement dans la formule. Dans le cas présent, supposons que A2 = 5 et B2 = 10.

35

Haut de la page

Soustraire les valeurs dans une cellule à l’aide d’une formule simple

Pour ce faire, utilisez le signe moins (-) comme opérateur arithmétique. Par exemple, la formule =12-9 affiche un résultat de 3.

Pour plus d’informations sur l’utilisation des opérateurs arithmétiques dans une formule, voir l’article Utiliser Excel comme calculatrice.

Haut de la page

Additionner les valeurs dans une colonne ou une ligne à l’aide d’un bouton

Vous pouvez utiliser la fonctionnalité Somme automatique pour additionner rapidement une plage de nombres dans une colonne ou une ligne. Cliquez sur une cellule vide en dessous d’une colonne de nombres ou à droite d’une ligne de nombres, puis sur Somme automatique. Excel sélectionne ce qu’il considère comme la plage de données la plus probable. Cliquez de nouveau sur Somme automatique pour accepter la plage sélectionnée par Excel, ou sélectionnez votre propre plage, puis cliquez sur Somme automatique.

Utilisation du bouton SommeAuto pour additionner rapidement une ligne de données

Pour plus d’informations sur l’utilisation de la fonctionnalité Somme automatique, voir l’article Utiliser Excel comme calculatrice.

Haut de la page

Additionner les valeurs d’une plage à l’aide d’une fonction

La fonction SOMME est utile lorsque vous voulez additionner ou soustraire des valeurs de différentes plages ou combiner des valeurs numériques et des plages de nombres. Utilisez la fonction SOMME pour additionner tous les arguments que vous spécifiez entre les parenthèses ouvrante et fermante. Chaque argument peut être une plage, une référence de cellule ou une valeur numérique positive ou négative.

Pour entrer une formule simple, tapez =SOMME dans une cellule, puis une parenthèse ouvrante. Tapez ensuite un ou plusieurs nombres, références de cellule ou plages de cellules, séparés par des points-virgules. Tapez une parenthèse fermante, puis appuyez sur Entrée pour afficher le résultat. Vous pouvez également utiliser la souris pour sélectionner les cellules qui contiennent les données que vous voulez additionner.

1

2

3

A

Présence

4823

12335

Par exemple, toutes les formules suivantes utilisent la fonction SOMME avec les données du tableau précédent pour renvoyer la même valeur (17158) :

  • =SOMME(4823,12335)

  • =SOMME(A2;A3)

  • =SOMME(A2:A3)

  • =SOMME(A2;12335)

La figure suivante montre la formule qui utilise la fonction SOMME pour additionner la valeur de la cellule A2 et 12335. Sous la formule, une info-bulle fournit des conseils pour l’utilisation de la fonction SOMME.

Utilisation de la fonction SOMME pour additionner une cellule et une valeur


Remarques : 

  • Il n’y a pas de fonction SOUSTRAIRE dans Excel. Pour soustraire des valeurs à l’aide d’une fonction, utilisez les valeurs négatives avec la fonction SOMME. Par exemple, la formule =SOMME(30;A3;-15;-B6) ajoute 30 à la valeur dans la cellule A3, soustrait 15, puis soustrait la valeur dans la cellule B6.

  • Vous pouvez inclure jusqu’à 255 valeurs numériques ou des références de cellule ou de plage, quelle que soit la façon dont vous les combinez, en tant qu’arguments dans la fonction SOMME.

Pour plus d’informations, voir l’article Fonction SOMME.

Haut de la page

Soustraire les valeurs d’une plage à l’aide d’une fonction

Utilisez la fonction SOMME pour soustraire des nombres en entrant les nombres que vous voulez soustraire comme des nombres négatifs dans la formule.

1

2

3

A

Présence

29072

12335

Par exemple, toutes les formules suivantes utilisent la fonction SOMME avec les données du tableau précédent pour renvoyer la même valeur (16737) :

  • =SOMME(29072;-12335)

  • =SOMME(A2;-A3)

  • =SOMME(A2;-12335)

  • =SOMME(A2;(-1*(A3)))

Haut de la page

Addition des données par regroupement et création d’un tableau croisé dynamique

Vous pouvez utiliser un plan ou un rapport de tableau croisé dynamique pour regrouper et résumer vos données.

Additionner les valeurs dans une colonne à l’aide d’un plan

Si vos données sont disposées normalement (dans des lignes et des colonnes) et que vous pouvez les regrouper logiquement selon les valeurs de colonne, vous pouvez les regrouper et les résumer en créant un plan. La création d’un plan permet de synthétiser les données en insérant des sous-totaux et des totaux généraux. Supposons que vous disposez des chiffres de ventes suivants, organisés par région et par mois.

1

2

3

4

5

6

7

A

B

C

Région

Mois

Ventes

Est

Janvier

18 000 €

Est

Février

23 000 €

Est

Mars

19 000 €

Ouest

Janvier

17 000 €

Ouest

Février

27 000 €

Ouest

Mars

21 000 €

L’illustration suivante montre un plan incluant des sous-totaux, regroupés par région et un total général.

Plan avec sous-totaux et un total général

Utilisez la commande Sous-total (onglet Données, groupe Plan) pour créer un plan, des sous-totaux et un total général.

Les données d’origine inclus trois lignes de données pour la région Est et trois lignes de données pour la région Ouest (lignes 2 à 7). Notez que l’opération de sous-total a inséré le total de la région Est dans la ligne 5 entre la dernière ligne des données de la région Est et la première ligne des données de la région Ouest.

Si vous cliquez sur la cellule A4, puis sur la commande Sous-total, Excel crée un plan et insère des lignes pour Total Est, Total Ouest et Total général, et remplit les cellules de la colonne Ventes avec ces totaux.

Pour plus d’informations, voir les articles suivants :

Haut de la page

Additionner les valeurs dans une liste ou une colonne de tableau Excel à l’aide d’une fonction

Alternative plus flexible à la commande Sous-total, vous pouvez utiliser la fonction SOUS.TOTAL pour calculer les sous-totaux et totaux généraux sur des listes ou des tableaux Excel qui contiennent des lignes ou colonnes masquées. Dans la fonction SOUS.TOTAL, vous spécifiez un argument qui inclut ou n’inclut pas des valeurs masquées.

Remarque : La fonction SOUS.TOTAL permet de contrôler l’intégration des lignes masquées dans les résultats et ignore toujours les lignes filtrées.

Par exemple, supposons que vous vouliez calculer les sous-totaux et un total général pour les données dans les cellules C2 à C7, mais que vous voulez ignorer les données masquées dans les lignes 3 et 6. La fonction que vous utilisez se présente comme suit :

=SOUS.TOTAL(109;C2:C7)

Le premier argument (109) indique que vous voulez additionner les valeurs de la plage et ignorer les valeurs masquées. Pour inclure les valeurs masquées, vous utilisez 9 comme premier argument à la place.

Pour plus d’informations, voir l’article Fonction SOUS.TOTAL.

Haut de la page

Additionner des données et les consulter selon différentes perspectives

Lorsqu’une feuille de calcul contient des centaines ou des milliers de lignes de données similaires, il peut être difficile de donner du sens à ces nombres. Vous pouvez créer un rapport de tableau croisé dynamique dans Excel à partir de ces données pour afficher les sous-totaux et les totaux généraux, et synthétiser des données sur la base des catégories que vous spécifiez.

Vous pouvez créer rapidement un tableau croisé dynamique en sélectionnant une cellule dans une plage de données ou un tableau Excel, puis, en cliquant sur Tableau croisé dynamique dans le groupe Tableaux de l’onglet Insertion.

Pour vous permettre de comprendre l’utilité d’un tableau croisé dynamique, notez que dans l’exemple suivant, les données de ventes contiennent plusieurs lignes (il y a en réalité 40 lignes de données, mais le graphique n’en montre qu’une partie). Par ailleurs, les données ne sont pas synthétisées, et il n’y a pas de sous-totaux ou de total général.

Données utilisées dans un rapport de tableau croisé dynamique

Un rapport de tableau croisé dynamique basé sur les mêmes données affiche les sous-totaux, les totaux généraux et permet de consulter un résumé d’un simple coup d’œil.

Données synthétisées et totalisées dans un rapport de tableau croisé dynamique

La création et l’utilisation de tableaux croisés dynamiques peuvent impliquer certaines étapes de préparation initiale de vos données et la connaissance de certains concepts. Pour des informations détaillées sur la prise en main, consultez les articles suivants :


Haut de la page

Additionner des valeurs sur la base d’une ou plusieurs conditions

Les fonctions de feuille de calcul vous permettent d’appliquer des conditions (ou critères) afin d’ajouter les seules données qui correspondent aux conditions que vous spécifiez.

Additionner les valeurs dans une plage sur la base d’une seule condition à l’aide d’une fonction ou d’une combinaison de fonctions

Utilisez la fonction SOMME.SI ou imbriquez la fonction SOMME dans la fonction SI.

Vous pouvez ajouter des nombres sur la base d’un seul critère à l’aide de la fonction SOMME.SI ou d’une combinaison des fonctions SOMME et SI.

Par exemple, la formule =SOMME(A2:A6;">20" additionne uniquement les nombres de la plage A2 à A6 supérieurs à 20.

Remarque : Les informations suivantes sont un peu techniques, mais cela vaut la peine d’en prendre connaissance.

Si la fonction SOMME.SI n’existe pas, vous pouvez tout de même créer la même réponse en combinant les fonctions SI et SOMME. La combinaison des fonctions de cette manière est également appelée « imbrication » (une fonction est utilisée dans une autre fonction).

Pour créer une formule qui reproduit la fonction SOMME.SI , vous devez entrer une formule qui traite la plage A2 à A6 sous la forme d’un tableau. La plage est ainsi considérée comme une seule entité contenant cinq cellules.

Votre formule se présente comme suit : {=SOMME(S(A2:A6>20;A2:A6))}. Les accolades qui entourent la formule indiquent qu’il s’agit d’une formule de tableau. Une telle formule nécessite un traitement spécial : Au lieu de taper les accolades vous-même, vous devez appuyer sur Ctrl+Maj+Entrée. Excel entoure alors la formule =SOMME(SI(A2:A6>20;A2:A6)) d’accolades. Le fait d’insérer les accolades vous-même ne permet pas de créer une formule de tableau.

Essayez ceci.    

Copiez les données du tableau suivant dans la cellule A1 d’une feuille de calcul. Après avoir collé les données, vous remarquerez que la cellule A10 contient une erreur #VALEUR!. Cela signifie que vous devez convertir la cellule A10 en formule de tableau. Pour ce faire, vous devez appuyer sur F2, puis sur Ctrl+Maj+Entrée. Excel affiche le résultat (65) dans les cellules A8 et A10.

1

2

3

4

5

6

7

8

9

10

A

Poids

18

29

36

11

16

Utilisation de la fonction SOMME.SI

=SOMME.SI(A2:A6;">20")

Utilisation des fonctions SOMME et SI

=SOMME(SI(A2:A6>20;A2:A6))

Pour plus d’informations, voir l’article Fonction SOMME.SI et la section « Additionner des nombres en fonction d’une condition » dans l’article Additionner des nombres.

Par ailleurs, l’article de la Base de connaissances Quand utiliser SOMME(SI()) au lieu de NB.VIDE() fournit des recommandations supplémentaires sur l’utilisation de la fonction SOMME.SI.

Haut de la page

Additionner les valeurs dans une colonne sur la base d’une ou plusieurs conditions à l’aide d’une fonction

Utilisez la fonction BDSOMME pour additionner les nombres inclus dans un champ (colonne) d’enregistrements d’une liste ou d’une base de données qui correspondent aux conditions (ou critères) que vous spécifiez.

Vous pouvez également utiliser la fonction BDSOMME lorsque vous avez une liste de colonnes et que vous trouvez plus facile de définir vos conditions dans une plage de cellules distincte plutôt que d’utiliser une fonction imbriquée.

Pour plus d’informations, consultez l’article Fonction BDSOMME.

Pour plus d’informations, consultez également la section « Additionner des nombres en fonction de critères stockés dans une plage distincte » dans l’article Additionner des nombres.

Haut de la page

Additionner les valeurs dans une plage sur la base de plusieurs conditions à l’aide d’une fonction ou d’une combinaison de fonctions

Utilisez la fonction SOMME.SI.ENS. Indiquez la plage que vous voulez additionner, une plage contenant des conditions et les conditions appliquées à la plage de conditions. Vous pouvez également imbriquer les fonctions SOMME et SI.

Pour plus d’informations, voir l’article Fonction SOMME.SI.ENS.

Consultez la section « Additionner des nombres en fonction de plusieurs conditions » dans l’article Ajouter des nombres pour plus d’informations sur l’utilisation conjointe des fonctions SOMME et SI.

Consultez les articles de la Base de connaissances suivants pour obtenir des informations supplémentaires :

Haut de la page

Addition de valeurs de carré et de tableau

Vous pouvez utiliser les fonctions de feuille de calcul pour additionner les valeurs de deux ou plusieurs colonnes correspondant l’une à l’autre. Ce type d’opération peut permettre de calculer une moyenne pondérée (voir l’exemple suivant qui calcule une moyenne pondérée cumulative). Il peut également s’agir d’un calcul statistique ou technique complexe.

Additionner le produit de valeurs correspondantes dans un ou plusieurs tableaux

Utilisez la fonction SOMMEPROD. Par exemple, vous pouvez calculer la moyenne pondérée cumulative d’un étudiant en utilisant la fonction SOMMEPROD et en divisant ce résultat par le nombre de crédits, comme montré dans l’illustration suivante.

Multiplication des valeurs correspondantes de deux matrices

La formule =SOMMEPROD(A2:A6;B2:B6)/SOMME(B2:B6) multiplie la note obtenue pour chaque cours par le nombre de crédits correspondant, calcule la somme de ces produits (61,3), divise cette somme par le nombre total de crédits (18) et détermine la moyenne pondérée cumulative (3,41). Ce type de calcul est également appelé moyenne pondérée.

Vous pouvez également utiliser la fonction SOMMEPROD dans des opérations mathématiques plus avancées pour multiplier plusieurs tableaux.

La fonction SOMMEPROD est facile à utiliser avec des tableaux qui ont les mêmes dimensions. Vous pouvez également utiliser la fonction SOMME dans un formule de tableau si vous avez besoin de davantage de flexibilité.

Pour plus d’informations, voir l’article Fonction SOMMEPROD.

En général, les quatre fonctions suivantes sont utilisées dans des applications mathématiques complexes ou statistiques avancées. Aussi, elles sont juste décrites brièvement. Pour plus d’informations, cliquez sur le nom de la fonction pour accéder directement à sa rubrique de référence.

  • Fonction SOMME.CARRES Renvoie la somme des carrés d’une liste de nombre ou de valeurs dans un plage. Par exemple, SOMME.CARRES(2;3) renvoie 13.

  • Fonction SOMME.X2PY2 Additionne la somme des carrés des valeurs correspondantes de deux tableaux.

  • Fonction SOMME.X2MY2 Renvoie la somme de la différence des carrés des valeurs correspondantes de deux matrices.

  • Fonction SOMME.XMY2 Renvoie la somme des carrés des différences entre les valeurs correspondantes de deux matrices.

Haut de la page

Cas particuliers (résultat cumulé, valeurs uniques)

Vous pouvez utiliser les fonctions de feuille de calcul pour créer des totaux mis à jour automatiquement tandis que vous ajoutez des données à une plage ou un tableau, ou pour ajouter les seules valeurs uniques incluses dans une plage ou un tableau.

Créer un résultat cumulé à l’aide d’une fonction

Utilisez la fonction SOMME. Par exemple, créez les en-têtes de colonne Dépôts, Retraits et Solde dans une feuille de calcul.

  1. Dans la première cellule sous la colonne Solde, entrez votre solde d’ouverture.

  2. Dans la cellule située directement sous votre solde (dans ce cas, C3), entrez une formule qui additionne la valeur de la colonne Dépôts dans la même ligne et soustrait la valeur de la colonne Retraits(=SOMME(C2;A3;-B3).

  3. Faites glisser cette formule vers le bas pour l’appliquer aux nouvelles lignes que vous voulez additionner. Dans l’exemple suivant, la formule est déplacée vers la ligne 4.

1

2

3

4

A

B

C

Dépôts

Retraits

Solde

500

1000

625

=SOMME(C2;A3;-B3)

1000

740

=SOMME(C3;A4;-B4)

Vous pouvez utiliser un solde courant comme vous le feriez avec un registre de chèques pour voir les valeurs des éléments dans les cellules augmenter ou diminuer à mesure que vous entrez de nouveaux éléments et valeurs.

Pour plus d’informations, voir l’article Calculer un solde courant.

Haut de la page

Additionner des valeurs uniques dans une plage à l’aide d’une formule composée

Dans une colonne, entrez une liste de valeurs qui contient des doublons et utilisez une combinaison des fonctions SOMME, SI et FRÉQUENCE pour additionner les seules valeurs uniques, disponibles dans cette plage.

Pour des informations détaillées sur l’exécution de ce type d’opération, voir la section « Additionner des valeurs uniques » dans l’article Additionner des nombres.

Haut de la page

Insertion de valeurs issues d’autres feuilles de calcul ou classeurs dans une formule

Vous pouvez additionner ou soustraire des cellules ou des plages de données issues d’autres feuilles de calcul ou classeurs dans une formule en incluant une référence à celles-ci. Pour faire référence à une cellule ou une plage dans un autre classeur ou feuille de calcul, utilisez les instructions dans le tableau suivant.

Pour faire référence à :

Entrez ceci

Exemples

Une cellule ou une plage dans une autre feuille de calcul du même classeur

Le nom de la feuille de calcul, un point d’exclamation, puis la référence de cellule ou le nom de la plage.

Feuil2!B2:B4
Feuil3!ChiffresVentes

Une cellule ou une plage dans un autre classeur actuellement ouvert

Le nom de fichier du classeur entre crochets ([]) et le nom de la feuille de calcul suivi d’un point d’exclamation, puis la référence de cellule ou le nom de la plage.

[MonClasseur.xlsx]Feuil1!A7

Une cellule ou une plage dans un autre classeur qui n’est pas ouvert

Le chemin d’accès complet et le nom de fichier du classeur entre crochets ([]) et le nom de la feuille de calcul suivi d’un point d’exclamation, puis la référence de cellule ou le nom de la plage. Si le chemin d’accès complet contient des espaces, insérez un guillemet simple au début du chemin d’accès et à la fin du nom de la feuille de calcul (voir l’exemple).

['C:\Mes documents\[MonClasseur.xlsx]Feuil1'!A2:A5


Haut de la page

Addition et soustraction de valeurs de date et d’heure

Vous pouvez utiliser les fonctions de date et d’heure, et même une addition ou une soustraction simple, pour calculer le temps écoulé, estimer des dates d’exécution de projets, etc. Le tableau suivant montre des formules de calcul d’heures et de jours écoulés. Si la soustraction d’une date ou d’une heure génère une valeur négative, Excel affiche les caractères ### dans la cellule qui contient la formule.

1

2

3

4

5

A

B

C

Heure de début

Heure de fin

Formule de calcul du temps écoulé

Description (résultat)

11:55:24 AM

2:48:13 PM

=B2-A2

Affiche le temps écoulé en heures, minutes et secondes. Dans ce cas, Excel affiche le résultat (2:52:49 AM) dans un format « AM », car la différence est inférieure à 12 heures. Si la différence avait été de plus de 12 heures, Excel aurait affiché un format « PM ».

Date de début

Date de fin

Formule de calcul des jours écoulés

Description (résultat)

28/05/2008

03/06/2008

=B5-A5

Affiche les jours écoulés sous la forme d’un nombre (6).

Les valeurs de date et d’heure peuvent produire des résultats inattendus, aussi, utilisez-les avec précaution.

Haut de la page

Affichage des calculs sur la barre d’état d’Excel

Pour obtenir un aperçu rapide du total de cellules sélectionnées dans votre feuille de calcul, consultez la barre d’état d’Excel (en bas de la fenêtre de document). Dans la barre d’état, Excel affiche la somme des cellules sélectionnées contenant des données numériques. La valeur de somme qui apparaît dans la barre d’état est mise à jour dès lors que vous sélectionnez ou désélectionnez des cellules.

Barre d’état d’Excel

Barre d’état d’Excel

Valeur de somme calculée dans la barre d’état d’Excel

Lorsqu’une ou plusieurs cellules sont sélectionnées, les informations sur les données dans ces cellules apparaissent dans la barre d’état d’Excel. Par exemple, si les quatre cellules dans votre feuille de calcul sont sélectionnées, et qu’elles contiennent les valeurs 2, 3, une chaîne de texte (par exemple, « cloud ») et 4, toutes les valeurs suivantes peuvent apparaître dans la barre d’état en même temps : Moyenne, Total, Nb (nombres), Minimum, Maximum et Somme. Cliquez avec le bouton droit sur la barre d’état pour afficher et masquer la totalité ou une partie de ces valeurs. Ces valeurs apparaissent dans l’illustration suivante.

Barre d’état affichant les calculs et le nombre de cellules sélectionnées

Remarque    Dans les versions d’Excel antérieures à Excel 2007, ces valeurs peuvent apparaître sur la barre d’état (une seule valeur à la fois).

Haut de la page

Ces informations vous ont-elles été utiles ?

Très bien ! Vous avez d’autres commentaires ?

Comment pouvons-nous l’améliorer ?

Nous vous remercions pour vos commentaires.

×