La fonction NB.SI.ENS

Cet article décrit la syntaxe de formule et l’utilisation de la fonctionNB.SI.ENS dans Microsoft Office Excel.

Description

Applique les critères aux cellules de plusieurs plages et compte le nombre de fois où tous les critères sont remplis.

Syntaxe

NB.SI.ENS(plage_critères1; critère1; [plage_critères2; critères2]…)

La syntaxe de la fonction NB.SI.ENS contient les argumentsuivants :

  • plage_critères1    Requis. La première plage dans laquelle évaluer les critères associés.

  • critère1    Requis. Critères, sous forme de nombre, d’expression, de référence de cellule ou de texte, qui déterminent les cellules à compter. Par exemple, les critères peuvent être les suivants :32, ">32", B4, "pommes" ou"32".

  • plage_critères1, plage_critères2, …    Facultatif. Plages supplémentaires et leurs critères associés. Jusqu’à 127 paires plage/critères sont autorisées.

    Important   Chaque plage supplémentaire doit avoir le même nombre de lignes et de colonnes en tant qu’argument plage_critères1 . Les plages ne doivent pas nécessairement être adjacentes.

Remarques

  • Chaque critère de plage est appliqué une cellule à la fois. Si toutes les premières cellules répondent à leurs critères associés, le nombre augmente de 1. Si toutes les deuxièmes cellules répondent à leurs critères associés, le nombre augmente de 1 à nouveau, et ainsi de suite jusqu’à ce que toutes les cellules soient évaluées.

  • Si l’argument critère est une référence à une cellule vide, la fonction NB.SI.ENS traite la cellule vide comme une valeur 0.

  • Vous pouvez utiliser les caractères génériques [le point d’interrogation (?) et l’astérisque (*)] dans l’argument critère. Le point d’interrogation correspond à un caractère quelconque et l’astérisque à une séquence de caractères. Si vous recherchez un point d’interrogation ou un astérisque, tapez un tilde (~) devant ce caractère. 

Exemple 1

L'exemple sera peut-être plus facile à comprendre si vous le copiez dans une feuille de calcul vide.

Comment copier un exemple ?



1

2

3

4

5

6




7



8




9

A

B

C

D

Vendeur

Quota trucs dépassé

Quota machins dépassé

Quota bidules dépassé

Davidoski

Oui

Non

Non

Burke

Oui

Oui

Non

Sundaram

Oui

Oui

Oui

Levitan

Non

Oui

Oui

Formule

Description

Résultat

=NB.SI.ENS(B2:D2,"=Oui")

Compte le nombre de fois où Davidoski a dépassé un quota de ventes pour Trucs, Machins et Bidules.

1

=NB.SI.ENS(B2:B5,"=Oui",C2:C5,"=Oui")

Compte le nombre de vendeurs qui ont dépassé leur quota de ventes pour les trucs et les machins.

2

=NB.SI.ENS(B5:D5,"=Oui",B3:D3,"=Oui")

Compte le nombre de fois que Levitan et Burke ont dépassé le même quota pour les trucs, les machins et les bidules.

1

Exemple

L'exemple sera peut-être plus facile à comprendre si vous le copiez dans une feuille de calcul vide.

Comment copier un exemple ?

  1. Sélectionnez l’exemple présent dans cet article. Si vous copiez l’exemple dans Excel Online, copiez et collez une cellule à la fois.
    Important: Ne sélectionnez pas les en-têtes des lignes ou des colonnes.

    Sélection d’un exemple de l’aide

    Sélection d’un exemple de l’aide

  2. Appuyez sur Ctrl+C.

  3. Créez un classeur ou une feuille de calcul vide.

  4. Dans la feuille de calcul, sélectionnez la cellule A1, puis appuyez sur Ctrl+V. Si vous travaillez dans Excel Online, effectuez un copier-coller pour chaque cellule de l’exemple.
    Important: Pour que l’exemple fonctionne correctement, vous devez le coller dans la cellule A1 de la feuille de calcul.

  5. Pour passer de l’affichage des résultats à celui des formules permettant de renvoyer les résultats, appuyez sur Ctrl+` (accent grave) ou, sous l’onglet Formules, dans le groupe Audit des formules, cliquez sur le bouton Afficher les formules.

Une fois que vous avez copié l’exemple dans la feuille de calcul vide, vous pouvez l’adapter selon vos besoins.

1

2

3

4

5

6

7

8



9





10



11

A

B

C

Données

Données

1

5/1/2008

2

5/2/2008

3

5/3/2008

4

5/4/2008

5

5/5/2008

6

5/6/2008

Formule

Description

Résultat

=NB.SI.ENS(A2:A7,"<6",A2:A7,">1")

Compte combien de nombres compris entre 1 et 6 (1 et 6 exclus) sont contenus dans les cellules A2 à A7.

4

=NB.SI.ENS(A2:A7, "<5",B2:B7,"<5/3/2008")

Compte combien de lignes contiennent des nombres inférieurs à 5 dans les cellules A2 à A7 et des dates antérieures à 5/3/2008 dans les cellules B2 à B7.

2

=NB.SI.ENS(A2:A7, "<" & A6,B2:B7,"<" & B4)

Description identique à l’exemple précédent, mais avec des références de cellules au lieu de constantes dans les critères.

2

S’applique à : Excel 2007



Ces informations vous ont-elles été utiles ?

Oui Non

Comment pouvons-nous nous améliorer ?

255 caractères restants

Afin de protéger votre vie privée, n’indiquez aucune information de contact dans vos commentaires. Lisez notre déclaration de confidentialité.

Nous vous remercions pour vos commentaires.

Ressources de support

Changer la langue