Je ne peux pas enregistrer ma base de données répliquée au format Access 2007

Remarque :  Nous faisons de notre mieux pour vous fournir le contenu d’aide le plus récent aussi rapidement que possible dans votre langue. Cette page a été traduite automatiquement et peut donc contenir des erreurs grammaticales ou des imprécisions. Notre objectif est de faire en sorte que ce contenu vous soit utile. Pouvez-vous nous indiquer en bas de page si ces informations vous ont aidé ? Voici l’article en anglais à des fins de référence aisée.

Symptômes

Dans Microsoft Office Access 2007, les bases de données qui ont été créés dans les versions antérieures d’Access répliquées (. Format MDB) ne peuvent pas être enregistré dans le nouveau. Format de fichier ACCDB. L’option apparaît en grisé (indisponible) lorsque vous essayez d’utiliser la commande Enregistrer sous forme de base de données (cliquez sur le Bouton Microsoft Office Image du bouton Office , puis cliquez sur la flèche en regard de Enregistrer sous ).

Raison

Le format de fichier .ACCDB ne prend pas en charge la réplication.

Résolution

Utiliser la base de données répliquée au format de fichier .MDB

Vous pouvez continuer à utiliser votre base de données répliquée au format de fichier .MDB, car la fonctionnalité de réplication est toujours prise en charge pour ce format.

Recréer manuellement la base de données au format de fichier Office Access 2007

Si vous décidez que le nouveau format de fichier est plus avantageux que la réplication, vous pouvez créer une base de données au format Office Access 2007 et recréer manuellement la base de données répliquée.

Remarque : Cette méthode fonctionnera sur les bases de données répliquées. Sauf si vous travaillez avec un réplica complet synchronisé avec tous les autres réplicas dans le jeu de réplicas, les données et projets qui ne se trouvent pas déjà dans votre réplica ne figureront toutefois pas dans la nouvelle base de données.

Avant de commencer à recréer votre base de données, vous devez vous assurer que tous les objets masqués et système dans le réplica sont visibles. Cela vous permet de vérifier que vous pouvez accéder aux champs replica-specific dans le réplica lorsque vous e recréez.

  1. Ouvrez le réplica que vous souhaitez convertir. Vous devez ouvrir le réplica en utilisant la version d'Access qui a été utilisée au départ pour créer le réplica, afin d'afficher les champs masqués et système.

  2. Dans le menu Outils, cliquez sur Options. La boîte de dialogue Options s'ouvre.

  3. Dans l'onglet Affichage, dans la section Afficher, sélectionnez Objets masqués et Objets système. Cliquez sur OK pour appliquer les nouveaux paramètres, puis fermez la boîte de dialogue Options.

Recréer manuellement la base de données

  1. Créez une base de données vide, puis ouvrez-la.

    Remarque : Access crée une nouvelle table vide nommée Table1. Vous devez supprimer cette table — pour ce faire, vous pouvez la fermer immédiatement avant de lui apporter la moindre modification. Cliquez droit sur son onglet Objet, puis cliquez sur Fermer dans le menu contextuel.

  2. Dans l’onglet Données externes, accédez au groupe Importer et cliquez sur Access.

    La boîte de dialogue Données externes - Base de données Access s'affiche.

  3. Cliquez sur Parcourir pour rechercher la base de données répliquée.

  4. Cliquez sur la base de données répliquée qui contient les objets de base de données à recréer dans la nouvelle base, puis cliquez sur Ouvrir.

  5. Dans la boîte de dialogue Données externes - Base de données Access, cliquez sur Importer des tables, des requêtes, des formulaires, des états, des macros et des modules dans la base de données active, puis sur OK.

  6. Cliquez sur les objets que vous voulez importer dans la nouvelle base de données. Pour importer tous les objets, cliquez sur Sélectionner tout sur chaque onglet.

    Important    Ne sélectionnez aucune table à cette étape. Vous recréerez les tables à une étape ultérieure.

  7. Une fois que vous avez sélectionné les objets, cliquez sur OK pour les importer.

    Sur la dernière page de l'Assistant, vous avez la possibilité d'enregistrer les étapes d'importation pour une utilisation ultérieure. Pour ce faire, activez la case à cocher Enregistrer les étapes d'importation, entrez les informations appropriées, puis cliquez sur Enregistrer l'importation.

  8. Ouvrez la base de données répliquée dans Office Access 2007. Pour chaque table de la base de données répliquée, créez une requête Création de table qui prend toutes les données de l'ancienne table et crée une table dans la nouvelle base de données avec les mêmes données.

    Remarque : Si le champ s_GUID est une clé primaire (et clés étrangères dans d’autres tables y faire), vous devez inclure inclure ce champ dans la nouvelle table. Si le champ Inclure ce n’est pas utilisé comme clé primaire, il est inutile de conserver dans la nouvelle table. Ne pas copier les champs s_Lineage et s_Generation vers la nouvelle table.

    Par défaut, les champs s_GUID, s_Lineage et s_Generation sont masqués. Pour afficher ces champs, suivez la procédure suivante :

    1. Dans la base de données répliquée, vérifiez que toutes les tables sont fermées.

    2. Cliquez droit sur le haut du volet de navigation, puis cliquez sur Options de navigation. La boîte de dialogue Options de navigation s'ouvre.

    3. Dans la section Options d'affichage , sélectionnez Objets système , puis cliquez sur OK .

      Procédure

      1. Créez une requête en sélectionnant les tables qui contiennent les enregistrements que vous souhaitez inclure dans la nouvelle table.

        Procédure

        1. Dans l'onglet Créer, cliquez sur Création de requête dans le groupe Autre.

        2. Dans la boîte de dialogue Afficher la table, cliquez sur l'onglet répertoriant les tables dont vous souhaitez utiliser les données.

        3. Double-cliquez sur le nom de chaque objet que vous voulez ajouter à la requête, puis cliquez sur Fermer.

        4. Ajoutez des champs à la ligne Champ, dans la grille de création.

        5. Pour afficher les résultats de la requête, cliquez sur le menu Affichage, puis cliquez sur Mode Feuille de données.

      2. En mode Création de la requête, dans le groupe Type de requête de l'onglet Création, cliquez sur Créer une table. La boîte de dialogue Création de table s'affiche.

      3. Dans la zone Nom de la table, tapez le nom de la table à créer ou à remplacer.

      4. Cliquez sur Autre base de données, puis tapez le chemin d'accès à la base de données dans laquelle vous souhaitez placer la nouvelle table ou cliquez sur Parcourir afin de rechercher la base de données.

      5. Cliquez sur OK.

      6. Sous l’onglet Création, dans le groupe résultats, cliquez sur exécuter. Cette option permettra que la nouvelle table.

        Remarque : La nouvelle table que vous créez n'hérite pas des propriétés de champs ni du paramètre clé primaire de la table d'origine.

  9. Pour chaque table de la nouvelle base de données, créez le même index et la même clé primaire que ceux utilisés dans la table du réplica.

    Procédure

    1. Ouvrez une table en mode Création.

    2. Dans la partie supérieure de la fenêtre, cliquez sur le champ pour lequel vous souhaitez créer un index.

    3. Dans la partie inférieure de la fenêtre, cliquez sur la zone de propriété Indexé, puis sur Oui - Avec doublons ou Oui - Sans doublons.

    4. Sélectionnez le champ ou les champs qui comprennent la clé primaire.

    5. Sous l'onglet Création du groupe Outils , cliquez sur Clé primaire.

  10. Pour chaque table dans la nouvelle base de données, créez les relations qu’il existe pour la table du réplica.

    Procédure

    Lorsque vous créez une relation entre tables, les champs correspondants n’êtes pas obligé d’avoir le même nom. Toutefois, ils doivent comporter le même type de données, sauf si le champ de clé primaire est un champ NuméroAuto. Vous pouvez faire correspondre un champ NuméroAuto avec un champ numérique uniquement si la propriété TailleChamp des deux champs correspondants est la même. Par exemple, vous pouvez faire correspondre un champ NuméroAuto avec un champ numérique si la propriété TailleChamp des deux champs est Entier Long. Propriété doit être TailleChamp même si les deux champs associés sont des champs numériques.

    Définir un un-à-plusieurs ou une relation

    1. Fermez toutes les tables ouvertes. Vous ne pouvez pas créer ou modifier des relations entre des tables ouvertes.

    2. Dans l’onglet Outils de base de données, dans le groupe Afficher/Masquer, cliquez sur Relations.

    3. Si vous n'avez défini aucune relation dans votre base de données, la boîte de dialogue Afficher la table apparaît automatiquement.

      Si vous devez ajouter les tables que vous souhaitez lier et que la boîte de dialogue Afficher la table n'apparaît pas, appelez-la : pour cela, dans le groupe Afficher/Masquer de l'onglet Création, cliquez sur le bouton Afficher la table.

    4. Double-cliquez sur le nom des tables que vous souhaitez lier, puis fermez la boîte de dialogue Afficher la table. Pour créer une relation entre une table et elle-même, ajoutez-la deux fois.

    5. Faites glisser à partir d'une table le champ que vous souhaitez lier au champ d'une autre table.

      Pour faire glisser plusieurs champs, appuyez sur CTRL, cliquez sur chaque champ, puis faites-les glisser.

      Dans la plupart des cas, vous faites glisser le champ de clé primaire (dont le texte apparaît en gras) d'une table vers un champ similaire (portant généralement le même nom), appelé la clé étrangère de l'autre table.

    6. La boîte de dialogue Modification des relations s'affiche. Vérifiez le nom des champs affichés dans les deux colonnes et assurez-vous qu'ils sont corrects. Vous pouvez les modifier si nécessaire.

      Définissez les options de relation, si nécessaire.

    7. Cliquez sur le bouton Créer pour créer la relation.

    8. Répétez les étapes 4 à 7 pour chaque paire de tables à lier.

      Lorsque vous fermez la fenêtre Relations, Microsoft Access vous demande si vous souhaitez enregistrer la mise en forme. Quelle que soit votre réponse, les relations créées sont enregistrées dans la base de données.

    Définir une relation plusieurs-à-plusieurs

    1. Créez les tables entre lesquelles vous souhaitez établir une relation plusieurs à plusieurs

    2. Créez une troisième table, appelée table de jointure, puis ajoutez-lui de nouveaux champs possédant les mêmes définitions que les champs de clé primaire de chacune des deux autres tables. Dans la table de jointure, les champs de clé primaire fonctionnent comme des clés étrangères. Vous pouvez ajouter d'autres champs à la table de jointure de la même manière que pour une autre table.

    3. Dans la table de jointure, définissez la clé primaire qui doit inclure les champs de clé primaire des deux autres tables. Par exemple, dans une table de jointure Détails des commandes, la clé primaire serait composée des champs N° de commande et N° de produit.

      Procédure

      1. Ouvrez la table en mode Création.

      2. Sélectionnez le ou les champs que vous souhaitez définir en tant que clé primaire.

        Pour sélectionner un champ, cliquez sur le sélecteur de ligne en regard du champ.

        Pour sélectionner plusieurs champs, maintenez la touche CTRL enfoncée et cliquez sur le sélecteur de ligne correspondant à chaque champ.

      3. Sous l'onglet Création du groupe Outils , cliquez sur Clé primaire.

        Remarque : Si vous voulez que l'ordre des champs dans une clé primaire de plusieurs champs soit différent de celui des champs de la table, cliquez sur le bouton Index dans le groupe Afficher/Masquer pour afficher la fenêtre Index, puis changez l'ordre des noms des champs pour l'index nommé CléPrimaire.

    4. Définir un relation un-à-plusieurs entre chacune des deux tables source et la table de jonction.

  11. Enregistrez votre nouvelle base de données.

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×