Insérer une feuille de données dans un formulaire

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Une feuille de données est un affichage simplifié de données organisées en lignes et en colonnes. Si vous double-cliquez sur une table dans le volet Navigation, Microsoft Office Access 2007 affiche la table sous forme de feuille de données. En raison de leur présentation compacte des données, les feuilles de données sont utiles lorsqu'elles sont utilisées comme sous-formulaires pour afficher des données du côté « plusieurs » d'une relation un-à-plusieurs. Cet article explique comment ajouter des feuilles de données à vos formulaires dans Office Access 2007.

Que voulez-vous faire ?

Afficher un exemple d’une feuille de données dans un formulaire

Établir des relations entre tables

Créer un formulaire contenant une feuille de données à l’aide de l’outil formulaire

Créer un formulaire contenant une feuille de données en mode page

Insérer une feuille de données dans un formulaire existant en mode page

Insérer une feuille de données dans un formulaire existant en mode Création

Découvrez les différences entre un formulaire double affichage et un formulaire contenant une feuille de données

Afficher un exemple de feuille de données sur un formulaire

Supposons que vous vouliez créer un formulaire qui affiche des données concernant des catégories de produits ainsi que les produits de ces catégories. Les données de la table Catégories représentent le côté « un » de la relation, alors que les données de la table Produits représentent le côté « plusieurs » de cette relation. Chaque catégorie peut avoir de nombreux produits.

Formulaire contenant un sous-formulaire

1. Le formulaire principal affiche les données du côté « un » de la relation.

2. La feuille de données affiche les données du côté « plusieurs » de la relation.

Haut de la Page

Établir des relations entre des tables

Avant d'aborder la création d'un formulaire contenant une feuille de données, vous avez intérêt à étudier les relations existant entre vos tables et ajouter les relations éventuellement manquantes. Cela permet à Access de créer automatiquement les liens entre les feuilles de données et les formulaires principaux. Pour afficher, ajouter ou modifier les relations entre les tables de votre base de données, dans l'onglet Outils avancés, groupe Analyser, cliquez sur Relations. Pour plus d'informations sur la création de relations, voir la section Voir aussi.

Haut de la Page

Créer un formulaire contenant une feuille de données à l'aide de l'outil Formulaire

Lorsque vous utilisez l'outil Formulaire pour créer un formulaire qui est basé sur une table qui figure sur « un » côté d'une relation un-à-plusieurs unique, Access insère automatiquement une feuille de données qui affiche les données du côté « plusieurs » de la relation.

Par exemple, si les conditions suivantes sont réunies, Access insère une feuille de données qui présente toutes les commandes de chaque client :

  • Vous avez créé un formulaire standard basé sur la table Clients.

  • Vous avez défini une relation un-à-plusieurs avec la table Commandes qui spécifie qu'un enregistrement de la table Clients peut être lié à plusieurs enregistrements de la table Commandes.

  • La table Client ne se trouve pas du côté « un » d'une autre relation un-à-plusieurs.

  • Dans le volet de navigation, cliquez sur la table qui se trouve du côté « un » de la relation un-à-plusieurs.

  • Sous l’onglet créer, dans le groupe formulaires, cliquez sur formulaire. Image du bouton

Access crée le formulaire en plaçant la feuille de données au bas de ce dernier. Si Access ne crée pas de feuille de données, cela signifie que la table que vous avez utilisée pour le formulaire ne fait pas partie d'une relation un-à-plusieurs, ou que cette table fait partie de plusieurs relations un-à-plusieurs.

Remarques : 

  • Mis à part le formulaire principal, cette procédure ne crée aucun autre objet de formulaire. La feuille de données est une vue directe de la table.

  • Pour masquer une colonne dans une feuille de données    Cliquez avec le bouton droit sur la colonne, puis cliquez sur Masquer la colonne. Ce paramétrage est enregistré. Par conséquent, si vous enregistrez et fermez le formulaire et que vous le rouvrez, la colonne sera toujours masquée.

  • Pour restaurer une colonne masquée dans une feuille de données    Cliquez avec le bouton droit sur un en-tête de colonne de la feuille de données, puis cliquez sur Afficher les colonnes. Activez la case à cocher en regard de chaque colonne dont vous souhaitez rétablir l'affichage, puis cliquez sur Fermer.

Haut de la Page

Créer un formulaire contenant une feuille de données à l'aide du mode Page

Si, dans votre base de données, vous avez déjà défini les relations entre tables, vous pouvez créer rapidement un formulaire contenant une feuille de données standard à l'aide du mode Page. Lorsque vous ajoutez un champ du côté « plusieurs » d'une relation à un formulaire basé sur le côté « un » de la relation, Access crée automatiquement une feuille de données pour afficher les enregistrements associés.

  1. Sous l’onglet créer, dans le groupe formulaires, cliquez sur Formulaire vierge. Image du bouton

    Access ouvre un formulaire vierge en mode Page et affiche le volet Liste des champs .

    Remarque : Si vous fermez accidentellement le volet Liste de champs, vous pouvez le rouvrir en effectuant l'une des opérations suivantes :

    • Appuyez sur ALT+F8.

      —ou—

      Sous l’onglet Format, dans le groupe contrôles, cliquez sur Ajouter des champs existants. Image du bouton

  2. Cliquez sur le signe plus en regard de la table située du côté « un » de la relation un-à-plusieurs, puis faites glisser le premier champ de votre choix vers le formulaire.

    Notez que le volet Liste de champs divise les tables en sections : Champs disponibles pour cette vue et, en dessous de celle-ci, Champs disponibles dans les tables associées. Au bas du volet Liste champs, les autres champs qui ne sont pas directement liés à la table principale sont répertoriés sous Champs disponibles dans les autres tables.

  3. Depuis la section Champs disponibles pour cet affichage, faites glisser les champs désirés sur le formulaire principal.

  4. Depuis la section Champs disponibles dans les tables associées, faites glisser le premier champ désiré de votre feuille de données sur le formulaire. Access crée une feuille de données et y ajoute le champ.

  5. Vous devez d'abord cliquer sur la feuille de données Money pour ajouter d'autres champs à la feuille de données nouvelle pour le sélectionner. Notez qu'Access réorganise le volet Liste des champs afin que les champs disponibles pour la feuille de données se trouvent au sommet. À partir de la section Champs disponibles pour cette vue, faites glisser n'importe quel autre champ de votre choix sur la feuille de données. Tandis que vous faites glisser chaque champ sur la feuille de données, Access dessine une barre d'insertion pour vous indiquer l'emplacement où sera inséré le champ lorsque vous relâcherez le bouton de souris.

  6. Continuez à ajouter des champs au formulaire principal ou à la feuille de données en cliquant d'abord sur le formulaire principal ou sur la feuille de données pour le sélectionner, puis en faisant glisser le champ depuis le volet Liste de champs.

La section champs disponibles dans les autres tables du volet Liste de champs contient les tables qui ne sont pas directement liés à la table ou requête basée sur la feuille de données ou le formulaire sélectionné. Si vous avez défini toutes les relations de table valide dans la fenêtre Relations, les champs dans la section champs disponibles dans les autres tables ne sont pas susceptibles d’être valides pour le formulaire que vous créez. Si vous faites glisser un champ à partir de cette section au formulaire, Access affiche la boîte de dialogue Spécifier la relation. Vous devez entrer l’ou les champs qui sont associés entre les deux tables eux avant de poursuivre. Si vous procédez ainsi, le volet Liste de champs ne sera plus sections triées en fonction des relations prédéfinies. Il peut être préférable de cliquer sur Annuler dans cette boîte de dialogue et de réexaminer les relations entre les tables à la place. Pour plus d’informations sur les relations, voir l’article créer, modifier ou supprimer une relation.

Haut de la Page

Insérer une table ou une feuille de données de requêtes dans un formulaire existant avec le mode Page

Si vous avez déjà défini les relations entre les tables de votre base de données, vous pouvez rapidement ajouter une feuille de données à un formulaire existant en mode Page. Lorsque vous ajoutez un champ du côté « plusieurs » d'une relation à un formulaire basé sur le côté « un » de la relation, Access crée automatiquement une feuille de données pour afficher les enregistrements associés.

  1. Ouvrez le formulaire existant en mode Page en cliquant avec le bouton droit sur son nom dans le volet de navigation, puis cliquez sur Mode Page dans le menu contextuel.

    Si le volet Liste des champs n'est pas affiché :

    • Appuyez sur ALT+F8.

      —ou—

      Sous l’onglet Format, dans le groupe contrôles, cliquez sur Ajouter des champs existants. Image du bouton

      Notez que le volet Liste de champs divise les tables en sections : Champs disponibles pour cette vue et, en dessous de celle-ci, Champs disponibles dans les tables associées. Au bas du volet Liste champs, les autres champs qui ne sont pas directement liés à la table principale sont répertoriés sous Champs disponibles dans les autres tables.

  2. Dans la section Champs disponibles dans les tables associées, développez la table contenant le premier champ que vous souhaitez intégrer à votre feuille de données, puis faites glisser ce champ vers le formulaire. Access crée une feuille de données et y ajoute le champ.

  3. Vous devez d'abord cliquer sur la feuille de données Money pour ajouter d'autres champs à la nouvelle feuille de données. Notez qu'Access réorganise le volet Liste de champs, afin que les champs disponibles pour la feuille de données se trouvent au sommet. À partir de la section Champs disponibles pour cette vue , faites glisser n'importe quel autre champ de votre choix sur la feuille de données. Tandis que vous faites glisser chaque champ sur la feuille de données, Access dessine une barre d'insertion pour vous indiquer l'emplacement où sera inséré le champ lorsque vous relâcherez le bouton de souris.

  4. Continuez à ajouter des champs au formulaire principal ou à la feuille de données en cliquant d'abord sur le formulaire principal ou sur la feuille de données pour le sélectionner, puis en faisant glisser le champ depuis le volet Liste de champs.

La section champs disponibles dans les autres tables du volet Liste de champs contient les tables qui ne sont pas directement liés à la table ou requête basée sur le formulaire sélectionné. Si vous avez défini toutes les relations de table valide dans la fenêtre Relations, les champs dans la section champs disponibles dans les autres tables ne sont pas susceptibles d’être valides pour le formulaire que vous créez. Si vous faites glisser un champ à partir de cette section au formulaire, Access affiche la boîte de dialogue Spécifier la relation. Vous devez entrer l’ou les champs qui sont associés entre les deux tables eux avant de poursuivre. Si vous procédez ainsi, le volet Liste de champs n’est plus sont trié en sections en fonction des relations prédéfinies. Il peut être préférable de cliquer sur Annuler dans cette boîte de dialogue et de réexaminer les relations entre les tables à la place. Pour plus d’informations sur les relations, voir l’article créer, modifier ou supprimer une relation.

Haut de la Page

Insérer une feuille de données dans un formulaire existant en mode Création

Cette procédure permet d'ajouter une feuille de données directement basée sur une table ou une requête à un formulaire existant en mode Création.

  1. Ouvrez le formulaire en mode Création en cliquant dessus avec le bouton droit dans le volet de navigation, puis en cliquant sur Mode Création.

  2. Dans l'onglet Création, groupe Contrôles, si l'outil Utiliser les Assistants Contrôles est sélectionné, cliquez dessus pour le désactiver.

    Image du bouton

    Pourquoi ?

    S'il est utilisé, l'Assistant Contrôle de sous-formulaire crée un objet de formulaire distinct et base le contrôle de sous-formulaire sur cet objet. En revanche, cette procédure crée une feuille de données directement basée sur une table ou une requête et non sur un formulaire.

  3. Sous l’onglet Création, dans le groupe contrôles, cliquez sur le bouton Image du bouton Sous-formulaire/sous-état. Image du bouton

  4. Dans la grille de création de formulaire, cliquez à l'endroit où vous souhaitez insérer la grille de données.

  5. Repositionnez et redimensionnez le contrôle de sous-formulaire en faisant glisser les poignées des bords et des coins du contrôle.

  6. Modifiez l'étiquette attachée du contrôle de sous-formulaire en cliquant d'abord sur l'étiquette, en double-cliquant dessus pour en sélectionner le texte, puis en tapant un nouveau libellé. Si vous préférez supprimer l'étiquette, cliquez une fois sur celle-ci, puis appuyez sur Suppr.

  7. Si la feuille de propriétés n'est pas déjà affichée, appuyez sur F4 pour l'afficher.

  8. Si le contrôle de sous-formulaire n'est pas actuellement sélectionné, cliquez une fois dessus.

  9. Sous l'onglet Données de la feuille de propriétés, cliquez dans la liste déroulante Objet source, puis sélectionnez la table ou la requête que vous souhaitez afficher dans la feuille de données. Par exemple, si vous voulez afficher les données de la table Commandes, cliquez sur Table.Commandes.

  10. Si vous avez correctement configuré les relations avant de commencer cette procédure, Access affecte automatiquement aux propriétés Lier les champs enfants et Lier les champs pères les valeurs correctes qui lieront le formulaire principal à la feuille de données.

    Mes propriétés lier les champs enfants et lier les champs pères sont vides

    Si Access n'est pas en mesure de lier le contrôle de sous-formulaire au formulaire principal, il conserve les propriétés Lier les champs enfants et Lier les champs pères du contrôle de sous-formulaire vides. Vous devez les définir manuellement en procédant comme suit :

    1. Ouvrez le formulaire principal en mode Création.

    2. Cliquez une fois sur le contrôle de sous-formulaire pour le sélectionner.

    3. Si la feuille des propriétés n'est pas affichée, appuyez sur F4.

    4. Dans l'onglet Données de la feuille des propriétés, cliquez sur ... en regard de la boîte des propriétés Lier les champs fils.

      La boîte de dialogue Gestionnaire de liaisons du sous-formulaire s'affiche.

    5. Dans les listes déroulantes Champs pères et Champs fils, sélectionnez les champs auxquels vous voulez lier les formulaires. Si vous ne savez pas exactement quels champs utiliser, cliquez sur Suggérer pour qu'Access détermine les champs à lier. Lorsque vous avez terminé, cliquez sur OK.

      Si vous ne voyez pas le champ que vous voulez utiliser pour lier les formulaires, vous pouvez éventuellement modifier la source du formulaire père ou fils pour vérifier que le champ s'y trouve. Par exemple, si le formulaire est basé sur une requête, vérifiez que le champ à lier est présent dans les résultats de la requête.

    6. Enregistrez le formulaire principal et passez au mode Formulaire pour vérifier que le formulaire se comporte comme prévu.

  11. Enregistrez le formulaire en cliquant sur Enregistrer Image du bouton sur la Barre d’outils Accès rapide ou en appuyant sur CTRL + S.

  12. Passez en mode Formulaire et vérifiez que la feuille de données fonctionne comme prévu.

Haut de la Page

Différences entre un formulaire fractionné et un formulaire contenant une feuille de données

Un formulaire qui contient une feuille de données affiche les données de plusieurs sources de données (en générales associées). Par exemple, un formulaire peut montrer les employés et contenir une feuille de données qui montre toutes les tâches affectées à chaque employé. La feuille de données possède une source de données différente du formulaire qui le contient. Un formulaire fractionné possède deux sections (un formulaire et une feuille de données), mais les mêmes données sont affichées dans les deux sections. Les deux sections sont dynamiques et permettent de montrer deux affichages des données.

Pour plus d’informations sur la création et l’utilisation d’un formulaire double affichage, voir l’article créer un formulaire double affichage.

Haut de la Page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×