Insérer un objet dans votre feuille de calcul Excel

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Vous pouvez utiliser Object Linking and Embedding (OLE) pour inclure le contenu à partir d’autres programmes, tels que Word ou Excel.

OLE est pris en charge par différents programmes et OLE est utilisé pour rendre le contenu est créé dans un programme disponible dans un autre programme. Par exemple, vous pouvez insérer un document Office Word dans un classeur Office Excel. Pour voir quels types de contenu que vous pouvez insérer, cliquez sur objet dans le groupe texte sous l’onglet Insertion. Seuls les programmes installés sur votre ordinateur et qui prennent en charge les objets OLE apparaissent dans la zone type d’objet.

Si vous copiez des informations entre Excel ou n’importe quel programme qui prend en charge OLE, telle que Word, vous pouvez copier les informations comme un objet lié ou un objet incorporé. Les principales différences entre objets liés et incorporés sont où sont stockées les données et comment l’objet est mis à jour une fois que vous placez dans la fichier de destination. Objets incorporés sont stockés dans le classeur dans lequel ils sont insérés, et elles ne sont pas mises à jour. Objets liés restent en tant que fichiers distincts, et ils peuvent être mis à jour.

Objets liés et incorporés dans un document

Objets liés et incorporés dans un document Office pour Windows

1. un objet incorporé a aucune connexion vers le fichier source.

2. un objet lié est lié au fichier source.

3. le fichier source met à jour l’objet lié.

Quand utiliser des objets liés

Si vous souhaitez que les informations dans votre fichier de destination mise à jour lorsque les données dans le fichier source sont modifiées, utilisez des objets liés.

Avec un objet lié, les informations d'origine restent stockées dans le fichier source. Le fichier de destination affiche une représentation des informations liées mais stocke uniquement l'emplacement des données d'origine (ainsi que la taille s'il s'agit d'un objet de graphique Excel). Le fichier source doit demeurer disponible sur votre ordinateur ou votre réseau pour conserver le lien vers les données d'origine.

Les informations liées peuvent être mis à jour automatiquement si vous modifiez les données d’origine dans le fichier source. Par exemple, si vous sélectionnez un paragraphe dans un document Word, puis collez le paragraphe comme un objet lié dans un classeur Excel, les informations peuvent être mis à jour dans Excel si vous modifiez les informations dans votre document Word.

Quand utiliser des objets incorporés

Si vous ne voulez pas mettre à jour les données copiées lorsqu’il est modifié dans le fichier source, utilisez un objet incorporé. La version de la source est intégralement incorporée dans le classeur. Si vous copiez des informations sous forme d’objet incorporé, le fichier de destination requiert davantage d’espace disque que si vous liez les informations.

Lorsqu’un utilisateur ouvre le fichier sur un autre ordinateur, il peut afficher l’objet incorporé sans avoir accès aux données d’origine. Car un objet incorporé n’a aucun lien vers le fichier source, l’objet n’est pas mis à jour si vous modifiez les données d’origine. Pour modifier un objet incorporé, double-cliquez sur l’objet pour ouvrir et modifier dans le programme source. Le programme source (ou un autre programme capable de modifier l’objet) doit être installé sur votre ordinateur.

Modifier le mode d’affichage d’un objet OLE

Vous pouvez afficher un objet lié ou objet incorporé dans un classeur exactement tel qu’il apparaît dans la programme source ou sous forme d’icône. Si le classeur est affiché en ligne et que vous ne souhaitez pas imprimer le classeur, vous pouvez afficher l’objet sous forme d’icône. Cela permet de réduire la quantité d’espace disque que l’objet occupe. Les personnes pour afficher les informations peuvent double-cliquer sur l’icône.

Incorporer un objet dans une feuille de calcul

  1. Cliquez à l’intérieur de la cellule de la feuille de calcul dans laquelle vous voulez insérer l’objet.

  2. Sous l’onglet Insertion, dans le groupe texte, cliquez sur objet Icône de l’objet dans le ruban .
    Insérer un objet

  3. Dans la boîte de dialogue objet , cliquez sur l’onglet créer à partir du fichier.

  4. Cliquez sur Parcourir, puis sélectionnez le fichier à insérer.

  5. Si vous voulez insérer une icône dans la feuille de calcul au lieu d’afficher le contenu du fichier, activez la case à cocher Afficher sous forme d’icône . Si vous ne sélectionnez pas les cases à cocher, Excel affiche la première page du fichier. Dans les deux cas, le fichier complet s’ouvre avec un double-clic. Cliquez sur OK.

    Remarque : Après avoir ajouté l’icône ou le fichier, vous pouvez faire glisser et déposez-la n’importe où sur la feuille de calcul. Vous pouvez également redimensionner l’icône ou le fichier en utilisant les poignées de redimensionnement. Pour rechercher les poignées, cliquez sur l’icône ou le fichier une seule fois.

Insérer un lien vers un fichier

Vous souhaiterez peut-être simplement ajouter un lien vers l’objet plutôt qu’entièrement incorporant. Vous pouvez le faire si votre classeur et l’objet que vous voulez ajouter sont stockés sur un site SharePoint, un lecteur réseau partagé ou un emplacement similaire, et si l’emplacement des fichiers restera identique. C’est pratique si l’objet lié fait l’objet de modifications, car le lien ouvre toujours le document plus à jour.

Remarque : Si vous déplacez le fichier lié vers un autre emplacement, le lien cesse de fonctionner.

  1. Cliquez à l’intérieur de la cellule de la feuille de calcul dans laquelle vous voulez insérer l’objet.

  2. Sous l’onglet Insertion, dans le groupe texte, cliquez sur objet Icône de l’objet dans le ruban .
    Insérer un objet

  3. Cliquez sur l’onglet créer à partir du fichier .

  4. Cliquez sur Parcourir et sélectionnez le fichier que vous souhaitez lier.

  5. Activez la case à cocher Lier au fichier, puis cliquez sur OK.

Créer un objet à partir d’Excel

Vous pouvez créer un objet entièrement nouvel basé sur un autre programme sans quitter votre classeur. Par exemple, si vous voulez ajouter une explication plus détaillée à votre graphique ou un tableau, vous pouvez créer un document incorporé, tel qu’un fichier Word ou PowerPoint, dans Excel. Vous pouvez définir votre objet à afficher avec le bouton droit dans une feuille de calcul ou ajouter une icône qui ouvre le fichier.

Cet objet incorporé est un document Word.
  1. Cliquez à l’intérieur de la cellule de la feuille de calcul dans laquelle vous voulez insérer l’objet.

  2. Sous l’onglet Insertion, dans le groupe texte, cliquez sur objet Icône de l’objet dans le ruban .
    Insérer un objet

  3. Sous l’onglet Nouvel objet, dans la liste affichée, sélectionnez le type d’objet à insérer. Si vous voulez insérer une icône à la place de l’objet dans la feuille de calcul, activez la case à cocher Afficher sous forme d’icône.

  4. Cliquez sur OK. Selon le type de fichier que vous insérez, une nouvelle fenêtre d’application s’ouvre ou une fenêtre d’édition s’affiche dans Excel.

  5. Créer l’objet à insérer.

    Lorsque vous avez terminé, si Excel a ouvert une nouvelle fenêtre d’application dans laquelle vous avez créé l’objet, vous pouvez travailler directement dans celle-ci.

    Vous pouvez modifier le document Word incorporé directement dans Excel.

    Lorsque vous avez terminé de travailler dans la fenêtre, vous pouvez effectuer d’autres tâches sans enregistrer l’objet incorporé. Lorsque vous fermez le classeur vos nouveaux objets seront enregistrés automatiquement.

    Remarque : Une fois l’objet ajouté, vous pouvez glisser-déplacer celui-ci n’importe où sur votre feuille de calcul Excel. Vous pouvez également redimensionner l’objet à l’aide des poignées de redimensionnement. Pour trouver les poignées, cliquez une fois sur l’objet.

Incorporer un objet dans une feuille de calcul

  1. Cliquez à l’intérieur de la cellule de la feuille de calcul dans laquelle vous voulez insérer l’objet.

  2. Sous l’onglet Insertion, dans le groupe Texte, cliquez sur Objet.

    L’option Objet apparaît sous l’onglet Insertion.
  3. Cliquez sur l’onglet créer à partir du fichier.

    Onglet Créer à partir d’un fichier dans la boîte de dialogue Objet
  4. Cliquez sur Parcourir, puis sélectionnez le fichier à insérer.

  5. Si vous voulez insérer une icône dans la feuille de calcul au lieu d’afficher le contenu du fichier, activez la case à cocher Afficher sous forme d’icône . Si vous ne sélectionnez pas les cases à cocher, Excel affiche la première page du fichier. Dans les deux cas, le fichier complet s’ouvre avec un double-clic. Cliquez sur OK.

    Remarque : Après avoir ajouté l’icône ou le fichier, vous pouvez faire glisser et déposez-la n’importe où sur la feuille de calcul. Vous pouvez également redimensionner l’icône ou le fichier en utilisant les poignées de redimensionnement. Pour rechercher les poignées, cliquez sur l’icône ou le fichier une seule fois.

Insérer un lien vers un fichier

Vous souhaiterez peut-être simplement ajouter un lien vers l’objet plutôt qu’entièrement incorporant. Vous pouvez le faire si votre classeur et l’objet que vous voulez ajouter sont stockés sur un site SharePoint, un lecteur réseau partagé ou un emplacement similaire, et si l’emplacement des fichiers restera identique. C’est pratique si l’objet lié fait l’objet de modifications, car le lien ouvre toujours le document plus à jour.

Remarque : Si vous déplacez le fichier lié vers un autre emplacement, le lien cesse de fonctionner.

  1. Cliquez à l’intérieur de la cellule de la feuille de calcul dans laquelle vous voulez insérer l’objet.

  2. Sous l’onglet Insertion, dans le groupe Texte, cliquez sur Objet.

    L’option Objet apparaît sous l’onglet Insertion.
  3. Cliquez sur l’onglet créer à partir du fichier .

  4. Cliquez sur Parcourir et sélectionnez le fichier que vous souhaitez lier.

  5. Activez la case à cocher Lier au fichier, puis cliquez sur OK.

    Sous l’onglet Créer à partir du fichier, sélectionnez Lier au fichier.

Créer un objet à partir d’Excel

Vous pouvez créer un objet entièrement nouvel basé sur un autre programme sans quitter votre classeur. Par exemple, si vous voulez ajouter une explication plus détaillée à votre graphique ou un tableau, vous pouvez créer un document incorporé, tel qu’un fichier Word ou PowerPoint, dans Excel. Vous pouvez définir votre objet à afficher avec le bouton droit dans une feuille de calcul ou ajouter une icône qui ouvre le fichier.

Cet objet incorporé est un document Word.
  1. Cliquez à l’intérieur de la cellule de la feuille de calcul dans laquelle vous voulez insérer l’objet.

  2. Sous l’onglet Insertion, dans le groupe Texte, cliquez sur Objet.

    L’option Objet apparaît sous l’onglet Insertion.
  3. Sous l’onglet Nouvel objet, dans la liste affichée, sélectionnez le type d’objet à insérer. Si vous voulez insérer une icône à la place de l’objet dans la feuille de calcul, activez la case à cocher Afficher sous forme d’icône.

    Onglet Créer dans la boîte de dialogue Objet
  4. Cliquez sur OK. Selon le type de fichier que vous insérez, une nouvelle fenêtre d’application s’ouvre ou une fenêtre d’édition s’affiche dans Excel.

  5. Créer l’objet à insérer.

    Lorsque vous avez terminé, si Excel a ouvert une nouvelle fenêtre d’application dans laquelle vous avez créé l’objet, vous pouvez travailler directement dans celle-ci.

    Vous pouvez modifier le document Word incorporé directement dans Excel.

    Lorsque vous avez terminé de travailler dans la fenêtre, vous pouvez effectuer d’autres tâches sans enregistrer l’objet incorporé. Lorsque vous fermez le classeur vos nouveaux objets seront enregistrés automatiquement.

    Remarque : Une fois l’objet ajouté, vous pouvez glisser-déplacer celui-ci n’importe où sur votre feuille de calcul Excel. Vous pouvez également redimensionner l’objet à l’aide des poignées de redimensionnement. Pour trouver les poignées, cliquez une fois sur l’objet.

Lier ou incorporer du contenu d'un autre programme à l'aide d'OLE

Vous pouvez lier ou incorporer l'ensemble ou une partie du contenu d'un autre programme.

Créer un lien vers contenu à partir d’un autre programme

  1. Cliquez dans la feuille de calcul où vous voulez placer la objet lié.

  2. Sous l'onglet Insertion, dans le groupe Texte, cliquez sur Objet.

    Image Ruban Excel

  3. Cliquez sur l’onglet créer à partir du fichier.

  4. Dans la zone nom de fichier, tapez le nom du fichier, ou cliquez sur Parcourir pour le sélectionner dans la liste.

  5. Activez la case à cocher lier au fichier.

  6. Effectuez l’une des opérations suivantes :

    • Pour afficher le contenu, désactivez la case à cocher Afficher sous forme d’icône.

    • Pour afficher une icône, activez la case à cocher Afficher sous forme d’icône. Vous pouvez également pour modifier l’image de l’icône par défaut ou l’étiquette, cliquez sur Changer d’icône, puis cliquez sur l’icône de votre choix dans la liste icône ou tapez une étiquette dans la zone légende.

    Remarque : Vous ne pouvez pas utiliser la commande objet pour insérer des graphiques et certains types de fichiers. Pour insérer un graphique ou un fichier, sous l’onglet Insertion, dans le groupe Illustrations, cliquez sur image.

Incorporer du contenu à partir d’un autre programme

  1. Cliquez dans la feuille de calcul où vous voulez placer la objet incorporé.

  2. Sous l'onglet Insertion, dans le groupe Texte, cliquez sur Objet.

    Image Ruban Excel

  3. Si le document n'existe pas déjà, cliquez sur l'onglet Nouvel objet. Dans la zone Type d'objet, cliquez sur le type d'objet que vous voulez créer.

    Si le document existe déjà, cliquez sur l'onglet Créer à partir du fichier. Dans la zone Nom du fichier, tapez le nom du fichier ou cliquez sur Parcourir pour le sélectionner dans une liste.

  4. Désactivez la case à cocher Lier au fichier.

  5. Effectuez l’une des opérations suivantes :

    • Pour afficher le contenu, désactivez la case à cocher Afficher sous forme d’icône.

    • Pour afficher une icône, activez la case à cocher Afficher sous forme d’icône. Pour modifier l’image de l’icône par défaut ou l’étiquette, cliquez sur Changer d’icône, puis cliquez sur l’icône de votre choix dans la liste icône ou tapez une étiquette dans la zone légende.

Lier ou incorporer du contenu partiel à partir d’un autre programme

  1. À partir d’un programme autre que Excel, sélectionnez les informations que vous voulez copier sous la forme lié ou objet incorporé.

  2. Dans l’onglet Accueil, dans le groupe Presse-papiers, cliquez sur Copier.

    Image du ruban Excel

  3. Basculer vers la feuille de calcul que vous souhaitez placer les informations dans, puis cliquez sur l’endroit où vous souhaitez faire figurer les informations.

  4. Dans le groupe Presse-papiers de l’onglet Accueil, cliquez sur la flèche affichée au-dessous de Coller et sélectionnez Collage spécial.

  5. Effectuez l’une des opérations suivantes :

    • Pour coller les informations en tant qu'objet lié, cliquez sur Coller avec liaison.

    • Pour coller les informations sous forme d’objet incorporé, cliquez sur Coller. Dans la zone en tant que, cliquez sur l’entrée avec le mot « objet » dans son nom. Par exemple, si vous avez copié les informations à partir d’un document Word, cliquez sur Objet Document Microsoft Word.

Modifier l'affichage d'un objet OLE

  1. Cliquez sur l’icône ou l’objet, pointez sur le type d’objetobjet (par exemple, Objet Document ), puis cliquez sur convertir.

  2. Effectuez l’une des opérations suivantes :

    • Pour afficher le contenu, désactivez la case à cocher Afficher sous forme d’icône.

    • Pour afficher une icône, activez la case à cocher Afficher sous forme d’icône. Si vous le souhaitez, vous pouvez modifier l’image de l’icône par défaut ou l’étiquette. Pour ce faire, cliquez sur Changer d’icône, puis cliquez sur l’icône de votre choix dans la liste icône ou tapez une étiquette dans la zone légende.

Contrôler les mises à jour des objets liés

Vous pouvez définir des liens vers d’autres programmes à mettre à jour des façons suivantes : automatiquement, lorsque vous ouvrez le fichier de destination; manuellement, lorsque vous souhaitez afficher les données précédente avant la mise à jour avec les nouvelles données à partir de la fichier source; ou lorsque vous demandez spécifiquement la mise à jour, indépendamment de si une mise à jour automatique ou manuel est activé.

Définir une liaison vers un autre programme à mettre à jour

  1. Dans l’onglet Données, dans le groupe Connexions, cliquez sur Modifier les liens.

    Image Ruban Excel

    Remarque : La commande Modifier les liens d'accès n'est pas disponible si votre fichier ne contient pas de liaisons vers d'autres fichiers.

  2. Dans la liste Source, cliquez sur l’objet lié à mettre à jour. Un A dans la colonne mettre à jour signifie que le lien est automatique et un M dans les moyens de colonne de mettre à jour le lien est défini sur la mise à jour manuelle.

    Conseil : Pour sélectionner plusieurs objets liés, maintenez la touche CTRL enfoncée, puis cliquez sur chacun des objets liés. Pour sélectionner tous les objets liés, appuyez sur CTRL+A.

  3. Pour mettre à jour un objet lié uniquement lorsque vous cliquez sur Mettre à jour les valeurs, cliquez sur Manuelle.

Définir une liaison vers un autre programme à mettre à jour automatiquement

  1. Dans l’onglet Données, dans le groupe Connexions, cliquez sur Modifier les liens.

    Image Ruban Excel

    Remarque : La commande Modifier les liens d'accès n'est pas disponible si votre fichier ne contient pas de liaisons vers d'autres fichiers.

  2. Dans la liste Source, cliquez sur l'objet lié que vous voulez mettre à jour. La lettre A dans la colonne Mettre à jour signifie que la liaison sera automatiquement mise à jour, tandis que la lettre M dans la colonne Mettre à jour signifie que la liaison doit être mise à jour manuellement.

    Conseil : Pour sélectionner plusieurs objets liés, maintenez la touche CTRL enfoncée et cliquez sur chaque objet lié. Pour sélectionner tous les objets liés, appuyez sur CTRL+A.

  3. Cliquez sur OK.

Problème : je ne parviens pas à mettre à jour les liens automatiques sur ma feuille de calcul

L'option Automatique peut être remplacée par l'option Excel Mise à jour des liaisons vers d'autres documents.

Pour vous assurer qu’automatique des liens aux objets OLE peut être automatiquement mises à jour :

  1. Cliquez sur le Bouton Microsoft Office Image du bouton Office et cliquez sur Options Excel, puis cliquez sur la catégorie Options avancées.

  2. Sous lors du calcul de ce classeur, vérifiez que la case à cocher mettre à jour les liens vers d’autres documents est activée.

Mettre à jour une liaison vers un autre programme

  1. Dans l’onglet Données, dans le groupe Connexions, cliquez sur Modifier les liens.

    Image Ruban Excel

    Remarque : La commande Modifier les liens n’est pas disponible si votre fichier ne contient pas d’informations liées.

  2. Dans la liste Source, cliquez sur l’objet lié à mettre à jour.

    Conseil : Pour sélectionner plusieurs objets liés, maintenez la touche CTRL enfoncée, puis cliquez sur chacun des objets liés. Pour sélectionner tous les objets liés, appuyez sur CTRL+A.

  3. Cliquez sur Mettre à jour les valeurs.

Modifier le contenu d'un programme OLE

Lorsque vous êtes dans Excel, vous pouvez modifier le contenu lié ou incorporé à partir d’un autre programme.

Modifier un objet lié dans le programme source

  1. Dans l’onglet Données, dans le groupe Connexions, cliquez sur Modifier les liens.

    Image Ruban Excel

    Remarque : La commande Modifier les liens n’est pas disponible si votre fichier ne contient pas d’informations liées.

  2. Dans la liste Source, cliquez sur la source pour la objet lié, puis cliquez sur Ouvrir la Source.

  3. Apportez les modifications souhaitées à l'objet lié.

  4. Quittez programme source pour revenir au fichier de destination.

Modifier un objet incorporé dans le programme source

  1. Double-cliquez sur objet incorporé pour l’ouvrir.

  2. Apportez les modifications souhaitées à l'objet.

  3. Si vous modifiez l’objet directement dans le programme ouvert, cliquez n’importe où en dehors de l’objet pour revenir à la fichier de destination.

    Si vous modifiez l'objet incorporé dans le programme source dans une fenêtre séparée, quittez le programme source pour retourner au fichier de destination.

Remarque : Double-cliquer sur certains objets incorporés, tels que des clips audio et vidéo, lit l’objet au lieu d’ouvrir un programme. Pour modifier l’un de ces objets incorporés, cliquez sur l’icône ou l’objet, pointez sur le type d’objetobjet (par exemple, Objet Clip multimédia ), puis cliquez sur Modifier.

Modifier un objet incorporé dans un programme autre que le programme source

  1. Sélectionnez le objet incorporé que vous voulez modifier.

  2. Cliquez sur l’icône ou l’objet, pointez sur le type d’objetobjet (par exemple, Objet Document ), puis cliquez sur convertir.

  3. Effectuez l’une des opérations suivantes :

    • Pour convertir l’objet incorporé au type que vous spécifiez dans la liste, cliquez sur convertir en.

    • Pour ouvrir l'objet incorporé comme type spécifié dans la liste sans modifier le type d'objet incorporé, cliquez sur Activer.

Sélectionner un objet OLE à l'aide du clavier

  1. Appuyez sur CTRL+T pour ouvrir la boîte de dialogue Atteindre.

  2. Cliquez sur spécial, sélectionner des objets, puis cliquez sur OK.

  3. Appuyez sur TAB jusqu'à ce que l'objet souhaité soit sélectionné.

  4. Appuyez sur Maj+F10.

  5. Pointez sur Objet ou Objet graphique, puis cliquez sur Modifier.

Problème : Quand je double-clique sur un objet lié ou incorporé, un message de modification impossible s'affiche.

Ce message s’affiche lorsque le fichier source ou programme source ne peuvent pas être ouverts.

Vérifiez que le programme source est disponible     Si le programme source n’est pas installé sur votre ordinateur, convertissez l’objet au format de fichier d’un programme que vous avez installé.

Assurez-vous que la mémoire est suffisant     Vérifiez que vous disposez d’assez de mémoire pour exécuter le programme source. Fermez les autres programmes pour libérer la mémoire, le cas échéant.

Fermez toutes les boîtes de dialogue     Si le programme source est en cours d’exécution, vérifiez qu’elle ne comporte toutes les boîtes de dialogue Ouvrir. Basculer vers le programme source, puis fermez toutes les boîtes de dialogue Ouvrir.

Fermez le fichier source     Si le fichier source est un objet lié, assurez-vous qu’un autre utilisateur ne l’a ouvert.

Assurez-vous que le nom du fichier source n’a pas changé     Si le fichier source que vous voulez modifier est un objet lié, assurez-vous qu’il porte le même nom qu’elle avait lorsque vous avez créé le lien et qu’il n’a pas été déplacé. Sélectionnez l’objet lié, puis cliquez sur la commande Modifier les liens dans le groupe connexions sous l’onglet données pour voir le nom du fichier source. Si le fichier source a été renommé ou déplacé, utilisez le bouton Modifier la Source dans la boîte de dialogue Modifier les liens pour localiser le fichier source et vous reconnecter le lien.

Vous avez besoin d’une aide supplémentaire ?

Vous pouvez toujours consulter un expert de la communauté technique Excel, obtenir une assistance dans la communauté Answers ou suggérer une nouvelle fonctionnalité ou une amélioration sur le forum Excel User Voice.

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×