Insérer automatiquement du texte

Dans Word, vous pouvez insérer automatiquement du texte avec des blocs de texte préformaté provenant de votre galerie d’insertions automatiques, ou avec des mots, des expressions ou des phrases que Word complète automatiquement après que vous avez tapé quelques caractères.

Remarque : Pour plus d’informations sur les paramètres de mise en forme automatique, comme la mise en forme automatique des traits d’union, tirets, fractions, liens hypertexte, guillemets et listes à puces ou numérotées, voir Configurer ou désactiver la mise en forme automatique du texte.

Les insertions automatiques sont stockées sous la forme de blocs de construction. Pour créer une nouvelle entrée, utilisez la boîte de dialogue Créer un nouveau bloc de construction.

  1. Dans votre document, sélectionnez le texte que vous voulez ajouter à votre galerie d’insertions automatiques.

  2. Dans l’onglet Insertion, dans le groupe Texte, cliquez sur QuickPart, pointez sur InsertionAuto, puis cliquez sur Enregistrer la sélection dans la galerie d’insertion automatique.

  3. Complétez les informations nécessaires dans la boîte de dialogue Créer un nouveau bloc de construction. La plupart des valeurs par défaut sont correctes, mais l’insertion d’un nom unique et d’une description facilite l’utilisation de l’insertion automatique.

    Boîte de dialogue Créer un nouveau bloc de construction

    • Nom    Tapez un nom unique pour le bloc de construction Insertion automatique.

    • Galerie    Sélectionnez la galerie Insertion automatique.

    • Catégorie    Sélectionnez la catégorie Général ou créez une catégorie.

    • Description    Tapez une description du bloc de construction.

    • Enregistrer dans    Cliquez sur le nom du modèle dans la liste déroulante. Par exemple, cliquez sur Normal

      Un modèle doit être ouvert afin de s’afficher dans la liste déroulante des noms de modèles.

    • Options    Choisissez l’une des options suivantes :

      • Sélectionnez Insérer un contenu dans sa propre page pour placer le bloc de construction dans une autre page, séparée du reste de votre contenu à l’aide de sauts de page.

      • Sélectionnez Insérer le contenu dans son paragraphe afin que le contenu se trouve dans un paragraphe séparé, même si le curseur de l’utilisateur se trouve au milieu d’un paragraphe.

      • Sélectionnez Insérer uniquement le contenu pour tous les autres types de contenu.

Haut de la page

  1. Dans l’onglet Insertion, cliquez sur QuickPart, puis pointez sur InsertionAuto.

  2. Cliquez sur l’entrée que vous voulez ajouter.

En ajoutant des entrées de texte dans la boîte de dialogue Correction automatique, vous pouvez configurer Word pour qu’il complète automatiquement un mot, une expression ou une phrase après que vous avez tapé quelques caractères.

  1. Sélectionnez le texte à insérer automatiquement.

  2. Cliquez sur l’onglet Fichier.

  3. Cliquez sur Options.

  4. Cliquez sur Vérification.

  5. Cliquez sur Options de correction automatique, puis cliquez sur l’onglet Correction automatique.

    Boîte de dialogue Correction automatique

  6. Cochez la case Correction en cours de frappe si ce n’est pas déjà fait.

  7. Sous Remplacer, tapez les caractères à utiliser pour votre texte automatique. Le texte sélectionné dans votre document doit apparaître sous Par.

La liste de corrections automatiques est commune à l’ensemble des programmes Office qui prennent en charge la fonctionnalité Correction automatique. Lorsque vous ajoutez ou supprimez un terme de cette liste dans l’un des programmes Office, cette modification est reflétée dans les autres programmes.

Haut de la page

Lorsque vous tapez dans votre document, le texte dans la colonne de gauche de la liste Correction automatique, sous Remplacer, est automatiquement remplacé par le texte dans la colonne de droite, sous Par.

Haut de la page

Voir aussi

Configurer ou désactiver la mise en forme automatique du texte

Choisir les options de correction automatique pour la mise en majuscules, l’orthographe et les symboles

  1. Dans l’onglet Insertion, cliquez sur QuickPart, puis pointez sur InsertionAuto.

  2. Cliquez sur l’entrée que vous voulez ajouter.

Dans Word 2010, les entrées d’insertions automatiques sont stockées sous la forme de blocs de construction. Pour créer une entrée, utilisez la boîte de dialogue Créer un nouveau bloc de construction.

  1. Dans votre document Word, sélectionnez le texte que vous voulez ajouter à votre galerie d’insertions automatiques.

  2. Dans l’onglet Insertion, dans le groupe Texte, cliquez sur QuickPart, pointez sur InsertionAuto, puis cliquez sur Enregistrer la sélection dans la galerie d’insertion automatique.

  3. Complétez les informations nécessaires dans la boîte de dialogue Créer un nouveau bloc de construction :

    • Nom    Tapez un nom unique pour le bloc de construction Insertion automatique.

    • Galerie    Sélectionnez la galerie Insertion automatique.

    • Catégorie    Sélectionnez la catégorie Général ou créez une catégorie.

    • Description    Tapez une description du bloc de construction.

    • Enregistrer dans    Cliquez sur le nom du modèle dans la liste déroulante. Par exemple, cliquez sur Normal

      Un modèle doit être ouvert afin de s’afficher dans la liste déroulante des noms de modèles.

    • Options    Choisissez l’une des options suivantes :

      • Sélectionnez Insérer un contenu dans sa propre page pour placer le bloc de construction sur une page distincte, avec des sauts de page situés avant et après.

      • Sélectionnez Insérer le contenu dans son paragraphe afin que le contenu se trouve dans un paragraphe séparé, même si le curseur de l’utilisateur se trouve au milieu d’un paragraphe.

      • Sélectionnez Insérer uniquement le contenu pour tous les autres types de contenu.

Haut de la page

Si vous utilisiez des insertions automatiques dans Microsoft Office Word 2003, vous pouvez les migrer manuellement vers Word 2010. Insertions automatiques que vous avez créées dans Word 2007 sont migrées automatiquement.

  1. Recherchez le fichier Normal11.dot en procédant comme suit :

  2. Si votre ordinateur exécute Windows 7   , ouvrez l’Explorateur Windows, puis accédez à C:\Utilisateurs\nom d’utilisateur\AppData\Roaming\Microsoft\Templates.

    Remarque :  Si vous ne voyez pas le dossier AppData dans l’Explorateur Windows, cliquez sur Organiser, sur Options des dossiers et de recherche, sur l’onglet Affichage, puis sur Afficher les fichiers, dossiers et lecteurs. Ensuite, fermez puis rouvrez l’Explorateur Windows.

  3. Si votre ordinateur exécute Windows Vista    Ouvrez l’Explorateur Windows, puis accédez à C:\Utilisateurs\nom d’utilisateur\AppData\Roaming\Microsoft\Templates.

    Remarque :  Si vous ne voyez pas le dossier AppData dans l’Explorateur Windows, cliquez sur Organiser, sur Options des dossiers et de recherche, sur l’onglet Affichage, puis sur Afficher les fichiers, dossiers et lecteurs. Ensuite, fermez puis rouvrez l’Explorateur Windows.

  4. Si votre ordinateur exécute Windows XP    Ouvrez l’Explorateur Windows, puis accédez à C:\Documents and Settings\nom d’utilisateur\Application Data\Microsoft\Templates.

    Remarque :  Si vous ne voyez pas le dossier Application Data dans l’Explorateur Windows, cliquez sur le menu Outils, sur Options des dossiers, sur l’onglet Affichage, puis sur Afficher les fichiers et les dossiers masqués. Ensuite, fermez puis rouvrez l’Explorateur Windows.

  5. Cliquez avec le bouton droit sur Normal11.dot, puis cliquez sur Ouvrir.

  6. Cliquez sur l’onglet Fichier.

  7. Cliquez sur Enregistrer sous.

  8. Dans la boîte de dialogue Enregistrer sous, accédez à l’emplacement correct :

  9. Si votre ordinateur exécute Windows 7    C:\Utilisateurs\nom d’utilisateur\AppData\Roaming\Microsoft\Word\Démarrage

  10. Si votre ordinateur exécute Windows Vista    C:\Utilisateurs\nom d’utilisateur\AppData\Roaming\Microsoft\Word\Démarrage

  11. Si votre ordinateur exécute Windows XP    C:\Documents and Settings\nom d’utilisateur\Application Data\Microsoft\Word\Démarrage

    Remarque :  Il se peut que vous deviez créer le dossier Démarrage en cliquant sur Nouveau dossier.

  12. Dans la Nom de fichier, tapez Insertion automatique.

  13. Dans la liste Type de fichier, cliquez sur Modèle Word prenant en charge les macros.

  14. Cliquez sur Enregistrer.

    À l’invite, cliquez sur OK.

  15. Quittez Word.

Haut de la page

Pour ajouter des entrées de texte qui sont insérées automatiquement lorsque vous tapez un ensemble spécifique de caractères, vous devez utiliser la boîte de dialogue Correction automatique.

  1. Cliquez sur l’onglet Fichier.

  2. Cliquez sur Options.

  3. Cliquez sur Vérification.

  4. Cliquez sur Options de correction automatique, puis cliquez sur l’onglet Correction automatique.

  5. Activez la case à cocher Correction en cours de frappe, si elle n’est pas déjà activée.

  6. Sous Remplacer, tapez les caractères que vous voulez utiliser pour votre texte automatique.

Le texte que vous avez sélectionné dans votre document devrait apparaître sous Par qui.

Haut de la page

Dans Microsoft Office Word 2007, vous pouvez ajouter des entrées d’insertions automatiques dans la galerie d’insertions automatiques.

Ou bien, si vous voulez ajouter du texte automatiquement lorsque vous tapez quelques caractères, ajoutez des entrées de texte dans la boîte de dialogue Correction automatique.

Pour ajouter des insertions automatiques à partir de la galerie, vous devez ajouter celle-ci à la barre d’outils Accès rapide. Une fois la galerie ajoutée, vous pouvez créer des entrées, ainsi que migrer vos entrées de Word 2003 vers la galerie.

  1. Cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur Options Word.

  2. Cliquez sur Personnaliser.

  3. Dans la liste sous Choisir les commandes dans les catégories suivantes, cliquez sur Toutes les commandes.

  4. Faites défiler la liste des commandes jusqu’à voir Insertion automatique.

  5. Cliquez sur Insertion automatique, puis sur Ajouter.

Le bouton Insertion automatique apparaît désormais dans la barre d’outils Accès rapide. Cliquez sur Insertion automatique pour opérer un choix dans une galerie d’insertions automatiques.

Haut de la page

  1. Dans votre document Word, sélectionnez le texte que vous voulez ajouter à votre galerie d’insertions automatiques.

  2. Dans la barre d’outils Accès rapide, cliquez sur Insertion automatique, puis sur Enregistrer la sélection dans la galerie d’insertion automatique.

  3. Complétez les informations nécessaires dans la boîte de dialogue Créer un nouveau bloc de construction :

    • Nom     Tapez un nom unique pour le bloc de construction.

    • Galerie     Sélectionnez la galerie dans laquelle vous voulez que le bloc de construction apparaisse.

    • Catégorie     Sélectionnez une catégorie, telle que Général ou Prédéfini, ou créez une nouvelle catégorie.

    • Description     Tapez une description du bloc de construction.

    • Enregistrer dans     Cliquez sur le nom du modèle dans la liste déroulante.

    • Un modèle doit être ouvert afin de s’afficher dans la liste déroulante des noms de modèles.

    • Options     Choisissez une des options suivantes :

      • Sélectionnez Insérer un contenu dans sa propre page pour placer le bloc de construction sur une page distincte, avec des sauts de page situés avant et après.

      • Sélectionnez Insérer le contenu dans son paragraphe afin que le contenu se trouve dans un paragraphe séparé, même si le curseur de l’utilisateur se trouve au milieu d’un paragraphe.

      • Sélectionnez Insérer uniquement le contenu pour tous les autres types de contenu.

Pour plus d’informations sur l’utilisation de l’Organisateur de blocs de construction afin de créer et gérer des insertions automatiques, voir Utiliser des composants QuickPart et insertions automatiques dans Word.

Si vous utilisiez des insertions automatiques dans Microsoft Office Word 2003, vous pouvez les migrer manuellement vers Word 2007.

  1. Copiez le fichier Normal11.dot vers le dossier Blocs de construction de document en procédant comme suit :

    • Si votre ordinateur exécute Windows Vista    Ouvrez l’Explorateur Windows, puis copiez le modèle Normal11.dot de C:\Utilisateurs\nom d’utilisateur\AppData\Roaming\Microsoft\Templates vers C:\Users\user name\AppData\Roaming\Microsoft\Blocs de construction de document.

    • Si votre ordinateur exécute Windows XP    Ouvrez l’Explorateur Windows, puis copiez le modèle Normal11.dot de C:\Documents and Settings\nom d’utilisateur\Application Data\Microsoft\Templates vers C:\Documents and Settings\nom d’utilisateur\Application Data\Microsoft\Blocs de construction de document.

  2. Dans Office Word 2007, ouvrez le modèle Normal11.dot.

  3. Enregistrez le fichier sous AutoText.dotx.

    À l’invite, cliquez sur Continuer.

    1. Cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur Convertir.

À l’invite, cliquez sur OK.

Le fichier est mis à jour au nouveau format de fichier.

  1. Sous l’onglet Insertion, dans le groupe Texte, cliquez sur Composants QuickPart, puis sur Organisateur de blocs de construction.

  2. Dans l’Organisateur de blocs de construction, sélectionnez une insertion automatique, cliquez sur Modifier les propriétés, puis sélectionnez la galerie appropriée dans la liste Galerie.

  3. Dans la liste Enregistrer dans, cliquez sur Normal.dotm, puis sur OK.

  4. Répétez cette procédure pour chaque insertion automatique que vous voulez utiliser dans Office Word 2007.

Pour ajouter des entrées de texte qui sont insérées automatiquement lorsque vous tapez un ensemble spécifique de caractères, vous devez utiliser la boîte de dialogue Correction automatique.

  1. Dans votre document Word 2007, sélectionnez le texte que vous voulez ajouter automatiquement.

  2. Cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur Options Word.

  3. Cliquez sur Vérification.

  4. Cliquez sur Options de correction automatique, puis sur l’onglet Correction automatique.

  5. Activez la case à cocher Correction en cours de frappe, si elle n’est pas déjà activée.

  6. Sous Remplacer, tapez les caractères que vous voulez utiliser pour votre texte automatique.

    Le texte que vous avez sélectionné dans votre document devrait apparaître sous Par qui.

Haut de la page

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×