Importer une base de données Access 2.0 dans un fichier Access 2007

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Si vous utilisez une base de données existante au format Access 2.0 (.mdb), vous pouvez importer des tables, requêtes et macros à partir de cette base de données dans une base de données Microsoft Office Access 2007 (.accdb).

Pour importer des formulaires, États ou des modules dans Office Access 2007, vous devez tout d’abord convertir la base de données à l’aide d’une version antérieure d’Access, ouvrez la base de données dans Access 2007 et puis convertir la base de données au format de base de données Access 2007.

Les sections suivantes de cet article expliquent comment effectuer chacune de ces tâches.

Que voulez-vous faire ?

Ouvrir une base de données Access 2.0 dans Access 2007

Importer des données d’une base de données Access 2.0

Convertir une base de données Access 2.0 à l’aide de Access 2000, Access 2002 ou Access 2003

Ouvrir une base de données Access 2.0 dans Access 2007

Lorsque vous ouvrez une base de données Access 2.0 dans Access 2007, Access affiche un nombre d’invite qui, lorsqu’il est suivi, se termine par le message cette base de données a été enregistré au format de fichier Microsoft Access 2.0.

Boîte de dialogue

Vous pouvez importer des tables, requêtes et macros dans une base de données Office Access 2007 (.accdb). Pour importer des formulaires, États ou modules dans une base de données Access 2007, tout d’abord convertir la base de données à l’aide d’une version antérieure d’Access, puis ouvrez la base de données convertie en utilisant Access 2007 et puis convertir la base de données dans une base de données Access 2007. Consultez la section convertir une base de données Access 2.0 à l’aide d’Access 2003, Access 2002 ou Access 2000 pour plus d’informations.

Haut de la Page

Importer des données à partir d'une base de données Access 2.0

Lorsque vous importez des objets d’une autre base de données, les copies des objets que vous importez sont créées dans la base de données de destination. La source n’est pas modifiée. Pour importer des données à partir d’une base de données Access 2.0, vous ouvrez tout d’abord la base de données que vous souhaitez importer les données. Vous puis utilisez les commandes sous l’onglet Données externes pour poursuivre le processus d’importation, qui inclut l’appel de l’Assistant Importer.

Remarque : Vous pouvez importer des tables, requêtes et macros à partir d’une base de données Access 2.0 dans une base de données Office Access 2007 (.accdb). Pour importer des formulaires, États et modules, convertir la base de données à l’aide d’une version antérieure d’Access, ouvrez la base de données convertie à l’aide d’Access 2007 et puis convertir la base de données dans une base de données Access 2007. Consultez la section convertir une base de données Access 2.0 à l’aide d’Access 2003, Access 2002 ou Access 2000 pour plus d’informations.

  1. Cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur Ouvrir.

  2. Dans la boîte de dialogue Ouvrir, sélectionnez et ouvrez la base de données dans laquelle importer les tables, les requêtes ou les macros.

  3. Sous l’onglet Données externes, dans le groupe Importer, cliquez sur accès. Image du bouton

    Remarque : L'onglet Données externes n'est disponible que lorsqu'une base de données est ouverte.

  4. Dans la zone de texte Nom du fichier de l'Assistant Données externes, tapez le nom de la base de données source ou cliquez sur Parcourir pour afficher la boîte de dialogue Ouvrir puis choisissez ou tapez le nom de la base de données source.

  5. Cliquez sur Importer des tables, des requêtes, des formulaires, des états, des macros et des modules dans la base de données active, puis sur OK.

  6. Dans la boîte de dialogue Importer des objets, cliquez sur chaque onglet et sélectionnez les objets souhaités. N'oubliez pas que vous pouvez importer uniquement des tables, des requêtes et des macros à partir d'une base de données Access 2.0.

    Boîte de dialogue Importer des objets

    Pour désélectionner un objet, cliquez de nouveau sur cet objet.

  7. Cliquez sur Options pour spécifier d'autres paramètres.

    Le tableau suivant décrit l'impact de chaque option sur les résultats de l'opération.

Élément

Description

Case à cocher Relations

Importe les relations entre les tables sélectionnées.

Case à cocher Menus et barres d'outils

Importe les menus et barres d'outils personnalisés qui existent dans la base de données source. Les menus et barres d'outils sont affichés sous un onglet nommé Compléments.

Case à cocher Paramètres d'import/export

Importe toute spécification d'importation ou d'exportation qui existe dans la base de données source.

Case à cocher Groupes du volet de navigation

Importe les groupes du volet de navigation personnalisés qui existent dans la base de données source.

Bouton Définition et données

Importe la structure et les données de toutes les tables sélectionnées.

Bouton Définition uniquement

Importe uniquement les champs des tables sélectionnées. Les enregistrements sources ne sont pas importés.

Bouton Comme des requêtes

Importe les requêtes sélectionnées en tant que requêtes. Dans ce cas, n'oubliez pas d'importer toutes les tables sous-jacentes avec les requêtes.

Bouton Comme des tables

Importe les requêtes en tant que tables. Dans ce cas, il n'est pas nécessaire d'importer les tables sous-jacentes.

  1. Cliquez sur OK pour terminer l'opération.

    Access copie les données et affiche des messages d'erreur en cas de problème. Si l'importation des données réussit, la dernière page de l'Assistant vous permet d'enregistrer les détails de l'opération comme spécification d'importation pour une utilisation ultérieure. La section qui suit explique comment enregistrer les détails de l'opération en tant que spécification.

Enregistrer la spécification d'importation

Vous pouvez enregistrer les détails de l’opération d’importation en tant que spécification d’importation afin que vous puissiez répéter l’opération ultérieurement sans avoir à entrer de nouvelles informations dans l’Assistant. Une option supplémentaire, vous pouvez créer une tâche dans Microsoft Office Outlook 2007 pour vous rappeler d’exécuter la spécification d’importation. Pour plus de commodité, la tâche Office Outlook 2007 que vous créez contient un bouton qui vous permet d’exécuter l’opération sans ouvrir la base de données Access. Pour utiliser cette fonctionnalité, Office Outlook 2007 doit être installé et configuré sur votre ordinateur.

  1. Activez la case à cocher Enregistrer les étapes d’importation pour enregistrer les détails de l’opération.

  2. Dans la zone Enregistrer sous, tapez un nom pour la spécification d'importation. Éventuellement, tapez une description dans la zone Description.

  3. Activez la case à cocher Créer une tâche Outlook si vous voulez effectuer l'opération à intervalles réguliers, par exemple toutes les semaines ou tous les mois.

    Cela crée une tâche Office Outlook 2007 qui vous permet d’exécuter la spécification.

  4. Cliquez sur Enregistrer l'importation.

    Si vous n'avez pas activé la case à cocher Créer une tâche Outlook, Access enregistre la spécification d'importation et importe les objets que vous avez spécifiés. Vous pouvez maintenant examiner les tables et autres objets importés afin de vous assurer qu'ils ont été importés correctement.

Si vous avez sélectionné la case à cocher Créer une tâche Outlook et Outlook est installé et configuré sur votre ordinateur, Access démarre Outlook. Utilisez cette procédure pour effectuer les étapes qui suivent.

Remarque : Si Outlook n'est pas installé, Access affiche un message d'erreur. Si Outlook n'est pas configuré correctement, l'Assistant Démarrage d'Outlook se lance. Suivez les instructions de l'Assistant.

  1. Dans Outlook, examinez et modifiez les paramètres de tâche, tels que Échéance et Rappel.

    Pour rendre la tâche périodique, cliquez sur Périodicité. Cette figure montre le Planificateur de tâches avec certains paramètres par défaut.

    Planificateur de tâches Outlook

    Pour plus d’informations sur la planification des tâches Outlook, voir l’article planifier une importation ou exportation.

  2. Cliquez sur Enregistrer et fermer.

    Pour exécuter la spécification à une date ultérieure, ouvrez la tâche dans Outlook et puis, sous l’onglet tâche, dans le groupe Microsoft Office Access, cliquez sur Exécuter l’importation Image du bouton .

  3. Dans Access, passez en revue les tables et autres objets importés pour vous assurer que toutes les données et tous les objets ont bien été copiés.

Haut de la Page

Convertir une base de données Access 2.0 à l'aide d'Access 2003, Access 2002 ou Access 2000

Vous pouvez convertir une base de données Access 2.0 vers Access 2000 ou Access 2002-2003 le format à l’aide d’une des versions d’Access répertoriés dans le tableau suivant, autant que vous avez acheté cette version d’Access et installez sur votre ordinateur. Selon votre version d’accès, le convertisseur Access 2.0 sera soit déjà installé, ou vous devrez télécharger à partir de Microsoft Office Online.

Version

Convertisseur Access 2.0

Microsoft Office Access 2003

Téléchargez et installez le Convertisseur Access 2.0 pour Access 2003. Cliquez sur le lien dans la section Voir aussi de cet article ou, si le lien n'est pas disponible, recherchez le convertisseur dans le Centre de téléchargement Microsoft.

Microsoft Access 2002

Fourni avec le produit.

Microsoft Access 2000

Fourni avec le produit.

Vous devez convertir le fichier Access 2.0 au Access 2000 ou Access 2002 - format de fichier .mdb 2003. Vous pouvez ensuite utiliser Access 2007 pour convertir le fichier au format de fichier Access 2007. Selon votre version d’Access, procédez comme suit :

Microsoft Office Access 2003   

  1. Téléchargez et installez le Convertisseur Access 2.0 pour Access 2003.

  2. Démarrez Access 2003.

  3. Dans le menu Fichier, cliquez sur Ouvrir, puis cliquez sur le nom de fichier de la base de données Access 2.0 à convertir.

    La boîte de dialogue Convertir/Valider une base de données s'affiche.

  4. Sélectionnez Convertir une base de données, puis cliquez sur OK.

  5. Dans la boîte de dialogue Convertir la base de données sous, entrez un nom de fichier pour le nouveau fichier, puis cliquez sur Enregistrer.

    Vous pouvez voir un message d’information d’avertissement indiquant que vous ne serez pas en mesure d’utiliser la base de données convertie dans les versions antérieures d’Access. Si ce message s’affiche, cliquez sur OK.

    Le fichier est enregistré au format de fichier Access 2000 ou Access 2002 - 2003.

  6. Démarrez Access 2007.

  7. Cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur Ouvrir.

  8. Dans la boîte de dialogue Ouvrir, sélectionnez et ouvrez la base de données convertie.

  9. Cliquez sur le bouton Microsoft Office Image du bouton Office , puis cliquez sur Convertir.

  10. Dans la boîte de dialogue Enregistrer sous, entrez un nom de fichier pour le fichier Access 2007, ou acceptez le nom de fichier est fourni, puis cliquez sur Enregistrer.

    Le fichier est enregistré au format de fichier Access 2007.

Microsoft Access 2002 ou Access 2000   

  1. Démarrez Access 2002 ou Access 2000.

  2. Dans le menu Fichier, cliquez sur Ouvrir, puis cliquez sur le nom de fichier de la base de données Access 2.0 à convertir.

    La boîte de dialogue Convertir/Valider une base de données s'affiche.

  3. Sélectionnez Convertir une base de données, puis cliquez sur OK.

  4. Lorsque la boîte de dialogue Convertir la base de données sous s’affiche, entrez un nom de fichier pour le nouveau fichier, puis cliquez sur Enregistrer.

    Vous pouvez voir un message d’information d’avertissement indiquant que vous ne serez pas en mesure d’utiliser la base de données convertie dans les versions antérieures d’Access. Si ce message s’affiche, cliquez sur OK.

    Le fichier est enregistré au format de fichier que vous avez spécifié — c'est-à-dire, Access 2002 ou Access 2000.

  5. Démarrez Access 2007.

  6. Cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur Ouvrir.

  7. Dans la boîte de dialogue Ouvrir, sélectionnez et ouvrez la base de données convertie.

  8. Cliquez sur le bouton Microsoft Office Image du bouton Office , puis cliquez sur Convertir.

  9. Dans la boîte de dialogue Enregistrer sous, entrez un nom de fichier pour le fichier Access 2007, ou accepter celui qui est fourni, puis cliquez sur Enregistrer.

    Le fichier est enregistré au format de fichier Access 2007.

Haut de la Page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×