Importer ou exporter des fichiers texte (.txt ou .csv)

Importer ou exporter des fichiers texte (.txt ou .csv)

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Excel vous permet d’importer des données à partir d’un fichier texte de deux manières : vous pouvez l’ouvrir dans Excel ou l’importer sous forme de plage de données externes. Pour exporter des données à partir d’Excel dans un fichier texte, utilisez la commande Enregistrer sous et modifiez le type de fichier dans le menu déroulant.

Deux formats de fichier texte sont couramment utilisés :

  • Les fichiers texte délimités (fichiers .txt), dans lesquels les champs de texte sont séparés par des tabulations (caractère ASCII, code 009).

  • Les fichiers texte CSV (valeurs séparées par une virgule), dans lesquels les champs de texte sont en général séparés par des virgules.

Vous pouvez modifier le caractère séparateur utilisé dans les fichiers délimités et les fichiers texte .csv. Il peut être nécessaire de vérifier que l’opération d’importation ou d’exportation fonctionne de la façon prévue.

Remarque : Vous pouvez importer ou exporter jusqu’à 1 048 576 lignes et jusqu’à 16 384 colonnes.

Importer un fichier texte en l’ouvrant dans Excel

Vous pouvez ouvrir un fichier texte créé dans un autre logiciel sous la forme d’un classeur Excel à l’aide de la commande Ouvrir. Ouvrir un fichier texte dans Excel ne modifie pas le format du fichier ; vous pouvez le voir dans la barre de titre d’Excel où le nom du fichier conserve l’extension du nom du fichier texte (par exemple, .txt ou .csv).

  1. Accédez à Fichier > Ouvrir.

    Si vous utilisez Excel 2007, cliquez sur le bouton Microsoft Office Image du bouton Office , puis cliquez sur Ouvrir.

  2. Sélectionnez Fichiers texte dans la boîte de dialogue Ouvrir.

  3. Recherchez le fichier texte que vous souhaitez ouvrir et double-cliquez sur son entrée.

    • S’il s’agit d’un fichier texte (.txt), Excel démarre l’Assistant Importation de texte. Lorsque vous avez effectué toutes les étapes, cliquez sur Terminer pour terminer l’opération d’importation.

    • Voir : Pour plus d’informations sur les délimiteurs et les options avancées, voir Importer des données à l’aide de l’Assistant Importation de texte.

    • S’il s’agit d’un fichier .csv, Excel ouvre automatiquement le fichier texte et affiche les données dans un nouveau classeur.

      Remarque : Lorsqu’Excel ouvre un fichier .csv, il utilise les paramètres de mise en forme des données actifs par défaut pour importer chaque colonne de données. Pour plus de souplesse pour convertir les colonnes en d’autres formats, utilisez l’Assistant Importation de texte. Par exemple, le format d’une colonne de données d’un fichier .csv peut être MJA alors que le format des données par défaut d’Excel est AMJ, ou encore vous souhaitez convertir une colonne qui contient des nombres commençant par des zéros en texte tout en préservant les zéros. Pour forcer Excel à exécuter l’Assistant Importation de texte, vous pouvez modifier l’extension du nom du fichier de .csv en .txt avant de l’ouvrir ou importer un fichier texte en s’y connectant.

Vous pouvez importer les données d’un fichier texte dans une feuille de calcul existante sous la forme d’une plage de données externes.

  1. Cliquez sur la cellule dans laquelle vous voulez placer les données du fichier texte.

  2. Dans l’onglet Données, dans le groupe Données externes, cliquez sur À partir d’un fichier texte/CSV.

    Options Récupérer et transformer dans l’onglet Données

  3. Recherchez le fichier texte que vous souhaitez importer et double-cliquez sur son entrée.

    Suivez les instructions de l’Assistant Importation de texte. Pour plus d’informations sur l’utilisation de l’Assistant, cliquez sur Aide Image du bouton dans une page quelconque de l’Assistant Importation de texte. Lorsque vous avez terminé les étapes de l’Assistant, cliquez sur Terminer pour terminer l’opération d’importation.

  4. Dans la boîte de dialogue Importation de données, procédez comme suit :

    • Au besoin, cliquez sur Propriétés pour définir les options d’actualisation, de mise en forme et de mise en page des données importées.

    • Sous Insérer les données dans, effectuez l’une des opérations suivantes :

      • Pour placer les données à l’emplacement que vous avez sélectionné, cliquez sur Feuille de calcul existante.

      • Pour renvoyer les données dans le coin supérieur gauche d’une nouvelle feuille de calcul, cliquez sur Nouvelle feuille de calcul.

  5. Cliquez sur OK.

    Excel place la plage de données externes à l’emplacement que vous spécifiez.

Si Excel ne convertit pas les données d’une colonne dans un format qui vous convient, vous pouvez convertir les données après les avoir importées. Pour plus d’informations, voir Convertir les nombres stockés en tant que texte en nombres et Convertir les dates stockées en tant que texte en dates.

Utilisez la commande Enregistrer sous pour convertir une feuille de calcul Excel en fichier texte.

  1. Accédez à Fichier > Enregistrer sous.

    Si vous utilisez Excel 2007, cliquez sur le bouton Microsoft Office Image du bouton Office , puis cliquez sur Enregistrer sous.

  2. La boîte de dialogue Enregistrer sous s’affiche.

  3. Dans la zone Type de fichier, choisissez le format de fichier texte dans lequel vous voulez enregistrer la feuille de calcul.

    • Par exemple, cliquez sur Texte (séparateur : tabulation) ou CSV (séparateur : virgule).

    • Remarque : Les différents formats prennent en charge différentes fonctionnalités. Pour plus d’informations sur les fonctionnalités prises en charge par les différents formats de fichier texte, voir Formats de fichiers pris en charge dans Excel.

  4. Recherchez l’emplacement dans lequel vous voulez enregistrer le nouveau fichier texte, puis cliquez sur Enregistrer.

  5. Une boîte de dialogue s’affiche pour vous rappeler que seule la feuille de calcul active sera enregistrée comme nouveau fichier. Si vous êtes sûr que la feuille de calcul active est celle que vous voulez enregistrer comme fichier texte, cliquez sur OK. Vous pouvez enregistrer d’autres feuilles de calcul en tant que nouveaux fichiers texte en répétant cette procédure pour chaque feuille de calcul.

  6. Une seconde boîte de dialogue s’affiche pour vous rappeler que votre feuille de calcul peut contenir des fonctionnalités qui ne sont pas prises en charge par les formats de fichier texte. Si vous souhaitez uniquement enregistrer les données de la feuille de calcul dans le nouveau fichier texte, cliquez sur Oui. Si vous avez un doute et voulez en savoir plus sur les fonctionnalités d’Excel qui ne sont pas prises en charge par les formats de fichier texte, cliquez sur Aide pour plus d’informations.

Pour plus d’informations sur l’enregistrement de fichiers dans d’autres formats, voir Enregistrer un classeur dans un autre format de fichier.

Si vous utilisez l’Assistant Importation de texte pour importer un fichier texte, vous pouvez modifier le séparateur utilisé pour délimiter un fichier texte en remplaçant le caractère de tabulation par un autre caractère à l’étape 2 de l’Assistant. À l’étape 2, vous pouvez également indiquer comment les séparateurs consécutifs, comme les guillemets consécutifs, doivent être interprétés.

Voir : Pour plus d’informations sur les délimiteurs et les options avancées, voir Importer des données à l’aide de l’Assistant Importation de texte.

  1. Dans Microsoft Windows, cliquez sur le bouton Démarrer puis cliquez sur Panneau de configuration.

  2. Ouvrez la boîte de dialogue permettant de modifier les paramètres régionaux et de langue.

  3. Tapez un nouveau séparateur dans la zone Séparateur de listes.

  4. Cliquez deux fois sur OK.

Remarque : Une fois que vous avez changé le caractère de séparation de listes de votre ordinateur, tous les programmes utiliseront le nouveau caractère comme caractère de séparation de liste. Vous pouvez rétablir le caractère par défaut en suivant la même procédure.

Vous avez besoin d’une aide supplémentaire ?

Vous pouvez toujours consulter un expert de la communauté technique Excel, obtenir une assistance dans la communauté Answers ou suggérer une nouvelle fonctionnalité ou une amélioration sur le forum Excel User Voice.

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Voir aussi

Vue d’ensemble des formules dans Excel

Comment éviter les formules incorrectes

Rechercher et corriger les erreurs dans les formules

Raccourcis clavier et touches de fonction dans Excel

Fonctions Excel (par ordre alphabétique)

Fonctions Excel (par catégorie)

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×