Importer ou créer une liaison avec des données d’une liste SharePoint

Importer ou créer une liaison avec des données d’une liste SharePoint

Vous pouvez transférer des données à partir de SharePoint dans Access de deux manières : par importation ou par liaison.

Le processus d’importation revient à copier la liste SharePoint dans une base de données Access. Au cours de l’importation, vous pouvez spécifier les listes à copier mais aussi, pour chaque liste sélectionnée, indiquer si vous souhaitez importer la liste entière ou seulement une vue précise.

Le processus de liaison se connecte aux données d’un autre programme pour vous permettre d’afficher et de modifier les données les plus récentes tant dans SharePoint que dans Access, et ce, sans créer ni conserver de copie de ces données dans Access. Si vous ne voulez pas copier de liste SharePoint dans votre base de données Access, mais souhaitez exécuter des requêtes et générer des états s’appuyant sur le contenu de cette liste, effectuez une liaison des données.

Cet article décrit les étapes à suivre pour importer ou lier une liste SharePoint.

Remarque : Cet article ne s’applique pas aux applications web Access (type de base de données que vous créez dans Access et publiez en ligne).

Que voulez-vous faire ?

Importer une liste SharePoint

Que faut-il savoir d’autre sur l’importation ?

Tâches associées à l’importation

Lier une liste SharePoint

Vous utilisez Access 2007 et recherchez l’Assistant Déplacer vers le site SharePoint ? Consultez la section Utiliser l’Assistant Déplacer vers le site SharePoint d’Access 2007 plus bas dans cet article.

Importer une liste SharePoint

Quand vous importez des données, Access crée une table et y copie les colonnes et les éléments issus de la liste source (ou de sa vue source) sous forme de champs et d’enregistrements. À la fin de l’importation, vous pouvez enregistrer au besoin les détails de l’opération sous forme de spécification d’importation. Vous pourrez ainsi répéter l’opération sans repasser à chaque fois par les étapes de l’Assistant Importation.

Voici quelques raisons courantes d’importer une liste SharePoint dans une base de données Access :

  • Pour déplacer définitivement des données, une liste de contacts par exemple, vers une base de données Access car vous n’avez plus besoin des informations sur votre site SharePoint. Vous pouvez importer cette liste dans Access, puis la supprimer du site SharePoint.

  • Votre service ou groupe de travail utilise Access mais vous êtes parfois redirigé vers une liste SharePoint pour obtenir des données supplémentaires qui doivent être fusionnées avec l’une de vos bases de données.

Effectuer les étapes suivantes avant d’importer la liste

  1. Localisez le site SharePoint qui contient les listes à copier et notez l’adresse du site.

    Une adresse de site valide commence par http:// ou https:// suivi du nom du serveur, et se termine par le chemin d’accès du site sur le serveur.

  2. Identifiez les listes à copier vers la base de données, puis indiquez si vous souhaitez inclure la liste entière ou seulement une vue en particulier. Vous pouvez importer plusieurs listes en une seule opération mais vous ne pouvez importer qu’une seule vue par liste. Le cas échéant, créez une vue contenant uniquement les colonnes et éléments qui vous intéressent.

  3. Passez en revue les colonnes de la vue ou liste source.

    Le tableau suivant répertorie quelques considérations à garder à l’esprit lors de l’importation de différents éléments :

    Élément

    Considérations

    Colonnes

    Access importe seulement les 256 premières colonnes, car seuls 256 champs sont pris en charge dans une table. Pour éviter ce problème, créez une vue et n’y ajoutez que les colonnes souhaitées, afin de vous assurer que le nombre total de colonnes ne dépasse pas 256.

    Dossiers

    Chaque dossier de la liste SharePoint apparaît sous forme d’enregistrement dans la table Access. Les éléments inclus dans un dossier apparaissent également sous forme d’enregistrements placés juste en dessous de l’enregistrement correspondant à ce dossier.

    Colonnes de recherche

    Si une colonne source recherche des valeurs dans une autre liste, vous avez deux possibilités :

    • Vous importez les valeurs à afficher en tant que partie intégrante du champ. Dans ce cas, vous n’avez pas à importer la liste associée.

    • Vous forcez le champ de destination à rechercher dans une autre table. Dans ce cas, si la base de données ne contient pas de table hébergeant les valeurs de recherche, vous devez également importer la liste associée.

    Remarque : Une colonne source de type Personne ou Groupe correspond à un type spécial de colonne de recherche. Elle recherche en effet les valeurs dans la liste d’informations utilisateur. Vous devez dès lors indiquer si vous souhaitez importer la liste d’informations utilisateur en même temps que d’autres listes.

    Colonnes calculées

    Les résultats d’une colonne calculée sont copiés vers un champ dont le type de données varie en fonction de celui du résultat calculé. L’expression qui permet le calcul n’est cependant pas copiée.

    Pièces jointes

    La colonne de pièces jointes de la liste est copiée dans un champ intitulé Pièces jointes.

    Colonnes à valeurs multiples

    Une colonne de type Choix ou Recherche peut contenir plusieurs valeurs. Lorsque vous importez une colonne qui prend en charge des valeurs multiples, Access crée une colonne qui les accepte également.

    Mise en forme de texte enrichi

    Les colonnes avec mise en forme de texte enrichi sont importées dans Access en tant que champs de type Mémo. La propriété Format du texte du champ Mémo est définie sur Texte enrichi et la mise en forme est conservée. Notez qu’à partir d’Access 2013, les champs de données Mémo ont été renommés champs Texte long.

    Relations

    Access ne crée pas automatiquement les relations entre les tables liées à la fin d’une opération d’importation. Vous devez par conséquent créer manuellement les relations entre ces tables nouvelles et existantes à l’aide des options de l’onglet Relations. Pour afficher l’onglet Relations, sous l’onglet Outils de base de données, dans le groupe Relations, cliquez sur Relations.

  4. Indiquez la base de données dans laquelle vous souhaitez importer les listes.

    Vérifiez que vous disposez des autorisations nécessaires pour ajouter des données à la base de données. Si vous ne souhaitez pas stocker les données dans l’une de vos bases de données existantes, créez une base de données vide.

  5. Parcourez les tables de la base de données.

    L’opération d’importation crée une table du même nom que la liste SharePoint. Si ce nom est déjà utilisé, Access ajoute « 1 » au nom de la nouvelle table, par exemple Contacts1. Si Contacts1 est aussi déjà utilisé, Access crée Contacts2, etc.

Remarque : Access ne remplace jamais de table dans la base de données dans le cadre d’une opération d’importation. En outre, vous ne pouvez pas ajouter le contenu d’une liste ou d’une vue à une table existante.

Importer la liste

  1. Ouvrez la base de données Access dans laquelle les données importées doivent être stockées. Si vous ne voulez pas stocker ces données dans une base de données existante, créez-en une vide.

  2. L’emplacement de l’Assistant Importation/Attache de texte varie en fonction de la version d’Access. Choisissez la procédure correspondant à votre version d’Access :

    • Si vous utilisez la dernière version de la version d’abonnement Office 365 d’Access, dans l’onglet Données externes, accédez au groupe Importer et lier et cliquez sur Nouvelle source de données > À partir d'Online Services > Liste SharePoint.

    • Si vous utilisez Access 2016, Access 2013 ou Access 2010, dans l’onglet Données externes, accédez au groupe Importer et lier, cliquez sur le bouton Autres pour afficher la liste déroulante des options disponibles, puis choisissez Liste SharePoint.

    • Si vous utilisez Access 2007, sous l’onglet Données externes, accédez au groupe Importer, puis cliquez sur Liste SharePoint.

  3. Access ouvre la boîte de dialogue Données externes – Site SharePoint.

    Choisissez d’importer ou de lier un site SharePoint dans la boîte de dialogue Données externes - Site SharePoint.

  4. Dans l’Assistant, spécifiez l’adresse du site source.

  5. Sélectionnez l’option Importer les données sources dans une nouvelle table de la base de données active et cliquez sur Suivant.

  6. Dans la liste affichée par l’Assistant, sélectionnez celles que vous voulez importer.

  7. Dans la colonne Éléments à importer, sélectionnez la vue souhaitée pour chaque liste sélectionnée.

  8. La case à cocher intitulée Importer les valeurs d’affichage plutôt que les ID pour les champs qui recherchent les valeurs stockées dans une autre liste détermine les données à importer dans les listes sélectionnées en vue de servir de listes de choix. Exécutez l’une des procédures suivantes :

    • Pour importer les valeurs à afficher en tant que partie intégrante du champ, activez la case à cocher. Le champ ne recherche ainsi pas les valeurs dans une autre table.

    • Pour que le champ de destination recherche les valeurs dans une autre table, désactivez la case à cocher. Les ID des lignes des valeurs à afficher sont alors copiés dans le champ de destination. Ces ID sont requis pour définir un champ Liste de choix dans Access.

    Lors de l’importation des ID, vous devez importer les listes qui fournissent les valeurs actives aux listes de choix (à moins que la base de données de destination contienne déjà des tables pouvant servir de tables de choix).

    L’opération d’importation place les ID dans le champ correspondant, mais ne définit pas toutes les propriétés nécessaires pour que le champ ait le même comportement qu’un champ Liste de choix. Les étapes à suivre pour définir les propriétés de recherche d’un tel champ sont décrites sous Définir les champs Liste de choix dans cet article.

  9. Cliquez sur OK.

Access importe les listes, puis affiche l’état de l’opération sur la dernière page de l’Assistant. Si vous prévoyez de répéter l’opération d’importation ultérieurement, vous pouvez enregistrer les détails en tant que spécification d’importation.

Que faut-il savoir d’autre sur l’importation ?

Tâches associées à l’importation

Au terme de l’opération d'importation, vous pouvez exécuter d’autres tâches :

Vérifier les types de données    Access sélectionne le type de données approprié pour chacun des champs correspondant à une colonne source. Vérifiez chaque champ et ses paramètres pour vous assurer que tous les champs sont configurés comme vous le souhaitez.

Déterminer l’origine des champs supplémentaires    Selon le type de liste sur laquelle la table s’appuie, vous remarquerez peut-être la présence dans la table de quelques champs supplémentaires (par exemple, Modifier, Modifié le et Type). Pour plus d’informations sur ces champs et sur les informations qu’ils contiennent, reportez-vous à l’aide de SharePoint. Si vous n’avez pas besoin de ces champs dans la base de données Access, vous pouvez les supprimer sans risque.

Définir les champs Liste de choix    Si vous avez importé des ID en vue de les utiliser dans des listes de choix, vous devez définir manuellement les propriétés de recherche des champs correspondants.

  1. En mode Création de table, dans la liste Type de données du champ, cliquez sur Assistant Liste de choix.

  2. Dans l’Assistant, acceptez la sélection par défaut (Je veux que la liste de choix recherche les valeurs dans une table ou requête), puis cliquez sur Suivant.

  3. Sélectionnez la table ou la requête qui doit fournir les valeurs de la liste de choix pour le champ, puis cliquez sur Suivant.

    Remarque :  Il peut s’agir d’une table nouvellement importée ou d’une table existante.

  4. Dans le volet Liste des champs, sélectionnez l’ID du champ ainsi que le champ qui contient les valeurs à afficher, puis cliquez sur Suivant.

  5. Spécifiez un ordre de tri, puis cliquez sur Suivant.

  6. Cliquez sur Terminer, puis enregistrez vos modifications de structure.

Haut de la page

Attacher une liste SharePoint

Lorsque vous liez à une liste SharePoint, Access crée une nouvelle table, souvent appelée table liée, qui reflète la structure et le contenu de la liste source. Contrairement à l’importation, attacher revient à créer un lien portant seulement sur la liste choisie, et non pas sur une vue spécifique de cette liste.

L’attache est une technique plus puissante que l’importation pour deux aspects :

  • Ajout et mise à jour de données    Vous pouvez modifier des données à partir du site SharePoint ou en travaillant en mode Feuille de données ou Formulaire dans Access. Les modifications effectuées à un emplacement sont répercutées dans l’autre. Néanmoins, si vous souhaitez apporter des modifications structurelles, comme la suppression ou la modification d’une colonne, vous devez ouvrir la liste sur le site SharePoint. Vous ne pouvez pas ajouter, supprimer ou modifier les champs d’une table liée lorsque vous travaillez dans Access.

  • Tables de choix    Lorsque vous liez une liste SharePoint, Access crée automatiquement des tables liées pour toutes les listes de choix (sauf si ces listes sont déjà liées à la base de données). Si les listes de choix contiennent des colonnes qui effectuent des recherches parmi les valeurs d’autres listes, ces listes sont également incluses dans l’opération de liaison, afin que la liste de choix de chaque table liée possède une table liée correspondante dans la base de données. Access crée également les relations entre ces tables liées.

Scénarios courants pour attacher une liste SharePoint

Vous attachez généralement une liste SharePoint depuis une base de données Access pour les raisons suivantes :

  • Votre service ou groupe de travail utilise Access pour bénéficier des fonctionnalités d’élaboration d’états et de requêtes avancés, et utilise Windows SharePoint Services pour la collaboration et la communication entre les équipes. Chaque équipe crée des listes pour effectuer le suivi de divers éléments (tels que des contacts et des problèmes rencontrés), mais les données de ces listes doivent souvent être réintégrées à une base de données en vue d’une agrégation et de l’élaboration d’états. L’attache constitue un choix pertinent car la technique permet aussi bien aux utilisateurs du site SharePoint qu’à ceux de la base de données d’ajouter et de mettre à jour des données, mais aussi de pouvoir toujours afficher et travailler avec les données les plus récentes.

  • Vous êtes un utilisateur d’Access n’ayant commencé à utiliser Windows SharePoint Services que récemment. Vous avez fait migrer plusieurs de vos bases de données vers le site SharePoint de votre équipe et la plupart des tables de ces bases de données sont des tables attachées. Désormais, plutôt que de créer des tables locales, vous créerez des listes SharePoint et les attacherez à vos bases de données.

  • Vous désirez continuer à stocker vos listes sur des sites SharePoint mais voulez également travailler avec les données les plus récentes à partir d’Access pour pouvoir exécuter des requêtes et établir des états destinés à l’impression.

Préparer la liaison à une liste SharePoint

  1. Localisez le site SharePoint qui héberge les listes à attacher et notez l’adresse du site.

    Une adresse de site valide commence par http:// ou https:// suivi du nom du serveur, et se termine par le chemin d’accès du site sur le serveur.

  2. Identifiez les listes à attacher. Vous pouvez attacher plusieurs listes en une seule opération mais vous ne pouvez attacher qu’une seule vue spécifique par liste.

    Remarque : Il vous est également impossible d’attacher des enquêtes ou des discussions.

  3. Passez en revue les colonnes de la liste source. Le tableau suivant répertorie quelques aspects à prendre en compte lors de la liaison de différents éléments.

    Élément

    Considérations

    Colonnes

    Access ne prend pas en charge plus de 256 champs dans une table, par conséquent la table attachée contient uniquement les 256 premières colonnes.

    Dossiers

    Chaque dossier de la liste SharePoint apparaît sous forme d’enregistrement dans la table Access. Les éléments inclus dans un dossier apparaissent également sous forme d’enregistrements placés juste en dessous de l’enregistrement correspondant à ce dossier.

    Colonnes de recherche

    Si une colonne source recherche des valeurs dans une autre liste et que la liste associée ne se trouve pas déjà dans la base de données, Access crée automatiquement les tables attachées pour les listes associées.

    Remarque : Une colonne source de type Personne ou Groupe correspond à un type spécial de colonne de recherche. Elle recherche des valeurs dans la liste d’informations utilisateur. Si vous l’attachez à une liste contenant une colonne Personne ou Groupe, Access crée automatiquement une table attachée pour la liste d’informations utilisateur.

    Colonnes calculées

    Les résultats dans une colonne calculée s’affichent dans le champ correspondant mais vous n’avez la possibilité ni d’afficher ni de modifier la formule dans Access.

    Pièces jointes

    La colonne de pièces jointes de la liste s’affiche sous forme de champ intitulé Pièces jointes.

    Colonnes en lecture seule

    Les colonnes qui sont en lecture seule dans une liste SharePoint restent en lecture seule dans Access. En outre, vous risquez de ne pas pouvoir ajouter, supprimer ou modifier des colonnes dans Access.

    Colonnes à valeurs multiples

    Une colonne de type Choix ou Recherche peut contenir plusieurs valeurs. Pour ces colonnes, l’opération d’attache entraîne la création de champs prenant en charge les valeurs multiples. Ces colonnes de choix à valeurs multiples sont créées dans la table attachée si la colonne source est de type Recherche.

  4. Identifiez la base de données dans laquelle vous voulez créer les tables attachées. Assurez-vous que vous disposez des autorisations nécessaires pour ajouter des données à la base de données. Si vous ne voulez pas stocker les données dans une base existante, créez-en une vide.

  5. Parcourez les tables de la base de données. Lorsque vous liez une liste SharePoint, une table possédant le même nom que la liste source est créée. Si ce nom est déjà utilisé, Access ajoute le chiffre « 1 » au nom de la nouvelle table, par exemple Contacts1 (si Contacts1 est déjà utilisé, Access crée Contacts2, etc.). La même règle s’applique aux listes liées.

    Remarque : Rappelez-vous qu’Access ne remplace jamais une table de la base de données dans le cadre d’une opération de liaison. En outre, vous ne pouvez pas ajouter le contenu d’une liste SharePoint à une table existante.

Lier des données

  1. Ouvrez la base de données de destination.

  2. L’emplacement de l’Assistant Importation/Attache de texte varie en fonction de la version d’Access. Choisissez la procédure correspondant à votre version d’Access :

    • Si vous utilisez la dernière version de la version d’abonnement Office 365 d’Access, dans l’onglet Données externes, accédez au groupe Importer et lier et cliquez sur Nouvelle source de données > À partir d'Online Services > Liste SharePoint.

    • Si vous utilisez Access 2016, Access 2013 ou Access 2010, dans l’onglet Données externes, accédez au groupe Importer et lier, cliquez sur le bouton Autres pour afficher la liste déroulante des options disponibles, puis choisissez Liste SharePoint.

    • Si vous utilisez Access 2007, sous l’onglet Données externes, accédez au groupe Importer, puis cliquez sur Liste SharePoint.

  3. Access ouvre la boîte de dialogue Données externes – Site SharePoint.

    Choisissez d’importer ou de lier un site SharePoint dans la boîte de dialogue Données externes - Site SharePoint.

  4. Dans l’Assistant, spécifiez l’adresse du site source.

  5. Sélectionnez Lier à la source de données en créant une table attachée, puis cliquez sur Suivant.

    L’Assistant affiche les listes qui peuvent être attachées.

  6. Sélectionnez celles qui vous intéressent, puis cliquez sur OK.

    Remarque :  Si certaines listes sont déjà attachées à la base de données active, les cases correspondantes sont activées. Si vous voulez supprimer des liens, désactivez les cases à cocher des liens à supprimer.

    Access Access tente de créer les tables attachées, tant pour les listes que vous avez sélectionnées dans cette opération que pour chacune des listes associées. Access tente également d’actualiser les tables attachées correspondant aux listes sélectionnées dans l’Assistant. Access crée enfin aussi les relations entre ces tables. Contrairement à une opération d’importation, une opération d’attache conserve le paramètre des propriétés de liste de choix entre un champ Liste de choix et sa table associée. Il n’est pas impératif de définir manuellement les propriétés du champ Liste de choix en mode Création de table.

  7. Parcourez les nouvelles tables attachées en mode Feuille de données. Assurez-vous que tous les champs et enregistrements s’affichent correctement.

    Access choisit le type de données approprié pour chacun des champs correspondant à une colonne source. Il est important de noter que chaque fois que vous ouvrez une table liée ou la liste source, vous y retrouvez les données les plus récentes. Les modifications structurelles apportées à une liste ne sont cependant pas automatiquement répercutées dans une table liée. Pour mettre à jour une table liée en appliquant la structure de liste la plus récente, dans le volet de navigation, cliquez avec le bouton droit sur la table, pointez sur Autres options, puis cliquez sur Actualiser la liste.

Haut de la page

Remarque : cette section s’applique uniquement à Access 2007.

Vue d’ensemble

Lorsque vous déplacez une base de données d’Access vers un site SharePoint, vous créez sur le site SharePoint des listes qui restent liées aux tables de votre base de données. L’Assistant Déplacer vers le site SharePoint vous aide à déplacer les données de toutes vos tables en même temps tout en conservant leurs relations.

Une fois les listes SharePoint créées, il est possible de les utiliser sur le site SharePoint ou dans les tables liées d’Access, tout en utilisant les fonctionnalités d’un site SharePoint pour gérer les données et rester averti des modifications.

Les liens vers les listes SharePoint sont stockés dans votre base de données Access, et les formulaires, requêtes et rapports sont également conservés dans Access. Vous pouvez entrer les données à l’aide d’une table ou d’un formulaire Access ou en modifiant la liste sur le site SharePoint.

Déplacement des données

Dans la mesure du possible, l’Assistant Déplacer vers le site SharePoint déplace les données vers des listes basées sur des modèles du site SharePoint, comme une liste Contacts. Si une table ne correspond pas à un modèle de liste, elle est traitée en tant que liste personnalisée dans la vue Feuille de données du site SharePoint.

Selon la taille de la base de données, le nombre d’objets qu’elle contient et les performances du système, l’opération peut être plus ou moins longue. Si vous changez d’avis en cours de processus, vous pouvez cliquer sur Arrêter pour l’annuler.

L’Assistant crée une copie de sauvegarde de la base de données sur votre ordinateur. Dans Access, il crée des liens vers les listes à partir des tables. Vous pouvez ainsi facilement localiser les données disponibles sur le site SharePoint lorsque vous travaillez dans Access. Dans la mesure du possible, les relations entre les tables sont représentées sous forme de liens entre les listes SharePoint.

Lorsque des problèmes surviennent, l’Assistant Déplacer vers le site SharePoint les signale et les enregistre dans la base de données Access sous forme de table journal que vous pouvez utiliser pour tenter de trouver une solution.

Utiliser l’Assistant Déplacer vers le site SharePoint

  1. Dans l’onglet Données externes, accédez au groupe Listes SharePoint et cliquez sur Déplacer vers SharePoint.

  2. Suivez les étapes de l’Assistant Déplacer vers le site SharePoint, notamment pour spécifier l’emplacement de votre site SharePoint.

    Pour annuler le processus, cliquez sur Arrêter.

  3. Dans la dernière page de l’Assistant, activez la case à cocher Afficher les détails pour afficher d’autres détails relatifs à la migration.

    Cette page de l’Assistant indique les tables liées à des listes et fournit des informations sur l’emplacement de sauvegarde et l’URL de la base de données. Elle affiche également un avertissement si des problèmes de migration se sont produits et indique l’emplacement d’une table journal contenant les détails des problèmes.

  4. Cliquez sur Terminer une fois toutes les opérations de l’Assistant terminées.

    Si l’Assistant affiche un avertissement, consultez la table journal et prenez les mesures nécessaires pour vérifier que vos données ont bien été déplacées. Par exemple, certains champs n’ont peut-être pas été déplacés ou ont été convertis en données d’un autre type compatible avec une liste SharePoint.

Remarque : Pour afficher vos listes du site SharePoint, cliquez sur Listes dans Lancement rapide ou cliquez sur Afficher tout le contenu du site. Il peut s’avérer nécessaire d’actualiser la page dans le navigateur web. Pour afficher vos listes dans Lancement rapide sur le site SharePoint ou pour modifier d’autres paramètres (activer le suivi des versions, par exemple), vous pouvez modifier les paramètres de liste sur le site SharePoint. Pour plus d’informations, consultez l’aide relative au site SharePoint.

Limites de la migration

Au terme de l’Assistant Déplacer vers le site SharePoint, un message s’affiche si Access a rencontré des problèmes avec les données. Access crée une table journal appelée Problèmes lors du déplacement vers le site SharePoint et l’ajoute à la base de données. La table Problèmes lors du déplacement vers le site SharePoint est stockée dans la base de données, mais elle n’est pas publiée en tant que liste sur le site SharePoint.

Le tableau suivant répertorie les limites relatives à la migration des données, notamment lorsque Access et SharePoint ne prennent pas en charge la même fonctionnalité, voire le même type de données. Par exemple, si votre table Access prend en charge intégrité référentielle, elle ne s’applique pas à la liste sur le site SharePoint. Les informations contenues dans le tableau suivant vous aideront à déterminer si vous devez migrer vos données, et elles peuvent s’avérer très utiles lors de l’examen des problèmes signalés dans la table Problèmes lors du déplacement vers le site SharePoint.

Type de données ou de problème

Problème

Résultat

Type de données Objet COM

Les sites SharePoint ne prennent pas en charge le type de données Objet COM.

Le champ n’est pas déplacé.

Type de données Binary

Les sites SharePoint ne prennent pas en charge le type de données Binary.

Le champ n’est pas déplacé.

Date

Les sites SharePoint ne prennent pas en charge les dates antérieures à 1900.

Les données comportant des dates antérieures à 1900 ne sont pas déplacées.

Caractères de nouvelle ligne dans les champs de texte

Les sites SharePoint ne prennent pas en charge les caractères de nouvelle ligne dans un champ Une seule ligne de texte.

Le champ est converti en champ Plusieurs lignes de texte ou Mémo.

Type de données Decimal

Les sites SharePoint ne prennent pas en charge le type de données Decimal.

Le champ Nombre ou Entier double est utilisé.

Type de données N° de réplication

Les sites SharePoint ne prennent pas en charge le type de données N° de réplication.

Un type de données Une seule ligne de texte est utilisé, en fonction du type de données.

Intégrité référentielle

Les sites SharePoint ne prennent pas en charge l’intégrité référentielle.

L’intégrité référentielle ne s’applique pas à la nouvelle liste.

Valeurs par défaut non prises en charge dans une liste SharePoint

Les sites SharePoint acceptent les valeurs par défaut statiques, telles qu’un texte ou un nombre, ainsi que les dates standard. Les valeurs par défaut dynamiques d’Access ne sont pas déplacées.

Les propriétés de certaines valeurs par défaut ne sont pas déplacées.

Validation des données dans un champ ou une table

Aucune règle de validation des données n’est déplacée vers les sites SharePoint.

Les validations de données présentes dans un champ ou une table ne sont pas déplacées ou appliquées.

Champs d’index unique

Les sites SharePoint utilisent un champ d’index unique pour la colonne ID d’une liste.

Les autres champs ou ensembles de champs d’index unique ne sont pas déplacés.

Relations avec les suppressions ou mises à jour en cascade

Les sites SharePoint ne prennent pas en charge les suppressions en cascade des enregistrements associés.

Les suppressions ne se répercutent pas sur les enregistrements associés, et les mises à jour ne se répercutent pas sur les champs associés.

Relations qui appliquent l’intégrité référentielle

Les sites SharePoint ne prennent pas en charge l’intégrité référentielle.

L’intégrité référentielle ne s’applique pas aux relations entre les données des listes.

Champs avec énumération automatique (autres que le champ ID)

Les sites SharePoint ne prennent en charge la numérotation automatique que sur le champ utilisé pour la colonne ID d’une liste.

La numérotation automatique ne s’applique pas aux colonnes de la colonne ID.

Relations dans lesquelles aucune recherche ne peut être créée

Certaines relations ne sont pas prises en charge sur les sites SharePoint, notamment lorsque la clé primaire n’est pas associée à la colonne ID ou ne correspond pas à un nombre entier.

La relation n’est pas déplacée.

Haut de la page

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×