Importer ou attacher des données sur une liste SharePoint

Importer ou attacher des données sur une liste SharePoint

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Remarque : Cet article ne s’applique pas aux applications web Access (type de base de données que vous créez dans Access et publiez en ligne). Pour plus d’informations, voir Créer une application Access.

Vous pouvez transférer des données à partir de SharePoint dans Access de deux manières : par importation ou par liaison.

Le processus d’importation revient à copier la liste SharePoint dans une base de données Access. Au cours de l’importation, vous pouvez spécifier les listes à copier mais aussi, pour chaque liste sélectionnée, indiquer si vous souhaitez importer la liste entière ou seulement une vue précise.

Le processus de liaison se connecte aux données d’un autre programme, vous pouvez ainsi afficher et modifier les données les plus récentes tant dans SharePoint que dans Access, et ce, sans créer ni maintenir de copie de ces données dans Access. Si vous ne voulez pas copier de liste SharePoint dans votre base de données Access, mais souhaitez exécuter des requêtes et générer des états s’appuyant sur le contenu de cette liste, effectuez une liaison des données.

Cet article décrit les étapes tant pour importer que pour attacher une liste SharePoint.

Que voulez-vous faire ?

Importer une liste SharePoint

Attacher une liste SharePoint

Importer une liste SharePoint

Quand vous importez des données, Access crée une table et y copie les colonnes et les éléments issus de la liste source (ou de sa vue source) sous forme de champs et d’enregistrements. À la fin de l’importation, vous pouvez enregistrer au besoin les détails de l’opération sous forme de spécification d’importation. Vous pourrez ainsi répéter l’opération sans repasser à chaque fois par les étapes de l’Assistant Importation.

Voici quelques raisons courantes d’importer une liste SharePoint dans une base de données Access :

  • Pour déplacer définitivement des données, une liste de contacts par exemple, vers une base de données Access car vous n’avez plus besoin des informations sur votre site SharePoint. Vous pouvez importer cette liste dans Access, puis la supprimer du site SharePoint.

  • Votre service ou groupe de travail utilise Access mais vous êtes parfois redirigé vers une liste SharePoint pour obtenir des données supplémentaires qui doivent être fusionnées avec l’une de vos bases de données.

Effectuer les étapes suivantes avant d’importer la liste

  1. Localisez le site SharePoint qui contient les listes à copier et notez l’adresse du site.

    Une adresse de site valide commence par http:// ou https:// suivi du nom du serveur et se termine par le chemin d'accès au site spécifique sur le serveur.

  2. Identifiez les listes à copier vers la base de données, puis indiquez si vous souhaitez inclure la liste entière ou seulement une vue en particulier. Vous pouvez importer plusieurs listes en une seule opération mais vous ne pouvez importer qu’une seule vue par liste. Le cas échéant, créez une vue contenant uniquement les colonnes et éléments qui vous intéressent.

  3. Passez en revue les colonnes de la vue ou liste source.

    Le tableau suivant répertorie quelques considérations à garder à l’esprit lors de l’importation de différents éléments :

    Élément

    Considérations

    Colonnes

    Access importe seulement les 256 premières colonnes, car seuls 256 champs sont pris en charge dans une table. Pour éviter ce problème, créez une vue et n’y ajoutez que les colonnes souhaitées, afin de vous assurer que le nombre total de colonnes ne dépasse pas 256.

    Dossiers

    Chaque dossier de la liste SharePoint apparaît sous forme d’enregistrement dans la table Access. Les éléments inclus dans un dossier apparaissent également sous forme d’enregistrements placés juste en dessous de l’enregistrement correspondant à ce dossier.

    Colonnes de recherche

    Si une colonne source recherche des valeurs dans une autre liste, vous avez deux possibilités :

    • Vous importez les valeurs à afficher en tant que partie intégrante du champ. Dans ce cas, vous n’avez pas à importer la liste associée.

    • Vous forcez le champ de destination à rechercher dans une autre table. Dans ce cas, si la base de données ne contient pas de table hébergeant les valeurs de recherche, vous devez également importer la liste associée.

    Remarque : Une colonne source de type Personne ou Groupe correspond à un type spécial de colonne de recherche. Elle recherche en effet les valeurs dans la liste d’informations utilisateur. Vous devez dès lors indiquer si vous souhaitez importer la liste d’informations utilisateur en même temps que d’autres listes.

    Colonnes calculées

    Les résultats d’une colonne calculée sont copiés vers un champ dont le type de données varie en fonction de celui du résultat calculé. L’expression qui permet le calcul n’est cependant pas copiée.

    Pièces jointes

    La colonne de pièces jointes de la liste est copiée dans un champ intitulé Pièces jointes.

    Colonnes à valeurs multiples

    Une colonne de type Choix ou Recherche peut contenir plusieurs valeurs. Lorsque vous importez une colonne qui prend en charge des valeurs multiples, Access crée une colonne qui les accepte également.

    Mise en forme de texte enrichi

    Les colonnes au format RTF sont importées dans Access en tant que champs de type Mémo. La propriété Format du texte du champ Mémo a pour valeur Texte enrichi et la mise en forme est conservée.

    Relations

    Access ne crée pas automatiquement les relations entre des tables liées à la fin d'une opération d'importation. Vous devez créer manuellement les relations entre les tables, existants et nouveaux différents en utilisant les options sous l'onglet relations. Pour afficher l'onglet relations, sur le onglet Outils de base de données, dans le groupe relations, cliquez sur relations Image du bouton .

  4. Indiquez la base de données dans laquelle vous voulez importer les listes.

    Assurez-vous d'avoir les autorisations nécessaires pour ajouter des données à la base de données. Si vous ne voulez pas stocker les données dans un de vos bases de données existantes, créez une nouvelle base de données en cliquant sur le fichier onglet, Nouveau, puis sur base de données vide.

  5. Parcourez les tables de la base de données.

    L’opération d’importation crée une table du même nom que la liste SharePoint. Si ce nom est déjà utilisé, Access ajoute « 1 » au nom de la nouvelle table, par exemple Contacts1. Si Contacts1 est aussi déjà utilisé, Access crée Contacts2, etc.

Remarque : Access ne remplace jamais de table dans la base de données dans le cadre d’une opération d’importation. En outre, vous ne pouvez pas ajouter le contenu d’une liste ou d’une vue à une table existante.

Importer la liste

  1. Ouvrez la base de données de destination, puis sous l’onglet Données externes, dans le groupe Importer et lier, cliquez sur Plus, puis sur Liste SharePoint.

  2. Dans l’Assistant, spécifiez l’adresse du site source.

  3. Sélectionnez l’option Importer les données sources dans une nouvelle table de la base de données active et cliquez sur Suivant.

  4. Dans la liste affichée par l’Assistant, sélectionnez celles que vous voulez importer.

  5. Dans la colonne Éléments à importer, sélectionnez la vue souhaitée pour chaque liste sélectionnée.

  6. La case à cocher intitulée Importer les valeurs d’affichage plutôt que les ID pour les champs qui recherchent les valeurs stockées dans une autre liste détermine les données à importer dans les listes sélectionnées en vue de servir de listes de choix. Exécutez l’une des procédures suivantes :

    • Pour importer les valeurs à afficher en tant que partie intégrante du champ, activez la case à cocher. Le champ ne recherche ainsi pas les valeurs dans une autre table.

    • Pour que le champ de destination recherche les valeurs dans une autre table, désactivez la case à cocher. Les ID des lignes des valeurs à afficher sont alors copiés dans le champ de destination. Ces ID sont requis pour définir un champ Liste de choix dans Access.

    Lors de l’importation des ID, vous devez importer les listes qui fournissent les valeurs actives aux listes de choix (à moins que la base de données de destination contienne déjà des tables pouvant servir de tables de choix).

    L’opération d’importation place les ID dans le champ correspondant, mais ne définit pas toutes les propriétés nécessaires pour que le champ ait le même comportement qu’un champ Liste de choix. Les étapes à suivre pour définir les propriétés de recherche d’un tel champ sont décrites sous Définir les champs Liste de choix dans cet article.

  7. Cliquez sur OK.

Access importe les listes, puis affiche l’état de l’opération sur la dernière page de l’Assistant. Si vous prévoyez de répéter l’opération d’importation ultérieurement, vous pouvez enregistrer les détails en tant que spécification d’importation. Accédez aux étapes suivantes pour achever cette tâche.

Option d’enregistrement des paramètres d’importation

Si vous envisagez d’utiliser l’opération d’importation à l’avenir, vous pouvez enregistrer les paramètres d’importation. Vous avez également la possibilité de définir l’opération d’importation en tant que tâche dans Outlook si vous devez répéter l’importation à intervalles réguliers. Voici comment enregistrer les paramètres :

  1. Dans le dernier écran de l’Assistant, activez la case à cocher Enregistrer les étapes d’importation.

    Un ensemble de contrôles supplémentaires s’affiche.

  2. Dans la zone Enregistrer sous, tapez le nom de la spécification d’importation. Tapez éventuellement une description dans la zone Description.

  3. Si vous voulez effectuer l’opération à intervalles réguliers (p. ex. : toutes les semaines ou tous les mois), activez la case à cocher Créer une tâche Outlook. Une tâche est créée dans Microsoft Outlook 2013 qui vous permet d’exécuter la spécification.

  4. Cliquez sur Enregistrer l’importation.

Configurer la tâche Outlook

Si vous avez sélectionné la case à cocher Créer une tâche Outlook dans la procédure précédente, Access démarre Outlook et affiche une nouvelle tâche. Suivez ces étapes pour configurer la tâche.

Important : Si Outlook n'est pas installé, Access affiche un message d'erreur. Si Outlook n'est pas configuré correctement, la Outlook Assistant Configuration démarre. Suivez les instructions de l'Assistant pour configurer Outlook.

  1. Dans la fenêtre Importer nom de la tâche dans Outlook, vérifiez et modifiez les paramètres de tâche, notamment échéance et rappel.

    Pour la rendre périodique, sous l’onglet Tâche, dans le groupe Périodicité, cliquez sur Périodicité.

  2. Lorsque vous en avez terminé avec les paramètres, cliquez sur Enregistrer et fermer.

Exécuter une tâche enregistrée

  1. Dans le volet de navigation Outlook, cliquez sur Tâches et double-cliquez sur la tâche que vous voulez exécuter.

  2. Sous l’onglet Tâche, dans le groupe Microsoft Office Access, cliquez sur Exécuter l’importation.

  3. Retournez dans Access, puis ouvrez la table importée en mode Feuille de données. Assurez-vous que tous les champs et enregistrements ont bien été importés et qu’aucune erreur n’est mentionnée. Activez le mode Création pour consulter le type de données et autres propriétés de champs.

Tâches connexes

Une fois l’importation terminée, vous pouvez envisager d’exécuter d’autres tâches.

Vérifier les types de données   Access sélectionne le type de données approprié pour chaque champ correspondant à une colonne source. Pour afficher la liste de Access et types de données SharePoint correspondances entre eux pendant l'importation ou une liaison, et définir les paramètres de champ importés avec succès pour chaque type de données. 

Examiner les champs supplémentaires    Selon le type de liste sur lequel est basée la table, vous remarquerez également la présence dans la table de quelques champs supplémentaires (par exemple, modifier, modifiées et Type). Pour plus d'informations sur ces champs et les informations qu'ils contiennent, consultez l'aide de SharePoint. Si vous n'avez pas besoin ces champs dans la base de données Access, vous pouvez les supprimer en toute sécurité.

Définir les champs Liste de choix    Si vous avez importé des ID en vue de les utiliser dans des listes de choix, vous devez définir manuellement les propriétés de recherche des champs correspondants.

  1. En mode Création de table, dans la liste Type de données du champ, cliquez sur Assistant Liste de choix.

  2. Dans l’Assistant, acceptez la sélection par défaut (Je veux que la liste de choix recherche les valeurs dans une table ou requête), puis cliquez sur Suivant.

  3. Sélectionnez la table ou la requête qui doit fournir les valeurs de la liste de choix pour le champ, puis cliquez sur Suivant.

Remarque : Il peut s’agir d’une table nouvellement importée ou d’une table existante.

  1. Dans le volet Liste des champs, sélectionnez l’ID du champ ainsi que le champ qui contient les valeurs à afficher, puis cliquez sur Suivant.

  2. Spécifiez un ordre de tri, puis cliquez sur Suivant.

  3. Cliquez sur Terminer.

Haut de la page

Attacher une liste SharePoint

Lorsque vous liez à une liste SharePoint, Access crée une nouvelle table, souvent appelée table liée, qui reflète la structure et le contenu de la liste source. Contrairement à l’importation, attacher revient à créer un lien portant seulement sur la liste choisie, et non pas sur une vue spécifique de cette liste.

L’attache est une technique plus puissante que l’importation pour deux aspects :

  • Ajout et mise à jour des données    Vous pouvez apporter des modifications aux données en naviguant sur le site SharePoint ou en travaillant en mode feuille de données ou de formulaires dans Access. Les modifications que vous apportez dans un seul endroit sont répercutées dans l'autre. Mais, si vous souhaitez apporter des modifications structurelles, par exemple suppression ou modification d'une colonne, vous devez le faire en ouvrant la liste sur le site SharePoint. Vous ne pouvez pas ajouter, supprimer ou modifier les champs dans une table liée lorsque vous travaillez dans Access.

  • Tables de choix    Lorsque vous liez à une liste SharePoint, Access crée automatiquement les tables attachées pour toutes les listes de choix (à moins que ces listes sont déjà liés à la base de données). Si les listes de recherche contiennent des colonnes qui s'affichent les autres listes, ces listes sont également incluses dans l'opération d'attache, afin que la liste de choix de chaque table attachée compte une table attachée correspondante dans la base de données. Access crée également les relations entre ces tables liées.

Scénarios courants pour attacher une liste SharePoint

Vous attachez généralement une liste SharePoint depuis une base de données Access pour les raisons suivantes :

  • Votre service ou groupe de travail utilise Access pour bénéficier des fonctionnalités d’élaboration d’états et de requêtes avancés, et utilise Windows SharePoint Services pour la collaboration et la communication entre les équipes. Chaque équipe crée des listes pour effectuer le suivi de divers éléments (tels que des contacts et des problèmes rencontrés), mais les données de ces listes doivent souvent être réintégrées à une base de données en vue d’une agrégation et de l’élaboration d’états. L’attache constitue un choix pertinent car la technique permet aussi bien aux utilisateurs du site SharePoint qu’à ceux de la base de données d’ajouter et de mettre à jour des données, mais aussi de pouvoir toujours afficher et travailler avec les données les plus récentes.

  • Vous êtes un utilisateur d’Access n’ayant commencé à utiliser Windows SharePoint Services que récemment. Vous avez fait migrer plusieurs de vos bases de données vers le site SharePoint de votre équipe et la plupart des tables de ces bases de données sont des tables attachées. Désormais, plutôt que de créer des tables locales, vous créerez des listes SharePoint et les attacherez à vos bases de données.

  • Vous désirez continuer à stocker vos listes sur des sites SharePoint mais voulez également travailler avec les données les plus récentes à partir d’Access pour pouvoir exécuter des requêtes et établir des états destinés à l’impression.

Préparer la liaison à une liste SharePoint

  1. Localisez le site SharePoint qui héberge les listes à attacher et notez l’adresse du site.

    Une adresse de site valide commence par http:// ou https:// suivi du nom du serveur et se termine par le chemin d'accès au site spécifique sur le serveur.

  2. Identifiez les listes à attacher. Vous pouvez attacher plusieurs listes en une seule opération mais vous ne pouvez attacher qu’une seule vue spécifique par liste.

    Remarque : Il vous est également impossible d’attacher des enquêtes ou des discussions.

  3. Passez en revue les colonnes de la liste. Le tableau suivant répertorie quelques considérations à garder à l’esprit lors de l’importation de différents éléments.

    Élément

    Considérations

    Colonnes

    Access ne prend pas en charge plus de 256 champs dans une table, par conséquent la table attachée contient uniquement les 256 premières colonnes.

    Dossiers

    Chaque dossier de la liste SharePoint apparaît sous forme d’enregistrement dans la table Access. Les éléments inclus dans un dossier apparaissent également sous forme d’enregistrements placés juste en dessous de l’enregistrement correspondant à ce dossier.

    Colonnes de recherche

    Si une colonne source recherche des valeurs dans une autre liste et que la liste associée ne se trouve pas déjà dans la base de données, Access crée automatiquement les tables attachées pour les listes associées.

    Remarque : Une colonne source de type Personne ou Groupe correspond à un type spécial de colonne de recherche. Elle recherche des valeurs dans la liste d’informations utilisateur. Si vous l’attachez à une liste contenant une colonne Personne ou Groupe, Access crée automatiquement une table attachée pour la liste d’informations utilisateur.

    Colonnes calculées

    Les résultats dans une colonne calculée s’affichent dans le champ correspondant mais vous n’avez la possibilité ni d’afficher ni de modifier la formule dans Access.

    Pièces jointes

    La colonne de pièces jointes de la liste s’affiche sous forme de champ intitulé Pièces jointes.

    Colonnes en lecture seule

    Les colonnes qui sont en lecture seule dans une liste SharePoint restent en lecture seule dans Access. En outre, vous risquez de ne pas pouvoir ajouter, supprimer ou modifier des colonnes dans Access.

    Colonnes à valeurs multiples

    Une colonne de type Choix ou Recherche peut contenir plusieurs valeurs. Pour ces colonnes, l’opération d’attache entraîne la création de champs prenant en charge les valeurs multiples. Ces colonnes de choix à valeurs multiples sont créées dans la table attachée si la colonne source est de type Recherche.

  4. Identifiez la base de données dans laquelle vous voulez créer les tables attachées. Assurez-vous que vous disposez des autorisations nécessaires pour ajouter des données à la base de données. Si vous ne voulez pas stocker les données dans une base existante, créez-en une vide.

  5. Parcourez les tables de la base de données. Quand vous importez une liste SharePoint, une table possédant le même nom que la liste source est créée. Si ce nom est déjà utilisé, Access ajoute au nouveau nom de table « 1 », par exemple Contacts1. Si Contacts1 est déjà utilisé, Access crée Contacts2, etc. La même règle s’applique pour les listes attachées.

    Remarque : Rappelez-vous qu’Access ne remplace jamais de table dans la base de données dans le cadre d’une opération d’importation. En outre, vous ne pouvez pas ajouter le contenu d’une liste SharePoint à une table existante.

Lier des données

  1. Ouvrez la base de données de destination.

  2. Sous l’onglet Données externes, dans le groupe Importer et lier, cliquez sur Plus.

  3. Cliquez sur Liste SharePoint.

  4. Dans l’Assistant, spécifiez l’adresse du site source.

  5. Sélectionnez Lier à la source de données en créant une table attachée, puis cliquez sur Suivant.

    L’Assistant affiche les listes qui peuvent être attachées.

  6. Sélectionnez celles qui vous intéressent, puis cliquez sur OK.

    Remarque :  Si certaines listes sont déjà attachées à la base de données active, les cases correspondantes sont activées. Si vous voulez supprimer des liens, désactivez les cases à cocher des liens à supprimer.

    Access Access tente de créer les tables attachées, tant pour les listes que vous avez sélectionnées dans cette opération que pour chacune des listes associées. Access tente également d’actualiser les tables attachées correspondant aux listes sélectionnées dans l’Assistant. Access crée enfin aussi les relations entre ces tables. Contrairement à une opération d’importation, une opération d’attache conserve le paramètre des propriétés de liste de choix entre un champ Liste de choix et sa table associée. Il n’est pas impératif de définir manuellement les propriétés du champ Liste de choix en mode Création de table.

  7. Parcourez les nouvelles tables attachées en mode Feuille de données. Assurez-vous que tous les champs et enregistrements s’affichent correctement.

    Access choisit le type de données approprié pour chaque champ correspondant à une colonne source. Il est important de noter que chaque fois que vous ouvrez une table attachée ou la liste source, vous y retrouvez les données les plus récentes. Les modifications structurelles effectuées dans une liste ne sont cependant pas répercutées automatiquement dans une table attachée. Pour mettre à jour une table attachée en appliquant la structure de liste la plus récente, cliquez avec le bouton droit sur la table dans le volet de navigation, pointez sur Options de liste SharePoint, puis cliquez sur Actualiser la liste Image du bouton .

Haut de la page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×