Importer des données à partir d’Excel, de SQL Server, de sites SharePoint et d’autres sources externes

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Vous pouvez rapidement importer et afficher des données directement sur vos formes à l’aide de Microsoft Office Visio Professionnel 2007. La première étape consiste à vous connecter à la source de données et importer des données dans votre dessin. La deuxième étape consiste à lier les données importées à des formes.

Pour plus d'informations sur la manière dont vous pouvez ajouter des données à vos formes sans importer les données, consultez Ajouter des données aux formes.

Dans cet article

Étape 1 : Importer les données

Étape 2 : Lier les lignes de données à des formes du dessin

Étape 1 : Importer les données

Au cours de cette première étape, vous utilisez l’Assistant Sélecteur de données pour importer vos données dans la fenêtre Données externes.

Les données figurant dans la fenêtre Données externes sont un instantané de votre source de données au moment de l’importation. Vous pouvez mettre à jour les données dans votre dessin pour faire correspondre les modifications dans votre source de données. Toutefois, vous ne pouvez pas actualiser votre source de données en modifiant les données dans votre dessin. Voir Actualiser des données importées.

  1. Dans le menu Données, cliquez sur Lier des données à des formes.

  2. Dans la première page de l'Assistant Sélecteur de données, choisissez, parmi les types de sources de données suivants, ceux que vous voulez utiliser :

    • Classeur Microsoft Office Excel

    • Base de données Microsoft Office Access

    • Liste Microsoft Windows SharePoint Services

    • Base de données Microsoft SQL Server

    • Autre source de données OLEDB ou ODBC

    • Connexion précédemment créée

  3. Poursuivez l'exécution de l'Assistant jusqu'au terme de la procédure.

    Remarque : Si vous choisissez une source autre qu'un classeur Excel, une base de données Access ou une liste SharePoint dans la première page de l'Assistant, il se peut que vous soyez redirigé temporairement vers l'Assistant Connexion de données au cours de l'exécution de l'Assistant Sélecteur de données.

    Vous pouvez obtenir une aide spécifique pour la plupart des pages de l'Assistant. Pour accéder à l'aide, appuyez sur F1 ou cliquez sur le bouton Aide.

Une fois que vous avez cliqué sur Terminer dans la dernière page de l'Assistant Sélecteur de données, la fenêtre Données externes s'ouvre en affichant vos données importées dans une grille.

Haut de la page

Étape 2 : Lier les lignes de données à des formes du dessin

Il existe trois façons de lier des lignes de données à des formes dans votre dessin : vous pouvez lier des lignes à des formes existantes une par une, vous pouvez lier automatiquement les lignes à des formes ou vous pouvez créer des formes à partir des données.

Lier des lignes à des formes existantes une par une

Cette approche est recommandée pour des dessins existants qui contiennent relativement peu de formes.

  • Faites glisser une ligne depuis la fenêtre Données externes sur une forme de votre dessin.

    Les données apparaissent dans la forme et une icône de liaison s'affiche à gauche de la ligne dans la fenêtre Données externes.

    Faire glisser une ligne sur une forme

    Remarques : 

    • Vous pouvez lier une seule ligne à plusieurs formes, mais vous ne pouvez pas lier plusieurs lignes à une seule forme.

    • Pour modifier ou améliorer l'apparence des formes et des données, consultez Améliorer vos données avec des graphiques.

    • Pour afficher la fenêtre Données externes, dans le menu Affichage, cliquez sur Fenêtre Données externes.

Lier automatiquement des lignes à des formes existantes

Cette approche est recommandée pour des dessins existants avec un grand nombre de formes. Cela fonctionne uniquement si les formes contiennent des données déjà qu’ils que vous pouvez lier aux données dans la source de données.

  1. Dans le menu Données, cliquez sur Liaison automatique.

  2. Suivez les étapes de l'Assistant Liaison automatique.

    Vos données seront affichent dans vos formes. Pour modifier ou améliorer l’aspect des formes et des données, voir améliorer vos données grâce aux graphiques de données.

Aide spécifique est disponible pour la plupart des pages de l’Assistant. Pour accéder à l’aide, appuyez sur F1 ou cliquez sur l’icône d’aide.

Créer des formes à partir de vos données

Cette approche est recommandée lorsque votre dessin ne contient pas encore de formes et que vous ne devez pas utiliser de formes spécifiques.

  1. Cliquez sur une forme dans la fenêtre Formes.

  2. Faites glisser une ligne ou un jeu de lignes depuis la fenêtre Données externes sur un espace vide de votre dessin.

    Une instance de la forme sur laquelle vous cliquez apparaît pour chaque ligne que vous faites glisser sur le dessin.

Haut de la page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×