Importer des bases de données Access 2.0 et Access 95 dans les versions actuelles

Importer des bases de données Access 2.0 et Access 95 dans les versions actuelles

Si vous utilisez une base de données existante au format Access 2.0 ou Access 95 (.mdb), dans certains cas, vous pouvez importer ses tables, requêtes et macros dans une version plus récente d’Access qui utilise le format de fichier .accdb.

Pour importer des formulaires et états contenant du code (et des modules) VBA, commencez par convertir votre base de données Access 2.0 ou Access 95 au format de fichier Access 2002 - 2003 ou Access 2000 à l’aide de Microsoft Office Access 2003, Access 2002 ou Access 2000. Vous pouvez ensuite utiliser une version plus récente, comme Access 2007, pour convertir ce fichier au format .accdb afin de l’ouvrir dans Access 2016, Access 2013 ou Access 2010.

Les sections suivantes de cet article expliquent comment effectuer ces opérations.

Vous utilisez Access 2010, Access 2013 ou Access 2016 ?

Access 2007 était la dernière version à prendre en charge l’ouverture, l’importation, la liaison ou l’exportation vers Access 2.0 et Access 95. Vous devez disposer d’Access 2007 pour pouvoir exporter, importer ou lier des données à partir de fichiers Access 1.0 et 2.0 (Red 2 ou Jet 2) et de bases de données Access 95. Dans ce cas, vous devez utiliser Access 2007 comme étape intermédiaire pour convertir une base de données Access 2.0 dans un format compatible avec l’une de ces versions.

Que voulez-vous faire ?

Ouvrir une base de données Access 2.0 dans Access 2007

Importer les données d’une base de données Access 2.0 dans Access 2007

Importer les données d’une base de données Access 95 dans Access 2007

Convertir une base de données Access 2.0 ou Access 95 à l’aide d’Access 2000, Access 2002 ou Access 2003

Ouvrir une base de données Access 2.0 dans Access 2007

Lorsque vous ouvrez une base de données Access 2.0 dans Access 2007, Access affiche un certain nombre d’invites au terme desquelles le message suivant apparaît : Cette base de données a été enregistrée au format de fichier Microsoft Access 2.0.

Cette base de données a été enregistrée au format de fichier Microsoft Access 2.0.

Vous pouvez importer les tables, requêtes et macros d’une base de données Access 2.0 dans une base de données Access 2007 (.accdb). Pour importer des formulaires, états ou modules dans une base de données Access 2007, commencez par convertir la base de données à l’aide d’une version antérieure d’Access, puis ouvrez la base de données convertie à l’aide d’Access 2007 et convertissez-la en base de données Access 2007 au format de fichier .accdb. Pour plus d’informations, consultez la section Convertir une base de données Access 2.0 ou Access 95 à l’aide d’Access 2003, Access 2002 ou Access 2000.

Importer les données d’une base de données Access 2.0 dans Access 2007

Lorsque vous importez des objets à partir d’une autre base de données, des copies des objets importés sont créées dans la base de données de destination. La source n’est pas modifiée. Pour importer les données d’une base de données Access 2.0 dans Access 2007, commencez par ouvrir la base de données dans laquelle vous souhaitez importer les données. Utilisez ensuite les commandes de l’onglet Données externes pour poursuivre le processus d’importation, qui implique l’appel de l’Assistant Importation.

  1. Ouvrez Access 2007, puis cliquez sur le bouton Microsoft Office et sur Ouvrir.

  2. Dans la boîte de dialogue Ouvrir, sélectionnez et ouvrez la base de données dans laquelle vous souhaitez importer les tables, requêtes ou macros.

  3. Dans l’onglet Données externes, accédez au groupe Importer et cliquez sur Access.

  4. Dans la zone de texte Nom du fichier de l’Assistant Données externes, entrez le nom de la base de données source, ou cliquez sur Parcourir pour afficher la boîte de dialogue Ouvrir le fichier et choisissez ou entrez le nom de la base de données source.

  5. Cliquez sur Importer des tables, des requêtes, des formulaires, des états, des macros et des modules dans la base de données active, puis sélectionnez OK.

  6. Dans la boîte de dialogue Importer des objets, cliquez sur chaque onglet, puis sélectionnez les objets souhaités. N’oubliez pas que les tables, requêtes et macros d’une base de données Access 2.0 peuvent uniquement être importées dans Access 2007.

    Boîte de dialogue Importer des objets

    Pour annuler la sélection d’un objet, cliquez à nouveau sur celui-ci.

  7. Cliquez sur Options pour spécifier des paramètres supplémentaires.

    Le tableau suivant décrit l’impact de chaque option sur les résultats de l’opération.

    Élément

    Description

    Case à cocher Relations

    Importe les relations entre les tables sélectionnées.

    Case à cocher Menus et barres d’outils

    Importe les menus et barres d’outils personnalisés présents dans la base de données source. Ceux-ci s’affichent dans un onglet nommé Compléments.

    Case à cocher Paramètres d'import/export

    Importe les spécifications d’importation ou d’exportation enregistrées présentes dans la base de données source.

    Case à cocher Groupes du volet de navigation

    Importe les groupes du volet de navigation personnalisés présents dans la base de données source.

    Bouton Définition et données

    Importe la structure et les données de toutes les tables sélectionnées.

    Bouton Définition uniquement

    Importe uniquement les champs des tables sélectionnées. Les enregistrements sources ne sont pas importés.

    Bouton Comme des requêtes

    Importe les requêtes sélectionnées en tant que requêtes. Dans ce cas, n’oubliez pas d’importer toutes les tables sous-jacentes en plus des requêtes.

    Bouton Comme des tables

    Importe les requêtes en tant que tables. Dans ce cas, il est inutile d’importer les tables sous-jacentes.

  8. Cliquez sur OK pour finaliser l’opération.

    Access copie les données et affiche des messages d’erreur s’il rencontre des problèmes. Si l’opération d’importation des données aboutit, la dernière page de l’Assistant vous permet d’enregistrer les détails de l’opération en tant que spécification d’importation en vue d’un usage futur.

Importer les données d’une base de données Access 95 dans Access 2007

Pour importer les données d’une base de données Access 95 dans Access 2007, commencez par ouvrir la base de données Access 2007 dans laquelle vous souhaitez importer les données. Utilisez ensuite les commandes de l’onglet Données externes, qui impliquent l’appel de l’Assistant Importation.

Vous pouvez importer les tables, requêtes et macros d’une base de données au format Access 95 (.mdb) dans une base de données Access 2007 (.accdb). Vous pouvez également importer des formulaires et états qui n’utilisent pas le code VBA. Pour importer des formulaires et états contenant du code (et des modules) VBA, commencez par convertir votre base de données Access 95 au format de fichier Access 2002 - 2003 ou Access 2000 à l’aide de Microsoft Office Access 2003, Access 2002 ou Access 2000, puis utilisez Access 2007 pour convertir ce fichier au format Access 2007 (.accdb).

  1. Ouvrez Access 2007, puis cliquez sur le bouton Microsoft Office et sur Ouvrir.

  2. Dans la boîte de dialogue Ouvrir, sélectionnez et ouvrez la base de données dans laquelle vous souhaitez importer les tables, requêtes ou macros.

  3. Dans l’onglet Données externes, accédez au groupe Importer et cliquez sur Access.

  4. Dans la zone de texte Nom du fichier de l’Assistant Données externes, entrez le nom de la base de données source, ou cliquez sur Parcourir pour afficher la boîte de dialogue Ouvrir le fichier, puis choisissez ou entrez le nom de la base de données source.

  5. Cliquez sur Importer des tables, des requêtes, des formulaires, des états, des macros et des modules dans la base de données active, puis sélectionnez OK.

  6. Dans la boîte de dialogue Importer des objets, cliquez sur chaque onglet, puis sélectionnez les objets à importer.

    Pour annuler la sélection d’un objet, cliquez à nouveau sur celui-ci.

  7. Cliquez sur Options pour spécifier des paramètres supplémentaires. Ces paramètres supplémentaires s’afficheront en groupes sous la liste d’objets.

  8. Cliquez sur OK pour finaliser l’opération.

    Access copie les données et affiche des messages d’erreur s’il rencontre des problèmes. Si l’opération d’importation des données aboutit, la dernière page de l’Assistant vous permet d’enregistrer les détails de l’opération en tant que spécification d’importation en vue d’un usage futur.

Convertir une base de données Access 2.0 ou Access 95 à l’aide d’Access 2000, Access 2002 ou Access 2003

Vous pouvez convertir une base de données Access 2.0 au format de fichier Access 2000 ou Access 2002 - 2003 à l’aide d’une des versions d’Access répertoriées dans le tableau suivant, à condition d’avoir acheté cette version d’Access et de l’avoir installée sur votre ordinateur. Selon la version d’Access que vous utilisez, le convertisseur Access 2.0 est peut-être déjà installé.

Version

Convertisseur Access 2.0

Microsoft Office Access 2003

Cette version requiert le téléchargement et l’installation du convertisseur Access 2.0 pour Access 2003. Sachez néanmoins que cet outil n’est plus disponible dans le Centre de téléchargement Microsoft, car le support étendu d’Access 2003 n’est plus assuré.

Microsoft Access 2002

Inclus dans le produit.

Microsoft Access 2000

Inclus dans le produit.

Vous devez convertir le fichier Access 2.0 ou Access 95 au format Access 2000 ou Access 2002 - 2003 (.mdb). Utilisez ensuite Access 2007 pour convertir le fichier obtenu au format Access 2007 (.accdb). Vous pouvez alors utiliser la base de données dans Access 2007, ou l’ouvrir dans Access 2016, Access 2013 ou Access 2010. Selon la version antérieure d’Access dont vous disposez, procédez comme suit :

  1. Ouvrez Access 2000, Access 2002 ou Access 2003.

  2. Dans le menu Fichier, cliquez sur Ouvrir, puis sélectionnez le nom de fichier de la base de données Access 95 que vous souhaitez convertir.

  3. Dans le menu Outils, cliquez sur Utilitaires de base de données, Convertir une base de données, puis Vers le format de fichiers Access 2000.

  4. Dans la boîte de dialogue Convertir la base de données sous, entrez le nom du nouveau fichier, puis cliquez sur Enregistrer.

    Un message d’avertissement peut s’afficher pour vous indiquer que vous ne serez pas en mesure d’utiliser la base de données convertie dans les versions antérieures d’Access. Si ce message s’affiche, cliquez sur OK.

    Le fichier est enregistré au format Access 2000.

  5. Ouvrez Access 2007.

  6. Cliquez sur le bouton Microsoft Office, puis sur Ouvrir.

  7. Dans la boîte de dialogue Ouvrir, sélectionnez et ouvrez la base de données convertie.

  8. Cliquez sur le bouton Microsoft Office, puis sur Convertir.

  9. Dans la boîte de dialogue Enregistrer sous, entrez le nom du fichier Access 2007 ou acceptez le nom de fichier proposé, puis cliquez sur Enregistrer.

    Le fichier est enregistré au format Access 2007 (.accdb).

Haut de page

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×