Imbriquer une fonction dans une fonction

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Lorsque vous créez une formule en utilisant une fonction, vous pouvez imbriquer des fonctions à l’intérieur d’autres fonctions. Lorsque vous effectuez, vous utilisez les résultats des fonctions imbriquées comme arguments, la fonction première nécessaires au bon fonctionnement de données. Vous pouvez toujours déterminer quand une fonction est imbriquée, car il est à l’intérieur des parenthèses.

Voici un exemple. La fonction SI utilise les fonctions imbriquées MOYENNE et SOMME comme arguments.

=SI(MOYENNE(F2:F5)>50;SOMME(G2:G5);0)

Cette formule se lit de gauche à droite. SI la valeur moyenne des cellules F2 à F5 est supérieure à 50, alors effectuer la SOMME des valeurs dans les cellules G2 à G5. Dans le cas contraire, renvoyer 0.

Vous pouvez imbriquer jusqu’à 64 niveaux de fonctions et vous les entrez comme n’importe quelle autre fonction :

  1. Cliquez sur la cellule qui contiendra la formule.

  2. Entrez la formule dans la barre de formule, puis appuyez sur Entrée.

Voici un autre exemple. Celui-ci imbrique une fonction SI dans une autre fonction SI pour calculer des déductions sur base d’un niveau de revenu.

=SI(A5<31500;A5*15%;SI(A5<72500;A5*25%;A5*28%))

Vous pouvez également lire cet exemple de gauche à droite. SI la valeur dans la cellule A5 est inférieure à 31 500, alors multiplier la valeur par 15%. Mais SI ce n’est pas le cas, vérifier si la valeur est inférieure à 72 500. SI c’est le cas, multiplier par 25%, sinon multiplier par 28%.

Notez que les niveaux de revenus n’utilisent pas de virgules. Si c’était le cas, la fonction SI essaierait de les utiliser comme arguments et la formule ne fonctionnerait pas (remarque applicable uniquement à la version anglaise d’Excel, où la virgule est utilisée comme séparateur de liste).

Haut de la page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×