Gérer les plages de données externes et leurs propriétés

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Vous pouvez modifier les propriétés d’une plage de données externes pour contrôler les données importées dans une feuille de calcul via une connexion à une source de données externes.

Que voulez-vous faire ?

Pour plus d’informations sur les propriétés et les plages de données externes

Rechercher une plage de données externes

Modifier le nom d’une plage de données externes

Modifier la requête sous-jacente d’une plage de données externes

Copier une plage de données externes et sa requête sous-jacente

Spécifier le mode d’ajout de données à une plage de données externes

Spécifier le format et la disposition des données

Copier des formules lorsqu’une plage de données externes s’agrandit

Geler les données d’une plage de données externes

Personnaliser les noms des champs d’une plage de données externes

Supprimer une plage de données externes

En savoir plus sur les plages de données externes et les propriétés

Une plage de données externes (également appelée table de requêtes) est un nom défini ou un nom de table qui définit l’emplacement des données insérées dans une feuille de calcul. Lorsque vous vous connectez aux données externes, Excel crée automatiquement une plage de données externes. Seul un rapport de tableau croisé dynamique qui est connecté à une source de données fait exception à cette règle, car il ne fait pas appel à une plage de données externes. Dans Excel, vous pouvez formater et disposer une plage de données externes ou l’utiliser dans des calculs comme avec d’autres données.

Propriétés d’une plage de données externes

Une plage de données externes présente des propriétés supplémentaires (à ne pas confondre avec des propriétés de connexion) qui vous permettent de contrôler les données, en préservant le formatage des cellules ou la largeur des colonnes, par exemple. Vous pouvez modifier ces propriétés de plages de données externes en cliquant sur Propriétés dans le groupe Connexions de l’onglet Données. Apportez ensuite les modifications requises en procédant comme suit :

  • Pour les plages de données externes créées à partir de Microsoft Query et l’Assistant Connexion de données, utilisez la boîte de dialogue Propriétés des données externes.

  • Pour les plages de données externes créées à partir d’un fichier texte importé ou d’une requête Web qui récupère des données HTML, utilisez la boîte de dialogue Propriétés de la plage de données externes.

  • Pour les plages de données externes créées à partir d’une requête Web qui extrait les données XML, utilisez la boîte de dialogue Propriétés du mappage XML.

Utilisation de modèles avec des plages de données externes

Si vous voulez partager une synthèse ou un rapport reposant sur des données externes, vous pouvez donner aux autres utilisateurs un classeur qui contient une plage de données externes ou créer un modèle de rapport. Un modèle de rapport vous permet d’enregistrer la synthèse ou le rapport sans enregistrer les données externes afin de réduire la taille du fichier. Les données externes sont extraites lorsqu’un utilisateur ouvre le modèle de rapport.

Haut de la page

Rechercher une plage de données externes

  1. Sélectionnez la feuille de calcul dans laquelle vous voulez rechercher une plage de données externes.

  2. Dans la barre de formule, cliquez sur la flèche en regard de l’option Zone Nom, puis sur le nom de la plage de données externes de votre choix.

Haut de la page

Modifier le nom d’une plage de données externes

  1. Dans l’onglet Formules, dans le groupe Noms définis, cliquez sur Gestionnaire de noms.

    Image du ruban Excel

  2. Dans la boîte de dialogue Gestionnaire de noms, cliquez sur le nom de la plage de données externes, puis sur Modifier. Vous pouvez également double-cliquer sur le nom.

  3. Dans la boîte de dialogue Modifier le nom, tapez le nouveau nom de la référence dans la zone Nom.

Remarque : Le bouton Fermer ne ferme que la boîte de dialogue Gestionnaire de noms. Il n’est pas nécessaire de cliquer sur Fermer pour valider les modifications apportées.

Haut de la page

Modifier la requête sous-jacente d’une plage de données externes

Vous pouvez modifier la requête sous-jacente d’une plage de données externes créée dans Microsoft Query, un fichier texte importé, une requête Web ou l’Assistant Connexion de données.

Modifier la requête sous-jacente d’une plage de données externes créée par Microsoft Query

  1. Cliquez sur une cellule de la plage de données externes dont vous souhaitez modifier la requête sous-jacente.

  2. Sous l’onglet données, dans le groupe connexions, cliquez sur Propriétés.

    Image Ruban Excel

  3. Dans la boîte de dialogue Propriétés des données externes, cliquez sur Propriétés de connexion propriétés .

  4. Dans la boîte de dialogue Propriétés de connexion, cliquez sur l’onglet Définition, puis sur Modifier la requête.

Pour plus d’informations sur la création et la modification de requêtes dans Microsoft Query, voir l’aide de Microsoft Query.

Modifier la requête sous-jacente d’une plage de données externes créée à partir d’un fichier texte importé

  1. Cliquez sur une cellule de la plage de données externes dont vous souhaitez modifier la requête sous-jacente.

  2. Dans l’onglet Données, dans le groupe Connexions, cliquez sur Connexions.

    Image Ruban Excel

  3. Dans la boîte de dialogue Connexions du classeur, cliquez sur Propriétés.

  4. Dans la boîte de dialogue Propriétés de connexion, cliquez sur l’onglet Définition, puis sur Modifier la requête.

  5. Dans la boîte de dialogue Importer Fichier Texte, cliquez sur Importer.

  6. Modifiez le fichier texte importé dans l’Assistant Importation de texte, et cliquez sur Terminer.

    Pour plus d’informations sur l’importation de fichiers texte, voir Importer ou exporter des fichiers texte.

Modifier la requête sous-jacente d’une plage de données externes créée par une requête Web

  1. Cliquez sur une cellule de la plage de données externes dont vous souhaitez modifier la requête sous-jacente.

  2. Sous l’onglet données, dans le groupe connexions, cliquez sur Propriétés.

    Image Ruban Excel

  3. Dans la boîte de dialogue Connexions du classeur, cliquez sur Propriétés.

  4. Dans la boîte de dialogue Propriétés de connexion, cliquez sur l’onglet Définition, puis sur Modifier la requête.

  5. Modifiez la requête Web dans la boîte de dialogue Modifier la requête sur le Web, puis cliquez sur Terminer.

Pour plus d’informations sur la création et la modification de requêtes Web, voir Obtenir des données externes à partir d’une page Web.

Modifier la requête sous-jacente d’une plage de données externes créée par l’Assistant Connexion de données

  1. Cliquez sur une cellule de la plage de données externes dont vous souhaitez modifier la requête sous-jacente.

  2. Sous l’onglet données, dans le groupe connexions, cliquez sur Propriétés.

    Image Ruban Excel

  3. Dans la boîte de dialogue Propriétés des données externes, cliquez sur Propriétés de connexion propriétés .

  4. Dans la boîte de dialogue Propriétés de connexion, cliquez sur l’onglet Définition.

  5. Effectuez l’une des opérations suivantes :

    • Dans la zone Type de commande, cliquez sur Table, puis, dans la zone Texte de la commande, remplacez la valeur par le nom d’une table, d’une vue ou d’une requête appropriée.

    • Dans la zone Type de commande, cliquez sur SQL ou Par défaut, puis, dans la zone Texte de la commande, modifiez l’instruction SQL.

      Remarque : Selon la définition de la connexion, la zone Type de commande risque de ne pas être disponible (estompée).

Haut de la page

Copier une plage de données externes et sa requête sous-jacente

  1. Dans la barre de formule, cliquez sur la flèche en regard de Zone Nom, puis sélectionnez le nom de la plage de données externes à copier.

    Pour un tableau Excel, sélectionnez le nom de la plage, puis appuyez sur Ctrl+A pour sélectionner les en-têtes du tableau.

    Si vous souhaitez inclure des étiquettes ou formules de colonnes ne faisant pas partie de la plage de données externes, sélectionnez les cellules contenant les étiquettes ou formules de colonnes à copier. Dans la barre de formule, cliquez sur la flèche en regard de l’option Zone Nom, puis sélectionnez le nom de la plage de données externes à copier.

  2. Dans l’onglet Accueil, dans le groupe Presse-papiers, cliquez sur Copier.

    Image du ruban Excel

  3. Ouvrez le classeur dans lequel vous souhaitez coller la plage de données externes.

  4. Cliquez sur la cellule supérieure gauche de la zone de collage.

    Pour vous assurer que les données externes ne remplacent pas les données actuelles, veillez à ce que la feuille de calcul ne contienne aucune donnée sous la cellule sur laquelle vous cliquez ou à droite de cette dernière.

  5. Dans l’onglet Accueil, dans le groupe Presse-papiers, cliquez sur Coller.

Remarque : Si vous copiez uniquement une partie d’une plage de données externes, le sous-jacent requête n’est pas copiée et les données copiées ne peuvent pas être actualisées.

Haut de la page

Spécifier le mode d’ajout de données à une plage de données externes

Vous pouvez déterminer la manière dont est géré un jeu de données plus ou moins important renvoyé à Excel lorsque les données sont actualisées.

  1. Sous l’onglet données, dans le groupe connexions, cliquez sur Propriétés.

    Image Ruban Excel

  2. Dans la boîte de dialogue Propriétés de la plage de données externes, sous Si le nombre d’enregistrements (lignes) change après l’actualisation, cliquez sur l’une des options suivantes :

    • Insérer des cellules pour les nouvelles données, supprimer les cellules inutilisées

      Remarques : 

      • Lorsqu’une ou plusieurs lignes sont ajoutées à la source de données, les cellules se trouvant directement sous la plage de données externes descendent, mais les cellules se trouvant à droite de la plage de données externes restent au même endroit.

      • Lorsqu’une ou plusieurs lignes sont supprimées de la source de données, les cellules se trouvant directement sous la plage de données externes montent, mais les cellules se trouvant à droite de la plage de données externes restent au même endroit.

    • Insérer des lignes pour les nouvelles données, supprimer les cellules inutilisées

      Remarques : 

      • Lorsqu’une ou plusieurs lignes sont ajoutées à la source de données, les cellules se trouvant directement sous la plage de données externes et à droite de cette dernière descendent.

      • Lorsqu’une ou plusieurs lignes sont supprimées de la source de données, les cellules se trouvant directement sous la plage de données externes et à droite de cette dernière restent au même endroit.

    • Remplacer le contenu des cellules si nécessaire, supprimer les cellules inutilisées

      Remarques : 

      • Lorsqu’une ou plusieurs lignes sont ajoutées à la source de données, les cellules se trouvant directement sous la plage de données externes sont remplacées, mais les cellules se trouvant à droite de la plage de données externes restent au même endroit.

      • Lorsqu’une ou plusieurs lignes sont supprimées de la source de données, les cellules se trouvant directement sous la plage de données externes et à droite de cette dernière restent au même endroit.

Haut de la page

Spécifier le format et la disposition des données

  1. Sous l’onglet données, dans le groupe connexions, cliquez sur Propriétés.

    Image Ruban Excel

  2. Sous Format et disposition des données, effectuez une ou plusieurs opérations parmi les suivantes :

    • Pour spécifier des noms de champs sur la première ligne, activez la case à cocher Inclure les noms de champ.

      Remarque : Cette case à cocher n’est disponible que pour une plage de données externes convertie à partir d’un programme Microsoft Office 2003 ou une plage de données externes créée par programme.

    • Pour ajouter une colonne de numéros de lignes, activez la case à cocher Inclure les numéros de lignes.

      Remarque : Cette case à cocher n’est pas disponible pour un fichier texte importé, un fichier XML ou une requête Web.

    • Pour conserver le formatage appliqué aux cellules, activez la case à cocher Conserver le format des cellules.

      Remarque : Dans le cas d’une requête Web, cette option est automatiquement désactivée lorsque vous sélectionnez Mise en forme HTML complète dans la boîte de dialogue Options. La boîte de dialogue Options est accessible via la boîte de dialogue Modifier la requête.

    • Pour conserver les largeurs de colonnes définies, activez la case à cocher Ajuster la largeur des colonnes.

    • Pour conserver les disposition, filtre et tri des colonnes, activez la case à cocher Conserver les disposition/filtre/tri des colonnes.

      Remarque : Cette case à cocher n’est pas disponible pour une requête Web.

    • Pour conserver le filtre des colonnes, activez la case à cocher Conserver le filtre des colonnes.

      Remarque : Cette case à cocher n’est disponible que pour une requête Web basée sur des données XML.

Haut de la page

Copier des formules lorsqu’une plage de données externes s’agrandit

Remarque : La procédure suivante s’applique uniquement à une plage de données externes convertie à partir d’un programme Microsoft Office 2003 ou à une plage de données externes créée par programme. Dans Office Excel 2007, toutes les plages de données externes créées via l’interface utilisateur le sont sous la forme de tableaux Excel. Ces tableaux s’agrandissent automatiquement lorsque de nouvelles lignes sont ajoutées et remplissent des colonnes calculées.

  1. Entrez une formule dans une cellule adjacente à la première ligne de données de la plage de données externes.

    Remarque : La première ligne de données peut être la première ou la seconde ligne de la plage de données externes si la première ligne contient des en-têtes.

  2. Sélectionnez la cellule et double-cliquez sur la poignée de recopie pour copier la formule dans toutes les lignes de la plage de données externes.

  3. Cliquez sur une cellule de la plage de données externes.

  4. Sous l’onglet données, dans le groupe connexions, cliquez sur Propriétés.

    Image Ruban Excel

  5. Dans la boîte de dialogue Propriétés de la plage de données externes, activez la case à cocher Recopier les formules dans les colonnes voisines.

    Remarque : Si la plage de données externes s’agrandit lors d’une actualisation, Excel ne copie que les formules adjacentes à la plage de données externes ou qui en font partie.

Haut de la page

Geler les données d’une plage de données externes

Le gel d’une plage de données externes permet de conserver les données, mais pas la requête sous-jacente correspondante. Ainsi, une plage de données externes gelée ne peut pas être actualisée.

Geler les données d’un tableau Excel

  1. Cliquez sur la feuille de calcul qui contient le tableau Excel duquel vous souhaitez supprimer la connexion de données.

  2. Dans la barre de formule, cliquez sur la flèche en regard de la Zone Nom, puis cliquez sur le nom de la plage de données externes à partir de laquelle vous souhaitez supprimer la connexion de données. La plage de données est sélectionnée.

  3. Sous l’onglet Outils, dans le groupe Données externes de la Table, cliquez sur Dissocier. La plage de données est conservé et toujours porte le même nom, mais la connexion est supprimée.

Geler les données d’une plage

Remarque : La procédure suivante s’applique uniquement à une plage de données externes convertie à partir d’un programme Microsoft Office 2003 ou à une plage de données externes créée par programme. Dans Office Excel 2007, toutes les plages de données externes créées via l’interface utilisateur le sont sous la forme de tableaux Excel. Ces tableaux s’agrandissent automatiquement lorsque de nouvelles lignes sont ajoutées et remplissent des colonnes calculées.

  1. Sous l’onglet données, dans le groupe connexions, cliquez sur Propriétés.

    Image Ruban Excel

  2. Sous Définition de la requête, désactivez la case à cocher Enregistrer la définition de la requête.

Remarque : Lorsque vous enregistrez votre classeur, la requête sous-jacente est supprimée du classeur. Toutefois, les fichiers de requêtes de bases de données enregistrés (fichiers .dqy ou .odc) ne sont pas supprimés. Si vous avez enregistré la requête lors de sa création dans l’Assistant Requête ou Microsoft Query, le fichier de requête est enregistré sur votre ordinateur et vous pouvez réutiliser la requête pour récupérer des données externes. Pour plus d’informations, voir l’aide de Microsoft Query.

Haut de la page

Personnaliser les noms des champs d’une plage de données externes

Remarque : La procédure suivante ne s’applique qu’à une plage de données externes créée via l’Assistant Connexion de données ou Microsoft Query (et non à un fichier texte importé ou à une requête Web), une plage de données externes convertie à partir d’un programme Microsoft Office 2003 ou une plage de données externes créée par programme. Dans Office Excel 2007, toutes les plages de données externes créées via l’interface utilisateur le sont sous la forme de tableaux Excel.

  1. Insérez une ligne vide au-dessus de la plage de données externes.

    Insertion d’une ligne vide

    1. Effectuez l’une des opérations suivantes :

      • Insérer de nouvelles cellules vides    Sélectionnez une plage de cellules où vous souhaitez insérer les nouvelles cellules vides. Vous devez sélectionner un nombre de cellules identique à celui des cellules à insérer.

      • Insérer une seule ligne    Cliquez sur une cellule de la ligne se trouvant immédiatement sous la nouvelle ligne que vous souhaitez insérer. Par exemple, pour insérer une nouvelle ligne au-dessus de la ligne 5, cliquez sur une cellule de la ligne 5.

      • Insérer plusieurs lignes    Sélectionnez les lignes se trouvant immédiatement sous les nouvelles lignes que vous souhaitez insérer. Vous devez sélectionner un nombre de lignes identique à celui des lignes à insérer.

      • Insérer une seule colonne    Cliquez sur une cellule de la colonne se trouvant immédiatement à droite de la nouvelle colonne que vous souhaitez insérer. Par exemple, pour insérer une colonne à gauche de la colonne B, cliquez sur une cellule de la colonne B.

      • Insérer plusieurs colonnes    Sélectionnez les colonnes se trouvant immédiatement à droite de celles que vous souhaitez insérer. Vous devez sélectionner un nombre de colonne identique à celui des colonnes à insérer.

    2. Dans l’onglet Accueil, groupe Cellules, cliquez sur la flèche en regard de l’option Insérer, puis sur une des options suivantes : Insérer des cellules, Insérer des lignes dans la feuille ou Insérer des colonnes dans la feuille.

      Si vous insérez des cellules vides, cliquez sur Décaler les cellules vers la droite ou Décaler les cellules vers le bas pour définir l’endroit vers lequel transférer les cellules existantes.

      Le bouton Reproduire la mise en forme image du bouton du groupe Presse-papiers de l’onglet Accueil vous permet de choisir comment définir le format des cellules, lignes ou colonnes insérées.

  2. Tapez les étiquettes de votre choix dans les cellules de la ligne vide.

  3. Cliquez sur une cellule de la plage de données externes.

  4. Sous l’onglet données, dans le groupe connexions, cliquez sur Propriétés.

    Image Ruban Excel

  5. Dans la boîte de dialogue Propriétés de la plage de données externes, sous Format et disposition des données, désactivez la case à cocher Inclure les noms de champ, puis cliquez sur OK.

  6. Pour supprimer les noms de champs existants et actualiser la plage de données externes, cliquez sur une cellule de la plage de données externes, puis sur Actualiser les données Image du bouton .

Remarque : Lorsque vous récupérez des données à partir d’une base de données, les modifications apportées aux noms de colonnes dans Microsoft Query sont conservées dans la plage de données externes. Pour plus d’informations sur la modification des noms de colonnes dans la requête, voir l’aide de Microsoft Query.

Haut de la page

Supprimer une plage de données externes

  1. Cliquez sur la feuille de calcul qui contient la plage de données externes à supprimer.

  2. Dans la barre de formule, cliquez sur la flèche en regard de l’option Zone Nom, puis sur le nom de la plage de données externes à supprimer.

    Si la plage de données externes est un tableau Excel, appuyez sur Ctrl+A pour sélectionner le tableau entier.

  3. Pour supprimer la plage de données externes, appuyez sur Suppr.

  4. Pour supprimer la requête sous-jacente, cliquez sur Oui lorsqu’Excel vous y invite.

Haut de la page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×