Fonction SOMMEPROD

Cet article décrit la syntaxe de formule et l’utilisation de la fonction SOMMEPROD dans Microsoft Excel.

Description

Multiplie les valeurs correspondantes des matrices spécifiées et calcule la somme de ces produits.

Syntaxe

SOMMEPROD(matrice1, [matrice2], [matrice3], ...)

La syntaxe de la fonction SOMMEPROD contient les arguments suivants :

  • matrice1     Obligatoire. Représente le premier argument de matrice dont vous voulez multiplier les valeurs pour ensuite additionner leur produit.

  • matrice2; matrice3;...     Facultatif. Arguments de matrices 2 à 255 dont vous voulez multiplier les valeurs pour ensuite additionner leur produit.

Remarques

  • Les matrices spécifiées comme arguments doivent avoir la même dimension. Si tel n’est pas le cas, SOMMEPROD renvoie la valeur d’erreur #VALEUR!.

  • SOMMEPROD affecte aux entrées de matrice non numériques la valeur zéro.

Exemple

Copiez les données d’exemple dans le tableau suivant, et collez-le dans la cellule A1 d’un nouveau classeur Excel. Pour que les formules affichent des résultats, sélectionnez-les, appuyez sur F2, et sur Entrée. Si nécessaire, vous pouvez modifier la largeur des colonnes pour afficher toutes les données.

Matrice 1

Matrice 2

3

4

2

7

8

6

6

7

1

9

5

3

Formule

Description

Résultat

=SOMMEPROD(A2:B4;D2:E4)

Multiplie toutes les valeurs des deux matrices, puis additionne les produits ; c’est-à-dire : 3*2 + 4*7 + 8*6 + 6*7 + 1*5 + 9*3 (156)

156

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×