Fonction SOMME.SI

Cet article décrit la syntaxe de la formule et l’utilisation de la fonction SOMME.SI dans Microsoft Excel.

Description

La fonction SOMME.SI permet de calculer la somme des valeurs d’une plage qui répond au critère spécifié. Par exemple, supposons que dans une colonne contenant des nombres, vous vouliez uniquement calculer la somme des valeurs supérieures à 5. Vous pouvez utiliser la formule suivante :

= SOMME.SI(B2:B25;">5")

Dans cet exemple, le critère est appliqué aux valeurs calculées. Si vous le souhaitez, vous pouvez appliquer le critère à une plage et calculer les valeurs dans une autre plage. Par exemple, la formule =SOMME.SI(B2:B5;"Jean";C2:C5) calcule uniquement la somme des valeurs de la plage C2:C5, dans laquelle les cellules correspondantes de la plage B2:B5 contiennent le mot « Jean ».

Remarque   Pour calculer la somme de cellules en fonction de plusieurs critères, voir Fonction SOMME.SI.ENS.

Syntaxe

SOMME.SI(plage;critère;[somme_plage])

La syntaxe de la fonction SOMME.SI contient les arguments suivants :

  • plage   Obligatoire. Plage de cellules à calculer en fonction du critère. Les cellules de chaque plage doivent être des nombres ou des noms, des matrices ou des références contenant des nombres. Les valeurs vides ou textuelles ne sont pas prises en compte.

  • critère   Obligatoire. Critère, exprimé sous forme de nombre, d’expression, de référence de cellule, de texte ou de fonction qui définit les cellules à ajouter. Par exemple, l’argument critère peut être exprimé sous l’une des formes suivantes : 32, ">32", B5, "32", "pommes" ou AUJOURDHUI().

      Tous les critères textuels et tous les critères qui contiennent des symboles mathématiques ou logiques doivent être placés entre guillemets ("). En revanche, les guillemets ne sont pas nécessaires pour les critères numériques.

  • plage_somme   Facultatif. Cellules réelles à ajouter, si vous voulez ajouter d’autres cellules que celles qui sont spécifiées dans l’argument plage. Si l’argument plage_somme est omis, Excel ajoute les cellules spécifiées dans l’argument plage (les cellules auxquelles s’applique le critère).

  • Vous pouvez utiliser les caractères génériques (point d’interrogation (?) et astérisque (*)) dans l’argument critère. Le point d’interrogation correspond à un caractère quelconque et l’astérisque correspond à une séquence de caractères quelconque. Pour rechercher réellement un point d’interrogation ou un astérisque, tapez un tilde (~) devant ce caractère.

Remarques

  • La fonction SOMME.SI renvoie des résultats incorrects lorsque vous l’utilisez pour mettre en correspondance des chaînes comportant plus de 255 caractères ou avec la chaîne #VALEUR!.

  • L’argument plage_somme ne doit pas nécessairement avoir la même taille et la même forme que l’argument plage. Les cellules effectivement additionnées sont déterminées en utilisant la cellule supérieure gauche de l’argument plage_somme comme cellule de début, puis en incluant les cellules dont la taille et la forme correspondent à l’argument plage. Par exemple :

Si la plage est

Si somme_plage est

Les cellules sont

A1:A5

B1:B5

B1:B5

A1:A5

B1:B3

B1:B5

A1:B4

C1:D4

C1:D4

A1:B4

C1:C2

C1:D4

Toutefois, lorsque les arguments plage et plage_somme dans la fonction SOMME.SI ne comportent pas le même nombre de cellules, le recalcul de la feuille de calcul peut prendre plus de temps que prévu.

Exemples

Exemple 1

Copiez les données d’exemple dans le tableau suivant, et collez-le dans la cellule A1 d’un nouveau classeur Excel. Pour que les formules affichent des résultats, sélectionnez-les, appuyez sur F2, et sur Entrée. Si nécessaire, vous pouvez modifier la largeur des colonnes pour afficher toutes les données.

Valeur de propriété

Commission

Données

100 000,00 €

7 000,00 €

250 000,00 €

200 000,00 €

14 000,00 €

300 000,00 €

21 000,00 €

400 000,00 €

28 000,00 €

Formule

Description

Résultat

=SOMME.SI(A2:A5;">160000";B2:B5)

Somme des valeurs de commissions excédant 160 000

63 000,00 €

=SOMME.SI(A2:A5;">160000")

Somme des valeurs de propriétés excédant 160 000

900 000,00 €

=SOMME.SI(A2:A5;300000;B2:B5)

Somme des commissions relatives aux valeurs de propriétés égales à 300 000

21 000,00 €

=SOMME.SI(A2:A5;">" & C2;B2:B5)

Somme des commissions relatives aux valeurs de propriétés supérieures à la valeur de C2.

49 000,00 €

Exemple 2

Copiez les données d’exemple dans le tableau suivant, et collez-le dans la cellule A1 d’un nouveau classeur Excel. Pour que les formules affichent des résultats, sélectionnez-les, appuyez sur F2, et sur Entrée. Si nécessaire, vous pouvez modifier la largeur des colonnes pour afficher toutes les données.

Catégorie

Nourriture

Ventes

Légumes

Tomates

2 300,00 €

Légumes

Céleri

5 500,00 €

Fruits

Oranges

800,00 €

Beurre

400,00 €

Légumes

Carottes

4 200,00 €

Fruits

Pommes

1 200,00 €

Formule

Description

Résultat

=SOMME.SI(A2:A7;"Fruits";C2:C7)

Somme de la vente de tous les produits alimentaires dans la catégorie « Fruits ».

2 000,00 €

=SOMME.SI(A2:A7;"Légumes";C2:C7)

Somme de la vente de tous les produits alimentaires dans la catégorie « Légumes ».

12 000,00 €

=SOMME.SI(B2:B7;"*es";C2:C7)

Somme de la vente de tous les produits alimentaires se terminant par « es » (Tomates, Oranges et Pommes).

4 300,00 €

=SOMMES.SI(A2:A7;"";C2:C7)

Somme de la vente de tous les produits alimentaires n’appartenant pas à une catégorie spécifique.

400,00 €

Haut de la page

S’applique à : Excel 2007, Excel 2010, Excel Online, Excel 2013, Excel Starter, Excel 2016 for Mac



Ces informations vous ont-elles été utiles ?

Oui Non

Comment pouvons-nous nous améliorer ?

255 caractères restants

Afin de protéger votre vie privée, n’indiquez aucune information de contact dans vos commentaires. Lisez notre déclaration de confidentialité.

Nous vous remercions pour vos commentaires.

Ressources de support

Changer la langue