Fonction SI

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

La fonction si est une des fonctions les plus populaires dans Excel, et il vous autorise à apporter des comparaisons logiques entre une valeur et ce que vous attendiez. Dans sa forme la plus simple, la fonction si indique :

  • SI(un élément est vrai, action à effectuer, sinon autre action)

Pour une instruction IF peut avoir deux résultats. Le premier résultat est si votre comparaison est vraie, la seconde si votre comparaison est faux.

Si vous voulez passer directement à l’utilisation de plusieurs instructions IF, voir : fonctions si avancées - utilisation de formules imbriquées et évitant pièges.

Utilisez la fonction SI, une des fonctions logiques, pour renvoyer une valeur si une condition est vraie et une autre valeur si elle est fausse.

Syntaxe

SI(test_logique; valeur_si_vrai; [valeur_si_faux])

Par exemple :

  • =SI(A2>B2;"Dépasse le budget";"OK")

  • =SI(A2=B2;B4-A4;"")

Argument

Description

test_logique    (obligatoire)

Condition que vous souhaitez tester.

valeur_si_vrai    (obligatoire)

Valeur que vous voulez renvoyer si le résultat de test_logique est VRAI.

valeur_si_faux    (facultatif)

Valeur que vous voulez renvoyer si le résultat de test_logique est FAUX.

Exemples simples d’utilisation de la fonction SI

La cellule D2 contient la formule =SI(C2="Oui";1;2)
  • =SI(C2=”Oui”;1;2)

Dans l’exemple ci-dessus, la cellule D2 indique : SI(C2 = Oui, renvoyer la valeur 1, sinon renvoyer la valeur 2)

La cellule D2 contient la formule =SI(C2=1;"OUI";"NON")
  • =SI(C2=1;”Oui”;”Non”)

Dans cet exemple, la formule dans la cellule D2 indique : SI(C2 = 1, renvoyer Oui, sinon renvoyer Non)

Comme vous le voir, la fonction si peut servir à évaluer les valeurs et le texte à la fois. Il peut également être utilisé pour évaluer les erreurs. Vous n’êtes pas limités à uniquement vérifier si une chose est égale à un autre et renvoyer un seul résultat, vous pouvez également utiliser les opérateurs mathématiques et effectuer des calculs supplémentaires en fonction de vos critères. Vous pouvez également imbriquer des fonctions si plusieurs ensemble afin d’effectuer des comparaisons de plusieurs.

Remarque : Si vous souhaitez utiliser du texte dans les formules, vous devez ajuster le texte entre guillemets (par exemple, « texte »). La seule exception qui utilise vrai ou faux, qui comprend automatiquement les Excel.

Prise en main

La meilleure façon de commencer à écrire une instruction si est de réfléchir à ce que vous voulez faire. Quels comparaison que vous essayez d’effectuer ? De nombreux cas, écrire une instruction IF peut être aussi simple que penser à travers le code dans votre en-tête : « conséquences si cette condition est remplie et conséquences si elle n’est pas ? » Vous souhaiterez toujours pour vous assurer que vos étapes de suivent une progression logique, sinon votre formule ne convient pas ce que vous pensez qu'il convient. Ceci est particulièrement important lorsque vous créez des instructions IF (imbriquées) complexes.

Autres exemples d’utilisation de la fonction SI

La formule dans la cellule D2 est =SI(C2>B2;”Dépasse le budget”;”Cadre dans le budget”)
  • =SI(C2>B2;”Dépasse le budget”;”Cadre dans le budget”)

Dans l’exemple ci-dessus, la fonction SI dans la cellule D2 indique SI(C2 est supérieur à B2, renvoyer « Dépasse le budget », sinon renvoyer « Cadre dans le budget »)

La formule dans la cellule E2 est =SI(C2>B2;C2-B2;"")
  • =SI(C2>B2;C2-B2;0)

Dans l’illustration ci-dessus, au lieu de retourner un résultat de texte, nous allons renvoyer un calcul mathématique. Pour que la formule dans E2 dit Si (réel est supérieure à budgétés, puis soustraire le montant budgété du montant réel, sinon renvoie rien).

La formule dans la cellule F7 est SI(E7=”Oui”;F5*0,0825;0)
  • =SI(E7=”Oui”;F5*0,0825;0)

Dans cet exemple, la formule dans la cellule F7 indique SI(E7=“Oui”, calculer le montant total dans F5*8,25 %, sinon renvoyer 0 car aucune taxe n’est due)

Pratiques recommandées - Variables

Dans l’exemple précédent, vous voyez à la fois « Oui » et le taux de taxe (0.0825) entré directement dans la formule. Il n’est généralement pas une bonne pratique pour placer des constantes littérales (valeurs que vous devrez peut-être modifier de temps à autre) directement dans les formules, car elles peuvent être difficiles à rechercher et modifier ultérieurement. Il est préférable de placer les constantes dans leurs propre des cellules, où ils sont arrière dans la boîte de dialogue et facilement trouvent et modifié. Dans ce cas, il est OK, car il est uniquement une fonction si et le taux de taxe changeront rarement. Même si c’est le cas, il sera facile à modifier dans la formule.

Opérateurs de calcul

Si vous voulez en savoir plus sur les opérateurs de calcul différents que vous pouvez utiliser dans les formules, (< inférieur à, est égal à égal => , <> pas égal à, etc.), voir cet article : opérateurs de calcul et priorité.

Utilisation de la fonction SI pour vérifier si une cellule est vide

Vous devez parfois vérifier si une cellule est vide, généralement pour éviter qu’une formule n’affiche un résultat sans saisie préalable.

La formule dans la cellule E2 est =SI(D2=1;"Oui";SI(D2=2;"Non";"Peut-être"))

En pareil cas, vous pouvez utiliser la fonction SI avec la fonction ESTVIDE :

  • =SI(ESTVIDE(D2);"Vide";"Non vide")

Qui dit IF(D2 is blank, then return "Blank", otherwise return "Not Blank"). Vous pouvez tout aussi bien utiliser votre propre formule pour la condition de « Non vide ». Dans l’exemple suivant, nous utilisons » » au lieu d’ESTVIDE. Le « » signifie principalement « rien ».

Vérifier si une cellule est vide - La formule dans la cellule E2 est =SI(ESTVIDE(D2),"Vide","Non vide")
  • =SI(D3="";"Vide";"Non vide")

Cette formule indique Si (D3 rien, puis revenez « Vide », dans le cas contraire « non vide »). Voici un exemple d’une méthode très courante de l’utilisation de « » pour empêcher une formule de calcul si une cellule dépendante est vide :

  • =SI(D3="";"";VotreFormule())

    SI(D3 ne contient aucun élément, ne rien renvoyer, sinon calculer la formule).

Exemple de fonction SI imbriquée

Là où une simple fonction SI présente deux résultats uniquement (True ou False), les fonctions SI imbriquées peuvent comporter de 3 à 64 résultats.

Utiliser des guillemets ("") pour rechercher les cellules vides - La formule dans la cellule E3 est=SI(D3="";"Vide";"Non vide")
  • =SI(D2=1;”Oui”;SI(D2=2;”Non”;”Peut-être”))

Dans l’illustration ci-dessus, la formule dans la cellule E2 a la signification suivante : SI(D2 est égal à 1, renvoyer « Oui », sinon SI(D2 est égal à 2, renvoyer « Non », sinon renvoyer « Peut-être »)). Notez la présence de deux parenthèses fermantes à la fin de la formule. Elles sont requises pour fermer les deux fonctions SI. Si vous essayez de valider la formule sans ces deux parenthèses, Excel tente de la corriger à votre place.

Recommandation

Tandis que Excel vous permettra d’imbriquer jusqu'à 64 fonctions si différentes, il n’est pas du tout recommandé pour le faire. Pourquoi ?

  • Plusieurs instructions IF requièrent un grand nombre de réflexion pour générer les correctement et assurez-vous que leur logique calcule correctement à chaque condition jusqu'à la fin. Si vous ne pas imbriquer vos instructions IF 100 % avec précision, puis une formule peut fonctionnent avec 75 % de l’heure, mais retourner des résultats inattendus 25 % du temps. Malheureusement, les chances de vous interception les 25 % est compacte.

  • Il peut être difficile de gérer plusieurs instructions SI, en particulier lorsqu’en y revenant plus tard, vous essayez de déterminer ce que vous, ou une autre personne, avez essayé de faire exactement.

  • Plusieurs expressions SI nécessitent la présence de plusieurs parenthèses ouvrantes et fermantes (), ce qui peut être difficile à gérer si votre formule devient complexe.

Problèmes courants

Problème

Cause

O (zéro) dans la cellule

Il n’y a pas de valeur pour l’argument valeur_si_vrai ou valeur_si_faux. Pour afficher la valeur correcte renvoyée, ajoutez le texte de l’argument aux deux arguments, ou ajoutez VRAI ou FAUX à l’argument.

#NOM? dans la cellule

En règle générale, cela signifie que la formule est mal orthographiée.

Vous avez une question sur une fonction en particulier ?

Posez une question sur le forum de la communauté Excel

Contribuer à l’amélioration d’Excel

Avez-vous des suggestions sur la manière dont nous pouvons améliorer la prochaine version d’Excel ? Si c’est le cas, consultez les rubriques du forum User Voice sur Excel

Voir aussi

Vidéo : Fonctions si avancées

Fonction IFS (Office 365, Excel 2016 et versions ultérieur)

Fonctions si avancées - utilisation de formules imbriquées et évitant pièges

Vidéos de formation : fonctions si avancées

La fonction NB.Si comptera des valeurs basées sur un critère unique

La fonction NB.Si.ens compter des valeurs en fonction de plusieurs critères

La fonction somme.Si additionner des valeurs basées sur un critère unique

La fonction somme.Si.ens additionner les valeurs en fonction de plusieurs critères

ET

Fonction OR

RECHERCHEV

Vue d’ensemble des formules dans Excel

Comment éviter les formules incorrectes

Utiliser la vérification des erreurs pour détecter les erreurs dans les formules

Fonctions logiques

Fonctions Excel (par ordre alphabétique)

Fonctions Excel (par catégorie)

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×