Fonction SI

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

La fonction SI est l’une des plus populaires dans Excel. Elle permet d’établir des comparaisons logiques entre une valeur et le résultat attendu. Dans sa forme la plus simple, la fonction SI a la signification suivante :

  • SI(un élément est vrai, action à effectuer, sinon autre action)

Une instruction SI peut donc avoir deux résultats. Le premier résultat est appliqué si la comparaison est vérifiée, sinon le deuxième résultat est appliqué.

Si vous voulez passer directement à l’utilisation de plusieurs instructions SI, voir : Fonctions SI avancées - Utiliser des formules imbriquées et éviter les pièges

Utilisez la fonction SI, une des fonctions logiques, pour renvoyer une valeur si une condition est vraie et une autre valeur si elle est fausse.

Syntaxe

SI(test_logique; valeur_si_vrai; [valeur_si_faux])

Par exemple :

  • =SI(A2>B2;"Dépasse le budget";"OK")

  • =SI(A2=B2;B4-A4;"")

Argument

Description

test_logique    (obligatoire)

Condition que vous souhaitez tester.

valeur_si_vrai    (obligatoire)

Valeur que vous voulez renvoyer si le résultat de test_logique est VRAI.

valeur_si_faux    (facultatif)

Valeur que vous voulez renvoyer si le résultat de test_logique est FAUX.

Exemples simples d’utilisation de la fonction SI

La cellule D2 contient la formule =SI(C2="Oui";1;2)
  • =SI(C2=”Oui”;1;2)

Dans l’exemple ci-dessus, la cellule D2 indique : SI(C2 = Oui, renvoyer la valeur 1, sinon renvoyer la valeur 2)

La cellule D2 contient la formule =SI(C2=1;"OUI";"NON")
  • =SI(C2=1;”Oui”;”Non”)

Dans cet exemple, la formule dans la cellule D2 indique : SI(C2 = 1, renvoyer Oui, sinon renvoyer Non)

Comme vous pouvez le voir, la fonction SI permet d’évaluer du texte et des valeurs. Elle permet également d’évaluer des erreurs. La fonction SI ne se limite pas à la vérification d’une égalité entre deux éléments et au renvoi d’un résultat simple : vous pouvez également utiliser des opérateurs mathématiques et effectuer d’autres calculs en fonction de vos critères. Vous pouvez également imbriquer plusieurs fonctions SI afin d’effectuer plusieurs comparaisons.

Remarque : Si vous comptez utiliser du texte dans des formules, vous devez l’entourer de guillemets (par exemple, “Texte”). La seule exception est l’utilisation des valeurs VRAI ou FAUX qui sont comprises automatiquement par Excel.

Prise en main

Pour commencer à écrire une instruction SI, vous devez penser au résultat que vous cherchez à obtenir. Quelle comparaison essayez-vous d’établir ? Pour écrire une instruction SI, il suffit souvent d’utiliser la logique suivante : « Que doit-il se passer si cette condition est remplie et si elle ne l’est pas ? ». Vous devez toujours vérifier que vos étapes suivent une progression logique, sans quoi votre formule ne vous permettra pas d’atteindre le résultat escompté. Ceci est particulièrement important lorsque vous créez des instructions SI complexes (imbriquées).

Autres exemples d’utilisation de la fonction SI

La formule dans la cellule D2 est =SI(C2>B2;”Dépasse le budget”;”Cadre dans le budget”)
  • =SI(C2>B2;”Dépasse le budget”;”Cadre dans le budget”)

Dans l’exemple ci-dessus, la fonction SI dans la cellule D2 indique SI(C2 est supérieur à B2, renvoyer « Dépasse le budget », sinon renvoyer « Cadre dans le budget »)

La formule dans la cellule E2 est =SI(C2>B2;C2-B2;"")
  • =SI(C2>B2;C2-B2;0)

Dans l’illustration ci-dessus, au lieu de renvoyer un texte de résultat, nous allons renvoyer un calcul mathématique. La formule dans la cellule E2 a la signification suivante : SI(la valeur Réel est supérieure à la valeur Budget, soustraire le montant de Budget du montant Réel, sinon ne rien renvoyer).

La formule dans la cellule F7 est SI(E7=”Oui”;F5*0,0825;0)
  • =SI(E7=”Oui”;F5*0,0825;0)

Dans cet exemple, la formule dans la cellule F7 indique SI(E7=“Oui”, calculer le montant total dans F5*8,25 %, sinon renvoyer 0 car aucune taxe n’est due)

Pratiques recommandées - Variables

Dans le dernier exemple, la valeur « Oui » et la taxe sur les ventes (0,0825) sont entrées directement dans la formule. En général, il n’est pas recommandé d’entrer des constantes littérales (valeurs pouvant changer de temps à autre) directement dans les formules, car il peut être difficile de les trouver et de les modifier ultérieurement. Il est préférable de placer vos constantes dans leurs propres cellules, où elles sont visibles et peuvent être facilement trouvées et modifiées. Dans ce cas, cela convient, car il n’y a qu’une fonction SI et que la taxe sur les ventes change rarement. Même si cela devait arriver, il serait facile de la modifier dans la formule.

Opérateurs de calcul

Si vous voulez en savoir plus sur les opérateurs de calcul différents que vous pouvez utiliser dans les formules, (< inférieur à, est égal à égal => , <> pas égal à, etc.), voir cet article : calcul opérateurs et priorité.

Utilisation de la fonction SI pour vérifier si une cellule est vide

Vous devez parfois vérifier si une cellule est vide, généralement pour éviter qu’une formule n’affiche un résultat sans saisie préalable.

La formule dans la cellule E2 est =SI(D2=1;"Oui";SI(D2=2;"Non";"Peut-être"))

Dans ce cas, nous utilisons si avec la fonction ESTVIDE :

  • =SI(ESTVIDE(D2);"Vide";"Non vide")

La formule a la signification suivante : SI(D2 est vide, renvoyer « Vide », sinon renvoyer « Non vide »). Vous pouvez aussi utiliser votre propre formule pour la condition « Non vide ». Dans l’exemple suivant, nous utilisons des guillemets ("") au lieu de la fonction ESTVIDE. Ceux-ci signifient qu’il n’y a « rien ».

Vérifier si une cellule est vide - La formule dans la cellule E2 est =SI(ESTVIDE(D2),"Vide","Non vide")
  • =SI(D3="";"Vide";"Non vide")

Cette formule a la signification suivante : SI(D3 ne contient aucun élément, renvoyer « Vide », sinon renvoyer « Non vide »). Voici un exemple d’une méthode courante d’utilisation des guillemets ("") pour empêcher le calcul d’une formule si une cellule dépendante est vide :

  • =SI(D3="";"";VotreFormule())

    SI(D3 ne contient aucun élément, ne rien renvoyer, sinon calculer la formule).

Exemple de fonction SI imbriquée

Là où une simple fonction SI présente deux résultats uniquement (True ou False), les fonctions SI imbriquées peuvent comporter de 3 à 64 résultats.

Utiliser des guillemets ("") pour rechercher les cellules vides - La formule dans la cellule E3 est=SI(D3="";"Vide";"Non vide")
  • =SI(D2=1;”Oui”;SI(D2=2;”Non”;”Peut-être”))

Dans l’illustration ci-dessus, indique la formule dans E2 : IF (D2 est égale à 1 puis retour « Oui », dans le cas contraire si (D2 est égal à 2 puis retour « non », dans le cas contraire retourne « Peut-être »)). Notez qu’il existe deux parenthèses fermantes à la fin de la formule. Ce sont nécessaires pour effectuer les deux conditions les fonctions si et si vous essayez d’entrer la formule sans les deux conditions les parenthèses fermantes, Excel essaie de corriger pour vous.

Recommandation

Si Excel autorise l’imbrication d’un maximum de 64 fonctions SI différentes, il n’est pas conseillé de le faire. Pourquoi ?

  • L’utilisation de plusieurs instructions SI nécessite beaucoup de réflexion car il faut créer celles-ci correctement et vérifier que leur logique peut être calculée correctement condition après condition. Si vous n’imbriquez pas vos instructions SI avec précision, il est possible qu’une formule fonctionne 75 % du temps, mais renvoie des résultats inattendus 25 % du temps. Malheureusement, les chances d’identifier ces 25 % sont minces.

  • Il peut être difficile de gérer plusieurs instructions SI, en particulier lorsqu’en y revenant plus tard, vous essayez de déterminer ce que vous, ou une autre personne, avez essayé de faire exactement.

  • Plusieurs instructions IF requièrent plusieurs parenthèses ouvrantes et fermantes (), qui peut être difficile à gérer en fonction de la complexité de votre formule devient.

Problèmes courants

Problème

Cause

O (zéro) dans la cellule

Il n’y a pas de valeur pour l’argument valeur_si_vrai ou valeur_si_faux. Pour afficher la valeur correcte renvoyée, ajoutez le texte de l’argument aux deux arguments, ou ajoutez VRAI ou FAUX à l’argument.

#NOM? dans la cellule

En règle générale, cela signifie que la formule est mal orthographiée.

Vous avez une question sur une fonction en particulier ?

Publier une question sur le forum de la Communauté Excel

Contribuer à l’amélioration d’Excel

Avez-vous des suggestions sur la manière dont nous pouvons améliorer la prochaine version d’Excel ? Si c’est le cas, consultez les rubriques du forum User Voice sur Excel.

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Voir aussi

Regarder une vidéo sur l’utilisation de la fonction SI

Fonction SI.CONDITIONS (Office 365, Excel 2016 et version ultérieure)

Fonctions SI avancées - Utiliser des formules imbriquées et éviter les pièges

Vidéos de formation : fonctions SI avancées

La fonction NB.SI compte les valeurs sur la base d’un seul critère

La fonction NB.SI.ENS compte les valeurs sur la base de plusieurs critères

La fonction SOMME.SI additionne des valeurs sur la base d’un seul critère

La fonction SOMME.SI.ENS additionne des valeurs sur la base de plusieurs critères

Fonction ET

Fonction OU

Fonction RECHERCHEV

Vue d’ensemble des formules dans Excel

Comment éviter les formules incorrectes

Détecter les erreurs dans les formules à l’aide de la vérification des erreurs

Fonctions logiques

Fonctions Excel (par ordre alphabétique)

Fonctions Excel (par catégorie)

Partager Facebook Facebook Twitter Twitter E-mail E-mail

Ces informations vous ont-elles été utiles ?

Très bien ! Vous avez d’autres commentaires ?

Comment pouvons-nous l’améliorer ?

Nous vous remercions pour vos commentaires.

×