Fonction OU

Pour déterminer si des conditions d’un test sont vraies, utilisez la fonction OU, l’une des fonctions logiques.

Exemple

Exemples d’utilisation de la fonction OU.

La fonction OU renvoie VRAI si l’un de ses arguments a pour résultat VRAI, et renvoie FAUX si l’un de ses arguments a pour résultat FAUX.

La fonction OU est couramment utilisée pour développer l’utilité d’autres fonctions qui effectuent des tests logiques. Par exemple, la fonction SI effectue un test logique, puis renvoie une valeur si le résultat du test est VRAI, et une autre valeur si le résultat du test est FAUX. En utilisant la fonction OU en tant qu’argument test_logique de la fonction SI, vous pouvez tester un grand nombre de conditions différentes.

Syntaxe

OU(logique1;[logique2];...)

La syntaxe de la fonction OU utilise les arguments suivants :

Argument

Description

Logique1

Obligatoire. Première condition que vous souhaitez tester, pouvant avoir pour résultat la valeur VRAI ou FAUX.

Logique2, ...

Facultatif. Conditions supplémentaires que vous souhaitez tester, pouvant avoir pour résultat la valeur VRAI ou FAUX. Vous pouvez tester jusqu’à 255 conditions.

Remarques

  • Les arguments doivent correspondre à des valeurs logiques, telles que VRAI ou FAUX, ou être des matrices ou des références qui contiennent des valeurs logiques.

  • Si une matrice ou une référence tapée comme argument contient du texte ou des cellules vides, ces valeurs ne sont pas prises en compte.

  • Si la plage spécifiée ne contient aucune valeur logique, la fonction OU renvoie la valeur d’erreur #VALEUR!.

  • Vous pouvez utiliser une formule de tableau OU pour voir si une valeur apparaît dans une matrice. Pour entrer une formule de tableau, appuyez sur CTRL+MAJ+ENTRÉE.

Exemples

Voici quelques exemples généraux d’utilisation de la fonction OU isolément ou conjointement avec la fonction SI.

Exemples d’utilisation de la fonction OU avec la fonction SI.


Formule

Description

=OU(A2>1;A2<100)

Affiche VRAI si la valeur de la cellule A2 est supérieure à 1 OU inférieure à 100 ; sinon, affiche FAUX.

= SI(OU(A2>1;A2<100);A3;"la valeur est hors plage»)

Affiche la valeur de la cellule A3 si elle est supérieurs à 1 OU inférieure à 100 ; sinon affiche le message « Valeur hors limites ».

=SI(ET(0<A2;A2<50);A2;"Valeur hors limites")

Affiche la valeur de la cellule A2 si elle est inférieure à 0 OU supérieure à 50 ; sinon, affiche un message.

Calcul de commission de ventes

Voici un scénario assez courant dans le cadre duquel il s’agit de calculer si un représentant commercial a droit à une commission, en utilisant les fonctions SI et OU.

Exemple d’utilisation des fonctions SI et OU pour calculer une commission de ventes.
  • =SI(OU(B14>= $B$4;C14>=$B5$);B14*$B$6;0) - SI Total Sales est supérieur ou égal (>=) à Sales Goal, OU Accounts est supérieur ou égal à (>=) à Account Goal, multiplier Total Sales par le % Commission, sinon retourner 0.

Vous avez besoin d’une aide supplémentaire ?

Vous pouvez toujours consulter un expert de la communauté technique Excel, obtenir une assistance dans la communauté Answers ou suggérer une nouvelle fonctionnalité ou une amélioration sur le forum Excel User Voice.

Voir aussi

Regardez une vidéo sur l’utilisation de la fonction SI

Découvrez comment utiliser des fonctions imbriquées dans une formule

Fonction SI

Fonction ET

Fonction NON

Vue d’ensemble des formules dans Excel

Comment éviter les formules incorrectes

Corriger les erreurs courantes dans les formules à l’aide de la vérification des erreurs

Raccourcis clavier dans Excel 2016 pour Windows

Raccourcis clavier dans Excel 2016 pour Mac

Fonctions logiques (référence)

Fonctions Excel (par ordre alphabétique)

Fonctions Excel (par catégorie)

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×