Fonction ET

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Pour déterminer si toutes les conditions d’un test sont vraies, utilisez la fonction ET, l’une des fonctions logiques.

Exemple

Exemples d’utilisation de la fonction ET

La fonction ET renvoie la valeur VRAI si tous ses arguments produisent un résultat vrai, et la valeur FAUX si au moins l’un des arguments produit un résultat faux.

La fonction ET est couramment utilisée pour développer l’utilité d’autres fonctions qui effectuent des tests logiques. Par exemple, la fonction SI effectue un test logique, puis renvoie une valeur si le test a pour résultat la valeur VRAI et une autre valeur s’il a pour résultat la valeur FAUX. En utilisant la fonction ET en tant qu’argument test_logique de la fonction SI, vous pouvez tester un grand nombre de conditions différentes.

Syntaxe

ET(logique1;[logique2];...)

La syntaxe de la fonction ET utilise les arguments suivants :

Argument

Description

Logique1

Obligatoire. Première condition que vous souhaitez tester, pouvant avoir pour résultat la valeur VRAI ou FAUX.

Logique2...

Facultatif. Conditions supplémentaires que vous souhaitez tester, pouvant avoir pour résultat la valeur VRAI ou FAUX. Vous pouvez tester jusqu’à 255 conditions.

Remarques

  • Les arguments doivent avoir pour résultat des valeurs logiques telles que VRAI ou FAUX, ou être des tableaux ou des références contenant des valeurs logiques.

  • Si une matrice ou une référence tapée comme argument contient du texte ou des cellules vides, ces valeurs ne sont pas prises en compte.

  • Si la plage spécifiée ne contient aucune valeur logique, la fonction ET renvoie l’erreur #VALEUR!

Exemples

Voici quelques exemples généraux d’utilisation de la fonction ET isolément, et conjointement avec la fonction SI.

Exemples d’utilisation des fonctions SI avec ET

Formule

Description

=ET(A2>1;A2<100)

Affiche VRAI si la valeur de la cellule A2 est supérieure à 1 ET inférieure à 100 ; sinon, affiche FAUX.

=SI(ET(A2<A3;A2<100);A2;"Valeur hors limites")

Affiche la valeur de la cellule A2 si elle est inférieure à A3 ET inférieure à 100 ; sinon affiche le message « Valeur hors limites ».

=SI(ET(A3>1;A3<100);A3;"Valeur hors limites")

Affiche la valeur de la cellule A3 si elle est supérieure à 1 ET inférieure à 100 ; sinon affiche un message. Vous pouvez remplacer ce message par celui de votre choix.

Calcul du bonus

Voici un scénario assez courant dans le cadre duquel il s’agit de calculer si un représentant commercial a droit à une prime en utilisant les fonctions SI et ET.

Exemple de calcul de prime de ventes avec les fonctions SI et ET.  La formule dans la cellule E14 est =SI(ET(B14>=$B$7;C14>=$B$5);B14*$B$8,0)
  • =SI(ET(B14>=$B$7;C14>=$B$5);B14*$B$8;0)SI Total Sales est supérieur ou égal (>=) à Sales Goal, ET Accounts est supérieur ou égal à (>=) à Account Goal, multiplier Total Sales par le % Bonus, sinon retourner 0.

Vous avez besoin d’une aide supplémentaire ?

Vous pouvez toujours consulter un expert de la communauté technique Excel, obtenir une assistance dans la communauté Answers ou suggérer une nouvelle fonctionnalité ou une amélioration sur le forum Excel User Voice.

Rubriques connexes

Vidéo : Fonctions si avancées
apprendre à utiliser les fonctions imbriquées dans une formule
fonction si
fonction ou
non
vue d’ensemble des formules dans Excel
Comment éviter les formules incorrectes
erreurs pour détecter les erreurs dans les formules
raccourcis clavier dans Excel 2016 pour Windows
raccourcis clavier dans Excel 2016 pour Mac
Logique fonctions (référence)
fonctions Excel (par ordre alphabétique)
fonctions Excel (par catégorie)

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×