Exemples de formules courantes dans les listes SharePoint

Exemples de formules courantes dans les listes SharePoint

L’utilisation de formules dans des colonnes calculées d’une liste SharePoint ou d’une bibliothèque SharePoint peut vous aider à compléter des colonnes existantes, par exemple, par l’ajout d’un calcul de taxes sur un prix. Ces formules peuvent être combinées pour valider des données par programme.

Lors de l’entrée de formules, sauf indication contraire, il n’y pas d’espace entre les mots clés et les opérateurs. La liste suivante n’est pas exhaustive. Pour découvrir toutes les formules dans SharePoint, voir la liste alphabétique à la fin de cet article.

Remarque : Les champs calculés fonctionnant uniquement sur leur propre ligne, vous ne pouvez pas faire référence à une valeur figurant dans une autre ligne, ou dans des colonnes contenues dans une autre liste ou bibliothèque. Vous ne pouvez pas utiliser dans une formule des champs de recherche, ou l’ID d’une ligne nouvellement insérée, car l’ID n’existe pas lors du traitement de la formule.

Vous pouvez utiliser les formules suivantes pour tester la condition d’une instruction et renvoyer une valeur Oui ou Non, pour tester une valeur de remplacement telle que OK ou Pas OK, ou pour renvoyer une valeur vide ou un tiret pour représenter une valeur NULL.

Déterminer si un nombre est supérieur ou inférieur à un autre

Utilisez la fonction SI pour effectuer cette comparaison.

Colonne1

Colonne2

Formule

Description (résultat possible)

15000

9000

=[Colonne1]>[Colonne2]

Colonne1 est-elle supérieure à Colonne2 ? (Oui)

15000

9000

=SI([Colonne1]<=[Colonne2], "OK", "Pas OK")

Colonne1 est-elle inférieure ou égale à Colonne2 ? (Pas OK)

Renvoyer une valeur logique après comparaison du contenu des colonnes

Pour un résultat qui est une valeur logique (Oui ou Non), utilisez les fonctions ET, OU et NON.

Colonne1

Colonne2

Colonne3

Formule

Description (résultat possible)

15

9

8

=ET([Colonne1]>[Colonne2], [Colonne1]<[Colonne3])

15 est-il supérieur à 9 et inférieur à 8 ? (Non)

15

9

8

=OU([Colonne1]>[Colonne2], [Colonne1]<[Colonne3])

15 est-il supérieur à 9 ou inférieur à 8 ? (Oui)

15

9

8

=NON([Colonne1]+[Colonne2]=24)

15 plus 9 n’est-il pas égal à 24 ? (Non)

Pour un résultat qui est un autre calcul, ou toute valeur autre que Oui ou Non, utilisez les fonctions SI, ET et OU.

Colonne1

Colonne2

Colonne3

Formule

Description (résultat possible)

15

9

8

=SI([Colonne1]=15, "OK", "Pas OK")

Si la valeur dans Colonne1 est égale à 15, renvoyer « OK ». (OK)

15

9

8

=SI(ET([Colonne1]>[Colonne2], [Colonne1]<[Colonne3]), "OK", "Pas OK")

Si 15 est supérieur à 9 et inférieur à 8, renvoyer « OK ». (Pas OK)

15

9

8

=SI(OU([Colonne1]>[Colonne2], [Colonne1]<[Colonne3]), "OK", "Pas OK")

Si 15 est supérieur à 9 ou inférieur à 8, renvoyer « OK ». (OK)

Afficher des zéros sous forme d’espaces ou de tirets

Pour afficher un zéro, effectuez un calcul simple. Pour afficher un vide ou un tiret, utilisez la fonction SI.

Colonne1

Colonne2

Formule

Description (résultat possible)

10

10

=[Colonne1]-[Colonne2]

Deuxième nombre soustrait du premier (0)

15

9

=SI([Colonne1]-[Colonne2],"-",[Colonne1]-[Colonne2])

Renvoie un tiret lorsque la valeur est zéro (-)

Masquer les valeurs d’erreur dans les colonnes

Pour afficher un tiret, #N/A ou NA à la place d’une valeur d’erreur, utilisez la fonction ESTERREUR.

Colonne1

Colonne2

Formule

Description (résultat possible)

10

0

=[Colonne1]/[Colonne2]

A pour résultat une erreur (#DIV/0)

10

0

=SI(ESTERREUR([Colonne1]/[Colonne2]),"NA",[Colonne1]/[Colonne2])

Renvoie NA quand la valeur est une erreur

10

0

=SI(ESTERREUR([Colonne1]/[Colonne2]),"-",[Colonne1]/[Colonne2])

Renvoie un tiret quand la valeur est une erreur

Vérifier la présence de champs vides

Vous pouvez utiliser la formule ESTVIDE pour rechercher des champs vides.

Colonne1

Formule

Description (résultat possible)

"Jelly beans"

=ESTVIDE([Colonne1]

Renvoie Oui ou Non selon que le champ est vide ou non

"Steel"

=SI(ESTVIDE([Colonne1]), "Pas OK", "OK")

Renseignez vos propres choix : d’abord si le champ est vide, ensuite s’il ne l’est pas

Pour plus d’informations sur les fonctions EST, voir fonctions EST.

Vous pouvez utiliser les formules suivantes pour effectuer des calculs qui reposent sur les dates et heures, notamment ajouter un nombre de jours, mois ou années à une date, calculer la différence entre deux dates et convertir une heure en une valeur décimale.

Ajouter des dates

Pour ajouter un nombre de jours à une date, utilisez l’opérateur d’addition (+).

Remarque : Lorsque vous manipulez des dates, le type de renvoi de la colonne calculée doit être défini sur Date et heure.

Colonne1

Colonne2

Formule

Description (résultat)

09/06/2007

3

=[Colonne1]+[Colonne2]

Ajoute 3 jours au 09/06/2007 (12/06/2007)

10/12/2008

54

=[Colonne1]+[Colonne2]

Ajoute 54 jours au 10/12/2008 (02/02/2009)

Pour ajouter un nombre de mois à une date, utilisez les fonctions DATE, ANNEE, MOIS et JOUR.

Colonne1

Colonne2

Formule

Description (résultat)

09/06/2007

3

=DATE(ANNEE([Colonne1]),MOIS([Colonne1])+[Colonne2],JOUR([Colonne1]))

Ajoute 3 mois au 09/06/2007 (09/09/2007)

10/12/2008

25

=DATE(ANNEE([Colonne1]),MOIS([Colonne1])+[Colonne2],JOUR([Colonne1]))

Ajoute 25 mois au 10/12/2008 (10/01/2011)

Pour ajouter un nombre d’années à une date, utilisez les fonctions DATE, ANNEE, MOIS et JOUR.

Colonne1

Colonne2

Formule

Description (résultat)

09/06/2007

3

=DATE(ANNEE([Colonne1])+[Colonne2],MOIS([Colonne1]),JOUR([Colonne1]))

Ajoute 3 ans au 09/06/2007 (09/06/2010)

10/12/2008

25

=DATE(ANNEE([Colonne1])+[Colonne2],MOIS([Colonne1]),JOUR([Colonne1]))

Ajoute 25 ans au 10/12/2008 (10/12/2033)

Pour ajouter une combinaison de jours, de mois et d’années à une date, utilisez les fonctions DATE, ANNEE, MOIS et JOUR.

Colonne1

Formule

Description (résultat)

09/06/2007

=DATE(ANNEE([Colonne1])+3,MOIS([Colonne1])+1,JOUR([Colonne1])+5)

Ajoute 3 ans, 1 mois et 5 jours au 09/06/2007 (14/07/2010)

10/12/2008

=DATE(ANNEE([Colonne1])+1,MOIS([Colonne1])+7,JOUR([Colonne1])+5)

Ajoute 1 an, 7 mois et 5 jours au 10/12/2008 (15/07/2010)

Calculer la différence entre deux dates

Utilisez la fonction DATEDIF pour effectuer ce calcul.

Colonne1

Colonne2

Formule

Description (résultat)

01-janv.-1995

15-juin-1999

=DATEDIF([Colonne1], [Colonne2],"d")

Renvoie le nombre de jours entre les deux dates (1626)

01-janv.-1995

15-juin-1999

=DATEDIF([Colonne1], [Colonne2],"ym")

Renvoie le nombre de mois entre les dates, en ignorant la partie Années (5)

01-janv.-1995

15-juin-1999

=DATEDIF([Colonne1], [Colonne2],"yd")

Renvoie le nombre de jours entre les dates, en ignorant la partie Années (165)

Calculer la différence entre deux heures

Pour présenter le résultat au format d’heure standard (heures:minutes:secondes), utilisez l’opérateur de soustraction (-) et la fonction TEXTE. Pour que cette méthode fonctionne, les heures ne doivent pas dépasser 24, et les minutes et les secondes ne doivent pas dépasser 60.

Colonne1

Colonne2

Formule

Description (résultat)

09/06/2007 10:35

09/06/2007 15:30

=TEXTE([Colonne2]-[Colonne1],"h")

Nombre d’heures entre deux heures (4)

09/06/2007 10:35

09/06/2007 15:30

=TEXTE([Colonne2]-[Colonne1],"h:mm")

Nombre d’heures et de minutes entre deux heures (4:55)

09/06/2007 10:35

09/06/2007 15:30

=TEXTE([Colonne2]-[Colonne1],"h:mm:ss")

Nombre d’heures, de minutes et de secondes entre deux heures (4:55:00)

Pour présenter le résultat dans un total qui repose sur une unité de temps, utiliser la fonction ENT, ou la fonction HEURE, MINUTE ou SECONDE.

Colonne1

Colonne2

Formule

Description (résultat)

09/06/2007 10:35

10/06/2007 15:30

=ENT(([Colonne2]-[Colonne1])*24)

Nombre total d’heures entre deux heures (28)

09/06/2007 10:35

10/06/2007 15:30

=ENT(([Colonne2]-[Colonne1])*1440)

Nombre total de minutes entre deux heures (1 735)

09/06/2007 10:35

10/06/2007 15:30

=ENT(([Colonne2]-[Colonne1])*86400)

Nombre total de secondes entre deux heures (104 100)

09/06/2007 10:35

10/06/2007 15:30

=HEURE([Colonne2]-[Colonne1])

Nombre d’heures entre deux heures, lorsque la différence n’excède pas 24 (4)

09/06/2007 10:35

10/06/2007 15:30

=MINUTE([Colonne2]-[Colonne1])

Nombre de minutes entre deux heures, lorsque la différence n’excède pas 60 (55)

09/06/2007 10:35

10/06/2007 15:30

=SECONDE([Colonne2]-[Colonne1])

Nombre de secondes entre deux heures, lorsque la différence n’excède pas 60 (0)

Convertir des heures

Pour convertir des heures du format d’heure standard en nombre décimal, utilisez la fonction ENT.

Colonne1

Formule

Description (résultat)

10:35

=([Colonne1]-ENT([Colonne1]))*24

Nombre d’heures écoulées depuis 00:00 (10,583333)

12:15

=([Colonne1]-ENT([Colonne1]))*24

Nombre d’heures écoulées depuis 00:00 (12,25)

Pour convertir des heures à partir d’un nombre décimal au format horaire standard (heures:minutes:secondes), utilisez l’opérateur de division et la fonction TEXTE.

Colonne1

Formule

Description (résultat)

23:58

=TEXTE(Colonne1/24, "hh:mm:ss")

Heures, minutes et secondes écoulées depuis 00:00 (00:59:55)

02:06

=TEXTE(Colonne1/24, "h:mm")

Heures et minutes écoulées depuis 00:00 (0:05)

Insérer des dates au format ordinal

Une date au format ordinal fait référence à un format de date qui est une combinaison de l’année en cours et du nombre de jours écoulés depuis le début de l’année. Par exemple, le 1er janvier 2007 est représenté sous la forme 2007001 et le 31 décembre 2007 est représenté sous la forme 2007365. Ce format n’est pas basé sur le calendrier julien.

Pour convertir une date en une date au format ordinal, utilisez les fonctions TEXTE et DATEVAL.

Colonne1

Formule

Description (résultat)

23/06/2007

=TEXTE([Colonne1],"yy")&TEXTE(([Colonne1]-DATEVAL("1/1/"& TEXTE([Colonne1],"yy"))+1),"000")

Date au format ordinal, avec une année à 2 chiffres (07174)

23/06/2007

=TEXTE([Colonne1],"yyyy")&TEXTE(([Colonne1]-DATEVAL("1/1/"&TEXTE([Colonne1],"yy"))+1),"000")

Date au format ordinal, avec une année à 4 chiffres (2007174)

Pour convertir une date en une date au format ordinal qui est utilisée en astronomie, utilisez la constante 2415018,50. Cette formule ne fonctionne que pour les dates postérieures au 03/01/1901, et si vous utilisez le système de date 1900.

Colonne1

Formule

Description (résultat)

23/06/2007

=[Colonne1]+2415018,50

Date au format ordinal, utilisée en astronomie (2454274,50)

Afficher les dates en tant que jours de la semaine

Pour convertir des dates en texte pour le jour de la semaine, utilisez les fonctions TEXTE et JOURSEM.

Colonne1

Formule

Description (résultat possible)

19-févr.-2007

=TEXTE(JOURSEM([Colonne1]), "dddd")

Calcule le jour de la semaine pour la date et renvoie le nom complet du jour (Lundi)

3-janv.-2008

=TEXTE(JOURSEM([Colonne1]), "ddd")

Calcule le jour de la semaine pour la date et renvoie le nom abrégé du jour (Lun)

Vous pouvez utiliser les formules suivantes pour effectuer des calculs mathématiques, tels qu’une addition, une soustraction, une multiplication et une division de nombres ; calculer la moyenne ou la médiane des nombres ; arrondir un nombre ; et compter des valeurs.

Additionner des nombres

Pour additionner des nombres dans plusieurs colonnes d’une ligne, utilisez l’opérateur d’addition (+) ou la fonction SOMME.

Colonne1

Colonne2

Colonne3

Formule

Description (résultat)

6

5

4

=[Colonne1]+[Colonne2]+[Colonne3]

Additionne les valeurs des trois premières colonnes (15)

6

5

4

=SOMME([Colonne1],[Colonne2],[Colonne3])

Additionne les valeurs des trois premières colonnes (15)

6

5

4

=SOMME(SI([Colonne1]>[Colonne2], [Colonne1]-[Colonne2], 10), [Colonne3])

Si Colonne1 est supérieure à Colonne2, additionne la différence et Colonne3. Sinon additionne 10 et Colonne3 (5).

Soustraire des nombres

Pour soustraire des nombres dans plusieurs colonnes d’une ligne, utilisez l’opérateur de soustraction (-) ou la fonction SOMME avec des nombres négatifs.

Colonne1

Colonne2

Colonne3

Formule

Description (résultat)

15000

9000

-8000

=[Colonne1]-[Colonne2]

Soustrait 9000 de 15000 (6000)

15000

9000

-8000

=SOMME([Colonne1], [Colonne2], [Colonne3])

Additionne les nombres des trois premières colonnes, y compris les valeurs négatives (16000)

Calculer la différence entre deux nombres sous forme de pourcentage

Utilisez les opérateurs de soustraction (-) et de division (/) et la fonction ABS.

Colonne1

Colonne2

Formule

Description (résultat)

2342

2500

=([Colonne2]-[Colonne1])/ABS([Colonne1])

Variation en pourcentage (6,75 % ou 0,06746)

Multiplier des nombres

Pour multiplier les nombres de plusieurs colonnes d’une ligne, utilisez l’opérateur de multiplication (*) ou la fonction PRODUIT.

Colonne1

Colonne2

Formule

Description (résultat)

5

2

=[Colonne1]*[Colonne2]

Multiplie les nombres des deux premières colonnes (10)

5

2

=PRODUIT([Colonne1], [Colonne2])

Multiplie les nombres des deux premières colonnes (10)

5

2

=PRODUIT([Colonne1],[Colonne2],2)

Multiplie les nombres des deux premières colonnes et le nombre 2 (20)

Diviser des nombres

Pour diviser les nombres de plusieurs colonnes d’une ligne, utilisez l’opérateur de division (/).

Colonne1

Colonne2

Formule

Description (résultat)

15000

12

=[Colonne1]/[Colonne2]

Divise 15000 par 12 (1250)

15000

12

=([Colonne1]+10000)/[Colonne2]

Additionne 15000 et 10000, et divise le total par 12 (2083)

Calculer la moyenne des nombres

Pour calculer la moyenne des nombres de plusieurs colonnes d’une ligne, utilisez la fonction MOYENNE.

Colonne1

Colonne2

Colonne3

Formule

Description (résultat)

6

5

4

=MOYENNE([Colonne1], [Colonne2],[Colonne3])

Moyenne des nombres des trois premières colonnes (5)

6

5

4

=MOYENNE(SI([Colonne1]>[Colonne2], [Colonne1]-[Colonne2], 10), [Colonne3])

Si Colonne1 est supérieure à Colonne2, calcule la moyenne de la différence et Colonne3. Sinon calcule la moyenne de la valeur 10 et Colonne3 (2,5).

Calculer la médiane des nombres

La médiane est la valeur au centre d’une plage ordonnée de nombres. Utilisez la fonction MEDIANE pour calculer la médiane d’un groupe de nombres.

A

B

C

D

E

F

Formule

Description (résultat)

10

7

9

27

0

4

=MEDIANE(A, B, C, D, E, F)

Médiane des nombres des 6 premières colonnes (8)

Calculer le plus petit ou le plus grand nombre d’une plage

Pour calculer le plus petit ou le plus grand nombre de plusieurs colonnes d’une ligne, utilisez les fonctions MIN et MAX.

Colonne1

Colonne2

Colonne3

Formule

Description (résultat)

10

7

9

=MIN([Colonne1], [Colonne2], [Colonne3])

Plus petit nombre (7)

10

7

9

=MAX([Colonne1], [Colonne2], [Colonne3])

Plus grand nombre (10)

Compter des valeurs

Pour compter des valeurs numériques, utilisez la fonction NB.

Colonne1

Colonne2

Colonne3

Formule

Description (résultat)

Pomme

12/12/2007

=NB([Colonne1], [Colonne2], [Colonne3])

Compte le nombre de colonnes qui contiennent des valeurs numériques. Exclut les valeurs de date et heure, texte et NULL (0).

12 €

#DIV/0!

1,01

=NB([Colonne1], [Colonne2], [Colonne3])

Compte le nombre de colonnes qui contiennent des valeurs numériques, mais exclut les valeurs d’erreur et les valeurs logiques (2)

Augmenter ou réduire un nombre par un pourcentage

Utilisez l’opérateur de pourcentage (%) pour effectuer ce calcul.

Colonne1

Colonne2

Formule

Description (résultat)

23

3 %

=[Colonne1]*(1+5 %)

Augmente le nombre dans Colonne1 de 5 % (24,15)

23

3 %

=[Colonne1]*(1+[Colonne2])

Augmente le nombre dans Colonne1 de la valeur en pour cent dans Colonne2 : 3 % (23,69)

23

3 %

=[Colonne1]*(1-[Colonne2])

Diminue le nombre dans Colonne1 de la valeur en pour cent dans Colonne2 : 3 % (22,31)

Élever un nombre à une puissance

Utilisez l’opérateur exponentiel (^) ou la fonction PUISSANCE pour effectuer ce calcul.

Colonne1

Colonne2

Formule

Description (résultat)

5

2

=[Colonne1]^[Colonne2]

Calcule cinq au carré (25)

5

3

=PUISSANCE([Colonne1], [Colonne2])

Calcule cinq au cube (125)

Arrondir un nombre

Pour arrondir un nombre, utilisez la fonction ARRONDI.SUP, IMPAIR ou PAIR.

Colonne1

Formule

Description (résultat)

20,3

=ARRONDI.SUP([Colonne1],0)

Arrondit 20,3 au nombre entier immédiatement supérieur (21)

-5,9

=ARRONDI.SUP([Colonne1],0)

Arrondit -5,9 au nombre entier immédiatement supérieur (-5)

12,5493

=ARRONDI.SUP([Colonne1],2)

Arrondit 12,5493 au centième le plus proche, à deux décimales (12,55)

20,3

=PAIR([Colonne1])

Arrondit 20,3 au nombre pair le plus proche (22)

20,3

=IMPAIR([Colonne1])

Arrondit 20,3 au nombre impair le plus proche (21)

Pour arrondir à un nombre inférieur, utilisez la fonction ARRONDI.INF.

Colonne1

Formule

Description (résultat)

20,3

=ARRONDI.INF([Colonne1],0)

Arrondit 20,3 au nombre entier inférieur le plus proche (20)

-5,9

=ARRONDI.INF([Colonne1],0)

Arrondit -5,9 au nombre entier inférieur le plus proche (-6)

12,5493

=ARRONDI.INF([Colonne1],2)

Arrondit 12,5493 au centième inférieur le plus proche, à deux décimales (12,54)

Pour arrondir un nombre au nombre ou à la fraction la plus proche, utilisez la fonction ARRONDI.

Colonne1

Formule

Description (résultat)

20,3

=ARRONDI([Colonne1],0)

Arrondit 20,3 au nombre inférieur, car la partie fractionnaire est inférieure à 0,5 (20)

5,9

=ARRONDI([Colonne1],0)

Arrondit 5,9 au nombre supérieur, car la partie fractionnaire est supérieure à 0,5 (6)

-5,9

=ARRONDI([Colonne1],0)

Arrondit -5,9 au nombre inférieur, car la partie fractionnaire est inférieure à 0,5 (-6)

1,25

=ARRONDI([Colonne1], 1)

Arrondit le nombre au dixième le plus proche (une décimale). Étant donné que la partie à arrondir est supérieure ou égale à 0,05, le nombre est arrondi au nombre supérieur (résultat : 1,3)

30,452

=ARRONDI([Colonne1], 2)

Arrondit le nombre au centième le plus proche (deux décimales). Étant donné que la partie à arrondir, 0,002, est inférieure à 0,005, le nombre est arrondi au nombre inférieur (résultat : 30,45)

Pour arrondir un nombre afin qu’il soit un chiffre significatif supérieur à 0, utilisez les fonctions ARRONDI, ARRONDI.SUP, ARRONDI.INF, ENT et NBCAR.

Colonne1

Formule

Description (résultat)

5492820

=ARRONDI([Colonne1],3-NBCAR(ENT([Colonne1])))

Arrondit le nombre à 3 chiffres significatifs (5490000)

22230

=ARRONDI.INF([Colonne1],3-NBCAR(ENT([Colonne1])))

Arrondit au nombre inférieur à 3 chiffres significatifs (22200)

5492820

=ARRONDI.SUP([Colonne1], 5-NBCAR(ENT([Colonne1])))

Arrondit au nombre supérieur à 5 chiffres significatifs (5492900)

Vous pouvez utiliser les formules suivantes pour manipuler le texte, notamment combiner ou concaténer les valeurs de plusieurs colonnes, comparer le contenu de colonnes, supprimer des caractères ou des espaces et des caractères extensibles.

Modifier la casse du texte

Pour modifier la casse du texte, utilisez la fonction MAJUSCULE, MINUSCULE ou NOMPROPRE.

Colonne1

Formule

Description (résultat)

nina Vietzen

=MAJUSCULE([Colonne1])

Change le texte en majuscules (NINA VIETZEN)

nina Vietzen

=MINUSCULE([Colonne1])

Change le texte en minuscules (nina vietzen)

nina Vietzen

=NOMPROPRE([Colonne1])

Change le texte en casse de titre (Nina Vietzen)

Combiner le prénom et le nom

Pour combiner le prénom et le nom, utilisez l’opérateur « esperluette » (&) ou la fonction CONCATENER.

Colonne1

Colonne2

Formule

Description (résultat)

Carlos

Carvallo

=[Colonne1]&[Colonne2]

Combine les deux chaînes (CarlosCarvallo)

Carlos

Carvallo

=[Colonne1]&" "&[Colonne2]

Combine les deux chaînes, en les séparant par un espace (Carvallo Carlos)

Carlos

Carvallo

=[Colonne2]&", "&[Colonne1]

Combine les deux chaînes, en les séparant par une virgule et un espace (Carvallo, Carlos)

Carlos

Carvallo

=CONCATENER([Colonne2], ",", [Colonne1])

Combine les deux chaînes, en les séparant par une virgule (Carvallo,Carlos)

Combiner le texte et les nombres de différentes colonnes

Pour combiner texte et nombres, utilisez la fonction CONCATENER, l’opérateur « esperluette » (&), ou la fonction TEXTE et l’opérateur « esperluette ».

Colonne1

Colonne2

Formule

Description (résultat)

Yang

28

=[Colonne1]&" a vendu "&[Colonne2]&" unités."

Combine le contenu en une phrase (Yang a vendu 28 unités.)

Dubois

40 %

=[Colonne1]&" a réalisé "&TEXTE([Colonne2],"0 %")&" des ventes totales."

Combine le contenu en une phrase (Dubois a réalisé 40 % des ventes totales.)

Remarque : La fonction TEXTE ajoute la valeur mise en forme de Colonne2 au lieu de la valeur sous-jacente, 0,4.

Yang

28

=CONCATENER([Colonne1]," a vendu ",[Colonne2]," unités.")

Combine le contenu en une phrase (Yang a vendu 28 unités.)

Combiner du texte avec une date ou heure

Pour combiner du texte avec une date ou heure, utilisez la fonction TEXTE et l’opérateur « esperluette » (&).

Colonne1

Colonne2

Formule

Description (résultat)

Date de facturation

5-juin-2007

="Date déclaration : "&TEXTE([Colonne2], "d-mmm-yyyy")

Combine du texte avec une date (Date déclaration : 5-juin-2007)

Date de facturation

5-juin-2007

=[Colonne1]&" "&TEXTE([Colonne2], "mmm-dd-yyyy")

Combine du texte et une date de différentes colonnes dans une colonne (Date de facturation 5-juin-2007)

Comparer le contenu des colonnes

Pour comparer une colonne à une autre colonne ou une liste de valeurs, utilisez les fonctions EXACT et OU.

Colonne1

Colonne2

Formule

Description (résultat possible)

BD122

BD123

=EXACT([Colonne1],[Colonne2])

Compare le contenu des deux premières colonnes (Non)

BD122

BD123

=EXACT([Colonne1], "BD122")

Compare le contenu de Colonne1 et la chaîne « BD122 » (Oui)

Déterminer si une valeur de colonne ou une partie de celle-ci correspond à un texte spécifique

Pour déterminer si une valeur de colonne ou une partie de celle-ci correspond à un texte spécifique, utilisez les fonctions SI, TROUVE, CHERCHE et ESTNUM.

Colonne1

Formule

Description (résultat possible)

Vietzen

=SI([Colonne1]="Vietzen", "OK", "Pas OK")

Détermine si Colonne1 est Vietzen (OK)

Vietzen

=SI(ESTNUM(TROUVE("v",[Colonne1])), "OK", "Pas OK")

Détermine si Colonne1 contient la lettre v (OK)

BD123

=ESTNUM(TROUVE("BD",[Colonne1]))

Détermine si Colonne1 contient BD (Oui)

Compter les colonnes non vides

Pour compter les colonnes non vides, utilisez la fonction NBVAL.

Colonne1

Colonne2

Colonne3

Formule

Description (résultat)

Ventes

19

=NBVAL([Colonne1], [Colonne2])

Compte le nombre de colonnes non vides (2)

Ventes

19

=NBVAL([Colonne1], [Colonne2], [Colonne3])

Compte le nombre de colonnes non vides (2)

Supprimer les caractères de texte

Pour supprimer des caractères du texte, utilisez les fonctions NBCAR, GAUCHE et DROITE.

Colonne1

Formule

Description (résultat)

Vitamine A

=GAUCHE([Colonne1],NBCAR([Colonne1])-2)

Renvoie 8 caractères (10-2), à partir de la gauche (Vitamine)

Vitamine B1

=DROITE([Colonne1], NBCAR([Colonne1])-9)

Renvoie 2 caractères (11-9), en commençant de la droite (B1)

Supprimer les espaces de début et fin d’une colonne

Pour supprimer des espaces d’une colonne, utilisez la fonction SUPPRESPACE.

Colonne1

Formule

Description (résultat)

 Bonjour !

=SUPPRESPACE([Colonne1])

Supprime les espaces de début et de fin (Bonjour !)

Répéter un caractère dans une colonne

Pour répéter un caractère dans une colonne, utilisez la fonction REPT.

Formule

Description (résultat)

=REPT(".",3)

Répète un point 3 fois (...)

=REPT("-"; 10)

Répète un tiret 10 fois (----------)

Liste alphabétique des fonctions

Voici une liste de liens vers les fonctions disponibles pour les utilisateurs de SharePoint. Elle inclut des fonctions trigonomiques, statistiques et financières, ainsi que des formules conditionnelles, mathématiques, de date et de texte.

ABS

ACOS

ACOSH

ACOSH

ET

ASIN

ASINH

ATAN

ATAN2

MOYENNE

AVERAGEA

LOI.BETA

BETA.INVERSE

LOI.BINOMIALE

PLAFOND

CAR

LOI.KHIDEUX

CHOISIR

CODE

CONCATENER

INTERVALLE.CONFIANCE

COS

NB

NBVAL

CRITERE.LOI.BINOMIALE

DATE

DATEDIF

DATEVAL

JOUR

JOURS360

DDB

DEGRES

DEVISE

PAIR

EXACT

LOI.EXPONENTIELLE

FACT

LOI.F

TROUVE

INVERSE.LOI.F

FISHER

CTXT

LOI.GAMMA

LOI.GAMMA.INVERSE

LNGAMMA

MOYENNE.GEOMETRIQUE

MOYENNE.HARMONIQUE

HEURE

LOI.HYPERGEOMETRIQUE

SI

ENT

INTPER

EST

GAUCHE

NBCAR

LN

LOG

LOG10

LOI.LOGNORMALE.INVERSE

LOI.LOGNORMALE

MINUSCULE

MAX

ME

MEDIANE

MID

MIN

MINA

MINUTE

MOD

MOIS

LOI.BINOMIALE.NEG

LOI.NORMALE

LOI.NORMALE.STANDARD

LOI.NORMALE.STANDARD.INVERSE

NON

NPM

VAN

VAN

IMPAIR

OU

VPM

PUISSANCE

PRINCPER

PRODUIT

NOMPROPRE

VA

RADIANS

REPLACE

REPT

DROITE

ARRONDI

ARRONDI.INF

ARRONDI.SUP

CHERCHE

SECONDE

SIGNE

SIN

SINH

RACINE

CENTREE.REDUITE

STDEVA

ECARTYPEP

STDEVPA

SOMME

SOMME.CARRES

SYD

TANH

LOI.STUDENT

TEXTE

TEMPS

LOI.STUDENT.INVERSE

AUJOURDHUI

SUPPRESPACE

VRAI

VRAI

MAJUSCULE

USDOLLAR

CNUM

VAR

VARA

VAR.P

VARPA

JOURSEM

LOI.WEIBULL

ANNEE

Autres ressources

Si cet article ne contient pas l’action que vous essayez d’effectuer, essayez de la réaliser dans Excel ou consultez l’article Filtres de composants WebPart. Voici quelques ressources supplémentaires. Certaines d’entre-elles s’appliquent à d’anciennes versions. L’interface utilisateur peut ne pas être la même. Par exemple, des éléments du menu Actions du site dans SharePoint2010 figurent désormais dans le menu Paramètres Le bouton des paramètres d’Office 365 ressemble à une roue dentée située en regard de votre nom. .

Il existe de nombreuses autres ressources sur le web que vous pouvez rechercher, par exemple, comment attribuer des codes couleur aux champs calculés.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×