Exemples de formules courantes

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Vous pouvez utiliser les exemples ci-dessous dans les colonnes calculées d'une liste ou d'une bibliothèque. Les exemples qui ne contiennent aucune référence de colonne peuvent être utilisés pour spécifier la valeur par défaut d'une colonne.

Contenu de cet article

Formules conditionnelles

Formules de date et heure

Formules mathématiques

Formules de texte

Formules conditionnelles

Vous pouvez utiliser les formules ci-dessous pour tester la condition d'une instruction et renvoyer une valeur Oui ou Non, pour tester une autre valeur comme OK ou Pas OK ou pour renvoyer un blanc ou un tiret représentant une valeur nulle.

Déterminer si un nombre est supérieur ou inférieur à un autre

Utilisez la fonction SI pour effectuer cette comparaison.

Colonne1

Colonne2

Formule

Description (résultat possible)

15000

9000

= [Colonne1]>[Colonne2]

La valeur de Colonne1 est-elle supérieure à celle de Colonne2 ? (Oui)

15000

9000

=SI([Colonne1]<=[Colonne2], "OK", "Pas OK")

La valeur de Colonne1 est-elle inférieure ou égale à celle de Colonne2 ? (Pas OK)

Renvoyer une valeur logique après comparaison du contenu des colonnes

Pour un résultat qui est une valeur logique (Oui ou Non), utilisez les fonctions ET, OU et NON.

Colonne1

Colonne2

Colonne3

Formule

Description (résultat possible)

15

9

8

=ET([Colonne1]>[Colonne2], [Colonne1]<[Colonne3])

15 est-il supérieur à 9 et inférieur à 8 ? (Non)

15

9

8

=OU([Colonne1]>[Colonne2], [Colonne1]<[Colonne3])

15 est-il supérieur à 9 ou inférieur à 8 ? (Oui)

15

9

8

=NON([Colonne1]+[Colonne2]=24)

15 plus 9 est-il différent de 24 ? (Non)

Pour un résultat qui est un autre calcul ou une valeur autre que Oui ou Non, utilisez les fonctions SI, ET et OU.

Colonne1

Colonne2

Colonne3

Formule

Description (résultat possible)

15

9

8

=SI([Colonne1]=15, "OK", "Pas OK")

Si la valeur de Colonne1 est égale à 15, renvoie « OK ».

15

9

8

=SI(ET([Colonne1]>[Colonne2], [Colonne1]<[Colonne3]), "OK", "Pas OK")

Si 15 est supérieur à 9 et inférieur à 8, renvoie « OK ». (OK)

15

9

8

=SI(OU([Colonne1]>[Colonne2], [Colonne1]<[Colonne3]), "OK", "Pas OK")

Si 15 est supérieur à 9 ou inférieur à 8, renvoie « OK ».

Afficher des zéros sous forme d’espaces ou de tirets

Pour afficher un zéro, effectuez un calcul simple. Pour afficher un blanc ou un tiret, utilisez la fonction SI.

C olonne1

Colonne2

Formule

Description (résultat possible)

10

10

=[Colonne1]-[Colonne2]

Deuxième nombre soustrait du premier (0)

15

9

=SI([Colonne1]-[Colonne2],"-",[Colonne1]-[Colonne2])

Renvoie un tiret si la valeur est zéro (-)

Masquer les valeurs d’erreur dans les colonnes

Pour afficher un tiret, #N/A ou NA à la place d'une valeur d'erreur, utilisez la fonction ESTERREUR.

Colonne1

Colonne2

Formule

Description (résultat possible)

10

0

=[Colonne1]/[Colonne2]

A pour résultat une erreur (#DIV/0)

10

0

=SI(ESTERREUR([Colonne1]/[Colonne2]),"NA",[Colonne1]/[Colonne2])

Renvoie NA lorsque la valeur est une erreur

10

0

=SI(ESTERREUR([Colonne1]/[Colonne2]),"-",[Colonne1]/[Colonne2])

Renvoie un tiret lorsque la valeur est une erreur

Haut de la Page

Formules de date et heure

Vous pouvez utiliser les formules ci-dessous pour effectuer des calculs basés sur des dates et des heures, par exemple ajouter un nombre de jours, d'années ou de mois à une date, calculer la différence entre deux dates ou convertir l'heure en une valeur décimale.

Ajouter des dates

Pour ajouter un nombre de jours à une date, utilisez l'opérateur d'addition (+).

Remarque : Lorsque vous manipulez des dates, la colonne calculée qui affichera le résultat doit être définie sur Date et heure.

Colonne1

Colonne2

Formule

Description (Résultat)

09/06/2007

3

=[Colonne1]+[Colonne2]

Ajoute 3 jours à 09/06/2007 (12/06/2007)

10/12/2008

54

=[Colonne1]+[Colonne2]

Ajoute 54 jours à 10/12/2008 (02/02/2009)

Pour ajouter un nombre de mois à une date, utilisez les fonctions DATE, ANNEE, MOIS et JOUR.

Colonne1

Colonne2

Formule

Description (Résultat)

09/06/2007

3

=DATE(ANNEE([Colonne1]),MOIS([Colonne1])+[Colonne2],JOUR([Colonne1]))

Ajoute 3 mois à 09/06/2007 (09/09/2007)

10/12/2008

25

=DATE(ANNEE([Colonne1]),MOIS([Colonne1])+[Colonne2],JOUR([Colonne1]))

Ajoute 25 mois à 10/12/2008 (10/01/2011)

Pour ajouter un nombre d'années à une date, utilisez les fonctions DATE, ANNEE, MOIS et JOUR.

Colonne1

Colonne2

Formule

Description (Résultat)

09/06/2007

3

=DATE(ANNEE([Colonne1])+[Colonne2],MOIS([Colonne1]),JOUR([Colonne1]))

Ajoute 3 années à 09/06/2007 (09/06/2010)

10/12/2008

25

=DATE(ANNEE([Colonne1])+[Colonne2],MOIS([Colonne1]),JOUR([Colonne1]))

Ajoute 25 années à 10/12/2008 (10/12/2033)

Pour ajouter une combinaison de jours, mois et années à une date, utilisez les fonctions DATE, ANNEE, MOIS et JOUR.

Colonne1

Formule

Description (Résultat)

09/06/2007

=DATE(ANNEE([Colonne1])+3,MOIS([Colonne1])+1,JOUR([Colonne1])+5)

Ajoute 3 années, 1 mois et 5 jours à 06/09/2007 (14/07/2010)

10/12/2008

=DATE(ANNEE([Colonne1])+1,MOIS([Colonne1])+7,JOUR([Colonne1])+5)

Ajoute 1 année, 7 mois et 5 jours à 12/10/2007 (15/07/2010)

Calculer la différence entre deux dates

Pour effectuer ce calcul, utilisez la fonction DATEDIF.

Colonne1

Colonne2

Formule

Description (Résultat)

01.01.95

15.06.99

=DATEDIF([Colonne1], [Colonne2],"j")

Renvoie le nombre de jours entre les deux dates (1626)

01.01.95

15.06.99

=DATEDIF([Colonne1], [Colonne2],"am")

Renvoie le nombre de mois entre les dates, en ignorant la partie année (5)

01.01.95

15.06.99

=DATEDIF([Colonne1], [Colonne2],"aj")

Renvoie le nombre de jours entre les dates, en ignorant la partie année (165)

Calculer la différence entre deux heures

Pour présenter le résultat au format horaire standard (heures:minutes:secondes), utilisez l'opérateur de soustraction (-) et la fonction TEXTE. Pour que cette méthode fonctionne, les heures ne doivent pas dépasser 24, les minutes et les secondes ne doivent pas dépasser 60.

Colonne1

Colonne2

Formule

Description (Résultat)

09/06/2007 10:35

09/06/2007 15:30

=TEXTE([Colonne2]-[Colonne1],"h")

Nombre d'heures pleines entre deux heures (4)

09/06/2007 10:35

09/06/2007 15:30

=TEXTE([Colonne2]-[Colonne1],"h:mm")

Heures et minutes entre deux heures (4:55)

09/06/2007 10:35

09/06/2007 15:30

=TEXTE([Colonne2]-[Colonne1],"h:mm:ss")

Heures, minutes et secondes entre deux heures (4:55:00)

Pour présenter le résultat dans un total basé sur une unité de temps, utilisez la fonction ENT ou les fonctions HEURE, MINUTE et SECONDE.

Colonne1

Colonne2

Formule

Description (Résultat)

09/06/2007 10:35

10/06/2007 15:30

=INT(([Colonne2]-[Colonne1])*24)

Nombre d'heures pleines entre ces deux heures (28)

09/06/2007 10:35

10/06/2007 15:30

=INT(([Colonne2]-[Colonne1])*1440)

Nombre de minutes entre ces deux heures (1735)

09/06/2007 10:35

10/06/2007 15:30

=INT(([Colonne2]-[Colonne1])*86400)

Nombre de secondes entre ces deux heures (104100)

09/06/2007 10:35

10/06/2007 15:30

=HEURE([Colonne2]-[Colonne1])

Nombre d'heures entre ces deux heures, lorsque la différence ne dépasse pas 24 (4)

09/06/2007 10:35

10/06/2007 15:30

=MINUTE([Colonne2]-[Colonne1])

Nombre de minutes entre ces deux heures, lorsque la différence ne dépasse pas 60 (55)

09/06/2007 10:35

10/06/2007 15:30

=SECONDE([Colonne2]-[Colonne1])

Nombre de secondes entre ces deux heures, lorsque la différence ne dépasse pas 60 (0)

Convertir des heures

Pour convertir des heures à partir du format horaire standard en nombre décimal, utilisez la fonction ENT.

Colonne1

Formule

Description (Résultat)

10:35

=([Colonne1]-ENT([Colonne1]))*24

Nombre d'heures depuis 00:00 (10,583333)

00:15

=([Colonne1]-ENT([Colonne1]))*24

Nombre d'heures depuis 12:00 (12,25)

Pour convertir des heures de nombre décimal en format horaire standard (heures:minutes:secondes), utilisez l'opérateur de division et la fonction TEXTE.

Colonne1

Formule

Description (Résultat)

23:58

=TEXTE(Colonne1/24, "hh:mm:ss")

Heures, minutes et secondes depuis 12:00 (00:59:55)

2:06

=TEXTE(Colonne1/24, "h:mm")

Heures et minutes depuis 12:00 (0:05)

Insérer des dates au format ordinal

L'expression « date au format ordinal » fait référence à un format de date qui est une combinaison de l'année en cours et du nombre de jours écoulés depuis le début de l'année. Par exemple le 1er janvier 2007 est représenté sous la forme 2007001 et le 31 décembre 2007, sous la forme 2007365. Notez que ce format n'est pas basé sur le calendrier julien.

Pour convertir une date en une date au format ordinal, utilisez les fonctions TEXTE et DATEVAL.

Colonne1

Formule

Description (Résultat)

23/06/2007

=TEXTE([Colonne1],"yy")&TEXTE(([Colonne1]-DATEVAL("1/1/"& TEXTE([Colonne1],"yy"))+1),"000")

Date au format ordinal, avec une année à deux chiffres (07174)

23/06/2007

=TEXTE([Colonne1],"yyyy")&TEXTE(([Colonne1]-DATEVAL("1/1/"&TEXTE([Colonne1],"yy"))+1),"000")

Date au format ordinal, avec une année à quatre chiffres (2007174)

Pour convertir une date en une date au format ordinal utilisée en astronomie, utilisez la constante 2415018.50. Cette formule ne fonctionne que pour les dates postérieures au 01/03/1901 et si vous utilisez le calendrier depuis 1900.

Colonne1

Formule

Description (Résultat)

23/06/2007

=[Colonne1]+2415018.50

Date au format de date ordinal utilisée en astronomie (2454274.50)

Afficher les dates en tant que jours de la semaine

Pour convertir les dates en texte pour le jour de la semaine, utilisez les fonctions TEXTE et JOURSEM.

Colonne1

Formule

Description (résultat possible)

19-févr-2007

=TEXTE(JOURSEM([Colonne1]), "jjjj")

Calcule le jour de la semaine correspondant à la date et renvoie le nom du jour en entier (lundi)

3-janv-2008

=TEXTE(JOURSEM([Colonne1]), "jjj")

Calcule le jour de la semaine correspondant à la date et renvoie le nom abrégé du jour (jeu)

Haut de la Page

Formules mathématiques

Vous pouvez utiliser les formules ci-dessous pour effectuer plusieurs calculs mathématiques, par exemple additionner, soustraire, multiplier et diviser des nombres, calculer la moyenne ou la médiane de nombres, arrondir des nombres et compter des valeurs.

Additionner des nombres

Pour additionner les nombres de plusieurs colonnes dans une ligne, utilisez l'opérateur d'addition (+) ou la fonction SOMME.

Colonne1

Colonne2

Colonne3

Formule

Description (Résultat)

6

5

4

=[Colonne1]+[Colonne2]+[Colonne3]

Additionne les valeurs des trois premières colonnes (15)

6

5

4

=SOMME([Colonne1],[Colonne2],[Colonne3])

Additionne les valeurs des trois premières colonnes (15)

6

5

4

=SOMME(SI([Colonne1]>[Colonne2], [Colonne1]-[Colonne2], 10), [Colonne3])

Si la valeur de Colonne1 est supérieure à la valeur de Colonne2, additionne la différence et la valeur de Colonne3. Sinon, additionne 10 et la valeur de Colonne3 (5)

Soustraire des nombres

Pour soustraire les nombres de plusieurs colonnes dans une ligne, utilisez l'opérateur de soustraction (-) ou la fonction SOMME avec des nombres négatifs.

Colonne1

Colonne2

Colonne3

Formule

Description (Résultat)

15000

9000

-8 000

=[Colonne1]-[Colonne2]

Soustrait 9 000 de 15 000 (6 000)

15000

9000

-8 000

=SOMME([Colonne1], [Colonne2], [Colonne3])

Additionne les nombres des trois premières colonnes, y compris les nombres négatifs (16 000)

Calculer la différence entre deux nombres sous forme de pourcentage

Utilisez les opérateurs de soustraction (-) et de division (/) ainsi que la fonction ABS.

Colonne1

Colonne2

Formule

Description (Résultat)

2342

2500

=([Colonne2]-[Colonne1])/ABS([Colonne1])

Pourcentage de différence (6,75 % ou 0,06746)

Multiplier des nombres

Pour multiplier les nombres de plusieurs colonnes dans une ligne, utilisez l'opérateur de multiplication (*) ou la fonction PRODUIT.

Colonne1

Colonne2

Formule

Description (Résultat)

5

2

=[Colonne1]*[Colonne2]

Multiplie les nombres des deux premières colonnes (10)

5

2

=PRODUIT([Colonne1], [Colonne2])

Multiplie les nombres des deux premières colonnes (10)

5

2

=PRODUIT([Colonne1],[Colonne2],2)

Multiplie les nombres des deux premières colonnes, fois 2 (20)

Diviser des nombres

Pour diviser les nombres de plusieurs colonnes dans une ligne, utilisez l'opérateur de division (/).

Colonne1

Colonne2

Formule

Description (résultat)

15000

12

=[Colonne1]/[Colonne2]

Divise 15 000 par 12 (1 250)

15000

12

=([Colonne1]+10000)/[Colonne2]

Ajoute 15 000 à 10 000, puis divise le total par 12 (2 083)

Calculer la moyenne des nombres

Pour calculer la moyenne des nombres de plusieurs colonnes dans une ligne, utilisez la fonction MOYENNE.

Colonne1

Colonne2

Colonne3

Formule

Description (Résultat)

6

5

4

=MOYENNE([Colonne1], [Colonne2],[Colonne3])

Calcule la moyenne de tous les nombres des trois premières colonnes (5)

6

5

4

=MOYENNE(SI([Colonne1]>[Colonne2], [Colonne1]-[Colonne2], 10), [Colonne3])

Si la valeur de Colonne1 est supérieure à la valeur de Colonne2, calcule la moyenne de la différence et de Colonne3. Sinon, calcule la moyenne de la valeur 10 et de la valeur de Colonne3 (2,5)

Calculer la médiane des nombres

La médiane est la valeur au centre d'une plage de nombres ordonnés. Utilisez la fonction MEDIANE pour calculer la médiane d'un groupe de nombres.

A

B

C

D

E

F

Formule

Description (Résultat)

10

7

9

27

0

4

=MEDIANE(A, B, C, D, E, F)

Médiane des nombres des 6 premières colonnes (8)

Calculer le plus petit ou le plus grand nombre d’une plage

Pour calculer le plus petit ou le plus grand nombre de plusieurs colonnes dans une ligne, utilisez les fonctions MIN et MAX.

Colonne1

Colonne2

Colonne3

Formule

Description (Résultat)

10

7

9

=MIN([Colonne1], [Colonne2], [Colonne3])

Plus petit nombre de la plage (7)

10

7

9

=MAX([Colonne1], [Colonne2], [Colonne3])

Plus grand nombre de la plage (10)

Compter des valeurs

Pour compter des valeurs numériques, utilisez la fonction NB.

Colonne1

Colonne2

Colonne3

Formule

Description (Résultat)

Pomme

12/12/2007

=NB([Colonne1], [Colonne2], [Colonne3])

Compte le nombre de colonnes qui contiennent des valeurs numériques. Exclut les valeurs de date et d'heure, les valeurs texte et les valeurs nulles (0)

$12

#DIV/0!

1,01

=NB([Colonne1], [Colonne2], [Colonne3])

Compte le nombre de colonnes qui contiennent des valeurs numériques. Exclut les valeurs d'erreur et les valeurs logiques (2)

Augmenter ou réduire un nombre par un pourcentage

Utilisez l'opérateur % pour effectuer ce calcul.

Colonne1

Colonne2

Formule

Description (résultat)

23

3 %

=[Colonne1]*(1+5%)

Augmente le nombre de Colonne1 de 5 % (24,15)

23

3 %

=[Colonne1]*(1+[Colonne2])

Ajoute au nombre de Colonne1 la valeur du pourcentage de Colonne2 : 3 % (23,69)

23

3 %

=[Colonne1]*(1-[Colonne2])

Soustrait du nombre de Colonne1 la valeur du pourcentage de Colonne2 : 3 % (22,31)

Élever un nombre à une puissance

Utilisez l'opérateur « ^ » ou la fonction PUISSANCE pour effectuer ce calcul.

Colonne1

Colonne2

Formule

Description (Résultat)

5

2

=[Colonne1]^[Colonne2]

Calcule cinq au carré (25)

5

3

=PUISSANCE([Colonne1], [Colonne2])

Calcule cinq au cube (125)

Arrondir un nombre

Pour arrondir un nombre au nombre supérieur, utilisez les fonctions ARRONDI.SUP, PAIR ou IMPAIR.

Colonne1

Formule

Description (Résultat)

20,3

=ARRONDI.SUP([Colonne1],0)

Arrondit 20,3 au nombre entier immédiatement supérieur (21)

-5,9

=ARRONDI.SUP([Colonne1],0)

Arrondit -5,9 à l'entier inférieur (-5)

12,5493

=ARRONDI.SUP([Colonne1],2)

Arrondit 12,5493 au centième immédiatement supérieur, avec deux décimales (12,55)

20,3

=PAIR([Colonne1])

Arrondit 20,3 au nombre entier pair immédiatement supérieur (22)

20,3

=IMPAIR([Colonne1])

Arrondit 20,3 au nombre entier impair immédiatement supérieur (21)

Pour arrondir un nombre au nombre inférieur, utilisez la fonction ARRONDI.INF.

Colonne1

Formule

Description (Résultat)

20,3

=ARRONDI.INF([Colonne1],0)

Arrondit 20,3 au nombre entier immédiatement inférieur (20)

-5,9

=ARRONDI.INF([Colonne1],0)

Arrondit -5,9 à l'entier supérieur (-6)

12,5493

=ARRONDI.INF([Colonne1],2)

Arrondit 12,5493 au centième immédiatement inférieur, avec deux décimales (12,54)

Pour arrondir un nombre au nombre ou à la fraction la plus proche, utilisez la fonction ARRONDI.

Colonne1

Formule

Description (Résultat)

20,3

=ARRONDI([Colonne1],0)

Arrondit 20,3 au nombre inférieur, car la partie fractionnaire est inférieure à 0,5 (20)

5,9

=ARRONDI([Colonne1],0)

Arrondit 5,9 au nombre supérieur, car la partie fractionnaire est supérieure à 0,5 (6)

-5,9

=ARRONDI([Colonne1],0)

Arrondit -5,9 au nombre inférieur, car la partie fractionnaire est inférieure à -0,5 (-6)

1,25

=ARRONDI([Colonne1], 1)

Arrondit le nombre au dixième le plus proche (une décimale). Dans la mesure où la partie à arrondir est supérieure ou égale à 0,05, le nombre est arrondi au chiffre supérieur (résultat : 1,3)

30,452

=ARRONDI([Colonne1], 2)

Arrondit le nombre au centième le plus proche (deux décimales). Dans la mesure où la partie à arrondir, 0,002, est inférieure à 0,005, le nombre est arrondi au chiffre inférieur (résultat : 30,45)

Pour arrondir un nombre à un chiffre significatif au-dessus de 0, utilisez les fonctions ARRONDI, ARRONDI.SUP, ARRONDI.INF, NBCAR et ENT.

Colonne1

Formule

Description (Résultat)

5 492 820

=ARRONDI([Colonne1],3-NBCAR(ENT([Colonne1])))

Arrondit le nombre du haut à un nombre inférieur à 3 chiffres significatifs (5 490 000)

22 230

=ARRONDI.INF([Colonne1],3-NBCAR(ENT([Colonne1])))

Arrondit le nombre du bas à un nombre inférieur à 3 chiffres significatifs (22 200)

5 492 820

=ARRONDI.SUP([Colonne1], 5-NBCAR(ENT([Colonne1])))

Arrondit le nombre du haut à un nombre supérieur à 5 chiffres significatifs (5 492 900)

Haut de la Page

Formules Texte

Vous pouvez utiliser les formules ci-dessous pour manipuler du texte, par exemple combiner ou concaténer des valeurs de plusieurs colonnes, comparer le contenu des colonnes, supprimer des caractères ou des espaces et répéter des caractères.

Modifier la casse du texte

Pour changer la casse du texte, utilisez les fonctions MAJUSCULE, MINUSCULE ou NOMPROPRE.

Colonne1

Formule

Description (Résultat)

anette Grohsmüller

=MAJUSCULE([Colonne1])

Met tout le texte en majuscules (ANETTE GROHSMÜLLER)

anette Grohsmüller

=MINUSCULE([Colonne1])

Met tout le texte en minuscules (anette grohsmüller)

anette Grohsmüller

=NOMPROPRE([Colonne1])

Met la première lettre des mots en majuscules (Anette Grohsmüller)

Combiner le prénom et le nom

Pour combiner le nom et le prénom, utilisez l'opérateur & ou la fonction CONCATENER.

Colonne1

Colonne2

Formule

Description (Résultat)

Carlos

Carvallo

=[Colonne1]&[Colonne2]

Combine les deux chaînes (CarlosCarvallo)

Carlos

Carvallo

=[Colonne1]&" "&[Colonne2]

Combine les deux chaînes, séparées par un espace (Carlos Carvallo)

Carlos

Carvallo

=[Colonne2]&", "&[Colonne1]

Combine les deux chaînes, séparées par une virgule et un espace (Carvallo, Carlos)

Carlos

Carvallo

=CONCATENER([Colonne2], ",", [Colonne1])

Combine les deux chaînes, séparées par une virgule (Carvallo,Carlos)

Combiner le texte et les nombres de différentes colonnes

Pour combiner du texte et des nombres, utilisez la fonction CONCATENER, l'opérateur & ou la fonction TEXTE et l'opérateur &.

Colonne1

Colonne2

Formule

Description (Résultat)

Yang

28

=[Colonne1]&" vendues "&[Colonne2]&" unités."

Combine les éléments ci-dessus pour former une expression (Yang a vendu 28 unités.)

Dubois

40 %

=[Colonne1]&" vendues "&TEXT([Colonne2],"0%")&" des ventes totales."

Combine les éléments ci-dessus pour former une expression (Dubois a vendu 40 % des ventes totales.)

Remarque : La fonction TEXTE ajoute la valeur mise en forme de Colonne2 au lieu de la valeur sous-jacente (0,4).

Yang

28

=CONCATENER([Colonne1]," vendues ",[Colonne2]," unités.")

Combine les éléments ci-dessus pour former une expression (Yang a vendu 28 unités.)

Combiner du texte avec une date ou heure

Pour combiner du texte avec une date ou une heure, utilisez la fonction TEXTE et l'opérateur &.

Colonne1

Colonne2

Formule

Description (Résultat)

Date de facturation

5-juin-2007

="Date du relevé: "&TEXTE([Colonne2], "d-mmm-yyyy")

Combine le texte avec une date (Date du relevé : 5-juin-2007)

Date de facturation

5-juin-2007

=[Colonne1]&" "&TEXTE([Colonne2], "mmm-dd-yyyy")

Combiner dans une colonne le texte et la date contenus dans différentes colonnes (Date de facturation 5-juin-2007)

Comparer le contenu des colonnes

Pour comparer une colonne à une autre colonne ou à une liste de valeurs, utilisez les fonctions EXACT et OU.

Colonne1

Colonne2

Formule

Description (résultat possible)

BD122

BD123

=EXACT([Colonne1],[Colonne2])

Compare le contenu des deux premières colonnes (Non)

BD122

BD123

=EXACT([Colonne1], "BD122")

Compare le contenu de Colonne1 et de la chaîne "BD122" (Oui)

Déterminer si une valeur de colonne ou une partie de celle-ci correspond à un texte spécifique

Pour vérifier si une valeur ou une partie d'une colonne correspond à un texte spécifique, utilisez les fonctions SI, TROUVE, CHERCHE et ESTNUM.

Colonne1

Formule

Description (résultat possible)

Grohsmüller

=SI([Colonne1]="Grohsmüller", "OK", "Pas OK")

Vérifie si Colonne1 est Grohsmüller (OK)

Grohsmüller

=SI(ESTNUM(TROUVE("h",[Colonne1])), "OK", "Pas OK")

Vérifie si Colonne1 contient la lettre h (OK)

BD123

=ESTNUM(TROUVE("BD",[Colonne1]))

Vérifie si Colonne1 contient BD (Oui)

Compter les colonnes non vides

Pour compter les colonnes non vides, utilisez la fonction NBVAL.

Colonne1

Colonne2

Colonne3

Formule

Description (Résultat)

Ventes

19

=NBVAL([Colonne1], [Colonne2])

Compte le nombre de colonnes non vides (2)

Ventes

19

=NBVAL([Colonne1], [Colonne2], [Colonne3])

Compte le nombre de colonnes non vides (2)

Supprimer les caractères de texte

Pour supprimer des caractères d'un texte, utilisez les fonctions NBCAR, GAUCHE et DROITE.

Colonne1

Formule

Description (Résultat)

Vitamine A

=GAUCHE([Colonne1],NBCAR([Colonne1])-2)

Renvoie 7 (9-2) caractères, à partir de la gauche (Vitamin)

Vitamine B1

=DROITE([Colonne1], NBCAR([Colonne1])-8)

Renvoie 2 (10-8) caractères, à partir de la droite (B1)

Supprimer les espaces de début et fin d’une colonne

Pour supprimer des espaces d'une colonne, utilisez la fonction SUPPRESPACE.

Colonne1

Formule

Description (Résultat)

Bonjour !

=SUPPRESPACE([Colonne1])

Supprime les espaces au début et à la fin de la chaîne (Bonjour !)

Répéter un caractère dans une colonne

Pour répéter un caractère dans une colonne, utilisez la fonction REPT.

Formule

Description (Résultat)

=REPT(".",3)

Répète un point (.) 3 fois (...)

=REPT("-",10)

Répète un tiret (-) 10 fois (----------)

Haut de la Page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×