Envoyer des données de formulaire vers une base de données Microsoft SQL Server

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Contenu de cet article

Vue d’ensemble

Étape 1 : Activer la connexion de données

Étape 2 : Configurer les options d’envoi

Présentation

Lorsque vous créez un modèle de formulaire reposant sur une base de données Microsoft SQL Server, l'Assistant Connexion de données active une connexion de données d'envoi à la base de données si les conditions suivantes sont remplies :

  • Les formulaires basés sur ce modèle doivent être remplis avec Microsoft Office InfoPath (ceux remplis dans un navigateur Web ne pourront pas être soumis directement à la base de données). Pour configurer un modèle de formulaire compatible avec les navigateurs web pour envoyer des données à la base de données, utilisez une connexion de données qui envoie les données à un service Web fonctionnant avec la base de données.

  • La table de la base de données primaire utilisée dans la connexion de données principale contient une clé primaire, une contrainte ou un index unique.

  • Les autres tables de la base de données utilisées avec cette connexion de données principale ont une relation simple avec la table de la base de données primaire.

Si la base de données remplit ces conditions, InfoPath active la connexion de données d'envoi et ajoute un bouton Envoyer à la barre d'outils Standard et une commande Envoyer au menu Fichier dans le formulaire.

Vous pouvez décider de désactiver la connexion de données d'envoi dans l'Assistant lorsque vous créez un modèle de formulaire reposant sur une base de données. Vous pourrez rétablir la connexion à tout moment en modifiant la connexion de données principale. Cet article décrit la procédure d'activation d'une connexion de données d'envoi.

Remarque : Vous ne pouvez disposer d'une connexion de données d'envoi que sur une connexion de données principale à la base de données. Vous ne pouvez pas ajouter de connexion de données d'envoi au modèle de formulaire s'il s'agit d"une connexion de données secondaire à la base de données. Si vous souhaitez utiliser une connexion de données d'envoi à une base de données en tant que connexion de données secondaire, utilisez un service Web qui fonctionne avec la base de données, puis ajoutez une connexion de données d'envoi à ce service Web.

Une fois la connexion de données d'envoi activée, vous pouvez personnaliser les options d'envoi du modèle de formulaire de la façon suivante :

  • en modifiant le texte affiché sur le bouton Envoyer de la barre d'outils Standard et dans la commande Envoyer du menu Fichier ;

  • en modifiant les raccourcis clavier du bouton Envoyer de la barre d'outils Standard et de la commande Envoyer du menu Fichier ;

  • en créant des messages personnalisés que les utilisateurs recevront lorsqu'ils enverront les formulaires ;

  • en indiquant s'il convient de laisser le formulaire ouvert, de le fermer ou d'en ouvrir un autre (vide) une fois le formulaire envoyé.

Haut de la Page

Étape 1 : Activer la connexion de données d'envoi

  1. Dans le menu Outils, cliquez sur Connexions de données.

  2. Dans la boîte de dialogue Connexions de données, cliquez sur la connexion principale, puis sur Modifier.

  3. Dans l'Assistant Connexion de données, cliquez sur Suivant.

  4. Sur la page suivante de l'Assistant, activez la case à cocher Activer l'envoi pour cette connexion, puis cliquez sur Terminer.

Haut de la Page

Étape 2 : Configurer les options d'envoi

Une fois que vous avez activé la connexion de données d'envoi, InfoPath ajoute le bouton Envoyer à la barre d'outils Standard et la commande Envoyer au menu Fichier. InfoPath configure en outre les formulaires basés sur ce modèle pour qu'ils affichent un message après l'envoi du formulaire rempli. Ce message indique si le formulaire a bien été envoyé. Par défaut, InfoPath laisse les formulaires ouverts après envoi. Pour modifier le texte qui s'affiche sur le bouton Envoyer, ainsi que les actions postérieures à l'envoi des formulaires, procédez comme suit :

  1. Dans le menu Outils, cliquez sur Options d’envoi.

    1. Pour modifier le nom du bouton Envoyer qui s’affiche dans la barre d’outils Standard et la commande Envoyer qui s’affiche dans le menu fichier lorsque les utilisateurs rempliront le formulaire, tapez le nouveau nom dans la zone de légende dans la boîte de dialogue Options d’envoi.

      Conseil : Si vous voulez affecter un raccourci clavier à ce bouton et la commande, tapez une esperluette (&) avant le caractère que vous souhaitez utiliser comme un raccourci clavier. Par exemple, pour attribuer ALT + B que le raccourci clavier pour la commande et le bouton Envoyer, tapez & bouton Envoyer.

  2. Si vous ne souhaitez pas les personnes à utiliser une commande Envoyer ou le bouton Envoyer dans la barre d’outils Standard lorsqu’ils remplissent votre formulaire, désactivez la case à cocher Afficher l’option de menu Envoyer et le bouton Envoyer.

    1. Par défaut, une fois que les utilisateurs envoient un formulaire InfoPath laisse le formulaire ouvert et affiche un message pour indiquer si le formulaire a été envoyé. Pour modifier ce comportement par défaut, cliquez sur Avancé et effectuez l’une des opérations suivantes :

      • Pour fermer le formulaire ou créer un nouveau formulaire vide après que l’utilisateur a envoyé un formulaire complété, cliquez sur l’option souhaitée dans la liste après avoir soumettre.

      • Pour créer un message personnalisé pour indiquer si le formulaire a été envoyé, activez la case à cocher messages personnalisés utiliser et tapez vos messages dans les zones en cas de réussite et en cas d’échec.

        Conseil : Utiliser un message dans la zone en cas d’échec pour indiquer aux utilisateurs comment procéder si elles ne peuvent pas soumettre leur formulaire. Par exemple, vous pouvez suggérer que les utilisateurs enregistrement leur formulaire et contacter une personne pour obtenir des instructions supplémentaires.

      • Si vous ne souhaitez pas afficher un message après que l’utilisateur a envoyé un formulaire, désactivez la case à cocher Afficher les messages de réussite et Échec.

Haut de la Page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×