Envoyer des données de formulaire vers une base de données Microsoft Access

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Dans cet article

Présentation

Étape 1 : Activer la connexion de données d'envoi

Étape2: Configurer les options d'envoi

Présentation

Lorsque vous concevez un modèle de formulaire Microsoft Office InfoPath qui est basé sur un Microsoft Office Access (.mdb) ou une base de données Microsoft Office Access 2007 (.accdb), l'Assistant connexion de données crée une connexion de données envoi à la base de données si les conditions suivantes sont remplies.

  • Le modèle de formulaire est conçu pour que les utilisateurs doivent le remplir à l'aide d'InfoPath. Si le formulaire est rempli à l'aide d'un navigateur Web, le formulaire ne peut pas envoyer des données directement vers une base de données. Pour configurer un modèle de formulaire compatible avec les navigateurs web pour envoyer des données à une base de données, utilisez une connexion de données qui envoie des données à un service Web qui fonctionne avec la base de données.

  • La table de la base de données primaire utilisée dans la connexion de données principale contient une clé primaire, une contrainte ou un index unique.

  • Toute autre table de base de données utilisée avec cette connexion de données principale possède une relation simple et hiérarchique avec la table de base de données primaire.

  • La base de données ne contient pas de champs pouvant stocker un type de données binaires volumineuses, comme des photos, des images, des objets OLE, des pièces jointes, le type de données Mémo Office Access ou le type de données texte SQL.

Si la base de données répond à ces exigences, InfoPath crée la connexion de données d'envoi et ajoute un bouton Envoyer à la barre d'outils Standard, ainsi qu'une commande Envoyer au menu Fichier sur le formulaire.

Remarque : Les connexions de données secondaires ne peuvent pas envoyer de données vers une base de données. Si vous voulez utiliser une connexion de données d'envoi vers une base de données en tant que connexion de données secondaire, identifiez un service Web qui fonctionne avec la base de données, puis ajoutez une connexion de données d'envoi à ce service Web.

Une fois que vous avez activé la connexion de données d'envoi, vous pouvez personnaliser les options d'envoi pour votre modèle de formulaire de l'une des manières suivantes.

  • Modifier le texte qui s'affiche sur le bouton Envoyer dans la barre d'outils Standard et la commande Envoyer dans le menu fichier.

  • Modifier les raccourcis clavier pour le bouton Envoyer dans la barre d'outils Standard et la commande Envoyer dans le menu fichier.

  • en créant des messages personnalisés que les utilisateurs recevront lorsqu'ils enverront les formulaires ;

  • en indiquant s'il convient de laisser le formulaire ouvert, de le fermer ou d'en ouvrir un autre (vide) une fois le formulaire envoyé.

Haut de la page

Étape 1 : Activer la connexion de données d'envoi

  1. Dans le menu Outils, cliquez sur Connexions de données.

  2. Dans la boîte de dialogue Connexions de données, cliquez sur la connexion principale, puis sur Modifier.

  3. Dans l'Assistant Connexion de données, cliquez sur Suivant.

  4. Sur la page suivante de l'Assistant, activez la case à cocher Activer l'envoi pour cette connexion, puis cliquez sur Terminer.

Haut de la page

Étape 2 : Configurer les options d'envoi

Après avoir activé la connexion de données, InfoPath ajoute un bouton Envoyer à la barre d'outils Standard et une commande Envoyer au menu fichier. InfoPath configure également les formulaires basés sur ce modèle de formulaire pour afficher un message aux utilisateurs après son envoi leurs formulaires complétés. Ce message indique si le formulaire a été envoyé. Par défaut, InfoPath laisse le formulaire ouvert après a été envoyé par un utilisateur. Pour modifier le texte qui s'affiche sur le bouton Envoyer, ainsi que le comportement qui se produit après l'envoi des formulaires, procédez comme suit :

  1. Dans le menu Outils, cliquez sur Options d'envoi.

    1. Pour modifier le nom du bouton Envoyer qui s'affiche dans la barre d'outils Standard et la commande Envoyer qui s'affiche dans le menu fichier lorsque les utilisateurs rempliront le formulaire, tapez le nouveau nom dans la zone de légende dans la boîte de dialogue Options d'envoi.

      Conseil : Si vous voulez affecter un raccourci clavier à ce bouton et la commande, tapez une esperluette (&) avant le caractère que vous souhaitez utiliser comme un raccourci clavier. Par exemple, pour attribuer ALT + B que le raccourci clavier pour la commande et le bouton Envoyer, tapez Su et bouton Envoyer.

  2. Si vous ne souhaitez pas les personnes à utiliser une commande Envoyer ou le bouton Envoyer dans la barre d'outils Standard lorsqu'ils remplissent votre formulaire, désactivez la case à cocher Afficher l'option de menu Envoyer et le bouton Envoyer.

    1. Par défaut, une fois que les utilisateurs envoient un formulaire InfoPath laisse le formulaire ouvert et affiche un message pour indiquer si le formulaire a été envoyé. Pour modifier ce comportement par défaut, cliquez sur Avancé et effectuez l'une des opérations suivantes :

      • Pour fermer le formulaire ou créer un nouveau formulaire vide après que l'utilisateur a envoyé un formulaire complété, cliquez sur l'option souhaitée dans la liste après avoir soumettre.

      • Pour créer un message personnalisé pour indiquer si le formulaire a été envoyé, activez la case à cocher messages personnalisés utiliser et tapez vos messages dans les zones en cas de réussite et en cas d'échec.

        Conseil : Utiliser un message dans la zone en cas d'échec pour indiquer aux utilisateurs comment procéder si elles ne peuvent pas soumettre leur formulaire. Par exemple, vous pouvez suggérer que les utilisateurs enregistrement leur formulaire et contacter une personne pour obtenir des instructions supplémentaires.

      • Si vous ne souhaitez pas afficher un message après que l'utilisateur a envoyé un formulaire, désactivez la case à cocher Afficher les messages de réussite et Échec.

Haut de la page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×