Envoyer des données de formulaire vers plusieurs emplacements

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Vous pouvez créer un modèle de formulaire qui permette d'envoyer les données, par simple clic sur le bouton Envoyer, vers plusieurs emplacements à la fois.

Contenu de cet article

Vue d’ensemble

Étape 1 : Ajouter les connexions de données envoyer

Étape 2 : Configurer le modèle de formulaire pour permettre l’envoi

Présentation

Pour permettre aux utilisateurs d'envoyer les données de formulaire vers plusieurs emplacements, vous devez ajouter, pour chaque emplacement vers lequel vous souhaitez que les utilisateurs envoient le formulaire, une connexion de données secondaire au modèle de formulaire qui envoie les données. Une fois toutes les connexions de données d'envoi ajoutées, vous allez configurer le modèle de formulaire pour permettre aux utilisateurs d'envoyer leurs données vers plusieurs emplacements à l'aide d'une règle. Microsoft Office InfoPath ajoute par conséquent un bouton Envoyer à la barre d'outils Standard et une commande Envoyer au menu Fichier. InfoPath envoie les données du formulaire aux connexions de données secondaires en suivant l'ordre défini dans la règle. Il n'est pas possible de configurer la règle pour qu'elle utilise toutes les connexions d'envoi en même temps.

Lorsque vous configurez le modèle de formulaire pour permettre aux utilisateurs d'envoyer les données, vous pouvez également personnaliser les options d'envoi avec l'une des méthodes suivantes :

  • en modifiant le texte affiché sur le bouton Envoyer de la barre d'outils Standard et dans la commande Envoyer du menu Fichier ;

  • en modifiant les raccourcis clavier du bouton Envoyer de la barre d'outils Standard et de la commande Envoyer du menu Fichier ;

  • en créant des messages personnalisés que les utilisateurs recevront lorsqu'ils enverront les formulaires ;

  • en indiquant s'il convient de laisser le formulaire ouvert, de le fermer ou d'en ouvrir un autre (vide) une fois le formulaire envoyé.

Haut de la Page

Étape 1 : Ajouter les connexions de données d'envoi

Pour configurer le modèle de formulaire afin qu'il permette aux utilisateurs d'envoyer les formulaires remplis vers plusieurs emplacements, ajoutez les connexions de données d'envoi requises au modèle de formulaire. Vous pouvez ajouter des connexions de données aux éléments suivants :

  • service Web ;

  • bibliothèque de documents sur un serveur exécutant Microsoft Windows SharePoint Services ;

  • message électronique.

    Remarque : Microsoft Office Outlook doit être installé pour pouvoir envoyer les données des formulaires sous forme de message électronique.

Les procédures suivantes expliquent comment ajouter des connexions de données d'envoi à ces emplacements.

Ajouter une connexion de données qui envoie des données à un service Web

  1. Dans le menu Outils, cliquez sur Connexions de données.

  2. Dans la boîte de dialogue Connexions de données, cliquez sur Ajouter.

  3. Dans l'Assistant Connexion de données, cliquez sur Créer une nouvelle connexion, puis sur Envoyer les données et enfin, sur Suivant.

  4. Sur la page suivante de l'Assistant, cliquez sur Vers un service Web, puis cliquez sur Suivant.

  5. Sur la page suivante de l'Assistant, tapez l'emplacement du service Web vers lequel les utilisateurs enverront les formulaires, puis cliquez sur Suivant.

    Si vous souhaitez rechercher un serveur UDDI (Universal Description, Discovery, and Integration), cliquez sur Rechercher sur UDDI, tapez le nom du serveur UDDI à rechercher, indiquez si la recherche doit être effectuée par fournisseur ou selon les services fournis, tapez un mot clé de recherche, puis cliquez sur Rechercher. Les services Web qui correspondent à votre mot clé de recherche s'afficheront dans la liste Résultats de la recherche.

  6. Sur la page suivante de l'Assistant, dans la liste Sélectionnez une opération, cliquez sur le service Web qui recevra les données de formulaire, puis cliquez sur Suivant.

  7. À la page suivante de l'Assistant, effectuez l'une des opérations suivantes :

    Envoyer les données dans un champ ou un groupe

    1. Dans la liste Paramètres, cliquez sur un paramètre du service Web qui recevra les données du formulaire.

    2. Dans Options de paramètre, cliquez sur Champ ou groupe.

    3. Cliquez sur Modifier Image du bouton .

    4. Dans la boîte de dialogue Sélectionner un champ ou un groupe, cliquez sur le champ ou groupe dont vous souhaitez envoyer les données, puis cliquez sur OK.

    5. Dans la zone Inclure, cliquez sur Texte et éléments enfants uniquement pour envoyer uniquement le contenu et les éléments enfants du champ ou du groupe, ou cliquez sur Sous-arborescence XML comprenant l'élément sélectionné pour envoyer à la fois le contenu ainsi que le champ ou le groupe sélectionné.

    Envoyer toutes les données dans le formulaire

    1. Cliquez sur Formulaire entier (document XML avec instructions de traitement).

    Envoyer les données sous forme de chaîne

    1. Activez la case à cocher Envoyer les données sous forme de chaîne.

      En général, cette case à cocher est activée pour envoyer des données de signature numérique. Dans la plupart des cas, désactivez cette case à cocher.

  8. Cliquez sur Suivant.

  9. Dans la page suivante de l’Assistant, dans la zone Entrez un nom pour cette connexion de données, tapez un nom descriptif pour ce soumettre la connexion de données.

  10. Vérifiez l'exactitude des informations de la zone Résumé, puis cliquez sur Terminer.

Ajouter une connexion de données pour envoyer des données vers une bibliothèque de documents

  1. Dans le menu Outils, cliquez sur Connexions de données.

  2. Dans la boîte de dialogue Connexions de données, cliquez sur Ajouter.

  3. Dans l'Assistant Connexion de données, cliquez sur Créer une nouvelle connexion, puis sur Envoyer les données et enfin, sur Suivant.

  4. Sur la page suivante de l'Assistant, cliquez Vers une bibliothèque de documents sur un site SharePoint, puis cliquez sur Suivant.

  5. Sur la page suivante de l'Assistant, dans la zone Bibliothèque de documents, tapez l'emplacement de la bibliothèque de documents SharePoint.

  6. Dans la zone Nom de fichier, tapez un nom destiné à identifier le formulaire dans la bibliothèque de documents. Vous pouvez aussi utiliser une formule pour garantir que les noms des formulaires soient tous uniques.

    Procédure

    1. Cliquez sur Insérer une formule Bouton Formule .

    2. Dans la boîte de dialogue Insérer une formule, effectuez l'une des opérations suivantes :

      • Pour utiliser un champ dans la formule, cliquez sur Insérer un champ ou un groupe, cliquez sur le champ que vous souhaitez utiliser dans la boîte de dialogue Sélectionner un champ ou un groupe, puis cliquez sur OK.

      • Pour utiliser une fonction dans la formule, cliquez sur Insérer une fonction, sélectionnez la fonction que vous souhaitez utiliser dans la boîte de dialogue Insérer une fonction, puis cliquez sur OK.

        Si la fonction requiert des paramètres, sélectionnez la fonction dans la boîte de dialogue Insérer une fonction, cliquez sur OK puis, dans la zone Formule de la boîte de dialogue Insérer une formule, double-cliquez sur la fonction que vous avez ajoutée, puis cliquez sur un champ ou un groupe. Pour plus d'informations, reportez-vous à la section Voir aussi.

      • Pour insérer une valeur ou un opérateur mathématique dans la formule, tapez la valeur ou le symbole de l'opération mathématique dans la zone Formule.

    Opération

    Symbole

    Addition

    +

    Soustraction

    -

    Multiplication

    *

    Division

    /

    • Remarque : Si votre formule se sert de l'opérateur de division (/), vérifiez qu'un espace est présent avant et après l'opérateur. Dans le cas contraire, InfoPath risque d'interpréter « / » comme séparateur d'étapes d'emplacements XPath plutôt que comme opérateur de division.

    • Pour vérifier si la syntaxe de la formule est correcte, dans la boîte de dialogue Insérer une formule, cliquez sur Vérifier la formule.

      Pour plus d'informations sur les formules, reportez-vous à la section Voir aussi.

  7. Pour remplacer des formulaires existants portant le même nom dans la bibliothèque de documents, activez la case à cocher Remplacer le fichier s'il existe.

  8. Cliquez sur Suivant.

  9. Dans la page suivante de l’Assistant, dans la zone Entrez un nom pour cette connexion de données, tapez un nom descriptif pour ce soumettre la connexion de données.

  10. Vérifiez l'exactitude des informations de la zone Résumé, puis cliquez sur Terminer.

Ajouter une connexion de données qui envoie les données dans un message électronique

  1. Dans le menu Outils, cliquez sur Connexions de données.

  2. Dans la boîte de dialogue Connexions de données, cliquez sur Ajouter.

  3. Dans l'Assistant Connexion de données, cliquez sur Créer une nouvelle connexion, puis sur Envoyer les données et enfin, sur Suivant.

  4. Sur la page suivante de l'Assistant, cliquez sur En tant que message électronique, puis cliquez sur Suivant.

  5. Sur la page suivante de l'Assistant, tapez les adresses de messagerie des destinataires du message, l'objet qui doit apparaître dans le message et un texte d'introduction dans les zones appropriées, puis cliquez sur Suivant. Vous pouvez également utiliser une formule dans chaque zone, sauf la zone Introduction.

    Procédure

    1. Cliquez sur Insérer une formule Bouton Formule .

    2. Dans la boîte de dialogue Insérer une formule, effectuez l'une des opérations suivantes :

      • Pour utiliser un champ dans la formule, cliquez sur Insérer un champ ou un groupe, cliquez sur le champ que vous souhaitez utiliser dans la boîte de dialogue Sélectionner un champ ou un groupe, puis cliquez sur OK.

      • Pour utiliser une fonction dans la formule, cliquez sur Insérer une fonction, sélectionnez la fonction que vous souhaitez utiliser dans la boîte de dialogue Insérer une fonction, puis cliquez sur OK.

        Si la fonction requiert des paramètres, sélectionnez la fonction dans la boîte de dialogue Insérer une fonction, cliquez sur OK puis, dans la zone Formule de la boîte de dialogue Insérer une formule, double-cliquez sur la fonction que vous avez ajoutée, puis cliquez sur un champ ou un groupe. Pour plus d'informations, reportez-vous à la section Voir aussi.

      • Pour insérer une valeur ou un opérateur mathématique dans la formule, tapez la valeur ou le symbole de l'opération mathématique dans la zone Formule.

    Opération

    Symbole

    Addition

    +

    Soustraction

    -

    Multiplication

    *

    Division

    /

    • Remarque : Si votre formule se sert de l'opérateur de division (/), vérifiez qu'un espace est présent avant et après l'opérateur. Dans le cas contraire, InfoPath risque d'interpréter « / » comme séparateur d'étapes d'emplacements XPath plutôt que comme opérateur de division.

    • Pour vérifier si la syntaxe de la formule est correcte, dans la boîte de dialogue Insérer une formule, cliquez sur Vérifier la formule.

      Pour plus d'informations sur les formules, reportez-vous à la section Voir aussi.

  6. À la page suivante de l'Assistant, effectuez l'une des opérations suivantes :

    1. Pour afficher le formulaire dans le corps du message électronique, cliquez sur Envoyer uniquement la vue active du formulaire sans pièce jointe.

    2. Pour envoyer les données de formulaire en tant que pièce jointe au message électronique, cliquez sur Envoyer les données du formulaire en tant que pièce jointe, activez la case à cocher joindre le modèle de formulaire pour garantir que les utilisateurs pourront ouvrir le formulaire et tapez un nom pour le formulaire dans la zone Nom de la pièce jointe. Vous pouvez également spécifier un champ ou utiliser une formule pour vous assurer que chaque nom de formulaire est unique. Cette option est disponible uniquement si le modèle de formulaire est configuré pour déterminer automatiquement le niveau de sécurité ou est configuré pour le niveau de sécurité restreint ou la confiance totale.

      Procédure

      1. Cliquez sur Insérer une formule Bouton Formule .

      2. Dans la boîte de dialogue Insérer une formule, effectuez l'une des opérations suivantes :

        • Pour utiliser un champ dans la formule, cliquez sur Insérer un champ ou un groupe, cliquez sur le champ que vous souhaitez utiliser dans la boîte de dialogue Sélectionner un champ ou un groupe, puis cliquez sur OK.

        • Pour utiliser une fonction dans la formule, cliquez sur Insérer une fonction, sélectionnez la fonction que vous souhaitez utiliser dans la boîte de dialogue Insérer une fonction, puis cliquez sur OK.

          Si la fonction requiert des paramètres, sélectionnez la fonction dans la boîte de dialogue Insérer une fonction, cliquez sur OK puis, dans la zone Formule de la boîte de dialogue Insérer une formule, double-cliquez sur la fonction que vous avez ajoutée, puis cliquez sur un champ ou un groupe. Pour plus d'informations, reportez-vous à la section Voir aussi.

        • Pour insérer une valeur ou un opérateur mathématique dans la formule, tapez la valeur ou le symbole de l'opération mathématique dans la zone Formule.

      Opération

      Symbole

      Addition

      +

      Soustraction

      -

      Multiplication

      *

      Division

      /

      • Remarque : Si votre formule se sert de l'opérateur de division (/), vérifiez qu'un espace est présent avant et après l'opérateur. Dans le cas contraire, InfoPath risque d'interpréter « / » comme séparateur d'étapes d'emplacements XPath plutôt que comme opérateur de division.

      • Pour vérifier si la syntaxe de la formule est correcte, dans la boîte de dialogue Insérer une formule, cliquez sur Vérifier la formule.

        Pour plus d'informations sur les formules, reportez-vous à la section Voir aussi.

      Les destinataires des données envoyées sous forme de pièce jointe ne peuvent ouvrir celle-ci que s'ils ont installé InfoPath sur leur ordinateur.

  7. Cliquez sur Suivant.

  8. Dans la page suivante de l’Assistant, dans la zone Entrez un nom pour cette connexion de données, tapez un nom descriptif pour ce soumettre la connexion de données.

  9. Vérifiez l'exactitude des informations de la zone Résumé, puis cliquez sur Terminer.

Haut de la Page

Étape 2 : Configurer le modèle de formulaire pour permettre l'envoi

Après avoir ajouté les connexions de données secondaires requises au modèle de formulaire, vous allez configurer ce dernier pour permettre aux utilisateurs d'envoyer leurs données. InfoPath ajoute alors une commande Envoyer au menu Fichier et un bouton de même nomà la barre d'outils Standard lorsque les utilisateurs remplissent le formulaire. Vous pouvez configurer l'action déclenchée par un clic sur le bouton Envoyer. Dans ce cas, vous devez ajouter une règle qui envoie les données du formulaire à chaque connexion de données d'envoi lorsqu'un utilisateur clique sur la commande Envoyer du menu Fichier ou sur le bouton Envoyer de la barre d'outils Standard.

Vous pouvez configurer les options d'envoi dans la même boîte de dialogue.

  1. Dans le menu Outils, cliquez sur Options d’envoi.

  2. Dans la boîte de dialogue Options d’envoi, activez la case à cocher Autoriser les utilisateurs à envoyer ce formulaire.

    Lorsque vous activez cette case à cocher, InfoPath ajoute un bouton Envoyer à la barre d'outils Standard et une commande Envoyer au menu Fichier lorsque les utilisateurs remplissent le formulaire.

  3. Cliquez sur Effectuer une action personnalisée à l'aide des règles, puis cliquez sur Règles.

  4. Dans la boîte de dialogue Règles pour l'envoi de formulaires, cliquez sur Ajouter.

  5. Cliquez sur Ajouter une action.

  6. Dans la zone Action, cliquez sur Envoyer via une connexion de données, cliquez sur la connexion de données que vous souhaitez utiliser pour cette action d'envoi dans la liste Connexion de données, puis cliquez sur OK.

  7. Répétez les étapes 5 et 6 pour chaque connexion de données d'envoi que vous avez ajoutée au modèle de formulaire.

  8. Une fois ajoutées les conditions pour toutes les connexions, cliquez deux fois sur OK.

    1. Pour modifier le nom du bouton Envoyer qui s’affiche dans la barre d’outils Standard et la commande Envoyer qui s’affiche dans le menu fichier lorsque les utilisateurs rempliront le formulaire, tapez le nouveau nom dans la zone de légende dans la boîte de dialogue Options d’envoi.

      Si vous voulez affecter un raccourci clavier à ce bouton et la commande, tapez une esperluette (&) avant le caractère que vous souhaitez utiliser comme un raccourci clavier. Par exemple, pour attribuer ALT + B que le raccourci clavier pour la commande et le bouton Envoyer, tapez & bouton Envoyer.

  9. Pour empêcher les utilisateurs d'activer la commande Envoyer ou le bouton Envoyer de la barre d'outils Standard pendant qu'ils remplissent le formulaire, désactivez la case à cocher Afficher l'option de menu Envoyer et le bouton Envoyer de la barre d'outils.

    1. Par défaut, une fois que les utilisateurs envoient un formulaire InfoPath laisse le formulaire ouvert et affiche un message pour indiquer si le formulaire a été envoyé. Pour modifier ce comportement par défaut, cliquez sur Avancé et effectuez l’une des opérations suivantes :

      • Pour fermer le formulaire ou créer un nouveau formulaire vide après que l’utilisateur a envoyé un formulaire complété, cliquez sur l’option souhaitée dans la liste après avoir soumettre.

      • Pour créer un message personnalisé pour indiquer si le formulaire a été envoyé, activez la case à cocher messages personnalisés utiliser et tapez vos messages dans les zones en cas de réussite et en cas d’échec.

        Utiliser un message dans la zone en cas d’échec pour indiquer aux utilisateurs comment procéder si elles ne peuvent pas soumettre leur formulaire. Par exemple, vous pouvez suggérer que les utilisateurs enregistrement leur formulaire et contacter une personne pour obtenir des instructions supplémentaires.

      • Si vous ne souhaitez pas afficher un message après que l’utilisateur a envoyé un formulaire, désactivez la case à cocher Afficher les messages de réussite et Échec.

Haut de la Page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×