Envoyer des données de formulaire dans une bibliothèque SharePoint

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Vous pouvez stocker et organiser tous les formulaires de vos utilisateurs en une bibliothèque de documents sur un serveur exécutant Microsoft Windows SharePoint Services. Dans cette bibliothèque, les utilisateurs peuvent remplir des formulaires basés sur votre modèle, exporter les données des formulaires remplis vers Microsoft Office Excel 2003 ou Microsoft Office Excel 2007 et fusionner les données de plusieurs formulaires en un seul formulaire.

Pour autoriser les utilisateurs à envoyer des formulaires basés sur votre modèle vers une bibliothèque de documents, vous pouvez ajouter une connexion de données secondaire au modèle de formulaire qui envoie les données. La connexion de données d'envoi ajoutée, vous pouvez configurer le modèle de formulaire pour qu'il autorise vos utilisateurs à soumettre leurs données de formulaire vers la bibliothèque de documents. Microsoft Office InfoPath ajoute alors un bouton Envoyer à la barre d'outils Standard et une commande Envoyer au menu Fichier dans le formulaire. Vous pouvez également personnaliser les options d'envoi avec l'une des méthodes suivantes :

  • en modifiant le texte affiché sur le bouton Envoyer de la barre d'outils Standard et dans la commande Envoyer du menu Fichier ;

  • en modifiant les raccourcis clavier du bouton Envoyer de la barre d'outils Standard et de la commande Envoyer du menu Fichier ;

  • en créant des messages personnalisés que les utilisateurs recevront lorsqu'ils enverront les formulaires ;

  • en indiquant s'il convient de laisser le formulaire ouvert, de le fermer ou d'en ouvrir un autre (vide) une fois le formulaire envoyé.

Ajouter une connexion de données d'envoi

  1. Dans le menu Outils, cliquez sur Options d'envoi.

  2. Dans la boîte de dialogue Options d'envoi, activez la case à cocher Autoriser les utilisateurs à envoyer ce formulaire.

  3. Cliquez sur Envoyer les données du formulaire vers une seule destination, puis cliquez sur Bibliothèque de documents SharePoint dans la liste.

  4. Cliquez sur Ajouter.

  5. Dans l'Assistant Connexion de données, dans la zone Bibliothèque de documents, tapez l'emplacement de la bibliothèque de documents SharePoint.

  6. Dans la zone Nom de fichier, tapez un nom destiné à identifier le formulaire dans la bibliothèque de documents.

    Conseil : Vous pouvez aussi utiliser une formule pour garantir que les noms des formulaires soient tous uniques.

    Comment ?

    1. Cliquez sur Insérer une formule Bouton Formule .

    2. Dans la boîte de dialogue Insérer une formule, effectuez l'une des opérations suivantes :

      • Pour utiliser un champ dans la formule, cliquez sur Insérer un champ ou un groupe, cliquez sur le champ que vous souhaitez utiliser dans la boîte de dialogue Sélectionner un champ ou un groupe, puis cliquez sur OK.

      • Pour utiliser une fonction dans la formule, cliquez sur Insérer une fonction, sélectionnez la fonction que vous souhaitez utiliser dans la boîte de dialogue Insérer une fonction, puis cliquez sur OK.

        Conseil : Si la fonction requiert des paramètres, sélectionnez la fonction dans la boîte de dialogue Insérer une fonction, cliquez sur OK puis, dans la zone Formule de la boîte de dialogue Insérer une formule, double-cliquez sur la fonction que vous avez ajoutée, puis cliquez sur un champ ou un groupe. Pour plus d'informations, reportez-vous à la section Voir aussi.

      • Pour insérer une valeur ou un opérateur mathématique dans la formule, tapez la valeur ou le symbole de l'opération mathématique dans la zone Formule.

    Opération

    Symbole

    Addition

    +

    Soustraction

    -

    Multiplication

    *

    Division

    /

    • Remarque : Si votre formule se sert de l'opérateur de division (/), vérifiez qu'un espace est présent avant et après l'opérateur. Dans le cas contraire, InfoPath risque d'interpréter « / » comme séparateur d'étapes d'emplacements XPath plutôt que comme opérateur de division.

    • Pour vérifier si la syntaxe de la formule est correcte, dans la boîte de dialogue Insérer une formule, cliquez sur Vérifier la formule.

      Pour plus d'informations sur les formules, reportez-vous à la section Voir aussi.

  7. Pour remplacer des formulaires existants portant le même nom dans la bibliothèque de documents, activez la case à cocher Remplacer le fichier s'il existe.

  8. Cliquez sur Suivant.

  9. Dans la page suivante de l'Assistant, dans la zone Entrez un nom pour cette connexion de données, tapez un nom descriptif pour ce soumettre la connexion de données.

  10. Vérifiez l'exactitude des informations de la zone Résumé, puis cliquez sur Terminer.

    1. Pour modifier le nom du bouton Envoyer qui s'affiche dans la barre d'outils Standard et la commande Envoyer qui s'affiche dans le menu fichier lorsque les utilisateurs rempliront le formulaire, tapez le nouveau nom dans la zone de légende dans la boîte de dialogue Options d'envoi.

      Conseil : Si vous voulez affecter un raccourci clavier à ce bouton et la commande, tapez une esperluette (&) avant le caractère que vous souhaitez utiliser comme un raccourci clavier. Par exemple, pour attribuer ALT + B que le raccourci clavier pour la commande et le bouton Envoyer, tapez & bouton Envoyer.

  11. Si vous ne souhaitez pas les personnes à utiliser une commande Envoyer ou le bouton Envoyer dans la barre d'outils Standard lorsqu'ils remplissent votre formulaire, désactivez la case à cocher Afficher l'option de menu Envoyer et le bouton Envoyer.

    1. Par défaut, une fois que les utilisateurs envoient un formulaire InfoPath laisse le formulaire ouvert et affiche un message pour indiquer si le formulaire a été envoyé. Pour modifier ce comportement par défaut, cliquez sur Avancé et effectuez l'une des opérations suivantes :

      1. Pour fermer le formulaire ou créer un nouveau formulaire vide après que l'utilisateur a envoyé un formulaire complété, cliquez sur l'option souhaitée dans la liste après avoir soumettre.

      2. Pour créer un message personnalisé pour indiquer si le formulaire a été envoyé, activez la case à cocher messages personnalisés utiliser et tapez vos messages dans les zones en cas de réussite et en cas d'échec.

        Conseil : Utiliser un message dans la zone en cas d'échec pour indiquer aux utilisateurs comment procéder si elles ne peuvent pas soumettre leur formulaire. Par exemple, vous pouvez suggérer que les utilisateurs enregistrement leur formulaire et contacter une personne pour obtenir des instructions supplémentaires.

      3. Si vous ne souhaitez pas afficher un message après que l'utilisateur a envoyé un formulaire, désactivez la case à cocher Afficher les messages de réussite et Échec.

Haut de la page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×