Envoyer des données de formulaire dans un message électronique

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Vous pouvez ajouter une connexion de données d'envoi secondaire à votre modèle de formulaire, qui permettra d'envoyer les données du formulaire dans un message électronique. Pour spécifier les adresses de messagerie auxquelles sera envoyé le formulaire, l'objet du message et le nom du formulaire, vous pouvez utiliser des valeurs statiques, des valeurs basées sur les données du formulaire, ou encore une formule. Vous pouvez en outre spécifier si vous souhaitez que le formulaire apparaisse dans le corps du message ou en tant que pièce jointe.

Si vous configurez le modèle pour que le formulaire soit envoyé en tant que pièce jointe au message, vous pouvez également joindre le modèle de formulaire au message électronique. En intégrant le formulaire et son modèle comme pièces jointes au message électronique, vous vous assurez que les destinataires du message pourront ouvrir le formulaire dans Microsoft Office InfoPath, même s'ils ne disposent pas du modèle du formulaire dans leur mémoire cache. Pour que les destinataires puissent ouvrir les pièces jointes, ils doivent disposer d'InfoPath.

Lorsque des utilisateurs envoient des données de formulaire dans un message électronique, InfoPath crée un message contenant ces données et l'envoie aux destinataires que vous avez indiqués à la création de la connexion de données. Si les personnes qui reçoivent les formulaires utilisent Microsoft Office Outlook 2007, elles peuvent ajouter un dossier à leur boîte de réception, destiné à contenir tous les formulaires InfoPath entrants, et configuré pour qu'il affiche les données des formulaires sous forme de colonnes dans Outlook.

Après avoir ajouté la connexion de données d'envoi, configurez votre modèle de formulaire pour permettre aux utilisateurs d'envoyer les données de formulaire. Lorsque les utilisateurs ouvrent le formulaire, InfoPath ajoute automatiquement un bouton Envoyer à la barre d'outils Standard et une commande Envoyer au menu Fichier. Vous pouvez également personnaliser les options d'envoi en optant pour l'une des méthodes suivantes :

  • en modifiant le texte affiché sur le bouton Envoyer de la barre d'outils Standard et dans la commande Envoyer du menu Fichier ;

  • en modifiant les raccourcis clavier du bouton Envoyer de la barre d'outils Standard et de la commande Envoyer du menu Fichier ;

  • en créant des messages personnalisés que les utilisateurs recevront lorsqu'ils enverront les formulaires ;

  • en indiquant s'il convient de laisser le formulaire ouvert, de le fermer ou d'en ouvrir un autre (vide) une fois le formulaire envoyé.

Haut de la page

Ajouter une connexion de données d'envoi

  1. Dans le menu Outils, cliquez sur Options d'envoi.

  2. Dans la boîte de dialogue Options d'envoi, activez la case à cocher Autoriser les utilisateurs à envoyer ce formulaire.

  3. Cliquez sur Envoyer les données du formulaire vers une seule destination puis, dans la liste, cliquez sur Message électronique.

  4. Cliquez sur Ajouter.

  5. Dans les zones appropriées de l'Assistant Connexion de données, tapez les adresses de messagerie des destinataires, l'objet qui doit apparaître dans le message et le cas échéant un texte de présentation, puis cliquez sur Suivant.

    Conseil : Vous pouvez également spécifier un champ ou utiliser une formule pour créer la valeur de chaque zone, sauf la zone Introduction.

    Comment ?

    1. Cliquez sur Insérer une formule Bouton Formule .

    2. Dans la boîte de dialogue Insérer une formule, effectuez l'une des opérations suivantes :

      • Pour utiliser un champ dans la formule, cliquez sur Insérer un champ ou un groupe, cliquez sur le champ que vous souhaitez utiliser dans la boîte de dialogue Sélectionner un champ ou un groupe, puis cliquez sur OK.

      • Pour utiliser une fonction dans la formule, cliquez sur Insérer une fonction, sélectionnez la fonction que vous souhaitez utiliser dans la boîte de dialogue Insérer une fonction, puis cliquez sur OK.

        Conseil : Si la fonction requiert des paramètres, sélectionnez la fonction dans la boîte de dialogue Insérer une fonction, cliquez sur OK puis, dans la zone Formule de la boîte de dialogue Insérer une formule, double-cliquez sur la fonction que vous avez ajoutée, puis cliquez sur un champ ou un groupe. Pour plus d'informations, reportez-vous à la section Voir aussi.

      • Pour insérer une valeur ou un opérateur mathématique dans la formule, tapez la valeur ou le symbole de l'opération mathématique dans la zone Formule.

    Opération

    Symbole

    Addition

    +

    Soustraction

    -

    Multiplication

    *

    Division

    /

    • Remarque : Si votre formule se sert de l'opérateur de division (/), vérifiez qu'un espace est présent avant et après l'opérateur. Dans le cas contraire, InfoPath risque d'interpréter « / » comme séparateur d'étapes d'emplacements XPath plutôt que comme opérateur de division.

    • Pour vérifier si la syntaxe de la formule est correcte, dans la boîte de dialogue Insérer une formule, cliquez sur Vérifier la formule.

      Pour plus d'informations sur les formules, reportez-vous à la section Voir aussi.

  6. À la page suivante de l'Assistant, effectuez l'une des opérations suivantes :

    1. Pour afficher le formulaire dans le corps du message électronique, cliquez sur Envoyer uniquement la vue active du formulaire sans pièce jointe.

    2. Pour envoyer les données du formulaire comme pièce jointe du message, cliquez sur Envoyer les données du formulaire en tant que pièce jointe, activez la case à cocher Joindre le modèle de formulaire pour garantir que les utilisateurs pourront ouvrir le formulaire, puis tapez un nom pour le formulaire dans la zone Nom de la pièce jointe. Vous pouvez également spécifier un champ ou utiliser une formule pour vérifier que chaque nom de formulaire est unique.

      Comment ?

      1. Cliquez sur Insérer une formule Bouton Formule .

      2. Dans la boîte de dialogue Insérer une formule, effectuez l'une des opérations suivantes :

        • Pour utiliser un champ dans la formule, cliquez sur Insérer un champ ou un groupe, cliquez sur le champ que vous souhaitez utiliser dans la boîte de dialogue Sélectionner un champ ou un groupe, puis cliquez sur OK.

        • Pour utiliser une fonction dans la formule, cliquez sur Insérer une fonction, sélectionnez la fonction que vous souhaitez utiliser dans la boîte de dialogue Insérer une fonction, puis cliquez sur OK.

          Conseil : Si la fonction requiert des paramètres, sélectionnez la fonction dans la boîte de dialogue Insérer une fonction, cliquez sur OK puis, dans la zone Formule de la boîte de dialogue Insérer une formule, double-cliquez sur la fonction que vous avez ajoutée, puis cliquez sur un champ ou un groupe. Pour plus d'informations, reportez-vous à la section Voir aussi.

        • Pour insérer une valeur ou un opérateur mathématique dans la formule, tapez la valeur ou le symbole de l'opération mathématique dans la zone Formule.

      Opération

      Symbole

      Addition

      +

      Soustraction

      -

      Multiplication

      *

      Division

      /

      • Remarque : Si votre formule se sert de l'opérateur de division (/), vérifiez qu'un espace est présent avant et après l'opérateur. Dans le cas contraire, InfoPath risque d'interpréter « / » comme séparateur d'étapes d'emplacements XPath plutôt que comme opérateur de division.

      • Pour vérifier si la syntaxe de la formule est correcte, dans la boîte de dialogue Insérer une formule, cliquez sur Vérifier la formule.

        Pour plus d'informations sur les formules, reportez-vous à la section Voir aussi.

      Remarque : Les personnes qui reçoivent les données de formulaire sous forme de pièce jointe dans un message électronique doivent disposer d'InfoPath sur leur ordinateur pour ouvrir cette pièce jointe.

  7. Cliquez sur Suivant.

  8. Dans la page suivante de l'Assistant, dans la zone Entrez un nom pour cette connexion de données, tapez un nom descriptif pour ce soumettre la connexion de données.

  9. Vérifiez l'exactitude des informations de la zone Résumé, puis cliquez sur Terminer.

    1. Pour modifier le nom du bouton Envoyer qui s'affiche dans la barre d'outils Standard et la commande Envoyer qui s'affiche dans le menu fichier lorsque les utilisateurs rempliront le formulaire, tapez le nouveau nom dans la zone de légende dans la boîte de dialogue Options d'envoi.

      Conseil : Si vous voulez affecter un raccourci clavier à ce bouton et la commande, tapez une esperluette (&) avant le caractère que vous souhaitez utiliser comme un raccourci clavier. Par exemple, pour attribuer ALT + B que le raccourci clavier pour la commande et le bouton Envoyer, tapez & bouton Envoyer.

  10. Si vous ne souhaitez pas les personnes à utiliser une commande Envoyer ou le bouton Envoyer dans la barre d'outils Standard lorsqu'ils remplissent votre formulaire, désactivez la case à cocher Afficher l'option de menu Envoyer et le bouton Envoyer.

    1. Par défaut, une fois que les utilisateurs envoient un formulaire InfoPath laisse le formulaire ouvert et affiche un message pour indiquer si le formulaire a été envoyé. Pour modifier ce comportement par défaut, cliquez sur Avancé et effectuez l'une des opérations suivantes :

      • Pour fermer le formulaire ou créer un nouveau formulaire vide après que l'utilisateur a envoyé un formulaire complété, cliquez sur l'option souhaitée dans la liste après avoir soumettre.

      • Pour créer un message personnalisé pour indiquer si le formulaire a été envoyé, activez la case à cocher messages personnalisés utiliser et tapez vos messages dans les zones en cas de réussite et en cas d'échec.

        Conseil : Utiliser un message dans la zone en cas d'échec pour indiquer aux utilisateurs comment procéder si elles ne peuvent pas soumettre leur formulaire. Par exemple, vous pouvez suggérer que les utilisateurs enregistrement leur formulaire et contacter une personne pour obtenir des instructions supplémentaires.

      • Si vous ne souhaitez pas afficher un message après que l'utilisateur a envoyé un formulaire, désactivez la case à cocher Afficher les messages de réussite et Échec.

Haut de la page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×