Enregistrer des macros dans Visio

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Créer une macro pour automatiser des étapes ou vous effectuez régulièrement des processus. Les commandes permettant d'enregistrer une macro sont sous l'onglet développeur.

Remarque :  Les macros peuvent déclencher des alertes de sécurité, car elles peuvent être créées et utilisées dans un but malveillant. Pour plus d’informations sur les risques posés par les macros et que faire si une alerte de sécurité s’affiche, voir Activer ou désactiver les macros dans les fichiers Office.

  1. Sous l’onglet Développeur, cliquez sur Enregistrer une macro. (Si l’onglet Développeur n’est pas affiché, voir « Afficher l’onglet Développeur » ci-dessous.)

    Commandes pour les macros

  2. Dans la zone Nom de la macro, tapez un nom pour la macro.

  3. Dans la zone Touche de raccourci, tapez une touche de raccourci à utiliser avec la touche Ctrl pour exécuter la macro.

  4. Dans la zone Enregistrer la macro dans, cliquez sur le document dans lequel vous souhaitez stocker la macro.

  5. Dans la zone Description, tapez une description pour la macro.

  6. Cliquez sur OK pour lancer l’enregistrement de la macro.

  7. Effectuez les actions que vous voulez inclure dans votre macro. Sous l’onglet Développeur, utilisez Suspendre l’enregistrement si nécessaire.

    Lorsque vous enregistrez une macro, vous pouvez utiliser la souris pour cliquer sur des commandes et des options, et pour travailler avec des formes et des objets dans vos dessins.

  8. Pour arrêter l’enregistrement de votre macro, cliquez sur Arrêter l’enregistrement sous l’onglet Développeur.

Vous pouvez interrompre ou reprendre l’enregistrement d’une macro à l’aide de la barre d’outils Enregistrement.

Pour afficher le code résultant, dans le menu Outils, pointez sur Macro, cliquez sur Macro, sur le nom de la macro, puis sur Modifier.

Afficher l’onglet Développeur

  1. Cliquez sur l’onglet Fichier, puis sur Options.

  2. Cliquez sur Personnaliser le ruban.

  3. Sous Personnaliser le ruban et Onglets principaux, activez la case à cocher Développeur.

    L’onglet Développeur s’affiche à l’extrémité du ruban à l’opposé de l’onglet Fichier.

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×