Détecter les erreurs dans les formules

Remarque : Nous faisons de notre mieux pour vous fournir le contenu d’aide le plus récent aussi rapidement que possible dans votre langue. Cette page a été traduite automatiquement et peut donc contenir des erreurs grammaticales ou des imprécisions. Notre objectif est de faire en sorte que ce contenu vous soit utile. Pouvez-vous nous indiquer en bas de page si ces informations vous ont aidé ? Voici l’article en anglais à des fins de référence aisée.

Les formules peuvent parfois renvoyer des erreurs et provoquer des résultats inattendus. Voici quelques outils que vous pouvez utiliser pour rechercher et déterminer les causes de ces erreurs et identifier des solutions.

Remarque : Cette rubrique présente des techniques qui peuvent vous aider à corriger les erreurs dans les formules. Il ne s’agit pas d’une liste de méthodes permettant de corriger toutes les erreurs imaginables. Pour obtenir de l’aide sur des erreurs spécifiques, vous pouvez rechercher des questions semblables dans le forum de la Communauté Excel ou publier votre question.

Lien vers le Forum de la Communauté Excel

Apprendre comment entrer une formule simple

Les formules sont des équations qui effectuent des calculs sur les valeurs contenues dans votre feuille de calcul. Une formule commence par un signe égal (=). Par exemple, la formule suivante additionne 3 et 1.

=3+1

Une formule peut contenir tout ou partie des éléments suivants : des fonctions, des références, des opérateurs et des constantes.

Parties d’une formule

Parties d’une formule

  1. Fonctions : inclus avec Excel, fonctions sont des formules ingénieries qui effectuent des calculs spécifiques. Par exemple, la fonction PI () renvoie la valeur de pi : 3,142...

  2. : Fait référence à des cellules individuelles ou des plages de cellules. A2 renvoie la valeur dans la cellule A2.

  3. Constantes : valeurs numériques ou de texte entrées directement dans une formule, par exemple 2.

  4. Opérateurs : l’opérateur ^ (caret) élève un nombre à une puissance et l’opérateur * (astérisque) le multiplie. Utilisez + et - pour ajouter ou soustraire des valeurs, et / pour diviser des valeurs.

    Remarque : Certaines fonctions nécessitent que sont appelé arguments. Les arguments sont les valeurs que certaines fonctions permet d’effectuer leurs calculs. Le cas échéant, les arguments sont placés entre parenthèses () de la fonction. La fonction PI ne nécessite pas de tous les arguments, c’est pourquoi il est vide. Certaines fonctions nécessitent un ou plusieurs arguments et peuvent laisser d’espace pour des arguments supplémentaires. Vous devez utiliser une virgule séparez les arguments ou un point-virgule ( ;) en fonction de vos paramètres d’emplacement.

Par exemple, la fonction SOMME ne requiert qu’un argument, mais peut accueillir jusqu’à 255 arguments.

Fonction SOMME

=SOMME(A1:A10) est un exemple d’utilisation d’un seul argument.

=SOMME(A1:A10;C1:C10) est un exemple d’utilisation de plusieurs arguments.

Le tableau suivant récapitule les erreurs qu’un utilisateur risque de rencontrer le plus fréquemment lors de la saisie d’une formule et explique comment les corriger.

Assurez-vous de

Informations complémentaires

Commencer toutes les fonctions par le signe égal (=)

Si vous ne spécifiez pas le signe égal, le contenu que vous entrez peut s’afficher sous forme de texte ou de date. Par exemple, si vous tapez SOMME(A1:A10), Excel affiche la chaîne de texte SOMME(A1:A10) et n’effectue pas le calcul. Si vous tapez 2/11, Excel affiche la date 02-nov (en partant du principe que le format de cellule est Général) au lieu de diviser 2 par 11.

Faire correspondre toutes les parenthèses ouvrantes et fermantes

Vérifiez si toutes les parenthèses font effectivement partie d’une paire (ouvrante et fermante). Lorsque vous utilisez une fonction dans une formule, chaque parenthèse doit être correctement placée. Par exemple, la formule =SI(B5<0);"Non valide";B5*1,05) ne fonctionnera pas, car elle contient deux parenthèses fermantes et une seule parenthèse ouvrante, alors qu’il ne devrait y en avoir qu’une de chaque. La formule doit se présenter comme suit : =SI(B5<0;"Non valide";B5*1,05).

Utiliser un signe deux-points pour indiquer une plage 

Lorsque vous faites référence à une plage de cellules, utilisez les deux-points (:) pour séparer, dans la plage, la référence de la première cellule de la référence de la dernière cellule. Par exemple, =SOMME(A1:A5), et non =SOMME(A1 A5) qui renverrait une erreur #NUL!.

Taper tous les arguments requis

Certaines fonctions requièrent des arguments précis. Vérifiez également que vous n’avez pas introduit trop d’arguments.

Entrer le type correct d’arguments

Certaines fonctions, telles que SOMME, requièrent des arguments numériques. D’autres fonctions, telles que REMPLACER, requièrent une valeur de texte pour au moins l’un de leurs arguments. Si vous utilisez un type de données incorrect en tant qu’argument, Excel risque de renvoyer des résultats inattendus ou d’afficher une erreur.

Ne pas imbriquer plus de 64 fonctions

Vous ne pouvez pas entrer, ou imbriquer, plus de 64 niveaux de fonctions au sein d’une fonction.

Placer d’autres noms de feuilles entre des guillemets simples

Si une formule fait référence à des valeurs ou à des cellules d’autres feuilles de calcul ou d’autres classeurs dont le nom contient des espaces ou des caractères non alphabétiques, vous devez placer une apostrophe (') de part et d’autre du nom de cette feuille de calcul ou de ce classeur (par exemple, ='Données trimestrielles'!D3 ou ='123'!A1).

Placer un point d’exclamation (!) après le nom de la feuille de calcul lorsque vous y faites référence dans une formule

Par exemple, pour renvoyer la valeur de la cellule D3 dans une feuille de calcul nommée « Données trimestrielles » dans le même classeur, utilisez cette formule : =’Données trimestrielles’!D3.

Insérer le chemin d’accès pour les classeurs externes

Vérifiez que chaque référence externe contient un nom de classeur et le chemin d’accès correspondant.

La référence à un classeur inclut le nom du classeur et doit être placée entre crochets ([NomClasseur.xlsx]). La référence doit également contenir le nom de la feuille de calcul dans le classeur.

Si le classeur auquel vous voulez faire référence n’est pas ouvert dans Excel, vous pouvez toujours inclure une référence le concernant dans une formule. Spécifiez le chemin d’accès complet au fichier, comme dans l’exemple suivant : =LIGNES('C:\Mes documents\[Opérations.xlsx T2]Ventes'!A1:A8). Cette formule renvoie le nombre de lignes de la plage qui inclut les cellules A1 à A8 dans l’autre classeur (8).

Remarque : Si le chemin d’accès complet contient des espaces, comme dans l’exemple précédent, utilisez des guillemets simples (au début du chemin d’accès et après le nom de la feuille de calcul, avant le point d’exclamation).

Saisir des nombres sans mise en forme

Ne mettez pas en forme les nombres lorsque vous les saisissez dans une formule. Par exemple, si vous devez entrer la valeur 1 000 €, entrez 1000 dans la formule. Si vous entrez une virgule dans un nombre, Excel la considère comme un caractère de séparation. Si vous souhaitez ajouter un séparateur de milliers ou de millions à un nombre, ou des symboles monétaires, mettez en forme les cellules après avoir entré les nombres.

Par exemple, si vous souhaitez additionner 3100 à la valeur de la cellule A3 et que vous entrez la formule =SOMME(3;100;A3), Excel additionne les valeurs 3 et 100, puis ajoute ce total à la valeur de A3, au lieu d’ajouter 3100 à A3 (dans ce cas, la formule serait =SOMME(3100;A3)). Autre exemple, si vous entrez la formule =ABS(-3100), Excel affiche une erreur, car la fonction ABS n’accepte qu’un seul argument : =ABS(-2134).

Vous pouvez implémenter certaines règles pour rechercher les erreurs dans les formules. Ces règles ne garantissent pas que votre feuille de calcul sera exempte d’erreurs, mais elles sont efficaces pour rechercher les erreurs courantes. Vous pouvez activer ou désactiver n’importe laquelle de ces règles individuellement.

Les erreurs peuvent être marquées et corrigées de deux façons : l’une après l’autre, à la manière d’un vérificateur d’orthographe, ou dès leur apparition dans la feuille de calcul au fur et à mesure de leur entrée.

Vous pouvez résoudre une erreur à l’aide des options qui s’affichent dans Excel ou bien l’ignorer en cliquant sur Ignorer l’erreur. Si vous choisissez de l’ignorer dans une cellule en particulier, l’erreur de cette cellule ne s’affiche plus dans les contrôles d’erreur suivants. Cependant, vous pouvez réinitialiser toutes les erreurs précédemment ignorées afin de les afficher à nouveau.

  1. Pour Excel, sur Windows, cliquez sur fichier > Options > formules, ou
    pour Excel sur Mac, cliquez sur le menu Excel > Préférences > Vérification des erreurs.

    Dans Excel 2007, cliquez sur le bouton Microsoft Office Image du bouton Office > Options Excel > Formules.

  2. Sous Vérification des erreurs, cochez Activer la vérification des erreurs d’arrière-plan. Les erreurs qui sont trouve, seront marqués avec un triangle dans le coin supérieur gauche de la cellule.

    Cellule présentant un problème de formule
  3. Pour changer la couleur du triangle qui indique où une erreur s’est produite, dans la zone Indiquer les erreurs à l’aide de cette couleur, sélectionnez la couleur souhaitée.

  4. Sous Règles de vérification d’Excel, cochez ou décochez les cases correspondant à l’une des règles suivantes :

    • Cellules dont les formules génèrent des erreurs : la formule n’utilise pas la syntaxe, les arguments ou les types de données requis. Les valeurs d’erreur comprennent les éléments #DIV/0!, #N/A, #NOM?, #NUL!, #NOMBRE!, #REF! et #VALEUR! Chacune de ces valeurs d’erreur est provoquée par un élément distinct et doit être résolue de façon spécifique.

      Remarque : Si vous entrez une valeur d’erreur directement dans une cellule, cette valeur est stockée mais n’est pas marquée comme une erreur. Toutefois, si une formule d’une autre cellule fait référence à cette cellule, elle renvoie la valeur d’erreur de cette cellule.

    • Formule de colonne calculée incohérente dans des tableaux Une colonne calculée peut inclure des formules individuelles différentes de la formule de colonne maître qui crée une exception. Des exceptions de colonne calculée sont créées lorsque vous :

      • tapez des données autres qu’une formule dans une cellule de colonne calculée.

      • Tapez une formule dans une cellule de colonne calculée, puis utilisez Ctrl + Z ou cliquez sur Annuler Bouton Annuler sur la Barre d’outils Accès rapide.

      • tapez une nouvelle formule dans une colonne calculée contenant déjà une ou plusieurs exceptions.

      • copiez des données dans la colonne calculée qui ne correspond pas à la formule de colonne calculée. Si les données copiées contiennent une formule, celle-ci remplace le contenu de la colonne calculée.

      • déplacez ou supprimez une cellule dans une autre zone de la feuille de calcul, qui est référencée par l’une des lignes d’une colonne calculée.

    • Cellules contenant des années à deux chiffres : la cellule contient une date au format texte, qui peut être mal interprétée, comme un siècle incorrect, lorsqu’elle est utilisée dans des formules. Par exemple, dans la formule =ANNEE("1/1/31"), la date peut être 1931 ou 2031. Utilisez cette règle pour contrôler les dates ambiguës.

    • Nombres mis en forme en tant que texte ou précédés d’une apostrophe : les cellules contiennent des nombres stockés en tant que texte. Cela se produit généralement lorsque les données sont importées à partir d’autres sources. Le stockage des nombres sous forme de texte peut entraîner des résultats de tri inattendus et nous vous conseillons de les stocker sous forme de nombres. '=SOMME(A1:A10) est considérée comme du texte.

    • Formules incohérentes avec d’autres formules de la zone : la formule ne correspond pas à la structure des autres formules situées à proximité. Dans de nombreux cas, les formules qui sont adjacentes à d’autres formules diffèrent uniquement par les références utilisées. Dans l’exemple suivant où quatre formules adjacentes sont représentées, Excel affiche une erreur en regard de la formule =SOMME(A10:C10) dans la cellule D4, car les formules adjacentes incrémentent d’une ligne, alors que celle-ci incrémente de 8 lignes. Excel attend la formule =SOMME(A4:C4).

      Excel affiche une erreur lorsqu’une formule ne correspond pas au modèle des formules adjacentes

      Si les références qui sont utilisées dans une formule ne sont pas cohérentes avec celles des formules adjacentes, Excel affiche une erreur.

    • Cellules omises dans une formule appliquée à une zone : une formule peut ne pas inclure automatiquement les références aux données que vous insérez entre la plage d’origine des données et la cellule contenant cette formule. Cette règle permet de comparer la référence dans une formule avec la plage de cellules adjacentes à la cellule qui contient la formule. Si les cellules adjacentes contiennent d’autres valeurs et qu’elles ne sont pas vides, Excel signale une erreur en regard de la formule.

      Par exemple, Excel insère une erreur en regard de la formule =SOMME(D2:D4) lorsque cette règle est appliquée, dans la mesure où les cellules D5, D6 et D7 sont adjacentes aux cellules qui sont référencées dans la formule et à la cellule qui contient la formule (D8), et parce que ces cellules contiennent des données qui doivent avoir été référencées dans la formule.

      Excel affiche une erreur lorsqu’une formule ignore les cellules d’une plage
    • Déverrouillée cellules contenant des formules: la formule n’est pas verrouillée pour la protection. Par défaut, toutes les cellules d’une feuille de calcul sont verrouillées afin qu’ils ne peuvent pas être modifiés lorsque la feuille de calcul est protégée. Cela permet d’éviter les erreurs par inadvertance comme accidentellement suppression ou modification des formules. Cette erreur indique que la cellule a été définie à déverrouiller, mais la feuille n’est pas protégée. Vérifiez que vous ne souhaitez pas la cellule verrouillée ou non.

    • Formules faisant référence à des cellules vides : la formule contient une référence à une cellule vide. Cela peut provoquer des résultats inattendus, comme illustré dans l’exemple suivant.

      Supposons que vous souhaitiez calculer la moyenne des nombres dans la colonne suivante de cellules. Si la troisième cellule est vide, elle n’est pas incluse dans le calcul et le résultat est 22,75. Si la troisième cellule contient 0, le résultat est 18,2.

      Excel affiche une erreur lorsqu’une formule fait référence à des cellules vides
    • Données incorrectes dans un tableau : un tableau comporte une erreur de validation. Vérifiez le paramètre de validation appliqué à la cellule en accédant à l’onglet Données > groupe Outils de données > Validation des données.

  1. Sélectionnez la feuille de calcul pour laquelle vous souhaitez vérifier les erreurs.

  2. Si la feuille de calcul est calculée manuellement, appuyez sur F9 pour la recalculer.

    Si la boîte de dialogue Vérification des erreurs n’apparaît pas, cliquez sur l’onglet Formules > Audit de formules > bouton Vérification des erreurs.

  3. Si vous avez précédemment ignoré des erreurs, vous pouvez vérifier ces erreurs à nouveau en procédant comme suit : cliquez sur fichier > Options > formules. Pour Excel sur Mac, cliquez sur le menu Excel > Préférences > Vérification des erreurs.

    Dans la section Vérification des erreurs, cliquez sur Rétablir les erreurs ignorées > OK.

    Vérification des erreurs

    Remarque : La réinitialisation des erreurs ignorées entraîne la réinitialisation de toutes les erreurs dans les feuilles du classeur actif.

    Conseil : Cela peut vous aider de déplacer la boîte de dialogue Vérification des erreurs juste en dessous de la barre de formule.

    Déplacer la boîte de dialogue Vérification des erreurs en dessous de la barre de formule
  4. Cliquez sur l’un des boutons d’action à droite dans la boîte de dialogue. Les actions disponibles sont différentes pour chaque type d’erreur.

  5. Cliquez sur Suivant.

Remarque : Si vous cliquez sur Ignorer l’erreur, l’erreur est marquée comme devant être ignorée pour les vérifications suivantes.

  1. À côté de la cellule, cliquez sur le bouton Vérification des erreurs Icône Vérification des erreurs qui s’affiche, puis cliquez sur l’option souhaitée. Les commandes disponibles sont différentes pour chaque type d’erreur, et la première entrée décrit l’erreur.

    Si vous cliquez sur Ignorer l’erreur, l’erreur est marquée comme devant être ignorée pour les vérifications suivantes.

    Déplacer la boîte de dialogue Vérification des erreurs en dessous de la barre de formule

Si une formule ne permet pas de calculer correctement un résultat, Excel affiche une valeur d’erreur, telle que #####, #DIV/0!, #N/A, #NOM?, #NUL!, #NOMBRE!, #REF! et #VALEUR!. Pour chaque type d’erreur, il existe des causes et des solutions différentes.

Le tableau suivant contient des liens vers des articles qui décrivent ces erreurs de façon plus détaillée ainsi qu’une courte description pour vous aider à commencer.

Rubrique

Description

Corriger une erreur #####

Excel affiche cette erreur pour indiquer qu’une colonne n’est pas suffisamment large pour accueillir tous les caractères d’une cellule ou qu’une cellule contient une date ou une heure négative.

Par exemple, le résultat d’une formule qui soustraie une date future à une date passée, telle que =15/06/2008-01/07/2008, est une valeur de date négative.

Conseil : Essayez d’ajuster automatiquement la cellule en double-cliquant sur entre les en-têtes de colonne. Si ### s’affiche parce que Excel ne peut pas afficher tous les caractères cela elle sera corrigée.

Erreur #

Corriger une erreur #DIV/0!

Excel affiche cette erreur lorsqu’un nombre est divisé par zéro (0) ou par une cellule qui ne contient aucune valeur.

Conseil : Ajoutez un gestionnaire d’erreur comme dans l’exemple suivant, =SI(C2;B2/C2;0).

Une fonction de gestion des erreurs telle que SI peut être utilisée pour traiter les erreurs

Corriger une erreur #N/A

Excel affiche cette erreur lorsqu’une valeur n’est pas disponible pour une fonction ou une formule.

Si vous utilisez une fonction RECHERCHEV, que vous essayez de rechercher ont une correspondance dans la plage de recherche ? Il ne plus souvent.

Essayez d’utiliser SIERREUR pour supprimer la # n/a. Dans ce cas, vous pouvez aussi utiliser :

=SIERREUR(RECHERCHEV(D2;$D$6:$E$8;2;TRUE);0)

Erreur #N/A

Corriger une erreur #NOM?

Cette erreur s’affiche lorsqu’Excel ne reconnaît pas le texte dans une formule, par exemple, si le nom d’une plage ou le nom d’une fonction est mal orthographié.

Remarque : Si vous utilisez une fonction, vérifiez que le nom de la fonction est correctement orthographié. Dans ce cas, somme est mal orthographiée. Supprimez le « e » et elle sera corrigée par Excel.

Excel affiche une erreur #NOM? lorsque le nom d’une fonction est mal orthographié

Corriger une erreur #NUL!

Excel affiche cette erreur lorsque vous spécifiez une intersection de deux zones qui, en réalité, ne se coupent pas. L’opérateur d’intersection est un caractère d’espacement qui sépare les références d’une formule.

Remarque : Vérifiez que vos plages sont séparés correctement - les zones C2 : C3 et E4:E6 ne se coupent pas, afin d’entrer la formule = Somme (C2 : C3 E4:E6) renvoie la #NULL ! erreur. Placer une virgule entre les plages C et E elle sera corrigée =SUM(C2:C3,E4:E6)

Erreur #NUL!

Corriger une erreur #NOMBRE!

Excel affiche cette erreur lorsqu’une formule ou une fonction contient des valeurs numériques non valides.

Vous utilisez une fonction qui produit une itération, telle que tri ou taux ? Si c’est le cas, le #NUM ! erreur est probablement parce que la fonction ne trouve pas de résultat. Reportez-vous à la rubrique d’aide pour la procédure de résolution.

Corriger une erreur #REF!

Excel affiche cette erreur lorsqu’une référence de cellule n’est pas valide, par exemple, si vous avez supprimé des cellules qui étaient référencées par d’autres formules ou si vous avez collé des cellules sur d’autres cellules qui étaient référencées par d’autres formules.

Avez-vous accidentellement supprimé une ligne ou colonne ? Nous supprimés colonne B dans cette formule, = SUM(A2,B2,C2), puis regardez où est passée.

Vous pouvez utiliser la fonction Annuler (Ctrl+Z) pour annuler la suppression, recréer la formule ou utiliser une référence de plage continue, comme celle-ci : =SOMME(A2:C2). Cette formule aurait été mise à jour automatiquement suite à la suppression de la colonne B.

Excel affiche l’erreur #REF! lorsqu’une référence de cellule n’est pas valide

Corriger une erreur #VALEUR!

Excel peut afficher cette erreur si votre formule inclut des cellules qui contiennent plusieurs types de données.

Vous êtes à l’aide des opérateurs mathématiques (+, -, *, /, ^) avec différents types de données ? Si c’est le cas, essayez d’utiliser une fonction à la place. Dans ce cas =SUM(F2:F5) serait corriger le problème.

Erreur #VALEUR!

Lorsque des cellules ne sont pas visibles dans une feuille de calcul, vous pouvez les visualiser avec leurs formules dans la barre d’outils Fenêtre Espion. La fenêtre Espion facilite la réalisation d’inspections et d’audits ou la confirmation des résultats de formules, ainsi que des résultats dans de grandes feuilles de calcul. Cette fenêtre est pratique, car vous n’avez pas besoin de parcourir la feuille de calcul en permanence.

La fenêtre Espion permet de contrôler aisément les formules utilisées dans une feuille de calcul

Cette barre d’outils peut être déplacée ou ancrée comme n’importe quelle autre barre d’outils. Par exemple, vous pouvez l’ancrer en bas de la fenêtre. La barre d’outils suit les propriétés de cellule suivantes : 1) Classeur, 2) Feuille, 3) Nom (si la cellule comporte une plage nommée correspondante), 4) Cellule, 5) Valeur et 6) Formule.

Remarque : Une seule fenêtre Espion est disponible par cellule.

Ajouter des cellules à la fenêtre Espion

  1. Sélectionnez les cellules que vous souhaitez examiner.

    Pour sélectionner toutes les cellules d’une feuille de calcul contenant des formules, dans le groupe Édition de l’onglet Accueil, cliquez sur Rechercher et sélectionner (ou vous pouvez utiliser Ctrl+G ou Ctrl+G sur Mac)> Atteindre Spécial > Formules.

    Boîte de dialogue Sélectionner les cellules
  2. Dans l’onglet Formules, dans le groupe Audit de formules, cliquez sur Fenêtre Espion.

  3. Cliquez sur Ajouter un espion.

    Cliquez sur Ajouter un espion pour ajouter un espion dans votre feuille de calcul
  4. Vérifiez que vous avez sélectionné toutes les cellules que vous voulez surveiller, puis cliquez sur Ajouter.

    Dans Ajouter un espion, entrez la plage de cellules à surveiller
  5. Pour changer la largeur d’une colonne de la fenêtre Espion, faites glisser la limite du côté droit de l’en-tête de la colonne.

  6. Pour afficher la cellule à laquelle une entrée de la barre d’outils Fenêtre Espion fait référence, double-cliquez sur cette entrée.

    Remarque : Les cellules contenant des références externes à d’autres classeurs ne s’affichent dans la barre d’outils Fenêtre Espion que lorsque les autres classeurs sont ouverts.

Supprimer des cellules de la fenêtre Espion

  1. Si la barre d’outils Fenêtre Espion n’est pas affichée, dans l’onglet Formules, dans le groupe Audit de formules, cliquez sur Fenêtre Espion.

  2. Sélectionnez les cellules à supprimer.

    Pour sélectionner plusieurs cellules, appuyez sur Ctrl de façon prolongée, puis cliquez sur les cellules.

  3. Cliquez sur Supprimer un espion.

    Supprimer un espion

Il est parfois difficile de comprendre comment une formule imbriquée calcule un résultat final, étant donné la nécessité de plusieurs calculs intermédiaires et de tests logiques. Toutefois, vous pouvez utiliser la boîte de dialogue Évaluation de formule pour visualiser les différentes parties d’une formule imbriquée évaluée dans l’ordre de calcul de la formule. Par exemple, la formule =SI(MOYENNE(D2:D5)>50;SOMME(E2:E5);0) est plus facile à comprendre si vous pouvez afficher les résultats intermédiaires suivants :

L’option Évaluation de formule vous permet de voir la manière dont les différentes parties d’une formule imbriquée sont évaluées

Dans la boîte de dialogue Évaluation de formule

Description

=SI(MOYENNE(D2:D5)>50;SOMME(E2:E5);0)

La formule imbriquée s’affiche au départ. La fonction MOYENNE et la fonction SOMME sont imbriquées dans la fonction SI.

La plage de cellules D2:D5 contient les valeurs 55, 35, 45 et 25. Par conséquent, le résultat de la fonction MOYENNE(D2:D5) est 40.

=SI(40>50;SOMME(E2:E5);0)

La plage de cellules D2:D5 contient les valeurs 55, 35, 45 et 25. Par conséquent, le résultat de la fonction MOYENNE(D2:D5) est 40.

=SI(FAUX;SOMME(E2:E5);0)

Étant donné que 40 est inférieur à 50, l’expression du premier argument de la fonction SI (l’argument test_logique) est Faux.

La fonction SI renvoie la valeur du troisième argument (argument valeur_si_faux). La fonction SOMME n’est pas évaluée, car il s’agit du deuxième argument de la fonction SI (argument valeur_si_vrai) et elle ne sera renvoyée que si l’expression est Vrai.

  1. Sélectionnez la cellule à évaluer. Il n’est possible d’évaluer qu’une seule cellule à la fois.

  2. Sélectionnez l’onglet Formules > Audit de formules > Évaluation de formule.

  3. Cliquez sur Évaluer pour examiner la valeur de la référence soulignée. Le résultat de l’évaluation apparaît en italique.

    Si la partie soulignée de la formule est une référence à une autre formule, cliquez sur Pas à pas détaillé pour afficher l’autre formule dans la zone Évaluation. Cliquez sur Pas à pas sortant pour revenir aux cellules et formules précédentes.

    Le bouton Pas à pas détaillé n’est pas disponible pour une référence la deuxième fois que celle-ci apparaît dans la formule, ou si la formule fait référence à une cellule dans un classeur distinct.

  4. Continuez en cliquant sur Évaluer jusqu’à ce que toutes les parties de la formule soient évaluées.

  5. Pour revoir l’évaluation, cliquez sur Redémarrer.

  6. Pour mettre fin à l’évaluation, cliquez sur Fermer.

Remarques : 

  • Certaines parties des formules qui utilisent les fonctions SI et CHOISIR ne sont pas calculées. Dans ces cas, #N/A s’affiche dans la zone Évaluation.

  • Si une référence est vide, une valeur zéro (0) s’affiche dans la zone Évaluation.

  • Les fonctions suivantes sont recalculées chaque fois que la feuille de calcul est modifiée, c’est pourquoi la boîte de dialogue Évaluation de formule peut donner des résultats différents de ce qui s’affiche dans la cellule : ALEA, ZONES, INDEX, DECALER, CELLULE, INDIRECT, LIGNES, COLONNES, MAINTENANT, AUJOURDHUI, ALEA.ENTRE.BORNES.

Vous avez besoin d’une aide supplémentaire ?

Vous pouvez toujours consulter un expert de la communauté technique Excel, obtenir une assistance dans la communauté Answers ou suggérer une nouvelle fonctionnalité ou une amélioration sur le forum Excel User Voice.

Voir aussi

Afficher les relations entre formules et cellules

Pourquoi ma formule est-elle incorrecte ?

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×