Déployer une application Access

Remarque : Nous faisons de notre mieux pour vous fournir le contenu d’aide le plus récent aussi rapidement que possible dans votre langue. Cette page a été traduite automatiquement et peut donc contenir des erreurs grammaticales ou des imprécisions. Notre objectif est de faire en sorte que ce contenu vous soit utile. Pouvez-vous nous indiquer en bas de page si ces informations vous ont aidé ? Voici l’article en anglais à des fins de référence aisée.

Access fournit une plateforme riche pour développer des applications de base de données. Une application de base de données est un programme informatique qui offre un moyen de stocker et gérer des données et une interface utilisateur conçue en respectant la logique des tâches professionnelles (logique d’application).

Pour déployer des Access applications qui peuvent s’exécuter sans une installation Access sur l’ordinateur d’un utilisateur, vous pouvez les distribuer avec la Access version exécutable (runtime), qui est disponible gratuitement à partir du centre de téléchargement de Microsoft.com.

Cet article décrit la planification du déploiement de base, les fonctionnalités de Access la version exécutable et comment télécharger cet exécutable. Cet article fournit également une vue d’ensemble du déploiement des applications de base de données à l’aide de Access.

Que voulez-vous faire ?

Planifier le déploiement

Comprendre Access Runtime

Télécharger Access Runtime

Déployer une application Access

Planifier le déploiement

Avant de commencer, vous devez vous poser les questions suivantes sur comment l’application va être déployée.

Les données et la logique doivent-elles être séparées ?

Vous pouvez créer un Access application qui combine la logique d’application et la gestion des données dans un seul fichier. C’est la structure d’application par défaut dans Access. Combiner la logique d’application et la gestion des données dans un seul fichier fournit la méthode de déploiement la plus simple, mais cette méthode fonctionne de manière optimale si seule une personne utilise l’application à la fois et elle implique des risques. Par exemple, un utilisateur peut entraîner la perte de données en supprimant involontairement ou en endommageant le fichier de l’application.

Dans la plupart des cas, vous devez séparer la logique d’application de la gestion des données. Cela permet d’améliorer :

  • la sécurité    Utilisez un serveur de stockage des données peut vous aider à sécuriser les données.

  • les performances    À l’aide d’une base de données fractionnée ou un serveur de base de données peut vous aider à réduire le trafic réseau.

  • Personnalisation    De nouvelles actions de macro pour le volet de Navigation peuvent vous aider à contrôler qui peut voir quoi. Vous pouvez distribuer les fichiers de logique d’application différents à différents utilisateurs.

Méthodes pour séparer les données et la logique

Une manière de séparer les données et la logique est à l’aide de la commande Base de données Access (dans l’onglet Outils de base de données, dans le groupe Déplacer les données). La commande Base de données Access fractionne votre application de base de données en deux fichiers Access : un pour les données et un pour la logique. Lorsque vous utilisez la commande Base de données Access, Access crée un fichier où « _be » (pour « back-end », ce qui signifie « principale ») est ajouté au nom du fichier, par exemple, si le nom du fichier de base de données d’origine est « Database1.accdb », Access crée un nouveau fichier de base de données nommé « Database1_be.accdb. »

Une autre méthode pour séparer la logique de la gestion des données consiste à utiliser un programme de serveur de base de données (par exemple, Microsoft SQL Server) pour la gestion des données et Access pour la logique d’application.

Pour déterminer si un seul fichier Access est suffisant pour la logique d’application et la gestion des données, considérez ce qui suit :

  • Sécurité et l’intégrité des données    Access les utilisateurs doivent disposent d’autorisations en lecture/écriture pour le fichier qui contient la logique d’application. Si vous combinez les données et la logique dans un seul fichier, les données sont exposées aux mêmes risques que la logique d’application.

    Une Access application qui sépare la logique et les fichiers de données peut contribuer à protéger l’intégrité et la sécurité des données en tirant parti des fonctionnalités de sécurité NTFS. Étant donné que les utilisateurs peuvent accéder en lecture/écriture explicite uniquement au fichier de logique de l’application, le fichier de données peut être plus sécurisé.

    Votre application peut nécessiter des options de sécurité supplémentaires, telle que la possibilité de contrôler quels utilisateurs ont accès à des données spécifiques. Dans ce cas, vous devez utiliser un produit serveur tel que SQL Server ou un système d’exploitation Windows server avec Windows SharePoint Services pour stocker et gérer vos données d’application et utiliser Access pour fournir la logique d’application.

  • Extensibilité    Un fichier Access peut avoir une taille maximale de 2 gigaoctets (Go). Bien que 2 Go soit une quantité importante de données texte, cela peut être insuffisant pour certaines applications, notamment des applications qui stockent des pièces jointes dans les enregistrements de base de données. Si vous séparez les données et la logique, votre application peut accueillir plus de données. Si vous prévoyez que les utilisateurs stockent un gros volume de données, vous pouvez envisager d’utiliser plusieurs fichiers de données Access.

    Vous devez également passer en revue les spécifications de Access pour plus d’information sur l’évolutivité du programme. Pour en savoir plus sur les spécifications Access, voir l'article spécifications d'Access.

  • Capacité réseau    Si plusieurs utilisateurs devront utiliser l’application en même temps sur un réseau, les données sont plus susceptibles d’être corrompues si les données et la logique sont combinées dans un seul fichier. Par ailleurs, si vous combinez les données et la logique dans un seul fichier Access, vous ne pouvez pas optimiser le trafic réseau qu’Access génère. Si plusieurs utilisateurs vont utiliser simultanément votre application sur un réseau, vous devez séparer les données et la logique, soit avec deux ou plusieurs fichiers Access, soit avec un produit serveur de base de données pour des données et Access pour la logique d’application.

Comment sera l’environnement réseau ?

Si vos utilisateurs sont tous sur le même réseau local ou si votre application n’est pas utilisée sur un réseau, un fichier d’application unique peut suffire dans la plupart des circonstances.

Les performances réseau seront améliorées si vous séparez les données et la logique. Si vos utilisateurs ne seront pas sur le même réseau local, utilisez un serveur pour stocker et gérer vos données et utilisez Access pour la logique d’application.

Les utilisateurs auront-ils Access?

Si tous vos utilisateurs ont Access installé sur leur ordinateur, ils peuvent ouvrir et utiliser l’application comme ils le feraient pour n’importe quel Access fichier de base de données.

Si tout ou partie de vos utilisateurs n’ont pas Access installé sur leur ordinateur, vous devez déployer le logiciel Runtime Access pour ces utilisateurs lorsque vous déployez votre application.

Haut de la page

Comprendre Access Runtime

Access Runtime est un programme redistribuable qui permet aux utilisateurs qui ne possèdent pas Access sur leur ordinateur d’utiliser des applications de base de données Access. Lorsque vous ouvrez une base de données Access à l’aide du Runtime Access, la base de données s’ouvre en mode version exécutable.

Le mode version exécutable (runtime), qu’est-ce que c’est ?

Le mode runtime est un mode d’exploitation de Access où certaines fonctionnalités Access ne sont pas disponibles par défaut. Certaines de ces fonctionnalités indisponibles peuvent toutefois être rendue disponibles en mode runtime.

Quelles fonctionnalités ne sont pas disponibles en mode runtime ?

Quelles fonctionnalités Access ne sont pas disponibles en mode runtime ?

  • Volet de navigation    Le volet de navigation n’est pas disponible en mode runtime. Cela permet d’empêcher les utilisateurs d’accéder à des objets arbitraires dans votre application de base de données. Seuls les objets vous exposez aux utilisateurs, par exemple, en fournissant un formulaire de menu général, peuvent être ouverts lors de l’utilisation en mode runtime. Le volet de navigation n’est jamais disponible en mode runtime.

  • Le ruban    Par défaut, le ruban n’est pas disponible en mode runtime. Cela permet d’empêcher les utilisateurs de créer ou modifier des objets de base de données et d’effectuer d’autres actions dangereuse, par exemple, connexion à de nouvelles sources de données ou l’exportation de données d’une manière non attendue. Vous pouvez créer un ruban personnalisé et puis associer ce ruban à un formulaire ou un état. Vous ne pouvez pas exposer les onglets du ruban par défaut en mode runtime.

  • Mode Création et mode Page    Les modes Création et Page ne sont pas disponibles pour tous les objets de base de données en mode runtime. Cela permet d’empêcher que les utilisateurs accèdent à des objets arbitraires dans votre application de base de données. Vous ne pouvez pas activer le mode Création ou Page en mode runtime.

  • Aide    Par défaut, l’aide intégrée n’est pas disponible en mode runtime. Étant donné que vous contrôlez quelles fonctionnalités sont disponibles dans votre application en mode runtime, certaines rubriques d’aide intégrée Access peuvent ne pas être utiles aux personnes qui utilisent votre application et peuvent potentiellement être source de confusion ou de frustration. Vous pouvez créer votre propre fichier d'aide personnalisé pour compléter votre application en mode exécutable.

Puis-je ouvrir une base de données Access en mode runtime sans utiliser le logiciel Runtime Access ?

Vous pouvez exécuter toute base de données Access en mode runtime sur un ordinateur sur lequel la version complète de Access est installée. Pour exécuter une base de données Access en mode runtime, effectuez l’une des opérations suivantes :

  • Modifier l’extension de nom de fichier du fichier de base de données de .accdb à .accdr.

  • Créer un raccourci vers la base de données et incluez le commutateur de ligne de commande /Runtime dans le raccourci.

Est-ce que le mode runtime rend ma base de données plus sûre ?

Bien que le mode runtime limite la disponibilité des fonctionnalités de création et de navigation, vous ne devez pas utiliser le mode runtime en tant qu’outil principal de sécurisation d’une application de base de données. Sur un ordinateur sur lequel la version complète de Access installée, un utilisateur peut ouvrir le runtime d’une application de base de données comme une application de base de données normale (autrement dit, avec toutes les fonctionnalités disponibles), puis modifier la conception ou effectuer d’autres actions indésirables.

Même si vous déployez votre application de base de données uniquement sur des ordinateurs qui n’ont pas la version complète de Access, il est toujours possible pour un utilisateur de transférer l’application sur un ordinateur qui dispose de la version complète de Access, puis d’ouvrir le runtime de l’application de base de données comme une application de base de données normale.

Remarque : Si vous souhaitez distribuer une application Access pour que les utilisateurs ne puissent pas modifier la conception des formulaires, les états ou les modules Microsoft Visual Basic Applications (VBA), envisagez d’utiliser un fichier binaire compilé (.accde). Pour plus d’informations sur l’utilisation d’un fichier binaire compilé, voir la section Décider du format de fichier à utiliser, plus loin dans cet article.

Haut de la page

Télécharger le runtime Access

Pour télécharger le runtime Access pendant l’exécution depuis le centre de téléchargement Microsoft, cliquez sur le lien correspondant à votre version :

Aucun achat n’est nécessaire pour télécharger, utiliser ou redistribuer le Runtime Access, et il n’y a pas de limite au nombre d’utilisateurs auxquels vous pouvez distribuer le runtime.

Haut de la page

Déployer une application Access

Pour déployer une application Access, vous devez au moins effectuer les tâches suivantes :

  1. Créer l’application    Votre application doit permettre aux utilisateurs d’ouvrir et d’utiliser des objets de base de données. Si votre application ne propose pas de tels moyens, vos utilisateurs devront avoir Access sur leur ordinateur pour utiliser l’application. Par ailleurs, vous ne pourrez pas prévoir comment les utilisateurs vont naviguer dans votre application, et il sera plus difficile pour vous de fournir une documentation complète sur l’application. Par ailleurs, si les utilisateurs ouvrent votre application à l’aide du runtime Access, les fonctionnalités intégrées de navigation de Access ne seront pas disponibles.

    Une approche consiste à créer un formulaire contenant des boutons de commande pour ouvrir des objets de base de données ou effectuer d’autres actions, puis de spécifier ce formulaire comme formulaire devant être ouvert par défaut lors du démarrage de l’application.

    Remarque : Pour obtenir de l’aide sur la création d’un formulaire, consultez la rubrique Créer un formulaire à l’aide de l’outil formulaire.

    Comment spécifier le formulaire par défaut à ouvrir ?

    1. Cliquez sur Fichier > Options

    2. Dans le volet gauche de la boîte de dialogue Options Access, cliquez sur Base de données active.

    3. Dans le volet droit dans Options de l’application, sélectionnez le formulaire par défaut que vous souhaitez à l’aide de la zone de liste modifiable Formulaire d’affichage.

    Vous pouvez également créer un ruban personnalisé, puis associer ce ruban à un formulaire qui s’ouvre lorsque votre application démarre. Pour plus d’informations sur la création d’un ruban personnalisé, voir l’article Créer un ruban personnalisé dans Access.

  2. Installer l’application    Notez plusieurs options et considérations pour l’installation d’une application. Vous pouvez souhaiter déployer un format de fichier particulier pour mieux contrôler comment les utilisateurs utilisent l’application. Ou vous pourriez créer un package d’application pour faciliter l’installation ou déployer des données et des composants logiques distincts.

    Vous trouverez plus d’informations sur ces options et considérations dans les sections suivantes.

Décidez du format de fichier à utiliser

Il existe quatre formats de fichiers Access que vous pouvez utiliser lorsque vous déployez une application :

  • .accdb    Il s’agit du format de fichier par défaut pour Access. Lorsque vous déployez une application dans ce format, les utilisateurs ont la plupart des options pour personnaliser et parcourir l’application comme ils le préfèrent. Si vous voulez vous assurer que les utilisateurs ne modifient pas la conception de votre application, vous devez utiliser le format de fichier .accde. En outre, un utilisateur ne peut pas déterminer facilement si un fichier .accdb a été modifié une fois que vous l’avez compilé : pour rendre cela évident, utilisez le format de fichier .accdc.

  • .accdc    Ce format est également connu comme fichier de déploiement Access. Un fichier de déploiement Access est constitué d’un fichier d’application et d’un fichier de signature numérique qui est associé à ce fichier. Ce format de fichier garantit aux utilisateurs que personne n’a changé le fichier d’application une fois que vous l’avez compilé. Vous pouvez appliquer ce format à une fichier Access de format par défaut (.accdb) ou à un fichier compilé binaire (.accde) Access.

    Vous ne pouvez placer qu’un seul fichier d’application dans un fichier de déploiement Access. Si votre application a des fichiers logique et fichiers de données distincts, vous pouvez les compiler séparément.

  • .accde    Ce format est également connu comme fichier binaire compilé. Dans Access, un fichier binaire compilé est un fichier d’application de base de données qui a été enregistré avec tout le code VBA compilé. Aucun code source VBA ne reste dans un fichier binaire compilé Access.

    Vous pouvez utiliser le runtime Access pour ouvrir un fichier binaire compilé Access. Toutefois, par défaut, le runtime ne reconnaît pas l’extension de nom de fichier .accde. Pour ouvrir un fichier binaire compilé à l’aide du runtime Access, créez un raccourci qui pointe vers le runtime et ajoutez le chemin d’accès au fichier binaire compilé que vous souhaitez ouvrir avec le raccourci.

    Important : Si les utilisateurs ouvrent un fichier binaire compilé à l’aide d’une version d’Access antérieure à la version dans laquelle il a été compilé, les utilisateurs ne peuvent pas ouvrir le fichier binaire compilé. Pour résoudre ce problème, vous devez compiler le fichier binaire dans la version d’Access installée pour vos utilisateurs.

    Comment enregistrer un fichier Access en tant qu’un fichier binaire compilé ?

    1. Dans Access, ouvrez le fichier de base de données (.accdb) que vous voulez enregistrer comme fichier binaire compilé (.accde).

    2. Cliquez sur l’onglet Fichier, puis cliquez sur Enregistrer sous.

    3. Dans Types de fichiers de base de données, cliquez sur Créer fichier ACCDE puis Enregistrer sous.

    4. Dans la boite de dialogue Enregistrer sous, recherchez le dossier dans lequel vous souhaitez enregistrer le fichier, tapez le nom du fichier dans la zone Nom de fichier, puis cliquez sur Enregistrer.

  • .accdr    Ce format vous permet de déployer une application qui s’ouvre en mode runtime. Déployer une application runtime peut vous aider à contrôler la façon dont elle est utilisée, bien que ce ne soit pas pas un moyen de sécuriser une application. Pour plus d’informations sur le mode runtime, voir la section Comprendre Access Runtime.

Compiler et signer une Access base de données

Avec Access, il est plus simple et plus rapide de signer et de distribuer une base de données que dans les versions antérieures. Lorsque vous créez un fichier .accdb ou .accde, vous pouvez compiler le fichier, appliquer une signature numérique au package créé, puis envoyer le package signé à d’autres utilisateurs. La fonctionnalité compiler et signer place la base de données dans un fichier de déploiement Access (.accdc), signe le fichier, puis place le package signé dans un emplacement que vous choisissez. Les autres utilisateurs peuvent ensuite extraire la base de données du package et travailler directement dans la base (et pas dans le package).

Remarque : La fonction décrite dans cette section permet de compiler un fichier Access et d’appliquer une signature numérique au package, qui permet d’indiquer aux utilisateurs que le fichier est digne de confiance.

N’oubliez pas ces informations pour créer et signer un package :

  • Créer un package et le signer est une technique permettant d’étendre la sécurité. Lorsque vous ou vos utilisateurs reçoivent le package, la signature confirme que la base de données n’a pas été falsifiée. Si vous faites confiance à l’auteur, vous pouvez activer le contenu.

  • La fonctionnalité de compilation et de signature s’applique uniquement aux bases de données ayant un format de fichier .accdb. Access fournit des outils des versions antérieures de Microsoft Office que vous pouvez utiliser pour signer et distribuer des bases de données qui ont été créées dans un ancien format de fichier .mdb. Vous ne pouvez pas utiliser les outils de versions antérieures d’Office pour signez et distribuez des fichiers créés dans les formats de fichier .accdb plus récents.

  • Vous ne pouvez ajouter qu’une seule base de données à un package.

  • Lorsque vous créez un package et signez une base de données, tous les objets dans le fichier de base de données sont signés et encodés, pas seulement des macros ou modules de code. Le fichier de package est compressé lors du processus de compilation et de signature pour réduire les temps de téléchargement.

  • Vous pouvez extraire des bases de données de fichiers de package présents sur des serveurs SharePoint.

Les sections suivantes expliquent comment créer un fichier de package signé, et comment utiliser une base de données dans un fichier de package signé.

Remarque : Pour effectuer ces étapes, vous devez disposer d’au moins un certificat de sécurité disponible. Si vous n’avez pas un certificat installé sur votre ordinateur, vous pouvez en créer un à l’aide de l’outil SelfCert. Pour plus d’informations sur la création d’un certificat de sécurité privé, voir l’article Plus de confiance en ajoutant une signature numérique.

Créer un package signé

  1. Ouvrez la base de données dont vous voulez faire un package signé.

  2. Cliquez sur l’onglet Fichier, puis cliquez sur Enregistrer sous.

  3. Dans Types de fichiers de base de données, cliquez sur Créer fichier de package et le signer puis Enregistrer sous.

  4. Dans la boîte de dialogue Sélectionnez un certificat, sélectionnez un certificat numérique, puis cliquez sur OK.

    La boîte de dialogue Créer un package signé Microsoft Office Access apparaît.

  5. Dans la liste Enregistrer dans, sélectionnez un emplacement pour votre package de base de données signé.

  6. Tapez un nom pour le package signé dans la zone Nom de fichier, puis cliquez sur Créer.

    Access crée le fichier .accdc et le place à l’endroit que vous avez choisi.

Extraire et utiliser un package signé

  1. Cliquez sur Fichier > Ouvrir.

  2. Dans la boîte de dialogue Ouvrir, sélectionnez Packages signés Microsoft Office Access (*.accdc) comme type de fichier.

  3. Dans la liste Rechercher dans, localisez le dossier qui contient votre fichier .accdc, sélectionnez le fichier, puis cliquez sur Ouvrir.

  4. Effectuez l’une des opérations suivantes :

    • Si vous avez décidé de faire confiance au certificat numérique utilisé pour signer le package de déploiement, la boîte de dialogue Extraire la base de données dans s’affiche. Passez à l’étape 5.

    • Si vous n’avez pas encore accepté le certificat numérique, ce message conseil s’affiche.

      1. Message consultatif

      2. Si vous avez confiance dans la base de données, cliquez sur Ouvrir. Si vous avez confiance dans tous les certificats de ce fournisseur, cliquez sur Approuver tous à partir de l’éditeur. La boîte de dialogue Extraire la base de données vers s’affiche.

  5. Sinon, dans la liste Enregistrer dans, sélectionnez un emplacement pour la base de données extraite puis, dans la zone Nom de fichier, tapez un autre nom pour la base de données extraite.

Si vous n’êtes pas certain de pouvoir faire confiance à un certificat, l’article Comment savoir si une signature numérique est digne de confiance fournit des informations générales sur la vérification des dates et autres éléments d’un certificat pour permettre de s’assurer de sa validité.

Haut de la page

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×