Déplacer un modèle de formulaire publié dans une nouvelle bibliothèque SharePoint

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Contenu de cet article

Vue d’ensemble

Avant de commencer

Obtenir une copie de travail de votre modèle de formulaire

Étape 1 : Publier le modèle de formulaire sur la nouvelle bibliothèque de documents

Étape 2 : Copier et relier les formulaires existants

Vue d'ensemble

Après avoir publié un modèle de formulaire sur une bibliothèque de documents pour que vos utilisateurs le remplissent, vous pouvez devoir déplacer le modèle de formulaire vers une autre bibliothèque de documents. Vous pouvez par exemple souhaiter le placer sur un serveur de plus grande capacité, afin de permettre à un plus grand nombre d'utilisateurs de remplir les formulaires en même temps. Certains utilisateurs peuvent avoir déjà rempli des formulaires basés sur votre modèle de formulaire qui était stocké dans la bibliothèque de documents d'origine. Lorsque vous déplacez votre modèle de formulaire dans une nouvelle bibliothèque de documents, veillez à déplacer également les formulaires existants. De même, vérifiez que les formulaires existants fonctionneront dans la nouvelle bibliothèque de documents avant d'archiver ou de supprimer l'ancienne bibliothèque de documents.

Conseil : Avant de placer des modèles de formulaire publiés dans une nouvelle bibliothèque de documents, créez un plan qui prévoit d'informer vos utilisateurs que leurs formulaires ont été déplacés dans une nouvelle bibliothèque de documents. Vos utilisateurs doivent pouvoir utiliser la nouvelle bibliothèque de documents pour stocker des formulaires nouveaux ou modifier des formulaires existants. Le plan doit également comprendre un processus d'archivage ou de suppression de la bibliothèque de documents d'origine.

Pour déplacer un modèle de formulaire et ses formulaires existants dans une nouvelle bibliothèque de documents, vous devez d'abord publier la copie de travail de votre modèle de formulaire dans la nouvelle bibliothèque de documents. La copie de travail est la version qui est stockée sur votre ordinateur ou dans un programme de contrôle de version tel que Microsoft Visual SourceSafe.

Conseil : Si vous ne disposez pas d'une copie de travail du modèle de formulaire, vous pouvez enregistrer sur votre ordinateur une copie du modèle de formulaire que vous trouverez dans la bibliothèque de documents d'origine, afin de l'utiliser comme copie de travail.

Après avoir publié le copie de travail sur la nouvelle bibliothèque de documents, vous devez copier dans la nouvelle bibliothèque de documents tous les formulaires de l'ancienne bibliothèque de documents, puis recréer des liens entre les formulaires de la nouvelle bibliothèque de documents et le modèle de formulaire que vous venez de publier.

Si vous devez apporter des modifications au modèle de formulaire consécutives à son déplacement, faites-le avant sa publication. Par exemple, l'emplacement des sources de données externes qui sont utilisées par les formulaires créés sur la base de ce modèle de formulaire peuvent également changer à la suite du déplacement du formulaire. Dans ce cas, vous devez modifier la connexion des données dans le modèle de formulaire vers le nouvel emplacement des sources de données externes avant de publier le modèle de formulaire. Vous trouverez des liens vers des informations supplémentaires sur la modification des connexions de données dans la section Voir aussi.

Remarque : Publication d’un modèle de formulaire n’est pas différente de celle dans l’enregistrement d’un modèle de formulaire. Lorsque vous publiez un modèle de formulaire, l’Assistant Publication ajoute l’emplacement de publication et des instructions pour le modèle de formulaire de traitement afin que les utilisateurs peuvent ouvrir les formulaires basés sur ce modèle de formulaire. Lorsque vous enregistrez un modèle de formulaire, vous enregistrez une copie du modèle de formulaire, comme vous le feriez lorsque vous enregistrez un fichier sur votre ordinateur. Vous devez toujours utiliser l’Assistant publication lorsque vous voulez rendre votre modèle de formulaire pour vos utilisateurs à remplir.

Haut de la Page

Avant de commencer

Avant de déplacer dans une nouvelle bibliothèque de documents le modèle de formulaire et tous les formulaires existants qui sont basés sur ce modèle, vous aurez besoin des éléments suivants :

  • La copie de travail du modèle de formulaire    Il s'agit d'une copie du modèle de formulaire que vous modifierez avant de republier sur la nouvelle bibliothèque de documents. La copie de travail peut être stockée sur votre ordinateur ou dans un programmer de contrôle de version tel que Visual SourceSafe.

  • Les emplacements des nouvelles sources de données externes    Si les formulaires créés à partir du modèle utilisent des source de données externes qui ont changé, vous aurez besoin du nouvel emplacement de ces sources de données externes. Vérifiez auprès de votre administrateur que vous et vos utilisateurs disposez des autorisations appropriées pour utiliser les sources de données externes. Si le modèle de formulaire utilise des paramètres dans un fichier de connexion de données pour se connecter à une source de données externe, vérifiez que ce fichier de connexion de données a été mis à jour et contient le nouvel emplacement des sources de données externes.

  • Les droits appropriés sur le serveur exécutant Windows SharePoint Services 3.0    Vous devrez disposer des droits nécessaires pour publier un modèle de formulaire et copier les formulaires existants de l'ancienne bibliothèque de documents dans la nouvelle bibliothèque de documents. Vérifiez auprès de votre administrateur que vous disposez de ces droits.

Haut de la Page

Obtenir une copie de travail de son modèle de formulaire

Si vous souhaitez modifier un modèle de formulaire qui a été publié sur une bibliothèque de documents ou sur un emplacement réseau partagé mais que vous ne disposez pas d'une copie de travail de votre modèle de formulaire, vous pouvez enregistrer une copie de travail du modèle de formulaire à partir de l'emplacement de publication, sur votre ordinateur.

Conseil : Envisagez d'utiliser un programme de contrôle de version tel que Microsoft Visual SourceSafe pour gérer les copies de travail de vos modèles de formulaire.

Enregistrez sur votre ordinateur une copie du modèle de formulaire d'une bibliothèque de documents de formulaire

  1. Dans un navigateur Web, ouvrez la bibliothèque de documents où le modèle de formulaire a été publié.

  2. Dans le menu paramètres, cliquez sur paramètres, puis cliquez sur Paramètres de la bibliothèque de formulaires.

  3. Sous Paramètres généraux, cliquez sur Paramètres avancés.

  4. Dans la section Modèle de document, cliquez sur Modifier le modèle.

    Le modèle de formulaire s’ouvre dans Microsoft Office InfoPath.

  5. Dans la boîte de dialogue Microsoft Office InfoPath, cliquez sur Oui.

  6. Dans le menu Fichier, cliquez sur Enregistrer sous.

  7. Dans la boîte de dialogue Microsoft Office InfoPath, cliquez sur OK.

  8. Dans la boîte de dialogue Enregistrer sous, accédez à l'emplacement dans lequel vous voulez enregistrer une copie du modèle de formulaire puis cliquez sur Enregistrer.

Enregistrez sur votre ordinateur une copie du modèle de formulaire depuis le dossier réseau partagé

  1. Dans le menu fichier, cliquez sur créer un modèle de formulaire.

  2. Sous Ouvrir un modèle de formulaire, cliquez sur Sur mon ordinateur.

  3. Accédez au dossier réseau partagé du modèle de formulaire publié et cliquez sur le modèle de formulaire, puis cliquez sur Ouvrir.

  4. Dans le menu Fichier, cliquez sur Enregistrer sous.

  5. Dans la boîte de dialogue Microsoft Office InfoPath, cliquez sur OK.

  6. Dans la boîte de dialogue Enregistrer sous, sélectionnez un emplacement autre que la cellule d’origine emplacement dans lequel vous voulez enregistrer une copie de travail du modèle de formulaire de publication, puis cliquez sur Enregistrer.

Haut de la Page

Étape 1 : publier le modèle de formulaire dans la nouvelle bibliothèque de documents

  1. Ouvrez la copie de travail du modèle de formulaire en mode Création.

  2. Dans le menu Fichier, cliquez sur Publier.

  3. Dans l'Assistant Publication, cliquez sur Vers un serveur SharePoint avec ou sans InfoPath Forms Services, puis cliquez sur Suivant.

  4. Dans la zone Indiquez l'emplacement de votre site SharePoint ou InfoPath Forms Services, tapez l'emplacement du site SharePoint qui contient la nouvelle bibliothèque de documents dans laquelle vous souhaitez déplacer votre modèle de formulaire, puis cliquez sur Suivant.

  5. Sur la page suivante de l'Assistant, cliquez sur Bibliothèque de documents, puis sur Suivant.

  6. Cliquez sur Créer une nouvelle bibliothèque de documents, puis cliquez sur Suivant.

  7. Sur la page suivante de l'Assistant, tapez un nom et une description pour la nouvelle bibliothèque de documents, puis cliquez sur Suivant.

  8. Choisissez les champs dans le modèle de formulaire que vous souhaitez afficher comme des colonnes dans l'affichage par défaut de la bibliothèque de documents.

    Procédure

    1. Cliquez sur Ajouter.

    2. Sélectionnez le champ que vous voulez ajouter en tant qu’une colonne dans la bibliothèque de documents, puis effectuez l’une des opérations suivantes :

      • Tapez un nom pour la colonne dans la zone nom de colonne.

      • Sélectionnez la colonne de site dans la liste groupe de colonnes de Site, sélectionnez un nom dans la liste nom de colonne, puis cliquez sur OK.

        Remarque : Si vous avez sélectionné un champ extensible pour afficher des données dans la bibliothèque de documents, vous pouvez définir comment vous voulez afficher le champ dans la bibliothèque de documents en cliquant sur une valeur dans la liste de fonctions. Vous pouvez choisir si vous voulez afficher la première valeur dans le champ, la dernière valeur dans le champ, ou un compteur de toutes les occurrences du champ, ou si vous souhaitez fusionner toutes les valeurs.

    3. Cliquez sur OK.

    Vous trouverez des liens vers des informations complémentaires sur l'affichage de données en colonnes dans une bibliothèque de documents dans la section Voir aussi.

  9. Cliquez sur Suivant.

  10. Sur la page suivante de l'Assistant, vérifiez que les informations affichées sont correctes, puis cliquez sur Publier.

  11. Pour ouvrir la bibliothèque de documents et tester le processus de remplissage d'un formulaire basé sur ce modèle de formulaire, activez la case à cocher Ouvrir cette bibliothèque de documents, puis cliquez sur Fermer .

    La bibliothèque de documents s'ouvrira dans un navigateur. Lorsque vous cliquez sur Nouveau dans la barre d'outils de liste, un formulaire basé sur ce modèle s'ouvre dans Microsoft Office InfoPath.

Lorsque vous avez publié le modèle de formulaire dans une nouvelle bibliothèque de documents, vous pouvez copier les formulaires existants, créés à partir de l'ancienne version du modèle de formulaire de l'ancienne bibliothèque de documents, dans la nouvelle bibliothèque de documents. Après avoir copié les formulaires existants, vous pouvez recréer des liens entre eux et la nouvelle version du modèle de formulaire. Si vous ne liez pas les formulaires existants, les utilisateurs risquent de ne pas pouvoir les ouvrir.

Haut de la Page

Étape 2 : copier et relier les formulaires existants

Cette procédure part du principe que les deux bibliothèque de documents se trouvent sur un serveur exécutant Windows SharePoint Services 3.0.

  1. Ouvrez l'ancienne bibliothèque de documents dans un navigateur Web.

  2. Dans le menu Affichage, cliquez sur Mode Explorateur.

  3. En maintenant la touche CTRL enfoncée, sélectionnez chaque formulaire que vous voulez déplacer, puis cliquez avec le bouton droit sur un des formulaires.

  4. Dans la boîte de dialogue Internet Explorer, cliquez sur Oui, puis cliquez sur Copier dans le menu contextuel.

  5. Ouvrez la nouvelle bibliothèque de documents.

  6. Sous Sélectionner un affichage , cliquez sur Mode Explorateur .

  7. Cliquez avec le bouton droit dans la zone vierge dans la fenêtre du dossier.

  8. Dans la boîte de dialogue Internet Explorer, cliquez sur Oui, puis cliquez sur Coller dans le menu contextuel.

  9. Dans le menu Affichage, cliquez sur Recréer un lien entre ces documents.

  10. Dans la colonne Recréer un lien, activez la case à cocher pour chaque formulaire que vous souhaitez lier au nouveau modèle de formulaire.

  11. Dans la barre d'outils de liste, cliquez sur Recréer un lien vers les documents sélectionnés.

Lorsque vous avez recréé un lien entre les formulaires existants et le nouveau modèle de formulaire, vos utilisateurs peuvent modifier les formulaires existants, que vous avez copiés dans la nouvelle bibliothèque de documents, ou remplir les nouveaux formulaires, qui sont basés sur le modèle qui vient d'être publié.

Haut de la Page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×