Créer ou supprimer une macro

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Pour automatiser des tâches répétitives, vous pouvez enregistrer rapidement une macro dans Microsoft Office Excel. Vous pouvez également créer une macro à l’aide de Visual Basic Editor dans Microsoft Visual Basic pour écrire votre propre script de macro, ou copier intégralement ou partiellement une macro dans une nouvelle macro. Après avoir créé une macro, vous pouvez l’affecter à un objet (par exemple à un bouton de barre d’outils, un graphique ou un contrôle) pour pouvoir l’exécuter en cliquant sur l’objet. Lorsque vous n’utilisez plus une macro, vous pouvez la supprimer.

Que voulez-vous faire ?

Enregistrer une macro

Créer une macro à l’aide de Microsoft Visual Basic

Pour copier une partie d’une macro vous permettant de créer une autre macro

Affecter une macro à un objet, un graphique ou un contrôle

Supprimer une macro

Enregistrer une macro

Lorsque vous enregistrez une macro, l’enregistreur de macro enregistre toutes les étapes nécessaires à la réalisation des opérations que vous souhaitez que la macro exécute. La navigation dans le ruban n’est pas prévue dans les étapes enregistrées.

Remarque : Le ruban est un composant de l’Interface utilisateur Microsoft Office Fluent.

  1. Si l’onglet Développeur n’est pas disponible, affichez-le de la manière suivante :

    1. Cliquez sur le bouton Microsoft Office Image du bouton Office, puis sur Options Excel.

    2. Dans la catégorie Standard, sous Meilleures options pour travailler avec Excel, cochez la case Afficher l’onglet Développeur dans le ruban, puis cliquez sur OK.

  2. Pour définir temporairement le niveau de sécurité de manière à activer toutes les macros :

    1. Dans l’onglet Développeur, dans le groupe Code, cliquez sur Sécurité des macros.

      Groupe Code de l’onglet Développeur

    2. Sous Paramètres des macros, cliquez sur Activer toutes les macros (non recommandé ; risque d’exécution de code potentiellement dangereux), puis sur OK.

      Remarque : Pour empêcher du code potentiellement dangereux de s’exécuter, il est recommandé de revenir à chacun des paramètres qui désactivent toutes les macros une fois que vous avez fini d’utiliser des macros. Pour plus d’informations sur la modification des paramètres, voir Modifier les paramètres de sécurité des macros dans Excel.

  3. Dans l’onglet Développeur, dans le groupe Code, cliquez sur Enregistrer une macro.

  4. Dans la zone Nom de la macro, tapez le nom de la macro.

Remarque : Le premier caractère du nom de la macro doit être une lettre. Les caractères qui suivent peuvent être des lettres, des nombres ou des traits de soulignement. Les espaces ne peuvent pas être utilisés dans les noms de macro. Un trait de soulignement fonctionne parfaitement pour séparer les mots. Si vous utilisez un nom de macro qui porte le nom d’une référence de cellule, vous pouvez obtenir des messages d’erreur lorsque le nom de macro n’est pas valide.

  1. Pour affecter une touche de raccourci de combinaison Ctrl permettant d’exécuter la macro, dans la zone Touche de raccourci, tapez la lettre minuscule ou majuscule de votre choix.

    Remarque : Le raccourci clavier remplace un raccourci clavier Excel par défaut lorsque le classeur contenant la macro est ouvert. Pour obtenir une liste des raccourcis clavier utilisant la touche Ctrl qui sont déjà affectés dans Excel, reportez-vous à la section Touches de raccourci et de fonction dans Excel.

  2. Dans le champ Enregistrer la macro dans, sélectionnez le classeur dans lequel vous voulez stocker la macro.

    Conseil : Si vous voulez que la macro soit disponible chaque fois que vous utilisez Excel, sélectionnez Classeur de macros personnelles. Lorsque vous sélectionnez Classeur de macros personnelles, Excel crée un classeur de macros personnelles masqué (Personal.xlsb) s’il n’existe pas encore, et y enregistre la macro. Dans Windows Vista, ce classeur est enregistré dans le dossier C:\Users\nom d’utilisateur\AppData\Local\Microsoft\Excel\XLStart. Dans Microsoft Windows XP, ce classeur est enregistré dans le dossier C:\Documents and Settings\nom d’utilisateur\Application Data\Microsoft\Excel\XLStart. Les classeurs dans le dossier XLStart sont ouverts automatiquement au démarrage d’Excel. Si vous souhaitez qu’une macro du classeur de macros personnelles soit exécutée automatiquement dans un autre classeur, vous devez également enregistrer ce dernier dans le dossier XLStart afin que les deux classeurs soient ouverts au démarrage d’Excel.

  3. Dans la zone Description, tapez une description de la macro.

  4. Cliquez sur OK pour commencer à enregistrer.

  5. Effectuez les opérations que vous souhaitez enregistrer.

  6. Dans l’onglet Développeur, dans le groupe Code, cliquez sur Arrêter l’enregistrement Image du bouton.

    Vous pouvez également cliquer sur Arrêter l’enregistrement Image du bouton sur le côté gauche de la barre d’état.

Haut de la page

Créer une macro à l’aide de Microsoft Visual Basic

  1. Si l’onglet Développeur n’est pas disponible, affichez-le de la manière suivante :

    1. Cliquez sur le bouton Microsoft Office Image du bouton Office, puis sur Options Excel.

    2. Dans la catégorie Standard, sous Meilleures options pour travailler avec Excel, cochez la case Afficher l’onglet Développeur dans le ruban, puis cliquez sur OK.

  2. Pour définir temporairement le niveau de sécurité de manière à activer toutes les macros :

    1. Dans l’onglet Développeur, dans le groupe Code, cliquez sur Sécurité des macros.

      Groupe Code de l’onglet Développeur

    2. Sous Paramètres des macros, cliquez sur Activer toutes les macros (non recommandé ; risque d’exécution de code potentiellement dangereux), puis sur OK.

      Remarque : Pour empêcher du code potentiellement dangereux de s’exécuter, il est recommandé de revenir aux paramètres qui désactivent toutes les macros une fois que vous avez fini d’utiliser des macros.

  3. Dans l’onglet Développeur, dans le groupe Code, cliquez sur Visual Basic.

  4. Le cas échéant, dans Visual Basic Editor, cliquez sur Module dans le menu Insertion.

    Remarque : Les modules sont créés automatiquement pour toutes les feuilles du classeur.

  5. Dans la fenêtre de code du module, entrez le code de la macro à utiliser, ou copiez-le.

  6. Pour exécuter la macro à partir de la fenêtre du module, appuyez sur la touche F5.

  7. Dans Visual Basic Editor, dans le menu Fichier, cliquez sur Fermer et retourner à Microsoft Excel lorsque vous avez fini d’écrire la macro.

Haut de la page

Pour copier une partie d’une macro vous permettant de créer une autre macro

  1. Si l’onglet Développeur n’est pas disponible, affichez-le de la manière suivante :

    1. Cliquez sur le bouton Microsoft Office Image du bouton Office, puis sur Options Excel.

    2. Dans la catégorie Standard, sous Meilleures options pour travailler avec Excel, cochez la case Afficher l’onglet Développeur dans le ruban, puis cliquez sur OK.

  2. Pour définir temporairement le niveau de sécurité de manière à activer toutes les macros :

    1. Dans l’onglet Développeur, dans le groupe Code, cliquez sur Sécurité des macros.

      Groupe Code de l’onglet Développeur

    2. Sous Paramètres des macros, cliquez sur Activer toutes les macros (non recommandé ; risque d’exécution de code potentiellement dangereux), puis sur OK.

      Remarque : Pour empêcher du code potentiellement dangereux de s’exécuter, il est recommandé de revenir aux paramètres qui désactivent toutes les macros une fois que vous avez fini d’utiliser des macros.

  3. Ouvrez le classeur contenant la macro à copier.

  4. Dans l’onglet Développeur, dans le groupe Code, cliquez sur Macros.

  5. Dans la zone Nom de la macro, cliquez sur le nom de la macro que vous souhaitez copier.

  6. Cliquez sur Modifier.

  7. Dans la fenêtre de code de Visual Basic Editor, sélectionnez les lignes de la macro que vous souhaitez copier.

Conseil : Pour copier toute la macro, incluez les lignes Sub et End Sub dans la sélection.

  1. Dans le menu Edition, cliquez sur Copier.

    Vous pouvez également cliquer avec le bouton droit de la souris et cliquer sur Copier, ou vous pouvez appuyer sur les touches Ctrl+C.

  2. Dans la zone Procédure de la fenêtre de code, cliquez sur le module, à l’emplacement auquel vous souhaitez positionner le code.

  3. Dans le menu Edition, cliquez sur Coller.

    Vous pouvez également cliquer avec le bouton droit de la souris et cliquer sur Coller, ou vous pouvez appuyer sur les touches Ctrl+V.

Conseil : Vous ne pouvez pas modifier votre fichier de classeur de macros personnelles (Personal.xls), car il s’agit d’un classeur masqué qui est toujours ouvert. Vous devez d’abord l’afficher à l’aide de la commande Afficher. Vous pouvez également l’ouvrir dans Visual Basic Editor en appuyant sur les touches Alt+F11.

Haut de la page

Affecter une macro à un objet, un graphique ou un contrôle

  1. Dans une feuille de calcul, cliquez avec le bouton droit de la souris sur l’objet, le graphique ou le contrôle auquel vous souhaitez affecter une macro existante, puis cliquez sur Affecter une macro.

  2. Dans la zone Nom de la macro, cliquez sur la macro à affecter.

Haut de la page

Supprimer une macro

  1. Effectuez l’une des opérations suivantes :

    • Ouvrez le classeur contenant la macro à supprimer.

    • Si la macro à supprimer est stockée dans le classeur des macros personnelles (Personal.xlsb) et que celui-ci est masqué, procédez comme suit pour afficher le classeur :

      1. Dans l’onglet Affichage, dans le groupe Fenêtre, cliquez sur Afficher.

      2. Sous Afficher le classeur, cliquez sur PERSONAL, puis cliquez sur OK.

  2. Si l’onglet Développeur n’est pas disponible, affichez-le de la manière suivante :

    1. Cliquez sur le bouton Microsoft Office Image du bouton Office, puis sur Options Excel.

    2. Dans la catégorie Standard, sous Meilleures options pour travailler avec Excel, activez la case à cocher Afficher l’onglet Développeur dans le ruban, puis cliquez sur OK.

  3. Dans l’onglet Développeur, dans le groupe Code, cliquez sur Macros.

    Groupe Code de l’onglet Développeur

  4. Dans la liste Macros dans, sélectionnez le classeur qui contient la macro à supprimer. Par exemple, cliquez sur Ce classeur.

  5. Dans la zone Nom de la macro, cliquez sur le nom de la macro que vous souhaitez supprimer.

  6. Cliquez ensuite sur Supprimer.

Haut de la page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Ces informations vous ont-elles été utiles ?

Comment pouvons-nous nous améliorer ?

Comment pouvons-nous nous améliorer ?

Afin de protéger votre vie privée, n’indiquez aucune information de contact dans vos commentaires. Lisez notre déclaration de confidentialité.

Nous vous remercions pour vos commentaires.