Créer une zone de liste en cascade

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Zones de liste en cascade aident les utilisateurs à remplir des formulaires plus rapidement et de vous assurer que les utilisateurs entrent des données correctement. Cet article décrit comment créer et remplir des zones de liste en cascade avec des données. Dans Microsoft Office InfoPath, vous pouvez remplir une liste avec des données qui utilisant des valeurs de formulaire, des valeurs d'un document de langage XML (Extensible Markup) externes ou des valeurs d'une base de données Microsoft Office Access.

Dans cet article

Qu'est une zone de liste en cascade ?

Étape 1: Insérer une zone de liste en cascade

Étape 2: Fournir les données

Qu'est une zone de liste en cascade ?

Une zone de liste en cascade est une zone de liste avec les options qui changent en fonction de la valeur qu'un utilisateur sélectionne une autre zone de liste. Par exemple, si un utilisateur clique sur Condiments dans la zone catégories présentée dans l'illustration suivante, la zone produits affiche une liste de condiments.

Exemple de zone de liste en cascade

Les sections suivantes vous montrent comment créer un modèle de formulaire avec deux zones de liste, où la deuxième zone de liste est filtrée selon la valeur de qu'un utilisateur sélectionne dans la zone de liste. Lorsque la valeur dans la première zone de liste change, le filtre est appliqué automatiquement vers la deuxième zone de liste qui modifie ses valeurs.

Considérations en matière de compatibilité

Filtres peuvent être utilisés que dans les modèles de formulaire qui sont conçus pour être remplis dans InfoPath. Filtres ne sont pas disponibles dans les modèles de formulaires compatibles avec les navigateurs.

Haut de la page

Étape 1: Insérer une zone de liste en cascade

Pour créer une zone de liste en cascade, vous devez insérer deux zones de liste dans votre modèle de formulaire.

Remarque : Lorsque vous insérez une zone de liste en cascade dans votre modèle de formulaire, assurez-vous que les deux zones de liste ne sont pas dans une section extensible ou tableau extensible.

  1. Si le volet Office Contrôles n’est pas visible, cliquez sur Autres contrôles dans le menu Insertion, ou appuyez sur Alt+I, C.

  2. Sous Insérer des contrôles dans le volet Office contrôles, cliquez sur Zone de liste déroulante. Lorsqu'un utilisateur remplit un formulaire basé sur votre modèle de formulaire, la sélection dans cette zone de liste déroulante déterminera les choix sont disponibles dans la deuxième zone de liste.

  3. Cliquez sur zone de liste. Votre modèle de formulaire doit maintenant contenir une zone de liste déroulante et une zone de liste standard.

    Zone de liste déroulante et zone de liste dans un formulaire

  4. Double-cliquez sur la zone de liste déroulante que vous avez inséré dans votre modèle de formulaire à l'étape 2.

  5. Dans la boîte de dialogue Propriétés de zone de liste déroulante, cliquez sur l'onglet données.

  6. Dans la zone nom du champ, tapez Zoneliste1, puis cliquez sur OK.

  7. Double-cliquez sur la zone de liste que vous avez inséré dans votre modèle de formulaire à l'étape 3.

  8. Dans la boîte de dialogue Propriétés de zone de liste, cliquez sur l'onglet données.

  9. Dans la zone nom du champ, tapez listBox2Cascade, puis cliquez sur OK.

Haut de la page

Étape 2: Fournir les données

Maintenant que vous avez inséré les zones de liste dans votre modèle de formulaire, vous devez fournir les données qu'ils seront affichent. Puis vous devez appliquer un filtre afin que les choix dans la deuxième zone de liste sont basés sur la sélection de l'utilisateur dans la première zone de liste.

Cette section explique comment connecter les zones de liste à des données à l'aide de trois méthodes courantes : ajouter les données dans le formulaire lui-même ; connexion du formulaire à un document XML existant qui contient les données ; ou connexion du formulaire à une base de données qui contient les données. Pour terminer la création de votre zone de liste en cascade, cliquez sur la méthode que vous souhaitez utiliser dans la liste suivante.

Se connecter aux données dans le formulaire

Se connecter à un document XML externe

Se connecter à une base de données

Se connecter aux données dans le formulaire

Dans cette section, vous allez apprendre à remplir les zones de liste avec des données à partir de l'écran. Pour ce faire, vous devez d'abord configurer les champs dans le modèle de formulaire afin que vous puissiez entrer les noms des catégories et un ensemble de produits pour chaque catégorie.

Configurer les champs dans le modèle de formulaire

  1. Si le volet Office Source de données n'est pas visible, cliquez sur Source de données dans le menu affichage.

  2. Dans le volet Office Source de données, cliquez sur le groupe mesChamps, puis cliquez sur Ajouter.

  3. Dans la zone nom, dans la boîte de dialogue Ajouter un champ ou un groupe, tapez CatégoriesEtProduits.

  4. Dans la liste Type, cliquez sur groupe.

  5. Activez la case à cocher extensible, puis cliquez sur OK.

  6. Dans le volet Office Source de données, cliquez sur le groupe CatégoriesEtProduits.

  7. Dans la zone nom, dans la boîte de dialogue Ajouter un champ ou un groupe, tapez catégorie, puis cliquez sur OK. Ce champ contient les noms des catégories pour la première zone de liste.

  8. Cliquez sur le groupe CatégoriesEtProduits, puis cliquez sur Ajouter.

  9. Dans la zone nom, dans la boîte de dialogue Ajouter un champ ou un groupe, tapez produit.

  10. Activez la case à cocher extensible, puis cliquez sur OK. Ce champ contient les noms des produits de la deuxième zone de liste.

Étant donné que cette zone de liste est remplie avec des données à partir de l'écran, les données doivent être ajoutées au formulaire. Pour ce faire, vous devrez créer des valeurs par défaut pour les champs produit et catégorie.

Conseil

Vous pouvez également créer des zones de liste qui affichent les valeurs que les utilisateurs tapent dans l'écran eux-mêmes. Pour ce faire, associer la zone de liste avec des champs qui sont liés aux contrôles dans le formulaire. Lorsqu'un utilisateur entre des valeurs dans les contrôles, les choix dans la zone de liste modifier.

Créer des valeurs par défaut

  1. Dans le menu Outils, cliquez sur Les valeurs par défaut.

  2. Dans la boîte de dialogue Modifier les valeurs par défaut, dans le groupe CatégoriesEtProduits, sélectionnez le champ catégorie (ne désactivez pas la case à cocher), puis dans la zone valeur par défaut, tapez mer.

  3. Sélectionnez le champ produit (ne désactivez pas la case à cocher), puis dans la zone valeur par défaut, tapez crabe viande.

  4. Cliquez sur le champ produit, puis cliquez sur Ajouter un autre produit ci-dessus. Cela vous permet d'ajouter un deuxième produit pour mer comme une valeur par défaut.

  5. Avec le bouton droit de la deuxième instance du champ produit (ne désactivez pas la case à cocher), puis dans la zone valeur par défaut, tapez saumon.

  6. Cliquez sur le groupe CatégoriesEtProduits, puis cliquez sur Ajouter un autre CatégoriesEtProduits ci-dessous. Cela vous permet d'ajouter une deuxième catégorie comme une valeur par défaut.

  7. Utilisez les étapes précédentes pour spécifier les valeurs par défaut pour la deuxième instance des champs de catégorie et de produit à produits laitiersCheddar et chocolat, respectivement.

  8. Cliquez sur OK.

À présent que vous avez entré les valeurs par défaut pour les champs de catégorie et de produit, vous pouvez vous connecter à la première zone de liste aux données que vous venez d'entrer.

Connecter la première zone de liste aux données

  1. Dans le modèle de formulaire, double-cliquez sur la zone de liste déroulante que vous avez inséré précédemment.

  2. Cliquez sur l'onglet Données.

  3. Dans la boîte de dialogue Propriétés de zone de liste déroulante sous entrées de la liste, cliquez sur Rechercher des valeurs dans la source de données du formulaire.

  4. Cliquez sur Sélectionner une expression XPath  Image du bouton en regard de la zone Entrées.

  5. Dans la boîte de dialogue Sélectionner un champ ou un groupe, dans le groupe CatégoriesEtProduits, cliquez sur le champ catégorie, puis cliquez sur OK.

Maintenant que vous devez vous connecter à la deuxième zone de liste aux données. Lorsque vous effectuez cette connexion de données, vous devez appliquer un filtre à la deuxième zone de liste. Ce filtre sera remplir la deuxième zone de liste avec les produits appropriés, en fonction de la catégorie sélectionnée dans la zone de liste. Le filtre compare la valeur sélectionnée dans la première zone de liste (champ Zoneliste1) avec la liste des catégories enregistrées dans le formulaire (champ de catégorie).

Connecter la deuxième zone de liste aux données

  1. Dans le modèle de formulaire, double-cliquez sur la zone de liste standard que vous avez inséré précédemment.

  2. Cliquez sur l'onglet Données.

  3. Dans la boîte de dialogue Propriétés de zone de liste, sous entrées de la liste, cliquez sur Rechercher des valeurs dans la source de données du formulaire.

  4. Cliquez sur Sélectionner une expression XPath  Image du bouton en regard de la zone Entrées.

  5. Dans la boîte de dialogue Sélectionner un champ ou un groupe, dans le groupe CatégoriesEtProduits, cliquez sur le champ produit, puis cliquez sur Filtrer les données.

  6. Dans la boîte de dialogue Filtrer les données, cliquez sur Ajouter.

  7. Dans la boîte de dialogue Spécifier les Conditions du filtre, cliquez sur Sélectionner un champ ou un groupe dans la première zone.

  8. Dans la boîte de dialogue Sélectionner un champ ou un groupe, cliquez sur Zoneliste1, puis cliquez sur OK.

  9. Dans la boîte de dialogue Spécifier les Conditions du filtre, cliquez sur Sélectionner un champ ou un groupe dans la troisième zone.

  10. Dans la boîte de dialogue Sélectionner un champ ou un groupe, cliquez sur le champ catégorie, puis cliquez sur OK pour fermer toutes les boîtes de dialogue Ouvrir.

À présent que vous avez connecté la deuxième zone de liste aux données et le filtre appliqué, vous êtes prêt à tester les zones de liste pour vous assurer qu'elles fonctionnent correctement.

Tester les zones de liste

  1. Pour tester vos modifications, cliquez sur Aperçu dans la barre d’outils Standard, ou appuyez sur Ctrl+Maj+B.

  2. Dans la zone de liste déroulante, cliquez sur mer. La zone de liste standard doit afficher une ligne vide, de viande de mer et saumon.

    Remarque : La ligne vierge permet aux utilisateurs de supprimer leur choix dans la zone de liste.

Si les zones de liste ne fonctionnent pas correctement, passez en revue le filtre de la deuxième zone de liste pour vous assurer qu'il compare le champ Zoneliste1 avec le champ catégorie.

Haut de la section

Se connecter à un document XML externe

Dans cette section, vous allez apprendre à créer une connexion de données à un document XML qui contient des valeurs de produit et la catégorie. Le document XML sera votre source de données secondaire. Pour créer cette connexion de données, vous devez créer le document XML, associer les zones de liste dans le modèle de formulaire avec le document XML et puis appliquer un filtre à la deuxième zone de liste afin que la liste de produits change de manière appropriée.

Avant que vous pouvez associer le formulaire à une source de données secondaire, vous devez créer le document XML.

Créer le document XML

  1. Démarrez le bloc-notes ou un autre éditeur de texte.

  2. Copiez et collez les données XML suivantes dans l'éditeur de texte :

    <?xml version="1.0" encoding="UTF-8"?>
    <ListBoxData>
    <CategoriesAndProducts>
    <Categories>Seafood</Categories>
    <Products>
    <Product>Crab meat</Product>
    </Products>
    <Products>
    <Product>Salmon</Product>
    </Products>
    </CategoriesAndProducts>
    <CategoriesAndProducts>
    <Categories>Dairy</Categories>
    <Products>
    <Product>Chocolate milk</Product>
    </Products>
    <Products>
    <Product>Cheddar</Product>
    </Products>
    </CategoriesAndProducts>
    </ListBoxData>
  3. Enregistrez le fichier sur votre ordinateur sous DonnéesZoneListe.XML.

Maintenant que vous avez créé un document XML, vous pouvez vous connecter au modèle de formulaire. Cela créera une source de données secondaire.

Lier le document XML au modèle de formulaire

  1. Dans le menu Outils, cliquez sur Connexions de données.

  2. Dans la boîte de dialogue Connexions de données, cliquez sur Ajouter.

  3. Dans l'Assistant Connexion de données, cliquez sur Réception des données, puis cliquez sur Suivant.

  4. Dans la page suivante de l'Assistant, cliquez sur document XML, puis cliquez sur suivant.

  5. Dans la page suivante de l'Assistant, cliquez sur Parcourir, sélectionnez le fichier DonnéesZoneListe.XML que vous avez enregistrée sur votre ordinateur, puis sur Ouvrir.

  6. Dans la page suivante de l'Assistant, cliquez sur inclure les données sous forme d'un fichier de ressources dans le modèle de formulaire ou un composant de modèle, puis cliquez sur suivant.

  7. Dans la page suivante de l'Assistant, dans la zone Entrez un nom pour cette connexion de données, tapez FichierXMLDonnéesZoneListe.

  8. Activez la case à cocher extraire automatiquement les données lorsque le formulaire est ouvert. Cela garantit que les données de zone de liste sera disponibles chaque fois que le formulaire est ouvert, au lieu d'obliger l'utilisateur à la requête pour qu'elle.

  9. Cliquez sur Terminer.

  10. Dans la boîte de dialogue Connexions de données, cliquez sur Fermer.

Vous êtes maintenant prêt à connecter la première zone de liste dans le modèle de formulaire aux données dans le document XML.

Connecter la première zone de liste aux données

  1. Dans le modèle de formulaire, double-cliquez sur la zone de liste déroulante que vous avez inséré précédemment.

  2. Cliquez sur l'onglet Données.

  3. Dans la boîte de dialogue Propriétés de zone de liste déroulante sous entrées de la liste, cliquez sur Rechercher des valeurs d'une source de données externes.

  4. Dans la zone source de données, cliquez sur FichierXMLDonnéesZoneListe.

  5. Cliquez sur Sélectionner une expression XPath  Image du bouton en regard de la zone Entrées.

  6. Dans la boîte de dialogue Sélectionner un champ ou un groupe, dans le groupe CatégoriesEtProduits, cliquez sur le champ catégories.

    Remarque : L'arrière-plan jaune dans la boîte de dialogue Sélectionner un champ ou un groupe indique que vous travaillez avec une source de données secondaire.

  7. Cliquez deux fois sur OK.

Vous devez maintenant connecter la deuxième zone de liste dans le document XML. Lorsque vous effectuez cette connexion de données, vous devez appliquer un filtre à la deuxième zone de liste. Ce filtre sera remplir la deuxième zone de liste avec les produits appropriés, en fonction de la catégorie sélectionnée dans la zone de liste. Le filtre compare la valeur sélectionnée dans la première zone de liste (champ Zoneliste1) avec la liste des catégories enregistrées dans le formulaire (champ de catégorie).

Connecter la deuxième zone de liste aux données

  1. Dans le modèle de formulaire, double-cliquez sur la zone de liste standard que vous avez inséré précédemment.

  2. Cliquez sur l'onglet Données.

  3. Dans la boîte de dialogue Propriétés de zone de liste, sous entrées de la liste, cliquez sur Rechercher des valeurs d'une source de données externes.

  4. Dans la zone source de données, cliquez sur FichierXMLDonnéesZoneListe.

  5. Cliquez sur Sélectionner une expression XPath  Image du bouton en regard de la zone Entrées.

  6. Dans la boîte de dialogue Sélectionner un champ ou un groupe, dans le groupe CatégoriesEtProduits, développez le groupe de produits, puis cliquez sur le champ produit.

  7. Cliquez sur Filtrer les données.

  8. Dans la boîte de dialogue Filtrer les données, cliquez sur Ajouter.

  9. Dans la boîte de dialogue Spécifier les Conditions du filtre, cliquez sur Sélectionner un champ ou un groupe dans la première zone.

  10. Dans la zone source de données, dans la boîte de dialogue Sélectionner un champ ou un groupe, cliquez sur principale.

  11. Cliquez sur Zoneliste1, puis cliquez sur OK.

  12. Dans la boîte de dialogue Spécifier les Conditions du filtre, cliquez sur Sélectionner un champ ou un groupe dans la troisième zone.

  13. Dans la zone source de données, dans la boîte de dialogue Sélectionner un champ ou un groupe, cliquez sur FichierXMLDonnéesZoneListe (secondaire), puis cliquez sur catégories.

  14. Cliquez sur OK pour fermer l’ensemble des boîtes de dialogue ouvertes.

À présent que vous avez connecté la deuxième zone de liste au document XML et le filtre appliqué, vous êtes prêt à tester les zones de liste pour vous assurer qu'elles fonctionnent correctement.

Tester les zones de liste

  1. Pour tester vos modifications, cliquez sur Aperçu dans la barre d’outils Standard, ou appuyez sur Ctrl+Maj+B.

  2. Dans la zone de liste déroulante, cliquez sur mer. La zone de liste standard doit afficher uniquement une ligne vide, de viande de mer et saumon.

    Remarque : La ligne vierge permet aux utilisateurs de supprimer leur choix dans la zone de liste.

Si les zones de liste ne fonctionnent pas correctement, passez en revue le filtre de la deuxième zone de liste pour vous assurer qu'il compare le champ Zoneliste1 avec le champ catégorie.

Haut de la section

Se connecter à une base de données

Dans cette section, vous allez apprendre à créer une connexion de données à deux tables dans une base de données Access. Pour ce faire, vous associez les zones de liste dans le modèle de formulaire à la base de données et puis appliquez un filtre à la deuxième zone de liste pour que la liste affichée correctement dans la deuxième zone change liste basée sur la valeur sélectionnée dans la zone de liste. Dans cet exemple, supposons que la base de données Access contienne deux tables appelées Categories and Products, et que les deux tables sont liés entre eux par le champ CategoryID, qui est utilisé dans chaque table.

Table catégories   

Code catégorie

Nom de la catégorie

1

Mer

2

Produits laitiers

Table de produits   

ID de produit

Code catégorie

NomProduit

1

1

Viande de mer

2

1

Saumon

3

2

Chocolat

4

2

Cheddar

Connecter le modèle de formulaire à la source de données

Tout d'abord, vous devez créer une connexion de données entre le modèle de formulaire et les tables dans la base de données. Étant donné que vous affichez uniquement les données à partir de la base de données, au lieu de modifier directement, la base de données Access seront une source de données secondaire pour le modèle de formulaire.

  1. Dans le menu Outils, cliquez sur Connexions de données.

  2. Dans la boîte de dialogue Connexions de données, cliquez sur Ajouter.

  3. Dans l'Assistant Connexion de données, cliquez sur Réception des données, puis cliquez sur Suivant.

  4. Dans la page suivante de l'assistant, cliquez sur Base de données (uniquement Microsoft SQL Server ou Microsoft Office Access) puis cliquez sur Suivant.

  5. Dans la page suivante de l'Assistant, cliquez sur Sélectionner une base de données et puis recherchez et double-cliquez sur la base de données Access sur votre disque dur.

  6. Dans la boîte de dialogue Sélectionner le tableau, cliquez sur la table qui contient les données que vous souhaitez afficher dans la première liste (dans cet exemple, la table Categories), puis cliquez sur OK. Spécifie la table en tant que table primaire de la connexion de données.

  7. Dans l'Assistant, cliquez sur Ajouter une Table.

  8. Dans la boîte de dialogue Ajouter une Table ou requête, cliquez sur la table qui contient les données que vous souhaitez afficher dans la seconde liste (dans cet exemple, la table produits), puis cliquez sur suivant.

  9. Dans la boîte de dialogue Modifier la relation, vérifiez que les champs de connexion sont corrects. Dans cet exemple, les tables sont liées à l'autre par le champ CategoryID.

    Conseil : Si les champs de connexion sont incorrects, sélectionnez les champs, puis cliquez sur Supprimer la relation. Ensuite, cliquez sur Ajouter une relation, sélectionnez les champs appropriés, puis cliquez sur OK.

  10. Cliquez sur Terminer.

    Remarque : Dans cet exemple, la table categories a une relation un-à-plusieurs à la table products, ce qui signifie que pour chaque catégorie il peut y avoir plusieurs produits. Dans une base de données, ce type de relation est généralement défini à l'aide de champs de clé. Dans ce cas, le champ de clé CategoryID autorise l'accès à associer le bon ensemble de produits avec les catégories appropriées.

  11. Dans l'Assistant, passez en revue la structure de source de données. Vous devriez voir deux tables connectés entre eux : la table primaire et la table secondaire. Pour afficher les champs individuels dans le tableau, activez la case à cocher Afficher les colonnes d'un tableau. Une fois que vous avez terminé la révision de la structure de données, cliquez sur suivant.

  12. Désactivez la case à cocher Enregistrer une copie des données dans le modèle de formulaire, puis cliquez sur Suivant.

  13. Dans la zone Entrez un nom pour cette connexion de données, dans la page suivante de l'Assistant, tapez un nom pour la connexion de données.

  14. Activez la case à cocher extraire automatiquement les données lorsque le formulaire est ouvert.

  15. Cliquez sur Terminer, puis cliquez sur Fermer dans la boîte de dialogue Connexions de données.

Connecter la première zone de liste à des données

Maintenant que vous avez créé une connexion de données à la source de données secondaire, vous pouvez vous connecter à la première zone de liste dans le modèle de formulaire aux tables de la base de données.

  1. Dans le modèle de formulaire, double-cliquez sur la zone de liste déroulante que vous avez inséré précédemment.

  2. Cliquez sur l'onglet Données.

  3. Dans la boîte de dialogue Propriétés de zone de liste déroulante sous entrées de la liste, cliquez sur Rechercher des valeurs d'une source de données externes.

  4. Dans la zone source de données, vérifiez que la connexion de données que vous avez créé est activée.

  5. Cliquez sur Sélectionner une expression XPath  Image du bouton en regard de la zone Entrées.

  6. Dans la boîte de dialogue Sélectionner un champ ou un groupe, cliquez sur le nom de la table qui contient les données que vous souhaitez afficher dans la liste déroulante (dans cet exemple, d: catégories ), puis cliquez sur OK.

    Remarque : L'arrière-plan jaune dans la boîte de dialogue Sélectionner un champ ou un groupe indique que vous travaillez avec une source de données secondaire.

  7. Cliquez sur Sélectionner une expression XPath Image du bouton en regard de la zone valeur.

  8. Dans la boîte de dialogue Sélectionner un champ ou un groupe, assurez-vous que le champ qui se connecte (dans cet exemple, : CategoryID ) est sélectionnée, puis cliquez sur OK. Il s'agit de la valeur qui sera enregistrée lorsque l'utilisateur effectue une sélection dans la zone de liste.

  9. Cliquez sur Sélectionner une expression XPath Image du bouton en regard de la zone nom complet.

  10. Dans la boîte de dialogue Sélectionner un champ ou un groupe, cliquez sur le nom du champ que vous souhaitez afficher dans la liste déroulante (dans cet exemple, : nom de la catégorie ).

  11. Cliquez deux fois sur OK.

Connecter la deuxième zone de liste à des données

Vous devez maintenant connecter la deuxième zone de liste à la base de données. Lorsque vous effectuez cette connexion de données, vous devez appliquer un filtre à la deuxième zone de liste. Ce filtre sera remplir la deuxième zone de liste avec les valeurs appropriées, en fonction de la valeur qui sont sélectionnés dans la première zone de liste.

  1. Dans le modèle de formulaire, double-cliquez sur la zone de liste standard.

  2. Cliquez sur l'onglet Données.

  3. Dans la boîte de dialogue Propriétés de zone de liste, sous entrées de la liste, cliquez sur Rechercher des valeurs d'une source de données externes.

  4. Dans la zone source de données, vérifiez que la connexion de données que vous avez créé est activée.

  5. Cliquez sur Sélectionner une expression XPath  Image du bouton en regard de la zone Entrées.

  6. Dans la boîte de dialogue Sélectionner un champ ou un groupe, développez le groupe (dans cet exemple, d: catégories ) principal, puis cliquez sur le groupe secondaire qui correspond à la table qui contient les données que vous voulez afficher dans la zone de liste en cascade (dans cet exemple, produits ).

  7. Cliquez sur Filtrer les données.

  8. Dans la boîte de dialogue Filtrer les données, cliquez sur Ajouter.

  9. Dans la boîte de dialogue Spécifier les Conditions du filtre dans la première zone, vérifiez que le champ qui se connecte à partir de la table secondaire (dans cet exemple, produits ) est sélectionné.

    Important : Si les champs de connexion portent le même nom dans les deux tables, assurez-vous que vous sélectionnez l'option correcte. Les champs de chaque table sont triés ensemble dans la liste. Par conséquent, vous pouvez utiliser les noms de champs environnante pour déterminer qui est correcte. Dans cet exemple, nous allons sélectionner le champ CategoryID qui s'affiche avec les autres champs de la table produits.

  10. Dans la troisième zone, cliquez sur Sélectionner un champ ou un groupe.

  11. Dans la zone source de données, dans la boîte de dialogue Sélectionner un champ ou un groupe, cliquez sur principale et cliquez sur le champ Zoneliste1, puis cliquez sur OK.

    Vous avez configuré un filtre qui compare la valeur sélectionnée dans la zone de liste déroulante (champ Zoneliste1) avec la liste de valeurs dans la zone de liste standard.

  12. Cliquez trois fois sur OK pour revenir à la boîte de dialogue Propriétés de zone de liste.

  13. Cliquez sur Sélectionner une expression XPath Image du bouton en regard de la zone valeur.

  14. Dans la boîte de dialogue Sélectionner un champ ou un groupe, sélectionnez la valeur que vous voulez enregistrer lorsque l'utilisateur effectue une sélection dans la zone de liste. Dans cet exemple, nous préférable d'enregistrer le champ Réf produit pour une utilisation ultérieure. Par conséquent, nous allons sélectionner la : ProductID de groupe, puis cliquez sur OK.

  15. Cliquez sur Sélectionner une expression XPath Image du bouton en regard de la zone nom complet.

  16. Dans la boîte de dialogue Sélectionner un champ ou un groupe, cliquez sur le nom du champ que vous voulez afficher dans la zone de liste (dans cet exemple, : ProductName ).

  17. Cliquez deux fois sur OK.

Tester les zones de liste

À présent que vous avez connecté la deuxième zone de liste à la base de données et le filtre appliqué, vous êtes prêt à tester les zones de liste pour vous assurer qu'elles fonctionnent correctement.

  1. Pour tester vos modifications, cliquez sur Aperçu dans la barre d’outils Standard, ou appuyez sur Ctrl+Maj+B.

  2. Sélectionnez une valeur dans la zone de liste déroulante. La zone de liste standard doit afficher les valeurs appropriées dans la table secondaire, selon le champ de connexion que vous avez choisi.

Conseil : Si les zones de liste ne fonctionnent pas correctement, passez en revue le filtre de la deuxième zone de liste pour vous assurer qu'il compare le champ Zoneliste1 avec le champ CategoryID.

Haut de la section

Haut de la page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×