Créer une solution de suivi des biens à l’aide d’InfoPath et Excel

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Microsoft Office InfoPath vous permet de créer des modèles de formulaire d’entrée de données et de collection de sites. Microsoft Office Excel 2007 permet aux utilisateurs de calculer, graphique et analyser des données. À l’aide de ces programmes et XML, vous pouvez facilement créer un simple mais solution d’entreprise efficace, sans code pour le suivi des biens dans une société.

Vue d’ensemble de la solution de suivi des biens

Dans cet article

Introduction à la création d’une solution de suivi des biens

Étape 1 : Personnaliser le modèle de formulaire de suivi des biens

Étape 2 : Mapper le fichier de schéma et personnaliser la disposition du tableau dans Excel

Étape 3 : Créer un rapport de synthèse de tableau croisé dynamique et graphique croisé dynamique

Étape 4 : Collecter les informations sur les éléments des utilisateurs

Étape 5 : Importer des formulaires dans Excel

Conclusions : envisagez d’utiliser une base de données Access ou une liste SharePoint

Introduction à la création d’une solution de suivi des biens

Vous pouvez échanger des données XML entre InfoPath et Excel. Bien que la commande Infopath Exporter soit simple, simples à envoyer des données de formulaire vers Excel, il existe une autre approche que vous pouvez prendre qui vous donne une plus grande flexibilité. En mappant explicitement le fichier de schéma (.xsd) InfoPath XML dans Excel et puis l’importation de fichiers de formulaire InfoPath (.xml) dans Excel, vous pouvez personnaliser la mise en page de vos données et mieux exploiter les fonctionnalités d’Excel pour vous aider à gérer et analyser vos données plus efficacement.

Dans cet article, nous utiliserons le modèle de formulaire InfoPath bien suivi exemple afin d’illustrer comment vous pouvez apporter InfoPath, XML et Excel travailler ensemble. Imaginons que chaque année, votre organisation répertorie actifs dans office de chaque employé. Ensuite, un rapport Excel est exécuté pour aider à déterminer comment répartir le budget d’équipement pour l’année suivante. Le diagramme suivant est une vue d’ensemble de comment vous pouvez collecter, effectuer le suivi et rapport de données actif dans votre service.

a

1. le modèle de formulaire de suivi des biens est créé.

2. le fichier de schéma est mappé à un tableau Excel et la disposition du tableau est personnalisée.

3. un rapport de synthèse tableau croisé dynamique et graphique croisé dynamique vide est créé.

4. le formulaire de suivi des biens est utilisé pour collecter les données des utilisateurs.

5. toutes les données de formulaire sont exportées dans le tableau Excel et les rapports de tableau croisé dynamique et graphique croisé dynamique sont actualisés.

Cette solution comprend les produits et les rôles utilisateur suivants :

Icône Support total = requis Icône Pas de support = non requis

Configuration logicielle requise

Rôles

Office InfoPath 2007

Office Outlook 2007

Office Excel 2007

Concepteur de solutions

Icône Support total

Icône Support total

Icône Support total

Décideurs informatiques

Icône Support total

Icône Support total

Icône Support total

Employés

Icône Support total

Icône Support total

Icône Pas de support

Haut de la Page

Étape 1 : Personnaliser le modèle de formulaire de suivi des biens

Le modèle de formulaire de suivi des biens, qui est inclus dans InfoPath, vous permet de recueillir des informations sur chaque élément d’office d’un employé, le service de l’employé appartient, catégories d’actifs et plus d’informations sur chaque élément. Dans cette solution, un concepteur de formulaires soumet le modèle de formulaire au compte de messagerie de décideurs à l’aide de Office Outlook 2007.

Modèle de suivi des biens

Tâche 1 : Ouvrir et personnaliser le modèle de formulaire de suivi des biens

Étant donné que vous ne peut pas publier un modèle de formulaire vers une liste de destinataires de messages électroniques dans le cas d’un contrôle de zone de texte enrichi contenant des images liées, vous devez apporter une petite modification à l’exemple de formulaire de modèle suivi des biens.

  1. Dans le menu Fichier, cliquez sur Créer un modèle de formulaire.

  2. Dans la boîte de dialogue créer un modèle de formulaire, sous Ouvrir un modèle de formulaire, cliquez sur Personnaliser un exemple.

  3. Dans la boîte de dialogue Mise en route, cliquez sur Sample - suivi des biens et puis, sous Tâches de formulaire, cliquez sur modifier ce formulaire.

  4. Cliquez avec le bouton droit sur le contrôle assetNotes pointez sur Propriétés de Zone de texte enrichi et cliquez sur l’onglet affichage, puis sous mises en forme disponibles, désactivez la case à cocher Images liées.

Tâche 2 : Définir les options d’envoi

La tâche suivante consiste à définir les options d’envoi pour que les employés puissent envoyer un fichier nommé de manière unique formulaire (.xml) au compte de messagerie de décideurs comme un fichier joint.

  1. Dans le menu Outils, cliquez sur Options d’envoi.

  2. Dans la boîte de dialogue Options d’envoi, activez la case à cocher Autoriser les utilisateurs à envoyer ce formulaire.

  3. Cliquez sur Envoyer les données du formulaire vers une seule destination puis, dans la liste, cliquez sur Message électronique.

  4. Cliquez sur Ajouter.

    L' Assistant connexion de données apparaît.

  5. Dans la zone à, tapez l’alias de la décideurs qui recevra tous les formulaires envoyés.

  6. Pour spécifier une ligne d’objet unique, dans la zone objet:

    • Cliquez sur Insérer une formule Bouton Formule .

    • Tapez la formule suivante :

concat(my:employee/my:employeeName, my:employee/my:employeeDepartment)

  • Cliquez sur Vérifier la formule, puis cliquez sur OK à deux reprises.

  • Dans la zone Introduction, tapez un message approprié ou ajoutez des instructions importantes pour cette solution.

  • Cliquez sur Suivant.

  • Dans la page suivante de l’Assistant, cliquez sur Envoyer les données du formulaire en tant que pièce jointe et puis activez la case à cocher joindre le modèle de formulaire pour garantir que les utilisateurs pourront ouvrir le formulaire.

    Cela permet de garantir que les employés ont accès au fichier de modèle de formulaire (.xsn) au cas où ils ne peuvent pas y accéder à partir de son emplacement réseau.

  • Pour spécifier un un nom de fichier unique pour chaque fichier de formulaire (.xml) dans la zone Nom de la pièce jointe:

    1. Cliquez sur Insérer une formule Bouton Formule .

    2. Tapez la même formule en tant que celui de la ligne d’objet:

concat(my:employee/my:employeeName, my:employee/my:employeeDepartment)

  1. Cliquez sur Vérifier la formule, puis cliquez sur OK à deux reprises.

  • Cliquez sur Suivant.

  • Dans la page suivante de l’Assistant, dans la zone Entrez un nom pour cette connexion de données, tapez un nom descriptif pour ce soumettre la connexion de données.

  • Vérifiez l'exactitude des informations de la zone Résumé, puis cliquez sur Terminer.

  • Enregistrez le formulaire dans un dossier réseau public accessible pour les décideurs et à tous les employés.

Haut de la Page

Étape 2 : Mapper le fichier de schéma et personnaliser la disposition du tableau dans Excel

Configuration de la connexion entre InfoPath et Excel nécessite trois tâches : extraire le fichier de schéma pour le modèle de formulaire de suivi des biens, mappage de ce fichier de schéma dans Excel et personnalisation de la disposition par défaut de la table Excel contenant le fichier XML importé fichiers de données de formulaire.

Tâche 1 : Extraire le fichier de schéma d’InfoPath

  1. Dans InfoPath, ouvrez le fichier de modèle de formulaire de suivi des biens.

  2. Dans le menu Outils, cliquez sur modifier ce formulaire.

  3. Dans le menu Fichier, cliquez sur Enregistrer en tant que fichiers source.

  4. Dans la boîte de dialogue Rechercher un dossier, sélectionnez un dossier ou créer un dossier dans lequel vous souhaitez stocker le fichier de schéma.

Notez l’emplacement du dossier dans lequel tous les fichiers source sont enregistrés et le nom du fichier de schéma, dans ce cas, myschema.xsd, qui contient la définition de schéma du formulaire de données XML.

Tâche 2 : Mapper le fichier de schéma InfoPath dans Excel

  1. Créer un fichier Excel et enregistrez-le dans un emplacement accessible à la décideurs.

  2. Dans Excel, si l’onglet développeur n’est pas visible, procédez comme suit :

    1. Cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur Options Excel.

    2. Dans la catégorie Standard, sous Meilleures options pour travailler avec Excel, activez la case à cocher Afficher l'onglet Développeur dans le ruban, puis cliquez sur OK.

      Remarque : Le ruban est un élément de l'Interface utilisateur Microsoft Office Fluent.

  3. Sous l'onglet Développeur, dans le groupe XML, cliquez sur Source.

    Groupe XML dans le ruban

    Le volet Office Source XML s’affiche.

  4. Cliquez sur Mappages XML, puis cliquez sur Ajouter dans la boîte de dialogue Mappages XML.

  5. Sur un ordinateur exécutant Windows Vista   

    1. Dans la barre d’adresses, cliquez sur le lecteur ou le dossier qui contient le fichier myschema.xsd que vous avez créé à l’étape 2 de la section tâche 1 : extraire le fichier de schéma InfoPath.

      Sur un ordinateur exécutant Microsoft Windows XP   

    2. Dans la liste Regarder dans, cliquez sur le lecteur ou le dossier qui contient le fichier myschema.xsd que vous avez créé à l’étape 2 de la section tâche 1 : extraire le fichier de schéma InfoPath.

  6. Sélectionnez le fichier, puis cliquez sur Ouvrir.

  7. Lorsque la boîte de dialogue Plusieurs racines s’affiche, cliquez sur le nœud racine assetTracking défini dans le fichier myschema.xsd, puis cliquez sur OK.

    Le mappage XML s’affiche dans le volet Office Source XML.

  8. Faites glisser l’élément de nœud ns1:asset, qui est un élément XML répétitif, à l’emplacement de feuille de calcul où vous souhaitez le tableau Excel doit apparaître.

    Mappage du fichier de schéma InfoPath dans Excel

Tâche 3 : Personnaliser la disposition du tableau Excel

Par défaut, Excel utilise les noms des éléments XML comme en-têtes de colonne pour la table. Toutefois, vous pouvez modifier les en-têtes de colonne en modifiant les cellules d’en-tête de colonne.

  1. Pour modifier les en-têtes de colonne par défaut, que le tableau Excel sélectionné, recherchez le préfixe chaîne suivant, ns1:asset et supprimez-la. Par exemple, vous le feriez modifier ns1:assetIDID.

    Personnalisation des en-têtes de tableau Excel

  2. Pour ajuster la largeur de colonne, cliquez sur le bouton Sélectionner tout, puis double-cliquez sur n’importe quelle limite d’en-tête de colonne.

Haut de la Page

Étape 3 : Créer un rapport de synthèse de tableau croisé dynamique et graphique croisé dynamique

Aux décideurs utilisent tableau croisé dynamique et rapports de graphique croisé dynamique pour analyser, Explorer et visualiser des données de synthèse. En configurant les rapports de tableau croisé dynamique et graphique croisé dynamique que vous souhaitez utiliser dans ce scénario avance, il sera une opération simple pour une décideurs exécuter le rapport avec les données plus tard.

  1. Sélectionnez une cellule dans le tableau Excel.

  2. Sous l'onglet Insertion, dans le groupe Tableaux, cliquez sur Tableau croisé dynamique, puis cliquez sur Tableau croisé dynamique.

    Image du ruban Excel

    Excel affiche la boîte de dialogue Créer un tableau croisé dynamique.

  3. Pour placer le rapport de tableau croisé dynamique dans une feuille de calcul commençant à la cellule A1, cliquez sur Nouvelle feuille de calcul, puis cliquez sur OK.

    Excel ajoute un rapport de tableau croisé dynamique vide à l’emplacement spécifié et affiche la Liste de champs de tableau croisé dynamique afin que vous pouvez ajouter des champs, créer une mise en page et personnaliser le rapport de tableau croisé dynamique.

  4. Pour créer un rapport tabulaire de manière croisée les données, faites glisser le champ vers la zone valeurs, le champ département vers la zone étiquettes de colonne, le champ de catégorie vers la zone étiquettes de ligne et le champ AffectéÀ vers la zone de filtre de rapport.

  5. Cliquez sur le rapport de tableau croisé dynamique.

  6. Sous l’onglet Insertion, dans le groupe graphiques, cliquez sur le type de graphique barre.

    Image du ruban Excel

  7. Sous Barres 2D, sélectionnez Barres groupées.

  8. Ajuster la taille et l’emplacement du rapport de graphique croisé dynamique selon vos préférences.

Rapports de tableau croisé dynamique et graphique croisé dynamique vides

Haut de la Page

Étape 4 : Collecter les informations sur les éléments des utilisateurs

Maintenant, que le modèle de formulaire est prêt à être remplis par tous les employés, vous devez publier le formulaire et l’envoyer à chaque employé. Lors de chaque employé envoie le formulaire complété, il est envoyé en tant que fichier de données XML (.xml) joint dans un message électronique au compte de messagerie de décideurs. Les décideurs pouvez ensuite déplacer tous les messages vers un dossier InfoPath dédié dans Outlook. Dans ce scénario, il est recommandé que vous affectez une période de temps spécifique pour tous les utilisateurs remplir les formulaires afin que les décideurs pouvez exécuter le rapport avec tous les formulaires complétés lorsque le délai de collecte de données a été atteinte.

Saisie de données dans les formulaires de suivi des biens

  1. Dans InfoPath, ouvrez le modèle de formulaire (.xsn) que vous avez enregistrée étape 1 : créer le modèle de formulaire de suivi des biens exemple

  2. Dans le menu Outils, cliquez sur modifier ce formulaire.

  3. Dans le menu Fichier, cliquez sur Publier.

  4. Dans l'Assistant Publication, cliquez sur Vers une liste de destinataires de courrier électronique, puis sur Suivant.

  5. Sur la page suivante de l'Assistant, dans la zone Nom du modèle de formulaire, tapez un nom, puis cliquez sur Suivant. Le nom du modèle de formulaire apparaîtra dans l'objet du message envoyé aux destinataires.

  6. Si vous le souhaitez, dans la page suivante de l’Assistant, vous pouvez créer des colonnes qui apparaîtront dans vos dossiers Outlook pour aider à organiser vos messages électroniques.

  7. Cliquez sur Suivant.

  8. Cliquez sur Publier.

  9. Lorsque l'Assistant Publication a terminé de publier le modèle de formulaire, un message électronique contenant le formulaire s'ouvre.

  10. Remplir le message, tapez dans les noms des employés ou utiliser une liste de distribution et envoyez le message.

Dans Outlook, les décideurs pouvez organiser tous les formulaires XML soumis de deux façons :

  • Si la boîte de message de dossiers de formulaires InfoPath s’affiche la première fois que le message s’ouvre, cliquez sur Créer un dossier de formulaires.

  • Créer une règle dans Outlook pour déplacer tous les formulaires InfoPath associées à un dossier InfoPath.

    Pour plus d’informations, voir Gérer les messages à l’aide de règles.

Haut de la Page

Étape 5 : Importer des formulaires dans Excel

Étant donné que vous avez déjà créé les étapes de classeur Excel 2 et 3, il est très simple pour les décideurs exporter et passez en revue les données du formulaire. Les décideurs doit simplement exporter les fichiers xml (.xml) à partir d’Outlook, importer tous les fichiers de formulaire (.xml) dans le classeur Excel et actualisez les données.

Tâche 1 : Exporter les écrans à partir d’Outlook vers un dossier Windows

  1. Dans Outlook, sélectionnez le dossier qui contient tous les formulaires que vous avez reçu des employés et appuyez sur CTRL + A pour sélectionner tous les messages électroniques de formulaire.

  2. Cliquez avec le bouton droit sur la sélection, pointez sur Actions de InfoPath, puis cliquez sur Exporter les formulaires.

  3. Dans la boîte de dialogue Exporter les formulaires, sélectionnez un dossier, puis appuyez sur OK.

Tâche 2 : Importer les formulaires dans Excel

  1. Dans le classeur Excel que vous avez créé dans étape 2 : mapper le fichier de schéma et personnaliser la disposition du tableau dans Excel, sélectionnez une des cellules mappées dans le tableau Excel.

  2. Sous l’onglet développeur, dans le groupe XML, cliquez sur Importer.

    Groupe XML dans le ruban

    La boîte de dialogue Importer au format XML s’affiche.

  3. Sur un ordinateur exécutant Windows Vista   

  4. Effectuez l’une des opérations suivantes :

    • Si les fichiers sont contigus, appuyez sur MAJ, puis cliquez sur le premier et le dernier fichier dans la liste.

    • Si les fichiers ne sont pas contigus, appuyez sur CTRL, puis cliquez sur chaque fichier que vous souhaitez importer dans la liste.

  5. Cliquez sur Importer.

    Tableau Excel de données importées

Par défaut, Excel remplace les données existantes dans les cellules mappées, qui est le résultat final souhaité pour cette solution professionnelle. Toutefois, une décideurs pourrait, par exemple, importer les données plusieurs fois pour évaluer la progression avant la date d’échéance planifiée.

Remarque : Dans Excel, vous pouvez également ajouter les données à l’aide de l’option Ajouter de nouvelles données aux tableaux XML existants (sous l’onglet développeur, dans le groupe XML, cliquez sur Propriétés du mappage ), qui peut être approprié pour d’autres solutions.

Pour plus d’informations, voir les rubriques d’aide Excel, données importer au format XML et Ajouter ou remplacer les données XML mappées.

Tâche 3 : Actualisation des rapports de tableau croisé dynamique et graphique croisé dynamique

  • Cliquez sur une cellule dans le rapport de tableau croisé dynamique.

  • Sous l’onglet Options, dans le groupe données, cliquez sur la flèche en regard de Actualiser tout, puis cliquez sur Actualiser.

    Image du ruban Outlook

Tableau croisé dynamique et graphique croisé dynamique finaux

Le classeur Excel contient maintenant toutes les données et rapports de synthèse que vous devez vous aider à allouer le budget d’équipement pour l’année suivante. Bien entendu, vous pouvez faire plus d’analyse dans votre classeur Excel, le cas échéant, telles que le tri, le filtrage ou mise en forme conditionnelle les données.

Haut de la Page

Conclusions : envisagez d’utiliser une base de données Access ou une liste SharePoint

Comme alternative, envisagez d’utiliser une liste SharePoint ou une base de données Access, au lieu de XML, pour transférer des données entre InfoPath et Excel.

Utiliser une liste SharePoint

À partir d’InfoPath, vous pouvez facilement utiliser une liste SharePoint comme source de données en lecture seule. Vous pouvez effectuer une des deux actions suivantes :

  • Dans la liste SharePoint, exporter les données vers Excel, ce qui crée automatiquement une connexion de données dans Excel.

  • À partir d’Excel, explicitement créer une connexion de données à la liste SharePoint.

Une fois une connexion de données est créée, vous pouvez actualiser les données dans Excel pour extraire des données à jour.

Vous pouvez utiliser une liste SharePoint pour ajouter et mettre à jour les données, un formulaire InfoPath permet d’afficher un élément dans la liste (par exemple, un complexe ou longue élément meilleures affiché verticalement), puis utiliser Excel pour analyser les données.

Combinaison d’InfoPath, d’une liste SharePoint et d’Excel

1. afficher un seul élément pour révision facile dans InfoPath.

2. ajouter et mettre à jour des données dans une liste SharePoint.

3. actualiser et de rapports à jour avec Excel.

Pour plus d’informations, voir Ajouter une connexion de données à une bibliothèque de documents SharePoint ou une liste et Importer les données d’une liste SharePoint.

Utiliser une base de données Access

À partir d’InfoPath, vous pouvez créer une connexion en lecture/écriture à une base de données Access. À partir d’Excel, vous pouvez explicitement créer une connexion de données à la base de données Access vous pouvez actualiser pour récupérer des données à jour. Vous pouvez même définir la connexion pour l’actualisation automatique lorsque le classeur est ouvert ou actualisez régulièrement, tel que toutes les 5 minutes.

Vous pouvez utiliser une base de données Access en tant qu’intermédiaire entre InfoPath et Excel. Lorsque vous envoyez un formulaire InfoPath dans Access, vous mettez à jour la base de données Access. Lorsque vous actualisez la connexion de données dans Excel, vous récupérez des données mises à jour à partir d’Access. En fait, vous soumettez données indirectement à partir d’InfoPath dans un classeur Excel.

Combinaison d’InfoPath, d’Access et d’Excel

1. Affichez et envoyer un formulaire à une base de données Access.

2. stocker des données dans une base de données Access.

3. actualiser et de rapports à jour avec Excel.

Pour plus d’informations, voir créer un modèle de formulaire qui est basé sur une base de données Microsoft Access.

Conseil : Saviez-vous que vous pouvez créer un formulaire InfoPath directement à partir d’Access 2007 ? Si vos utilisateurs disposent d’Outlook 2007 et InfoPath 2007 sur leur ordinateur, vous pouvez recueillir données auprès des utilisateurs centralisées directement à partir d’Access 2007 à l’aide de l’Assistant collecter les données de messages électroniques. Pour plus d’informations, consultez la rubrique d’aide Access 2007, collecter les données à l’aide de messages électroniques.

Haut de la Page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×