Créer une référence externe (liaison) à une plage de cellules d'un autre classeur

Vous pouvez faire référence au contenu de cellules d’un autre classeur en créant une référence externe. Une référence externe (également appelée liaison) est une référence à une cellule ou une plage de cellules dans une feuille de calcul d’un autre classeur Excel, ou une référence à un nom défini dans un autre classeur. Vous pouvez également référencer la plage de cellules spécifique, un nom défini pour la plage de cellules, ou définir un nom pour la référence externe.

Que voulez-vous faire ?

En savoir plus sur les références externes

Créer une référence externe entre les cellules de différents classeurs

Créer une référence externe à un nom défini dans un autre classeur

Définir un nom contenant une référence externe à des cellules d’un autre classeur

En savoir plus sur les références externes

Bien que les références externes soient similaires à des références de cellules, il existe toutefois des différences importantes. Vous utilisez des références externes lorsque vous travaillez avec de grandes quantités de données ou des formules complexes couvrant plusieurs classeurs. Vous les créez différemment et elles apparaissent différemment dans une cellule ou dans la barre de formule.

Où les références externes peuvent être utilisées efficacement

Les références externes s’avèrent particulièrement utiles lorsqu’il n’est pas possible de conserver dans un même classeur des modèles de feuille de calcul de grande taille.

  • Fusionner des données contenues dans plusieurs classeurs.      Vous pouvez lier des classeurs appartenant à plusieurs utilisateurs ou services et intégrer les données pertinentes dans un classeur de synthèse. Ainsi, lorsque les classeurs source sont modifiés, vous n’êtes pas contraint de modifier manuellement le classeur de synthèse.

  • Créer plusieurs vues de vos données.       Vous pouvez taper toutes vos données dans un ou plusieurs classeurs source, puis créer un classeur de rapport contenant des références externes aux données pertinentes uniquement.

  • Rationaliser des modèles complexes.       Divisez un modèle complexe en une série de classeurs interdépendants, ce qui vous permet de travailler sur le modèle sans ouvrir toutes les feuilles connexes. Les classeurs de petite taille sont plus faciles à modifier, nécessitent moins de mémoire, s’ouvrent, s’enregistrent et se calculent plus rapidement.

Comment créer des références externes

Si vous créez une référence de cellule à partir d’une référence externe, vous pouvez alors appliquer également des formules aux informations. En basculant entre les différents types de référence, vous pouvez également choisir les cellules à relier en déplaçant la référence externe. Par exemple, si vous utilisez une référence relative, lorsque vous déplacez la référence externe, les cellules qui sont reliées changent pour refléter sa nouvelle position sur la feuille de calcul.

Lorsque vous créez une référence externe entre deux classeurs, vous devez utiliser un nom pour référencer les cellules que vous liez. Vous pouvez créer une référence externe en utilisant un nom qui est déjà défini ou définir ce nom au moment de créer la référence externe. En utilisant un nom, il vous sera plus facile de mémoriser le contenu des cellules que vous liez. Les liaisons qui ont recours à des noms définis ne changent pas lorsque vous les déplacez, car chaque nom fait référence à une cellule spécifique ou à une plage de cellules. Si vous voulez qu’une référence externe ayant recours à un nom change lorsque vous la déplacez, changez le nom utilisé dans cette référence ou changez les cellules auxquelles le nom fait référence.

Ce à quoi ressemble une référence externe à un autre classeur

Il existe deux manières d’afficher les références externes à d’autres classeurs, selon que le classeur source (c’est-à-dire celui qui fournit des données à une formule) est ouvert ou fermé.

Lorsque la source est ouverte, la référence externe contient le nom du classeur entre crochets droits ([ ]), suivi du nom de la feuille de calcul, d’un point d’exclamation (!) et des cellules dont dépend la formule. Par exemple, la formule suivante ajoute la cellule C10:C25 du classeur Budget.xls.

Référence externe

=SOMME([Budget.xlsx]Annuel!C10:C25)

Lorsque la source n’est pas ouverte, la référence externe contient l’intégralité du chemin d’accès.

Référence externe

=SOMME('C:\Rapports\[Budget.xlsx]Annuel'!C10:C25)

Remarque : Si le nom de l’autre feuille de calcul ou classeur contient des caractères non alphabétiques, vous devez encadrer le nom (ou le chemin d’accès) de guillemets dactylographiques simples.

Les formules qui établissent une liaison vers un nom défini dans un autre classeur utilisent le nom du classeur suivi d’un point d’exclamation (!), puis le nom. Par exemple, la formule suivante ajoute les cellules dans la plage Ventes du classeur Budget.xlsx.

Référence externe

=SOMME(Budget.xlsx!Ventes)

Haut de la page

Créer une référence externe entre les cellules de différents classeurs

  1. Ouvrez le classeur contenant la référence externe (le classeur de destination) et le classeur contenant les données vers lesquelles vous voulez établir la liaison (le classeur source).

  2. Dans le classeur source, cliquez sur Enregistrer Image du bouton sur la barre d’outils Accès rapide.

  3. Sélectionnez la ou les cellules dans lesquelles vous voulez créer la référence externe.

  4. Tapez = (signe égal). Si vous voulez effectuer des calculs à partir de la valeur de la référence externe ou exécuter des fonctions sur celle-ci, tapez l’opérateur ou la fonction qui doit précéder la référence externe.

  5. Ouvrez le classeur source, puis cliquez sur la feuille de calcul contenant les cellules vers lesquelles vous voulez établir la liaison.

  6. Sélectionnez la ou les cellule(s) que vous souhaitez lier.

  7. Revenez au classeur de destination. Vous constaterez qu’Excel ajoute la référence au classeur source et les cellules sélectionnées à l’étape précédente.

  8. Vous pouvez aussi modifier la formule dans la feuille de calcul.

  9. Appuyez sur CTRL+MAJ+ENTRÉE.

Haut de la page

Créer une référence externe à un nom défini dans un autre classeur

  1. Ouvrez le classeur contenant la référence externe (le classeur de destination) et le classeur contenant les données vers lesquelles vous voulez établir la liaison (le classeur source).

  2. Dans le classeur source, cliquez sur Enregistrer Image du bouton sur la barre d’outils Accès rapide.

  3. Sélectionnez la ou les cellules dans lesquelles vous voulez créer la référence externe.

  4. Tapez = (signe égal). Si vous voulez effectuer des calculs à partir de la valeur de la référence externe ou exécuter des fonctions sur celle-ci, tapez l’opérateur ou la fonction qui doit précéder la référence externe.

  5. Dans l’onglet Vue, dans le groupe Fenêtre, cliquez sur Changement de fenêtre, sur le nom du classeur source, puis sur le classeur contenant les cellules vers lesquelles vous voulez établir la liaison.

    Groupe Fenêtre sous l’onglet Affichage

  6. Appuyez sur F3, puis sélectionnez le nom vers lequel vous voulez établir la liaison.

Haut de la page

Définir un nom contenant une référence externe à des cellules d’un autre classeur

  1. Ouvrez le classeur de destination et le classeur source.

  2. Dans le classeur de destination, dans l’onglet Formules, dans le groupe Noms définis, cliquez sur Définir un nom.

    Image du ruban Excel

  3. Dans la zone Nom de la boîte de dialogue Nouveau nom, tapez le nom de la plage.

  4. Dans la zone Fait référence à, supprimez le contenu, puis maintenez le curseur dans cette zone.

    Si le nom contient une formule, entrez la formule, puis placez le curseur à l’emplacement où vous voulez créer la référence externe. Par exemple, tapez =SOMME(), puis placez le curseur entre les parenthèses.

  5. Dans l’onglet Vue, dans le groupe Fenêtre, cliquez sur Changement de fenêtre, sur le nom du classeur source, puis sur le classeur contenant les cellules vers lesquelles vous voulez établir la liaison.

    Groupe Fenêtre sous l’onglet Affichage

  6. Sélectionnez la cellule ou la plage de cellules vers lesquelles vous voulez établir la liaison.

  7. Dans la boîte de dialogue Nouveau nom, cliquez sur OK.

Haut de la page

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×