Créer une base de données

Créer une base de données

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Cet article décrit le processus de base du démarrage Access et création d’une base de données qui sera utilisé sur les ordinateurs de bureau, pas sur le Web. Il explique comment créer une base de données à l’aide d’un modèle et comment créer une base de données à partir de zéro en créant vos propres tables, formulaires, États et autres objets de base de données. Cette rubrique explique également certaines techniques que vous pouvez utiliser pour obtenir des données existantes dans votre nouvelle base de données.

Contenu de cet article

Vue d’ensemble

Créer une base de données en utilisant un modèle

Créer une base de données sans l’aide d’un modèle

Copier des données à partir d’une autre source dans une table Access

Importer, ajouter ou attacher des données à partir d’une autre source

Ajouter un composant d’application

Ouvrir une base de données Access existante

Vue d’ensemble

Lors du premier démarrage d’Access, ou si vous fermez une base de données sans fermer Access, mode Backstage de Microsoft Office s’affiche.

Mode Backstage est un point de départ à partir duquel vous pouvez créer une nouvelle base de données, ouvrir une base de données existante, consulter le contenu proposé à partir de Office.com — tout ce que vous pouvez utiliser Access à suivre pour un fichier de base de données ou en dehors d’une base de données, contrairement à au sein de une base de données.

Création d’une base de données

Lorsque vous ouvrez Access, mode Backstage affiche l’onglet Nouveau. L’onglet Nouveau propose plusieurs méthodes que vous pouvez créer une nouvelle base de données :

  • Une base de données vide    Si vous le souhaitez, vous pouvez le démarrer à partir de zéro. Il s’agit d’un bon choix si vous avez exigences de conception très spécifiques ou des données existantes que vous devez prendre en compte ou incorporer.

  • Un modèle qui est installé avec Access    Utilisation d’un modèle si vous démarrez un nouveau projet et que vous souhaitez qu’un point de départ. Access est fourni avec plusieurs modèles installés par défaut.

  • Un modèle à partir de Office.com    Outre les modèles fournis avec Access, vous pouvez trouver plusieurs autres modèles sur Office.com. Vous n’avez pas encore ouvrir un navigateur, les modèles sont disponibles à partir de l’onglet Nouveau.

Ajout d’une base de données

Une fois que vous travaillez dans une base de données, vous pouvez ajouter des champs, des tableaux ou des composants d’application.

Composants d’application sont une fonctionnalité qui vous permettent d’utiliser conjointement plusieurs objets de base de données connexes comme s’il s’agissait d’une. Par exemple, composant d’application peut être constituée d’une table et un formulaire qui est basé sur la table. Vous pouvez ajouter la table et le formulaire en même temps en utilisant le composant d’application.

Vous pouvez également créer des requêtes, formulaires, États et macros - tous les objets de base de données que vous êtes habitué à utiliser.

Créer une base de données en utilisant un modèle

Access est fourni avec de nombreux modèles que vous pouvez utiliser en tant que-est ou point de départ. Un modèle est une base de données prêtes à l’emploi qui contient toutes les tables, requêtes, formulaires, macros et rapports requis pour exécuter une tâche spécifique. Par exemple, il existe des modèles que vous pouvez utiliser pour le suivi des problèmes, gérer les contacts ou garder une trace de dépenses. Certains modèles contiennent quelques exemples d’enregistrements afin d’illustrer leur utilisation.

Si un de ces modèles est adaptée à vos besoins, à l’utiliser est généralement le moyen le plus rapide pour obtenir une base de données démarrée. Toutefois, si vous possédez des données dans un autre programme que vous souhaitez importer dans Access, vous pouvez décider qu’il est préférable de créer une base de données sans l’aide d’un modèle. Modèles ont une structure de données déjà définie, et il peut nécessiter un grand nombre de travail d’adapter vos données existantes à la structure du modèle.

  1. Si vous avez une base de données ouvert, sous l’onglet fichier, cliquez sur Fermer. Mode Backstage affiche l’onglet Nouveau.

  2. Plusieurs ensembles de modèles sont disponibles dans l’onglet Nouveau, certaines d'entre elles sont intégrées dans Access. Vous pouvez télécharger des modèles supplémentaires à partir de Office.com. Consultez la section suivante dans cet article pour plus d’informations.

  3. Sélectionnez le modèle que vous voulez utiliser.

  4. Access suggère un nom de fichier pour votre base de données dans la zone Nom de fichier, vous pouvez modifier le nom du fichier, si vous voulez. Pour enregistrer la base de données dans un dossier autre que celui affiché sous la zone Nom de fichier, cliquez sur Image du bouton , accédez au dossier dans lequel vous souhaitez enregistrer, puis cliquez sur OK. Si vous le souhaitez, vous pouvez créer et lier votre base de données à un site SharePoint.

    Remarque : Bien qu’ils sont tous deux utilisent SharePoint, une base de données liée à un site SharePoint n’est pas différente de celle dans une base de données web utilisant Access Services. Pour utiliser une base de données, vous devez avoir accès installé. Une base de données web peut être utilisé avec un navigateur web.

  5. Cliquez sur Créer.

    Access crée une base de données à partir du modèle que vous avez choisi et puis l’ouvre la base de données. Pour de nombreux modèles, un formulaire est affiché dans lequel vous pouvez commencer à entrer des données. Si votre modèle contient des exemples de données, vous pouvez supprimer chaque enregistrement en cliquant sur le sélecteur d’enregistrement (la zone ombrée ou barre située à gauche de l’enregistrement), puis procédez comme suit :

    Sous l’onglet accueil, dans le groupe enregistrements, cliquez sur Supprimer. Image du bouton

  6. Pour commencer à entrer des données, cliquez sur la première cellule vide du formulaire et commencez à taper. La Volet de navigation permet de rechercher d’autres formulaires et rapports que vous souhaiterez peut-être utiliser. Certains modèles intègrent un formulaire de navigation qui permet de vous déplacer entre les objets de base de données différente.

Pour plus d’informations sur l’utilisation des modèles, voir l’article utiliser un modèle pour créer une base de données Access.

Haut de la Page

Créer une base de données sans l’aide d’un modèle

Si vous n’êtes pas d’informations sur l’aide d’un modèle, vous pouvez créer une base de données en créant vos propres tables, formulaires, États et autres objets de base de données. Dans la plupart des cas, cela implique une ou plusieurs des opérations suivantes :

  • Saisie, coller, ou importer des données dans la table qui est créée lorsque vous créez une nouvelle base de données et puis répétition du processus avec les nouvelles tables que vous créez à l’aide de la commande tableau sous l’onglet créer.

  • Importation de données provenant d’autres sources et créer les tables dans le processus.

Créer une base de données vide

  1. Sous l’onglet fichier, cliquez sur Nouveau, puis cliquez sur Base de données vide.

  2. Tapez un nom de fichier dans la zone Nom de fichier. Pour modifier l’emplacement du fichier à partir de la valeur par défaut, cliquez sur Rechercher un emplacement votre base de données Image du bouton (à côté de la zone Nom de fichier ), naviguez jusqu’au nouvel emplacement, puis cliquez sur OK.

  3. Cliquez sur Créer.

    Access crée la base de données avec une table vide nommée Table1 et Table1 puis l’ouvre en mode feuille de données. Le curseur est placé dans la première cellule vide dans la colonne cliquez sur Ajouter.

  4. Commencez à taper pour ajouter des données, ou vous pouvez coller des données à partir d’une autre source, comme décrit dans la section copier des données d’une autre source dans une table Access.

Saisie de données en mode feuille de données est conçue pour être très similaire à l’utilisation d’une feuille de calcul Excel. La structure de table est créée pendant que vous entrez des données. Lorsque vous ajoutez une nouvelle colonne à la feuille de données, un nouveau champ est défini dans la table. Access définit automatiquement le type de données de chaque champ basé sur les données que vous entrez.

Si vous ne souhaitez pas d’entrer des données dans la table Table1 pour l’instant, cliquez sur Fermer Image du bouton . Si vous avez apporté des modifications à la table, Access vous invite à enregistrer les modifications. Cliquez sur Oui pour enregistrer vos modifications, cliquez sur non pour les annuler ou cliquez sur Annuler pour laisser la table ouverte.

Conseil : Access recherche d’un fichier nommé Blank.accdb dans le dossier situé à [lecteur d’installation] : \Program Files\Microsoft Office\Templates\1033\Access\. S’il existe, Blank.accdb est le modèle pour toutes les nouvelles bases de données vierges, en excluant des bases de données web. Tout son contenu est héritée par toutes les nouvelles vides bases de données. Il s’agit d’un bon moyen de distribuer le contenu par défaut, tels que les numéros de référence ou exclusions de société et les stratégies. N’oubliez pas Blank.accdb n’a aucun effet sur la création de vide nouvelles bases de données web.

Important : Si vous fermez la table Table1 sans l’enregistrer au moins une fois, Access supprime toute la table, même si vous avez entré les données qu’il contient.

Ajouter une table

Vous pouvez ajouter des tables à une base de données existante en utilisant les commandes dans le groupe tableaux, sous l’onglet créer.

Image du ruban Access

Créer une table en mode feuille de données    En mode feuille de données, vous pouvez entrer des données immédiatement et laisser Access générer une structure de table en arrière-plan. Noms des champs affectés numérique (champ1, Champ2, etc.) et Access définit automatiquement le type de données de chaque champ basé sur les données que vous entrez.

  1. Sous l’onglet créer, dans le groupe tableaux, cliquez sur tableau. Image du bouton

    Access crée la table et sélectionne la première cellule vide dans la colonne cliquez sur Ajouter.

  2. Sous l’onglet champs, dans le groupe Ajouter et supprimer, cliquez sur le type de champ que vous voulez ajouter. Si vous ne voyez pas le type de votre choix, cliquez sur Plus de champs Image du bouton .

  3. Access affiche une liste des champs couramment utilisés. Cliquez sur le type de champ souhaité, et Access ajoute le nouveau champ à la feuille de données au niveau du point d’insertion.

    Vous pouvez déplacer le champ en le faisant glisser. Lorsque vous faites glisser un champ dans une feuille de données, une barre verticale d’insertion apparaît où le champ sera placé.

  4. Pour ajouter des données, commencez à taper dans la première cellule vide ou collez des données à partir d’une autre source, comme décrit dans la section copier des données d’une autre source dans une table Access.

  5. Pour renommer une colonne (champ), double-cliquez sur l’en-tête correspondant, puis tapez le nouveau nom.

    Vous devez attribuer un nom significatif à chaque champ, afin que vous pouvez déterminer qu’il s’affiche lorsqu’elle apparaît dans le volet Liste de champs.

  6. Pour déplacer une colonne, cliquez sur son en-tête pour sélectionner la colonne et puis faites glisser la colonne à l’emplacement souhaité. Vous pouvez également sélectionner plusieurs colonnes adjacentes, puis faites-les glisser vers un nouvel emplacement en une seule fois. Pour sélectionner plusieurs colonnes adjacentes, cliquez sur l’en-tête de colonne de la première colonne, puis, tout en maintenant la touche MAJ ENFONCÉE, cliquez sur l’en-tête de colonne de la dernière colonne.

Créer une table en mode Création    En mode Création, vous créez tout d’abord la structure de table. Vous puis passez en mode feuille de données pour entrer des données, ou entrez des données à l’aide d’une autre méthode, telles que le collage ou l’importation.

  1. Sous l’onglet créer, dans le groupe tableaux, cliquez sur Création de Table. Image du bouton

  2. Pour chaque champ dans votre table, tapez un nom dans la colonne Nom de champ et puis sélectionnez un type de données dans la liste Type de données.

  3. Si vous le souhaitez, vous pouvez taper une description pour chaque champ dans la colonne Description. La description apparaît alors sur la barre d’état lorsque le curseur se trouve dans ce champ en mode feuille de données. La description est également utilisée en tant que texte de la barre d’état pour tous les contrôles dans un formulaire ou l’état que vous créez en faisant glisser le champ à partir du volet Liste de champs ou pour les contrôles qui sont créés de ce champ lorsque vous utilisez l’Assistant formulaire ou état.

  4. Après avoir ajouté tous les champs, enregistrez la table :

    • Sous l’onglet Fichier, cliquez sur Enregistrer.

  5. Vous pouvez commencer à taper les données dans le tableau à tout moment en passant en mode feuille de données et en cliquant sur la première cellule vide. Vous pouvez également coller des données à partir d’une autre source, comme décrit dans la section copier des données d’une autre source dans une table Access.

Définir les propriétés de champ en mode Création    Quelle que soit la façon dont vous avez créé votre tableau, il est recommandé d’examiner et de définir les propriétés de champ. Tandis que certaines propriétés sont disponibles en mode feuille de données, certaines propriétés ne peuvent être définies en mode Création. Pour passer en mode Création, avec le bouton droit de la table dans le volet de Navigation, puis cliquez sur Mode Création. Pour afficher les propriétés d’un champ, cliquez sur le champ dans la grille de création. Les propriétés sont affichent en dessous de la grille de création, sous Propriétés du champ.

Pour afficher une description de chaque propriété de champ, cliquez sur la propriété et lisez la description dans la zone en regard de la liste des propriétés sous Propriétés du champ. Vous pouvez obtenir des informations plus détaillées en cliquant sur le bouton aide.

Le tableau suivant décrit certaines des propriétés de champ courantes.

Propriété

Description

Taille du champ

Pour les champs de texte, cette propriété définit le nombre maximal de caractères pouvant être stockés dans le champ. La valeur maximale est 255. Pour les champs numériques, cette propriété définit le type de numéro qui sera stocké (entier Long, Double, et ainsi de suite). Pour le stockage des données plus efficace, il est recommandé que vous allouez le moins d’espace dont vous aurez besoin pour les données. Vous pouvez ajuster la valeur ultérieurement, si l’évolution de vos besoins.

Format

Cette propriété définit la façon dont les données sont affichées. Il n’affecte pas les données réelles qu’il est stocké dans le champ. Vous pouvez sélectionner un format prédéfini ou entrez un format personnalisé.

Masque de saisie

Utilisez cette propriété pour spécifier un modèle pour toutes les données à entrer dans ce champ. Cela permet de garantir que toutes les données est correcte, et qu’il contient le nombre requis de caractères. Pour une aide sur la création d’un masque de saisie, cliquez sur Bouton Générateur sur le côté droit de la zone de propriété.

Valeur par défaut

Utilisez cette propriété pour spécifier la valeur par défaut qui s’affichent dans ce champ chaque fois qu’un nouvel enregistrement est ajouté. Par exemple, si vous avez un champ Date/heure dans lequel vous voulez toujours enregistrer la date à laquelle l’enregistrement a été ajouté, vous pouvez entrer « Date() » (sans guillemets) en tant que la valeur par défaut.

Obligatoire

Cette propriété définit si une valeur est requise dans ce champ. Si vous définissez cette propriété sur Oui, Access n’autorise pas vous permet d’ajouter un nouvel enregistrement, sauf si une valeur est entrée pour ce champ.

Haut de la Page

Copier des données à partir d’une autre source dans une table Access

Si vos données sont stockées dans un autre programme, comme Excel, vous pouvez copier et coller dans une table Access. En règle générale, il est préférable que vos données sont déjà séparées en colonnes, comme dans une feuille de calcul Excel. Si vos données sont dans un mot programme de traitement, il est préférable pour séparer les colonnes de données à l’aide des onglets, ou pour convertir les données dans une table dans le programme de traitement de texte avant de copier les données. Si les données doivent être modifiées ou manipulation (par exemple, fractionner les noms complets en premier et derniers noms), vous souhaiterez peut-être procédez comme suit avant de copier les données, notamment si vous n’êtes pas familiarisé avec Access.

Lorsque vous collez des données dans une table vide, Access définit le type de données de chaque champ en fonction de quel type de données trouvés à cet emplacement. Par exemple, si un champ collé ne contient que des valeurs de date, Access applique les données Date/heure type pour ce champ. Si le champ collé ne contient uniquement les mots « Oui » et « », Access applique la valeur Oui/aucune donnée ne tapez dans le champ.

Accès des noms aux champs en fonction de ce qu’elle trouve dans la première ligne de données collées. Si la première ligne de données collées est un type similaire aux lignes suivantes, Access détermine que la première ligne fait partie des données et attribue aux champs des noms génériques (F1, F2, etc.). Si la première ligne de données collées n’est pas similaire aux lignes qui suivent, Access détermine que la première ligne se compose de noms de champs. Accès des noms aux champs en conséquence et n’inclut pas la première ligne dans les données.

Si Access attribue des noms de champ générique, vous devez renommer les champs dès que possible pour éviter toute confusion. Procédez comme suit :

  1. Appuyez sur CTRL + S pour enregistrer la table.

  2. En mode feuille de données, double-cliquez sur chaque en-tête de colonne et tapez un nom de champ descriptif pour chaque colonne.

  3. Enregistrez de nouveau la table.

Remarque : Vous pouvez également renommer les champs en passant en mode Création et en modifiant le nom du champ. Pour passer en mode Création, avec le bouton droit de la table dans le volet de Navigation, cliquez sur Mode Création. Pour revenir au mode feuille de données, double-cliquez sur la table dans le volet de Navigation.

Haut de la Page

Importer, ajouter ou attacher des données à partir d’une autre source

Vous disposez de données qui sont stockées dans un autre programme, et que vous voulez importer ces données dans une nouvelle table ou les ajouter à une table existante dans Access. Ou vous pouvez travailler avec des personnes qui conservent les données dans d’autres programmes, et que vous voulez utiliser dans Access en créant un lien vers celle-ci. Dans les deux cas, Access facilite utiliser des données provenant d’autres sources. Vous pouvez importer des données à partir d’une feuille de calcul Excel, d’un tableau dans une autre base de données Access, d’une liste SharePoint ou à partir d’une variété d’autres sources. Le processus varie légèrement, en fonction de votre source, mais la procédure suivante vous aideront à démarrer.

  1. Dans Access, sous l’onglet Données externes, dans le groupe Importer et lier, cliquez sur la commande correspondant au type de fichier que vous importez.

    Groupe Importer et lier sous l’onglet Données externes

    Par exemple, si vous importez des données à partir d’une feuille de calcul Excel, cliquez sur Excel. Si vous ne voyez pas le type de programme dont vous avez besoin, cliquez sur plus.

    Remarque : Si vous ne trouvez pas le type de format approprié dans le groupe Importer et lier, vous devrez peut-être démarrer le programme dans lequel vous avez créé les données, puis utilisez ce programme pour enregistrer les données dans un format de fichier courant (par exemple, un fichier texte délimité ) avant que vous pouvez importer t ces données dans Access.

  2. Dans la boîte de dialogue Données externes, cliquez sur Parcourir pour rechercher le fichier de données source ou tapez le chemin d’accès complet du fichier de données source dans la zone nom de fichier.

  3. Cliquez sur l’option souhaitée (tous les programmes vous permettent d’importer et certaines vous permettent d’ajouter ou créer un lien) sous spécifier comment et où vous voulez stocker les données dans la base de données Active. Vous pouvez créer une nouvelle table qui utilise les données importées ou (avec certains programmes), vous pouvez ajouter les données à une table existante ou créer une table liée qui contient un lien vers les données dans le programme source.

  4. Si un Assistant démarre, suivez les instructions sur les pages suivantes de l’Assistant. Dans la dernière page de l’Assistant, cliquez sur Terminer.

    Si vous importez des objets ou lier des tables à partir d’une base de données Access, l’option Importer des objets ou Tables lien boîte de dialogue s’affiche. Choisissez les éléments que vous voulez, puis cliquez sur OK.

    Le processus varie selon que vous choisissez à importer, ajouter ou lier des données.

  5. Access vous demande si vous souhaitez enregistrer les détails de l’opération d’importation que vous venez d’effectuer. Si vous pensez que vous exécutez cette opération d’importation même ultérieurement, cliquez sur Enregistrer les étapes d’importation, puis entrez les détails. Vous pouvez facilement recommencez l’opération ultérieurement en cliquant sur Importations enregistrées Image du bouton dans le groupe Importer et lier sous l’onglet Données externes. Si vous ne voulez pas enregistrer les détails de l’opération, cliquez sur Fermer.

Si vous choisissez d’importer une table, Access permet d’importer les données dans une nouvelle table, puis affiche la table dans le groupe Tables dans le volet de Navigation. Si vous choisissez d’ajouter des données à une table existante, les données sont ajoutées à la table. Si vous avez choisi attacher des données, Access crée une table liée dans le groupe Tables dans le volet de Navigation.

Haut de la Page

Ajouter un composant d’application

Vous pouvez utiliser le composant d’application pour ajouter des fonctionnalités à une base de données existante. Composant d’application peut être aussi simple qu’une seule table, ou elle peut contenir plusieurs objets associés, par exemple une table et un formulaire lié.

Par exemple, le composant d’application de commentaires est constitué d’un tableau avec un champ NuméroAuto ID, un champ de date et un champ Mémo. Vous pouvez l’ajouter à une base de données et utiliser en tant que-est ou avec minimales personnalisation.

  1. Ouvrez la base de données auquel vous souhaitez ajouter un composant d’application.

  2. Cliquez sur l’onglet créer.

  3. Dans le groupe modèles, cliquez sur Composants d’Application. Liste des composants WebPart disponibles s’ouvre.

  4. Cliquez sur le composant d’application que vous voulez ajouter.

Haut de la Page

Ouvrir une base de données Access existante

  1. Sous l’onglet Fichier, cliquez sur Ouvrir.

  2. Dans la boîte de dialogue Ouvrir, accédez à la base de données que vous voulez ouvrir.

  3. Effectuez l’une des opérations suivantes :

    • Double-cliquez sur la base de données pour l’ouvrir dans le mode par défaut spécifié dans la boîte de dialogue Options Access ou le mode qui a été défini par une stratégie d’administration.

    • Cliquez sur Ouvrir pour ouvrir la base de données pour un accès partagé dans un environnement multi-utilisateur afin que vous et autres utilisateurs puissent lire et écrire dans la base de données.

    • Cliquez sur la flèche en regard du bouton Ouvrir, puis sur Ouvrir en lecture seule pour ouvrir la base de données pour l’accès en lecture seule afin que vous pouvez afficher, mais pas le modifier. D’autres utilisateurs peuvent toujours lire et écrire dans la base de données.

    • Cliquez sur la flèche en regard du bouton Ouvrir, puis sur Ouvrir en exclusif pour ouvrir la base de données à l’aide d’un accès exclusif. Lorsque vous avez une base de données ouvert en mode exclusif, toute personne tente d’ouvrir la base de données permet de recevoir un message « fichier déjà en cours d’utilisation ».

    • Cliquez sur la flèche en regard du bouton Ouvrir, puis sur Ouvrir en mode lecture seule exclusif pour ouvrir la base de données pour l’accès en lecture seule. D’autres utilisateurs peuvent toujours ouvrir la base de données, mais elles sont limitées au mode lecture seule.

Remarque : Vous pouvez ouvrir directement un fichier de données dans un format de fichier externe, tels que dBASE, Microsoft Exchange ou Excel. Vous pouvez également ouvrir directement n’importe quel source de données ODBC, telles que Microsoft SQL Server. Access crée une nouvelle base de données Access dans le même dossier que le fichier de données automatiquement et ajoute des liens à chaque table dans la base de données externe.

Conseils

  • Pour ouvrir une base de données récemment ouvertes, sous l’onglet fichier, cliquez sur récents, puis cliquez sur le nom de fichier pour cette base de données. Access ouvre la base de données en utilisant les mêmes paramètres que lors de la dernière fois que vous l’avez ouvert. Si la liste des derniers fichiers utilisés n’est pas affichée, sous l’onglet fichier, cliquez sur Options. Dans la boîte de dialogue Options Access, cliquez sur Paramètres du Client. Sous Afficher, entrez le nombre de documents à afficher dans la liste de Documents récents, avec un maximum de 50.

    Vous pouvez également afficher les bases de données récentes dans la navigation barre du mode Backstage, pour l’accès de deux clics : (1) l’onglet fichier, 2) la base de données récente que vous voulez ouvrir. Au bas de l’onglet récent, activez la case à cocher accéder rapidement à ce nombre de bases de données récentes, puis ajustez le nombre de bases de données à afficher.

  • Si vous ouvrez une base de données en cliquant sur la commande Ouvrir dans l’onglet fichier, vous pouvez afficher une liste des raccourcis vers les bases de données que vous avez déjà ouvertes en cliquant sur Mes Documents récents dans la boîte de dialogue Ouvrir.

Haut de la Page

Que voulez-vous faire ?

Découvrir la prise en main page Microsoft Office Access

Créer une base de données en utilisant un modèle

Créer une base de données sans l’aide d’un modèle

Copier des données à partir d’une autre source dans une table Access

Importer, ajouter ou attacher des données à partir d’une autre source

Ouvrir une base de données Access existante

Créer un modèle vide personnalisé

Découvrir la prise en main page Microsoft Office Access

Lors du premier démarrage d’Access, ou si vous fermez une base de données sans fermer Access, la page Prise en main de Microsoft Office Access s’affiche.

Page Prise en main avec Microsoft Office Access

Cette page est un point de départ à partir duquel vous pouvez créer une nouvelle base de données, ouvrir une base de données existante ou consulter le contenu proposé à partir de Microsoft Office Online.

Créer une base de données en utilisant un modèle

Access fournit un large éventail de modèles que vous pouvez utiliser pour accélérer le processus de création d’une base de données. Un modèle est une base de données prêtes à l’emploi contenant toutes les tables, requêtes, formulaires et états requis pour effectuer une tâche spécifique. Par exemple, il existe des modèles que vous pouvez utiliser pour le suivi des problèmes, gérer les contacts ou garder une trace de dépenses. Certains modèles contiennent quelques exemples d’enregistrements afin d’illustrer leur utilisation. Bases de données de modèle peuvent être utilisés comme elles sont ou les personnaliser selon vos besoins.

Si un de ces modèles est adaptée à vos besoins, à l’utiliser est généralement le moyen le plus rapide pour obtenir une base de données démarrée. Toutefois, si vous possédez des données dans un autre programme que vous souhaitez importer dans Access, vous pouvez décider qu’il est préférable de créer une base de données sans l’aide d’un modèle. Modèles ont une structure de données déjà définie, et il peut nécessiter un grand nombre de travail d’adapter vos données existantes à la structure du modèle.

  1. Si vous avez une base de données ouvert, cliquez sur le Bouton Microsoft Office Image du bouton Office , puis sur Fermer de base de données Image du bouton pour afficher la page Prise en main de Microsoft Office Access.

  2. Plusieurs modèles proposés s’affichent au milieu de la page Prise en main de Microsoft Office Access, et plus deviennent disponibles lorsque vous cliquez sur les liens dans le volet Catégories de modèles. Vous pouvez télécharger des modèles supplémentaires à partir du site Web Office Online. Consultez la section suivante dans cet article pour plus d’informations.

  3. Cliquez sur le modèle que vous voulez utiliser.

  4. Access suggère un nom de fichier pour votre base de données dans la zone Nom de fichier, vous pouvez modifier le nom du fichier, si vous voulez. Pour enregistrer la base de données dans un dossier autre que celui affiché sous la zone Nom de fichier, cliquez sur Image du bouton , accédez au dossier dans lequel vous souhaitez enregistrer, puis cliquez sur OK. Si vous le souhaitez, vous pouvez créer et lier votre base de données à un site SharePoint.

  5. Cliquez sur créer (ou sur Télécharger, pour un modèle Office Online).

    Access crée ou téléchargements de la base de données, puis l’ouvre. Un formulaire est affiché dans lequel vous pouvez commencer à entrer des données. Si votre modèle contient des exemples de données, vous pouvez supprimer chaque enregistrement en cliquant sur le sélecteur d’enregistrement (la zone ombrée ou barre située à gauche de l’enregistrement), puis procédez comme suit :

    Sous l’onglet accueil, dans le groupe enregistrements, cliquez sur Supprimer. Image du bouton

  6. Pour commencer à entrer des données, cliquez sur la première cellule vide du formulaire et commencez à taper. Utilisez le volet de Navigation pour rechercher d’autres formulaires et rapports que vous souhaiterez peut-être utiliser.

Télécharger un modèle à partir d’Office Online

Si vous ne trouvez pas un modèle qui correspond à vos besoins dans la page Prise en main de Microsoft Office Access et que vous êtes connecté à Internet, vous pouvez explorer le site Web Office Online pour un large éventail.

  1. Dans la page Prise en main de Microsoft Office Access, sous informations supplémentaires sur Office Online, cliquez sur modèles.

    La page d’accueil Modèles sur Office Online s’affiche dans la fenêtre du navigateur.

  2. Utilisez les outils de recherche et de navigation Office Online pour trouver le modèle Access que vous voulez utiliser, puis suivez les instructions pour la télécharger. Lorsque vous téléchargez un modèle, un fichier de base de données est téléchargé sur votre ordinateur et ouvert dans une nouvelle instance d’Access. Dans la plupart des cas, le modèle est conçu pour ouvrir un formulaire de saisie de données afin que vous puissiez commencer à entrer directement des données.

Pour plus d’informations sur l’utilisation des modèles, voir l’article Guide pour les modèles Access 2007.

Haut de la Page

Créer une base de données sans l’aide d’un modèle

Si vous n’êtes pas d’informations sur l’aide d’un modèle, vous pouvez créer une base de données en créant vos propres tables, formulaires, États et autres objets de base de données. Dans la plupart des cas, cela implique généralement moins l’une des opérations suivantes :

  • Saisie, coller, ou importer des données dans la table qui est créée lorsque vous créez une nouvelle base de données et puis répétition du processus avec les nouvelles tables que vous créez à l’aide de la commande tableau sous l’onglet créer.

  • Importation de données provenant d’autres sources et créer les tables dans le processus.

Créer une base de données vide
  1. Dans la page Prise en main de Microsoft Office Access, sous Nouvelle base de données vide, cliquez sur Base de données vide.

    Bouton Base de données vide

  2. Dans le volet Base de données vide, tapez un nom de fichier dans la zone Nom de fichier. Si vous ne fournissez pas une extension de nom de fichier, Access l’ajoute pour vous. Pour modifier l’emplacement du fichier à partir de la valeur par défaut, cliquez sur Rechercher un emplacement votre base de données Image du bouton (à côté de la zone Nom de fichier ), naviguez jusqu’au nouvel emplacement, puis cliquez sur OK.

  3. Cliquez sur Créer.

    Access crée la base de données avec une table vide nommée Table1 et Table1 puis l’ouvre en mode feuille de données. Le curseur est placé dans la première cellule vide dans la colonne Ajouter un nouveau champ.

  4. Commencez à taper pour ajouter des données, ou vous pouvez coller des données à partir d’une autre source, comme décrit dans la section copier des données d’une autre source dans une table Access.

Entrer des informations en mode feuille de données est conçue pour être très similaire à l’utilisation d’une feuille de calcul Microsoft Office Excel 2007. La structure de table est créée pendant que vous entrez des données, chaque fois que vous ajoutez une nouvelle colonne à la table, un nouveau champ est défini. Access définit automatiquement le type de données de chaque champ basé sur les données que vous entrez.

Si vous ne souhaitez pas entrer des informations dans la table Table1 pour l’instant, cliquez sur Fermer Image du bouton . Si vous avez apporté des modifications à la table, Access vous invite à enregistrer les modifications dans la table. Cliquez sur Oui pour enregistrer vos modifications, cliquez sur non pour les annuler ou cliquez sur Annuler pour laisser la table ouverte.

Important : Si vous fermez la table Table1 sans l’enregistrer au moins une fois, Access supprime toute la table, même si vous avez entré les données qu’il contient.

Ajouter une table

Vous pouvez ajouter des tables à une base de données existante en utilisant les commandes dans le groupe tableaux, sous l’onglet créer.

Image du ruban Access

Créer une table en mode feuille de données    En mode feuille de données, vous pouvez entrer des données immédiatement et laisser Access générer une structure de table en arrière-plan. Noms des champs affectés numérique (champ1, Champ2, etc.) et Access définit automatiquement le type de données de chaque champ basé sur les données que vous entrez.

  1. Sous l’onglet créer, dans le groupe tableaux, cliquez sur tableau. Image du bouton

    Access crée la table et sélectionne la première cellule vide dans la colonne Ajouter un nouveau champ.

    Remarque : Si vous ne voyez pas une colonne Ajouter un nouveau champ, vous êtes peut-être en mode Création au lieu du mode feuille de données. Pour basculer en mode feuille de données, double-cliquez sur la table dans le volet de Navigation. Access vous invite à enregistrer la nouvelle table, puis bascule en mode feuille de données.

  2. Sous l’onglet feuille de données, dans le groupe champs et colonnes, cliquez sur Nouveau champ. Image du bouton

    Access affiche le volet Modèles de champ, qui contient la liste des champs couramment utilisés. Si vous cliquez ou faites glisser l’une de ces champs dans votre feuille de données, Access ajoute un champ portant ce nom et définit ses propriétés les valeurs appropriées pour ce type de champ. Vous pouvez modifier les propriétés plus tard, si vous voulez. Si vous faites glisser le champ, vous devez faire glisser sur une zone de la feuille de données qui contient des données. Une barre verticale d’insertion apparaît, vous indiquant que l’endroit où le champ est placé.

  3. Pour ajouter des données, commencez à taper dans la première cellule vide ou collez des données à partir d’une autre source, comme décrit dans la section copier des données d’une autre source dans une table Access.

  4. Pour renommer une colonne (champ), double-cliquez sur l’en-tête correspondant, puis tapez le nouveau nom.

    Il est recommandé d’attribuer un nom significatif à chaque champ, afin que vous pouvez déterminer qu’il s’affiche lorsqu’elle apparaît dans le volet Liste de champs.

  5. Pour déplacer une colonne, cliquez sur son en-tête pour sélectionner la colonne, puis faites glisser la colonne à l’emplacement souhaité.

    Vous pouvez également sélectionner plusieurs colonnes adjacentes, puis faites-les glisser vers un nouvel emplacement en une seule fois. Pour sélectionner plusieurs colonnes adjacentes, cliquez sur l’en-tête de colonne de la première colonne, puis, tout en maintenant la touche MAJ ENFONCÉE, cliquez sur l’en-tête de colonne de la dernière colonne.

Créer une table en mode Création    En mode Création, vous créez tout d’abord la structure de la nouvelle table. Vous puis passez en mode feuille de données pour entrer des données, ou entrez des données à l’aide d’une autre méthode, telles que le collage ou l’importation.

  1. Sous l’onglet créer, dans le groupe tableaux, cliquez sur Création de Table. Image du bouton

  2. Pour chaque champ dans votre table, tapez un nom dans la colonne Nom de champ et puis sélectionnez un type de données dans la liste Type de données.

    Remarque : Si vous ne voyez pas les colonnes Nom de champ et Type de données, vous êtes peut-être en mode feuille de données au lieu du mode Création. Pour basculer en mode Création, avec le bouton droit de la table dans le volet de Navigation, puis cliquez sur Mode Création Image du bouton . Access vous invitant à entrer un nom pour la nouvelle table, puis bascule en mode Création.

  3. Si vous le souhaitez, vous pouvez taper une description pour chaque champ dans la colonne Description. La description apparaît alors sur la barre d’état lorsque le curseur se trouve dans ce champ en mode feuille de données. La description est également utilisée en tant que texte de la barre d’état pour tous les contrôles dans un formulaire ou l’état que vous créez en faisant glisser le champ à partir du volet Liste de champs ou pour les contrôles qui sont créés de ce champ lorsque vous utilisez l’Assistant formulaire ou état.

  4. Après avoir ajouté tous les champs, enregistrez la table :

    • Cliquez sur le Bouton Microsoft Office Image du bouton Office , puis cliquez sur Enregistrer ou appuyez sur CTRL + S Image du bouton .

  5. Vous pouvez commencer à taper les données dans le tableau à tout moment en passant en mode feuille de données et en cliquant sur la première cellule vide. Vous pouvez également coller des données à partir d’une autre source, comme décrit dans la section copier des données d’une autre source dans une table Access.

Créer une table à l’aide d’un modèle    Access fournit des modèles pour les types de fréquemment utilisées des tables. Avec un seul clic, vous pouvez créer une structure de table complète avec les champs déjà configurés et prêt à l’emploi. Si nécessaire, vous pouvez puis ajouter ou supprimer des champs afin que la table adapté à vos besoins.

  1. Sous l’onglet créer, dans le groupe tableaux, cliquez sur Modèles de Table, puis sélectionnez un des modèles disponibles dans la liste.

  2. Pour ajouter des données, commencez à taper dans la première cellule vide ou collez des données à partir d’une autre source, comme décrit dans la section copier des données d’une autre source dans une table Access.

    • Pour supprimer une colonne   

      1. Avec le bouton droit de l’en-tête de colonne, puis cliquez sur Supprimer la colonne Image du bouton .

    • Pour ajouter une nouvelle colonne   

      1. Sous l’onglet feuille de données, dans le groupe champs et colonnes, cliquez sur Nouveau champ. Image du bouton

      2. Access affiche le volet Modèles de champ, qui contient la liste des champs couramment utilisés. Si vous cliquez ou faites glisser l’une de ces champs dans votre feuille de données, Access ajoute un champ portant ce nom et définit ses propriétés les valeurs appropriées pour ce type de champ. Vous pouvez modifier les propriétés plus tard, si vous voulez. Si vous faites glisser le champ, vous devez faire glisser sur une zone de la feuille de données qui contient des données. Une barre verticale d’insertion apparaît, vous indiquant que l’endroit où le champ est placé.

  3. Enregistrez la table :

    • Cliquez sur le Bouton Microsoft Office Image du bouton Office , puis cliquez sur Enregistrer ou appuyez sur CTRL + S Image du bouton .

Définir les propriétés de champ en mode Création    Quelle que soit la façon dont vous avez créé votre tableau, il est recommandé d’examiner et de définir les propriétés de champ. Cela peut uniquement être exécuté en mode Création. Pour passer en mode Création, avec le bouton droit de la table dans le volet de Navigation, puis cliquez sur Mode Création. Pour afficher les propriétés d’un champ, cliquez sur le champ dans la grille de création. Les propriétés sont affichent en dessous de la grille de création, sous Propriétés du champ.

Pour afficher une description de chaque propriété de champ, cliquez sur la propriété et lisez la description dans la zone en regard de la liste des propriétés sous Propriétés du champ. Vous pouvez obtenir des informations plus détaillées en appuyant sur F1.

Le tableau suivant décrit certaines des propriétés de champ courantes.

Propriété

Description

Taille du champ

Pour les champs de texte, cette propriété définit le nombre maximal de caractères pouvant être stockés dans le champ. La valeur maximale est 255. Pour les champs numériques, cette propriété définit le type de numéro qui sera stocké (entier Long, Double, et ainsi de suite). Pour le stockage des données plus efficace, il est recommandé que vous allouez le moins d’espace dont vous aurez besoin pour les données. Vous pouvez ajuster la valeur ultérieurement, si l’évolution de vos besoins.

Format

Cette propriété définit la façon dont les données sont affichées. Il n’affecte pas les données réelles qu’il est stocké dans le champ. Vous pouvez sélectionner un format prédéfini ou entrez un format personnalisé.

Masque de saisie

Utilisez cette propriété pour spécifier un modèle pour toutes les données à entrer dans ce champ. Cela permet de garantir que toutes les données est correcte, et qu’il contient le nombre requis de caractères. Pour une aide sur la création d’un masque de saisie, cliquez sur Bouton Générateur sur le côté droit de la zone de propriété.

Valeur par défaut

Utilisez cette propriété pour spécifier la valeur par défaut qui s’affichent dans ce champ chaque fois qu’un nouvel enregistrement est ajouté. Par exemple, si vous avez un champ Date/heure dans lequel vous voulez toujours enregistrer la date à laquelle l’enregistrement a été ajouté, vous pouvez entrer « Date() » (sans guillemets) en tant que la valeur par défaut.

Obligatoire

Cette propriété définit si une valeur est requise dans ce champ. Si vous définissez cette propriété sur Oui, Access n’autorise pas vous permet d’ajouter un nouvel enregistrement, sauf si une valeur est entrée pour ce champ.

Haut de la Page

Copier des données à partir d’une autre source dans une table Access

Si vos données sont stockées dans un autre programme, tel que Office Excel 2007, vous pouvez copier et coller dans une table Access. En règle générale, il est préférable que vos données sont déjà séparées en colonnes, comme dans une feuille de calcul Excel. Si vos données sont dans un mot programme de traitement, il est préférable pour séparer les colonnes de données à l’aide des onglets, ou pour convertir les données dans une table dans le programme de traitement de texte avant de copier les données. Si les données doivent être modifiées ou manipulation (par exemple, fractionner les noms complets en premier et derniers noms), vous souhaiterez peut-être procédez comme suit avant de copier les données, en particulier si vous n’êtes pas familiarisé avec Access.

Lorsque vous collez des données dans une table vide, Access définit le type de données de chaque champ en fonction de quel type de données trouvés à cet emplacement. Par exemple, si un champ collé ne contient que des valeurs de date, Access applique les données Date/heure type pour ce champ. Si le champ collé ne contient uniquement les mots « Oui » et « », Access applique la valeur Oui/aucune donnée ne tapez dans le champ.

Accès des noms aux champs en fonction de ce qu’elle trouve dans la première ligne de données collées. Si la première ligne de données collées est un type similaire aux lignes suivantes, Access détermine que la première ligne fait partie des données et attribue aux champs des noms génériques (F1, F2, etc.). Si la première ligne de données collées n’est pas similaire aux lignes qui suivent, Access détermine que la première ligne se compose de noms de champs. Accès des noms aux champs en conséquence et n’inclut pas la première ligne dans les données.

Si Access attribue des noms de champ générique, vous devez renommer les champs dès que possible pour éviter toute confusion. Procédez comme suit :

  1. Enregistrez la table.

    • Cliquez sur le Bouton Microsoft Office Image du bouton Office , puis cliquez sur Enregistrer ou appuyez sur CTRL + S Image du bouton .

  2. En mode feuille de données, double-cliquez sur chaque en-tête de colonne et tapez un nom de champ valide pour chaque colonne. Il peut se présenter comme si vous tapez du texte sur les données, mais la ligne d’en-tête de colonne contient des noms de champs, pas de données.

  3. Enregistrez de nouveau la table.

Remarque : Vous pouvez également renommer les champs en passant en mode Création et en modifiant le nom du champ. Pour passer en mode Création, avec le bouton droit de la table dans le volet de Navigation, cliquez sur Mode Création. Pour revenir au mode feuille de données, double-cliquez sur la table dans le volet de Navigation.

Haut de la Page

Importer, ajouter ou attacher des données à partir d’une autre source

Vous pouvez avoir des données qui sont stockées dans un autre programme, et que vous voulez importer ces données dans une nouvelle table ou les ajouter à une table existante dans Access. Ou vous pouvez travailler avec des personnes qui conservent les données dans d’autres programmes, et que vous voulez utiliser dans Access en créant un lien vers celle-ci. Dans les deux cas, Access facilite utiliser des données provenant d’autres sources. Vous pouvez importer des données à partir d’une feuille de calcul Excel, d’un tableau dans une autre base de données Access, d’une liste SharePoint ou à partir d’une variété d’autres sources. Le processus varie légèrement, en fonction de votre source, mais la procédure suivante vous aideront à démarrer.

  1. Dans Access, sous l’onglet Données externes, dans le groupe Importer, cliquez sur la commande correspondant au type de fichier que vous importez.

    Image du ruban Access

    Par exemple, si vous importez des données à partir d’une feuille de calcul Excel, cliquez sur Excel. Si vous ne voyez pas le type de programme dont vous avez besoin, cliquez sur plus.

    Remarque : Si vous ne trouvez pas le type de format approprié dans le groupe Importer, vous devrez peut-être démarrer le programme dans lequel vous avez créé les données, puis utilisez ce programme pour enregistrer les données dans un fichier commun mettre en forme (par exemple, un fichier texte délimité ) que vous puissiez importer ces données dans Access.

  2. Dans la boîte de dialogue Données externes, cliquez sur Parcourir pour rechercher le fichier de données source ou tapez le chemin d’accès complet du fichier de données source dans la zone nom de fichier.

  3. Cliquez sur l’option souhaitée (tous les programmes vous permettent d’importer et certains permettant d’ajouter ou créer un lien) sous spécifier comment et où vous voulez stocker les données dans la base de données Active. Vous pouvez créer une nouvelle table qui utilise les données importées ou (avec certains programmes), vous pouvez ajouter les données à une table existante ou créer une table liée qui contient un lien vers les données dans le programme source.

  4. Si un Assistant démarre, suivez les instructions sur les pages suivantes de l’Assistant. Dans la dernière page de l’Assistant, cliquez sur Terminer.

    Si vous importez des objets ou lier des tables à partir d’une base de données Access, l’option Importer des objets ou Tables lien boîte de dialogue s’affiche. Choisissez les éléments souhaitée, puis cliquez sur OK.

    Le processus varie selon que vous choisissez à importer, ajouter ou lier des données.

  5. Access vous demande si vous souhaitez enregistrer les détails de l’opération d’importation que vous venez d’effectuer. Si vous pensez que vous exécutez cette opération d’importation même ultérieurement, cliquez sur Enregistrer les étapes d’importation, puis entrez les détails. Vous pouvez facilement recommencez l’opération ultérieurement en cliquant sur Importations enregistrées Image du bouton dans le groupe Importer sous l’onglet Données externes. Si vous ne voulez pas enregistrer les détails de l’opération, cliquez sur Fermer.

Si vous choisissez d’importer une table, Access permet d’importer les données dans une nouvelle table, puis affiche la table dans le groupe Tables dans le volet de Navigation. Si vous choisissez d’ajouter des données à une table existante, les données sont ajoutées à la table. Si vous avez choisi attacher des données, Access crée une table liée dans le groupe Tables dans le volet de Navigation.

Haut de la Page

Ouvrir une base de données Access existante
  1. Cliquez sur le Bouton Microsoft Office Image du bouton Office , puis sur Ouvrir.

  2. Dans la boîte de dialogue Ouvrir, accédez à la base de données que vous voulez ouvrir.

  3. Effectuez l’une des opérations suivantes :

    • Double-cliquez sur la base de données pour l’ouvrir dans le mode par défaut spécifié dans la boîte de dialogue Options Access ou le mode qui a été défini par une stratégie d’administration.

    • Cliquez sur Ouvrir pour ouvrir la base de données pour un accès partagé dans un environnement multi-utilisateur afin que vous et autres utilisateurs puissent lire et écrire dans la base de données.

    • Cliquez sur la flèche en regard du bouton Ouvrir, puis sur Ouvrir en lecture seule pour ouvrir la base de données pour l’accès en lecture seule afin que vous pouvez afficher, mais pas le modifier. D’autres utilisateurs peuvent toujours lire et écrire dans la base de données.

    • Cliquez sur la flèche en regard du bouton Ouvrir, puis sur Ouvrir en exclusif pour ouvrir la base de données en mode exclusif. Lorsque vous avez une base de données ouvert en mode exclusif, toute personne tente d’ouvrir la base de données permet de recevoir un message « fichier déjà en cours d’utilisation ».

    • Cliquez sur la flèche en regard du bouton Ouvrir, puis sur Ouvrir en mode lecture seule exclusif pour ouvrir la base de données pour l’accès en lecture seule. D’autres utilisateurs peuvent toujours ouvrir la base de données, mais elles sont limitées au mode lecture seule.

Si vous ne trouvez pas la base de données que vous voulez ouvrir   

  1. Dans la boîte de dialogue Ouvrir, cliquez sur Mon ordinateur ou, cliquez sur Poste de travail dans la liste déroulante Regarder dans.

  2. Dans la liste des lecteurs, avec le bouton droit le lecteur que vous pensez que peut contenir la base de données, puis cliquez sur recherche.

  3. Tapez vos critères de recherche dans la boîte de dialogue Résultats de la recherche, puis cliquez sur recherche pour rechercher la base de données.

  4. Si la base de données est trouvé, double-cliquez dessus pour l’ouvrir.

  5. Vous devez cliquer sur Annuler dans la base de données ouvrir la boîte de dialogue Ouvrir. Ensuite, fermez la boîte de dialogue Résultats de la recherche.

Remarque : Vous pouvez ouvrir directement un fichier de données dans un format de fichier externe, comme dBASE, Paradox, Microsoft Exchange ou Excel. Vous pouvez également ouvrir directement n’importe quel source de données ODBC, tel que Microsoft SQL Server ou Microsoft FoxPro. Access crée une nouvelle base de données Access dans le même dossier que le fichier de données automatiquement et ajoute des liens à chaque table dans la base de données externe.

Conseils
  • Pour ouvrir une base de données récemment ouvertes, cliquez sur le nom de fichier pour cette base de données dans la liste Ouvrir une base de données récente dans la page Prise en main de Microsoft Office Access. Access ouvre la base de données avec les mêmes paramètres que lors de la dernière fois que vous l’avez ouvert. Si la liste des derniers fichiers utilisés n’est pas affichée, cliquez sur le Bouton Microsoft Office Image du bouton Office , puis sur Options Access. Dans la boîte de dialogue Options Access, cliquez sur Avancé. Sous Afficher, entrez le nombre de documents à afficher dans la liste de Documents récents, avec un maximum de neuf.

  • Si vous ouvrez une base de données en cliquant sur le Bouton Microsoft Office Image du bouton Office , puis en utilisant la commande Ouvrir, vous pouvez afficher une liste des raccourcis vers les bases de données que vous avez déjà ouvertes en cliquant sur Mes Documents récents dans la Boîte de dialogue Ouvrir.

Haut de la Page

Créer un modèle vide personnalisé

Lorsque vous créez une nouvelle base de données vide, Access ouvre une nouvelle table dans laquelle vous pouvez entrer des données, mais qu’il ne crée aucuns autres objets dans la base de données. Si vous souhaitez que d’autres objets, tels que les formulaires, États, des macros ou des tables supplémentaires, présentent dans toutes les nouvelles bases de données que vous créez, vous pouvez créer un modèle vide personnalisé qui contient ces objets. Ensuite, la prochaine fois que vous créez une nouvelle base de données, il contient déjà ces objets dans votre modèle. Outre ces objets, le modèle peut inclure des tables préremplies avec les données, ainsi que les paramètres de configuration spéciaux, propriétés de la base de données, références ou code que vous souhaitez effectuer dans toutes les nouvelles bases de données.

Par exemple, supposons que vous disposez d’une collection de macros que vous souhaitez utiliser dans tous vos projets. Si vous créez un modèle vide contenant ces macros, Access inclut les nouvelles bases de données que vous créez.

Vous pouvez créer un modèle vide dans le format de fichier Office Access 2007, le format de fichier Access 2002-2003 ou le format de fichier Access 2000. Le modèle doit être nommé Blank.accdb pour le format de fichier Office Access 2007 et Blank.mdb pour les formats de fichier antérieurs.

  • Si le format de fichier par défaut est défini sur Access 2000 ou Access 2002 - 2003, Access utilise Blank.mdb comme le nom du fichier modèle vide. La nouvelle base de données est créée dans le même format de fichier que Blank.mdb. Par exemple, même si le format de fichier par défaut est Access 2000, si le modèle blank.mdb est au format de fichier Access 2002-2003, les nouvelles bases de données que vous créez sera au format Access 2002-2003.

  • Si le format de fichier par défaut est défini sur Access 2007, Access utilise Blank.accdb comme nom de fichier pour le modèle vide.

Comment modifier le format de fichier par défaut ?

  1. Cliquez sur le Bouton Microsoft Office Image du bouton Office , puis sur Options Access.

  2. Dans la boîte de dialogue Options Access, cliquez sur standard.

  3. Sous Création de bases de données, sélectionnez le format souhaité dans la liste déroulante format de fichier par défaut.

Pour créer un modèle vide, effectuez l’une des opérations suivantes :

  • Créer une nouvelle base de données (vous pouvez nommer Blank ou lui attribuer un nom temporaire), puis importez ou créez les objets que vous voulez inclure dans le modèle.

  • Faire une copie d’une base de données existante qui contient déjà les objets souhaités dans le modèle et supprimez les objets que vous ne voulez pas.

Une fois que vous avez les objets souhaités dans le modèle, vous devez l’enregistrer dans un emplacement spécifique.

  1. Cliquez sur le Bouton Microsoft Office Image du bouton Office et pointez sur Enregistrer sous.

  2. Sous Enregistrer la base de données dans un autre format, cliquez sur le format de fichier souhaité pour le modèle.

  3. Dans la boîte de dialogue Enregistrer sous, accédez à un de ces deux dossiers de modèles :

    • Dossier de modèles système    Par exemple, C:\Program Files\Microsoft Office\Templates\1033\Access

    • Dossier de modèles utilisateur    Par exemple :

      • Dans Windows Vista    c:\Users\user name\AppData\Roaming\Microsoft\Templates

      • Dans Microsoft Windows Server 2003 ou Microsoft Windows XP    C:\Documents and Settings\nom d’utilisateur\Application Data\Microsoft\Templates

        Remarque : Un modèle vierge dans le dossier de modèles système remplace un modèle vide dans les dossiers de modèle utilisateur.

  4. Dans la zone nom de fichier, tapez Blank.accdb (ou Blank.mdb, si vous créez un modèle pour une version antérieure), puis cliquez sur Enregistrer.

Maintenant que le nouveau modèle est en place, lorsque vous créez une nouvelle base de données vide, les objets dans le modèle sont inclus dans une nouvelle base de données que vous créez par défaut. Access ouvre une nouvelle table en mode feuille de données, comme nous le faisons lorsque vous créez de nouvelles bases de données vides sans l’aide d’un modèle.

Pour arrêter d’utiliser le modèle vide, supprimez ou renommez le fichier Blank.accdb (ou Blank.mdb, pour les versions antérieures d’Access).

Haut de la Page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×