Créer une base de données

Remarque : Nous faisons de notre mieux pour vous fournir le contenu d’aide le plus récent aussi rapidement que possible dans votre langue. Cette page a été traduite automatiquement et peut donc contenir des erreurs grammaticales ou des imprécisions. Notre objectif est de faire en sorte que ce contenu vous soit utile. Pouvez-vous nous indiquer en bas de page si ces informations vous ont aidé ? Voici l’article en anglais à des fins de référence aisée.

Cet article décrit le processus de base de démarrage d' Access et de création d'une base de données qui sera utilisée sur des ordinateurs de bureau, et non sur le Web. Ce guide décrit la création d'une base de données de bureau à l'aide d'un modèle et la création d'une base de données à partir de zéro en créant vos propres tables, formulaires, États et autres objets de base de données. Décrit également quelques techniques que vous pouvez utiliser pour récupérer des données existantes dans votre nouvelle base de données.

Contenu de cet article

Présentation

Créer une base de données à l’aide d’un modèle

Créer une base de données sans utiliser de modèle

Copier des données d'une autre source dans une table Access

Importer, ajouter ou lier des données d'une autre source

Ajouter un composant d'application

Ouvrir une base de données Access existante

Vous utilisez Access 2007?

Présentation

Lors du premier démarrage d'Access, ou si vous fermez une base de données sans fermer Access, le mode Microsoft Office Backstage est affiché.

Le mode Backstage est un point de départ qui vous permet de créer une base de données, d'ouvrir une base de données existante, d'afficher le contenu proposé dans Office.com: tout ce que vous pouvez utiliser pour effectuer une opération sur un fichier de base de données ou en dehors d'une base de données, plutôt que de au sein d'une base de données.

Création d'une base de données

Lorsque vous ouvrez Access, le mode Backstage affiche l'onglet nouveau . L'onglet nouveau fournit plusieurs méthodes pour créer une base de données:

  • Une base de données vide    Vous pouvez commencer à zéro si vous le souhaitez. Il s'agit d'une bonne option si vous avez des exigences spécifiques en matière de conception ou si vous avez des données à inclure ou à incorporer.

  • Modèle installé avec Access    EnVisagez d'utiliser un modèle si vous commencez un nouveau projet et voulez un début de tête. Access est fourni avec plusieurs modèles installés par défaut.

  • Modèle de Office.com    Outre les modèles inclus dans Access, vous pouvez trouver de nombreux modèles supplémentaires sur Office.com. Vous n'avez même pas besoin d'ouvrir un navigateur, les modèles sont disponibles sous l'onglet nouveau .

Ajouter des données à une base de données

Lorsque vous utilisez une base de données, vous pouvez ajouter des champs, tables ou composants d'application.

Les composants d'application sont une fonctionnalité qui vous permet d'utiliser plusieurs objets de base de données liés comme s'ils étaient. Par exemple, la partie d'une application peut se composer d'une table et d'un formulaire basé sur la table. Vous pouvez ajouter le tableau et le formulaire en même temps à l'aide du composant d'application.

Vous pouvez également créer des requêtes, des formulaires, des États, des macros-tous les objets de base de données que vous utilisez.

Créer une base de données à l’aide d’un modèle

Access est fourni avec différents modèles que vous pouvez utiliser en l'aspect ou en tant que point de départ. Un modèle est une base de données prête à l'emploi qui contient toutes les tables, requêtes, formulaires, macros et rapports nécessaires à l'exécution d'une tâche spécifique. Par exemple, il existe des modèles que vous pouvez utiliser pour effectuer le suivi des problèmes, gérer des contacts ou conserver une trace des dépenses. Certains modèles contiennent quelques exemples d'enregistrements pour vous permettre de montrer leur utilisation.

Si l'un de ces modèles correspond à vos besoins, il est généralement le moyen le plus rapide de démarrer une base de données. Toutefois, si vous avez des données à importer dans Access à partir d'un autre programme, il est possible que vous souhaitiez créer une base de données sans utiliser de modèle. Les modèles possèdent une structure de données déjà définie; cela peut nécessiter un grand nombre de tâches pour adapter vos données existantes à la structure du modèle.

  1. Si une base de données est ouverte, sous l'onglet fichier , cliquez sur Fermer. Le mode Backstage affiche l'onglet nouveau .

  2. Plusieurs jeux de modèles sont disponibles sous l'onglet nouveau , dont certaines sont intégrées dans Access. Vous pouvez télécharger des modèles supplémentaires à partir de Office.com. Pour plus d'informations, rePortez-vous à la section suivante de cet article.

  3. Sélectionnez le modèle que vous voulez utiliser.

  4. Access suggère un nom de fichier pour votre base de données dans la zone nom de fichier , vous pouvez modifier le nom du fichier si vous le souhaitez. Pour enregistrer la base de données dans un autre dossier que celui affiché sous la zone nom de fichier, cliquez sur Image du bouton , recherchez le dossier dans lequel vous voulez l'enregistrer, puis cliquez sur OK. Vous pouvez également créer et lier votre base de données sur un site SharePoint.

    Remarque : Même si les deux utilisent SharePoint, une base de données de bureau liée à un site SharePoint n'est pas identique à une base de données Web utilisant Access services. Pour utiliser une base de données de bureau, Access doit être installé. Une base de données Web peut être utilisée avec un navigateur Web.

  5. Cliquez sur Créer.

    Access crée une base de données à partir du modèle que vous avez choisi, puis ouvre la base de données. Dans de nombreux modèles, un formulaire s'affiche et vous permet de commencer à entrer des données. Si votre modèle contient des exemples de données, vous pouvez supprimer chaque enregistrement en cliquant sur le sélecteur d'enregistrement (zone ou barre ombrée), puis en procédant comme suit:

    Dans l’onglet Accueil, dans le groupe Enregistrements, cliquez sur Supprimer. Button image

  6. Pour commencer à entrer des données, cliquez sur la première cellule vide du formulaire et commencez à taper. Utilisez le Volet de navigation pour rechercher d'autres formulaires ou rapports que vous pouvez utiliser. Certains modèles incluent un formulaire de navigation qui vous permet de passer d'un objet de base de données à un autre.

Pour plus d'informations sur l'utilisation des modèles, voir l'article utiliser un modèle pour créer une base de données de bureau Access.

Haut de la page

Créer une base de données sans utiliser de modèle

Si vous n'êtes pas intéressé par l'utilisation d'un modèle, vous pouvez créer une base de données en créant vos propres tables, formulaires, États et autres objets de base de données. Dans la plupart des cas, vous devez procéder comme suit:

  • Saisie, collage ou importation de données dans la table créée lors de la création d'une base de données, puis répétition du processus avec de nouvelles tables créées à l'aide de la commande table sous l'onglet créer .

  • Importation de données provenant d'autres sources et création de nouvelles tables dans le processus.

Créer une base de données vide

  1. Dans l'onglet fichier , cliquez sur nouveau, puis sur base de données vide.

  2. Tapez un nom de fichier dans la zone nom de fichier . Pour modifier l'emplacement du fichier par défaut, cliquez sur Rechercher un emplacement pour le Image du bouton de votre base de données(en regard de la zone nom de fichier ), accédez au nouvel emplacement, puis cliquez sur OK.

  3. Cliquez sur Créer.

    Access crée la base de données à l'aide d'une table vide nommée Table1, puis ouvre la table1 en mode feuille de données. Le curseur est placé dans la première cellule vide de la colonne Cliquer pour ajouter .

  4. Commencez à taper pour ajouter des données ou vous pouvez coller des données d'une autre source, comme décrit dans la section copier des données d'une autre source dans une table Access.

La saisie de données en mode feuille de données est conçue pour être très similaire à l'utilisation d'une feuille de calcul Excel. La structure du tableau est créée lorsque vous entrez des données. Lorsque vous ajoutez une nouvelle colonne à la feuille de données, un nouveau champ est défini dans la table. Access définit automatiquement le type de données de chaque champ, en fonction des données que vous entrez.

Si vous ne souhaitez pas entrer de données dans la table1 pour le moment, cliquez sur Fermerles Button image . Si vous avez apporté des modifications à la table, Access vous invite à enregistrer les modifications. Cliquez sur Oui pour enregistrer vos modifications, cliquez sur non pour les ignorer ou cliquez sur Annuler pour laisser la table ouverte.

Conseil :  Access recherche un fichier intitulé Blank. accdb dans le dossier se trouvant sur [installation Drive]: \Program Files\Microsoft Office\Templates\1033\Access\. S'il existe, Blank. accdb est le modèle pour toutes les nouvelles bases de données vides, à l'exception des bases de données Web. Tout contenu qu'il contient est hérité par toutes les nouvelles bases de données vides. C'est un bon moyen de répartir le contenu par défaut, par exemple des numéros de référence ou des stratégies de non-revendication d'entreprise. N'oubliez pas que Blank. accdb n'a aucun effet sur la création de nouvelles bases de données Web vides.

Important : Si vous fermez la table table1 sans l'enregistrer au moins une fois, Access l'efface, même si vous y avez entré des données.

Ajouter un tableau

Vous pouvez ajouter des tables à une base de données existante en utilisant les commandes du groupe tables sous l'onglet créer .

Image du ruban Access

Créer une table à partir du mode feuille de données    En mode feuille de données, vous pouvez entrer des données immédiatement et laisser Access créer une structure de tableau en coulisses. Les noms de champs sont attribués numériquement (champ1, champ2, etc.) et Access définit automatiquement le type de données de chaque champ, en fonction des données que vous entrez.

  1. Sous l’onglet Création, dans le groupe Tables, cliquez sur Table. Button image

    Access crée le tableau et sélectionne la première cellule vide de la colonne Cliquer pour ajouter .

  2. Dans l'onglet champs , dans le groupe Ajouter & supprimer , cliquez sur le type de champ que vous voulez ajouter. Si vous ne voyez pas le type de votre choix, cliquez sur plus de champs Image du bouton .

  3. Access affiche une liste des types de champs fréquemment utilisés. Cliquez sur le type de champ souhaité, et Access ajoute le nouveau champ à la feuille de données au point d'insertion.

    Vous pouvez déplacer le champ en le faisant glisser. Lorsque vous faites glisser un champ dans une feuille de données, une barre d'insertion verticale s'affiche à l'endroit où le champ sera placé.

  4. Pour ajouter des données, commencez à taper dans la première cellule vide ou collez des données à partir d'une autre source, comme décrit dans la section copier des données d'une autre source dans une table Access.

  5. Pour renommer une colonne (champ), double-cliquez sur l'en-tête de colonne, puis tapez le nouveau nom.

    Donnez un nom significatif à chaque champ, afin que vous puissiez déterminer ce qu'il contient lorsque vous le voyez dans le volet liste de champs .

  6. Pour déplacer une colonne, cliquez sur son titre pour la sélectionner, puis faites glisser la colonne vers l'emplacement souhaité. Vous pouvez également sélectionner plusieurs colonnes contiguës, puis les faire glisser vers un nouvel emplacement en une seule fois. Pour sélectionner plusieurs colonnes contiguës, cliquez sur l'en-tête de la première colonne, puis, tout en maintenant la touche Maj enfoncée, cliquez sur l'en-tête de la dernière colonne.

Créer une table à partir du mode création    En mode création, vous commencez par créer la structure de la table. Vous pouvez ensuite basculer en mode feuille de données pour entrer des données ou entrer des données en utilisant une autre méthode (collage ou importation, par exemple).

  1. Dans l'onglet création , dans le groupe tableaux , cliquez sur création de table. Image du bouton

  2. Pour chaque champ de la table, entrez un nom dans la colonne nom du champ , puis sélectionnez un type de données dans la liste type de données .

  3. Si vous le souhaitez, vous pouvez taper une description pour chaque champ dans la colonne Description . La description s'affiche dans la barre d'État lorsque le curseur se trouve dans le champ en mode feuille de données. La description est également utilisée en tant que texte de la barre d'État pour les contrôles d'un formulaire ou d'un État que vous créez en faisant glisser le champ du volet liste de champs et pour les contrôles créés pour ce champ lorsque vous utilisez l'Assistant formulaire ou l'Assistant État.

  4. Après avoir ajouté tous vos champs, enregistrez la table:

    • Sous l’onglet Fichier, cliquez sur Enregistrer.

  5. Vous pouvez commencer à entrer des données dans le tableau à tout moment en passant en mode feuille de données et en cliquant sur la première cellule vide. Vous pouvez également coller les données à partir d'une autre source, comme décrit dans la section copier des données d'une autre source dans une table Access.

Définir des propriétés de champ en mode Création    Quelle que soit la méthode que vous avez créée, il peut s'avérer utile d'examiner et de définir les propriétés des champs. Même si certaines propriétés sont disponibles en mode feuille de données, certaines propriétés peuvent uniquement être définies en mode création. Pour basculer en mode création, cliquez avec le bouton droit sur la table dans le volet de navigation, puis cliquez sur mode création. Pour afficher les propriétés d'un champ, cliquez sur le champ dans la grille de création. Celles-ci s'affichent sous la grille de création, sous Propriétés du champ.

Pour afficher une description de chaque propriété de champ, cliquez sur la propriété et lisez la description dans la zone située en regard de la liste de propriétés sous Propriétés du champ. Vous pouvez obtenir des informations plus détaillées en cliquant sur le bouton aide.

Le tableau suivant décrit certaines des propriétés de champ généralement ajustées.

Propriété

Description

Taille du champ

Pour les champs de texte, cette propriété définit le nombre maximal de caractères pouvant être stockés dans le champ. La valeur maximale est 255. Pour les champs numériques, cette propriété définit le type de numéro qui sera stocké (entier long, double, etc.). Pour optimiser le stockage des données, il est recommandé d'allouer le plus petit nombre d'espace dont vous pensez avoir besoin pour les données. Vous pouvez ajuster la valeur par la suite, si vos besoins évoluent.

Mise en forme

Cette propriété définit le mode d'affichage des données. Il n'affecte pas les données réelles qui sont stockées dans le champ. Vous pouvez sélectionner un format prédéfini ou entrer un format personnalisé.

Masque de saisie

Utilisez cette propriété pour spécifier un modèle pour toutes les données qui seront entrées dans ce champ. Cela permet de s'assurer que toutes les données sont entrées correctement et qu'elles contiennent le nombre de caractères requis. Pour obtenir de l'aide sur la création d'un masque de saisie, cliquez Bouton Générateur sur le côté droit de la zone de propriété.

Valeur par défaut

Utilisez cette propriété pour spécifier la valeur par défaut qui s'affichera dans ce champ chaque fois qu'un nouvel enregistrement est ajouté. Par exemple, si vous avez un champ date/heure dans lequel vous voulez toujours enregistrer la date à laquelle l'enregistrement a été ajouté, vous pouvez entrer «Date ()» (sans guillemets) comme valeur par défaut.

Obligatoire

Cette propriété détermine si une valeur est requise dans ce champ. Si vous définissez cette propriété sur Oui, Access ne vous autorise pas à ajouter un nouvel enregistrement, sauf si une valeur est entrée pour ce champ.

Haut de la page

Copier des données d'une autre source dans une table Access

Si vos données sont actuellement stockées dans un autre programme (par exemple, Excel), vous pouvez les copier et les coller dans une table Access. En règle générale, cela est préférable si vos données sont déjà séparées en colonnes, comme dans une feuille de calcul Excel. Si vos données se trouvent dans un programme de traitement de texte, il est préférable de séparer les colonnes de données à l'aide d'onglets ou de convertir les données en tableau dans le programme de traitement de texte avant de copier les données. Si vos données nécessitent une modification ou une manipulation (par exemple, en séparant les noms complets en prénoms et les noms), vous pouvez le faire avant de copier les données, en particulier si vous n'êtes pas familiarisé avec Access.

Lorsque vous collez des données dans une table vide, Access définit le type de données de chaque champ en fonction du type de données qu'il recherche. Par exemple, si un champ collé ne contient aucune valeur de date, Access applique le type de données date/heure au champ. Si le champ collé contient uniquement les mots «Oui» et «non», Access applique le type de données oui/non au champ.

Access nomme les champs en fonction du contenu de la première ligne de données collées. Si la première ligne de données collées est semblable au type des lignes qui suivent, Access détermine que la première ligne fait partie des données et affecte les champs noms génériques (F1, F2, etc.). Si la première ligne de données collées n'est pas similaire aux lignes qui suivent, Access détermine que la première ligne se compose de noms de champs. Access nomme les champs en conséquence et n'inclut pas la première ligne dans les données.

Si Access attribue des noms de champs génériques, vous devez renommer les champs dès que possible afin d'éviter toute confusion. Procédez comme suit :

  1. Appuyez sur CTRL + S pour enregistrer la table.

  2. En mode feuille de données, double-cliquez sur chaque en-tête de colonne, puis tapez un nom de champ descriptif pour chaque colonne.

  3. Enregistrez de nouveau la table.

Remarque : Vous pouvez également renommer les champs en passant en mode création et en modifiant les noms des champs. Pour basculer en mode création, cliquez avec le bouton droit sur la table dans le volet de navigation, puis cliquez sur mode création. Pour revenir en mode feuille de données, double-cliquez sur la table dans le volet de navigation.

Haut de la page

Importer, ajouter ou lier des données d'une autre source

Vous avez peut-être des données qui sont stockées dans un autre programme et vous souhaitez importer ces données dans une nouvelle table ou les ajouter à une table existante dans Access. Ou bien, vous pouvez travailler avec des personnes qui gardent leurs données dans d'autres programmes, et vous voulez travailler dessus dans Access en créant un lien vers celle-ci. Quelle que soit la méthode utilisée, Access facilite l'utilisation de données provenant d'autres sources. Vous pouvez importer des données à partir d'une feuille de calcul Excel, d'une table dans une autre base de données Access, d'une liste SharePoint ou de diverses sources. Le processus que vous utilisez diffère légèrement selon votre source, mais la procédure suivante vous permet de commencer.

  1. Dans Access, sous l'onglet données externes , dans le groupe importer le lien de & , cliquez sur la commande correspondant au type de fichier que vous importez.

    Groupe Importer et lier sous l’onglet Données externes

    Par exemple, si vous importez des données à partir d'une feuille de calcul Excel, cliquez sur Excel. Si vous ne voyez pas le type de programme dont vous avez besoin, cliquez sur plus.

    Remarque : Si vous ne trouvez pas le type de format approprié dans le groupe importer le lien & , vous devrez peut-être démarrer le programme dans lequel vous avez créé les données à l'origine, puis utiliser ce programme pour enregistrer les données dans un format de fichier commun (tel qu'un fichier texte délimité ) avant de pouvoir impor t ces données dans Access.

  2. Dans la boîte de dialogue données externes , cliquez sur Parcourir pour rechercher le fichier de données source, ou tapez le chemin d'accès complet du fichier de données source dans la zone nom de fichier .

  3. Cliquez sur l'option de votre choix (tous les programmes vous permettent d'importer et d'autres options d'ajout ou de liaison) sous Spécifiez le mode et l'emplacement où vous voulez stocker les données dans la base de données active. Vous pouvez créer une nouvelle table qui utilise les données importées ou (avec certains programmes), vous pouvez ajouter les données à une table existante ou créer une table liée qui conserve un lien vers les données du programme source.

  4. Si un Assistant démarre, suivez les instructions dans les pages suivantes de l'Assistant. Sur la dernière page de l’Assistant, cliquez sur Terminer.

    Si vous importez des objets ou des tables à partir d'une base de données Access, vous pouvez utiliser la boîte de dialogue importer des objets ou lier les tables . Sélectionnez les éléments souhaités, puis cliquez sur OK.

    Le processus exact varie selon que vous choisissez d'importer, d'ajouter ou de lier des données.

  5. Access vous invite à indiquer si vous voulez enregistrer les détails de l'opération d'importation que vous venez de terminer. Si vous pensez que vous exécuterez de nouveau cette même opération d'importation à l'avenir, cliquez sur enregistrer les étapes d'importation, puis entrez les détails. Vous pouvez alors facilement répéter l'opération en cliquant sur importations enregistrées image du bouton dans le groupe importer le lien _AMP_ sous l'onglet données externes . Si vous ne voulez pas enregistrer les détails de l'opération, cliquez sur Fermer.

Si vous avez choisi d'importer une table, Access les importe dans une nouvelle table, puis affiche la table sous le groupe tables dans le volet de navigation. Si vous choisissez d'ajouter des données à une table existante, les données sont ajoutées à cette table. Si vous avez choisi de créer un lien vers des données, Access crée une table liée sous le groupe tables dans le volet de navigation.

Haut de la page

Ajouter un composant d'application

Vous pouvez utiliser un composant d'application pour ajouter des fonctionnalités à une base de données existante. Un composant d'application peut être aussi simple qu'une table unique, mais peut être composé de plusieurs objets connexes tels qu'un tableau et un formulaire lié.

Par exemple, le composant application commentaires comporte une table avec un champ ID NuméroAuto, un champ de date et un champ Mémo. Vous pouvez l'ajouter à une base de données et l'utiliser en l'État ou avec une personnalisation minimale.

  1. Ouvrez la base de données à laquelle vous voulez ajouter un composant d'application.

  2. Cliquez sur l'onglet créer .

  3. Dans le groupe modèles , cliquez sur composants d'application. La liste des composants disponibles s'ouvre.

  4. Cliquez sur le composant d'application que vous voulez ajouter.

Haut de la page

Ouvrir une base de données Access existante

  1. Sous l’onglet Fichier, cliquez sur Ouvrir.

  2. Dans la boîte de dialogue ouvrir , accédez à la base de données que vous voulez ouvrir.

  3. Effectuez l’une des actions suivantes :

    • Double-cliquez sur la base de données pour l'ouvrir dans le mode par défaut spécifié dans la boîte de dialogue Options Access ou le mode défini par une stratégie d'administration.

    • Cliquez sur ouvrir pour ouvrir la base de données pour l'accès partagé dans un environnement multi-utilisateur de sorte que vous et les autres utilisateurs puissiez lire et écrire dans la base de données.

    • Cliquez sur la flèche située en regard du bouton ouvrir , puis cliquez sur ouvrir en lecture seule pour ouvrir la base de données pour un accès en lecture seule afin de pouvoir la consulter, mais pas la modifier. Les autres utilisateurs peuvent toujours lire et écrire dans la base de données.

    • Cliquez sur la flèche en regard du bouton ouvrir , puis cliquez sur ouvrir en exclusif pour ouvrir la base de données à l'aide d'un accès exclusif. Lorsque vous ouvrez une base de données avec un accès exclusif, quiconque tente d'ouvrir la base de données reçoit un message «fichier déjà en cours d'utilisation».

    • Cliquez sur la flèche en regard du bouton ouvrir , puis cliquez sur ouvrir en mode lecture seule exclusif pour ouvrir la base de données pour un accès en lecture seule. Les autres utilisateurs peuvent toujours ouvrir la base de données, mais ils sont limités au mode lecture seule.

Remarque : Vous pouvez accéder directement à un fichier de données dans un format de fichier externe, tel que dBASE, Microsoft Exchange ou Excel. Vous pouvez également ouvrir directement n'importe quel source de données ODBC, tel que Microsoft SQL Server. Access crée automatiquement une base de données Access dans le même dossier que le fichier de données, puis ajoute des liens vers chaque table dans la base de données externe.

Conseils

  • Pour ouvrir une des bases de données récemment ouvertes, sous l'onglet fichier , cliquez sur récent, puis cliquez sur le nom de fichier de cette base de données. Access ouvre la base de données à l'aide des mêmes paramètres d'option que lorsque vous l'avez ouverte pour la dernière fois. Si la liste des derniers fichiers utilisés ne s'affiche pas, sous l'onglet fichier , cliquez sur options. Dans la boîte de dialogue Options Access , cliquez sur paramètres du client. Sous affichage, entrez le nombre de documents à afficher dans la liste documents récents, jusqu'à un maximum de 50.

    Vous pouvez également afficher les bases de données récentes dans la barre de navigation du mode Backstage, en double-cliquant sur Access: 1) sous l'onglet fichier , 2) la base de données récente que vous voulez ouvrir. Près du bas de l'onglet actions récentes , activez la case à cocher accéder rapidement à ce nombre de bases de données récentes , puis ajustez le nombre de bases de données à afficher.

  • Si vous ouvrez une base de données en cliquant sur la commande ouvrir sous l'onglet fichier , vous pouvez afficher la liste des raccourcis vers les bases de données que vous avez précédemment ouvertes en cliquant sur Mes documents récents dans la boîte de dialogue ouvrir .

Haut de la page

Vous utilisez Access 2007?

Lorsque vous démarrez Access pour la première fois ou si vous fermez une base de données sans fermer Access, la page mise en route de Microsoft Office Access s'affiche.

Page Prise en main avec Microsoft Office Access

Cette page vous permet de créer une base de données, d'ouvrir une base de données existante ou d'afficher le contenu proposé à partir de Microsoft Office Online.

Access vous propose une large gamme de modèles que vous pouvez utiliser pour accélérer le processus de création d'une base de données. Un modèle est une base de données prête à l'emploi contenant toutes les tables, requêtes, formulaires et rapports nécessaires à l'exécution d'une tâche spécifique. Par exemple, il existe des modèles que vous pouvez utiliser pour effectuer le suivi des problèmes, gérer des contacts ou conserver une trace des dépenses. Certains modèles contiennent quelques exemples d'enregistrements pour vous permettre de montrer leur utilisation. Les bases de données de modèles peuvent être utilisées comme elles, ou vous pouvez les personnaliser en fonction de vos besoins.

Si l'un de ces modèles correspond à vos besoins, il est généralement le moyen le plus rapide de démarrer une base de données. Toutefois, si vous avez des données à importer dans Access à partir d'un autre programme, il est possible que vous souhaitiez créer une base de données sans utiliser de modèle. Les modèles possèdent une structure de données déjà définie; cela peut nécessiter un grand nombre de tâches pour adapter vos données existantes à la structure du modèle.

  1. Si vous avez une base de données ouverte, cliquez sur le bouton Microsoft Office , puis sur Fermer la base de données Image du bouton pour afficher la page mise en route de Microsoft Office Access .

  2. Plusieurs modèles proposés sont affichés au milieu de la page mise en route de Microsoft Office Access et deviennent disponibles lorsque vous cliquez sur les liens du volet catégories de modèles . Vous pouvez télécharger des modèles supplémentaires à partir du site Web Office Online. Pour plus d'informations, rePortez-vous à la section suivante de cet article.

  3. Cliquez sur le modèle que vous voulez utiliser.

  4. Access suggère un nom de fichier pour votre base de données dans la zone nom de fichier , vous pouvez modifier le nom du fichier si vous le souhaitez. Pour enregistrer la base de données dans un autre dossier que celui affiché sous la zone nom de fichier, cliquez sur Image du bouton , recherchez le dossier dans lequel vous voulez l'enregistrer, puis cliquez sur OK. Vous pouvez également créer et lier votre base de données sur un site SharePoint.

  5. Cliquez sur créer (ou Télécharger) pour un modèle Office Online.

    Access crée ou télécharge la base de données, puis l'ouvre. Un formulaire s'affiche pour vous permettre de commencer à entrer des données. Si votre modèle contient des exemples de données, vous pouvez supprimer chaque enregistrement en cliquant sur le sélecteur d'enregistrement (zone ou barre ombrée), puis en procédant comme suit:

    Dans l’onglet Accueil, dans le groupe Enregistrements, cliquez sur Supprimer. Button image

  6. Pour commencer à entrer des données, cliquez sur la première cellule vide du formulaire et commencez à taper. Utilisez le volet de navigation pour rechercher d'autres formulaires ou rapports que vous pouvez utiliser.

Si vous ne trouvez pas de modèle qui correspond à vos besoins dans la page mise en route de Microsoft Office Access et que vous êtes connecté à Internet, vous pouvez découvrir le site Web Office Online pour une sélection plus large.

  1. Sur la page mise en route de Microsoft Office Access , sous plus d'informations sur Office Online, cliquez sur modèles.

    La page d'accueil modèles sur Office Online s'affiche dans la fenêtre de votre navigateur.

  2. Utilisez les outils de navigation et de recherche Office Online pour trouver le modèle Access que vous souhaitez utiliser, puis suivez les instructions pour le télécharger. Lorsque vous téléchargez un modèle, un fichier de base de données est téléchargé sur votre ordinateur et ouvert dans une nouvelle instance d'Access. Dans la plupart des cas, le modèle est conçu pour ouvrir un formulaire de saisie de données afin que vous puissiez commencer à entrer des données immédiatement.

Pour plus d'informations sur l'utilisation des modèles, voir l'article utiliser un modèle pour créer une base de données de bureau Access.

Haut de la page

Si vous n'êtes pas intéressé par l'utilisation d'un modèle, vous pouvez créer une base de données en créant vos propres tables, formulaires, États et autres objets de base de données. Dans la plupart des cas, cela implique généralement l'un des éléments suivants:

  • Saisie, collage ou importation de données dans la table créée lors de la création d'une base de données, puis répétition du processus avec de nouvelles tables créées à l'aide de la commande table sous l'onglet créer .

  • Importation de données provenant d'autres sources et création de nouvelles tables dans le processus.

  1. Dans la page mise en route de Microsoft Office Access , sous nouvelle base de données vide, cliquez sur base de données vide.

    Bouton Base de données vide

  2. Dans le volet base de données vide , tapez un nom de fichier dans la zone nom de fichier . Si vous ne fournissez pas d'extension de nom de fichier, Access l'ajoute pour vous. Pour modifier l'emplacement du fichier par défaut, cliquez sur Rechercher un emplacement pour le Image du bouton de votre base de données(en regard de la zone nom de fichier ), accédez au nouvel emplacement, puis cliquez sur OK.

  3. Cliquez sur Créer.

    Access crée la base de données à l'aide d'une table vide nommée Table1, puis ouvre la table1 en mode feuille de données. Le curseur est placé dans la première cellule vide de la colonne Ajouter un nouveau champ .

  4. Commencez à taper pour ajouter des données ou vous pouvez coller des données d'une autre source, comme décrit dans la section copier des données d'une autre source dans une table Access.

La saisie d'informations en mode feuille de données est conçue pour être très similaire à l'utilisation d'une feuille de calcul Microsoft Office Excel 2007. La structure de tableau est créée lorsque vous entrez des données (chaque fois que vous ajoutez une nouvelle colonne à la table, un nouveau champ est défini. Access définit automatiquement le type de données de chaque champ, en fonction des données que vous entrez.

Si vous ne souhaitez pas entrer les informations dans la table1 pour le moment, cliquez sur Fermerles Button image . Si vous avez apporté des modifications à la table, Access vous invite à enregistrer les modifications apportées à la table. Cliquez sur Oui pour enregistrer vos modifications, cliquez sur non pour les ignorer ou cliquez sur Annuler pour laisser la table ouverte.

Important : Si vous fermez la table table1 sans l'enregistrer au moins une fois, Access l'efface, même si vous y avez entré des données.

Vous pouvez ajouter des tables à une base de données existante en utilisant les commandes du groupe tables sous l'onglet créer .

Image du ruban Access

Créer une table à partir du mode feuille de données    En mode feuille de données, vous pouvez entrer des données immédiatement et laisser Access créer une structure de tableau en coulisses. Les noms de champs sont attribués numériquement (champ1, champ2, etc.) et Access définit automatiquement le type de données de chaque champ, en fonction des données que vous entrez.

  1. Sous l’onglet Création, dans le groupe Tables, cliquez sur Table. Button image

    Access crée le tableau et sélectionne la première cellule vide de la colonne Ajouter un nouveau champ .

    Remarque : Si vous ne voyez pas la colonne Ajouter un nouveau champ , il est possible que vous soyez en mode création au lieu du mode feuille de données. Pour basculer en mode feuille de données, double-cliquez sur la table dans le volet de navigation. Access vous invite à enregistrer la nouvelle table, puis bascule en mode feuille de données.

  2. Sous l’onglet Feuille de données, dans le groupe Champs et colonnes, cliquez sur Nouveau champ. Image du bouton

    Access affiche le volet modèles de champs qui contient une liste des types de champs fréquemment utilisés. Si vous double-cliquez ou faites glisser l'un de ces champs dans votre feuille de données, Access ajoute un champ en fonction de ce nom et définit ses propriétés sur les valeurs appropriées pour ce type de champ. Si vous le souhaitez, vous pouvez modifier les propriétés ultérieurement. Si vous faites glisser le champ, vous devez le faire glisser sur une zone de la feuille de données qui contient des données. Une barre d'insertion verticale apparaît pour vous montrer où le champ sera placé.

  3. Pour ajouter des données, commencez à taper dans la première cellule vide ou collez des données à partir d'une autre source, comme décrit dans la section copier des données d'une autre source dans une table Access.

  4. Pour renommer une colonne (champ), double-cliquez sur l'en-tête de colonne, puis tapez le nouveau nom.

    Il est recommandé de donner un nom significatif à chaque champ, afin que vous puissiez en savoir plus sur ce qu'il contient lorsque vous le voyez dans le volet liste de champs .

  5. Pour déplacer une colonne, cliquez sur son titre pour la sélectionner, puis faites-la glisser vers l'emplacement souhaité.

    Vous pouvez également sélectionner plusieurs colonnes contiguës, puis les faire glisser vers un nouvel emplacement en une seule fois. Pour sélectionner plusieurs colonnes contiguës, cliquez sur l'en-tête de la première colonne, puis, tout en maintenant la touche Maj enfoncée, cliquez sur l'en-tête de la dernière colonne.

Créer une table à partir du mode création    En mode création, vous commencez par créer la structure de la nouvelle table. Vous pouvez ensuite basculer en mode feuille de données pour entrer des données ou entrer des données en utilisant une autre méthode (collage ou importation, par exemple).

  1. Dans l'onglet création , dans le groupe tableaux , cliquez sur création de table. Image du bouton

  2. Pour chaque champ de la table, entrez un nom dans la colonne nom du champ , puis sélectionnez un type de données dans la liste type de données .

    Remarque : Si vous ne voyez pas les colonnes nom de champ et type de données, il est possible que vous soyez en mode feuille de données au lieu du mode création. Pour basculer en mode création, cliquez avec le bouton droit sur la table dans le volet de navigation, puis cliquez sur mode création Button image . Access vous invite à entrer un nom pour la nouvelle table, puis bascule en mode création.

  3. Si vous le souhaitez, vous pouvez taper une description pour chaque champ dans la colonne Description . La description s'affiche dans la barre d'État lorsque le curseur se trouve dans le champ en mode feuille de données. La description est également utilisée en tant que texte de la barre d'État pour les contrôles d'un formulaire ou d'un État que vous créez en faisant glisser le champ du volet liste de champs et pour les contrôles créés pour ce champ lorsque vous utilisez l'Assistant formulaire ou l'Assistant État.

  4. Après avoir ajouté tous vos champs, enregistrez la table:

    • Cliquez sur le bouton Microsoft Office, puis sur Enregistrer, ou appuyez sur CTRL + S Button image .

  5. Vous pouvez commencer à entrer des données dans le tableau à tout moment en passant en mode feuille de données et en cliquant sur la première cellule vide. Vous pouvez également coller les données à partir d'une autre source, comme décrit dans la section copier des données d'une autre source dans une table Access.

Créer un tableau à l'aide d'un modèle    Access fournit des modèles pour les types de tableaux fréquemment utilisés. En un seul clic de la souris, vous pouvez créer une structure de tableau complète avec les champs déjà configurés et prêts à l'emploi. Le cas échéant, vous pouvez ensuite ajouter ou supprimer des champs afin que le tableau réponde à vos besoins.

  1. Dans l'onglet création , dans le groupe tables , cliquez sur modèles de table , puis sélectionnez l'un des modèles disponibles dans la liste.

  2. Pour ajouter des données, commencez à taper dans la première cellule vide ou coller des données à partir d'une autre source, comme décrit dans la section copier des données d'une autre source dans une table Access.

    • Pour supprimer une colonne    

      1. Cliquez avec le bouton droit sur l'en-tête de colonne, puis cliquez sur Supprimer la colonne Image du bouton .

    • Pour ajouter une nouvelle colonne    

      1. Sous l’onglet Feuille de données, dans le groupe Champs et colonnes, cliquez sur Nouveau champ. Image du bouton

      2. Access affiche le volet modèles de champs qui contient une liste des types de champs fréquemment utilisés. Si vous double-cliquez ou faites glisser l'un de ces champs dans votre feuille de données, Access ajoute un champ en fonction de ce nom et définit ses propriétés sur les valeurs appropriées pour ce type de champ. Si vous le souhaitez, vous pouvez modifier les propriétés ultérieurement. Si vous faites glisser le champ, vous devez le faire glisser sur une zone de la feuille de données qui contient des données. Une barre d'insertion verticale apparaît pour vous montrer où le champ sera placé.

  3. Enregistrez la table:

    • Cliquez sur le bouton Microsoft Office, puis sur Enregistrer, ou appuyez sur CTRL + S Button image .

Définir des propriétés de champ en mode Création    Quelle que soit la méthode que vous avez créée, il peut s'avérer utile d'examiner et de définir les propriétés des champs. Cette opération peut être réalisée uniquement en mode création. Pour basculer en mode création, cliquez avec le bouton droit sur la table dans le volet de navigation, puis cliquez sur mode création. Pour afficher les propriétés d'un champ, cliquez sur le champ dans la grille de création. Celles-ci s'affichent sous la grille de création, sous Propriétés du champ.

Pour afficher une description de chaque propriété de champ, cliquez sur la propriété et lisez la description dans la zone située en regard de la liste de propriétés sous Propriétés du champ. Vous pouvez obtenir des informations plus détaillées en appuyant sur F1.

Le tableau suivant décrit certaines des propriétés de champ généralement ajustées.

Propriété

Description

Taille du champ

Pour les champs de texte, cette propriété définit le nombre maximal de caractères pouvant être stockés dans le champ. La valeur maximale est 255. Pour les champs numériques, cette propriété définit le type de numéro qui sera stocké (entier long, double, etc.). Pour optimiser le stockage des données, il est recommandé d'allouer le plus petit nombre d'espace dont vous pensez avoir besoin pour les données. Vous pouvez ajuster la valeur par la suite, si vos besoins évoluent.

Mise en forme

Cette propriété définit le mode d'affichage des données. Il n'affecte pas les données réelles qui sont stockées dans le champ. Vous pouvez sélectionner un format prédéfini ou entrer un format personnalisé.

Masque de saisie

Utilisez cette propriété pour spécifier un modèle pour toutes les données qui seront entrées dans ce champ. Cela permet de s'assurer que toutes les données sont entrées correctement et qu'elles contiennent le nombre de caractères requis. Pour obtenir de l'aide sur la création d'un masque de saisie, cliquez Bouton Générateur sur le côté droit de la zone de propriété.

Valeur par défaut

Utilisez cette propriété pour spécifier la valeur par défaut qui s'affichera dans ce champ chaque fois qu'un nouvel enregistrement est ajouté. Par exemple, si vous avez un champ date/heure dans lequel vous voulez toujours enregistrer la date à laquelle l'enregistrement a été ajouté, vous pouvez entrer «Date ()» (sans guillemets) comme valeur par défaut.

Obligatoire

Cette propriété détermine si une valeur est requise dans ce champ. Si vous définissez cette propriété sur Oui, Access ne vous autorise pas à ajouter un nouvel enregistrement, sauf si une valeur est entrée pour ce champ.

Haut de la page

Si vos données sont actuellement stockées dans un autre programme (par exemple, Office Excel 2007 ), vous pouvez les copier et les coller dans une table Access. En règle générale, cela est préférable si vos données sont déjà séparées en colonnes, comme dans une feuille de calcul Excel. Si vos données se trouvent dans un programme de traitement de texte, il est préférable de séparer les colonnes de données à l'aide d'onglets ou de convertir les données en tableau dans le programme de traitement de texte avant de copier les données. Si vos données nécessitent une modification ou une manipulation (par exemple, en séparant les noms complets en prénoms et les noms), vous pouvez le faire avant de copier les données, en particulier si vous n'êtes pas familiarisé avec Access.

Lorsque vous collez des données dans une table vide, Access définit le type de données de chaque champ en fonction du type de données qu'il recherche. Par exemple, si un champ collé ne contient aucune valeur de date, Access applique le type de données date/heure au champ. Si le champ collé contient uniquement les mots «Oui» et «non», Access applique le type de données oui/non au champ.

Access nomme les champs en fonction du contenu de la première ligne de données collées. Si la première ligne de données collées est semblable au type des lignes qui suivent, Access détermine que la première ligne fait partie des données et affecte les champs noms génériques (F1, F2, etc.). Si la première ligne de données collées n'est pas similaire aux lignes qui suivent, Access détermine que la première ligne se compose de noms de champs. Access nomme les champs en conséquence et n'inclut pas la première ligne dans les données.

Si Access attribue des noms de champs génériques, vous devez renommer les champs dès que possible afin d'éviter toute confusion. Procédez comme suit :

  1. Enregistrez la table.

    • Cliquez sur le bouton Microsoft Office, puis sur Enregistrer, ou appuyez sur CTRL + S Button image .

  2. En mode feuille de données, double-cliquez sur chaque en-tête de colonne, puis tapez un nom de champ valide pour chaque colonne. Il est possible que vous deviez écrire sur des données, mais que la ligne d'en-tête de colonne ne contient pas de noms de champs, pas de données.

  3. Enregistrez de nouveau la table.

Remarque : Vous pouvez également renommer les champs en passant en mode création et en modifiant les noms des champs. Pour basculer en mode création, cliquez avec le bouton droit sur la table dans le volet de navigation, puis cliquez sur mode création. Pour revenir en mode feuille de données, double-cliquez sur la table dans le volet de navigation.

Haut de la page

Vous avez peut-être des données qui sont stockées dans un autre programme et vous aimeriez importer ces données dans une nouvelle table ou les ajouter à une table existante dans Access. Ou bien, vous pouvez travailler avec des personnes qui gardent leurs données dans d'autres programmes, et vous voulez travailler dessus dans Access en créant un lien vers celle-ci. Quelle que soit la méthode utilisée, Access facilite l'utilisation de données provenant d'autres sources. Vous pouvez importer des données à partir d'une feuille de calcul Excel, d'une table dans une autre base de données Access, d'une liste SharePoint ou de diverses sources. Le processus que vous utilisez diffère légèrement selon votre source, mais la procédure suivante vous permet de commencer.

  1. Dans Access, sous l'onglet données externes , dans le groupe Importer , cliquez sur la commande correspondant au type de fichier que vous importez.

    Image du ruban Access

    Par exemple, si vous importez des données à partir d'une feuille de calcul Excel, cliquez sur Excel. Si vous ne voyez pas le type de programme dont vous avez besoin, cliquez sur plus.

    Remarque : Si vous ne trouvez pas le type de format approprié dans le groupe Importer , vous devrez peut-être démarrer le programme dans lequel vous avez créé les données, puis utiliser ce programme pour enregistrer les données dans un format de fichier commun (par exemple, fichier texte délimité ) avant de pouvoir importer ces données. dans Access.

  2. Dans la boîte de dialogue données externes , cliquez sur Parcourir pour rechercher le fichier de données source, ou tapez le chemin d'accès complet du fichier de données source dans la zone nom de fichier .

  3. Cliquez sur l'option de votre choix (tous les programmes vous permettent d'importer, et certains vous permettent d'ajouter ou de lier) sous Spécifiez le mode et l'emplacement où vous voulez stocker les données dans la base de données active. Vous pouvez créer une nouvelle table qui utilise les données importées ou (avec certains programmes), vous pouvez ajouter les données à une table existante ou créer une table liée qui conserve un lien vers les données du programme source.

  4. Si un Assistant démarre, suivez les instructions dans les pages suivantes de l'Assistant. Sur la dernière page de l’Assistant, cliquez sur Terminer.

    Si vous importez des objets ou des tables à partir d'une base de données Access, vous pouvez utiliser la boîte de dialogue importer des objets ou lier les tables . Sélectionnez les éléments souhaités, puis cliquez sur OK.

    Le processus exact varie selon que vous choisissez d'importer, d'ajouter ou de lier des données.

  5. Access vous invite à indiquer si vous voulez enregistrer les détails de l'opération d'importation que vous venez de terminer. Si vous pensez que vous exécuterez de nouveau cette même opération d'importation à l'avenir, cliquez sur enregistrer les étapes d'importation, puis entrez les détails. Vous pouvez alors facilement répéter l'opération ultérieurement en cliquant sur importations enregistrées image du bouton dans le groupe Importer sous l'onglet données externes . Si vous ne voulez pas enregistrer les détails de l'opération, cliquez sur Fermer.

Si vous avez choisi d'importer une table, Access les importe dans une nouvelle table, puis affiche la table sous le groupe tables dans le volet de navigation. Si vous choisissez d'ajouter des données à une table existante, les données sont ajoutées à cette table. Si vous avez choisi de créer un lien vers des données, Access crée une table liée sous le groupe tables dans le volet de navigation.

Haut de la page

  1. Cliquez sur le bouton Microsoft Office, puis sur Ouvrir.

  2. Dans la boîte de dialogue ouvrir , accédez à la base de données que vous voulez ouvrir.

  3. Effectuez l’une des actions suivantes :

    • Double-cliquez sur la base de données pour l'ouvrir dans le mode par défaut spécifié dans la boîte de dialogue Options Access ou le mode défini par une stratégie d'administration.

    • Cliquez sur ouvrir pour ouvrir la base de données pour l'accès partagé dans un environnement multi-utilisateur de sorte que vous et les autres utilisateurs puissiez lire et écrire dans la base de données.

    • Cliquez sur la flèche située en regard du bouton ouvrir , puis cliquez sur ouvrir en lecture seule pour ouvrir la base de données pour un accès en lecture seule afin de pouvoir la consulter, mais pas la modifier. Les autres utilisateurs peuvent toujours lire et écrire dans la base de données.

    • Cliquez sur la flèche en regard du bouton ouvrir , puis cliquez sur ouvrir en exclusif pour ouvrir la base de données avec accès exclusif. Lorsque vous ouvrez une base de données avec un accès exclusif, quiconque tente d'ouvrir la base de données reçoit un message «fichier déjà en cours d'utilisation».

    • Cliquez sur la flèche en regard du bouton ouvrir , puis cliquez sur ouvrir en mode lecture seule exclusif pour ouvrir la base de données pour un accès en lecture seule. Les autres utilisateurs peuvent toujours ouvrir la base de données, mais ils sont limités au mode lecture seule.

Si vous ne trouvez pas la base de données que vous voulez ouvrir    

  1. Dans la boîte de dialogue ouvrir , cliquez sur mon ordinateur ou cliquez sur mon ordinateur dans la liste déroulante chercher dans .

  2. Dans la liste des lecteurs, cliquez avec le bouton droit sur le lecteur qui pourrait contenir la base de données, puis cliquez sur Rechercher.

  3. Entrez vos critères de recherche dans la boîte de dialogue résultats de la recherche , puis cliquez sur Rechercher pour rechercher la base de données.

  4. Si vous trouvez la base de données, double-cliquez dessus pour l'ouvrir.

  5. Vous devez cliquer sur Annuler dans la boîte de dialogue ouvrir pour ouvrir la base de données. Fermez ensuite la boîte de dialogue résultats de la recherche .

Remarque : Vous pouvez accéder directement à un fichier de données dans un format de fichier externe, tel que dBASE, Paradox, Microsoft Exchange ou Excel. Vous pouvez également ouvrir directement n'importe quel source de données ODBC, tel que Microsoft SQL Server ou Microsoft FoxPro. Access crée automatiquement une base de données Access dans le même dossier que le fichier de données, puis ajoute des liens vers chaque table dans la base de données externe.

  • Pour ouvrir l'une des bases de données récemment ouvertes, cliquez sur le nom de fichier de cette base de données dans la liste ouvrir une base de données récente de la page mise en route de Microsoft Office Access . Access ouvre la base de données avec les mêmes paramètres d'option qu'au dernier moment où vous l'avez ouverte. Si la liste des derniers fichiers utilisés n'est pas affichée, cliquez sur le bouton Microsoft Office , puis sur Options Access. Dans la boîte de dialogue Options Access , cliquez sur avancé. Sous affichage, entrez le nombre de documents à afficher dans la liste documents récents de plus de neuf.

  • Si vous ouvrez une base de données en cliquant sur le bouton Microsoft Office , puis en utilisant la commande ouvrir , vous pouvez afficher la liste des raccourcis vers les bases de données que vous avez précédemment ouvertes en cliquant sur Mes documents récents dans le menu ouvrir . boîte de dialogue.

Haut de la page

Lorsque vous créez une base de données vide, Access ouvre une nouvelle table dans laquelle vous pouvez entrer des données, mais elle ne crée aucun autre objet dans la base de données. Si vous souhaitez ajouter d'autres objets, tels que des formulaires, des États, des macros ou des tableaux supplémentaires, dans toutes les nouvelles bases de données que vous créez, vous pouvez créer un modèle vierge personnalisé qui contient ces objets. La prochaine fois que vous créerez une nouvelle base de données, celle-ci contient déjà ces objets dans votre modèle. En plus de ces objets, le modèle peut inclure les tables préremplies, ainsi que les paramètres de configuration spéciaux, les propriétés de la base de données, les références ou le code que vous voulez inclure dans toutes les nouvelles bases de données.

Par exemple, supposons que vous ayez une collection de macros que vous souhaitez utiliser dans tous vos projets. Si vous créez un modèle vierge contenant ces macros, Access les inclut dans les nouvelles bases de données que vous créez.

Vous pouvez créer des modèles vides au format de fichier Office Access 2007, au format de fichier Access 2002-2003 ou au format de fichier Access 2000. Le modèle doit avoir pour nom Blank. accdb pour le format de fichier Office Access 2007 et Blank. mdb pour les formats de fichier antérieurs.

  • Si le format de fichier par défaut est défini sur Access 2000 ou Access 2002-2003, Access utilise Blank. mdb comme nom de fichier de modèle vide. La nouvelle base de données est créée au format de fichier Blank. mdb. Par exemple, même si le format de fichier par défaut est Access 2000, si le modèle appelé Blank. mdb est au format de fichier Access 2002-2003, toutes les nouvelles bases de données créées seront au format Access 2002-2003.

  • Si votre format de fichier par défaut est défini sur Access 2007, Access utilise Blank. accdb en tant que nom de fichier pour le modèle vide.

Comment changer le format de fichier par défaut?

  1. Cliquez sur le bouton Microsoft Office, puis cliquez sur Options Access.

  2. Dans la boîte de dialogue Options Access , cliquez sur populaires.

  3. Sous création de bases de données, sélectionnez le format souhaité dans la liste déroulante format de fichier par défaut .

Pour créer un modèle vierge, effectuez l'une des opérations suivantes:

  • Créez une base de données (donnez-lui un nom vide ou attribuez-lui un nom temporaire), puis importez ou créez les objets que vous voulez inclure dans le modèle.

  • Faites une copie d'une base de données existante qui contient déjà les objets souhaités dans le modèle, puis supprimez les objets indésirables.

Une fois que vous avez les objets souhaités dans le modèle, vous devez l'enregistrer dans un emplacement spécifique.

  1. Cliquez sur le bouton Microsoft Office, puis pointez sur Enregistrer sous.

  2. Sous enregistrer la base de données dans un autre format, cliquez sur le format de fichier que vous voulez utiliser pour le modèle.

  3. Dans la boîte de dialogue Enregistrer sous , accédez à l'un des deux dossiers de modèles suivants:

    • Dossier de modèle système    Par exemple, C:\Program Files\Microsoft Office\Templates\1033\Access

    • Dossier de modèle utilisateur    Par exemple :

      • Dans Windows Vista    C:\Utilisateurs\nom name\AppData\Roaming\Microsoft\Templates

      • Dans Microsoft Windows Server 2003 ou Microsoft Windows XP    C:\Documents and Settings\nom d'Utilisateur\application Data\Microsoft\Templates

        Remarque : Un modèle vide dans le dossier de modèle système remplace les modèles vides dans les dossiers de modèles utilisateur.

  4. Dans la zone nom de fichier , tapez Blank. accdb (ou Blank. mdb, si vous créez un modèle de version antérieure), puis cliquez sur Enregistrer.

À présent que le nouveau modèle est en place, lorsque vous créez une base de données vide, les objets dans le modèle sont inclus dans n'importe quelle nouvelle base de données créée par défaut. Access ouvre une nouvelle table en mode feuille de données, de la même façon que lorsque vous créez des bases de données vides sans utiliser de modèle.

Pour arrêter d'utiliser le modèle vide, supprimez le fichier intitulé Blank. accdb (ou Blank. mdb, pour les versions antérieures d'Access), ou renommez-le.

Haut de la page

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×