Créer un modèle de base de données (également appelé diagramme Entité-relation)

Créer un modèle de base de données (également appelé diagramme Entité-relation)

Avec le modèle Diagramme de modèle de base de données, vous pouvez créer un nouveau modèle ou rétroconcevoir une base de données existante pour la modéliser en utilisant les concepts de modélisation relationnelle ou relationnelle objet. Utilisez le gabarit Entité-relation pour modéliser les bases de données basées sur les normes SQL92 et antérieures. Utilisez le gabarit Relationnel objet, qui contient des formes supplémentaires pour l’utilisation de types, afin de modéliser les bases de données basées sur les normes SQL99 et ultérieures.

Exemple de modèle de base de données

Remarque : Si vous utilisez Visio Pro pour Office 365 et souhaitez en savoir plus sur la conception d’une base de données existante dans un modèle de base de données, consultez la rubrique Rétroconcevoir une base de données existante.

Avec le modèle Diagramme de modèle de base de données, vous pouvez créer un nouveau modèle ou rétroconcevoir une base de données existante pour la modéliser en utilisant les concepts de modélisation relationnelle ou relationnelle objet. Utilisez le gabarit Entité-relation pour modéliser les bases de données basées sur les normes SQL92 et antérieures. Utilisez le gabarit Relationnel objet, qui contient des formes supplémentaires pour l’utilisation de types, afin de modéliser les bases de données basées sur les normes SQL99 et ultérieures.

Cet article explique comment créer et utiliser un modèle de base de données.

Vous ne trouvez pas les fonctionnalités de modèle de base de données ?

Certaines éditions de Microsoft Visio ne disposent pas de la fonctionnalité de modèle de base de données. Si vous ne trouvez pas les fonctionnalités décrites dans les procédures de cet article, vous disposez probablement d’une édition de Visio dans laquelle elles ne sont pas disponibles.

  • Microsoft Visio Standard n’inclut pas le modèle Diagramme de modèle de base de données.

  • Les éditions Microsoft Visio Professionnel et Premium prennent en charge les fonctionnalités de rétroconception du modèle Diagramme de modèle de base de données (à savoir l’utilisation d’une base de données existante pour créer un modèle dans Visio), mais pas l'ingénierie en amont (à savoir l’utilisation d’un modèle de base de données Visio pour générer du code SQL). Pour plus d’informations, consultez la rubrique, Rétroconcevoir une base de données existante.

  1. Pour entamer votre diagramme de modèle de base de données, effectuez l’une des opérations suivantes :

    Créer un diagramme de modèle de toutes pièces

    Si vous ne disposez d’aucune base de données que vous souhaitez utiliser comme point de départ, vous pouvez commencer avec un modèle de base de données vierge et ajouter vos propres tables et relations.

    1. Cliquez sur l’onglet Fichier.

    2. Cliquez sur Nouveau, sur Logiciel et base de données, puis double-cliquez sur Diagramme de modèle de base de données.

    3. Sous l’onglet Base de données, accédez au groupe Gérer et cliquez sur Options d’affichage.

    4. Dans la boîte de dialogue Options du document de base de données, sélectionnez le jeu de symboles que vous souhaitez utiliser ainsi que les autres options de tables et de relations, puis cliquez sur OK.

    Utiliser une base de données existante comme point de départ

    Si vous disposez d’une base de données que vous souhaitez modéliser afin de mieux la comprendre ou de l’utiliser comme de point de départ d’un nouveau modèle, vous pouvez utiliser l’Assistant Rétroconcevoir pour extraire le schéma ou la structure de la base de données et créer un nouveau modèle.

    Avant de lancer l’Assistant :

    1. Si vous procédez à la rétroconception d’un classeur Microsoft Excel, avant de lancer l’Assistant, vous devez ouvrir le classeur et nommer le groupe (ou la plage) de cellules qui contient les en-têtes de colonne. Si vous souhaitez utiliser plusieurs feuilles de calcul, il vous suffit de nommer le groupe de cellules des colonnes dans chaque feuille de calcul. Ces plages sont traitées comme des tables dans l’Assistant. Pour savoir comment nommer une plage de cellules, reportez-vous à la rubrique Définir des plages ou références de cellules nommées dans l’aide d’Excel.

    2. Pour des résultats optimaux, définissez votre pilote par défaut sur la base de données cible que vous souhaitez rétroconcevoir avant d’exécuter l’Assistant Rétroconcevoir. Cette étape permet de veiller à ce que l’Assistant mappe correctement les types de données natifs et que tout le code extrait par l’Assistant s’affiche correctement dans la fenêtre Code.

    3. Cliquez sur l’onglet Fichier.

    4. Cliquez sur Nouveau, sur Logiciel et base de données, puis double-cliquez sur Diagramme de modèle de base de données.

    5. Sous l’onglet Base de données, accédez au groupe Modèle, puis cliquez sur Rétroconcevoir.

    6. Sur le premier écran de l’Assistant Rétroconcevoir, effectuez les opérations suivantes :

      1. Sélectionnez le pilote de base de données de votre système de gestion de base de données (SGBD). Si vous n’avez pas encore associé le pilote de base de données Visio à une source de données ODBC particulière, cliquez sur Configuration.

        Remarque : Si vous procédez à la rétroconception d’une feuille de calcul Excel, sélectionnez le pilote ODBC générique.

      2. Sélectionnez la source de données de la base de données que vous mettez à jour. Si vous n’avez pas encore créé de source de données pour la base de données existante, faites-le en cliquant sur Nouveau.

        Lorsque vous créez une nouvelle source, son nom est ajouté à la liste Sources de données.

      3. Lorsque les paramètres vous conviennent, cliquez sur Suivant.

    7. Suivez les instructions des boîtes de dialogue spécifiques au pilote.

      Par exemple, dans la boîte de dialogue Connecter la source de données, entrez le nom d’utilisateur et le mot de passe, puis cliquez sur OK.

      Remarque : Si vous utilisez le pilote ODBC générique, vous pouvez recevoir un message d’erreur indiquant que les informations de rétroconception sont incomplètes. Dans la plupart des cas, ce n’est pas un problème. Cliquez simplement sur OK et suivez l’Assistant.

    8. Cochez les cases correspondant au type d’informations que vous souhaitez extraire, puis cliquez sur Suivant.

      Remarque : Il se peut que des éléments soient indisponibles (grisés) car certains systèmes de gestion de base de données ne prennent pas en charge l’intégralité des éléments extraits par l’Assistant.

    9. Cochez les cases correspondant aux tables (et vues, le cas échéant) que vous souhaitez extraire, ou cliquez sur Sélectionner tout pour toutes les extraire, puis cliquez sur Suivant.

      Remarque : Si vous procédez à la rétroconception d’une feuille de calcul Excel et que vous ne voyez rien dans cette liste, il peut être nécessaire de nommer la plage de cellules qui contient les en-têtes de colonne de votre feuille de calcul.

    10. Si vous avez coché la case Procédures stockées, sélectionnez les procédures que vous souhaitez extraire, ou cliquez sur Sélectionner tout pour toutes les extraire, puis cliquez sur Suivant.

    11. Indiquez si vous souhaitez que les éléments rétroconçus soient automatiquement ajoutés à la page active.

      Remarque : Vous pouvez choisir de laisser l’Assistant créer automatiquement le dessin, en plus de la liste des éléments rétroconçus, dans la fenêtre Tables et vues. Si vous décidez de ne pas laisser l’Assistant créer automatiquement le dessin, vous pouvez faire glisser les éléments de la fenêtre Tables et vues vers votre page de dessin pour assembler manuellement le modèle de base de données.

    12. Passez en revue vos sélections pour vérifier que les informations à extraire sont correctes, puis cliquez sur Terminer.

      L’Assistant extrait les informations sélectionnées et affiche les commentaires relatifs au processus d’extraction dans la fenêtre Sortie.

    Importer et affiner un modèle existant

    Si vous disposez d’un modèle VisioModeler ou PLATINUM ERwin existant, vous pourrez peut-être l’importer pour créer un diagramme de modèle de base de données Visio. Cette fonctionnalité est réservée aux fichiers des modèles de dictionnaire VisioModeler 2.0 ou version ultérieure (.imd) et aux fichiers PLATINUM ERwin 2.6, 3.0 et 3.52 (.erx).

    1. Cliquez sur l’onglet Fichier.

    2. Cliquez sur Nouveau, sur Logiciel et base de données, puis double-cliquez sur Diagramme de modèle de base de données.

    3. Sous l’onglet Base de données, accédez au groupe Modèle, cliquez sur Importer, puis cliquez sur le type de modèle.

    4. Entrez le chemin et le nom de fichier du modèle que vous souhaitez importer, ou cliquez sur le bouton Parcourir pour rechercher le modèle, puis cliquez sur Ouvrir.

    5. Dans la boîte de dialogue Importer, cliquez sur OK.

      Visio importe le fichier et affiche la progression de l’importation dans la fenêtre Sortie. Les tables importées sont affichées dans la fenêtre Tables et vues.

    6. Dans la fenêtre Tables et vues, sélectionnez les tables que vous souhaitez modéliser, puis faites-les glisser vers la page de dessin.

  2. Une fois le diagramme de modèle de base de données créé, le travail d’affinage du diagramme commence. Vous pouvez ajouter et personnaliser des tables et des vues, créer des relations, et personnaliser des colonnes et des types de données.

    Tables

    Utilisez la forme Entité pour créer une table dans votre diagramme.

    1. À partir du gabarit Entité-relation ou Relationnel objet, faites glisser une forme Entité vers le dessin.

    2. Double-cliquez sur la forme pour ouvrir la fenêtre Propriétés de la base de données.

    3. Sous Catégories, cliquez sur Définition et entrez un nom pour la table.

    4. Sous Catégories, cliquez sur Colonnes, entrez un nom, puis sélectionnez un type de données.

    5. Cochez la case Null interdit pour les colonnes qui ne peuvent pas comporter de valeurs nulles.

    6. Cochez la case PK (clé primaire) pour les colonnes qui identifient de manière unique chaque ligne de la table de base de données.

    7. Sous Catégories, cliquez sur Index, Déclencheurs, Coche ou Étendu pour créer ces éléments facultatifs.

    Colonnes

    Utilisez la fenêtre Propriétés de la base de données pour ajouter ou modifier les propriétés des colonnes, y compris les types de données et les clés primaires.

    1. Double-cliquez sur la table dans votre diagramme.

    2. Dans la fenêtre Propriétés de la base de données, sous Catégories, cliquez sur Colonnes.

    3. Cliquez dans la première cellule Nom physique vide, puis entrez un nom.

    4. Pour modifier le type de données d’une colonne, cliquez sur le champ Type de données de la colonne, puis sélectionnez un type de données dans la liste ou entrez-le dans la liste. Par exemple, vous pouvez entrer décimal(8,2) ou car(30).

    5. Pour éviter les valeurs nulles, cochez la case Null interdit.

    6. Pour spécifier que la colonne est une clé primaire, cochez la case PK.

    7. Pour afficher d’autres propriétés de colonne en plus de celles qui s’affichent lorsque vous cliquez sur la catégorie Colonnes, sélectionnez la colonne, puis cliquez sur Modifier.

    Relations

    Les relations utilisent des clés primaires et étrangères pour permettre aux bases de données de faire correspondre une ligne située dans une table avec une ligne située dans une table liée. Vous pouvez afficher ces relations dans votre diagramme. En outre, vous pouvez définir leur cardinalité (par exemple, un-à-plusieurs) et utiliser la notation Crow's Foot, relationnelle ou IDEF1X pour afficher la cardinalité. Vous ne pouvez afficher des relations plusieurs-à-plusieurs avec aucune de ces notations dans le modèle Diagramme de modèle de base de données.

    1. Créer une relation entre des tables :

      1. Assurez-vous que les deux tables sont visibles dans le diagramme. Si vous avez procédé à la rétroconception du modèle à partir d’une base de données existante, vous devrez peut-être faire glisser une table, voire les deux, de la fenêtre Tables et vues vers la page de dessin.

      2. Double-cliquez sur la table que vous souhaitez placer côté clé primaire de la relation.

      3. Dans la fenêtre Propriétés de la base de données, sous Catégories, cliquez sur Colonnes.

      4. Dans la grille, cliquez sur la colonne que vous souhaitez utiliser pour identifier de manière unique chaque ligne de la table, puis cochez la case PK pour la définir en tant que clé primaire.

      5. Dans le gabarit Relationnel objet ou Entité-relation, faites glisser une forme Relation et déposez-la sur un espace vide de la page.

      6. Connectez l’extrémité supérieure à la table parente.

      7. Connectez l’autre extrémité à la table enfant.

        Si la deuxième table ne contient pas de colonne portant le même nom que la clé primaire, le modeleur l’ajoute à la deuxième table en tant que clé étrangère.

        Remarque : Si les lignes de relation disparaissent, sous l’onglet Base de données, accédez au groupe Gérer et cliquez sur Options d’affichage. Dans l’onglet Relations, sous Afficher, cochez la case Relations.

    2. Définissez la cardinalité de la relation :

      1. Double-cliquez sur la relation.

      2. Dans la fenêtre Propriétés de la base de données, sous Catégories, cliquez sur Divers.

      3. Sous Cardinalité, choisissez la cardinalité qui convient le mieux à la relation. Pour une relation un-à-plusieurs, choisissez Zéro ou plus ou Un ou plus. Pour une relation un-à-un, choisissez Zéro ou plus ou Exactement un.

  3. Pour apporter d’autres affinages à votre diagramme (création d’index, clauses de vérification, déclencheurs, etc.), vous pouvez effectuer les opérations suivantes :

    Créer des index

    Les index améliorent les performances, ou la vitesse, de votre base de données lorsque vous exécutez une requête.

    1. Ouvrez le diagramme de modèle de base de données.

    2. Double-cliquez sur la table à laquelle vous souhaitez ajouter un index puis, dans la fenêtre Propriétés de la base de données, accédez à la liste Catégories et cliquez sur Index.

    3. Cliquez sur Nouveau.

    4. Dans la boîte de dialogue Créer un index, attribuez un nom à l’index, puis cliquez sur OK.

    5. Dans la liste Type d’index, sélectionnez une option pour créer un index unique ou non.

    6. Dans la liste Colonnes disponibles, sélectionnez le nom de chacune des colonnes que vous souhaitez inclure dans cet index, puis cliquez sur Ajouter >.

    7. Dans la liste Colonnes indexées, cochez la case Crois. pour créer un index dans l’ordre croissant, ou décochez la case pour créer un index dans l’ordre décroissant.

      Le diagramme de modèle de base de données est mis à jour.

    Créer des vues

    Vous pouvez considérer une vue comme une requête enregistrée. Les vues sont particulièrement utiles lorsque vous devez accéder de manière récurrente aux mêmes informations à partir de plusieurs tables, ou si vous souhaitez permettre à des utilisateurs d’accéder aux données sans modifier les tables.

    À partir du gabarit Entité-relation ou Relationnel objet, faites glisser une forme Vue vers la page de dessin.

    Définir des propriétés étendues pour les tables et les vues

    En fonction de votre système de gestion de base de données (SGBD), vous pourrez peut-être définir des propriétés étendues pour les tables ou vues afin de déterminer où elles sont stockées.

    Double-cliquez sur la table ou vue dont vous souhaitez définir les propriétés étendues, puis dans la fenêtre Propriétés de la base de données, accédez à la liste Catégories et cliquez sur Étendu.

    Créer des clauses de vérification

    Utilisez des clauses de vérification pour vous assurer que les données entrées dans une colonne correspondent à une plage de valeurs spécifique. Par exemple, vous pouvez créer une clause de vérification exigeant que les données d’une colonne intitulée « Âge » soient supérieures à 65.

    1. Double-cliquez sur la table pour ouvrir la fenêtre Propriétés de la base de données.

    2. Sous Catégories, cliquez sur Colonnes, puis sélectionnez la colonne à laquelle vous souhaitez ajouter une clause de vérification.

    3. Cliquez sur Modifier.

    4. Sous l’onglet Vérifier de la boîte de dialogue Propriétés de la colonne, entrez les contraintes souhaitées.

      La clause de vérification est ajoutée à la fenêtre Code, sous Code local.

    Créer des procédures stockées et des fonctions définies par l’utilisateur

    Utilisez des procédures stockées et des fonctions définies par l’utilisateur pour créer des paquets de code que vous pourrez réutiliser pour répéter les mêmes actions. La différence majeure entre les deux est qu’une fonction définie par l’utilisateur renvoie une valeur, tandis que la procédure stockée exécute le code sans renvoyer de valeur.

    1. Sous l’onglet Base de données, accédez au groupe Afficher/Masquer, puis cochez la case Code pour ouvrir la fenêtre Code.

    2. Cliquez sur Code global, puis sur Nouveau.

    3. Sous l’onglet Propriétés de l’Éditeur de code, cliquez sur le type de code que vous souhaitez créer, puis entrez un nom pour le code.

    4. Sous l’onglet Corps, entrez le code, puis cliquez sur OK.

    Créer des déclencheurs

    Les déclencheurs exécutent le code SQL spécifié lorsqu’un événement particulier se produit dans la base de données.

    1. Double-cliquez sur la table pour ouvrir la fenêtre Propriétés de la base de données.

    2. Sous Catégories, cliquez sur Déclencheurs, puis sur Ajouter.

    3. Sous l’onglet Propriétés, entrez un nom pour le déclencheur.

    4. Sous l’onglet Corps, entrez le code, puis cliquez sur OK.

      Le déclencheur est ajouté à la fenêtre Code, sous Code local.

Cet article explique comment créer et utiliser un modèle de base de données. Pour un démarrage rapide, dans le menu Fichier, pointez sur Nouveau, puis sur Logiciel et base de données, et cliquez sur Diagramme de modèle de base de données.

Vous ne trouvez pas les fonctionnalités de modèle de base de données ?

Votre édition de Microsoft Office Visio n’inclut probablement pas les fonctionnalités que vous recherchez. Pour savoir quelle édition de Visio vous utilisez, cliquez sur À propos de Microsoft Office Visio dans le menu Aide. Le nom de l’édition apparaît sur la ligne de texte supérieure de la boîte de dialogue.

  • Microsoft Office Visio Standard n’inclut pas le modèle Diagramme de modèle de base de données.

  • Microsoft Office Visio Professionnel prend en charge les fonctionnalités de rétroconception du modèle Diagramme de modèle de base de données (à savoir l’utilisation d’une base de données existante pour créer un modèle dans Visio), mais pas l'ingénierie en amont (à savoir l’utilisation d’un modèle de base de données Visio pour générer du code SQL).

  • Vous trouverez la suite complète des fonctionnalités de modélisation de base de données, avec la rétroconception et l'ingénierie en amont, dans Visio pour Enterprise Architects. Visio pour Enterprise Architects est inclus dans l’abonnement MSDN Premium, qui est disponible avec Visual Studio Professional et les éditions basées sur les rôles de Visual Studio Team System.

  1. Pour entamer votre diagramme de modèle de base de données, effectuez l’une des opérations suivantes :

    Créer un diagramme de modèle de toutes pièces

    Si vous ne disposez d’aucune base de données que vous souhaitez utiliser comme point de départ, vous pouvez commencer avec un modèle de base de données vierge et ajouter vos propres tables et relations.

    1. Dans le menu Fichier, pointez sur Nouveau, puis sur Logiciel et base de données, et cliquez sur Diagramme de modèle de base de données.

    2. Dans le menu Base de données, pointez sur Options, puis cliquez sur Document.

    3. Dans la boîte de dialogue Options du document de base de données, sélectionnez le jeu de symboles que vous souhaitez utiliser ainsi que les autres options de tables et de relations, puis cliquez sur OK.

    Utiliser une base de données existante comme point de départ

    Si vous disposez d’une base de données que vous souhaitez modéliser afin de mieux la comprendre ou de l’utiliser comme de point de départ d’un nouveau modèle, vous pouvez utiliser l’Assistant Rétroconcevoir pour extraire le schéma ou la structure de la base de données et créer un nouveau modèle.

    Remarque : Avant de lancer l’Assistant :

    1. Si vous procédez à la rétroconception d’un classeur Microsoft Office Excel, avant de lancer l’Assistant, vous devez ouvrir le classeur et nommer le groupe (ou la plage) de cellules qui contient les en-têtes de colonne. Si vous souhaitez utiliser plusieurs feuilles de calcul, il vous suffit de nommer le groupe de cellules des colonnes dans chaque feuille de calcul. Ces plages sont traitées comme des tables dans l’Assistant. Pour savoir comment nommer une plage de cellules, reportez-vous à la rubrique Définir des plages ou références de cellules nommées dans l’aide de Microsoft Office Excel.

    2. Pour des résultats optimaux, définissez votre pilote par défaut sur la base de données cible que vous souhaitez rétroconcevoir avant d’exécuter l’Assistant Rétroconcevoir. Cette étape permet de veiller à ce que l’Assistant mappe correctement les types de données natifs et que tout le code extrait par l’Assistant s’affiche correctement dans la fenêtre Code.

    3. Dans le menu Fichier, pointez sur Nouveau, puis sur Logiciel et base de données, et cliquez sur Diagramme de modèle de base de données.

    4. Dans le menu Base de données, cliquez sur Rétroconcevoir.

    5. Sur le premier écran de l’Assistant Rétroconcevoir, effectuez les opérations suivantes :

      1. Sélectionnez le pilote de base de données Microsoft Office Visio de votre système de gestion de base de données (SGBD). Si vous n’avez pas encore associé le pilote de base de données Visio à une source de données ODBC particulière, cliquez sur Configuration.

        Remarque : Si vous procédez à la rétroconception d’une feuille de calcul Excel, sélectionnez le pilote ODBC générique.

      2. Sélectionnez la source de données de la base de données que vous mettez à jour. Si vous n’avez pas encore créé de source de données pour la base de données existante, faites-le en cliquant sur Nouveau.

        Lorsque vous créez une nouvelle source, son nom est ajouté à la liste Sources de données.

      3. Lorsque les paramètres vous conviennent, cliquez sur Suivant.

    6. Suivez les instructions des boîtes de dialogue spécifiques au pilote.

      Par exemple, dans la boîte de dialogue Connecter la source de données, entrez un nom d’utilisateur et un mot de passe, puis cliquez sur OK. Si votre source de données n’est pas protégée par un mot de passe, cliquez simplement sur OK.

      Remarque : Si vous utilisez le pilote ODBC générique, vous pouvez recevoir un message d’erreur indiquant que les informations de rétroconception sont incomplètes. Dans la plupart des cas, ce n’est pas un problème. Cliquez simplement sur OK et suivez l’Assistant.

    7. Cochez les cases correspondant au type d’informations que vous souhaitez extraire, puis cliquez sur Suivant.

      Remarque : Il se peut que des éléments soient indisponibles (grisés) car certains systèmes de gestion de base de données ne prennent pas en charge l’intégralité des éléments extraits par l’Assistant.

    8. Cochez les cases correspondant aux tables (et vues, le cas échéant) que vous souhaitez extraire, ou cliquez sur Sélectionner tout pour toutes les extraire, puis cliquez sur Suivant.

      Remarque : Si vous procédez à la rétroconception d’une feuille de calcul Excel et que vous ne voyez rien dans cette liste, il peut être nécessaire de nommer la plage de cellules qui contient les en-têtes de colonne de votre feuille de calcul.

    9. Si vous avez coché la case Procédures stockées à l’étape 5, sélectionnez les procédures que vous souhaitez extraire, ou cliquez sur Sélectionner tout pour toutes les extraire, puis cliquez sur Suivant.

    10. Indiquez si vous souhaitez que les éléments rétroconçus soient automatiquement ajoutés à la page active.

      Remarque : Vous pouvez choisir de laisser l’Assistant créer automatiquement le dessin, en plus de la liste des éléments rétroconçus, dans la fenêtre Tables et vues. Si vous décidez de ne pas laisser l’Assistant créer automatiquement le dessin, vous pouvez faire glisser les éléments de la fenêtre Tables et vues vers votre page de dessin pour assembler manuellement le modèle de base de données.

    11. Passez en revue vos sélections pour vérifier que les informations à extraire sont correctes, puis cliquez sur Terminer.

      L’Assistant extrait les informations sélectionnées et affiche les commentaires relatifs au processus d’extraction dans la fenêtre Sortie.

    Importer et affiner un modèle existant

    Si vous disposez d’un modèle VisioModeler ou PLATINUM ERwin existant, vous pourrez peut-être l’importer pour créer un diagramme de modèle de base de données Visio. Cette fonctionnalité est réservée aux fichiers des modèles de dictionnaire VisioModeler 2.0 ou version ultérieure (.imd) et aux fichiers PLATINUM ERwin 2.6, 3.0 et 3.52 (.erx).

    1. Dans le menu Fichier, pointez sur Nouveau, puis sur Logiciel et base de données, et cliquez sur Diagramme de modèle de base de données.

    2. Dans le menu Base de données, pointez sur Importer, puis cliquez sur Importer <type de modèle>.

    3. Entrez le chemin et le nom de fichier du modèle que vous souhaitez importer, ou cliquez sur le bouton Parcourir pour rechercher le modèle, puis cliquez sur Ouvrir.

    4. Dans la boîte de dialogue Importer, cliquez sur OK.

      Visio importe le fichier et affiche la progression de l’importation dans la fenêtre Sortie. Les tables importées sont affichées dans la fenêtre Tables et vues.

    5. Dans la fenêtre Tables et vues, sélectionnez les tables que vous souhaitez modéliser, puis faites-les glisser vers la page de dessin.

  2. Une fois le diagramme de modèle de base de données créé, le travail d’affinage du diagramme commence. Vous pouvez ajouter et personnaliser des tables et des vues, créer des relations, et personnaliser des colonnes et des types de données.

    Tables

    Utilisez la forme Entité pour créer une table dans votre diagramme.

    1. À partir du gabarit Entité-relation ou Relationnel objet, faites glisser une forme Entité vers le dessin.

    2. Double-cliquez sur la forme pour ouvrir la fenêtre Propriétés de la base de données.

    3. Sous Catégories, cliquez sur Définition et entrez un nom pour la table.

    4. Sous Catégories, cliquez sur Colonnes, entrez un nom, puis sélectionnez un type de données.

    5. Cochez la case Null interdit pour les colonnes qui ne peuvent pas comporter de valeurs nulles.

    6. Cochez la case PK (clé primaire) pour les colonnes qui identifient de manière unique chaque ligne de la table de base de données.

    7. Sous Catégories, cliquez sur Index, Déclencheurs, Coche ou Étendu pour créer ces éléments facultatifs.

    Colonnes

    Utilisez la fenêtre Propriétés de la base de données pour ajouter ou modifier les propriétés des colonnes, y compris les types de données et les clés primaires.

    1. Double-cliquez sur la table dans votre diagramme.

    2. Dans la fenêtre Propriétés de la base de données, sous Catégories, cliquez sur Colonnes.

    3. Cliquez dans la première cellule Nom physique vide, puis entrez un nom.

    4. Pour modifier le type de données d’une colonne, cliquez sur le champ Type de données de la colonne, puis sélectionnez un type de données dans la liste ou entrez-le dans la liste. Par exemple, vous pouvez entrer décimal(8,2) ou car(30).

    5. Pour éviter les valeurs nulles, cochez la case Null interdit.

    6. Pour spécifier que la colonne est une clé primaire, cochez la case PK.

    7. Pour afficher d’autres propriétés de colonne en plus de celles qui s’affichent lorsque vous cliquez sur la catégorie Colonnes, sélectionnez la colonne, puis cliquez sur Modifier.

    Relations

    Les relations utilisent des clés primaires et étrangères pour permettre aux bases de données de faire correspondre une ligne située dans une table avec une ligne située dans une table liée. Vous pouvez afficher ces relations dans votre diagramme. En outre, vous pouvez définir leur cardinalité (par exemple, un-à-plusieurs) et utiliser la notation Crow's Foot, relationnelle ou IDEF1X pour afficher la cardinalité. Vous ne pouvez afficher des relations plusieurs-à-plusieurs avec aucune de ces notations dans le modèle Diagramme de modèle de base de données.

    1. Créer une relation entre des tables :

      1. Assurez-vous que les deux tables sont visibles dans le diagramme. Si vous avez procédé à la rétroconception du modèle à partir d’une base de données existante, vous devrez peut-être faire glisser une table, voire les deux, de la fenêtre Tables et vues vers la page de dessin.

      2. Double-cliquez sur la table que vous souhaitez placer côté clé primaire de la relation.

      3. Dans la fenêtre Propriétés de la base de données, sous Catégories, cliquez sur Colonnes.

      4. Dans la grille, cliquez sur la colonne que vous souhaitez utiliser pour identifier de manière unique chaque ligne de la table, puis cochez la case PK pour la définir en tant que clé primaire.

      5. Dans le gabarit Relationnel objet ou Entité-relation, faites glisser une forme Relation et déposez-la sur un espace vide de la page.

      6. Connectez l’extrémité supérieure à la table parente.

      7. Connectez l’autre extrémité à la table enfant.

        Si la deuxième table ne contient pas de colonne portant le même nom que la clé primaire, le modeleur l’ajoute à la deuxième table en tant que clé étrangère.

        Remarque : Si les lignes de relation disparaissent sous le menu Base de données, pointez sur Options, puis cliquez sur Document. Dans l’onglet Relations, sous Afficher, cochez la case Relations.

    2. Définissez la cardinalité de la relation :

      1. Double-cliquez sur la relation.

      2. Dans la fenêtre Propriétés de la base de données, sous Catégories, cliquez sur Divers.

      3. Sous Cardinalité, choisissez la cardinalité qui convient le mieux à la relation. Pour une relation un-à-plusieurs, choisissez Zéro ou plus ou Un ou plus. Pour une relation un-à-un, choisissez Zéro ou plus ou Exactement un.

  3. Pour apporter d’autres affinages à votre diagramme (création d’index, clauses de vérification, déclencheurs, etc.), vous pouvez effectuer les opérations suivantes :

    Créer des index

    Les index améliorent les performances, ou la vitesse, de votre base de données lorsque vous exécutez une requête.

    1. Ouvrez le diagramme de modèle de base de données.

    2. Double-cliquez sur la table à laquelle vous souhaitez ajouter un index puis, dans la fenêtre Propriétés de la base de données, accédez à la liste Catégories et cliquez sur Index.

    3. Cliquez sur Nouveau.

    4. Dans la boîte de dialogue Créer un index, attribuez un nom à l’index, puis cliquez sur OK.

    5. Dans la liste Type d’index, sélectionnez une option pour créer un index unique ou non.

    6. Dans la liste Colonnes disponibles, sélectionnez le nom de chacune des colonnes que vous souhaitez inclure dans cet index, puis cliquez sur Ajouter >.

    7. Dans la liste Colonnes indexées, cochez la case Crois. pour créer un index dans l’ordre croissant, ou décochez la case pour créer un index dans l’ordre décroissant.

      Le diagramme de modèle de base de données est mis à jour.

    Créer des vues

    Vous pouvez considérer une vue comme une requête enregistrée. Les vues sont particulièrement utiles lorsque vous devez accéder de manière récurrente aux mêmes informations à partir de plusieurs tables, ou si vous souhaitez permettre à des utilisateurs d’accéder aux données sans modifier les tables.

    À partir du gabarit Entité-relation ou Relationnel objet, faites glisser une forme Vue vers la page de dessin.

    Définir des propriétés étendues pour les tables et les vues

    En fonction de votre système de gestion de base de données (SGBD), vous pourrez peut-être définir des propriétés étendues pour les tables ou vues afin de déterminer où elles sont stockées.

    Double-cliquez sur la table ou vue dont vous souhaitez définir les propriétés étendues, puis dans la fenêtre Propriétés de la base de données, accédez à la liste Catégories et cliquez sur Étendu.

    Créer des clauses de vérification

    Utilisez des clauses de vérification pour vous assurer que les données entrées dans une colonne correspondent à une plage de valeurs spécifique. Par exemple, vous pouvez créer une clause de vérification exigeant que les données d’une colonne intitulée « Âge » soient supérieures à 65.

    1. Double-cliquez sur la table pour ouvrir la fenêtre Propriétés de la base de données.

    2. Sous Catégories, cliquez sur Colonnes, puis sélectionnez la colonne à laquelle vous souhaitez ajouter une clause de vérification.

    3. Cliquez sur Modifier.

    4. Sous l’onglet Vérifier de la boîte de dialogue Propriétés de la colonne, entrez les contraintes souhaitées. Pour plus d’informations sur vos choix, reportez-vous ç Boîte de dialogue Propriétés des colonnes et des champs (onglet Vérification).

      La clause de vérification est ajoutée à la fenêtre Code, sous Code local.

    Créer des procédures stockées et des fonctions définies par l’utilisateur

    Utilisez des procédures stockées et des fonctions définies par l’utilisateur pour créer des paquets de code que vous pourrez réutiliser pour répéter les mêmes actions. La différence majeure entre les deux est qu’une fonction définie par l’utilisateur renvoie une valeur, tandis que la procédure stockée exécute le code sans renvoyer de valeur.

    1. Dans le menu Base de données, pointez sur Vue, puis cliquez sur Code pour ouvrir la fenêtre Code.

    2. Cliquez sur Code global, puis sur Nouveau.

    3. Sous l’onglet Propriétés de l’Éditeur de code, cliquez sur le type de code que vous souhaitez créer, puis entrez un nom pour le code.

    4. Sous l’onglet Corps, entrez le code, puis cliquez sur OK.

    Créer des déclencheurs

    Les déclencheurs exécutent le code SQL spécifié lorsqu’un événement particulier se produit dans la base de données.

    1. Double-cliquez sur la table pour ouvrir la fenêtre Propriétés de la base de données.

    2. Sous Catégories, cliquez sur Déclencheurs, puis sur Ajouter.

    3. Sous l’onglet Propriétés, entrez un nom pour le déclencheur.

    4. Sous l’onglet Corps, entrez le code, puis cliquez sur OK.

      Le déclencheur est ajouté à la fenêtre Code, sous Code local.

Voir aussi

Définir une relation dans un diagramme de modèle de base de données

Ajouter des tables et des colonnes à des diagrammes de modèle de base de données

Définir et modifier des types de données dans les diagrammes de modèle de base de données

Rétroconcevoir une base de données existante

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×