Créer un diagramme croisé dynamique Visio 2007 à partir des données de feuille de calcul Excel 2007

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Couverture du livre Advanced Microsoft Office Documents 2007 Edition Inside Out

Microsoft® avancées Office Documents 2007 Edition intérieur/extérieur
Par Stephanie Krieger

Stephanie Krieger est un MVP de Microsoft Office System, ainsi que les livres Advanced Microsoft Office Documents 2007 Edition Inside Out et Microsoft Office Document Designer. En tant que document professionnel consultant, elle a permis de nombreuses multinationales développer des solutions d'entreprise pour Microsoft Office et formation professionnels de nombreux à créer des documents à comprendre comment les programmes Office » réfléchissez. » Stephanie écrit régulièrement pour plusieurs pages Web Microsoft et anime souvent des présentations en ligne Microsoft Office.

Pour en savoir plus sur les autres livres sur Microsoft Office system 2007, visitez le site Microsoft Press.

Dans cet article

Générer un diagramme croisé dynamique

Mise en forme et la gestion d'un diagramme croisé dynamique

Comment puis-je modifier l'info-bulle d'une forme appliquée dans un diagramme croisé dynamique ?

Il s'agit d'un de mes fonctionnalités préférées 10 premiers dans la version d'Office 2007. Un diagramme croisé dynamique est simplement qu'il ressemble — un diagramme qui affiche uniquement les données comme un tableau croisé dynamique Excel ou graphique croisé dynamique. Un diagramme croisé dynamique est un diagramme hiérarchique (similaire à la structure d'un organigramme hiérarchique) qui reste connecté aux données, afin que vous pouvez examiner les données visuellement dans des configurations différentes autant que permettent de vos données.

Générer un diagramme croisé dynamique

Pour créer votre diagramme croisé dynamique, commencer par le programme d'installation de données dans Excel en ce qui concerne un tableau croisé dynamique (données dans des colonnes à une seule ligne d'en-têtes) et les valeurs de toutes les cellules, puis effectuez l'une des opérations suivantes.

  • Si vos données Excel sont mises en forme un tableau, sous l'onglet Outils de tableau création, cliquez sur les options d'exportation, puis sur Exporter le tableau vers un diagramme croisé dynamique Visio.

  • Si vos données Excel sont mises en forme un tableau ou une plage, vous pouvez également créer votre diagramme croisé dynamique à partir de Visio. Pour ce faire, dans le menu fichier, pointez sur Nouveau, Professionnel, puis cliquez sur diagramme croisé dynamique. Suivez l'Assistant pour sélectionner le fichier Excel et, si nécessaire, sélectionnez la feuille spécifique ou la plage dans ce fichier. Ensuite, simplement continuez à cliquer sur suivant jusqu'à ce que l'option Terminer apparaisse. Cliquez sur Terminer pour créer votre tableau.

    Lorsque vous créez le diagramme croisé dynamique en utilisant l'Assistant, la source de données peut provenir dans un classeur Excel, une base de données Access, une liste de Windows SharePoint Services, une base de données SQL Server ou un autre OLEDB (objet incorporé base de données liée) ou ODBC (Open Database Connectivity) source de données compatibles.

    Important : Si votre fichier Excel contient les graphiques dans leurs propres feuilles, utilisez la méthode fournie ici pour générer le diagramme croisé dynamique à partir de l'onglet Outils de tableau création dans Excel. Ou bien, ouvrez le fichier Excel avant de démarrer l'Assistant Diagramme croisé dynamique Visio. L'Assistant ne peut pas accéder à des fichiers Excel contenant des feuilles, à moins que le fichier se trouve actuellement ouvrent de graphique.

Avec une des méthodes précédentes, la page de diagramme croisé dynamique est générée avec une forme unique pour désigner le niveau supérieur du diagramme et une forme identifiant les données sources, dernière mise à jour et des filtres en place, comme le montre l'image suivante.

Formes sur la page Diagramme croisé dynamique dans Visio 2007

Notez que tous les champs disponibles pour le diagramme croisé dynamique sont fournis dans le volet de diagramme croisé dynamique, divisé en catégories (l'équivalent des champs de ligne ou une colonne dans un tableau croisé dynamique) et les totaux (l'équivalent des champs de valeur dans un tableau croisé dynamique).

Haut de la page

Mise en forme et la gestion d'un diagramme croisé dynamique

Cliquez pour appliquer une catégorie dans le volet de diagramme croisé dynamique à la page et Visio générera les formes applicables. Également dans le volet, sélectionnez les totaux que vous voulez voir apparaître dans chaque forme. Dans l'exemple suivant, les coûts de formation par personne est indiquée par secteur d'activité.

Diagramme croisé dynamique affichant les coûts de formation, répartis par secteur d’activité

Voici quelques astuces pour vous aider à créer le diagramme croisé dynamique que vous avez besoin.

  • Le Total dans l'exemple de diagramme croisé dynamique précédent est répertorié en tant que coût par personne, car il s'agit du nom de l'en-tête de colonne dans les données Excel. Mais, parce que vous avez réellement affiché coût total formation pour le service dans ce cas, vous souhaiterez peut-être modifier le nom du champ. Pour modifier le nom d'une catégorie ou d'un champ Total tel qu'il apparaîtra dans le diagramme, cliquez sur la flèche qui apparaît lorsque vous pointez sur le champ dans le volet de diagramme croisé dynamique, puis cliquez sur Configurer la colonne. Modifiez le nom selon vos besoins, cliquez sur OK. Le nom du champ change automatiquement dans toute la table.

  • Pour sortir davantage les catégories, sélectionnez les formes qui représentent les catégories que vous voulez rompre, puis cliquez sur la catégorie pour laquelle vous voulez voir les détails. Par exemple, pour afficher le coût par la personne dans le service de développement d'entreprise, sélectionnez la forme Du développement des activités qui contient le total, puis sur nom dans le volet de diagramme croisé dynamique. Le résultat ressemble à ceci.

    Diagramme croisé dynamique affichant les coûts de formation, répartis parmi les employés du développement des activités

    Étant donné que vous pouvez afficher les détails des formes individuelles, vous devez sélectionner toutes les formes dans une catégorie lorsque vous souhaitez ajouter une nouvelle sous-catégorie pour toutes les. Veillez à sélectionner la partie de la forme qui contient le total et pas l'en-tête de la forme. Pour sélectionner rapidement toutes les formes dans la catégorie, pointez sur le nom de catégorie dans le volet de diagramme croisé dynamique, cliquez sur la flèche déroulante qui apparaît, puis sur Sélectionner tout.

  • Vous pouvez mettre en forme et redimensionner des formes comme vous le feriez dans un diagramme Visio, les formes. Pour redimensionner plusieurs formes en même temps, sélectionnez toutes les formes à être redimensionnées et puis faites glisser les poignées de la sélection pour la redimensionner en tant que groupe.

  • Pour modifier le format numérique de totaux, dans le menu diagramme croisé dynamique, cliquez sur Modifier le graphique de données. Ou, dans le volet de diagramme croisé dynamique, cliquez sur Autres Actions, puis sur Modifier le graphique de données. Ensuite, procédez comme suit :

    1. Sélectionnez le graphique de données qui contient le nom du champ pour lequel vous souhaitez modifier la mise en forme, puis cliquez sur Modifier l'élément.

    2. Dans le champ Format de la valeur, cliquez sur les points de suspension pour ouvrir une boîte de dialogue Format des données, vous pouvez indiquer le numéro de mettre en forme que vous avez besoin.

  • Les formes dans un diagramme croisé dynamique qui contiennent les totaux pour chaque forme dans une catégorie sont appelés nœuds de tableau croisé dynamique. Vous pouvez appliquer des formes plus intéressants à des nœuds de tableau croisé dynamique à l'aide de l'option Appliquer la forme dans le menu de diagramme croisé dynamique ou d'un volet. Commencez par sélectionner les nœuds de tableau croisé dynamique à laquelle vous souhaitez appliquer une forme, puis dans la boîte de dialogue Appliquer des formes, cliquez sur une forme, puis sur OK. Formes des gabarits départements et des Objets de flux de travail sont disponibles automatiquement par le biais de cette boîte de dialogue.

    Pour apporter d'autres formes disponibles à votre diagramme croisé dynamique, dans le menu fichier, pointez sur formes, puis sélectionnez les gabarits qui que vous intéressent. Une fois que vous ouvrez un nouveau gabarit, qu'elle est disponible dans la liste déroulante gabarit dans la boîte de dialogue Appliquer la forme

  • Pour accéder aux options de filtrage pour n'importe quel champ dans le diagramme, cliquez sur la flèche qui apparaît lorsque vous pointez sur un champ dans le volet de diagramme croisé dynamique, puis cliquez sur Configurer la colonne.

  • Dans le menu diagramme croisé dynamique, vous pouvez gérer la mise en page du diagramme, trier les formes sélectionnées dans le diagramme, fusionner des formes sélectionnées dans une forme unique (Cela peut être un excellent moyen de gagner de l'espace lorsque vous voulez séparer plusieurs catégories dans un seul diagramme) et définir une série d'options pour votre diagramme croisé dynamique.

    Utiliser la boîte de dialogue Options de diagramme croisé dynamique, dans le menu diagramme croisé dynamique, pour modifier le nom de la table, choisissez Afficher ou masquer les éléments d'un diagramme et réviser votre source de données, comme indiqué dans l'image qui suit.

    Boîte de dialogue Options du diagramme croisé dynamique dans Visio 2007

Haut de la page

Comment puis-je modifier l'info-bulle d'une forme appliquée dans un diagramme croisé dynamique ?

Si vous appliquez une forme à un nœud de tableau croisé dynamique, comme indiqué dans la liste précédente, vous souhaiterez peut-être modifier l'info-bulle qui s'affiche lorsque vous pointez sur la forme. Toutefois, si vous sélectionnez la forme, puis cliquez sur le menu Insertion digne trouver l'option Modifier les info-bulle de forme, vous peut s'afficher à la place l'option Info-bulle de la forme. Cette dernière option indique qu'aucun info-bulle n'existe actuellement pour la sélection.

La raison pour laquelle que vous ne voyez pas l'option Modifier est que votre sélection est en réalité un groupe de formes. La forme appliquée est automatiquement groupée avec le nœud de tableau croisé dynamique. Pour modifier l'info-bulle existant pour la forme appliquée, cliquez une fois sur la forme appliquée (cela sélectionne le groupe), puis sur une deuxième fois (c'est inférieure à un double-clic) pour sélectionner simplement la forme appliquée au sein du groupe. Lorsque la forme est sélectionnée, vous verrez un x à l'intérieur de chacun des poignées de la forme. Une fois que simplement la forme est sélectionnée, cliquez sur le menu Insertion et l'option Modifier les info-bulle de forme seront disponible.

Grâce à la prise en charge technicien Jagadeesh Parameswaran, un membre de l'équipe de test Visio 2007, pour cela intrépides et quelques autres conseils dans ce chapitre.

Haut de la page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×